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Introduction

The basic component of MicroStation's drawing structure is the drawing element. Elements
are geometric shapes that can be assigned certain characteristics that distinquish it from
other elements in the design file. Some characteristics are visual and others are less
readily apparent.

Drawing Elements

Elements are single components of a drawing (i.e., line, arc, circle, etc.) and are the
smallest item in a drawing organization that can be acted upon by the system (i.e. delete,
scale, move, etc.). Some CAD systems refer to these as primitives. The elements include:

ARC
A continuous portion of a circle.

CIRCLE
A closed curve an equal distance from a center.

ELLIPSE
A closed curve defined by a center point and the radii of two axes. The
radius of the first axis is called the primary and the other is referred to as

the secondary.

LINE

A line is a element defined by two endpoints.
Although a “string” of lines can be drawn, each
segment is an individual element.

+ POINT
An element that represents a single location in two- or three-dimensional

space.

POLYGON (also called BLOCK and SHAPE) and
COMPLEXSHAPES

A closed continuous series of interconnected lines.
Although comprised of several segments, a polygon
is a single element.

LINE STRINGS and COMPLEX CHAINS
Line strings and complex chains are an open continuous series of intercon-

nected segments defined by more than two vertices or endpoints. Although
it resembles a series of elements, the segments of a line string or complex
chains represent a single element.

SPLINE

MicroStation offers several B-spline curve options.
Although the actual methods are different, this
element is a smooth curve defined by a set of

control points.
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Complex Chains and Shapes

Although a single line, arc, and point is rather easily identified, certain other elements are
more difficult to assess. MicroStation uses line strings, complex chains, shapes, and
complex shapes to define elements that appear to made up of multiple primitives, but are
actually a single element or act like a single element. For example, a rectangular shape can
be created in several different ways. One method is to draw four lines bounding the rectan-
gular shape using the PLACE LINE tool. In this case, the rectangle is comprised of four line
elements. Another approach is to draw the rectangle as a shape using the PLACE BLOCK
tool. With a shape, the four sides of the rectangle are comprised of a single element rather
than the four elements that result from using lines. Another approach is to draw four lines
to form a rectangle and then combine those lines into a complex shape. A complex shape,
much like a shape, treats the four lines as if they are a single element. Although they are
treated as a single element, MicroStation refers to each component as a “segment.” A
rectangular complex shape would be a single element comprised of four line segments.

Shapes and complex shapes define elements that are closed. A shape is a single element. A
complex shape is a single element comprised of multiple segments. Line strings and
complex chains refer to geometry in which the segments form a single element, but are not
closed. A line string forms a single element.

gElement Information
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Figure 3-1. An illustration of string, complex chain, shape, and complex shape.

How objects are created, such as the rectangle, is related to how they later can be manipu-
lated. For example, the rectangular shape created as four line elements can have any side
of the rectangle selectively deleted. The rectangle, drawn as a single element shape or one
that has been converted to a complex shape, cannot be partially deleted without first
"dropping" it from a shape or complex shape to its individual elements. Remember, an
element is the smallest item that can be acted upon by the system.

MicroStation does provide tools for taking individual elements and combining them into
complex chains and shapes. They also provide tools for taking complex chains and shapes
and making each segment an individual element.
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Dropelement Createcomplexchain Create complexshape _Createregion
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Figure 3-2. Groups tool box.

The DROP ELEMENT tool in the main tool frame is used to “break” elements into simpler
components. The CREATE COMPLEX CHAINS tool is used to combine contiguous elements
into a single, non-closed element. The CREATE COMPLEX SHAPE tool combines contiguous
elements that form a closed shape into a single-element complex shape.

1. Use File > Open to load the file complex.dgn (downloaded from web site).

2. After the file is loaded, select the FIT VIEW | gil| tool from the view border to make

sure the entire drawing is displayed. Cancel the command by clicking the right mouse
button. Note the tool remains active until you click cancel (right mouse button). The
design file should appear similar to the following illustration.
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Figure 3-3. Complex.dgn design file.

The design file contains elements, complex chains, and complex shapes.

3. Use the ELEMENT SELECTION | k | tool and pick each numbered element to

determine which are segments and which are independent elements. Each selected
entity is highlighted and the status bar indicates the selection.

4. Next, select the Element > Information menu option and pick item 7 and then item 14.
Note the information that is displayed in the GENERAL tab of the displayed dialog. You

can also select the ELEMENT INFORMATION tool from the primary toolbar.
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Creating Chains and Shapes
Select the CREATE COMPLEX CHAIN tool from the MAIN toolbar.

?ﬂ\al-ﬂl sixio] I8

Create complex chain tool
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Figure 3-4. Create complex chain tool on the groups tool box.

If SINGLE CLICK in the TOOLS section of Workspace > Preferences is set
to single shot, the tool is deselected when the command is completed. If
SINGLE CLICK is set to locked, the tool remains active until another tool has
been selected. If set to single shot, the tool can still be locked by double
clicking rather than single clicking the tool.

A tool settings box is displayed.

#& Create Complex Chain  [H[E
bethod: Manual v |
b & e | L

[~ Simplify geometry

Figure 3-5. Create complex chain tool settings box.
5. Set the METHOD in the create complex tool settings box to Manual.
Create Complex Chain > ldentify Element

Data point (click left mouse button) on line segments 1, 2, and 3. Each element is

highlighted when selected. If you select the wrong element, press RESET (right mouse
button).

Create Complex Chain > Accept/Reject (select nextinput)

MicroStation needs to know when you are done selecting. To continue to select use the
DATA POINT button (left mouse button). To end the selection, click in an area of the
window where there are no elements to accept the current selection set. You would
click the RESET button (right mouse button) to reset the command.
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6. After picking element 3, click a data point away from any element. Next, click a RESET
to reset the command.

After completing the operation, this should result in a complex chain. You can use the
Element > Information menu option to verify by selecting segment 1. The information
display should show a complex chain.

7. Select the CREATE COMPLEX CHAIN tool again from the MAIN toolbar.

Etreate Complex Chain [H|El

tethod: Automatic ¥

Max Gap: | 0.0010

¥ Simplify geometmy

J

Figure 3-6. Using the simplify geometry option with create complex chain tool.

This time, change the METHOD to Automatic and check Simplify geometry to enable
the option.

Create Complex Chain > ldentify Element

Click (left mouse button) on line segment 4. Click any point and MicroStation
automatically selects elements 5 and 6 since they form a coincident chain to line 4.

Create Complex Chain > Accept/Reject (select nextinput)

After the three elements are selected, click a DATA POINT away from an element or
RESET to finish the selection and complete the complex chain.

With the Simplify geometry option enabled, the resulting geometry is a line string rather
than a complex chain. Again, you can use the Element > Information menu option to
check by selecting segment 4. This time, the information display should show a line string.

8. Select the CREATE COMPLEX SHAPE tool from the MAIN toolbar. Set the METHOD to
Manual and disable the Simplify geometry option.

Create Complex Shape > Identify Element
Click (left mouse button) on line segments 8, 9, 10, and 11.
Create Complex Shape >Accept/Reject (select nextinput)

Click a DATA POINT away from any element and MicroStation creates a complex shape
from the four line elements.

After completing the operation, you can use the Element > Information menu option to
check by selecting segment 8. The information display should show a complex shape.

9. Repeat the complex shape command setting the METHOD to Automatic and enabling
the Simplify geometry option. Select line 12 and then click a data point away from any
element. This should automatically create a shape from line segments 12, 13, 14, and
15. You can check the results using the Element > Information menu option.
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Drop Elements
10. Select the DROP ELEMENT tool from the MAIN toolbar.

Groups _______________Fi
2o o & EHo
N

Drop element tool

Figure 3-7. Breaking element into components.

A tool settings box is displayed.
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[ Dimensions
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Figure 3-8. Drop element settings box.

The options on the settings box determines which items are broken into their component

parts.

Item
Complex
Dimensions

Line Strings
Shapes

Multi-lines

Shared Cells

Solids (3D)

Text

If enabled

Cell, complex chain, complex shape, text node, surface, and solid are
dropped to their component parts.

Breaks dimensions into lines, line strings, ellipses, arcs, and text.

Breaks line strings and shapes into individual line elements.

Breaks multi-line elements into line strings, lines, and arcs.

Shared cells are dropped to their components if set to geometry.
Shared cells are dropped to unshared (normal) cells if set to normal cells.

Solids are dropped to either wireframe or surfaces.

Text characters are converted to the line, line string, arc, ellipse, and
shape elements used to create the character.

11. Check Line Strings/Shapes and then pick element 7. This drops the element from a line
string to 3 line elements. Repeat the command and select element 16. This converts
the shape to 4 line elements.
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Working with Regions

Another useful tool is the CREATE REGION ﬂ tool. This tool allows you to manipulate
two intersecting complex shapes. There are four options available.

Option Action
Difference Subtract one complex shape or shape from another.
Union Combine two complex shapes or shapes into a single complex

shape comprised of the total area of both.

Intersection  Combine two complex shapes or shapes into a single complex
shape comprised of only the area common to both.

Flood A variation on intersection that creates a single complex shape
from elements that bound the area indicated.

@O« C

Originals Difference Union Intersection
Figure 3-9. Create region options.
12. Select the Difference method.
Create Region From Element Difference > Identify element
Select element 17.

Create Region From Element Difference > Accept/Reject (select next
input)

Select element 18. Click a data point away from any element and MicroStation
subtracts element 18 from element 17. You may need to select the UPDATE VIEW tool
in the border tools if the shape is not completely clear.

13. Choose the Union and Intersection methods and apply one to elements 19 and 20, and
the other option to elements 21 and 22. The procedure is the same as was done for the
Difference method.

Linear Elements
There are several tools for creating lines of varying appearance and use. These tools can be
found on the LINEAR ELEMENTS toolbar.

Linear Elements
Sl lAlMIn] <lH]
\

SmartLine Line Multi-line
Tool Tool Tool

Figure 3-10. Line tools in the linear elements toolbar.
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The PLACE LINE ,,-""r tool is used to place individual line elements. If the tool is in the

locked mode, it places several contiguous lines with each segment being a separate line
element. The line tool settings box provides options to constrain the line length and angle
in which the line is placed.

£ Place Line M= B

W ‘Length:; 2.0000
¥ fngle: 45*

Figure 3-11. Place line dialog with length and angle constrained.

In the above example, the line would be 2 units in length and positioned at a 45 degree
angle from the data point signifying the start of the line.

Line Style

MicroStation allows you to draw in one of several standard line styles or by defining a
custom line style. The standard line styles and several predefined custom line styles are
selected from the ACTIVE LINE STYLE list box in the ATTRIBUTES toolbar.

A ributes B

. Standard line styles
———— 1 /

Custom line styles

Figure 3-12. Selecting the active line style from the attributes toolbar.

There are eight standard line styles numbered 0-7. The active line style is applied to any
elements added to the file. It is also applied to any elements that are selected with the
active line style is changed.
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The following illustrates some of the custom line styles provided with MicroStation.

Curvy Curtain
Feltip Tree Line Batten

Figure 3-13. Sample custom line styles available with MicroStation.

Line styles are stored as a line style definition comprised of stroke patterns and point
symbols that can be customized. Line styles can also contain line style modifiers which
allow you to adjust the placement of the line style without creating a new line style defini-
tion. The modifiers allow you to change the width of the start and end of a line, shift the
pattern relative to the start point, and scale the line style pattern by a factor.

A custom line style is selected from the ACTIVE LINE STYLE list box in the ATTRIBUTES
toolbar or by selecting the Element > Line Style > Custom option.
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Figure 3-14. Selecting a custom line style from attributes toolbar and line style dialog.

The Line Style list box remembers the four most used line styles and lists those styles
above the custom line styles.

The Element > Line Style > Custom option displays a dialog with the line style modifiers.
You can change the modifiers and the results are previewed in the dialog box when you
click on the line style preview to activate the change.
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Figure 3-15. Activating modifiers for a custom line style.

In the above example, the Center custom line style pattern would be scaled by a factor of 2.
If you had an element selected when the change was made, it would be applied to the
element. Note that the change may not be visible on the displayed element at the current
view scale. Once you have explored several line styles and modifiers, return the active
setting to the standard solid line style (style number 0).

Line styles are stored in a library resource file. You can view the resource file or create a
new resource file by selecting the Element > Line Style > Edit option. You then select File
> Open. The default line style library is Istyle.rsc.

Even though the style may be elaborate, the line style is applied to a line or line string and
is treated by the system as a line element or complex chain.

Note that the standard line styles (those number 0-7) are hardware dependent;
therefore, their appearance is dependent on the output device. In other words,
what you see on the display may be significantly different than the printed
output. Custom line styles on the other hand operate in a more WYSIWYG
(what-you-see-is-what-you-get) mode.

SmartLine

e tool is used in a manner similar to , but eac
The PLACE SMARTLINE '{1 li di imil PLACE LINE, b h

segment is either an independent element or it is part of a complex chain (open) or com-
plex shape (closed). In addition to placing lines, SMARTLINE also allows you to place arcs.
In fact, you can switch between arcs and lines as you create the elements, the complex
chain, or the complex shape.

# Place SmartLine E3

{Segment T_I,Ipe:é Lines bl

Wertex Type:  Shar bl
R ounding Badius: I 1.0000

¥ Jain Elements :I

Figure 3-16. SmartLine tool.
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There are several options available when using the SmartLine tool:

Line segments Line segments Line segments

Sharp vertex Rounded vertex Chamfered vertex
Arc segments Arc segments
Sharp vertex Rounded vertex

Figure 3-17. SmartLine tool options.

The following describes the options:

Segment Type Lines Used to draw line segments.
Arcs Used to draw arc segments.
Vector Type Sharp A single vertex point is formed between adjacent
segments.
Rounded A rounded arc is placed between adjacent segments
equal to the rounding radius.
Chamfered A chamfer is placed between adjacent line

segments with an offset on each segment equal to
the chamfer offset.

Rounding Arc radius when using rounded vector type.
Radius

Chamfer The distance along each segment that is offset
Offset when chamfering a vertex.

Join elements If enabled, the segments form a complex chain or

complex shape.
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A drawing can be used to illustrate the use of the Smartline tool.

|1 |
— 1
—

Figure 3-18. SmartLine drawing.

Start a new drawing by selecting File > New. Name the file lines. When prompted to

=

is active and is

save changes to complex.dgn, select NO. Make sure AccuDraw

displaying a rectangular rather than a circular compass. You toggle between the two
compasses by pressing the SPACE BAR.

Select the SMARTLINE tool and set the following:

Segment Type Lines
Vertex Type Sharp
Join Elements (donotenable)

Click in the lower left of the window to begin the line.
Place SmartLine > Enter next vertex or reset to complete

Move to the right along the x-axis and enter a value of 4. Make sure AccuDraw remains
on the x-axis (horizontal). Click a data point (left mouse button) to accept that point.

Next, move the cursor directly up along the y-axis (vertical). Enter a value of 2 and
click a data point to accept.

At this point, switch to a SEGMENT TYPE of Arc. Again, move the cursor directly up.
Since the AccuDraw compass has rotated relative to the last line segment entered, this
direction (vertical) is relative to the x-axis in the AccuDraw dialog. Enter a value of .5
which is the radius of the arc. Click a data point to accept that value.

Move the cursor in a counter clockwise direction to establish the arc on the inside of
the previous line. Continue to move until the AccuDraw angle displays 180. Notice that
AccuDraw automatically changes from a rectangular to a circular compass when
specifying an arc. Click a data point to accept that angle.

Change the SEGMENT TYPE back to Line. Press the SPACE BAR to change to a
rectangular compass. Again, move directly up. This time it is along the y-axis. Enter a
value of 1 and click a data point to accept that point.
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If at any point a portion of the drawing is outside the view area, click the FIT

VIEW | gll| tool in the view border. After the drawing is zoomed, cancel the Fit

View tool by pressing reset once. Make sure you press the right mouse button
only once to cancel Fit View. If you click reset a second time you cancel the
Place SmartLine command.

5. Keep the SEGMENT TYPE set to Line and change the VERTEX TYPE to Rounded. Enter
a ROUNDING RADIUS of .5. Once you have entered the ROUNDING RADIUS, move the
cursor directly to the left. Because AccuDraw rotated the compass relative to the last
entry, moving to the left is along the y-axis. Enter a value of 3 and click a data point to
accept that position. Notice the previous vertex is rounded to a radius of .5.

Note that you can use Edit > Undo, CTRL -Z, or the UNDO tool in the
STANDARD toolbar if you make an error entering a point. UNDO acts upon the
last point if selected during the execution of a command.

6. Keep the SEGMENT TYPE set to Line and change the VERTEX TYPE to Chamfered.
Enter a CHAMFER OFFSET of .5. Once you have entered the CHAMFER OFFSET,
tentative to the starting point of the shape. Change the VERTEX TYPE to Sharp and
click a data point to accept the position. Notice the previous vertex is chamfered with
an offset of .5 on each line segment and the end of the shape has a sharp vertex.

Multi-lines

The MULTI-LINE tool ;’lﬁ creates a line which appears to be comprised of several ele-

ments, but remains a single line element. The multi-line tool allows you to place walls or
similar features by drawing a single line. The multi-line can be comprised of several compo-
nents having different styles, weights, and colors. The appearance of the multi-line is set
using the Element > Multi-lines command.
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Multi-line

Figure 3-19. The multi-line definition dialog box.

The multi-line is comprised of a series of components - line segments, start cap, end cap,
and joints.

Lines

Joints
Start Cap

YN
.

End Cap

L

Figure 3-20. Multi-line caps and joints.

Line segments are offset by a prescribed distance. Each line segment can be assigned
attributes independent of the other line segments. The COMPONENT pull-down list provides
options to modify each of the components.

Using Multi-line Tools
Creating a drawing best illustrates how to use the multi-line tools.

1. Load MicroStation and make sure the MicroStation Manager is displayed. If it is not
displayed, select File > New from the menu bar.
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Finished Drawing

The example below illustrates the finished drawing.
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Figure 3-21. Finished multi-line drawing.

Create a New Drawing

2. Determine the location of the new file by specifying the Drives and Directories
parameters. Name the new file cape.dgn and use the seed2d.dgn seed file. The file
extension .DGN is automatically appended. If the seed2d.dgn is not the current seed
file, click on SELECT and choose that file. Remember, this is a 2D drawing, so it is

important to select a 2
3.

4,

D seed file.

Once you have specified all the necessary information, select OK.

must have it highlighted in MicroStation Manager and then select OK.

Close Window 2 using the Window > View command.

At this point, notice that the file has been created but not loaded. To load the file, you
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Basic Drawing Setup

CAD systems generally draw in real world units. In other words, geometry is drawn at its
actual size. The first step is to establish the units of entry that you want to use with the
drawing. Naturally, the unit of entry must match the nature and extent of the item being

drawn.
6. Establish the unit of measurement for this drawing by selecting Settings > Design File.
7. Select the Working units category and set the following:
Master Units feet
Sub Units inches
Do not select OK at this point.
8. While the Design File Settings are displayed, select the Grid category. This is used to

establish the spacing for the drawing grid. A grid is a drawing aid that does not print.
Set the following:

Grid lock (do not check)
Grid Master 1

Grid Reference 10

Grid Config Ortho

Grid Aspect 1

The grid master sets the points on the grid to be spaced at 1 foot (master units) intervals.
The grid master sets a larger marker every 10 units of the grid; in this case every 10 feet.
The grid configuration is set to a standard orthochromatic (parallel to view) grid. And the
aspect sets the grid spacing equal both horizontally and vertically. The grid is displayed to
assist in drawing, but is not output when printing or plotting.

9.

Select OK.

10. Click the ZOOM OUT |/==| tool in the view border twice. Click a reset to cancel the

11.

tool. While drawing, you may need to use the ZOOM OUT tool, ZOOM IN E tool, and

the FIT VIEW | gl tool to adjust the view of the design file. These tools can be selected

at anytime while completing a command. Once selected, they must be cancelled before
continuing with the previous command. Carefully watch the prompting displayed on the
status bar to determine the required operation.

Select File > Save Settings to save the modifications made to the settings. Those
changes are then saved with the design file. You can use the Operation CATEGORY in
Workspace > Preferences to set MicroStation to automatically save settings when
exiting.
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Setup of Multi-line Tool
Before using the Multi-line tool it is necessary to set it up according to the type of line you
plan to draw and the current working units.

12. Select the Element > Multi-lines option. The multi-lines settings box is displayed.

From the settings box, you determine the appearance of the line, start cap, end cap, and
joints components of the multi-line.

The appearance of the multi-line for this activity is comprised of three lines segments. It
includes both a start and end cap. The joints are not displayed.
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Figure 3-22. Appearance of multi-line settings.
13. In the COMPONENT pull-down, select Line.

The appearance of the line is displayed at the bottom of the settings box. The multi-line for
this activity is comprised of three lines segments. If there are fewer than three lines,
highlight one of the lines and select Edit > Delete in the settings box. If there are more
than three lines, select Edit > Insert to add lines.

Each line is positioned relative to a zero (0) offset line. The outer walls of the floor plan are

6" in width. Set up three lines with the center line at 0, the inside of the line at -3" and the
outside line at 3". If expressed in master units, the distances are .25' and -.25' respectively.

L 0.25
N

3

Figure 3-23. Appearance of lines for multi-line.
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14. Select Settings > View Attributes and check to make sure CONSTRUCTION is enabled.
Click the ALL button. Since the center line is a construction class element, it will not
display unless the option is enabled in view attributes.

15. Pick each line and set the OFFSET in the multi-line settings box. If you enter inches,
type a colon to indicated the measurement is in sub units rather than master units.
You can either enter .25 or :3 for the outside of the wall and -.25 or -:3 for the inside.

16. Pick the center line (offset is 0) and change the attributes to:

Class Construction
Style Custom
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Pick the SELECT LINE STYLE and pick the CENTER custom line style. The
construction class allows the center line to display, but not print or plot.

= Hulke-linas M= B

Era |I.-|'\-l|'|
e i Sl |

Figure 3-24. Setting lines for multi-line.

You can close the multi-line settings box.

17.

18

Select the PLACE MULTI-LINE ﬁ tool. Use this tool to draw the outside walls of the
floor plan.

Set the PLACE BY to Maximum. There are four options: work line, center, maximum,
and minimum. In this case, the center and workline are the same. The maximum
represents the outside of the wall and the minimum would be the inside.

Make sure AccuDraw is active. If it is not, select the ACCUDRAW {:} tool. Also, make

sure the AccuSnap is enabled. To check, click the ACTIVE SNAP MODE =1 tool on the

status bar. You can also access the settings using the Settings > Snap > AccuSnap
menu option. In the GENERAL tab, enable the Enable AccuSnap, Show Tentative Hint,
Identify Elements Automatically, and Pop-up Info Automatic functions. Disable the
Display Icon function. If enabled, this function displays an icon indicating the type of
currently active snap mode.
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Figure 3-25. AccuSnap settings dialog.

AccuSnap provides a drawing aid that automatically inputs tentative snap points. Snap
points are used to precisely locate a position relative to existing elements. For example, a
position at the end of a line or the center of circle.
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When AccuSnap is enabled, a snap point symbol is displayed when you move the pointer
over a snap point. The symbol indicates you are near enough to the desired snap point to
enter a data point. If the data point is entered while the symbol is displayed, it automati-
cally locates the position on the snap point.

Pointer Snap point symbol

at endpoint of line

L o

Snap point symboI/J

at center of circle
Figure 3-26. AccuSnap display of snap points.

How close the cursor needs to be to a snap point is controlled by two settings. The first is
the Snap tolerance setting found in the FEEL tab of the AccuSnap settings dialog which
adjusts how close the pointer must be to an element in order to snap a tentative point to it.
The second uses the Workspace > Preference menu option to access the Locate Toler-
ance user preference found in the INPUT category. The tolerance value is set in screen
resolution (pixels) and determines the size of the location zone surrounding the pointer..

Once you have made the settings, close the AccuSnap Settings box.

19. Click in the lower left corner of the window to begin the drawing. Move the cursor up
along the vertical axis and enter 24:6. Click to accept that point. Note that the colon
indicates you entered 24 feet and 6 inches since the colon indicates the following
value is in sub units. The entry format is master units:sub units. You may need to

select the ZOOM OUT | =m| tool several times to see the line. If you selected the ZOOM
OUT tool, you need to click a reset to cancel the tool.

20. Move the cursor the right along the horizontal axis. Make sure AccuDraw indexes to
that axis and type 30:8. Click to accept that point.

21. Move the cursor down directly along the vertical axis and type 24:6. Click to accept
that point.

22. Close the shape by clicking CLOSE ELEMENT in the settings box. Click the FIT VIEW

all| tool to see the entire drawing. Cancel the fit view tool.
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Figure 3-27. Outer wall of floor plan.

Before drawing the inside walls, you can change the wall thickness from 6" to 5".

23. Select Element > Multi-lines. The multi-lines settings box is displayed.

24. First, pick the outside line indicated as .25 (feet). Change the OFFSET in the multi-line
settings box for this line to :2.5 (inches). Next, pick the inside line indicated as -.25
and change the OFFSET of that line to -:2.5. Make sure you enter a negative value and
the colon to indicated inches (sub units). The settings box displays the values in

master units (.2083 and -.2083).

You can close the multi-line settings box.

25. Select the PLACE MULTI-LINE ﬁ tool and set the PLACE BY to Center.

26. Make sure AccuDraw is active. Tentative to the inside corner of the wall in the upper

left side of the drawing. The AccuSnap £ symbol should display at the location when
the pointer is positioned near the corner.

Tentative
Point

Figure 3-28. Tentative point on outer wall of floor plan.

With AccuSnap enabled, you can either do a tentative on the location and then
a data point or you may data point directly without a tentative when AccuSnap
provides an indication that you are at the desired location.
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27. If you successfully located the tentative point, enter the letter O to set the AccuDraw
origin at the tentative position. Move the cursor down along the vertical axis and enter

5:2. Click to accept that point. You may need to select the ZOOM IN E tool to make

it easier to locate the tentative point. If you selected the ZOOM IN tool, you need to
click a reset to cancel the tool. Make sure you do not click reset twice or you will
cancel the multi-line command.

28. Move the cursor right along the horizontal axis. Make sure AccuDraw indexes to that
axis and type 10:11. Click to accept the point.

29. Move the cursor up along the vertical axis. Make sure AccuDraw indexes to that axis
and type 5:2. Click to accept the point

Figure 3-29. Interior wall of floor plan.

30. Click a reset to cancel the multi-line tool.

31. Select the PLACE MULTI-LINE ﬁ tool and set the PLACE BY to Center.

32. Tentative to the far left center of the line you just completed.

Tentative
Point

I
I
I
‘\7,7,7,7,7,4
I
|

Figure 3-30. Tentative point on outer wall of floor plan.

33. If you successfully located the tentative point, enter the letter O to set the AccuDraw
origin at this position. Move the cursor down along the vertical axis and enter 3:8.
Click to accept the point.
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34. Move the cursor right along the horizontal axis. Make sure AccuDraw indexes to that
axis and type 10:11. Click to accept the point.

35. Move the cursor down along the vertical axis. Make sure AccuDraw indexes to that axis
and type 14:9. Click to accept the point

Figure 3-31. Position of second interior wall of floor plan.

36. Click a reset to cancel the multi-line tool.

37. Select the PLACE MULTI-LINE ﬁ tool and set the PLACE BY to Center.

38. Tentative to the inside corner at the lower left of the outside wall.

Tentative
Point

Figure 3-32. Tentative point at lower left corner of outside wall.

39. If you successfully located the tentative point, enter the letter O to set the AccuDraw
origin at this position. Move the cursor up the vertical axis and enter 11:9. Click to
accept that point.

40. Move the cursor to the left along the horizontal axis. Make sure AccuDraw indexes to
that axis and type 22:10. Click to accept the point.
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41. Click a reset to cancel the multi-line tool.

Figure 3.33. Appearance of interior walls of floor plan.

42. Select the PLACE MULTI-LINE ﬁ tool and set the PLACE BY to Center.

43. Tentative to the position indicated in the following illustration.

Tentative
Point

Figure 3-34. Tentative point for interior wall of floor plan.

44. If you successfully located the tentative point, enter the letter O to set the AccuDraw
origin at this position. Move the cursor to the right along the horizontal axis and enter
5:11. Click to accept the point.

45. Move the cursor down along the vertical axis. Make sure AccuDraw indexes to that axis
and type 3:3. Click to accept the point
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Figure 3-35. Appearance of interior walls of floor plan.

46. Click the ACTIVE SNAP MODE =i tool on the status bar and access ACCUSNAP. In

the GENERAL tab, check to enable the Display Icon function. This function displays
an icon indicating the type of currently active snap mode. Close the AccuSnap settings

box.

47. Select the PLACE MULTI-LINE

i

"

tool and set the PLACE BY to Center.

48. Select the INTERSECTION snap from the ACTIVE SNAP MODE |..d tool on the status

bar. Move the pointer to the intersection of the two center lines indicated in the
illustration below. Once the intersection is located, tentative to that point. Notice that
an icon is displayed next to the pointer indicating the current snap mode is set to

intersection .

}77 ] — [

|
\ Tentative

Point

Figure 3-36. Tentative point for interior wall of floor plan.

49. If you successfully located the tentative point, enter the letter O to set the AccuDraw
origin at this position. Move the cursor to down along the vertical axis and enter 2:2.

Click to accept the point.
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50. Move the cursor right along the horizontal axis and enter 2:6. Click to accept the
point.

51. Move the cursor directly up along the vertical axis. Make sure AccuDraw indexes to
that axis and type 2. Click to accept that point

Figure 3-37. Appearance of interior and exterior walls.
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Multi-Line Joints

The multi-line joint tools allow you to construct a variety of joints and openings in lines
created with the multi-line tool.

Il 1l
ME / 19 Bl ] 0 LLI ]
Construct Closed Cross Joint -
A:Iﬁ // [ ] l_’_l_\_\
I Construct Open Cross Joint— "] Il
AJ: // .
- Construct Merged Cross Joint — & ]
ol il
=T Cut Single Component Line
- g Cut All Component Lines
— T e =

_____ / Construct Closed Tee Joint \ -
T //Construct Open Tee Joint \ 1] I
== Construct Merged Tee Joint . ,

—_— Construct Corner Joint

.
:

UncutComponentLines

_____ Multi-line Partial Delete [ ]
5 il
Move Multi-line Profile
=

I|F|=\I

Th =4

= Edit Multi-line Cap

I 5=8 B
ﬁ =5 3

Figure 3-38. Multi-line joint tools.

1. Select the Tools > Multi-line Joints option.

2. Select the CONSTRUCT MERGED TEE JOINT tool from the MULTI-LINE JOINTS

tool box. You may want to view the tool description on the status bar since the multi-
line joint tools look very similar.
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Once you have selected the tool, click the multi-lines indicated in the following
illustration to change the joints formed between the various multi-lines.

Figure 3-39. Multi-line tee joints.

3. Next, select the CONSTRUCT MERGED CROSS JOINT

.

tool from the MULTI-LINE

JOINTS tool box. Click the crossing lines indicated to form a cross joint.

- 1
[

Figure 3-40. Multi-line cross joint.

This completes the joints needed to merge the multi-lines. The next step is to create
openings for doors and windows. In this example, only simple door openings are created.

4. Select the MULTI-LINE PARTIAL DELETE tool from the MULTI-LINE JOINTS tool

box. A tool settings box is displayed.
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5. Set the CAP MODE to Active. The active mode is the one currently set by the Element
> Multi-lines command. Use that command to check to make sure the Start Cap and
End Cap COMPONENTS are both set to draw a line.

Multi-line Partial Delete > Identify multi-line at start of delete

The prompt indicates that you are to identify the multi-line element at the point the partial
delete is to begin.

6. On the far right side of the drawing, tentative to the point indicated in the illustration
below.

Tentative
Point

Figure 3-41. Tentative point for beginning the partial delete
7. If you successfully located the tentative point, enter the letter O to set the AccuDraw
origin at this position. Move the cursor left along the horizontal axis and enter 9. Click
to accept the point. This represents the start of the delete.
8. Move the cursor left along the horizontal axis and enter 4. Click to accept the point.

This represents the end of the cut created by the partial delete. An end cap should
appear on the multi-line.

9. Again, select the MULTI-LINE PARTIAL DELETE tool.

10. Tentative to the midpoint of the line indicated.

Tentative
Point

|
|
|
‘7,7,7,7,7,4
|
|

Figure 3-42. Tentative point at the midpoint of the wall.
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11. If you successfully located the tentative point, enter the letter O to set the AccuDraw
origin at this position. Move the cursor left along the horizontal axis and enter 1:3 (half
the width of the door opening). Click to accept the point.

12. Move the cursor left along the horizontal axis and enter 2:6. Click to accept the point.
This represents the other end of the door opening.

|
|
|
‘777777777,4
|
|

- T

Figure 3.43. Door opening centered on wall section.

13. Complete the remaining door openings where indicated using the MULTI-LINE PARTIAL

DELETE tool. If the position of the opening is not indicated, assume it is centered
on the wall section. The complete drawing is shown in Figure 3-21.

After you have completed the openings in the wall, the visibility of the center line can be
disabled by selecting Settings > View Attributes and removing the check from CONSTRUC-
TIONS. If you remember, the multi-line definition defined the center line as a construction
element rather than a primary element. The view attributes allow you to disable the display
of construction elements.

The center lines are valuable when dimensioning wall sections that typically dimension
from the center of the wall. Once the dimensions lines have been placed, the construction
lines used to help position the dimension lines can be disabled.
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Selection Tool
Before you begin to look at selection tools, load the drawing selection.dgn.

Level 1 @

(T3 O -
O

4

@)

Level 2 @

Figure 3-44. Selection.dgn design file.

Many commands require that you select one or more elements. There are several methods
for selecting a single element or multiple elements. The primary tool for selecting elements
is the ELEMENT SELECTION tool .

1. Pick the ELEMENT SELECTION IEI tool and select one of the large circles.

The selected element is indicated with handle points and highlighted. You will also notice
that elements are highlighted when the pointer is over the element.

Highlight and
= £ u selection colors
7] | |
Handle
7] & k

Figure 3-45. Handles and color are used to display selected element.

How a selection is displayed is based on user preference settings. Select Workspace >
Preferences and then select the OPERATIONS category. The Disable Edit Handles param-
eter determines if a selected element is displayed with “handles.” Colors associated with
selection are established in the COLOR category accessed with the Settings > Design File
menu option. Remember, if want changes in settings to be saved with the design file, select
File > Save Settings or use the Workspace > Preferences to automatically save settings.
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todify Color Settings
Element Highlight Color; NS ~

Drawing Pointer Color; S
Selection Set Color; I ~

Figure 3-46. Color settings related to selecting elements

Parameter Description

Element Highlight Color While in the element selection mode, this parameter
determines the color used to highlight when the
pointer encounters an element.

Drawing Pointer Color While the ELEMENT SELECTION tool is selected, this
parameter determines the color used for the pointer.

Selection Set Color After an element is selected, it becomes part of the
selection set. This parameter determines the color used to
highlight the selection set.

The ELEMENT SELECTION | k | tool can be used to select elements in several different

ways. The resulting selected elements comprise the selection set. The number of elements
in the selection set are displayed on the status bar.

Element Selection Tool

Action Results
Single Click Selects a single element.
Single Click Selects multiple elements.

while holding CTRL key

Click and drag Selects all elements that are entirely within
enclosure.

2. To deselect the currently highlighted element, select the ELEMENT SELECTION tool
and click the mouse pointer in an area that is not near any element.

When you use the selection tool, the mouse pointer includes a circle, often called an
aperture or target.

Figure 3-47. The selection tool cursor showing selection target area.

If no element is inside the target, nothing is selected. To select an element, a portion of
that element must reside within the target. The size of the target is controlled by the
Workspace > Preference command. In the Input category, you can set the Location
Tolerance to a smaller or larger value. The value represents the diameter of the target in
pixels.
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3. Pick the ELEMENT SELECTION tool. Next, select the Workspace > Preference
command. In the Input category, set the Location Tolerance to a value of 20. The
value represents the diameter of the target in pixels. Select OK and notice the target
area has increased in size. The change appears similar to the example below.

& W

Figure 3-48. Location tolerance size change for the selection tool cursor.

A larger location tolerance makes it easier to select elements, but also increases the
likelihood of selecting the wrong one when the selection includes several elements in close
proximity.

4. Select the Workspace > Preference command. In the Operations category, set the
Location Tolerance back to a value of 10.

5. Use the ELEMENT SELECTION IE tool to pick items in Selection.dgn. Click several

elements. Next, hold the CTRL key when clicking elements. Click away from any
elements to deselect the currently selected element. Place the cursor near, but not on
the number “1” in the “A” section of the design file. Click (left mouse button) and drag
(keep the mouse button depressed) it to the number “2.” You should notice a
rectangular “marquee” defined by the diagonal points. Release the mouse button when
located near position “2.”

If you had clicked directly on the number "1" when doing this operation, you will physically
move it rather than create a marquee. You must start the marquee in an area without an
element.

Notice the items highlighted within the area created by clicking and dragging the selection
tool from position “1” to position “2.” Only those elements completely within the rectangu-
lar “marquee” are part of the selection set.

6. Click away from any elements to deselect any currently selected elements.

PowerSelector Tool

An alternative to using the Element Selection tool is the POWERSELECTOR tool. This tool
incorporates several methods for selecting multiple elements. The PowerSelector tool is
located on the same tool box as the Element Selection tool.

1. Select the POWERSELECTOR I;‘?, tool. The tool settings box is displayed.

Method: |52 0] 7] |
Mode:  [n =| ]| o
hd

Figure 3-49. PowerSelector tool.
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PowerSel ector offers several optionsfor selecting elements. The Method determines the selection
process. The Mode determinesiif items are selected or deselected. Clicking the buttons toggles
through the available options.

Method Result
Individual Selection is performed on each element. If you enter adata point but
'$' miss an element, the Block method activates.

Block selection includes two options. Options are changed by selecting the block tool
when active.

Block Inside All elementsinside the defined block are sel ected.

Block Overlap  All elementsinside and overlapping the defined block are sel ected.

= U

Shape selection includes two options. Options are changed by selecting the shape tool
when active.

N

Shape Inside All elementsinside the defined shape are selected.

&

ShapeOverlap  All elementsinside and overlapping the defined shape are selected.

/ Line All elementsintersecting adrawn line are sel ected.
Mode Result
-+ Add Select elements,
- Subtract Deselect elements.
j Invert Toggle the selection status of an element. If selected, it becomes
desel ected.

|

;k/* New Clears the current selection set and starts a new set.
O Select All Select all elementsif no elementsare currently selected.
N Clear Deselect al currently selected elementsif element(s) selected.
71N

Figure 3-49. PowerSelector tool methods and modes.

2. Click the SHOW SELECTION INFORMATION | = | button on the PowerSelector settings
box.
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Clicking the SHOW SELECTION INFORMATION button expandsthetool settingswindow to provide
additional criteria for making selections with the PowerSel ector. The top entry box allowsyou to
select an attribute (level, color, style, weight, type, and class). The bottom entry box contains the
values for the attribute selected.

B PowerSelect ot =] =]

wotes | 2401 1 /]

Wode  [BH 1~ | B K=
|

Ewt |#Ty | w0
B | Tk |Sw

0 a
Ciefad
Lerenl 1

Liwend 2
Lerenl 3
Leveni &
Lerenl 5
Livel b
[
Lereei B
Leresl 9
Lt 10

Lerenl 11 '||II =

Figure 3-50. PowerSelector selection attributes.

The six tabs allow you to select elements based on the assigned attributes (level, color,
line style, line weight, element type, and element class). The outcome is dependent on the
currently active method and mode.

3. Click NEW mode in PowerSelector. Click in the view window away from any
elements to begin a new selection set.

4. Experiment with the various methods and modes for selecting elements. Make sure you

use the COLOR category accessed with the Settings > Design File menu option to pick
a unique color for selected elements.

5. After you have experimented with the various methods and modes, click NEW
mode to begin a new selection set.

6. Using PowerSelector, set the method to INDIVIDUAL and the mode to ADD .

Click the SHOW SELECTION INFORMATION | = button and pick the CO (color)
attribute tab. Next, pick the green (2) and red (0) colors. Note the elements selected.

After selecting based on color, pick the LV (level) attribute tab. Note that levels 1 and
2 are highlighted indicating elements on those two layers have been selected. Click
layer 1 to remove it from the selection set and note which elements remain selected.
The criteria now are all green and red elements located on layer 2.

7. Change the MODE to SUBTRACT IE‘ and select large circle in the D section. This
should remove the circle from the selection set.
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8. Change the MODE to ADD . On the color attribute tab, select blue (4). MicroStation

scans the design file for all elements that are the color 4 (blue). Note that elements on
both levels are selected. If you select the level tab, you will notice that both level 1
and level 2 are in the selection set.

9. Click NEW mode in PowerSelector. You can also use the CLEAR | 22| mode in
PowerSelector or the menu option Edit > Select None to deselect all elements.

10. Pick the PowerSelector tool and change the METHOD to LINE and the MODE to

ADD . In the Selection.dgn drawing, click on the number 1 and then click on the

number 7. Notice that all elements that intersect the line formed between the two
points are selected.

11. Select Edit > Select None to deselect all elements and close the PowerSelector dialog.

Fence

Another technique used to select items based on location is the use of afence. A fence describes a
technique for selecting elements that uses avariety of names (window, marquee, lasso, etc.). It allows
the user to draw a fence or border around the desired geometry for the purpose of selection. Many
software packages have added functions that mask the selection based on the desired outcome. For
example, the software may display options for selecting everything inside the fence, everything
outside the fence, or items that overlap the fence.

1 Selectthe PLACEFENCE | :|tool. Thetool settings show several optionsfor use of the tool.

EHEEE Fence M= E3

Fence T_I,Ipe:E Block -
Eence Mode:  Inzide hl

Figure 3-51. Place fence tool settings.
There are two parameters that control the fence: type and mode.

The Fence Type option determine the shape of the fence used to select elements. The
options are:

Type Description
Block The fence is a rectangular block.
Shape The fence is an irregular shape.
Circle The fence is in the shape of a circle.
_________ e ~
s ~ -7 T~
| 7 ~ Ve A

O
O
O

Figure 3-52. Block, shape, and circle fence type.
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Type
Element

From View

From Design File

EP'EEE Fence =]

Description

The fence uses the boundaries of an existing element.
If you select this type, you are prompted for a enclosed
element.

Create Fence From Element > Select element

The fence is derived from the extents of a selected window.
If you select this type, you are prompted for a view.

Create Fence From View > Select view

This option can be used with a single window or when
displaying multiple view windows.

The fence is placed at the extents of the active design file,
an attached reference file, or combination of both. If you
select this type, the Design parameter appears in the
settings box.

Fence Type: From Design Fils l
Eence Mode:  |nside il
Design  Active x>

Figure 3-53. From Design File parameter added to place fence.

Active

All

Choose

The fence is placed at the extents of the currently active
design file.

The fence is placed at the extents of the currently active
design file and any attached reference files.

The fence is placed at the extents of the file (active or
reference) that you identify. You are prompted to identify
an element in the desired file.

The Fence Mode determines which elements are included in the selection. The options are:

Mode
Inside
Overlap
Clip

Void
Void-Overlap

Void-Clip

Description

Elements selected are completely within the fence.
Elements selected are completely or partially within fence.
Only items completely in fence or portions inside fence

are acted upon. Elements that are partially inside fence are
“broken” into multiple elements.

Elements selected are completely outside the fence.
Elements selected are completely or partially outside
fence.

Only items completely outside fence or portions outside
fence are acted upon. Elements that are partially outside of
fence are “broken” into multiple elements.
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:

Void Void-Overlap Void-Clip

Figure 3-54. lllustration of selection with different fence modes.

The Fence tool does not take action directly on an element; it is only for the purpose of
selection. When you select other tools, they often have an option to “use fence” for the
selection of elements. For example, if you select the copy element tool, a USE FENCE
option is available. In essence, the fence works similar to a temporary group by only
selecting the items that have been fenced.

& Copy Element E4

[T Use Fence [nzide - |

Figure 3-55. Fence option display in copy settings box.

In the above example, if USE FENCE was enabled, the copy would apply to all elements
totally within the fence. To remove the fence, select the FENCE tool.

2. Select Edit > Select None to deselect all elements.
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If the fence dialog is not displayed, select the FENCE |i | tool. Select the Block for

TYPE and Inside for MODE. In example D of the Selection.dgn design file, tentative to
the small point located next to the number 3. Accept this location with a data point.

Next, tentative to the point next to the number 4 and accept with a data point. This

places a rectangular fence around several elements. The illustration below shows the
fence with a broken line.

Laval 2 (L '_;.

Figure 3-56. Illustration of a block fence.

Select the CHANGE ELEMENTS ATTRIBUTE t tool. Note that the USE FENCE option

is available for selection when a fence has been established. Enable the FENCE option
and set MODE to Inside. Click on COLOR and select green (2). Accept the change by
clicking a data point in the view window.

Select Edit > Undo change element attributes to change the elements back to their
previous color.

Next, select the Shape for TYPE and Inside for MODE. In example E of Selection.dgn,
first tentative to the point next to number 5, accept, and then tentative and accept on
each of the points next to numbers 6 through 9. Complete the shape by selecting
CLOSE ELEMENT. This places a shape fence around several elements.

Figure 3-57. Illustration of a shape fence.

7. Select the CHANGE ELEMENTS ATTRIBUTE ': tool. With the FENCE option enabled,

set MODE to Inside. Click on COLOR and select red (3). Accept the change by clicking
a data point in the view window.
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8. Select Edit > Undo change element attributes to change the elements back to their
previous color.

9. Next, select the Circle for TYPE and Inside for MODE. In example F of selection.dgn,
tentative and accept to the point next to number 10 and then tentative and accept to
the point next to number 11. This places a circular fence around several elements.

10. Again, use the CHANGE ELEMENTS ATTRIBUTE t tool and the Edit > Undo change
element attributes to modify the fenced elements.

11. Experiment with using several of the fence types and modes. Remember, when a fence
has been established, the fence option is available with several of the available tools.

Selection Options

In many cases, it is desirable to select elements based on specified criteria to increase
speed and efficiency. The process is often referred to as masking and can be used to
include or exclude geometry from selection. Some of these options are similar to those used
with the PowerSelector tool. MicroStation offers three menu options that define the selec-

tion set.

Edit > Select All
Edit > Select None
Edit > Select By Attributes

The Edit > Select All and Edit > Select None are used to select all elements or deselect all

elements respectively. They work the same as the SELECT ALL @ and CLEAR
modes available with PowerSelector.

The Edit > Select By Attributes is used to selectively include or exclude elements based
on specified characteristics or conditions.
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Figure 3-58. Select by attributes dialog box.
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1. Select the Edit > Select By Attributes menu option.

When selected, you have several options that determine what is selected, how it is se-
lected, and if the MODE is to include (Inclusion) or exclude (Exclusion) elements. These
options are categorized in terms of level, types, symbology, and mode. You can also use
properties and tags to determine the selection set.

The following is an overview of the options:

LEVELS

The selection set is based on the selected level(s). The highlighted levels indicate those
that are part of the selection set. Each level can be selected independently or you can drag
along the levels to toggle the setting.

TYPES
The selection set is based on the type of geometry (circles, lines, arcs, etc.). The high-
lighted types of geometry indicate those that are part of the selection set.

SYMBOLOGY

There are three different options.
Color If enabled, the selection set is based on color (red, blue, etc.).
Style If enabled, the selection set is based on line type (solid, dashed, etc.).
Weight If enabled, the selection set is based on line weight.

MODE

The MODE determines how criteria are used when the EXECUTE button is clicked.

Inclusion Determines if selected items are included from the selection set.
Exclusion Determines if selected items are excluded from the selection set.

Selection Elements are selected based on Select By criteria.

Location  Filters geometry based on Select By criteria. Only those elements that
meet the criteria are eligible for further selection. The elements are
not selected when the EXECUTE button is pressed, only a filter is
applied that limits further selection.

Display Filters display of elements based on Select By criteria. Only the
elements inthe selection set that meet the criteria are displayed.
When the selection set is cancelled and the view is updated, the
elements are again displayed.

On If set to On (the default), the Select By criteria is applied when the
EXECUTE button is pressed.
Off If set to Off, Select By criteria is ignored.

2. Inthe SELECT BY ATTRIBUTES dialog, select Level 2 in LEVELS and Ellipse in TYPES.
Click EXECUTE and all circles and ellipses on level 2 are selected. The EXECUTE
button creates the selection set based on the criteria specified.

3. Close the SELECT BY ATTRIBUTES dialog. A dialog is displayed.
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Figure 3-59. Select by attributes alert.

Your response to the alert message determines if the selection set remains active. If you
select OK, the criteria specified by SELECT BY ATTRIBUTES remains in effect. To remove
the selection criteria, you must select CANCEL. Selecting CANCEL allows you to select any
element. Select CANCEL.
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Review Questions

1. Define a drawing element.

2. Differentiate an element, complex chain, and complex shape.

3. How do you create a complex shape?

4. What happens when you "drop" an element?

5. Describe the three operations you can do to regions. These operations are often
referred to as Boolean operations.

6. Differentiate the line, SmartLine, and multi-line tools.

7. What are multi-line joints?

8. Describe the different methods available for selecting multiple elements.

9. What is PowerSelector?

10. Describe the types and modes available for use with the fence tool.

11. The Edit > Select By Attributes command provides several options for determining the
selection set. List and describe the available options.

Activities

1. Create a new drawing and experiment with each of the drawing elements. Some tools
for placing elements may not be displayed and can be found in the Tools menu.

2. Experiment with placing lines using the line, SmartLine, and multi-line tools. While
using the multi-line tool, select Element > Multi-lines to modify the appearance of the
multi-line.

3. Inthe ATTRIBUTES tool box, select the ACTIVE LINE STYLE pull-down and view the

custom line styles. Select Element > Line Style > Custom and experiment with
modifying the width, scale factor, and shift. After making each modification, use the
PLACE LINE tool to draw lines using the modified line styles.
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4. Complete the non-dimensioned drawings below. Merely draw the items without regard
to precise size.

A. Create this drawing using the PLACE SMARTLINE tool.

B. Use the PLACE CIRCLE tool and the CREATE REGION tool to complete
the following shapes.

C. Create a new drawing and set the master working units to feet and the sub-units to
inches.

Draw the item using the PLACE MULTI-LINE tool and the multi-line joint tools.
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