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Lesson 3 Extrusions 
 

 
Figure 3.1 Clamp  
OBJECTIVES 
 

• Create a feature using an Extruded protrusion 
• Understand Setup and Environment settings 
• Define and set a Material type  
• Create and use Datum features 
• Sketch protrusion and cut feature geometry using the Sketcher 
• Understand the feature Dashboard  
• Copy a feature 
• Save and Delete Old Versions of an object  

Extrusions 
 
The design of a part using Pro/E starts with the creation of base features (normally datum planes), 
and a solid protrusion. Other protrusions and cuts are then added in sequence as required by the 
design. You can use various types of Pro/E features as building blocks in the progressive creation 
of solid parts (Fig. 3.1). Certain features, by necessity, precede other more dependent features in the 
design process. Those dependent features rely on the previously defined features for dimensional 
and geometric references.  

The progressive design of features creates these dependent feature relationships known as 
parent-child relationships. The actual sequential history of the design is displayed in the Model 
Tree. The parent-child relationship is one of the most powerful aspects of Pro/E and parametric 
modeling in general. It is also very important after you modify a part. After a parent feature in a 
part is modified, all children are automatically modified to reflect the changes in the parent feature. 
It is therefore essential to reference feature dimensions so that Pro/E can correctly propagate design 
modifications throughout the model.  

An extrusion is a part feature that adds or removes material. A protrusion is always the first 
solid feature created. This is usually the first feature created after a base feature of datum planes. 
The Extrude Tool is used to create both protrusions and cuts. A toolchest button is available for 
this command or it can be initiated using Insert ⇒ Extrude from the menu bar. Figure 3.2 shows 
four different types of basic protrusions. 
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   Extrude   

   Revolve   

       Blend   

      Sweep   
Figure 3.2 Basic Protrusions  
The Design Process  
 
It is tempting to directly start creating models. Nevertheless, in order to build value into a design, 
you need to create a product that can keep up with the constant design changes associated with the 
design-through-manufacturing process. Flexibility must be “built in” to the design. Flexibility is the 
key to a friendly and robust product design while maintaining design intent, and you can 
accomplish it through planning. To plan a design, you need understand the overall function, form, 
and fit of the product. This understanding includes the following points: 
 

• Overall size of the part 
• Basic part characteristics 
• The way in which the part can be assembled 
• Approximate number of assembly components  
• The manufacturing processes required to produce the part 
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Lesson 3 STEPS 
 

 
Figure 3.3 Clamp and Datum Planes 
 
Clamp 
 
The clamp in Figure 3.3 is composed of a protrusion and two cuts. A number of things need to be 
established before you actually start modeling. These include setting up the environment, selecting 
the units, and establishing the material for the part. 

Before you begin any part using Pro/E, you must plan the design. The design intent will 
depend on a number of things that are out of your control and on a number that you can establish. 
Asking yourself a few questions will clear up the design intent you will follow: Is the part a 
component of an assembly? If so, what surfaces or features are used to connect one part to another? 
Will geometric tolerancing be used on the part and assembly? What units are being used in the 
design, SI or decimal inch? What is the part’s material? What is the primary part feature? How 
should I model the part, and what features are best used for the primary protrusion (the first solid 
mass)? On what datum plane should I sketch to model the first protrusion? These and many other 
questions will be answered as you follow the systematic lesson part. However, you must answer 
many of the questions on your own when completing the lesson project, which does not come with 
systematic instructions. 
  
Launch Pro/ENGINEER WILDFIRE 2.0 ⇒ File ⇒ Set Working Directory ⇒ select the 

working directory ⇒ OK ⇒  Create a new object ⇒ Part ⇒ Name CLAMP ⇒ 

 ⇒ OK ⇒ Edit ⇒ Setup ⇒ Units ⇒ Units Manager millimeter Newton 
Second (mmNs) ⇒ Set ⇒ Convert dimensions [Figs. 3.4(a-b)] ⇒ OK ⇒ Close ⇒ Material ⇒ 

Define ⇒ type STEEL  ⇒  [Fig. 3.4(c)] ⇒ File from the material 

table ⇒ Save ⇒ File ⇒ Exit ⇒ Assign ⇒ pick STEEL ⇒ Accept ⇒ MMB ⇒  ⇒ MMB (or 
Enter or OK) 
 
 The material file, STEEL, is without any file information [Fig. 3.4(c)]. As an option, if your 
instructor provides you with the specifications, or you are familiar with setting up material specs, 
you can edit the file using: Edit ⇒ Setup ⇒ Material ⇒ Edit ⇒ Steel ⇒ Accept ⇒ fill in the 
information ⇒ File ⇒ Save ⇒ File ⇒ Exit ⇒ Done. 
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Figure 3.4(a-b) Units Manager Dialog Box and Changing Model Units Dialog Box     

 
Figure 3.4(c) Material File    

Since  was selected, the default datum planes and the default coordinate 
system are displayed in the graphics window and in the Model Tree (Fig. 3.5). The default datum 
planes and the default coordinate system will be the first features on all parts and assemblies. The 
datum planes are used to sketch on and to orient the part’s features. Having datum planes as the 
first features of a part, instead of the first protrusion, gives the designer more flexibility during the 
design process. Picking on items in the Model Tree will highlight that item on the model (Fig. 3.5). 
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Figure 3.5 Default Datum Planes and Default Coordinate System 
 

Pick the FRONT datum plane in the Model Tree ⇒  Sketch Tool from the right Toolbar ⇒ 
Sketch dialog box opens [Fig. 3.6(a)], click:  
 

   
Figure 3.6(a) Sketch Dialog Box 
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Click: Close to accept the References [Fig. 3.6(b)] ⇒  Toggle the grid on from the top toolbar 
[Fig. 3.6(c)] 
 

   
Figure 3.6(b) References Dialog Box         Figure 3.6(c) Grid On 
 

The sketch is now displayed and oriented in 2D [Fig. 3.6(c)]. The coordinate system is at 
the middle of the sketch, where datum RIGHT and datum TOP intersect. The X coordinate arrow 
points to the right and the Y coordinate arrow points up. The Z arrow is pointing toward you (out 
from the screen).  The square box you see is the limited display of datum FRONT. This is similar to 
sketching on a piece of graph paper. Pro/E is not coordinate-based software, so you need not enter 
geometry with X, Y, and Z coordinates as with many other CAD systems.   
 
Use Shift MMB and Ctrl MMB to reposition and resize the sketch as needed. Since you now have 
a visible grid, it is a good idea to have your sketch picks snap to the grid. Click: Tools from the 

menu bar ⇒  Environment ⇒  [Fig. 3.6(d)] ⇒ Apply ⇒ OK  
 

You can control many aspects of the environment in which Pro/E runs with the 
Environment dialog box. To open the Environment dialog box, click Tools ⇒ Environment on the 
menu bar or click the appropriate icon in the toolbar. When you make a change in the Environment 
dialog box, it takes effect for the current session only. When you start Pro/E, the environment 
settings are defined by your configuration file, if any; otherwise, by Pro/E configuration defaults.   

 
Depending on which Pro/E Mode is active, some or all of the following options may be 

available in the Environment dialog box: 
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Display: 
 
Dimension Tolerances Display model dimensions with tolerances 
Datum Planes Display the datum planes and their names 
Datum Axes Display the datum axes and their names 
Point Symbols Display the datum points and their names 
Coordinate Systems Display the coordinate systems and their names 
Spin Center Display the spin center for the model 
3D Notes Display model notes 
 

Notes as Names Display the note as a name, not the full note 
Reference Designators Display reference designation of cabling, ECAD, 
and Piping components 
Thick Cables Display a cable with 3-D thickness 
Centerline Cables Display the centerline of a cable with location points 
Internal Cable Portions Display cable portions that are hidden from view 
Colors Display colors assigned to model surfaces 
Textures Display textures on shaded models 
Levels of Detail Controls levels of detail available in a shaded model 
during dynamic orientation 
  
Default Actions: 
 
Ring Message Bell Ring bell (beep) after each prompt or system message 
Save Display Save objects with their most recent screen display 
Make Regen Backup Backs up the current model before every 
regeneration 
Snap to Grid Make points you select on the Sketcher screen snap to a grid 
Keep Info Datums Control how Pro/E treats datum planes, datum points, 
datum axes, and coordinate systems created on the fly under the Info 
functionality 
Use 2D Sketcher Control the initial model orientation in Sketcher mode 
Sketcher Intent Manager Use the Intent Manager when in Sketcher 
Use Fast HLR Make possible the hardware acceleration of dynamic 
spinning with hidden lines, datums, and axes 
  
Display Style: 
 

• Wireframe Model is displayed with no distinction between 
visible and hidden lines 

• Hidden Line Hidden lines are shown in gray 
• No Hidden Hidden lines are not shown 
• Shading All surfaces and solids are displayed as shaded 

Figure 3.6(d) Environment Dialog Box 
 

Standard Orient: 
 

•        Isometric Standard isometric orientation 
•        Trimetric Standard trimetric orientation 
•        User Defined User-defined orientation  

 
   Tangent Edges: 

 
• Solid Display tangent edges as solid lines 
• No Display Blank tangent edges 
• Phantom Display tangent edges in phantom font 
• Centerline Display tangent edges in centerline font 
• Dimmed Display tangent edges in the Dimmed Menu system 
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Because you checked , you can now sketch by simply picking grid points 
representing the part’s geometry (outline).  Because this is a sketch in the true sense of the word, 
you need only create geometry that approximates the shape of the feature; the sketch does not have 
to be accurate as far as size or dimensions are concerned. No two sketches will be the same between 
those using these steps, unless you count grid spaces (which is not necessary). Even with the grid 
snap off Pro/E, constrains the geometry according to rules, which include but are not limited to the 
following: 
 

• RULE:  Symmetry 
DESCRIPTION:  Entities sketched symmetrically about a centerline are assigned equal values with 
respect to the centerline 

• RULE:  Horizontal and vertical lines 
DESCRIPTION:  Lines that are approximately horizontal or vertical are considered exactly horizontal or 
vertical 

• RULE:  Parallel and perpendicular lines 
DESCRIPTION:  Lines that are sketched approximately parallel or perpendicular are considered exactly 
parallel or perpendicular 

• RULE:  Tangency  
DESCRIPTION:  Entities sketched approximately tangent to arcs or circles are assumed to be exactly 
tangent 

  
The outline of the part’s primary feature is sketched using a set of connected lines. The 

part’s dimensions and general shape are provided in Figure 3.6(e). The cut on the front and sides 
will be the created with separate sketched features. Sketch only one series of lines (8 lines in this 
sketch). Do not sketch lines on top of lines. 

It is important not to create any unintended constraints while sketching. Therefore, 
remember to exaggerate the sketch geometry and not to align geometric items that have no 
relationship.  Pro/E is very smart: If you draw two lines at the same horizontal level, Pro/E thinks 
they are horizontally aligned. Two lines the same length will be constrained as so. 
   

 
Figure 3.6(e) Front View of Drawing Showing Dimensions for the Clamp 
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Click: RMB [Fig. 3.6(f)] ⇒ Centerline [Fig. 3.6(g)] ⇒ pick two positions to create the vertical 
centerline  
 

             
Figure 3.6(f) RMB Options             Figure 3.6(g) Create the Centerline 
   
Click: ⇒ RMB ⇒ Line ⇒ sketch the eight lines of the outline [Fig. 3.6(h)] ⇒ MMB to end the 
line sequence [Fig. 3.6(i)] ⇒ MMB 
 

  
Figure 3.6(h) Sketching the Outline 

 

 
Figure 3.6(i) Default Dimensions Display 
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  Dimensions, Constraints, Grid, and Vertices can be toggled on and off, as needed using the 

toolbar buttons . A sketcher constraint symbol  appears next to the entity 
that is controlled by that constraint. Sketcher constraints can be turned on or off (enabled or 
disabled) while sketching. An H next to a line means horizontal; a T means tangent. Dimensions 
display, as they are needed according to the references selected and the constraints. Seldom are they 
the same as the required dimensioning scheme needed to manufacture the part. You can add, delete, 
and move dimensions as required. The dimensioning scheme is important, not the dimension value, 
which can be modified now or later. 

Place and create the dimensions as required [Fig. 3.6(j)].  Do not be concerned with the 
perfect positioning of the dimensions, but try to, in general, follow the spacing and positioning 
standards found in the ASME Geometric Tolerancing and Dimensioning standards. This saves 
you time when you create a drawing of the part. Dimensions placed at this stage of the design 
process are displayed on the drawing document by simply showing all the dimensions.   

To dimension between two lines, simply pick the lines with the left mouse button (LMB) 
and place the dimension value with the middle mouse button (MMB).  To dimension a single line, 
pick on the line (LMB), and then place the dimension with MMB. 
 

Click: Tools ⇒  Environment ⇒  (it is easier to position the dimensions with 

Snap to Grid off) ⇒ Apply ⇒ OK ⇒ to see a clearer sketch, your may toggle  off ⇒  off 

⇒  off (Note that the textbook leaves these items on) ⇒ RMB ⇒ Dimension ⇒ Add and 
reposition dimensions as needed [Fig. 3.6(j)] 

(To move a dimension – click:   ⇒ pick a dimension ⇒ 
hold down the LMB ⇒ move it to a new position ⇒ release 
the LMB)  

 
If any of the dimension values are light gray in color, they are called weak dimensions. If a weak 
dimension matches your dimensioning scheme, make them strong ⇒ pick on a weak dimension 
value ⇒ RMB ⇒ Strong [Fig. 3.6(j)] 
 

 
Figure 3.6(j) Dimensioned Sketch (your initial dimensions will be different) 
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Next, control the sketch by adding symmetry constraints, click:  Impose sketcher constraints 

on the section ⇒  Make two points or vertices symmetric about a centerline [Fig. 3.6(k)] 
⇒ pick the centerline and then pick two vertices to be symmetric  [Fig. 3.6(l)] ⇒ repeat the 
process and make the sketch symmetrical [Fig. 3.6(m)] ⇒ Close  
 

               
Figure 3.6(k) Constraint       Figure 3.6(l) Adding Symmetry Constraint 
Dialog 
 

 
Figure 3.6(m) Sketch is Symmetrical  
 

You can now modify the dimensions to the design sizes. Your original sketch values will be 
different from the example, but the final design values will be the same. 
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Click:  ⇒ Window-in the sketch (place the cursor at one corner of the window with the LMB 
depressed, drag the cursor to the opposite corner of the window and release the LMB) to capture all 
four dimensions. They will turn red. ⇒ RMB ⇒ Modify ⇒  ⇒   [Fig. 
3.6(n)] ⇒ double-click on length dimension (here it is 660, but your dimension will be different) in 
the Modify Dimensions dialog box and type the design value at the prompt (123) [Fig. 3.6(o)] ⇒ 
Enter ⇒  Regenerate the section and close the dialog ⇒ double-click on another 
dimension and modify the value [Fig. 3.6(p)] ⇒ Enter ⇒ continue until all of the values are 
changed to the design sizes [Fig. 3.6(q)]  
 

  
Figure 3.6(n) Modify Dimensions  

     
Figure 3.6(o) Modify the Dimension             Figure 3.6(p) Modify each Dimension Individually  

 
Figure 3.6(q) Modified Sketch showing the Design Values 
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Click:  ⇒ Standard Orientation [Fig. 3.6(r)] ⇒  on ⇒  Continue with the current 

section [Fig. 3.6(s)]  ⇒  Zoom Out as needed to see the whole object ⇒  ⇒ MMB  
 

 
Figure 3.6(r) Regenerated Dimensions 
 

  
Figure 3.6(s) Completed Sketched Curve (Datum Curve) 
 
 The datum curve (Sketch1) will remain red, active and therefore selected. 
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Click:  Extrude Tool [Fig. 3.7(a)] ⇒ double-click on the depth value on the model ⇒ type 70  

[Fig. 3.7(b)] ⇒ Enter ⇒ place your pointer over the square drag handle  (it will turn black) 

⇒ RMB ⇒ Symmetric [Fig. 3.7(c)] ⇒ MMB [Fig. 3.7(d)] ⇒  ⇒ MMB 
 

 
Figure 3.7(a) Depth of Extrusion Previewed 
 

   
Figure 3.7(b) Modify the Depth Value                               Figure 3.7(c) Symmetric                                                               
 

 
Figure 3.7(d) Completed Extrusion   
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Click: Tools ⇒  Environment ⇒  ⇒ Apply ⇒ OK [Fig. 

3.7(e)] ⇒  ⇒  ⇒ MMB ⇒ File ⇒ Delete ⇒ Old Versions ⇒ MMB ⇒ LMB to deselect 
 

Storing an object on the disk does not overwrite an existing object file. To preserve earlier 
versions, Pro/E saves the object to a new file with the same object name but with an updated 
version number. Every time you store an object using Save, you create a new version of the object 
in memory, and write the previous version to disk. Pro/E numbers each version of an object storage 
file consecutively (for example, box.sec.1, box.sec.2, box.sec.3). If you save 25 times, you have 25 
versions of the object, all at different stages of completion. You can use File ⇒ Delete ⇒ Old 
Versions after the Save command to eliminate previous versions of the object that may have been 
stored.   

When opening an existing object file, you can open any version that is saved. Although 
Pro/E automatically retrieves the latest saved version of an object, you can retrieve any previous 
version by entering the full file name with extension and version number (for example, 
partname.prt.5). If you do not know the specific version number, you can enter a number relative 
to the latest version. For example, to retrieve a part from two versions ago, enter partname.prt.3 
(or partname.prt.-2). 

You use File ⇒ Erase to remove the object and its associated objects from memory. If you 
close a window before erasing it, the object is still in memory. In this case, you use File ⇒ Erase 
⇒ Not Displayed to remove the object and its associated objects from memory. This does not delete 
the object. It just removes it from active memory. File ⇒ Delete ⇒ All Versions removes the file 
from memory and from disk completely. You are prompted with a Delete All Confirm dialog box 
when choosing this command. Be careful not to delete needed files. 

 

 
Figure 3.7(e) Isometric Orientation                   
               
 Next, the cut through the middle of the part will be modeled. 
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Click:  Extrude Tool ⇒ RMB ⇒ Remove Material ⇒ RMB ⇒ Define Internal Sketch 
[Fig. 3.8(a)] ⇒ Use Previous from the Sketch dialog box  [Fig. 3.8(b)] ⇒ Sketch ⇒ 
RMB ⇒ Centerline [Fig. 3.8(c)] ⇒ create a vertical centerline ⇒ RMB ⇒ Line ⇒ sketch the 

seven lines of the open outline [Fig. 3.8(d)] ⇒ MMB ⇒  Impose sketcher constraints on the 

section ⇒  [Fig. 3.6(k)] ⇒ pick the centerline and then pick two vertices to be symmetric 
 ⇒ repeat the process and make the sketch symmetrical ⇒ If you attempt to create too many 

constraints, Pro/E will open the Resolve Sketch dialog box [Fig. 3.8(e)]. Delete the extra symmetric 
constraint if this happens. ⇒ Close 
 

              
Figure 3.8(a) RMB Options    Figure 3.8(b) Sketch Dialog Box                                         Figure 3.8(c) Centerline 
 

 
Figure 3.8(d) Sketch  
 

 
Figure 3.8(e) Resolve Sketch Dialog Box 
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Click:  RMB ⇒ Dimension ⇒ add and reposition dimensions, your values will be different ⇒  
Hidden Line [Fig. 3.8(f)] ⇒ MMB to deselect dimension tool and activate  Select items 
 

 
Figure 3.8(f) Dimensioned Sketch 
 
Window-in the sketch to capture all four dimensions. They will turn red. ⇒ RMB ⇒ Modify ⇒ 

 ⇒ modify the values [Fig. 3.8(g)] ⇒  [Fig. 3.8(h)] 
 

  
Figure 3.8(g) Modified Dimensions Dialog Box  
 

 
Figure 3.8(h) Modified Sketch Dimensions  
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Click:  Shading ⇒  ⇒ Standard Orientation ⇒  ⇒ note the yellow direction arrow 

⇒  Zoom Out ⇒ Options from the Dashboard ⇒ Side 1 ⇒  ⇒ Through All [Fig. 3.8(i)] ⇒ 

Side 2 ⇒  ⇒ Through All [Fig. 3.8(j)] ⇒ MMB [Fig. 3.8(k)] ⇒  ⇒  ⇒ MMB ⇒ LMB 
 

     
Figure 3.8(i) Options Side 1                                                Figure 3.8(j) Options Side 2 
 

 
Figure 3.8(k) Completed Cut 
 

The next feature will be a 20 × 20 centered cut (Fig. 3.9).  Because the cut feature is 
identical on both sides of the part, you can mirror and copy the cut after it has been created.  
 

 
 Figure 3.9 Top View of Drawing 
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Create the cut, click:  Extrude Tool ⇒  from the Dashboard ⇒  
Sketch dialog box opens ⇒ Sketch Plane--- Plane: select TOP datum from the model as the sketch 
plane [Fig. 3.10(a)] ⇒  ⇒ pick the left edge of the part to add it to the References 

dialog box [Fig. 3.10(b)] ⇒ click Close to accept the References ⇒ Tools ⇒  Environment ⇒ 

 ⇒ OK 
 

  
Figure 3.10(a) Sketch Plane Selection and Sketch Dialog Box 
 

  
Figure 3.10(b) Add the left edge/surface of the part to the References Dialog Box 
 

Click:  Hidden Line ⇒ RMB ⇒ Centerline ⇒ create a horizontal centerline through the center 
of the part ⇒ RMB ⇒ Line ⇒ place the mouse on the left edge and create three lines [Fig. 3.10(c)] 

⇒ MMB to end the line sequence [Fig. 3.10(d)] ⇒  Impose sketcher constraints on the 

section ⇒  ⇒ pick the centerline and then pick two vertices to be symmetric add the required 
dimensions ⇒ MMB ⇒ MMB ⇒ move and modify the values for the two dimensions (20 X 20) 

[Fig. 3.10(e)] ⇒  ⇒  ⇒ Standard Orientation ⇒ from the dashboard  Remove 

Material ⇒ Options tab ⇒  ⇒  Through All (Extrude in first direction to interest with 

all surfaces) [Fig. 3.10(f)] ⇒  ⇒  ⇒  Shading ⇒ rotate your model using MMB to 

see the cut clearly  [Fig. 3.10(g)] ⇒  ⇒ MMB 
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Figure 3.10(c) Three Line Sketch          Figure 3.10(d) Default Dimensions         Figure 3.10(e) Modified Values  

 
Figure 3.10(f) Options Through All  

  
Figure 3.10(g) Completed Second Cut 
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Click:  ⇒ Standard Orientation ⇒ with the new cut still highlighted [Fig. 3.11(a)], click:  
Mirror Tool ⇒ select the RIGHT datum plane from the Model Tree [Fig. 3.11(b)] ⇒ MMB [Fig. 
3.11(c)] ⇒ File ⇒ Save ⇒ MMB ⇒ MMB rotate part [Fig. 3.11(d)] ⇒ File ⇒ Close Window 
 

 
Figure 3.11(a) Extruded Cut is Highlighted (Selected)   

 
Figure 3.11(b) Select the RIGHT Datum Plane as the Mirroring Plane  

        
Figure 3.11(c) Mirror Cut                        Figure 3.11(d) Completed Part  

Lesson 3 is now complete. If you wish to model a project without instructions, a complete 
set of projects and illustrations are available at www.cad-resources.com ⇒ Downloads. 
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NOTES: 
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