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Exercise 1 
 

Sensitivity and Optimization Studies 

 

Introduction 

 

The purpose of the optimisation study is to help the designer in optimizing predetermined 

design parameters as a function of known measures, such as Von Mises stress or 

maximum displacement for a specific goal (i.e. minimise total mass).  Your knowledge of 

stress analysis comes in handy here, as the software cannot do all the work in the 

optimisation process.  There are a few more tasks involved than just clicking the 

“optimize my model” button. Consequently, the designer has to take the optimization 

from the start to a certain stage, and then let the software (Pro/MECHANICA
®

) take over 

for the final optimization steps.   

 

An optimization study is divided into two main phases: 

 

• Design phase I uses a static analysis combined with local sensitivity and global 

sensitivity studies in Pro/MECHANICA
®

.  In this phase, the finite element analyst 

uses Pro/ENGINEER
®

 WILDFIRE to set design parameters.  A design parameter is 

used by the Pro/MECHANICA
®

 studies as a variable for measures.  The measures 

also have to be determined by the analyst. 

 

1. The main objective of a local sensitivity study is to look at changes of the 

measures (most likely Von Mises stress) for small variations of each design 

parameter (+ 1%) independently. 

2. The objective of the global sensitivity study is to look at the variations of all 

parameters, within their respective range, into each step of the process as defined 

by the user. 

 

• Design phase II completes the optimization of the part according to your design 

objectives (goals).  All parameters are optimised concurrently.  A goal could be to 

minimise the total mass or the total costs of a model.  There are also other goals that 

can be defined in the optimization study. 

 

Estimated time: 2 hours
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In Pro/ENGINEER
®
 WILDFIRE          In Pro/MECHANICA

®
  

 

 

Start 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Figure 1: Overview of Design Optimization Study 

 

 

 

As you can appreciate, an optimization study is a lot of work.  So let’s get right to it. 

 

Create part, 

features & set 

parameters 

Create FEA modelling 

entities (shells) 

Assign design 

parameters 

Assign boundary 

conditions to model 

Create and Run a local sensitivity 

study. (Then analyse results) 

Set up and run an optimization 

study (determine goal) 

Create and Run a global sensitivity 

study. (Then analyse results) 
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Overview 

 

This exercise will demonstrate the know-how and uses of sensitivity, global and 

optimization studies in Pro/MECHANICA
®

.  A simple plate with two circular notches 

will be used for the model.  A shell mid-plane compression idealisation will be used to 

model the plate for FEA and a combination of triangular and quadrilateral shell elements 

will be used for the mesh.  The procedure is as follows: 

 

1. Create (Open) the part in Pro/ENGINEER
®

 WILDFIRE and create the shell mid-

plane compression idealisation in Pro/MECHANICA
®

; 

2. Create the mesh and boundary conditions (loads and constraints); 

3. Run an analysis (quick check) to make sure that the model converges to a solution; 

while establishing a preliminary goal, with respect to a measure (Von Mises stress); 

4. Set up design parameters for the preliminary design study; 

5. Run a local sensitivity study and select parameters that have an effect on the measures 

pre-determined; 

6. Run a global sensitivity study on selected parameters and find the parameter value 

(maximum or minimum) that has the greatest effect on the measure; 

7. Run an optimization study for the above parameters, setting the starting point of the 

study using the findings of point #6 above.  Optimize for your design objective(s).  

The design objective for this case is to minimise the mass of the plate. 

 

The following figure shows the model that will be used for the study.  It is a simple plate 

with two notched cuts located 6 in. from the left end.  The loads are applied at the tip of 

the right end of the plate, while the left end is constrained. 
 

 
Figure 2: Notched Cantilever Plate 

500 lbs 

500 lbs 
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Our design objective is to optimize the location and radius of the notch with respect to the 

left end of the plate.  We will also look at plate thickness and optimize all three 

parameters above for the total mass, using the Von Mises stresses as the measure.   

 

Procedure 

 

Phase 1: Preliminary Optimization Work 
 

Please refer to the model represented in Figure 2.  It is a flat bar made of steel.  Even 

though a simple model, it will illustrate the entire procedure of the optimization study.  

First, it is important to understand what our objectives are for the optimization study, as it 

may help you understand better each step involved in the process.  Consequently, let’s 

define our objectives and determine the measure to be studied for the selected design 

parameters.  Table 1 gives an overview of the objectives for this study. 

 

TABLE 1: OPTIMIZATION OBJECTIVES, MEASURES AND DESIGN PARAMETERS 
 

Design Parameters to be optimized 
Optimization 

Goal 

Measure to 

be used for 

optimization 
Name Description Initial value (in.)

 

Cut_length 

                 

 

Dimension from 

left edge to cut 

 

 

      6 

Cut_radius Notch radius .25 

 

Minimise 

weight of the 

part 

 

Von Mises 

stress 

thickness Plate thickness      .25 
 

 

It is important to keep the above objective, design parameters and measure(s) in mind as 

we move through the procedures of the optimization study. 

 

Part A: Building the Model and the Design Parameters 

 

Before you start the procedures below, create a directory named ‘opt_study’ using 

Microsoft Explorer
®

.  Move the part named notch_flatbar.prt to that directory. 

 

1. Start up Pro/ENGINEER® WILDFIRE 

 

Details on how to do this are different from system to system.  For a typical Windows 

platform, select Start > Programs > Proewildfire.   

(It takes 30 seconds approximately for Pro/ENGINEER
®

 to start.) 

 

Set up your working directory. (File > Set Working Directory) 

Select your working directory ‘opt_study,’ then click on Accept. 
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2. Open the Following Part: notched_flatbar  
 

Once open, the following part should appear on your screen. 

 

 
 

Figure 3: Notch_flatbar.prt (bar dimensions:  3″ X 12″ X 1/4″) 

 

 

3. Modifying Dimension Cosmetics 
 

Before we go to Pro/MECHANICA
®

, we will modify the dimension cosmetics in 

Pro/ENGINEER
®

 WILDFIRE for ease of recognising each optimized design parameter 

during the process.  From the model tree, select NOTCH_CUT and right mouse click on 

it to select Edit. At this time the dimensions for the feature should show up on the screen.  

From the filter at the bottom right corner of the screen, select Dimensions. 

 

Select the R.25 dimension and right mouse click on it to select Properties.  From the 

window that comes up (see Figure 4), change the dimension text name to cut_radius. 
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Figure 4 

 

Select OK.  Repeat same procedure as above for the 6.00 dimension.  This time change 

the dimension text name to cut_length as shown below. 

 

 
 

Figure 5 

 

Select OK.  Edit the feature FLAT_BAR by selecting it from the model tree, right click 

on it and select Edit.  Change the .25 dimension text name as shown in Figure 6 to 

thickness. 
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Figure 6 

 

Select OK.  

 

This completes the Pro/ENGINEER
®

 WILDFIRE portion of the exercise.  Next we go to 

Pro/MECHANICA
®

. 

 

4. Creating Shell Mid-surface Compression 
 

Select Applications > Mechanica > Continue.  Then from the right menu select 

Structure > Model > Idealizations > Shells > Midsurface > New.  

 

Holding down the CTRL key, select one of the plate faces, and then select the other face 

(then release the CTRL key and middle button mouse click).  To make sure that the 

compression of the shells works, select Compress > Shells Only > Show Compress, and 

you should see the yellow colour contour of the part on the screen as shown in Figure 7. 
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Figure 7: Notched plate shell model 
 

Select Done-Return > Done Return. 

 

5.   Assign Materials 
 

The plate is made of standard ASTM A-36 steel (36 ksi yield strength).  Select Materials 

and the following window will come up. 
 

 
 

Figure 8 
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Select Steel from the left column and click on the arrow to move in under the Materials 

in Model column.  Click on Assign > Parts and select the plate. Click on the middle 

mouse button to accept.  Click on Close. 

 

6.  Meshing of the Part 
 

We will keep the all default shell elements and settings that AutoGEM will create.  Select 

AutoGEM from the right menu, the following dialog box comes up on your screen. 

 

  
 

Figure 9 

 

Select Create.  The following confirmation of elements box should come up after about 

five seconds. 

 

 
 

Figure 10 
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Note that five triangular and eight quadrilateral elements have been created.  Select 

Close.  Use the display setting to shrink all elements to ten.  Your window should then 

look as follows: 

 

 
 

Figure 11: Meshed Notched Plate 

 

The mesh looks adequate for further analysis.  Select Close and answer Yes to saving the 

mesh. 
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7. Assignment of Boundary Conditions to the Model 
 

7.1 Loads 
 

The end load has 500 lbs in both the X and Y directions, as shown in 

an earlier figure.  We will set this load as and edge load.  Create the 

following Curve/Edge loads and constraints on the part.  

 

Select Loads > New > Edge-Curve or click on the corresponding 

icon.  Enter information as seen below. 

 

 
 

                    
                  

Figure 12: Force/Moment Definition Box 

 

 

Note: For reference-curves, click on the arrow  and select the right vertical edge 

from the model. 

 

Select OK.  Set simulation display to Tails Touching.  The model should now appear 

as shown in Figure 13. 
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Figure 13:  Notched Plate showing end load 
 
 

 
 

7.2 Constraints 
 

The plate is basically a cantilever beam with the left end being fixed.  To 

apply the end constraints, select Model > Constraints > New > Edge-

Curve or click on the corresponding icon. 

 

This edge for loads 
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Fill in and select the appropriate information from the dialog box below. 

 

 
 

Figure 14: Constraint Definition Box 

 

Note: For reference-curves, click on the arrow    and select the left vertical edge 

from the model. 
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Keep all DOF fixed (translations and rotations).  Select OK. The plate FEA model 

should now look as follows: 

 

 
 

Figure 15: Boundary conditions of the notched plate. 

 

 

8. Create the Static Analysis 
 

8.1 Quick Check 
 

Create and run a quick check-no convergence analysis named static_1 (see from 

below) to make sure that you can get to a solution.  Select Analyses/studies so the 

corresponding dialog box comes up.  Then File > New Static and enter information 

as shown in Figure 16. 

This edge for constraints 
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Figure 16 
 

Select OK.  Then select the analysis and right mouse click on it to select Start.  

Answer Yes to “Do you want error detection?”  Right mouse click to Status and 

make sure that you can get to a solution.  Once the run is completed, double-check 

your analysis results with the figure below: 
 

 
 

Figure 17: Status summary File (quick check) 

 

Select Close. 
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 STOP 

You will know that the model completed the solution by seeing Run Completed at the 

bottom of the summary file.  Results are not important at this point, we just want to make 

sure that the model can get to a solution. 

 
 

8.2 Multi-pass Adaptive Convergence 
 

Next edit the quick check analysis by right mouse clicking on it and selecting Edit.  

Enter the information as seen in the box below.  

 

 
 

Figure 18: Static Analysis Definition (Multi-Pass Adaptive) 

 

Select OK then Run the analysis.  Answer Yes to “Do you want error detection?”  

Select Status and make sure that you can get to a solution by showing Run 

Completed at the bottom of the status window. 

 

The solution converges within 10 percent in three passes.  Check your status window 

with the one shown in Figure 19. 
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Figure 19: Status Summary File 

 

8.3  Results of Static Analysis 
 

Check the results and record the max Von Mises stress off the summary window.  

The analysis should converge after six passes and the VM stress results should be 

around   1.86 X 10
4
 psi   Select Close > Close.  Select Results and create the 

maximum Von Mises stress definition sheet as follows: 

 

Click on this icon named “Insert a new definition.” 

 

 
 

Figure 20 
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Fill out result definition window as follows: 
          

                        Figure 21: a) Quantity Tab                                      b) Display Options Tab 

 

Select OK and Show. Animate the part to make sure that it behaves as we would 

expect it to, given the current loads and constraints.   
 

 
 

Figure 22: Static Analysis Von Mises Stress results 

Movement 

direction is 

down and 

to the right. 
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Once you are satisfied, Select File > Exit Results > No. 

 

 STOP 

Important: We must make sense of the above results before we go to the optimization.  

Ask yourself the following question: 
 

• Are the maximum VM stresses above the material design stress that we want to use? 

Say (Sy/1.5) for static?  If they are, there is no need really for an optimization study 

to minimise weight right?   
 

But let’s say that we want to use steel with (Sy =  36 ksi). 

Then our design stress is 36/1.5 = 24 ksi. 
 

The difference in value of (24 ksi  - our results  18.6  =  5.4 ksi) is an important design 

criteria.  If this number is greater than 1 and less than 10 ksi, then this leaves us some 

room for weight optimization using this material, without wasting our time.  

 

Note that phase 1 of the optimization demands a lot out of the user (from knowledge 

and experience).  The software cannot make the preliminary design decisions for us. 

For instance, we may want to change the thickness of the plate, say 5/16″ and rerun 

the analysis to give us some more room to maneuver from an optimization standpoint.  

For the sake of this example, let’s keep the thickness at 1/4″. 

 

 

Procedure 

 
Part B: Local Sensitivity Study 
 

 

Recall:  

 

• The objective of a local sensitivity study is to look at small changes of the measures 

(in our case Von Mises stresses) for small independent variations of each design 

parameters used (+ 1 to 2%). 

• Our design parameters for this study, as defined earlier in Pro/ENGINEER
®

 

WILDFIRE are plate thickness, the cut location with respect to the left edge and the 

cut radius. 

 

 

1. From the Pro/MECHANICA
®

 menu select Model > Dsgncontrols > Design 

Params > Create and select the type Dimension as shown below.  
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Figure 23 

 

2. Click on Select and click on the cut (notch).  Select the .25″ radius of the cut and 

enter the text shown below.  Note the values entered for the minimum and 

maximum are set at approximately plus and minus a few percent only of the 

nominal value as we are only interested at this stage in the effect of the small 

changes of the parameter on VM stress or how ‘sensitive’ the parameter is to the 

measure.   

 

Figure 24: Design Parameter 1 Definition 

 

Click on Accept. 

 

3. Repeat same procedure for the cut_length and plate thickness (see below for values 

to be entered).   
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• For cut length, select the 6″ dimension and enter 5.9 and 6.1 for the 

minimum and maximum values as shown below.   
 

 
 

Figure 25: Design Parameter 2 Definition 

 

• For the thickness, select the .25 inch dimension and enter .24 and .26 for 

minimum and maximum values as shown below.   

 

 
 

Figure 26: Design Parameter 3 Definition 

 

Click on Accept once all parameters have been defined. The design parameters 

window should look as shown in Figure 27. 
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Figure 27 

 

Click on Done when completed. 

 

4. To make sure of the effect of our parameters. Play around with the Shape Animate 

under the dsgncontrols menu.  Select the Parameter Cut Length and change the 

minimum and maximum values to 4 and 8 (as seen below).   

 

 
 

Figure 28: Shape Animation Definition Window 
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5. Click on Animate and answer Yes to all the prompts. At the same time, check the 

movement of the feature on the screen.  Repeat procedure for each parameter 

independently or animate as a group. 

 

6. Once completed with the animation of the parameters, select Done from the animate 

window. 

 

7. Create a design study as shown below.  Select Analyses/Design Studies.  Select 

File > New Design Study.  Make the following selections for the study: 

 

• Select local sensitivity study from the analysis menu and name it: 

loc_sens_stud1.   

• Check off all three parameters previously defined.   

• For settings, select the nominal dimension value for each of our 

previously defined parameter in Pro/ENGINEER
®

 WILDFIRE  

i.e. 6″, .25″ and .25″.   

• Select static_1 under analysis. 

 

 
 

Figure 29: Design Study Definition Window 

 

Select Accept. 
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8. Run the local sensitivity created above.  With the design study selected, click on 

Run. 

 

 
 

Figure 30 

 

 

Answer Yes to “Do you want error detection?”  It takes approximately two to 

three minutes for the analysis to complete.  Verify your status window to the one 

below shown below: 

 
Begin Sensitivity Analysis, Parameter: cut_radius 
 

Static Analysis "notch_plate_static": 

 

   Convergence Method: Multiple-Pass Adaptive 

   Plotting Grid:      4 

 

         Calculating Element Equations           (19:29:54) 

            Total Number of Equations:     492 

            Maximum Edge Order:              3 

         Solving Equations                       (19:29:58) 

         Post-Processing Solution                (19:29:59) 

         Calculating Disp and Stress Results     (19:30:04) 

 

         RMS Stress Error Estimates: 

 

         Load Set            Stress Error     % of Max Prin Str  

         -------------        ---------------    ------------------------ 

         LoadSet1           4.27e+03        21.2% of  2.02e+04 

 

         Resource Check                          (19:30:06) 

            Elapsed Time     (sec):     482.15 

            CPU Time         (sec):       6.95 

            Memory Usage      (kb):     167396 

            Wrk Dir Dsk Usage (kb):          0 

 

Analysis "notch_plate_static" Completed  (19:30:06) 

 

Derivatives of Measures for Analysis: notch_plate_static 

With Respect to Parameter: cut_radius 

 

      total_cost:        0.000000e+00 

      total_mass:       -1.132648e-01 

      com_x:             2.960725e-08 

      com_y:            -5.787104e-09 

      com_z:             0.000000e+00 

      inertia_xx:       -2.033609e-01 

      inertia_xy:        3.912722e-08 

      inertia_xz:        0.000000e+00 

      inertia_yy:       -3.683823e-03 
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      inertia_yz:        0.000000e+00 

      inertia_zz:       -2.070448e-01 

 

   Load Set: LoadSet1 

 

      max_beam_bending:  0.000000e+00 

      max_beam_tensile:  0.000000e+00 

      max_beam_torsion:  0.000000e+00 

      max_beam_total:    0.000000e+00 

      max_disp_mag:      1.432914e-05 

      max_disp_x:        3.515730e-06 

      max_disp_y:       -1.391126e-05 

      max_disp_z:        0.000000e+00 

      max_prin_mag:      2.998970e+04 

      max_rot_mag:       2.394071e-06 

      max_rot_x:         0.000000e+00 

      max_rot_y:         0.000000e+00 

      max_rot_z:        -2.394071e-06 

      max_stress_prin:   2.998970e+04 

      max_stress_vm:     2.950060e+04 

      max_stress_xx:     2.971161e+04 

      max_stress_xy:    -1.168241e+04 

      max_stress_xz:     0.000000e+00 

      max_stress_yy:    -2.327032e+02 

      max_stress_yz:     0.000000e+00 

      max_stress_zz:     0.000000e+00 

      min_stress_prin:  -2.324522e+04 

      strain_energy:     3.496831e-03 

 

 

Begin Sensitivity Analysis, Parameter: cut_length 
 

Static Analysis "notch_plate_static": 

 

   Convergence Method: Multiple-Pass Adaptive 

   Plotting Grid:      4 

 

         Calculating Element Equations           (19:54:04) 

            Total Number of Equations:     492 

            Maximum Edge Order:              3 

         Solving Equations                       (19:55:07) 

         Post-Processing Solution                (19:55:45) 

         Calculating Disp and Stress Results     (19:56:41) 

 

         RMS Stress Error Estimates: 

 

         Load Set          Stress Error         % of Max Prin Str 

         -------------       ---------------       ------------------------ 

         LoadSet1         4.34e+03            21.9% of  1.98e+04 

 

         Resource Check                          (19:58:47) 

            Elapsed Time     (sec):    2200.55 

            CPU Time         (sec):      10.02 

            Memory Usage      (kb):     168484 

            Wrk Dir Dsk Usage (kb):          0 

 

Analysis "notch_plate_static" Completed  (19:59:49) 

 

Derivatives of Measures for Analysis: notch_plate_static 

With Respect to Parameter: cut_length 

 

      total_cost:        0.000000e+00 
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      total_mass:        6.043610e-10 

      com_x:            -5.484068e-03 

      com_y:            -1.227412e-09 

      com_z:             0.000000e+00 

      inertia_xx:       -4.448353e-09 

      inertia_xy:       -8.720819e-09 

      inertia_xz:        0.000000e+00 

      inertia_yy:       -1.387973e-04 

      inertia_yz:        0.000000e+00 

      inertia_zz:       -1.388018e-04 

 

   Load Set: LoadSet1 

 

      max_beam_bending:  0.000000e+00 

      max_beam_tensile:  0.000000e+00 

      max_beam_torsion:  0.000000e+00 

      max_beam_total:    0.000000e+00 

      max_disp_mag:     -5.465288e-07 

      max_disp_x:       -2.288639e-08 

      max_disp_y:        5.525955e-07 

      max_disp_z:        0.000000e+00 

      max_prin_mag:     -2.787973e+03 

      max_rot_mag:       3.250554e-08 

      max_rot_x:         0.000000e+00 

      max_rot_y:         0.000000e+00 

      max_rot_z:        -3.250554e-08 

      max_stress_prin:  -2.787973e+03 

      max_stress_vm:    -2.936599e+03 

      max_stress_xx:    -2.902010e+03 

      max_stress_xy:     4.588746e+02 

      max_stress_xz:     0.000000e+00 

      max_stress_yy:     4.885327e+01 

      max_stress_yz:     0.000000e+00 

      max_stress_zz:     0.000000e+00 

      min_stress_prin:   4.651636e+03 

      strain_energy:    -1.340397e-04 

 

 

Begin Sensitivity Analysis, Parameter: thickness 
 

Static Analysis "notch_plate_static": 

 

   Convergence Method: Multiple-Pass Adaptive 

   Plotting Grid:      4 

 

         Calculating Element Equations           (20:07:32) 

            Total Number of Equations:     492 

            Maximum Edge Order:              3 

         Solving Equations                       (20:07:40) 

         Post-Processing Solution                (20:07:42) 

         Calculating Disp and Stress Results     (20:07:43) 

 

         RMS Stress Error Estimates: 

 

         Load Set         Stress Error         % of Max Prin Str 

         ------------       ---------------       ------------------------  

         LoadSet1        4.18e+03            21.9% of  1.91e+04 

 

         Resource Check                          (20:07:45) 

            Elapsed Time     (sec):    2741.65 

            CPU Time         (sec):      12.50 

            Memory Usage      (kb):     168484 
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            Wrk Dir Dsk Usage (kb):          0 

 

Analysis "notch_plate_static" Completed  (20:07:47) 

 

Derivatives of Measures for Analysis: notch_plate_static 

With Respect to Parameter: thickness 

 

      total_cost:        0.000000e+00 

      total_mass:        1.012423e+01 

      com_x:            -3.509118e-14 

      com_y:            -2.488438e-15 

      com_z:             0.000000e+00 

      inertia_xx:        7.526698e+00 

      inertia_xy:        2.972349e-08 

      inertia_xz:        0.000000e+00 

      inertia_yy:        1.221562e+02 

      inertia_yz:        0.000000e+00 

      inertia_zz:        1.296829e+02 

 

   Load Set: LoadSet1 

 

      max_beam_bending:  0.000000e+00 

      max_beam_tensile:  0.000000e+00 

      max_beam_torsion:  0.000000e+00 

      max_beam_total:    0.000000e+00 

      max_disp_mag:     -1.897407e-04 

      max_disp_x:       -3.682606e-05 

      max_disp_y:        1.861326e-04 

      max_disp_z:        0.000000e+00 

      max_prin_mag:     -7.643958e+04 

      max_rot_mag:      -2.339174e-05 

      max_rot_x:         0.000000e+00 

      max_rot_y:         0.000000e+00 

      max_rot_z:         2.339174e-05 

      max_stress_prin:  -7.643958e+04 

      max_stress_vm:    -7.167290e+04 

      max_stress_xx:    -7.621604e+04 

      max_stress_xy:     1.593076e+04 

      max_stress_xz:     0.000000e+00 

      max_stress_yy:    -1.764033e+04 

      max_stress_yz:     0.000000e+00 

      max_stress_zz:     0.000000e+00 

      min_stress_prin:   6.959613e+04 

      strain_energy:    -4.719402e-02 

 

Use Results to plot measures. 

 

------------------------------------------------------------ 

 

Memory and Disk Usage: 

 

   Machine Type: Windows NT/x86 

   RAM Allocation for Solver (megabytes): 128.0 

 

   Total Elapsed Time (seconds): 2776.18    

   Total CPU Time     (seconds): 13.40      

   Maximum Memory Usage (kilobytes): 168484     

   Working Directory Disk Usage (kilobytes): 0          

   Total Elapsed Time in Parameter Updates (seconds): 

      1420.12    

   Total Engine Elapsed Time Minus Param. Updates (seconds): 

      1356.06    
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   Total CPU Time in Parameter Updates (seconds): 

      1.58       

   Total Engine CPU Time Minus Param. Updates (seconds): 

      11.82      

 

   Results Directory Size (kilobytes): 

   386 .\loc_sens_study1 

 

------------------------------------------------------------ 

Run Completed 

Sat Apr 05, 2003   20:08:23 

------------------------------------------------------------ 

 
Figure 31: Status Summary File for local sensitivity study (partial) 

 

 

9. Select Close > Close.  Select Results and create the maximum Von Mises stress 

definition sheet as follows: 

 

Click on this icon named “Insert a New Definition.” 

 

 
 

Figure 32 

 

Let’s create results graph plotting each design parameter versus the Von Mises stress 

measure.  Under results, create three windows, one for each parameter defined. 

Name the first result window the following: Vm_thickness.  Fill out and make the 

appropriate selections as shown. 
 

 

 
 

Figure 33: Result Window Definition (Thickness) 
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10. Next, select maxvmstress as a measure and select Design Var from the Graph 

location.  Click on the Select (colored icon) from the quantity row and select 

max_stress_vm as shown below: 

 

 
 

Figure 34 

 

 

 



Copyrighted 
Material 

 
Copyrighted 

Material 
 

Copyrighted 
Material 

 
Copyrighted 

Material 

PRO/MECHANICA STRUCTURE:  ELEMENTS AND APPLICATIONS  

 

 30

Select Accept.  Click on the Arrow Icon and select the parameter thickness as 

shown: 

 

 
 

Figure 35 

 

Select Accept and OK.  Repeat the procedure above to create two additional result 

graphs as shown below. 

 

 
 

Figure 36: Result Window Definition (Cut length) 
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Select OK.  Create a new result window as shown: 

 

 
 

Figure 37: Result Window Definition (Cut radius) 

 

Select OK.  Select View > Display and select all three windows as shown: 

 

 
 

Figure 38 

 

Select OK.  The three result graphs should come up on your screen. 

 

 

11. Look at the three graphs in Figure 39. To understand the results, look at the 

variation of the VM stress versus each parameter.  Establish the relationship 

between each measure and the Von Mises stresses. 
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Figure 39: Local Sensitivity Study Parameter Results 

 

 

12. Analyse how sensitive each parameter is to the Von Mises stresses.  With the results 

shown, you should come to the following conclusions:  

 

That the VM stress is sensitive to all parameters. 

 

 

This was the main objective of the local sensitivity study.  We will carry all three 

parameters into the next phase.  Please note that should the VM stress not be sensitive to 

one of the parameters, we would not carry it on any further in the optimization study.  

Select File > Exit Results > No. 
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Procedure 
 
Part C: Global Sensitivity Study 
 

Recall: 

The objective of the global sensitivity study is to look at the variations of all 

parameters into each step of the process as defined by the user. 

 

 

1. In Pro/MECHANICA
®

, go back to Dsgn Controls > Design Parameters and the 

following window should come up on your screen. 

 

 
 

Figure 40 

 

Select Review.  Review each parameter and change the minimum and maximum 

values to the following magnitudes. 

 

Note: In practice, the designer would set these values as he has an understanding of 

the model by now. 
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To modify the parameter cut length, select cut_length > Review.  The following 

window will come up: 

 

 
 

Figure 41 

 

Modify minimum values to 4 and 6 as shown.  Click on Accept.  Repeat procedure 

for the other design parameters, values to be entered are shown in the following 

table: 

 

TABLE 2: DESIGN PARAMETERS 
 

Design parameter Minimum Current Maximum 

Cut_length (in.) 4 6 8 

Thickness (in.) .135 .25 .375 

Cut_radius (in.) .1 .25 .5 
 

 

Click on Done when you have completed all design parameters. 

 

2. Next, create a design study called:glob_sens_stud1.  Select Analyses/Design Studies 

and fill out the design study sheet as shown with the following settings: 

 

• Select global sensitivity under type. 

• Under analysis, select anlys_1 (static). 

• For the parameters: set as seen on the figure below. 

• Set the number of intervals to six for this analysis. 

• Do not check repeat P-loop convergence for this analysis (saves time). 
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Figure 42 

 

Note that the minimum and maximum values are set to minimize the plate weight as 

the study progresses according to the results of the local sensitivity study: 

loc_sens_stud1. Select Accept. 
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3.   Run the design study by selecting the design study and click on Run. (Answer Yes to 

“Do you want error detection?”)  It takes approximately five to six minutes.  Take a 

well-deserved break.  If you want to follow the analysis, click on the status icon: 

 

 
 

Figure 43: Status Summary File (global sensitivity study) 
 

Once the analysis is completed, check the last step (step 11) with the partial status 

file below: 

 
Sensitivity Step 11 of 11 

 

Parameters: 

   cut_radius                 0.5 

   cut_length                   8 

   thickness                0.135 

 

Static Analysis "notch_plate_static": 

 

   Convergence Method: Multiple-Pass Adaptive 

   Plotting Grid:      4 

 

   Convergence Loop Log:                         (21:49:36) 

 

   >> Pass  1 << 

         Calculating Element Equations           (21:49:36) 

            Total Number of Equations:     330 

            Maximum Edge Order:              1 

         Solving Equations                       (21:49:37) 

         Post-Processing Solution                (21:49:37) 

         Calculating Disp and Stress Results     (21:49:37) 

         Checking Convergence                    (21:49:37) 

            Elements Not Converged:         51 

            Edges Not Converged:           107 

            Local Disp/Energy Index:    100.0% 

            Global RMS Stress Index:    100.0% 
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         Resource Check                          (21:49:37) 

            Elapsed Time     (sec):    2951.92 

            CPU Time         (sec):      59.03 

            Memory Usage      (kb):     166628 

            Wrk Dir Dsk Usage (kb):       2048 

 

   >> Pass  2 << 

         Calculating Element Equations           (21:49:38) 

            Total Number of Equations:     966 

            Maximum Edge Order:              2 

         Solving Equations                       (21:49:38) 

         Post-Processing Solution                (21:49:38) 

         Calculating Disp and Stress Results     (21:49:38) 

         Checking Convergence                    (21:49:39) 

            Elements Not Converged:         33 

            Edges Not Converged:           106 

            Local Disp/Energy Index:    100.0% 

            Global RMS Stress Index:     67.3% 

         Resource Check                          (21:49:39) 

            Elapsed Time     (sec):    2953.28 

            CPU Time         (sec):      60.14 

            Memory Usage      (kb):     166628 

            Wrk Dir Dsk Usage (kb):       2048 

 

   >> Pass  3 << 

         Calculating Element Equations           (21:49:39) 

            Total Number of Equations:    1734 

            Maximum Edge Order:              3 

         Solving Equations                       (21:49:39) 

         Post-Processing Solution                (21:49:40) 

         Calculating Disp and Stress Results     (21:49:40) 

         Checking Convergence                    (21:49:41) 

            Elements Not Converged:          0 

            Edges Not Converged:             0 

            Local Disp/Energy Index:      7.6% 

            Global RMS Stress Index:      4.5% 

         RMS Stress Error Estimates: 

         Load Set        Stress Error      % of Max Prin Str 

         ------------       ------------       ----------------------- 

         LoadSet1        3.74e+03      12.0% of  3.12e+04 

         Resource Check                          (21:49:41) 

            Elapsed Time     (sec):    2955.73 

            CPU Time         (sec):      61.43 

            Memory Usage      (kb):     166628 

            Wrk Dir Dsk Usage (kb):       2048 

   The analysis converged to within 10% on 

   edge displacement, element strain energy, 

   and global RMS stress. 

Analysis "notch_plate_static" Completed  (21:49:42) 

Completed Global Sensitivity Study 

Use Results to plot measures. 

------------------------------------------------------------ 

Memory and Disk Usage: 

   Machine Type: Windows NT/x86 

   RAM Allocation for Solver (megabytes): 128.0 

   Total Elapsed Time (seconds): 2956.72    

   Total CPU Time     (seconds): 61.84      

   Maximum Memory Usage (kilobytes): 166628     

   Working Directory Disk Usage (kilobytes): 2048       

   Total Elapsed Time in Parameter Updates (seconds): 

      2647.64    

   Total Engine Elapsed Time Minus Param. Updates (seconds): 
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      309.08     

   Total CPU Time in Parameter Updates (seconds): 

      4.88       

   Total Engine CPU Time Minus Param. Updates (seconds): 

      56.96      

   Results Directory Size (kilobytes): 

   789 .\glob_sens_stud_stat1 

   Maximum Data Base Working File Sizes (kilobytes): 

   2048 .\glob_sens_stud_stat1.tmp\kel1.bas 

------------------------------------------------------------ 

Run Completed 

Sat Apr 05, 2003   21:49:43 

------------------------------------------------------------ 
 

Figure 44: Status Summary File (Partial) – Global Sensitivity Study 

 

Select Close > Close. 

 

 

Results 
 

Select Results and create the maximumVon Mises stress definition sheet as follows: 

 

Click on this icon named ‘Insert a new definition.’ 

 

 
 

Figure 45 

 

Create and show the design parameter graphs, similar to the ones for the local sensitivity 

study.  The three result windows are presented below. 
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Figure 46: Result Window Definition (Thickness) 

 

The first result window is titled: vm_thickness_gss.  Fill out the definition sheet as shown 

above, then select OK.  Create a second result definition window as follows. 

 

 
 

Figure 47: Result Window Definition (Cut length) 

 

The second result window is titled: vm_stress_cut_length_gss.  Fill out definition sheet as 

shown above, then select OK.  Similarly, create a third definition window titled: 

VM_cut_radius_gss.  Select the radius as the design variable and select OK.  Select View 

> Display and select all three windows as in Figure 48. 
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Figure 48 

 

Select OK.  The three result graphs should come up on your screen as shown below. 

 

 
 

Figure 49: Local Sensitivity Study Results 

 

The intent here is to find the best combination of parameters that will be carried on to the 

final optimization study. What conclusions do you come to with regards to each design 

parameter as a function of our measure (the Von Mises Stress)? 
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Your conclusion looking at the results above should be the following. That for minimum 

VM stress, we need the following: 

 

• maximum thickness, 

• maximum cut length and; 

• minimum cut radius. 

 

I know, these results may be evident to us as strength of material experts. But in practice 

of other design projects, it may not be so easy to get to them.  We suggest carrying this 

procedure for any project regardless of your expertise and confidence, especially for 

larger assemblies and design parameters that the effects on the measure are unknown.  

This will minimise the optimization time in all cases! 

 

 

Phase 2: The Optimization Study on Total Mass 
 

We now can move to the final phase of optimization. Let’s review what we have done so 

far: 

1. With our knowledge of the model and boundary conditions, we determined the 

parameters that we wish to optimize on for minimum weight design.   

2. We ran a static analysis to determine if our material of choice actually will fit the 

application and the study. 

3. We ran a local sensitivity study on each parameter to see the effects of VM stress 

as the parameter is modified slightly; 

4. We ran a global sensitivity study (minimum and maximum values set by the 

designer) to look at the best possible combination of parameters that will lead to 

our optimized design. 

5. We then concluded by selecting parameter values that will minimize the VM 

stress. 

 

Now, let’s perform the steps for the final optimization. 

 

 

Procedure 
 

1. Create a design study of type: optimization study named: opt_study_1.  Select Design 

Studies and make the following settings (see procedures on figure below). 

 

Select Design Study and enter the information as shown in Figure 50. 
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      These are pre-determined 
       from our global sensitivity study, 

Type in our design stress value (psi). 

 Click on Create and select Max_stress_vm from the list.           

 

       Set to 10 for this exercise  

but suggest a minimum of 15 in practice. 
 

Figure 50: Optimization Study Definition 

 

2. Run the design study.  This may approximately 20 to 30 minutes.  The study should 

go through five optimization passes.  Check the status file and compare it to the one 

shown below.  Locate the following results on your status file and write them down 

here: 

 

• Goal (Minimum mass of the model):  __________  

• Optimized thickness:   __________ 

• Optimized cut_length:  __________ 

• Optimized cut_radius: ___________ 

 

24000
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Figure 51: Status Summary File (partial) – Optimization Study 

 

Select Close > Close. 

 
 

Results 
 

We can create and plot the graphs to visualise the different parameters as a function of 

mass and Von Mises stresses.  Though we will only show a few result windows for this 

part of the exercise, there are a lot for the finite element analyst to play around with in 

this section. 

 

Select Results.  Once the empty window comes up, click on the icon named ‘Insert a 

new definition.’ 

 

 
 

Figure 52 

 

 

Create the two windows shown in Figures 53 and 54. 
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From the result window, click on Select; and select the max_vm stress as a measure as 

seen below: 

 

 
 

Figure 53: Result Window1 Definition (optimization study) 

 

Select OK.  Insert the following definition window. 

 

 
 

Figure 54: Result Window1 Definition (optimization study) 
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Repeat the same procedure to get the results for total mass.  Select OK.  Select  

View >Display and select both windows as shown below:  

 

 
 

Figure 55: Result Graphs (optimization study) 

 

 

Conclusion 

 

First, congratulations on your first optimization study!  I hope you realise that this is a lot 

of work.  We have reduced the weight of the plate to a minimum with the parameters that 

we wanted to measure, which should lead to reduced costs. 

 

Look at the optimization passes above.  After the first pass, Pro/MECHANICA
®

 starts 

moving towards our limit on the VM stress.  The reason that so few passes were needed 

is that we did the right work prior to the optimization.  All the preliminary work that we 

performed with the local and global sensitivity studies lead us to the general area of 

optimization, and then we used the optimization design study to refine it to perfection 

using the least amount of optimization pass. 
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Project 1 

 

Problem Definition 
 

We would like to optimise the sheet metal bracket in Table 3 in order to minimise 

weight and cost. 

 

TABLE 3: OPTIMIZATION PROJECT OBJECTIVES 
 

 

Optimization 

Objective 

 

Measure to be used for 

analysis of parameter 

effect on part 

 

 

Parameters to be used for 

optimisation study 

 

Minimise mass of the 

part 

 

Von Mises stress 

 

3. Material Thickness and; 

4. Bend radius  

 
 

 

The model is built from two features (you can omit the holes shown in the figures 

below).  It is simply a swept protrusion which can be built as shown in Table 4. 

 

TABLE 4: BRACKET MODEL FEATURES 
 

Feature # Description Reference figure 

1 Datum Curve (sketched) P1 

2 Thin swept protrusion P2 

3 Hole Pattern P4 
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Boundary Conditions  
 

Flat vertical flange surfaces (back): fixed in all DOF. 

 

Load (1000 lbs): Applied on curve surface (top of hat section) though the centre point. 

 

Hint: In load definition form, select Load through a point from load type. 

 

 
 

Figure P1: Suspension bracket (3-D view) 
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Figure P2: Dimensions of datum curve (2-D) 

 



Copyrighted 
Material 

 
Copyrighted 

Material 
 

Copyrighted 
Material 

 
Copyrighted 

Material 

SENSITIVITY AND OPTIMIZATION STUDIES  

 

 

 49

Cross Section 
 

 
 

Figure P3: Cross-section of suspension bracket - Thickness and BR are: 3/16″ 
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Figure P4: Hole Pattern – Holes (.36 in. diameter) are two inches apart (vertically) 

 

 

 

Objective: Optimize combined material thickness and bend radius for a design stress of 

34 ksi. 

 

Answer: (after “manually” rounding up to nearest nominal values) 

 Thickness: .25″ 

 Bend Radius: 5/16″ 

 

 

 

 

 

End of Exercise 
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