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Overview

This lesson will introduce tools for customizing your Pro/E configuration and working
environment and show you how to create some useful shortcuts for accessing Pro/E
commands. The major customization tool is the use of one or more configuration files
(default ' -onfig.pro and config.win). The lessc also i~cludes manag ag and creating
yourow custc 1t ol as n o opl ys. W 1 Iso se hc vy nc n re e your own
parttemy “ 5. % mi ~ pro) tu dir hi o oor 11 oine ~du -7 a4l first four parts
are presented.

Configuration Fil.s \«c.7.5.p:

By now, you should be familiar with the commands for environment settings that are
available in

Tools > Environment

Thesea rectsc th w rk )2 0 ¢ wme (1@ 1 ua, or )¢ n: sc pe ontrolled using
settings» ~ 1. ~ af .o dles cor ig 7. fc sk rt, Pt hiac oo eral hundred
individual configuration settings. All settings uave default values that will be used if not
specifically set in a ~onfi~ file, or changed during a ~2ssion.

The most importani confi f > a: ec. 1fi'le alle ¢ +f p ) thatis automatically read
when Pro/E starts up a new session. You can also read in (and/or change) additional
configuration settings at any time during a session. For example, you may want to have
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one group of settings for one project you are working on, and another group for a
different project ... you switch to during a sing.e session. In thi¢ utorial, we w 1 deal
only with theu ofth sit ¢ o1 ig v 10 1le cc fig or 1o d Laf “~ -1 .

Several copies of config.pro might exist on your system, and they are read in the

following order when Pro/™ ‘s - ached:

¢  configsup -thisisaj] otec d - m e " h sre liL - u :rsbutisnot
available for modification by users. Your system administrator has control of this
file.

¢ Pro/E loadpoint - this is read by all users and would usually contain common
settings determined by the system administrator such as search paths, formats,
libraries, and so on. This file cannot normally be altered by individual users.

4 user home directory - unique for each user ‘Unix)

¢ startupdir ctory .. w g lir tc s wer . E fo s 0T Jhd L ethis
directory . or-1 he ‘c ler Na “atc wh 1w irc la 1¢c Pr v

Settings made in the first copy (config.sup) cannot be overridden by users. This is handy
for making configurations 'n, to"- ~or ~dr~er-2My -~cr~---all sers ata Pro/E
installation (search paths ft v it wi 5, Ori swance . A 1 . du [ user can modify
entries in the last two copies of config.pro to suit tneir own requirements. If the same
entry appears more than once, the last entry encountered in the start-up sequence is the
one the system will use (except that settings in config.sup cannot be overridden). After
start-up, additional configuration settings can be read in at any time. These might be
used to create a configuration unique to a special project, or perhaps a special type of
modeling. Be aware that when a new configuration file is read in (or some settings
changed), some _.. ns may not take effect unti, Pro/E is1 starte” This is disc1 sed
more a bit later

Settings in config.pro are arranged in a table. Each row in the table is composed of two
entries in the following for

config_option_namc ~ fig_p. "7\ lue
Option values can be composed either of text, single numbers, or series of numbers. A
listing and description of many config options is contained in the on-line help. Select the
following (starting in the pull-down menus):
Help > Help Center
Then pick the I ‘s:

Fundamentals > Pro/ENGINEER Fundamentals

" In Windows, right click on the Pro/E icon on the desktop (if it exists), select
Properties > ShortCut and examine the Start In text entry field.
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Consider adding a bookmark for this page. In the Contents pane, expand the topics

e@P vE /C'N E. ] un am 1t s
« 0. garin Prc, ENGIN e R . anean. ita..

This shows quitea ™ 1g " t (partial'~ shown in Figl.e 1) of p ssible options. Click on
some of thesetosel a ~« taes ip dn nn ‘e wt aluec in :alics). You will have a
hard time remembe ngtl :1. >~ ng ~“«'* 2 opl Hr. | vt nately, as we will see in a
minute, the dialog window for working with configuration files contains a one line
description of each option and there is also a search capability for finding option names.
Although this makes finding the options much easier, you are encouraged to explore the
on-line help - you might find just the setting you need to make your life easier!

[ ——. I Tt | - | Fund~»mentals > Pre FENGINEER Fundamentals |
. =W IO fa
in
Pro/L..INEER
alle onfir vindow Fundamen*als
ang . to )
2t IR W< Yo oor 10 swrr oether ywo U configure
aute ace s B v F FN3| ZER ¢ ter g nfig.pro
bmgr_pref file configuration file options and their values in the
| born_format Options dialog box (Tools = Options).
button_narme_in_help e
color Pro/ENGINEER Fundamentals Help provides a
compress_output_files list of configuration options arranged in
d Creafe_numberedjayers alphabetical order. Each option contains the
= curve_tag_display = following information:
@ Aaf lawar
1 L4 - B R T ;I
F gus 2 1 On-]ine heln for confignration apt yne
The Configuration File Editor
You can access you ¢ 1 1t
configuration file u..ng E —
Showing: Sort:
. |Current Session |V| = ;L']J |A|phahetical |V|
Tools > Optlons Show only options loaded from file:

. . . Value Status
This brings up the Options -
window shown in Figure 2. If
your syste= has options set
already. nesev u 9f w 1 e !
window. Fro th ce tr an < o~ 5
of the window will be _lank, ¢._ Option:  _.due:
in Figure 2. We’ll discuss the | | [+]
operation of thisdi: 7 - 1d_.. o
from the top down. Close

Figure 2 The Options window for setting and
editing the configuration file
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The Showing pull-down list at the top will let you choose from a number of
configuration gr .p. (Current Session, your statw-up confi; pro, o elsewhere). ¢ lect
Current Sessio

Deselect the check box just below the Showing pull-aown box. After a couple of
seconds, a complete list of “'th Pro/E cor “iguration optic..s will ap zar. The first
column shows its name, an .* :cor~ ol mr h v¢ s ¢ rrert al : An entry with
an asterisk indicates a defa It va e.

Note that you can resize the column widths by dragging on the vertical column separator
bars at the top of the display area. At the far right (possibly out of the initial window
view) is a long (scrollable) one-line description of each option.

Browse down throioh the list. There are a lot of ~ptions here (over 750!). Note that the
options are arre ged al” .. et .. . Th' i " coasr e oo wtho 0wt Lo -down
menu in the top ‘ob*¢ vn . ‘h- ige st By ‘a oo y. Tt ir wro veect 21 tof
options to group them by func ion. F example, ct " out the settings available in the
Environment and Sketcher grouns. Fortunately, there are a couple of tools to help you

~ b

find the option name you’r . 12" I ’3¢ _ho e w

Check the box beside “Show only options loaded trom file” ana select
Sort(Alphabetical). Note that the options listed here are only those that are different
from the default settings.

Adding Settings to config.pro

Assumingyou. 'vea an c¢ i pi . et cre € cC p 0o 1S ul .. ¢ + the
bottom of the Opuuns windo  are tw  texu ooxes for ¢ tering option nawes auna values.
If you know the name of the option, you can just type it in to the first box. For new
users, a useful setting is thc Hll  7ine Int e text box helow Ontion :nter the option
name prompt_on_exit. As '« t je* . in no - 1 Pro le~'. pc 2sthe rest of the
text box based on the lettets you wave oy pea wi. 1wl oypinig €nuugh vnaracters (up to the
“x” in “exit”), the rest of the desired option will appear; just hit the Enter key. In the
pull-down list under Value, select Yes. Note that the option name is not case sensitive
and the default value is indicated by an asterisk in the pull-down list. Now select the
Add/Change button on the right. The entry now appears in the data area. A bright green
star in the Status column indicates that the option has been defined but has not yet taken
effect.

Nowenteradisy ~op ~. =~ efa .pe :dic la, = de n e_=~p.~~w 7 wvis
Shaded. Many people prefer .0 work .n hidden line ...vde - let’s make it the default on
start-up. Once again, we vl erter the configuration optio~ name an~ pick the value
from a drop-down list. Tk v Qlan *a a Ve W 21 ac

display hiddenvis
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Now select Add/Change as before (or just hit the Enter key after typing the “h”). Add the
followin o, ion to control how tangent cdges shot d be d inlaved (HIN : try typing in
the follc 7ing:” n< 1t > e ¢ >)

tangent_edge display dimmea

Another commons t -z ;the: ca on [ wl T W

of the Pro/E trail fil . As ro. ~. ali, Te Typ w©,

trail file contains a record of every il ||_Find Now_|

command and mouse click during a Lookin: | ALL_CATEGORY I+

Pro/E session. The default location for [] Search descriptions

this is the start-up directory. % fmmse wri

Theoretically, trail files can be used to Name [Description

recover from disastrous crashes Of cmdmar_trail_output Trail file and mapkey output
) s S . set_t il single step Yes - I ables atrail file to b

PI‘O/E, bocthis? e RS LIRS F [T 5 sa :zlayin seconds bet

Mostpe ~e*u d et th n. " s B B B OB W WAl Pro/ENGINEER tc

handy, therefore, to cc ecttra filesina '

single directory, where they can be ‘

easily removedlate T e~ ~~c “on i >

for setting the locat . b1 hi w ¢ ry. Set

Suppose we don’t know the lctemp B || Browse.. |

configuration option’s specific name.

Here is where a search function will _ Close |

come in handy. Figure 3 Finding a configuration file option

Atthe br ... of the Opntions window. cuck the Fi 4 butt 1. This bring up the Find
Option 'indov (F u :3 " 7.0 the e vo 7 ul nc sel *

Look in(ALL _CA1 EGORY) > Find Now

Several possibilitie ¢ ~1 up ' 2cHuc w v uni lister as rail_dir - scroll the
description to the ri_httc 0. *= ti. = . "t usc ti ~. 1d aen pick the Browse
button at the bottom to identify a suitable location on your system for the value. Perhaps
something like c:\temp. Then select Add/Change. The new entry appears in the Options
window. In the Find Option window, select Close.

For some options, the value is numeric (eg setting a default tolerance, number of digits,
or the coler nf entities on the screen). In *hese case you can enter the re'=vant number
(ornum 2arsser .. 2d , trrsa 0 CC 1S . "o wD ., D . )ption, enter
thenam. “vs’e.  V dem 20l © T 2nt d 'V lu ,e ter he umbve <¢ 16060
(separated by spaces). T'hese _ ve the value.  ced, green, and blue (out of 100). Equal
values yield gray; this setting will brighten the hidden lines a hit from the default value.
Select Add/Change

We have now specitied five options. I'o have them take ettect, select the Apply button at
the bottom. The green stars change to small green circles in the Status column. The



1-6 Pro/E Customization and Project Intro

. _____________________________________________________________________________________________________]
settings are automatically saved in a file current_session.pro in the working directory.

For practice, er rthe pt1 1« shc m v 4g re« " 1e «d "t t- ec = _v ati 1
options are decla. ... dov. ..ot w.er.y el ficete adu a v L2thilgs oo Yoo Jdle o2 search

paths, libraries, default editors, default decimal places, import/export settings, and so on).

Bloptions  NWSE " W A& W BN " W N K
Showing: So
| d:wildfire\schrofficonfig.pro |v| & || & | | Alphabetical v]
Value |Status |Descriptiun
d:ivYildfire\schrofficonfig.pro | |
% allow_anatomic_features yes &
# default_dec_places 1 & Sets the default number ol
# dir _, hiddenvi. & firefre e - Displays mo
# ¢ play_fv oo el sa /e - “u TN wme Sp Y dan
# n el *e st ¢ no @ lor le: lisp votth Mc
%  pro_unit_length unit_mm L Sets the aefauit units tor n
# pro_unit_mass unit_kilogram # Sets the default units for n
4 pro_unit_sys mrns & “pecifies tt  default syste
# prompt_on_exi il € el .. “hes ‘youare pror
% sketcher_dec_ u s 1 4 et v e ult number ol
# sketcher_lock_...odifie._dv....  yes i Jes Lo dif.ed dimensions
# sketcher_refit_after_dim_modif| no & Refits section after dimen:
# system_hidden_color 60 60 60 & Defines default color of hit
# template_designasm Dipteiwildfir... # Specifies the designated t
# template_solidpart Dipteiwildfir... # Specify the model used as
£ trail_dir DiTemp L Instructs ProfENGINEER 1
< ¢ >
Option: Va'r
N IVIPA'ANISIER
&, Find...
Close

Figure 4 Some sett 1gsi cc 'F pr

Notice the icons in the first column beside the option names. These mean the following:
# (lightning) - option takes effect immediately
% (wand -opuc Il et o Proext lT:e oAt
Bl (screen) - option wil :ake ef .ct the next ti~- .’ro/E is started

If you are using a configfi ¢ a=-vicc ~er~mcfPc/E- m: ' see a “stop sign”

(actually ared circle with¢ 1. :* rc g1 it) wh e 1stl it.c pt nis no longer
used.
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Try to add an illegal option name. For example, in Release 2000i there was an option
sketcher ... dme alert. Type thatin to the Ontic | field When you tr to set a value
for this, “will > :: ce te (e ad/ h 2g b to st sy -7, o . only
recognize. .alia cpdo wames Thuo, if ,0u e lype €. enee. an Lavai. wame, this is
indicated by not being able to enter a value tor 1it.

Saving Your co. fig.; 0 ", th.35

To store the settings we have just created so that they will be loaded automatically, select
the Save A Copy button @ at the top of the Options window. At the bottom of the new
window, type in the desired name for the file - in this case config.pro and select OK. It
should be saved in your default (start-up) working directory. To confirm that the settings
have save” ~~operly, use the Open Filel tton attt top ofthe Options indow. Select
theconj rpro” ¢ H us sa e th WG er x 0 @ e 4p Yy uc lew settings.

Loading a Confi~ur~tion File

To load anew conf jurat m e se «t 2Mp 2 F 2z 1 n :side the Showing list.
Select the desired file and then Open. Note that these settings will be read in but not
activated immediately (note the green star). Select the Apply button and observe the
green star.

Deleting Configuration Options

With the ~onfig 'va o1 fil na.  vii ble 11 »¢ 10 in fi d¢ thet ».1 ghlight one of
the options and select lelete. electing Apy *- .atomatically saves the current settings.

4

Now select Close 1 .ve . o'~ ~w “ov

Checking Your Configuration Options

Because some settings will not activate until Pro/E is restarted, many users will exit
Pro/E after making changes to their config.pro file and then restart, just to make sure the
settings are doing what they are supposed to. Do that now. This is not quite so critical
since thr up.iores window showse yoip with the ligh jing/w nd/screen i~c s whether an
optioni active H w~ /e1 ve vare >fw e P /F wi Ic k- . w2 on z2.profile on
start-up, as uiscussed i Huve. ] you uave saved omyig.pro i anvuier woiking directory
than the one you normally start in, then move it before starting Pro/E. On the other hand,
if you have settings ‘at u only w nt active when vou are ir 1 certain directory, keep a
copy of configpro ¢  d'~~ it nc ™ 'F 1as art~" p nd you have changed to
the desired director,. To .ec, w.nge ol .o, a.d ..l | ou ha. e plenty of experience
with changing the configuration settings, it is usually better to have only one copy of
config.pro in your startup directory.
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Note that it is probably easier to make some changes to the environment for a single
session using 7 .. - Environment. Also, as is uften the « 1se wt n learning fo se new
computer tools, lon’t* ya yt iny to e ve wrc s /it cc fig »r in -~ i dle >fapart
or assembly creav.c. Seoe.un - ,cune’ KLow v.aen o Uhantcipaccd o oot gt
clobber your work!

Customizing the Interface (config.win)

In addition to the environment

B TUT_BASE (Active) d:\Wildfire\schroff\TUT_BASE PRT._14 - Pro/ENGINEER

Settlngs, there are Several Ways Of FEile Edit View lnserf Analysis Info Applif:atiuns Tools Window Help
. . ) DRe0dF s A F A Q[ s g

customizing the Pro/E interface: Bao S alak DEE e e
using conﬁg.prr .uv bars. menus. 'M:EE'“;E" hi,“""q'jl"fd i"ffirgfng' isplay. / =
and mapkey§. - nexa Qlt i | L
customized inteti... 1S ..oWI .. .n€ & |

. ~
figure at the right. When you . \ Menus -
modify the interface layoul ‘ov - \ * =
changes will bg saqu ina (| \\ - sa Window w
config.win file in a director, of'y w an M~ 0z toporbottom)
choice (usually the current working 5

=
i

directory). It is possible and & i
.. . : <
permissible to hgve §everal different :; Toolbars -
config.win files in different | Customized buttons on [jq;
. . . . left, top, and/or right :
directories, each with a different P
. . . |
customization of the screen to suit
the work younr ybed .. o s - W _
in that directory egrepeeE S B B -y -

_igure 5 A (sc.__.what cluttered) customized screen
In this section, we will introduce layout

methods to customize thet .'b
and menus.

Toolbars

With the cursor on the top toolbar, hold down the right mouse button. This brings up the
menu shown in Figure 6. This shows the toolbar groups currently displayed (see check
marks); the tool” s can he toooled tn include/exclude they  fram e dienlay, Tt
contents of the enur gh dier o t ec rrer 1 >g m ita 1s. Ea ._.01 »c 1tainsa
set of functionaliy-iciateu shc cut bu' sns.

At the bottom of this pop-t me 1, select 7 rolbars. This ouens the ( ustomize window
which contains a list of all v "¢ let~~ > ,a ** > 1occ lor’~ 2 gure7). Atthe
bottom of this window you can s 2c.., .vheo.2r o. .0ot, and vhe.., (o .utomatically save
the current layout settings. The default is config.win in the current working directory. As
mentioned above, you can create multiple config.win files, and use File > Save Settings



Pro/E Customization and Project Intro 1-9

and File > Open Settings in the Customize window to store and recall previous files.
Note the’ ... . ddition to the standard toolvar groups here ¢ 3 three initial empty groups
(Toolba Tthr ug 3 w c v ac np d ate vi s orf zut = v us 1g methods
describea «c.ow. .ne w.-dov 1lisw at wie g 2L0W you LI paewe Lo ullected toolbars
at different places on the screen (left, right, top of graphics window).

Top Toolchest |’: E*“2*"1EH A" 1
Eile

TDD|harS‘Qummands Navigation Tabs Browser Options

Datum = | Top M=
v Datum Display
v File [ View Top v
v Graphic Selection Model Display Top v
+ Help Datum Caoplay Top v
Info
v Model o __ .iay
Tools
v Yiew
Window z
Automatically save to ||:|:\Wildfire\schruﬁ\cnnfig.win |V|

Commands...

Toolbars Cancel Default
Figure 6 The Figure 7 The Toolbars tab in the Customize window
Toolbar ouggle menu
Changing Toolbar Buttons
In the Customizev n' iy sel~ tt Co -~ w sta . (T 1 also available by selecting

Commands... in the menu. she .v.. in . Zu © 0. USILS 2w vew > Justomize Screen in the
pull-down menu.) The window shown in Figure 8 will open. Groups of toolbar
commands are listed in a tree structure in the Categories area on the left. Click on any of
the group names and the available short-cut buttons will appear in the Commands area
on the right. It is probably best not to place too many on a toolbar unless you are sure you
need them, since they will likely come up automatically when Pro/E enters particular
modes.

Ifyoure. ™ loc v ¢t = ga o toe oL ™" Ji tc ag *m th- ( = nands area (in
Figure 8) and drop it c..to an c..isting toolba. ... che top, right, or left. The button will be
added wherever yor drop it on the toolbar. To remeve it, drag it off the toolbar and drop
it somewhere else ( = t' . repn s ud w fo - a ipl.,. Nc ethatitis possible to mix
and match the short su.t tt s . bu »nea be; a :d n 1y toolbar. For example, a
button listed under the File category can also be added to the View toolbar. Buttons can
also be present on more than one toolbar. The possibilities are endless!
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At the bottom of the Categories list is New Menu. You can drag this up to the pull-
down menu ares ... e ton of the screen to creatc your owr menu: >f commonlv sed
commands. The zisal >a Ve v} y¢ t o1 mar v 1i¢c a ow y 1t -~ t yo rown
flyout groupings ... uny .cutbi .

If you turn on one of the us "to ™ars (sele t Toolbar 1, 2, or 3 under he Toolbars tab),
an initially empty buttonw 1>, :arm™ 1e es’ n2 :d oca on it ] ft, or right). You
can use the Commands s¢ >ctor o = _ar._ Hu.  tc lefi 2, ~. ov 1toolbar.

v

Check out the Navigation and

Browser tabs. One option available in  |Fjle view

the Browser area will prevent the Toolbars | Commands |Navigation Tabs | Browser | Options
Browser window from opening cvery To add a menu item or button, drag it from the "Commands" box
m ro/R 1 to the me= bar or any *~albar.
e you sta otice that the y
final tab in the astonr .. vi . i Toremove a menuiterr  rhutton  raq it o of the me | bar or
. . ™ . Ci i .
Options. This1 <v i et a¢ w0 do S - -
ey B ew. 4
of the dashboard and Edit E Open
command/message window (above or | View C un FEM Mesh
below the graphics area) a1 . 3¢ L: ’I’;ﬂ C n Named FEM Mesh..
other settings. " C n FEM Results...
Applications v S Workinag Directory... ™
o v| < >

When you leave the Customize dialog
box, your new settings can be written
to the file designated in the bottom
text entry box. Each new or altered [v] Automatically save to |D:wildfire\schrofficonfig.win v

COI’lﬁg.Wil’l file is numbered m |j
Nk Cancel Default

sequentially (co .x. vin.2.

Selected Command

config.win.3, a1 so o1 . figare C oc in sk rt ut” % 1 0 Idto
the ool_ars
T TP

It is tempting, especially ‘you rc o s w. 1aro H's e 1s ac ,toover-
populate the toolbars by trying to arrange every commonly used command on the
screen at once. This is reminiscent of many other Windows-based CAD programs.
Before you do that, you should work with Pro/E for a while. You will find that
Pro/E will generally bring up the appropriate toolbars for your current program status
automatically. For example, if you are in Sketcher, the Sketcher short-cut buttons
will appear. Thus, adding these buttons permanently to any toolbar is unnecessary
and the buttor w.. be orayed nut when you are not in S :tcher nywav - yon e
introducing s¢ zencl tte w h1 bt v it <ur e 10 ,1 an ¢ nn ~7 ¢ :>r dily
available in the coutea. vens ave, 1y t-mouse pop-ur NuIUs. Wiell s OCuuts
within the graphics window, the commands are easier to get to than the toolbars.
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Keyboard Shortcuts - Mapkeys

A mapk risa 101 sc ue ce » ke roa .} v:ro 2s r¢ fur uonl 'y at will launch
one or a series of rro/ comm 1ds. dince m~n simple commanas are 1aunched using
toolbar buttons, mapkeys are typically used to start extended command sequences.
Mapkeys are very s ilr 0 macro« hat con be defined i oth r software packages.
Mapkey definitions 1 ¢ e .o /i1 :lu .2 . owuroom”,. o ile, so they are loaded at
start-up. Mapkeys aie meant v be Used Wiur coinmanid scquenices that you use frequently.

The mapkey key stroke sequence can be as long as you want; most users restrict mapkeys
to only 2, or sometimes 3, characters. This gives several hundred possible mapkey
sequences - more than you can probably remember effectively. Pro/E constantly
monitors the keyboard for input and will immediately execute a defined command
sequence  ~n its mapkey is detected. C.ngle char cter i ~pkeys should "e avoided due
tothew ythat ro 7] oc ss 372y sarc in at. If ova >wor gy ey “v”and “vd”,
forexam, "~ hd ~~.or ~ upke wc Idr ve . ¢ e ac Pre ™ - ) and execute
the first one as soon as the “v’ s pressed. Fu. we same reason, a 3-character mapkey can
never have the sam~ *wo #rst letters as a 2-characte” mapkey.

Ideally, you would ketc 1c e ap ey ~arer est al 've 7e - easy to remember, like
“vd” (view default), or “rg” (regenerate). Because it is common to only use two
characters, it will take some planning to decide how you want to set up your definitions
to use only a couple of easy-to-remember key

strokes! The mapkey should be mnemonic, but

can’t collide with other definitions. You don’t want [El Mapkeys

to have to remember that “qy” means “repaint the Mapkeys in Session

screen.” mug :qme Newr...
i’ —Eﬁ, s ol Modify...

A practicai umit on us bie ma- <eys 1s perhene

« ’ vd View Default Run
the range of 20 to 30, although some “power users o
canuse over a hunc 4. ith the de elopment of -
ave...

the Pro/E interface » 1 se .. 00 me 2. us 1to
be several menus deep inw thie program, regdiing
numerous mouse clicks), the need for dozens of
mapkeys is diminishing - you can probably get by
with just a few.

Description

Listing . “rent Mapkeys

5P ~olr Eme
Toseea.. Jf, .c . .utm Kkey.(sc.a€ ... be
defined in your config.pro file) select Save Mapkeys
All

Tools> 1 v} ys

This dialog window (Figure 9) allows you to define
and record, modify, delete, run, and save mapkeys.

Figure 9 Defining mapkeys
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Note that each mapkey has a short Name and Description. The Name will be used on
any short-cut bv’ L. ‘described below), and the wescriptio will a pear at the hc om of

2

the main graph swin bw M ipt yo F tearty tl a® e e ior

Note that mapkeys created using a previous release may differ in command syntax and it
is likely that some mapkey *=fir ~lons fron srevious releas.s will no function properly.
However, mapkeys are eas « ", th1o: cc a.

In the following, it is assumed that you have no mapkeys defined as yet. If any of these
tutorial mapkeys collide with existing mapkeys shown in the mapkeys list (Figure 9), you
can modify the keyboard sequence (for example, use “dv” instead of “vd”) for the new
mapkey.

Creating M: ikeys

New mapkeys are created as 1.llows. Ve will creat. .. napkey sequence “vd” that will
reorient the view to the defanlt orientation. To set this up, y~u will have to bring in one of
your previously createdpa - V' wii. ot . o v pe...

Select the New button in the Mapkeys menu. The Record Mapkey dialog box shown in
Figure 10 will open. Enter the data shown in the figure: key sequence, name, description.
Now we record the command sequence:

Record
View > Orientation > Standard Orientation (in the top pull-down menus)
Stop .l
Every command auu keyswok uvetwer . Record ana ] % c oYM a [IeY
Stop is added to the mapkey. It’s that easy! Spin the [ SEEE
model with the middle mov b on. Inth Mapkeys Jvd ¥
window, highlight thenew 1 & y*~* a1 Is¢c ~~ h > B
Run button. It’s a good id-uto c..ec.. your ...apn-, | ﬁ,.ﬁz afadlt |

definitions now when it is easy to modify them.

Description

. .- . Sets default view orientation.
As mentioned above, mapkey definitions are saved in a

configuration file (as in config.pro). New mapkey < >
definitions are appended to the end of the file. If you
redefine a mapke" “~r use a duplicate keystroke
sequence), the « Afinitic .« s . 2t tt .0 th
config fileisthe =« th ¢v Il e ,ea Wh 1sa in_- 8 G Sy O
mapkey you can choose eithe. config.,ro or O Pause for keyboard input
current_session.pro. There are three ways to save the
mapkeys using the buttons  tF . Vi .2 y. . p7L.

W

Pro/E | OS Seript

~Pron tHandling

{ Re ord " & in 1t

I Reerard Pause Stop

|

.

Figure 10 Creating a mapkey
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Save - saves only the highlighted mapkey
Ch .5.d - saves anv mapkeys chauged this s ;sion
Ai -save ali n )ke s 2 ne tor e 101

Remember that if you save the mapkey in the current session.pro or elsewhere, it will
not be loaded autor tic: 'y the nex’ time you start . -o/E. To lo that, you must explicitly
save the mapkey de 1 « sintc hec zcor 7o v we. seie Hn  of the three options and
save our “vd” mapl vy.

Also, be aware that if you save all mapkeys defined in the session, they are appended to
the end of the config.pro file. If you do this excessively, the file can become quite large
(and slow to load). You should occasionally edit the file with a text editor to remove the
early duplicates.

Fable = 1 Some com — .ly used mapkeys

C 47 ¢ Mam re- ar Creation Mapkeys
wce Window Close ct Create Cut
wa Window Activate cp Create Protrusion
rg Regenerate ch Create Hole
dd Done cr Create Round
| a9 1_11 ______ alash e "g ': n Curve
Vi » Map :ys cu | Create Latum plane
T R ~air* U lity Mapkeys
sd S ac: f ‘eature Redefine
vd View Default fs Feature Suppress
vr View Refit fd Feature Delete
vt View Front fe Feature Resume
vh View Back fm Feature MeAify
vt [VYe T 1 wwwwlt (N1 rmation
vl View Left l
vg Vv oght “

Ay A e—— o e e = ———— —— —
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Close the Mapkeys window. Minimize Pro/E and open config.pro using your system text
editor. Scroll de .. .» the bottom of the file to scc the new ines tl t describe the

mapkey. Itisp ssible or » th n r ey tefi ti as Isc vh e 1t © " 1t- reach
definition these 1i...o sheoud 1 Voo be  paraied vanee v Jy wre u ConuNueaun oL w.€ Same
sequence. It is possible, but probably not advisable, to try to edit the mapkey definitions
manually - leave that to th¢ ow users! F it your text ed..or and re ore the Pro/E
window.

Some final points about mapkeys: it is possible to set up the mapkey so that execution
will pause to allow user input during the command sequence, either by picking on the
screen or through the keyboard. Mapkeys can also call other mapkeys. You might like
to experiment with these ideas on your own. The possibilities for customization are
almost limitless! Some commonly used mapkeys are listed in Table 1-1 on the previous
page. As mentioned earlier, with the “flattening” of the use* interface in Wildfire the
need for mapke sisdi* . sh" . "L yvre »n il .o d o Ls T f oL, ery
common comm. ‘d <3 er &¢ W w,"' ett ntc ni k¢ s te th ne -sect. n.

Creating a Custom 2 4 P21 T m :!-_e

Most part files that you create contain many common elements such as datums, defined
views, coordinate systems, parameters, and so on. Creating these from scratch for every
new part that you start is tedious and inefficient. Prior to Release 2000i* a very handy
model creation tool used the notion of a “start part” which contained these common
elements. Users would then create a mapkey that would bring the part into session and
then rename it. ™~ made the creation of new p.rts very ¢ ick ar ' efficient, wi  the
added bonus th stanc ra a1 se p. o ¢ sce f Hy L

This “start part” functionality nas beeu built into the program using part templates.
Several part templates are “~~luc~d with a standard Pro/E 1 tallation “or solid and sheet
metal parts in different sys 1 ¢ ¢ Wuws Y ur av @ o1 aSou. S ne point to create
your own template, which ewi d h e. We Talsc Jefi 2. = >k yto quickly bring
it in session and allow you to change its name. Then you can immediately get on with
the job of creating features. We will create the part template from scratch, although you
could use any of the existing templates as a basis for this.

Select File > New. Make sure the Part and Solid radio buttons are selected. Deselect
the Use Default Template box, and enter a name mytemplate. Select OK and in the next
window, select . km~" ter =" ‘e ~nd "

Create the default datum plan ;s and v : Edit > Set "'= Name (or select the teatures in
the model tree and use the RMB pop-up menu) to rename the datums RIGHT (DTM1),
TOP (DTM2), and FRON' U™ [3) Now et yr compe pqmed ows

View > Orienta..on > Re.. ¢t

and create the following three named views:
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View Referenc= 1 Reference 2 |I
Tagee )it on | P k J)a m D ec - | P 'k Datum
FRONT | Froat FRC .« Top TOP

TOP I Front | TOP Rig t RIGHT
RIGHT | 1~ 5L T ['c, TOP

The completed list of saved views should appear as shown in Figure 11. Feel free to add
additional standard views (Left, Back, Bottom, Iso_Right, ...). Select OK to leave the
Orientation dialog.

Check ¢ tour ev o ly 2t e m pke f 'sctit ;tl °d fav v “v 7).

Set the part units using
Edit>S8 t7 D U»r+ I E by reference |v|
= I N
and picking (or confirming) “millimeter-Newton- -Reference 1
Second”, then |Front v
X | TOP:F2(DATUM PLANE)
Set > OK > Close -Reference 2
|Right v
We are firiched with creating the start pe-t, so save A | SIDE:F1(DAT' M PLANE)
itwitht :nam  w te .o tuoor o he . i Default

access,1 ~vell potole it Uro Sinan -~ =

directory, something 1 e

Standard Orientation
Defa ": Orientation

\pte\wil . vr \tc _ la’ 00T
o3
This is the default directory where Pro/E will look =P
for part templates. If you do not have write access ‘
to this directory, leave the part file in your working Name | |
directory. You can rename the file to remove the
version number if you want, so that it appears as oK | | cancel | Undo |

mytemplate.prt rather than mytemplate.prt.1.
ytemp P ytemp P Fi~ure 11 Creati gnamed views
Creating More Mapkeys

Before we leave thi 1.~ hart*_ 1p te, - ¢ ate or~ . or mapkeys to go directly to
the named views. &clect



1-16 Pro/E Customization and Project Intro

Tools > Mapkeys > New

Usethekeysec ence’ " n en r s or 1am | e /i v >p an - ¢ pti n
“Orientation Top ..ow . .NO' ..cora e r.apke/ o

Record
Saved View Lis (o lbarr ttc y> 16 ?
Stop > OK

Spin the datum planes, and select Run to try out the mapkey. Similarly, create and test
two more mapkeys to go to the front view (“vf”) and the right side view (“vg”)>. Don’t
forget to save all the changed/new mapkeys in your config.pro file. Open up your
config.pro to confirm that they are there.

Using the Ne P T n ' je
Erase the current part from the session. Select
File > New

Deselect the Use Default Template box, enter a name (like zes?), and select OK.
Depending on what you did before, your template is either in your working directory or
in the default templates directory (or possibly both!). In the New File Options window,
scroll to and highlight the template mytemplate. This is the copy in the default
templates directory. If you weren’t able to put your file there, use the Browse button to
find it in the we ung directorv. Mnee the temnlate je locar d <elc +t OF A co~ of the
template isnow >roug ir > ss n v g ent e an y u: ec fie

Setting the Default P2 ~'T nplate

We can tell Pro/E to use ow new eniptae as the uciauit by setuug an option in
config.pro. Select

Tools > Options

and enter the Option template_solidpart. Set the value for the option by browsing to the
template directo~ | - use the current working d..ectory, w ereve  you have sav: | the
template file)a 1sele my th pe 1 e ay -:mp af .pp v ¢ at 1a’ w " zle t
Add/Change an.. " a1 .- _ly ~ .ew cttin ;(re e tl tt is. “o.. ~“:a._ .esthe
config file).

? The mapkey “vr”, which is more logical for the right view, is usually used for
“View Refit”
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Creating a Mapkey to Start a New Part
Eraseth curre tp t or th ¢ ss n. 3 :t
Tools > Mapkeys > New

r ue ¢ ) : e 7 e , o, ripti I
Enter the key seque 7% sat pe 7 e e re~ a7, and description “Create
a New Part and Rer..me™. No.v celee.

Record
File > New

Choose Part | Solid | OK. Leave the default part name as prt0001, and the check beside
Use Defar"'* Template. Now select

Fle ~7 o w

This is where we want the mapkey to stop, so select STOP > /K in the Record Mapkey
dialog. Inthe Ren: = < 1d... . .a .« n - : " car like test2, then select OK
twice. Wehavear wm >k vl 1“0 igh gl tr ;1 the Mapkeys dialog and
save it. Close the Mapkeys dialog window. Open the config.pro file to see the listing
added for this new mapkey.

To try out the mapkey, erase the new file with File > Erase > Current. Type “cp”.
Several windows will quickly open and close, and you will be left with the dialog box for
renaming the part. You can now enter the desired name for a new part, which will
contain * ¢ acfar™ datrme uvnits apd named views et up  ~nove fa worl- ith the view
mapkey wecr ite e ‘lic . . v ¢y ick

We have created a very simple part template here. You can make this as elaborate as you
like with parameter un” , materia . layers, datum ieatures ¢ d so on - even solid
features. Forexam ¢ f or-* :n re: ~ 't whe ehk~- fe tureis a cylindrical solid,
consider including ...is ir. u Sp <c.dl \eoapiae, pochap.s ca.iew ¢ inder.prt. You can
include as many features as you want in a template and, of course, use any of the

provided part templates as a starting point for any new ones.

Addir , ..Tankevs to Menus and Tag bars

Mapkeys cai be audec v any . the exisung v bars aud puill-aown nicnus. You might
like to do this for mapkeys that you do not use frequently, and are likely to forget.
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To see how this is done,
select the Comr ....: tab
in the Customi : winc w
(see Figure 12). ... wie
bottom of the Categories
list, you will find an entry
called Mapkeys. Select
this to see your currently
defined mapkeys on the
right. In the Mapkeys
pane, select the mapkey
Create Part. The two
buttons Description and
Modify Selection »ve now
active. Selectir  the
former showsy th~
description you entered

| Eile

Toolbars Commands | vavigation Tab  Browse Options

LOTR [ 5 — = = = = @ap ys — — — —
|— :ng. ' ing atur 3| ¢£ amn

Base caturcs

Edit. catures ‘© Col Screen

Facet Feature (Points Phase) © View Default

Facet Featu (VWrap Phase) 1) View Top

Facet: wtu pir 1w P 3 Ve
F¢ «ar tu (Fa trnase

]

on
2 @ BB
5 ‘ & Create Part

New Menu
< ¥

-Selected Command

Description ‘ Modify Selection

To add a menu item or button, drag it from the "Commands” box
to the menu bar or any toolbar. To remove a menu item or button,
drag it off of the menu b=r or its toolbar

444444

1g ve 12 Ac g nf ke s

'nomoar ot s

when defining the mapkey. Selecting the latter allows you to modify the mapkey button

image (currently a “happy

' e topl

Pro/E icons, or design your own.

Y-—-mi~bt e+~ ~at- d of the “happy

face”, since all mapkeysus t..s ar o1 o0 Y 1can ‘dec fr u le¢ ze collection of

Drag the Create Part mapkey in the right pane up to the File pull-down menu and drop it
in a convenient location, as in Figure 13 (notice the changed button icon). Selecting this

will launch the mapkey.

Another way to - ... e mapkevs is to create

shortcut button onthe oo va 5. g 0 el = [F e Ec ey Lt
the Create Part \.....xey . the _atp. ea.d - New
drag it to a toolbar. 3 Create Part

(7 N

We now have three differe

Create Part mapkey:

¢  from the keyboard, with “cp”
¢  from the pull-down File menu
¢ from the toolbar

0o tola e e

Se ¥ rk g lirectory...

x| Close Window

nalysis

L] Save
Save a Copy...
Backup...

Experiment with these to find out which one is

most suitable fc you.
cautionary note hor

"o m, <. =1 Me h
ut! i

-— . - . ~
S T C eT.

sc en. ad :d o¢ o -dec vnm

1Tyl
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Introduction to the Project

The assc blvy oj¢ t b cc » fet 1in hi tu ri ir ol es wwc eli gandassembly
of the three-wheeied v lity ca shown in Fi~v» 14. Tne cart contains 26 or so parts,
many of which are repeated in the assembly. The total assembly has about 75 parts
(mostly bolts!). Wi 7l" se the tec niguee infroduced i» the :ssons to model various
parts of the cartas« « .1 :s-.. 2¢ dc "_..h 2ssc . "0 ~i average about 4 parts per
lesson, so you shouid get 10ts vt pracuce: i the final lessun, we will assemble the cart,
using a number of advanced functions for dealing with assemblies. Try not to “jump the
gun” on this assembly task, since the functions to be covered in the last lesson can really

speed up your job of putting the cart together.

For your modeling exercises, the parts shown at the end of each lesson® will illustrate the
critical d*  -sions. A figure will also b_ provided > shov- where the pa s fit into the
overall semb” . "o an YiL e sic sa ¢ OV 1 1 cr par - I ca useyour
judgeme. © 2w > .at ' to  ter iime che . 1a air_d “ew *~s. *. his regard,
please take note of the (ollowing:

¢ ALLUM . RLu M _o”vwa TF LD Your ‘gl set up your default part
template vith 11 <o ing

¢ Dimensions are usually multiples of Smm. For instance, all the plate material
and the wall of the cargo box are Smm thick. The tubing is 25mm square.

¢ All holes and cylinders, unless otherwise dimensioned, are ¢10. This applies
to bolt holes, pins, rods, and so on.

¢ All holes, unless otherwise dimensioned, are coaxial with cylindrical surfaces
or located on symmetry planes.

¢  toremecfttatrickicr cos ‘'no 70 ¢ the Cauro- she zthe
dim 1si nc th e 7 .bcsom ¢ sct si 1¢ d int wue Yy 1getgoing.

3 A complete list of project parts is included on page ix in the preface (right after
the Table of Contents) to this book.
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Figure 14 Theas ¢ v, pion 't adb ce vb 20 utan ce

When we get to the final assembly in Lesson 8, remember that it is an easy matter to
modify dimensions of the various parts so that the assembly fits together. Don’t be too
concerned when you are modeling the parts if you have to guess at one or two
dimensions. These can be modified later if the need arises.

When you are ¢ ... g the parts. try to be aware uf the des n inte t for the part 1d how
itmighteventu lybe @c 1 1t ascab . o> xecp 1 th pa » e ~more
planes of symme.., it .om _..pra ice.vus.the w at..d.un. la.__ oo Ziese. In
the assembly, the Align constraint using these datum planes is an easy way to position the
part (usually with another ¢ mm ‘ric part).

Although a suggested part ame g -~ fi 'fi ~* 1 ake p_~. o n part names
(although this might cause confusion in Lesson 8!). Remember that Pro/E is fussy about
files that get renamed in isolation, or moved to another directory. If a part has been used
in an assembly (or sub-assembly) or drawing, make sure the assembly or drawing is in
session if you rename or move the part so that the related files can also be updated.

For the entire proiect, you will require about 10 Megabyte< of disk space to store all the
parts and asserr dies. 7.0 dc 2 ot dorrfow LTl 7 g len L
themselves, jus. hera pr je tr ts. yc tarc ¢ »e ¢ la yo re. rtaro *d k
housekeeping (like deleting o ler ver: on of the par* " _s), you will require more space.

* You might like to look ahead to the last lesson to see what assembly constraints
are used for each part.
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Summary

Thisles mishc Id a' :g et ~ u¢ oug 11 2a ar a1 m 1t uwe '0v youto
customize tne interfac so that ¢ will be mort » icient tor the type of work that you do.
There are a surprising number of users who are unaware of many options available in
config.pro. Check m 1!

In the next lesson we wili 100n a funcdons uirectly mvuorved i model creation. These
are for the creation of sweeps.

Quest sn, fo Raview

1. Whatis the nam o1 the ' .e containing v~ r configuration settings?
What is the name of the file containing your screen layout settings?

3. When,and frc w re =reyr rconfiguration settinog | aded? Why is there more
than one local »

4. What happens if your cuuligutauon iue contas wiupre entries for the same
option, each with different values?

5. How can you find out where your start-up directory is?

6. How can you create/edit/delete configuration settings?

7. When do configuration settings become active?

8. Isit possible to have more than one customized screen layout?

9.  How ' you place toolbars on the t_p/left/rig’ edge ~fthe graphic: window?

10. H vdoy aua.ld wer e he tc .ou o0 .o th w Ib 's?

11. Ho. -~ mn, ~ .pt * Llba are her ’

12. Where are the toulbar dcumitions saveu.

13.  What is a mar*ey?

14. Whydoyout vV ¢ Waue Yo op i "€ _.df 23S oun t?

15. Howisthe m: 'key ai e+ ffi en. *om1- e pl *v 2q ence?

16. How do you create a new mapkey?

17. Are new mapkeys stored automatically? Where?

18.  What is the purpose of a part template? Where are they stored and how do you
access them?
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Exercises
I. Createan seml yt n at 1 °~ sk uld a *n n Ild w s&¢ uwuar :d iewsto
match your view selecti 1 mapk ys and derau't its to matcn your default part

template. Make this the default template for assemblies.

2. Setup amapkey Cre. ¢ s 2»’., 0 re¢ ....e ass m'., si 2the default
assembly template.

3.  Put the Create Assembly mapkey on the pull-down File menu.




Pro/E Customization and Project Intro 1-23
|

Project Exercises

We’reg ngtc tar o w h: v.e« the 2a er ar si1 th ca 1uc 2s ould give you
some time to experim¢ it with our configur~t~ , file, mapkeys, and part template. The
project parts are shown in the figures below. Their location in the cart is also shown for
reference in the Fig =1 =2:

PART: FRON|_SPR_PLAIE

PART: ARM_VBRACK
(2 each side)

PART: ARM_orRACK
(3 each side)

PART: HANDLE_PIN

—_

Part: handte_pin « wil: front_spr_plate
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Part: arm_brac





