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S - | Project Introduction

Synopsis:

Configuration settings; customizing the screen toolbars and menus; mapkeys; part
templates; introduction to the project

Overview

This lesson will introduce tools for customizing your Pro/E configuration and working
environment and show you how to create some useful shortcuts for accessing Pro/E
commands. The major customization tool is the use of one or more configuration files
(default files config.pro and config.win). The lesson also includes managing and creating
your own custom toolbars and mapkeys. We’ll also see how you can create your own
part templates. The major project used in this tutorial is introduced and the first four parts
are presented.

Configuration Files (config.pro)

By now, you should be familiar with the commands for environment settings that are
available in

Tools > Environment

These aspects of the working environment (and much more!) can also be controlled using
settings stored in configuration files (config files for short). Pro/E has several hundred
individual configuration settings. All settings have default values that will be used if not
specifically set in a config file, or changed during a session.

The most important config file is a special file called config.pro that is automatically read
when Pro/E starts up a new session. You can also read in (and/or change) additional
configuration settings at any time during a session. For example, you may want to have
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one group of settings for one project you are working on, and another group for a
different project that you switch to during a single session. In this tutorial, we will deal
only with the use of the single configuration file, config.pro, loaded at start-up.

Several copies of config.pro might exist on your system, and they are read in the
following order when Pro/E is launched:

¢ config.sup - this is a protected system file which is read by all users but is not
available for modification by users. Your system administrator has control of this
file.

¢ Pro/E loadpoint - this is read by all users and would usually contain common
settings determined by the system administrator such as search paths, formats,
libraries, and so on. This file cannot normally be altered by individual users.

4 user home directory - unique for each user (Unix)

4 startup directory - the working directory when Pro/E starts up. To find where this
directory is, open the Folder Navigator when you first launch Pro/E and select
Working Directory in the Navigator pane'.

Settings made in the first copy (config.sup) cannot be overridden by users. This is handy
for making configuration settings to be applied universally across all users at a Pro/E
installation (search paths for part libraries, for instance). An individual user can modify
entries in the last two copies of config.pro to suit their own requirements. If the same
entry appears more than once, the last entry encountered in the start-up sequence is the
one the system will use (except that settings in config.sup cannot be overridden). After
start-up, additional configuration settings can be read in at any time. These might be
used to create a configuration unique to a special project, or perhaps a special type of
modeling. Be aware that when a new configuration file is read in (or some settings
changed), some options may not take effect until Pro/E is restarted. This is discussed
more a bit later.

Settings in config.pro are arranged in a table. Each row in the table is composed of two
entries in the following form:

config_option_name config_option_value
Option values can be composed either of text, single numbers, or series of numbers. A
listing and description of many config options is contained in the on-line help. Select the
following (starting in the pull-down menus):
Help > Help Center
Then pick the links:

Fundamentals > Pro/ENGINEER Fundamentals

" In Windows, right click on the Pro/E icon on the desktop (if it exists), select
Properties > ShortCut and examine the Start In text entry field.
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Consider adding a bookmark for this page. In the Contents pane, expand the topics

@& Pro/ENGINEER Fundamentals
@ Configuring Pro/ENGINEER Fundamentals

This shows quite a long list (partially shown in Figure 1) of possible options. Click on
some of these to see a short description and default values (in italics). You will have a
hard time remembering the meaning of all these options. Fortunately, as we will see in a
minute, the dialog window for working with configuration files contains a one line
description of each option and there is also a search capability for finding option names.
Although this makes finding the options much easier, you are encouraged to explore the
on-line help - you might find just the setting you need to make your life easier!

Fundamentals > ProfENGINEER Fundamentals

|»

Contents I Index I Search I

= Pro/EMGINEER Fundamentals
=1 Configuring Pro/ENGINEER About Configuring
1= About Configuring Pro/ERNT
To Set ProfENGINEER Fu Pro/ENGINEER
allow_confirm_window FU ndame ntals
angular_tal
| auto_regen_views

j HIDE NAVIGATION | << | »>

You can customize the way you configure

autoplace_single_comp Pra/ENGINEER by entering config. prao
hrngr_pref file configuration file options and their values in the

| bom_format Options dialog box (Tools = Options).
button_narne_in_help e
color Pro/ENGINEER Fundamentals Help provides a
compress_output_files list of configuration options arranged in

| create_numbered_layers alphabetical order. Each option contains the

= i:;“i—:j?—dmp'ay = following information:

b _’l—l B R T ;I

Figure 1 On-line help for configuration options

The Configuration File Editor

You can access your current

configuration file using [ Options
Showing: Sort:
urrent Session vl = || B abetical v
Tools > Options |Shuv:usnly options loaded from fi|e§| 2 e s
. . Value ‘Status
This brings up the Options =
window shown in Figure 2. If
your system has options set
already, these will appear in the
window. If not, the central area < sz 5]
of the window will be blank, as Option:  Value:
in Figure 2. We’ll discuss the | | [+]
operation of this dialog window X Find... |
from the top down. [

Figure 2 The Options window for setting and

The Showing pull-down list at 5" )
editing the configuration file
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the top will let you choose from a number of configuration groups (Current Session, your
start-up config.pro, or elsewhere). Select Current Session.

Deselect the check box just below the Showing pull-down box. A complete list of all the
Pro/E configuration options will appear. The first column shows its name, and the
second column shows its current value. An entry with an asterisk indicates a default
value.

Note that you can resize the column widths by dragging on the vertical column separator
bars at the top of the display area. At the far right (possibly out of the initial window
view) is a long (scrollable) one-line description of each option.

Browse down through the list. There are a lot of options here (over 750!). Note that the
options are arranged alphabetically. This is because of the setting in the Sort pull-down
menu in the top-right corner. Change this to By Category. This rearranges the list of
options to group them by function. For example, check out the settings available in the
Environment and Sketcher groups. Fortunately, there are a couple of tools to help you
find the option name you’re looking for. Let’s see how they work.

Check the box beside “Show only options loaded from file” and select
Sort(Alphabetical).

Adding Settings to config.pro

Assuming you have a blank config.pro, let’s create a couple of useful settings. At the
bottom of the Options window are two text boxes for entering option names and values.
If you know the name of the option, you can just type it in to the first box. For new
users, a useful setting is the following. In the text box below Option, enter the option
name prompt_on_exit. As you type this in, notice that Pro/E anticipates the rest of the
text box based on the letters you have typed in. After typing enough characters (up to the
“x” in “exit”), the rest of the desired option will appear; just hit the Enter key. In the
pull-down list under Value, select Yes. Note that the option name is not case sensitive
and the default value is indicated by an asterisk in the pull-down list. Now select the
Add/Change button on the right. The entry now appears in the data area. A bright green
star in the Status column indicates that the option has been defined but has not yet taken
effect.

Now enter a display option. The default part display mode in the graphics window is
Shaded. Many people prefer to work in hidden line mode - let’s make it the default on
start-up. Once again, we will enter the configuration option name and pick the value
from a drop-down list. The option name and value we want are

display hiddenvis

Now select Add/Change as before (or just hit the Enter key after typing the “h”). Add the
following option to control how tangent edges should be displayed (HINT: try typing in
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the following: tan<enter>, backspace to remove the default, then d<enter>):

tangent_edge display dimmed

Another common setting is the location
of the Pro/E trail file. As you recall, the
trail file contains a record of every
command and mouse click during a
Pro/E session. The default location for
this is the start-up directory.
Theoretically, trail files can be used to
recover from disastrous crashes of
Pro/E, but this is a tricky operation.
Most people just delete them. It is

1. Type keyword

ltrail | FindNow |

Lookin: |ALL_CATEGORY v

[1Search descriptions

2. Choose option

Name
cmdmgr_trail_output
set_trail_single_step

|Descriptiun
Trail file and mapkey output
Yes - Enables atrail file to L

trail_delay Sets a delay in seconds bet
trail_dir Instructs Pro/ENGINEER tg

handy, therefore, to collect trail files in a
single directory, where they can be
easily removed later. There is an option < >
for setting the location of this directory.
Suppose we don’t know the
configuration option’s specific name.
Here is where a search function will
come in handy.

3. Setvalue

clitemp |V| Browse... I

Close

Figure 3 Finding a configuration file option

At the bottom of the Options window,
click the Find button. This brings up the Find Option window (Figure 3). Type in the
keyword #rail and select

Look in(ALL_CATEGORY) > Find Now

Several possibilities come up. The option we want is listed as trail_dir - scroll the
description to the right to confirm this. Select this option and then pick the Browse
button at the bottom to identify a suitable location on your system for the value. Perhaps
something like c:\tfemp. Then select Add/Change. The new entry appears in the Options
window. In the Find Option window, select Close.

For some options, the value is numeric (eg setting a default tolerance, number of digits,
or the color of entities on the screen). In these cases, you can enter the relevant number
(or numbers separated by either spaces or commas). For example, under Option, enter
the name system_hidden_color. Then under Value, enter the numbers 60 60 60
(separated by spaces). These give the values of red, green, and blue (out of 100). Equal
values yield gray; this setting will brighten the hidden lines a bit from the default value.
Select Add/Change.

We have now specified five options. To have them take effect, select the Apply button at
the bottom. The green stars change to small green circles in the Status column. The
settings are automatically saved in a file current session.pro in the working directory.
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For practice, enter the options shown in Figure 4. The order that the configuration
options are declared does not matter. Feel free to add new settings to your file (for search
paths, libraries, default editors, default decimal places, import/export settings, and so on).

[El Options
Showing: Sort:
| d:wildfire\schrofficonfig.pro Iv| @ || 19| | Alphabetical v]
Value |Statu5 |Descriptiun
| o
% allow_anatomic_features yes &
# default_dec_places 1 & Sets the default number ol
# display hiddenvis ® ¥¥ireframe - Displays mod
# display_full_object_path yes @ Controls the display of the
# model_tree_start no @ Toggles display of the Mot
# pro_unit_length unit_mm L Sets the default units for n
# pro_unit_mass unit_kilogram # Sets the default units for n
4 pro_unit_sys mmns ® Specifies the default syste
# prompt_on_exit yes ® Determines if you are pror
# sketcher_dec_places 1 & Sets the default number ol
# sketcher_lock_modified_dims |yes & Yes - modified dimensions
# sketcher_refit_after_dim_modif| no & Refits section after dimen!
# system_hidden_color 6060 60 L Defines default color of hit
# template_designasm Dpteiwildfir... # Specifies the designated t
# template_solidpart Diptewwvildfir... # Specify the model used as
Z  trail_dir DATemp & Instructs ProfENGINEER 1
< EAIRS >
Option: Value:

|| | [+]
2 Find..

Close

Figure 4 Some settings in config.pro

Notice the icons in the first column beside the option names. These mean the following:
# (lightning) - option takes effect immediately
%" (wand) - option will take effect for the next object created
&l (screen) - option will take effect the next time Pro/E is started
If you are using a config file from a previous version of Pro/E you may see a “stop sign”
(actually a red circle with a line through it), which means that the option is no longer

used.

Try to add an illegal option name. For example, in Release 2000i there was an option
sketcher_readme_alert. Type that in to the Option field. When you try to set a value
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for this, it will not be accepted (the Add/Change button stays gray). Pro/E only
recognizes valid option names! Thus, if you mistype or enter an invalid name, this is
indicated by not being able to enter a value for it.

Saving Your config.pro Settings

To store the settings we have just created so that they will be loaded automatically, select
the Save A Copy button {3 | at the top of the Options window. At the bottom of the new
window, type in the desired name for the file - in this case config.pro and select OK. It
should be saved in your default (start-up) working directory. To confirm that the settings
have saved properly, use the Open File button at the top of the Options window. Select
the config.pro file you just saved, then Open. You will have to Apply the new settings.

Loading a Configuration File

To load a new configuration file, select the Open File button beside the Showing list.
Select the desired file and then Open. Note that these settings will be read in but not
activated immediately (note the green star). Select the Apply button and observe the
green star.

Deleting Configuration Options

With the configuration file name visible in the Showing field at the top, highlight one of
the options and select Delete. Selecting Apply automatically saves the current settings.

Now select Close in the Options window.

Checking Your Configuration Options

Because some settings will not activate until Pro/E is restarted, many users will exit
Pro/E after making changes to their config.pro file and then restart, just to make sure the
settings are doing what they are supposed to. Do that now. This is not quite so critical
since the Options window shows you with the lightning/wand/screen icons whether an
option is active. However be aware of where Pro/E will look for the config.pro file on
start-up, as discussed above. If you have saved config.pro in another working directory
than the one you normally start in, then move it before starting Pro/E. On the other hand,
if you have settings that you only want active when you are in a certain directory, keep a
copy of config.pro there and load it once Pro/E has started up and you have changed to
the desired directory. To keep things simple, and until you have plenty of experience
with changing the configuration settings, it is usually better to have only one copy of
config.pro in your startup directory.
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. _______________________________________________________________________________________________]
Note that it is probably easier to make some changes to the environment for a single
session using Tools > Environment. Also, as is often the case when learning to use new
computer tools, don’t try anything too adventurous with config.pro in the middle of a part

or assembly creation session - you never know when an unanticipated effect might
clobber your work!

Customizing the Interface (config.win)

In addition to the environment
SettlngS, there are Several Ways Of Eile Edit View !nser& Analysis Info Agplif:atinns Tools ﬂin‘:lnw Help
. . . . DR U&3 s BrFaads =k
customizing the Pro/E interface: Oaloofm ENa Lk NEE v
using config.pro, toolbars, menus,  EHEEHEREAT I EEE =
and mapkeys. An example of a
customized interface is shown in the
figure at the right. When you
modify the interface layout, your
changes will be saved in a =
config.win file in a directory of your
choice (usually the current working
directory). It is possible and
permissible to hgve §evera1 different Toolbars
config.win files in different | Customized buttons on
. . . . f left, top, and/or right
directories, each with a different
customization of the screen to suit
the work you may be doing on files
in that directory.

B TUT_BASE (Active) d:\wildfire\schroff,TUT_BASE PRT .14 - Pro/ENGINEER

o
- ge
ge

U~

Menus

Message Window
(and Dashboard; top or bottom)

I B S

| |Smarl ‘V‘

Figure 5 A (somewhat cluttered) customized screen
In this section, we will introduce layout

methods to customize the toolbars
and menus.

Toolbars

With the cursor on the top toolbar, hold down the right mouse button. This brings up a
menu similar to the one shown in Figure 6. This shows the toolbar groups currently
displayed (see check marks); the toolbars can be toggled to include/exclude them from
the display. The contents of the menu might depend on the current program status. Each
group contains a set of functionally-related shortcut buttons.

At the bottom of this pop-up menu, select Toolbars. This opens the Customize window
which contains a list of all available toolbars, and their location (see Figure 7). At the
bottom of this window you can specify whether or not, and where, to automatically save
the current layout settings. The default is config.win in the current working directory. As
mentioned above, you can create multiple config.win files, and use File > Save Settings
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and File > Open Settings in the Customize window to store and recall previous files.
Note that in addition to the standard toolbar groups there are three initially empty groups
(Toolbars 1 through 3), which you can populate with short-cut buttons using methods
described below. The pull-down lists at the right allow you to place the selected toolbars
at different places on the screen (left, right, top of graphics window).

Top Toolchest [El Customize
Ee
Toolbars ‘Qummands Navigation Tabs Browser Options
Datum . s
i File |Tup |V|
v Datum Display
v File View Top v
v Graphic Selection Model Display Top v
v Help Datum Display Top v
Info
¥ Model Display
Tools
¥ Yiew
Window =
Automatically save to ||:I:\Wildfire\schruﬁ\cnnﬁg.win |V|
Commands...
Toolbars... Cancel | Default |
Figure 6 The Figure 7 The Toolbars tab in the Customize window

Toolbar toggle menu

Changing Toolbar Buttons

In the Customize window, select the Commands tab. (This is also available by selecting
Commands... in the menu shown in Figure 6 or using Tools > Customize Screen in the
pull-down menu.) The window shown in Figure 8 will open. Groups of toolbar
commands are listed in a tree structure in the Categories area on the left. Click on any of
the group names and the available short-cut buttons will appear in the Commands area
on the right. It is probably best not to place too many on a toolbar unless you are sure you
need them, since they will likely come up automatically when Pro/E enters particular
modes.

If you really do want to add a button to a toolbar, just drag from the Commands area (in
Figure 8) and drop it onto an existing toolbar at the top, right, or left. The button will be
added wherever you drop it on the toolbar. To remove it, drag it off the toolbar and drop
it somewhere else (on the graphics window, for example). Note that it is possible to mix
and match the short-cut buttons: any button can be placed on any toolbar. For example, a
button listed under the File category can also be added to the View toolbar. Buttons can
also be present on more than one toolbar. The possibilities are endless!
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At the bottom of the Categories list is New Menu. You can drag this up to the pull-
down menu area at the top of the screen to create your own menus of commonly used
commands. There is also a New Flyout command which allows you to create your own
flyout groupings in any toolbar.

If you turn on one of the user toolbars (select Toolbar 1, 2, or 3 under the Toolbars tab),
an initially empty button will appear in the designated location (top, left, or right). You
can use the Commands selector to drag any button to define your own toolbar.

Check out the Navigation and

Browser tabs. One option available in  |Fjle view
the Browser area will prevent the
BI‘OWSCI‘ window from Openlng every To add a menu item or button, drag it from the "Commands" box
time you start Pro/E. Notice that the to the menu bar or any toolbar.

. . . . To remove a menu item or button, drag it off of the menu bar or
final tab in the Customize window is

Toolbars | Commands | Navigation Tabs | Browser | Options

. . . . Cat es: C d
Options. This lets you set the position | 223" ommands
~| | [ New... A
of the dashboard and . -
. Edit = Open...
command/message window (above or | View Open FEM Mesh
below the graphics area) and some rsel” _ Open Named FEM Mesh...
. nalysis
other Settll’lgs, Info i Open FEM Results...
Applications - [E'%‘Set Workina Directorv... R 4

When you leave the Customize dialog
box, your new settings can be written
to the file designated in the bottom

Selected Command

text entry box. Each new or altered [¥] Automatically save to |D:wildfire\schrofficonfig.win v
config.win file in the same directory is
) ) [ ok | Cancel Default
numbered sequentially (config.win.2,
config.win.3, and so on). Figure 8 Choosing short-cut buttons to add to
the toolbars
Helpful Hint

It is tempting, especially if you are blessed with a lot of screen space, to over-
populate the toolbars by trying to arrange every commonly used command on the
screen at once. This is reminiscent of many other Windows-based CAD programs.
Before you do that, you should work with Pro/E for a while. You will find that
Pro/E will generally bring up the appropriate toolbars for your current program status
automatically. For example, if you are in Sketcher, the Sketcher short-cut buttons
will appear. Thus, adding these buttons permanently to any toolbar is unnecessary
and the buttons will be grayed out when you are not in Sketcher anyway - you are
introducing screen clutter with no benefit. Furthermore, many commands are readily
available in the context-sensitive, right-mouse pop-up menus. When this occurs
within the graphics window, the commands are easier to get to than the toolbars.
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Keyboard Shortcuts - Mapkeys

A mapkey is a short sequence of keyboard key strokes or a function key that will launch
one or a series of Pro/E commands. Since many simple commands are launched using
toolbar buttons, mapkeys are typically used to start extended command sequences.
Mapkeys are very similar to macros that can be defined in other software packages.
Mapkey definitions are contained/included in your config.pro file, so they are loaded at
start-up. Mapkeys are meant to be used with command sequences that you use frequently.

The mapkey key stroke sequence can be as long as you want; most users restrict mapkeys
to only 2, or sometimes 3, characters. This gives several hundred possible mapkey
sequences - more than you can probably remember effectively. Pro/E constantly
monitors the keyboard for input and will immediately execute a defined command
sequence when its mapkey is detected. Single character mapkeys should be avoided due
to the way that Pro/E processes keyboard input. If you have two mapkeys “v” and “vd”,
for example, the second mapkey would never execute since Pro/E will trap and execute
the first one as soon as the “v” is pressed. For the same reason, a 3-character mapkey can
never have the same two first letters as a 2-character mapkey.

Ideally, you would like to have mapkey sequences that are very easy to remember, like
“vd” (view default), or “rg” (regenerate). Because it is common to only use two
characters, it will take some planning to decide how you want to set up your definitions
to use only a couple of easy-to-remember key

strokes! The mapkey should be mnemonic, but

can’t collide with other definitions. You don’t want [ElMapkeys
to have to remember that “qy” means “repaint the Mapkeys in Session
screen.” BYS Name New...
F1 BW Screen .
A ) g \ i . $F3 Col Screen Modify...
practical limit on usable mapkeys is perhaps in vl View Default Run
the range of 20 to 30, although some “power users” e
can use over a hundred. With the development of
the Pro/E interface (where some commands used to Save...
be several menus deep into the program, requiring
numerous mouse clicks), the need for dozens of
mapkeys is diminishing - you can probably get by
with just a few.
o e Description
Listing Current Mapkeys Sete BW color scheme
To see a list of your current mapkeys (some may be
defined in your config.pro file) select Save Mapkeys
All
Tools > Mapkeys
This dialog window (Figure 9) allows you to define

and record, modify, delete, run, and save mapkeys. Figure 9 Defining mapkeys
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Note that each mapkey has a short Name and Description. The Name will be used on
any short-cut button (described below), and the Description will appear at the bottom of
the main graphics window. Mapkeys that start with a “$” are function keys.

Note that mapkeys created using a previous release may differ in command syntax and it
is likely that some mapkey definitions from previous releases will not function properly.
However, mapkeys are easy enough to record.

In the following, it is assumed that you have no mapkeys defined as yet. If any of these
tutorial mapkeys collide with existing mapkeys shown in the mapkeys list (Figure 9), you
can modify the keyboard sequence (for example, use “dv” instead of “vd”) for the new
mapkey.

Creating Mapkeys

New mapkeys are created as follows. We will create a mapkey sequence “vd” that will
reorient the view to the default orientation. To set this up, you will have to bring in one of
your previously created parts. We will not be modifying the part.

Select the New button in the Mapkeys menu. The Record Mapkey dialog box shown in
Figure 10 will open. Enter the data shown in the figure: key sequence, name, description.
Now we record the command sequence:

Record
View > Orientation > Standard Orientation (in the top pull-down menus)
Stop > OK
Every command and keystroke between Record and [El Record Mapkey
Stop is added to the mapkey. It’s that easy! Spin the Key Sequence
model with the middle mouse button. In the Mapkeys vd ]
window, highlight the new mapkey “vd” and select the “Name
Run button. It’s a good idea to check your mapkey View Default |

definitions now when it is easy to modify them. .
-Description

. .. . Sets default view orientation.
As mentioned above, mapkey definitions are saved in a

configuration file (as in config.pro). New mapkey < >
definitions are appended to the end of the file. If you
redefine a mapkey (or use a duplicate keystroke
sequence), the definition closest to the bottom of the
config file is the one that will be used. When saving a

b

Pro/E | OS Seript

Prompt Handling

*) Record keyboard input
) Accept system defaults

mapkey you can choose either config.pro or ) Pause for keyboard input
current _session.pro. There are three ways to save the
mapkeys using the buttons in the Mapkeys window: Pause J| Stop

o

Figure 10 Creating a mapkey
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Save - saves only the highlighted mapkey
Changed - saves any mapkeys changed this session
All - saves all mapkeys defined for session

Remember that if you save the mapkey in the current session.pro or elsewhere, it will
not be loaded automatically the next time you start Pro/E. To do that, you must explicitly
save the mapkey definitions into the config.pro file. Select one of the three options and
save our “vd” mapkey.

Also, be aware that if you save all mapkeys defined in the session, they are appended to
the end of the config.pro file. If you do this excessively, the file can become quite large
(and slow to load). You should occasionally edit the file with a text editor to remove the
early duplicates.

Table 1-1 Some commonly used mapkeys

General Mapkeys Feature Creation Mapkeys
wce Window Close ct Create Cut
wa Window Activate cp Create Protrusion
rg Regenerate ch Create Hole
dd Done cr Create Round
qq Quit cc Create datum Curve

View Mapkeys cd Create Datum plane

T Repaint Utility Mapkeys
sd Shade fr Feature Redefine
vd View Default fs Feature Suppress
vr View Refit fd Feature Delete
vt View Front fe Feature Resume
vb View Back fm Feature Modify
vt View Top fi Feature Information
vl View Left

View Right
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Close the Mapkeys window. Minimize Pro/E and open config.pro using your system text
editor. Scroll down to the bottom of the file to see the new lines that describe the
mapkey. It is possible to move the mapkey definitions elsewhere in the file but for each
definition these lines should never be separated since they are a continuation of the same
sequence. It is possible, but probably not advisable, to try to edit the mapkey definitions
manually - leave that to the power users! Exit your text editor and restore the Pro/E
window.

Some final points about mapkeys: it is possible to set up the mapkey so that execution
will pause to allow user input during the command sequence, either by picking on the
screen or through the keyboard. Mapkeys can also call other mapkeys. You might like
to experiment with these ideas on your own. The possibilities for customization are
almost limitless! Some commonly used mapkeys are listed in Table 1-1 on the previous
page. As mentioned earlier, with the “flattening” of the user interface in Wildfire, the
need for mapkeys is diminishing. They are primarily used as shortcuts for a few, very
common command sequences. We will return to mapkeys after the next section.

Creating a Customized Part Template

Most part files that you create contain many common elements such as datums, defined
views, coordinate systems, parameters, and so on. Creating these from scratch for every
new part that you start is tedious and inefficient. Prior to Release 2000i* a very handy
model creation tool used the notion of a “start part” which contained these common
elements. Users would then create a mapkey that would bring the part into session and
then rename it. This made the creation of new parts very quick and efficient, with the
added bonus that standard part setups could be employed.

This “start part” functionality has been built into the program using part templates.
Several part templates are included with a standard Pro/E installation for solid and sheet
metal parts in different systems of units. You may have a reason at some point to create
your own template, which we will do here. We’ll also define a mapkey to quickly bring
it in session and allow you to change its name. Then you can immediately get on with
the job of creating features. We will create the part template from scratch, although you
could use any of the existing templates as a basis for this.

Select File > New. Make sure the Part and Solid radio buttons are selected. Deselect
the Use Default Template box, and enter a name mytemplate. Select OK and in the next
window, select the Empty template and OK.

Create the default datum planes and use Edit > Set Up > Name (or select the features in
the model tree and use the RMB pop-up menu) to rename the datums RIGHT (DTM1),
TOP (DTM2), and FRONT (DTM3). Now set up some named views.

View > Orientation > Reorient
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and create the following three named views:

View Reference 1 Reference 2
Name . .
Direction | Pick Datum Direction Pick Datum
FRONT Front FRONT Top TOP
TOP Front TOP Right RIGHT
RIGHT Front RIGHT Top TOP

The completed list of saved views should appear as shown in Figure 11. Feel free to add
additional standard views (Left, Back, Bottom, Iso_Right, ...). Select OK to leave the

Orientation dialog.

Check out our previously defined mapkey for setting the default view (“vd”).

Set the part units using
Edit > Set Up > Units

and picking (or confirming) “millimeter-Newton-
Second”, then

Set > OK > Close

We are finished with creating the start part, so save
it with the name mytemplate.prt. If you have write
access, move the part file to the Pro/E installation
directory, something like

\ptc\wildfire30\templates

This is the default directory where Pro/E will look
for part templates. If you do not have write access
to this directory, leave the part file in your working
directory. You can rename the file to remove the
version number if you want, so that it appears as
mytemplate.prt rather than mytemplate.prt.1.

Creating More Mapkeys

[El Orientation
Type

| Orient by reference |v|

Options

-Reference 1

| Front |V
L”TOP:FZ(DATUM PLANE)

-Reference 2
| Right v
L]|SIDE:F1 {DATUM PLANE})

Default

w Saved Views

Standard Orientation
Default Orientation
FRONT

RIGHT

TOP

Mame | |

OK I Cancel‘ Undo ‘

Figure 11 Creating named views

Before we leave this new part template, let’s create some more mapkeys to go directly to

the named views. Select




1-16 Pro/E Customization and Project Intro

Tools > Mapkeys > New

Use the key sequence “vt” and enter a short name like “View Top” and description
“Orientation Top View”. Now record the mapkey using

Record
Saved View List (a toolbar button) > TOP
Stop > OK

Spin the datum planes, and select Run to try out the mapkey. Similarly, create and test
two more mapkeys to go to the front view (“vf”) and the right side view (“vg”)>. Don’t
forget to save all the changed/new mapkeys in your config.pro file. Open up your
config.pro to confirm that they are there.

Using the New Part Template
Erase the current part from the session. Select
File > New

Deselect the Use Default Template box, enter a name (like zes?), and select OK.
Depending on what you did before, your template is either in your working directory or
in the default templates directory (or possibly both!). In the New File Options window,
scroll to and highlight the template mytemplate. This is the copy in the default
templates directory. Alternatively, if you weren’t able to put your file there, use the
Browse button to find it in the working directory. Once the template is located, select
OK. A copy of the template is now brought into session and given the name you
specified.

Setting the Default Part Template

We can tell Pro/E to use our new template as the default by setting an option in
config.pro. Select

Tools > Options

and enter the Option template_solidpart. Set the value for the option by browsing to the
template directory (or use the current working directory, wherever you have saved the
template file) and selecting the part file mytemplate.prt we created above. Select
Add/Change and then Apply the new setting (remember that this automatically saves the
config file).

? The mapkey “vr”, which is more logical for the right view, is usually used for
“View Refit”
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Creating a Mapkey to Start a New Part
Erase the current part from the session. Select
Tools > Mapkeys > New

Enter the key sequence “cp” (“create part”), name “Create Part”, and description “Create
a New Part and Rename”. Now select

Record
File > New

Choose Part | Solid | OK. Leave the default part name as prt0001, and the check beside
Use Default Template. Now select

File > Rename

This is where we want the mapkey to stop, so select STOP > OK in the Record Mapkey
dialog. In the Rename window, enter a new name for the part, like test2, then select OK
twice. We have a new mapkey called “cp”, so highlight this in the Mapkeys dialog and
save it. Close the Mapkeys dialog window. Open the config.pro file to see the listing
added for this new mapkey.

To try out the mapkey, erase the new file with File > Erase > Current. Type “cp”.
Several windows will quickly open and close, and you will be left with the dialog box for
renaming the part. You can now enter the desired name for a new part, which will
contain the default datums, units, and named views set up above to work with the view
mapkeys we created earlier. Pretty slick!

We have created a very simple part template here. You can make this as elaborate as you
like with parameters, units, materials, layers, datum features and so on - even solid
features. For example, if you often create parts whose base feature is a cylindrical solid,
consider including this in a special template, perhaps called cylinder.prt. You can
include as many features as you want in a template and, of course, use any of the
provided part templates as a starting point for any new ones.

Adding Mapkeys to Menus and Toolbars

Mapkeys can be added to any of the existing toolbars and pull-down menus. You might
like to do this for mapkeys that you do not use frequently, and are likely to forget.
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To see how this is done, | File |
select the Commands tab Toolbars Commands Iﬂavigatiun Tabs  Browser Options
in the Customize window | Sategories [ Mapkeys

. Engineering Features ) © BW Screen
(see Figure 12). Atthe Base Features © Col S

: Edit Features ol sereen
b,Ottom Othe Categorles Facet Feature (Points Phase) © View Default
list, you will find an entry Facet Feature (YWrap Phase) @ View Top
called Mapkeys. Select Facet Feature (Fine-Tune Phi |/ & vsigw, Front
. Facet Feature (Facet Phase) i .
this to see your currently @ View Right
defined mapkeys on the New Menu o || © Create Part]
. < S
right. In the Mapkeys
-Selected Command
pane, select the mapkey — - -
Description ‘ Modify Selection @ ‘

Create Part. The two

buttons Description and

To add a menu item or button, drag it from the "Commands” box e
to the menu bar or any toolbar. To remove a menu item or button, @

Modl.[y Selection are now drag it off of the menu bar or its toolbar.

444444

active. Selecting the
former shows you the
description you entered

Figure 12 Adding mapkeys to menus and toolbars

when defining the mapkey. Selecting the latter allows you to modify the mapkey button
image (currently a “happy face”) and display. You might like to get rid of the “happy
face”, since all mapkeys use this same icon. You can select from a large collection of

Pro/E icons, or design your own.

Drag the Create Part mapkey in the right pane up to the File pull-down menu and drop it
in a convenient location, as in Figure 13 (notice the changed button icon). Selecting this

will launch the mapkey.

Another way to utilize mapkeys is to create
shortcut buttons on the toolbars. Again select
the Create Part mapkey in the right pane and
drag it to a toolbar.

We now have three different ways to launch the
Create Part mapkey:

¢  from the keyboard, with “cp”
¢  from the pull-down File menu
¢ from the toolbar

Experiment with these to find out which one is
most suitable for you. Again, remember the
cautionary note about cluttering up your screen.

File Edit View Insert Analysis
0 New...
O Create Part
=* Open...
Set Working Directory...
%] Close ¥Window

L] Save
Save a Copy...
Backup...

Figure 13 Create Part mapkey
added to a pull-down menu
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Introduction to the Project

The assembly project to be completed in this tutorial involves the modeling and assembly
of the three-wheeled utility cart shown in Figure 14. The cart contains 26 or so parts,
many of which are repeated in the assembly. The total assembly has about 75 parts
(mostly bolts!). We will use the techniques introduced in the lessons to model various
parts of the cart as exercises at the end of each lesson. We will average about 4 parts per
lesson, so you should get lots of practice! In the final lesson, we will assemble the cart,
using a number of advanced functions for dealing with assemblies. Try not to “jump the
gun” on this assembly task, since the functions to be covered in the last lesson can really
speed up your job of putting the cart together.

For your modeling exercises, the parts shown at the end of each lesson® will illustrate the
critical dimensions. A figure will also be provided to show where the parts fit into the
overall assembly. Not all dimensions are shown on each part - you can use your
judgement and creativity to determine the remaining dimensions. In this regard,
please take note of the following:

¢  ALL UNITS ARE IN MILLIMETERS! You might set up your default part
template with this setting.

¢ Dimensions are usually multiples of Smm. For instance, all the plate material
and the wall of the cargo box are Smm thick. The tubing is 25mm square.

¢ All holes and cylinders, unless otherwise dimensioned, are ¢10. This applies
to bolt holes, pins, rods, and so on.

¢ All holes, unless otherwise dimensioned, are coaxial with cylindrical surfaces
or located on symmetry planes.

¢  For some of the trickier parts, in addition to the figures showing the
dimensions, there will be some discussion and hints to help you get going.

3 A complete list of project parts is included on page ix in the preface (right after
the Table of Contents) to this book.
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Figure 14 The assembly project - a three-wheeled utility cart

When we get to the final assembly in Lesson 8, remember that it is an easy matter to
modify dimensions of the various parts so that the assembly fits together. Don’t be too
concerned when you are modeling the parts if you have to guess at one or two
dimensions. These can be modified later if the need arises.

When you are creating the parts, try to be aware of the design intent for the part and how
it might eventually be placed in the assembly®. For example, if the part has one or more
planes of symmetry, it is common practice to use the default datum planes for these. In
the assembly, the Align constraint using these datum planes is an easy way to position the
part (usually with another symmetric part).

Although a suggested part name is given, feel free to make up your own part names
(although this might cause confusion in Lesson 8!). Remember that Pro/E is fussy about
files that get renamed in isolation, or moved to another directory. If a part has been used
in an assembly (or sub-assembly) or drawing, make sure the assembly or drawing is in
session if you rename or move the part so that the related files can also be updated.

For the entire project, you will require about 10 Megabytes of disk space to store all the
parts and assemblies. This does not include parts we will make during the lessons
themselves, just the cart project parts. If you are not particularly careful about disk
housekeeping (like deleting older version of the part files), you will require more space.

* You might like to look ahead to the last lesson to see what assembly constraints
are used for each part.
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Summary

This lesson should have given you enough ideas and ammunition to allow you to
customize the interface so that it will be most efficient for the type of work that you do.
There are a surprising number of users who are unaware of the many options available in
config.pro. Check them out!

In the next lesson we will look at functions directly involved in model creation. These
are for the creation of sweeps.

Questions for Review

1.

What is the name of the file containing your configuration settings?

What is the name of the file containing your screen layout settings?

When, and from where, are your configuration settings loaded? Why is there more
than one location?

What happens if your configuration file contains multiple entries for the same
option, each with different values?

How can you find out where your start-up directory is?

How can you create/edit/delete configuration settings?

When do configuration settings become active?

Is it possible to have more than one customized screen layout?

How do you place toolbars on the top/left/right edge of the graphics window?
How do you add/delete shortcut buttons on the toolbars?

How many empty toolbars are there?

Where are the toolbar definitions saved?

What is a mapkey?

Why do you usually want to keep mapkey names short?

How is the mapkey name different from the mapkey sequence?

How do you create a new mapkey?

Are new mapkeys stored automatically? Where?

What is the purpose of a part template? Where are they stored and how do you
access them?

How can you prevent the Browser pane from opening automatically when you
launch Pro/E?



1-22 Pro/E Customization and Project Intro

____________________________________________________________________________________________________________|

Exercises

1. Create an assembly template. This should have named datums and named views to
match your view selection mapkeys and default units to match your default part

template. Make this the default template for assemblies.

2. Set up a mapkey Create Assembly to create a new assembly using the default
assembly template.

3.  Put the Create Assembly mapkey on the pull-down File menu.
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Project Exercises

We’re going to start off with some of the easier parts in the cart. These should give you
some time to experiment with your configuration file, mapkeys, and part template. The
project parts are shown in the figures below. Their location in the cart is also shown for
reference in the Figure here:

PART: FRONT_SPR_PLATE

PART: ARM_VBRACK
(2 each side)

PART: ARM_BRACK
(3 each side)

PART: HANDLE_PIN

Part: handle pin

Part: front_spr_plate
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Part: arm_brack
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