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Lesson 3 

Floor Plans 
 

 

The floor plan is central to any architectural drawing.  We start by placing the exterior 

walls, then the interior walls, then doors, and finally windows. 

 

 

Tool Palette Walls 

Command Line WallAdd 

Menu Design→Walls→Add Wall 

 

 

 
Exercise 3-1: 

Creating Exterior Walls 
 

Drawing Name: New 

Estimated Time: 10 minutes 

 

This exercise reinforces the following skills: 

  

� Create Walls 

� Project Navigator 

 

1. 
 
 Start a new drawing using QNEW. 

 

2.  Launch the Tool Palette. 

 

 Select the Walls tab. 
 

 

3. 

 

Select the CMU-190 RIGID-038 Air-50 

Brick-090 wall style. 
 

4. 

 
 

Toggle ORTHO ON. 
 

Start the wall at 0,0. 

Create a rectangle 1830 mm tall and 914 mm wide. 

 



Copyrighted 
Material 

 
Copyrighted 

Material 
 

Copyrighted 
Material 

 
Copyrighted 

Material 

Autodesk AutoCAD Architecture 2009 Fundamentals 

3-2 

5. Select the Work tab. 
 

 

 

6. 

 
 

You see that the walls you placed 

are really 3-dimensional.   

 

7. Save your drawing as Ex3-1.dwg. 

 

 
TIP:  If you draw a wall and the materials composing the wall are on the wrong side, 

you can reverse the direction of the wall.  Simply select the wall, right click and select 

the Reverse option from the menu. 

 
 

 

Exercise 3-2: 

Inserting a Drawing Reference 
 

Drawing Name: new 

Estimated Time: 60 minutes 

 

This exercise reinforces the following skills: 

 

� Convert to Walls 

� Drawing references (previously known as external references or Xrefs) 

� Creating Interior Walls 

 

1. 
 

 

Start a new drawing using QNEW. 

2. 

 

Go to Insert→DWG Reference. 
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3. 

 

Locate ex3-1.dwg. 

Press Open. 

 

 

 

 
TIP:  Many architects use external drawing references to organize their projects.  That 

way teams of architects can concentrate just on their portions of a building.  External 

references also use less system resources. 

 

 

4. 

 
 

 

 Uncheck Specify On-Screen under Insertion point, Scale, and Rotation. 
 

Press OK. 

This will insert the file as an external reference at 0,0,0. 
 

 

5. Save the file as ex3-2.  

 

 

 

 
TIP:  You can convert lines, arcs, circles, or polylines to walls.  If you have created a 

floor plan in AutoCAD and want to convert it to 3D, open the floor plan drawing 

inside of AutoCAD Architecture.  Use the Convert to Walls tool to transform your 

floor plan into walls. 
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Exercise 3-3 

Convert to Walls 
 

Drawing Name: floor plan.dwg 

Estimated Time: 10 minutes 

 

This exercise reinforces the following skills: 

 

� Convert to Walls 

 

1. 

 
 

Open floor plan.dwg. 

This file can be downloaded from 

www.schroff.com/resources. 

2. 

 
 

Locate the Stud-102 GWB-018 Each Side: wall 

style. 

3. Highlight the wall tool. 

Right click and select Apply Tool Properties to → Linework. 
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4. Select all the interior lines. 
 

You are prompted if you want to erase the layout 

geometry.  Type Y for Yes. 

 
 

 

 

5. Switch to the Work tab so you can see how your house looks in 3D. 
 

 

 

6. Save the file as ex3-3.dwg. 
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Exercise 3-4: 

Wall Cleanup  
 

Drawing Name: ex3-3.dwg 

Estimated Time: 30 minutes 

 

This exercise reinforces the following skills: 

 

� Modifying Walls 

� Edit Justification 

� Wall Tools 

� Break at Point 

� Apply Tool Properties to Wall 

� Cleanup Tools 

 

1.   Open ex3-3.dwg. 

 

2. 

 

Add a closet area between the 

master bedroom and Bedroom #1. 
 

To do this, draw a wall from the 

mid-point of the wall in the 

horizontal direction and then draw a 

vertical wall from the mid-point of 

the new horizontal wall. 
 

3. 

 
 

To center the vertical wall, select it. 

Right click and select Edit Justification. 

4. 

 
 

Diamond grips will appear to indicate different wall 

justification methods (Left/Right/Center). 
 

Select the Center Diamond. 
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5. 

 

Draw a closet in Bedroom #2. 
 

Use the same interior wall style. 

Set the wall 304 mm from the hallway wall and 1820 

mm in length. 

6. 

 

Draw a vertical line 610 mm inside the living 

room area. 

7. 

 

Delete the vertical line to the right of  the line just placed. 

 

8. Locate the exterior wall style: CMU-190 

Rigid-038 Air-050 Brick-090. 
   

9. 

 

 

Convert the outside lines to the exterior wall style using Apply Tool Properties to 

Linework. 
 

10. When prompted to erase layout geometry, enter Yes. 
 

11. 

 

We have a small section of wall that should be split so that 

it can be assigned the exterior wall style. 
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12. 

 

 

Select the Break at Point tool on the Modify toolbar to split the 

wall into two sections. 

13. 

 
 

Select the wall. 
 

It will highlight. 

14. 

 
 

Select the point indicated as the break point. 

15. 

 
 

The wall is now two separate sections. 

16. 

 

Locate the CMU-190 Rigid-038 Air-050 

Brick-090 wall style. 

17. 

 
 

Right click and select Apply Tool Properties to→Wall. 
 

18. 

 
 

Select the small wall section to be converted. 

19. 

 
 

The wall will be converted to the correct wall style. 
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20. 

 
 

Select the small section of wall. 

Right click and select Cleanups→Apply ‘L’ Cleanup. 
 

21. 

 
 

You’ll be prompted to select the wall to cleanup with. 
 

Select the wall indicated. 

 

 

 

The corner is cleaned up. 

22. 

 
 

Repeat on the other corner. 

23. 

 
 

Select the interior wall. 

Right click and select Cleanups→Apply ‘T’ Cleanup. 

24. 

 
 

When prompted to select the boundary wall, select the wall 

indicated. 
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25. 

 

If the wall does not clean up 

properly, use grips to get the 

end points of the wall to 

appear correctly. 

26. 

 

 

Repeat the process for the other corner. 

27. 

 

Use the Break at Point Tool.  

Apply the correct Wall Style. 

Apply L Cleanup. 

 

28. 

 
 

The walls appear cleaner. 

29. 

 

The drawing is now updated. 
 

Save as ex3-4.dwg. 
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Exercise 3-5: 

Adding Closet Doors 
 

Drawing Name: Ex3-4.dwg 

Estimated Time: 10 minutes 

 

This exercise reinforces the following skills: 

 

� Adding Doors 

� Door Properties 

 

 

1. 
 

 

Open ex3-4.dwg. 

2. 
 

Locate the Bifold-Double door on the Doors tab of the Tool 

Palette. 
 

3. 

 
 

 

Highlight the Bifold-Double door. 

Right click and select Properties. 

 
TIP:  To create a freestanding door, press the ENTER key when prompted to pick a 

wall.  You can then use the grips on the door entity to move and place the door 

wherever you like. 
 

To move a door along a wall, use Door→Reposition→Along Wall.  Use the OSNAP 

From option to locate a door a specific distance from an adjoining wall. 
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4. 

 

Expand the Dimensions section. 

Set the Standard sizes to 1500.00 x 2100.00. 
 

Set the Opening percent to 50. 

 

 

 

 

 

 

 

 A 25% opening will show a door swing at a 45-degree angle. 

The value of the Opening percentage determines the angle of the arc swing.   

A 50% value indicates the door will appear half-open at a 90-degree angle.   
 

5. 

 

 

Expand the Location section. 
 

Set Position along wall to Offset/Center. 
 

 

6. Set the Automatic offset to 300.00.  
 

(This will center the closet doors along the wall.) 
 

Press OK to close the Properties dialog. 
 

7. Place the Bifold Double doors at the two closets. 
 

Note:   Enable a Midpoint OSNAP to locate the doors. 
 

The orientation of the door swing is determined by the wall side selected. 

In both cases, you want to select the outside face of the wall. 
 

 
 

TIP:  If you left click in the field, a down arrow will appear…select the down arrow 

and you will get a list of standard sizes.  Then, select the size you want. 
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8. 

 
 

Place a Bi-fold Double door in the wall shown. 

 

 
9. Save as ex3-5.dwg.  

 
 

 

Exercise 3-6: 

Adding Interior Doors 
 

Drawing Name: ex3-5.dwg 

Estimated Time: 10 minutes 

 

This exercise reinforces the following skills: 

 

� Adding Doors 

� Door Properties 

 

 
 

We will add single hinge doors in the areas shown. 
 

You may need to do some wall cleanup to get the rooms to look proper. 
 

Use AddWall, Extend, and Trim as needed. 
 

Try to keep the walls so they line up to keep the floor plan looking clean. 
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1.      Open ex3-5.dwg. 

 

2. 
 

Locate the Single Hinged door on the Doors tab of the Tool 

Palette. 

Right click and select Properties. 
 

3. 

 

 

Expand the Dimensions section. 

Set the Standard sizes to  

1000.00 x 2100.00. 

Set the Swing angle to 90. 

4. 

 

 

Set the Position along wall to Offset/ Center. 

Set the Automatic offset to 150. 
 

Press OK. 
 

5. Place the doors as indicated. 
 

6. Save the file ex3-6.dwg. 
 

 

 

 

 
Exercise 3-7: 

Create an Arched Opening Tool 
 

Drawing Name: ex3-6.dwg 

Estimated Time: 10 minutes 

 

This exercise reinforces the following skills: 

 

� Copying Tools 

� Tool Properties 

 

1. 

  

Open ex3-6.dwg. 

2. 
 

 

Locate the Cased Opening on the Design tab of the Tool Palette. 

 

3. Right click and select Copy. 
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4. 

 
 

Select the Doors tab. 

Right click and select Paste. 

5. 

 
 

Highlight the copied tool. 

Right click and select Properties. 

6. 

 
 

Change the Name to Arched Opening. 

Change the Description to Arched Opening. 

7. Expand the General section. 

Set the Description to Creates an 

Arched Opening. 

Set the Layer key to OPENING. 

Set the Style to Cased Opening- 

Halfround. 
 

8. 

 

 

Expand the Dimensions section. 

Set the Standard Size to 900.00 x 2100.00. 

Press OK. 

 
 

 

The tool is defined in the palette. 

9. Save as ex3-7.dwg.  
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Exercise 3-7: 

Adding an Opening 

 

Drawing Name: ex3-7.dwg 

Estimated Time: 10 minutes 

 

This exercise reinforces the following skills: 

 

� Adding Openings 

� Opening Properties 

� Copying Tools 

� Set Image from Selection 

 

Openings can be any size and elevation.  They can be applied to a wall or be 

freestanding.  The Add Opening Properties allow the user to either select a Pre-defined 

shape for the opening or use a custom shape. 
 

 

 

 

 

Openings will be added to the walls indicated. 

1. 

  

Open ex3-7.dwg. 

2. 
 

 

Select the Arched Opening tool. 

3. 

 

 

Expand the Location section. 

Set the Position along wall to Offset/Center. 

Set the Automatic offset to 300.00. 

4. 

 
 

Place the arched opening in the 

dining room wall. 
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5. Use View→3D orbit to view the arched opening. 

 

 

6. 

 

 

Select the Arched Opening icon on the tool 

palette. 

Right click and select Set Image from 

Selection… 

Pick the arched opening you created. 

The icon updates to show an arched opening.   

 

7. 
 

 

The tool icon updates with the new image. 

 

 

 

 

Next we place a rectangular opening in the location 

indicated. 

8. 
 

 

Select the Cased Opening tool from the Doors tool palette. 

9. 

 

Expand the Dimensions section. 

Select the Standard sizes of 1000.00 

x 2200.00. 

10. Expand the Location section. 

Set the Position along wall to Offset/Center. 

Set the Automatic offset to 300.00. 
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11. 

 

Place the opening in the wall between the kitchen and 

the dining room. 

 

12. 

 
 

Select the Work tab to view the openings. 
 

Select the Model tab. 

13. 

 

 

Place a rectangular opening between the kitchen and 

the family room. 

14. 

 

This is our floor plan so far. 
 

Save the file as ex3-8.dwg. 
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Exercise 3-9: 

Adding Doors 
 

Drawing Name: ex3-8.dwg 

Estimated Time: 20 minutes 

 

This exercise reinforces the following skills: 

 

� Adding Doors 

 

 

1. 
    

Open ex3-8.dwg. 

  

 

 

We will add an entry door on the wall 

indicated. 

 

 

2. 
 

 

Select the Hinged-Double-Exterior door. 

3. 

 
 

Expand the Dimensions section. 

Set the Standard size to 1800.00 x 2200.00. 

Set the Swing angle to 0.  
 

Expand the Location section. 

Set the Position along wall to Offset/Center. 

Set the Automatic offset to 300. 
 

4. 

 
 

Place the door so it is centered in the wall. 

5. 
 

Select the Overhead-Sectional door. 
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6. 

 

Expand the Dimensions section. 

Set the Standard size to 2440.00 x 

2134.00. 

Set the Swing angle to 0. 

7. 

 

Set the Position along wall to Offset/Center. 

Set the Automatic offset to 300.00. 

8. 

 
 

Place the door in the garage wall. 

9. 

 

 

 
 

Switch to the Work tab to view the garage door and 

front entry door. 
 

Switch back to the Model tab. 

10. Next we add a sliding door to the family 

room wall indicated. 

 
 

11. Select a Sliding Door - Double Full Lite to add to the 

family room.   
 

12. 

 

 

Expand the Dimensions section. 

Set the Standard size to 1800.00 x 2200.00. 

Set the Swing angle to 0.  
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13. 

 

 

Expand the Location section. 

Set the Position along wall to Offset/Center. 

Set the Automatic offset to 300. 

 

14. 

 

Place the sliding door. 

 

15. If your doors don’t look proper, use the Display 

Manager to modify the appearance. 

   

16. 

 

Go to Format→Display Manager. 

   

17. 

 
 

Expand the Configurations folder. 
 

Locate the Plan configuration under Medium Detail. 
 

Note that this configuration is in bold because it is the current 

active configuration. 
 

18. 

 

 

Place a check mark for Doors and 

Door/Window Assembly to set them 

visible in all views. 

19. Press Apply and OK.  
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20. Select the Work tab to view your model. 
 

 

21. Save the file as ex3-9.dwg.   
 

 

 

 
 

Exercise 3-10 

Add Window Assemblies 
 

Drawing Name: Lesson 3-9dwg 

Estimated Time: 30 minutes 

 

This exercise reinforces the following skills: 

 

� Add Windows 
 

 

1.  Open ex3-10wg. 

   

2. 
 

 

Select the Model tab. 

 

3. 
 

Select the Windows tab of the Tool Palette. 

Select the Casement-Double window. 
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4. Expand the Dimensions section. 

Set the size to 600 x 900.   

 

 
 

5. Expand the Location section. 

Set the Position along wall to Offset/Center. 

Set the Offset to 2510.00.   

 

 
 

6. 

 

Select the wall shown and the endpoint 

indicated. 
 

The endpoint is where the offset is calculated 

from. 

7. Select the Casement-Double window again. 
 

8. 

 

Place the window on the vertical bedroom wall. 

 Remember – if you don’t like the position of any of the 

Windows, you can reposition them. Just select the 

window, right click, and select Reposition Along Wall. 
 

 

 

9. 
 

 

Select the Casement window. 

10. Expand the Dimensions section. 

Set the size to 600.00 x 1200.00.   
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11. 

 

 

Expand the Location section. 

Set the Position along wall to Offset/Center. 

Set the Offset to 3′-1″.   

12. 

 

Place the window in the bath wall. 

 

13. Place a Double Casement window in Bedroom #2. 
 

 
 

14. 

 
 

Place a Double Casement window in Bedroom #2 

on the left vertical wall. 

15. 

 
 

Place a Double Casement window in Bedroom #3 

on the left vertical wall. 

 

 

16. 
 

Locate the Picture - Arched to place in the left dining room 

wall. 
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17. 

 

Expand the Dimensions section. 

Set the size to 600.00 x 1500.00 

Rise 300.00.   

18. 

 

 

Expand the Location section. 

Set the Position along wall to 

Offset/Center. 

Set the Offset to 0.00.   
 

19. 

 

Place the window. 

20. 

 

 

Add a Casement: Single window to the kitchen. 

 

 

21. 

 

 

Set the Head height to 2050.   
 

This will ensure that any cabinetry in the kitchen 

does not interfere with the window. 

22. 

 
 

Place an Arched Picture window with an offset of 0″ on 

each side of the entry door in the right living room wall. 
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23. 

  
 

Your floor plan should look 

similar to the one shown here. 
 

Save as ex3-10.dwg. 

 

 
 

 

 

Exercise 3-11: 

Adding a Fireplace 
 

Drawing Name: ex3-10.dwg 

Estimated Time: 20 minutes 

 

This exercise reinforces the following skills: 

 

� Using the Design Center 

� Adding Openings 

 

In this exercise, we add a fireplace to the family room.  You can download the fireplace 

from the publisher’s website or use the fireplace available from the Design Center. 

 

 

1.      Open ex3-10.dwg. 

 

Select the Model tab. 
 

2. 
 

 

Select the Design Center tool or type ADC on the command line. 

3. 
 

Select the DC Online tab. 
 

 

 Note:  In order to access DC Online, you must have an active internet connection.  

If you do not have an active connection, you can download the file from the 

publisher’s website and come back to this exercise. 
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4. 

 
 

In the Standard Parts section, browse to Fireplaces under 3D 

Architectural/House Design. 

5. 

 
 

There is a 3D model with a Hearth. 

6. 

 

Hover the mouse over the file icon.  An eyedropper will appear.  

This means the content is idrop-enabled.  Simply hold down your 

left mouse button to fill the eyedropper, then keep the left mouse 

button down, move the mouse into the graphics window and 

release the left mouse button to drag and drop the symbol into the 

drawing file. 
 

7. 

 
 

Place the fireplace into the family room wall. 

8. 

 
 

Use the 3D Orbit tool to inspect how the fireplace 

appears. 
 

Go back to a plan view. 

9. 

 
 

Go to the Walls tool palette. 
 

Select the Brick-090 Brick-090 wall style. 

10. 

 

 

Add walls in the vertical direction and in the horizontal 

direction to enclose the hearth. 
 

Switch Justification using the Properties dialog as you 

place the walls. 

11. 

 

Switch to a NE Isometric view to inspect the chimney. 
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12. 

 
 

We need to make the chimney taller. 
 

Select the walls for the chimney that were just 

placed. 
 

Right click and select Properties. 

13. 

 
 

Under Dimensions: 
 

Set the Base Height to 4875.00. 

14. 

 

 

The chimney now looks better. 
 

Switch back to a plan view. 

15. 

 

Place a small section of wall to enclose the chimney. 
 

  
 

Set the height to 1875.00. 
 

16. Select the wall for the chimney that was just placed. 

Right click and select Properties. 
 

17. 

 
 

Scroll down to Location: 
 

Set the Elevation to 3000. 
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18. 

 

 

Use new ViewCube tool to inspect 

your work so far. 

19. 

 

 

If you switch to a Realistic visual style, you see that we 

need an opening in our fireplace. 
 

Switch back to a plan view. 

20. 
 

 

Select the Opening tool from the Design Palette. 

21. 

 

 

Change the Width to 914.4. 

Change the Height to 862.6. 

22. 

 

 

Place the opening in the wall. 

23. 

 

 

Select the Home icon to switch to a 3D view. 

Then use the ViewCube to inspect the opening in the 

fireplace. 
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24. 

 

Your finished fireplace and chimney should look 

similar to this. 
 

Save the file as ex3-11.dwg. 
 

Close all open drawings. 

You can do this by typing CLOSEALL on the 

command line. 

 

 




