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Exercise 1 
 

Beam Elements 

 

 

Objectives 
 

At the end of this exercise, the learner should be able to: 

  

1. Set up a model using standard cross-sections beam elements with proper 

orientation; 

2. Set up and run a static analysis; 

3. Understand the units used in Pro/MECHANICA
®
; 

4. View maximum VM stress and maximum displacement results; 

5. Create shear and moment diagrams; 

6. Understand the basic solving principle of the Finite Element method. 

 

Introduction 
 

Beam elements are fast and efficient elements in FEA.  They are 1-D in nature but still 

represent what is called a 3-D idealization.  A 3-D idealization is a FEA modeling 

perspective of the model.  For a beam element, imagine an I-beam.  It could be 

represented as a straight line, with a cross-section the shape of an “I” assigned to it.  

This is, in essence, how a beam element is represented.   

 

From a modeling perspective, beam elements are relatively easy to create. They are 

defined by the following: 

 

- A datum curve determining the position of the end points of the beam; 

- A material; 

- A cross-sectional area (which will give an area moment of inertia and a 

torsional stiffness); 

- A defined orientation for the cross-section. 

 

Estimated time: 1½ hours
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Each beam element has its own internal coordinate system (let’s name it the Beam 

Section Coordinate System or BSCS). The BSCS has the following characteristics in 

Pro/MECHANICA
®
: 

 

- The x-axis is along the length of the beam (the beam’s axis); 

- The y-axis defines the perpendicular orientation of the beam section with 

respect to the beam’s axis; 

- The z-axis will follow according the first two axis’ above. 

 

The restriction of using beam elements in Pro/MECHANICA
®
, as with any other 

software, is that the section remains perpendicular and planar to the datum curve  

(the beam axis) through the entire FEA solution.  Before using beam elements, make  

sure that the part is fairly representative of a beam and that the aspect ratio (l/t) > 10. 

 

Procedure 
 

(NOTE: Before you start, create a folder named “beam” using Explorer; this will be the 

working directory for the exercise.) 

 

The problem to be solved: 

               F = 4500 lbs 

 

               2″ 
 

     40″       1″ 
 

              X-SECTION 

 

Objectives: Draw Shear and Moment diagrams, and obtain the Maximum VM stress and 

maximum deflection fringe plots. 
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Flow Chart of Procedure 
 

Here is an overview of the exercise, in the form of a flow chart, showing the different 

steps involve in the analysis. 

 

In Pro/ENGINEER
®
 WILDFIRE                In Pro/MECHANICA

®
  

 

 

Start 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Start Pro/ENGINEER® WILDFIRE 

 

Details on how to this is different from system to system.  For a typical windows 

platform: 

 

Start > Programs > PTC 
 

> Pro/ENGINEER  

(It takes approximately 30 seconds for Pro/ENGINEER
®
 to start.) 

 

Set up your working directory (File > Set Working Directory). 

Create Beam Section 

and Orientation 

Assign beam section & 

orientation & material to 

datum curve 

Assign boundary 

conditions to model 

Create and Run 

a static analysis. 

Check out results (stresses, 

displacements, etc…) 

Create part & Model 

Datum Curve 
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Figure 1 

 

Select your working directory, then select OK. 

 

2.  Create a part named: beam 
 

Select File > New. 

 

 
Figure 2 

 

Select part and type in: beam; then click on OK. 
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3. Setting up in Pro/ENGINEER® WILDFIRE for FEA Modeling 
 

Before we go to MECHANICA
®
, we must understand how beam elements are created.  

Think of beam modeling as a sweep-type protrusion in Pro/ENGINEER
®
 WILDFIRE.   

In the case of FEA modeling, a datum curve is created in Pro/ENGINEER
®
, then the 

beam cross-section (the beam element) is assigned in MECHANICA
®
.   

 

3.1 Creating a Datum Curve for Beam Assignment 

 

Click on the sketch datum curve icon. Use front as your sketching plane and accept 

the default viewing direction and other references.  (See dialog box below.) 

 

 
Figure 3 

 

Click on Sketch.  Once in sketcher, Use the line sketching tool        icon and sketch a 

horizontal datum curve as shown below with the following characteristics: 

 

• 40 units long; 

• Aligned with the top plane, symmetric about the right plane. 
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Figure 4:  View of sketch for datum curve 

 

NOTE: To modify your dimension, select the dimension to be modified and click on 

this icon (or alternatively double click on the dimension). 

 

Select Done out of sketcher (        icon).  Turn datum planes off using the datum icon 

at the top of your screen.  Select Tools > Environment (pull-down menu) and check 

off the spin center for increased visibility.  Select OK. 

 

 

Procedure in Pro/MECHANICA®  
 

 

1. Go to Pro/MECHANICA® from Pro/ENGINEER® 
 

Select Applications > Mechanica from the top pull-down menu (wait a few seconds). 

You will see a unit info dialog box come up on the screen as shown in Figure 5. 
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Figure 5: Unit Info Window 

 

Important: Have a look at the working units and then Click Continue.  This box will 

only reappear for that part if Pro/ENGINEER
®
 WILDFIRE is shut down.  The following 

box will come up: 

 
Figure 6 

 

Select Structure from the menu, then OK. 

 

 

2. Beam Assignment 
 

2.1 Beam Section 
 

Select Insert > Beam.  The dialog box in Figure 7 will come up.   
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Figure 7 

 

Under the Start tab, for the Section item, click on More; the following window will 

come up: 

 
Figure 8 

 

Click on New.  The dialog box shown below will come up.  Enter the information as 

seen in Figure 9.   

 

STOP 

What we are doing at this time is giving the cross-sectional dimensions of the beam 

element used for the analysis. At this time you must know these dimensions.  The 

cross-section is constant through the datum curve representing the beam.  The beam 

for our analysis is a rectangle 1 in wide and 2 inches high. 
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Figure 9 

 

NOTE: If the section is not in the above menu of pre-defined X-section, you can sketch it 

easily using the sketch options off the type menu. The menu picks are ‘sketch thin’ or 

sketch solid.  It will then take you to the Pro/ENGINEER
®
 Sketcher. 

 

Once the information is entered, click on OK. Then OK the beam section dialog box 

to return to the Beam Definition dialog box.   

 

We must now orient the vector of the cross-section.  Even though it will show up on 

the screen if we don’t, Pro/MECHANICA
®
 wants to make sure that it is oriented the 

proper way. The software needs insight here as to which way to go and to make sure 

that we know what we are doing!  A vector will be used to determine the orientation.  

This vector will determine the beam section coordinate system orientation.  

 

 

2.2 Beam Orientation 
 

Under the Start tab, for the orientation item, click on More. The Beam Orientation 

dialog box comes up; click on New.  Enter the following information in the box as 

shown in Figure 10. 

2. Select 

3. Enter 

dimensions 

1. Enter text 
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Figure 10 

 

Defined by: Y direction of vector in WCS Vector (0, 1, 0). (This defines the 

orientation of the cross-section, as explained on the previous page in the STOP note.)  

Click on OK then OK for the Beam Orientation dialog box. 

 

 

2.3  Beam Definition 
 

Complete the Beam Definition window as follows (also see the next page for menu 

selection description): 

 
Figure 11 
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Procedure to complete Figure 11: 
 

� Under Name: enter beam_exercise1. 

� Under References: select Edge/Curve. Click on the arrow and select the datum 

curve on the screen, then click on done sel. (Pay attention: selecting it more than 

once reverses the selection here.) 

� Material: Select More… and the following window will come up: 
 

 

Figure 12 

 

Select Steel by scrolling down the left column and moving it to the right column 

by clicking on the triple arrows box in the center. Then click on OK.  There are no 

beam releases for this analysis.  Select OK and note that small rectangles appear 

along the datum curve.  Zoom in on one of the rectangles and look!  
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Figure 13 

 

You should be able to see a vector inside the beam.  This vector is oriented in the 

coordinates given above (0, 1, 0).  You could easily change the orientation of the 

rectangular section and the vector simply by changing the directional coordinates  

of the vector.  Our beam idealization is fully defined.  Good job! 

 

 

3. Constraints 

 
Select Insert > Displacement Constraints  

or click on the icon as shown to the right. 

 

 

The following dialog box will come up. Enter and select the information as 

shown: 
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Figure 14 

 

� Name: end_constr_1 

� Member of set: ConstraintSet1 

� Under References, select Points. Click on the arrow icon         and select the end 

point as shown in Figure 15: 

 

 

 
Figure 15 

This point 

All translation 

DOF fixed 

All rotation 

DOF fixed 
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Select OK to close the Constraint Definition box. 

 

 

 4. Loads 
 

Select Insert > Force/Moment Load 

or click on the icon as shown to the right. 

 

The following dialog box will appear.  Fill out the information as seen in 

Figure 16.  

 

        
Figure 16 

 

Under References, select Points. Click on the arrow icon         and select the end point as 

shown below: 
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Figure 17 

 

Similar to the constraint point selection, select the vertex (located on the opposite end of 

the beam.  Click OK.  Under Force > Components, enter 4500 in the Y direction box. 

 

Select OK off the Force/Moment dialog box.   In order to properly show the load, from 

the top pull-down menu select View > Simulation display and select appropriate 

selections as shown in the dialog box below: 
 

 
Figure 18 

This point
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Click on OK to close the window.  The resulting window should look like the following 

(default view): 
 

 
Figure 19 

 

5. Generating Beam Elements 
 

We now need to generate the finite element mesh.  The nice feature about 

Pro/ENGINEER
®
 WILDFIRE is that now we can control the mesh of the model without 

having to go to independent mode.  There will be more applications of this new feature in 

subsequent exercises.  For the time being, Select AutoGEM > Create.  The following 

box will come up: 

 
Figure 20 

 

This box controls the mesh features, type and density.  Click on create.  The following 

dialog box will come up. (If the Create button is grayed out, review that the elements and 

material have been set properly) 
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Figure 21 

 

One beam element has been created.  Click on Close > Close and answer Yes to the 

following: 

 
Figure 22 

 

 

6. Set up and Run Analysis 
 

6.1 Static Analysis 
 

We will now attempt the static analysis of the beam.  Select Analysis > Mechanica 

Analyses-Studies from the right menu; the window shown in Figure 23 will open. 

 

 
Figure 23 

 

Select File > New static from the top left corner menu.  The following dialog box 

will come up.  Enter the following information: 
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� Name: Static1 

� Description: Analysis of cantilever beam. 

� Constraints and Loads as shown below. 

� Method: Multi-Pass Adaptive with 10 percent convergence.   

� Converge on local displacement and strain energy and global RMS stress. 

 

 
Figure 24 

Click on OK. 

 

6.2 Running the Analysis 
 

With the following window still up, select the analysis, use your right mouse button 

to scroll down to Start.  The analysis will now be running. The software will ask you 

if you want error detection and see the diagnostics window. Answer Yes. 

 

 
Figure 25 

 

To check things as the calculations are performed, still using the right mouse button, 

select Status.  (Note how fast the solution converged).  From the status summary file, 

the following information is important to consider. 
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Figure 26 

 

We are getting a maximum bending stress of 2.7 e+05 psi or 270 ksi, which is the 

same value as the exact solution from Mechanics of Solids.  The following table gives 

an overview of what details you should look for from the results of an analysis: 

 

TABLE 1.1: OVERVIEW OF SUMMARY FILE  

Item Description Where to find it What it should be 

Convergence The convergence will let 

us know if all elements 

converged and if they all 

converged to a solution. 

Click on Status 

under the Info menu 

and scroll down. 

For beams, less 

than 1% 

(0% for this 

analysis) 

270 ksi 

(max_stress_vm) 

 

Maximum 

VM stress or 

displacement 

of Model 

Gives the maximum Von 

Mises Stress or 

displacement for the 

analysis 

Click on Status 

under the Info menu 

and scroll down. 

.012885 (*) 

(max_displ_z) 

VM stress or 

displacement 

over entire 

model 

Gives the Von Mises 

Stress for the analysis for 

the entire model 

See procedure 

below. 

Depends on 

boundary 

conditions and 

geometry 

 

NOTE: (*) Be careful with the units of displacement in the results given by 

Pro/MECHANICA
®
.  This is discussed later in the exercise. Select Close and Close.   

Vm stress 

Displacements (*) 
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This will bring you back to the FEA model with the MEC STRUCT menu on the right 

hand side. 

 

Close the status window if not already done so. 

 

 

7. Analysis of Results   
 

Select Analysis > Results.  Once the empty window comes up, click on this icon named 

‘insert a new definition.’ 
 

 
Figure 27 

 

The following box will come up.  
 

 
Figure 28 

 

Complete the result window definition as shown in figure 29.  Under name, type in 

vm_stress (for Von Mises stress). 

 

 
Figure 29 
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Select the open file folder and select static1 for the analysis (click Open). Then fill out  

the contents definition box as shown above.  Once completed, select OK.  Then from the 

pull-down menu, select view > display.  The following window will come up: 

 

 
Figure 30 

 

Select vm_stress, then OK.  Then the following results window will come up: 

 

 
Figure 31: Von Mises Stress Results for Beam Analysis 

 (difficult to reproduce on a document) 

 

The results from a beam analysis are not the most impressive to look at; and are very 

difficult to reproduce on a document.  But they provide accuracy, given that your 

geometry and boundary conditions are precise.  The only colors that we see are along the 
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beam curve that represents the point on the beam cross-section where the Von Mises 

maximum stress is located.  We can see that the maximum stresses are at the fixed end of 

the beam.  Note that the maximum value is the same as the one given in the summary file. 

 

Note: you can save this window by simply selecting the save or save as icon on the top of 

the window.  Select File/Exit Results and answer No to the question: Do you want to 

save the current window?  

 

As a practice exercise, create the following result window in order to look at the 

maximum displacement from the model.  Simply follow the procedure in item 7 above.  

The only changes being under quantity on the definition form.  

 

 
Figure 32 

 

Select OK and Show. 
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Approximate Finite Element Analysis Solution (Theory Warning) 
 

Don’t skip this! There are some more Mechanica
®
 procedures included with it to 

make it more fun. 

 

In solving the beam analysis using FEA theory, the problem can be seen as follows, 

including all reactions and forces: 

 

 

 

       F = 4,500 lbs 

 

 Miz 

      

      y     L = 40 in. 

 x    Fyi 

  z  vi   , θzi                   vj   , θzj  
 

Figure 33 

 

 

Table 1.2 gives the symbol definitions: 

 

TABLE 1.2: SYMBOL DEFINITIONS 

Symbol Definition 

L Length of beam. 

Miz Bending moment at the fixed end of the beam. 

Fyi Vertical reaction at the fixed end of the beam. 

E E is the young’s modulus of elasticity of the material. 

I The 2
nd
 Moment of Area. 

d
2
v/dx

2
 The curvature of the beam (not shown). 

vi The vertical deflection at x = 0. 

θzi The beam slope at x = 0. 

vj The vertical deflection at x = L. 

θzj The beam slope at x = L. 

 

The general equation for beam deflection is from beam theory as follows: 
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ziyiz

zz

MxFM

where

dx

vd
EIM

+=

=

;

2

2

 

 

Consequently: 

      ziyiz
MxF

dx

vd
EI +=

2

2

               (1-1) 

 

Let’s get the moment diagrams from Mechanica
®
; this will be fun.  From your beam 

model, where you are in Applications > Mechanica > Structure, select Results > then 

click on the ‘insert a new definition’ icon. 

 

 
Figure 34 

 

Select static1 for the analysis. Then click on Accept.  The following contents definition 

box will come up.  Select and type in all information as shown in Figure 35. 

 

 
Figure 35 

 

Enter and select the following information as indicated in the figure above: 
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� Name and Title: V_M and Shear and Moment Diagrams 

� Design Study: Select the open folder and open the static1 analysis. 

� Display Type: Select Graph. 

� Quantity: Select shear and moment (and de-select P, Vz, Mx and My as they are 

not necessary for this two-dimensional problem).  Refer to the coordinate system 

on the beam model for those.  We only need the shear along the z-axis and the 

moment with respect to the y-axis.  (If you are not sure that you followed the 

modeling properly for this exercise, you can keep all shear and moment selected, 

it is not  going to change the answer.) 

� Graph Location: Make sure that curve is selected.  Click on Select and select 

the beam curve off the screen.  Click on the middle mouse button.  You will 

then be prompted with the following message as MECHANICA
®
 highlights one 

of the ends of the beam.  Select toggle once. Then OK. 
 

 
Figure 36 

Click on OK, then Accept and Show. 
 

 
Figure 37: Shear and moment diagrams 
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It may be difficult to see the numbers on the graphs above but on your screen, you should 

get the results we were expecting, where the maximum shear is 4,500 lbs and the 

maximum bending moment is 180,000 in.lbs.  Select File > Exit Results.  Do not save 

the result window. 

 

Now let’s integrate twice equation 1-1 above.  This will give the following: 

 

21

23

2

26

1
2

AxA
xMxF

vEI

AxM
xF

dx

dv
EI

ziyi

z

zi

yi

z

+++=

++=

 

 

1
st
 integration 

2
nd
 integration 
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From our problem definition, we have the following boundary conditions: 

 

At x = 0 At x = L 

vi = 0 

 

θzi = 0 

vj 
 

θzj  

 

Where v is the deflection (vertical) and θ is the slope at the respective locations.  Which 

will give the following 2 equations for the bending moment and the reaction force at the 

fixed end of the beam (i): 

 

 

zj

z

j

z

yi

zj

z

j

z

i

l

EI
v

l

EI
F

l

EI
v

l

EI
M

θ

θ

23

2

612

26

+=

+=

    (1-2) 

 

Which can be written under the following matrix form: {K} {D} = {F} as follows: 

 

 
⎭
⎬
⎫

⎩
⎨
⎧

=
⎪⎭

⎪
⎬
⎫

⎪⎩

⎪
⎨
⎧

zi

yi

zj

j

M

Fv

ll

ll
EI

θ2
    

6
  

6
    

12
 

2

23

  

 

Where {K} is the stiffness matrix for our beam deflection problem.  From our diagrams 

and figure above, we have the following data: 

- Fyi = 4,500 lbs and; 

- Mzi = 180,000 in. lbs 

- E = 29 X 10
6
 psi 

- I = bh
3
/12 = (1) (2)

3
 / 12 = .667 in.

3
 

 

What we are looking for here is the value of vj, solving the matrices above using the 

Gauss elimination method for vj gives a maximum displacement of 4.95 in.  Do you 

remember how to solve matrices?  Let’s bring back those bad memories: 

 

We have from equation (1-2): 

 

⎟
⎟
⎟
⎟

⎠

⎞

⎜
⎜
⎜
⎜

⎝

⎛

180,000         
2

      
6

4,500       
6

       
12

2

23

l

EI

l

EI

l

EI

l

EI

 

 

Line 1 

Line 2 
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We need to bring the matrix to a form as follows: 

 

⎟⎟
⎠

⎞
⎜⎜
⎝

⎛

C2               1                0

C1              1               1 A
 

 

 

So let’s perform the following operations on the matrix: 

- Divide line 1 by EI12 / l
3
 and; 

- Divide line 2 by EI6 / l
2
. 

 

Which gives the following matrix: 

 

⎟
⎟
⎟
⎟

⎠

⎞

⎜
⎜
⎜
⎜

⎝

⎛

,00003             /3        1

753               /2         1

2

3

EI

l
l

EI

l
l

 

 

 

Let’s now subtract line 1 from line 2. 

 

⎟
⎟
⎟
⎟

⎠

⎞

⎜
⎜
⎜
⎜

⎝

⎛

− 753-,00003            /6       0

753                     /2         1

32

3

EI

l

EI

l
l

EI

l
l

 

 

 

Finally, let’s divide line 2 by -l/6 

 

⎟
⎟
⎟
⎟

⎠

⎞

⎜
⎜
⎜
⎜

⎝

⎛

+ 250,2180000-            1       0

753                     /2         1

2

3

EI

l

EI

l

EI

l
l

 

 

Which gives the following solution, when all proper values are put in the matrix: 

 

θzj = -.186 rd and 
vj = 4.95 in. 
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Comparing the deflections: 

 

FEA Approximate 

Solution 

Pro/MECHANICA
®
 

Solution 

Exact Solution  

(PL
3 
/ 3EI) 

 

4.95 in. 

 

1.289 X 10
-2
 (sec

2
) 

 

4.96 in. 

 

The above results do not concur.  Well, the software ones anyway. What went wrong 

here?  Pro/MECHANICA
®
 actually gives a deflection value much smaller than the exact 

and FEA approximation solutions.  But the maximum Von Mises stress calculated by 

Pro/MECHANICA
®
 was accurate? 

 

The problem is with the system of units that Pro/Mechanica® uses.  We need to multiply 

the answer we got for deflection by the gravitational (386.4 in/sec
2
), so the final 

Pro/MECHANICA
®
 solution answer will be 4.96, almost the magnitude of the exact 

solution. 

 

 

Conclusion 
 

Beam elements are fast and accurate elements.  They are mainly used by analyst for 

getting an idea of the big picture of an assembly of different cross-section.  The frame rail 

of a trailer for instance.  They are also useful to get the shear and moment diagrams of 

structures.   

 

The modeling is fast (datum curves) and the beam assignment is also fast.  Remember: If 

it looks and smells like a beam, then use beam elements for the analysis.  On the other 

hand, you will not be able to study stress concentrations around holes, so shell elements 

should then be used for this type of analysis. 

 

Be careful with the units of displacement in the results given by Pro/MECHANICA
®
, 

multiply your answer by the gravitational constant in order to get to the units that you are 

looking for (inches in this case). 
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Project 1 
 

Problem Definition 

 

Determine the location and magnitudes of the maximum VM stress and the maximum 

displacement (in y) of the following application (diving board). 

 

      F= 250 lbs. 

          (8 × 1) in.2 
 

 

                 Beam section 

          25 in. 

 

     50 in. 

 

          y 

                x 

       z 

Figure 38: Diving Board Loading Diagram 

 

 

Notes and Hints: 

 

1.       Fixes the location in all 6 DOFs. 

 

2.       Fixes the y direction DOF and the rotation with respect to x axis.  

 

3. Material: Use Aluminum 2014. 

 

4. Create a datum point at the center reaction, use vertex for the left reaction and the 

load. 
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Results 

 
Figure 39: Summary file results for Project 1 

 

 
Figure 40: Von Mises Stress fringe plot for Project 1 
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End of Exercise 

 

 


