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Chapter 1
Creating Custom Templates

In this chapter you learn how to prepare templates, create preset annotation 
styles, create title blocks, create object styles, and create materials and fill 
patterns.

This chapter introduces:

Preparing Templates
Presetting Annotation Styles
Creating Title Blocks
Creating Object Styles
Materials and Fill Patterns
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1.1 Preparing Templates

A template is an existing project that holds information about 
component families, settings, and views, and sometimes 
geometry, all of which can be used to create a new project. You 
can have several templates for different types of buildings, such 
as residential, commercial, and industrial. If you do a lot of work 
for a specific client (e.g., a school system), you can create a 
template specifically for their projects with associated title blocks 
and other information. The aim is to save time with standards so 
that you can concentrate on the design.

Settings for 
Templates

Defining Levels in a template is helpful. They could be just a few 
basic floor plans for a residential project, as shown in Figure 1–1, 
or 100 stories for a high-rise.

Figure 1–1

Settings that are typically added to templates include Units, 
Snaps, Temporary Dimensions, Object Styles (Lineweights, 
Line color, and Line patterns), Line Styles, Materials, Fill 
Patterns, Annotation Styles (Text, Dimensions, Arrowheads, 
and Loaded Tags), Wall Types, Loaded Families, Views, 
Levels, Sheets, and Views on Sheets.

To set the default template file, click  in the Application 
Menu. In the Options dialog box, select the File Locations tab 
and select a file for the Default t emplate file option.

Views Defined in the Residential Template
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How to: Create a Template File
The first step in customizing a template file is to create one 
where you can add the various settings, views, and other 
information. To save time, use an existing template that includes 
some of the basics rather than starting from scratch.

1. In the Application Menu, click  (New). 
2. In the New Project dialog box, select a template file to build 

from or select None for a blank project file.
3. In the Create new section, select Project template, as 

shown in Figure 1–2.

Figure 1–2

4. Click .
5. If you do not specify a template file, you are prompted to 

specify the initial unit system for the project: Imperial or 
Metric, as shown in Figure 1–3.

Figure 1–3

6. Add settings, families, views, and more as needed to the new 
file.

7. Save the template file.

Project template files have the extension RTE.
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Specifying 
Units

Even though you select Imperial or Metric units when you create 
the template, you can set up the Project Units with specific 
formats and options. For example, if you are working on a Civil 
project where everything is set up in feet, you would specify 
Decimal Feet as the Length Format. For an international metric 
project, you need to find out if the country typically uses Meters, 
Centimeters, or Millimeters as the length units.

How to: Set Up Project Units

1. In the Manage tab>Settings panel, click  (Project Units) or 
type UN. 

2. In the Project Units dialog box, as shown on the left in 
Figure 1–4, in the Format column, click the button next to the 
type of units that you want to change. The related Format 
dialog box opens, as shown on the right in Figure 1–4.

Figure 1–4

3. Select the Units, Rounding, and other options as needed.
4. If needed, select the Discipline (set to Common by default) 

and change the formats for each discipline. The other options 
are Structural and Electrical.

5. Click  to close each dialog box.
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Format Options

Each unit has specific formatting options. The option is grayed 
out if it is not applicable to that unit.

The Use project settings and Show + for positive values 
options are grayed out when setting units for the project. This 
dialog box is also used when creating dimension styles or 
specifying label formats. At that point, the options are 
available.

Units Select the type of units in the Units drop-down list, as 
shown in Figure 1–5.

Figure 1–5

Rounding Specify how tightly you want the dimensions to be 
rounded. The options depend on the Units you 
selected.

Unit Symbol If you are using metric units, you can select from a 
unit symbol, such as cm for centimeters or None.

Suppress 
trailing 0’s

(For decimal-based units) If selected, this option 
removes any trailing 0s. For example, it displays 1.5 
instead of 1.50 if you are using two decimal places.

Suppress 0 feet (Length and Slope only.) If selected, this option 
removes the 0 in front of a dimension in inches only. 
For example, instead of 0’-4”, you see 4”.

Use digit 
grouping

If selected, the unit uses the Decimal symbol/digit 
grouping specified in the Project Units dialog box, as 
shown in Figure 1–6.

Figure 1–6

Suppress 
spaces

(Length and Slope only) If selected, this option 
removes the spaces between the feet and inches, so 
that a dimension reads 1’-2" rather than 1’ - 2".
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Snap Settings The Snaps dialog box controls Dimension Snaps, which are the 
increments you see in temporary dimensions, and Object Snaps, 
which are the points on elements that you can select . It also lists 
Temporary Overrides for which you can use a keyboard shortcut. 

In the Manage tab>Settings panel, click  (Snaps) to open the 
dialog box, as shown in Figure 1–7. 

Figure 1–7

If you want to snap to a specific type of snap, you can use the 
typed shortcuts you see listed in parentheses in the dialog 
box. Type the shortcut and the cursor only snaps to the type 
of snap you specify until you pick a point.
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Customizing 
Shortcuts

You can use keyboard shortcuts for commands other than 
snaps. Hover your cursor over a tool, such as Wall, and display 
the tool tip to see the associated shortcut, as shown in 
Figure 1–8. Keyboard shortcuts can be customized. 

Figure 1–8

How to: Customize Keyboard Shortcuts

1. In the Application Menu, click . 
2. In the Options dialog box, User Interface tab, Configure 

section, click , as shown in Figure 1–9.

Figure 1–9

3. In the Keyboard Shortcuts dialog box, use the Search or 
Filter options to narrow the search, as shown in Figure 1–10.

Figure 1–10
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4. Select the command you want to add or modify.
5. In the Press new keys section, type in the shortcut you want 

to use, as shown in Figure 1–11, and click .

Figure 1–11

6. Click  when you are finished.

You can also remove shortcuts and import or export the 
shortcut file to be used in other copies of Revit.

Temporary 
Dimension 

Settings

Temporary dimensions display when you draw or edit building 
elements in Revit. By default, they measure from the center lines 
of walls to the center lines of openings, as shown in Figure 1–12.

Figure 1–12

When you move a witness line to another element or part of 
an element, the location is remembered within the current 
session of Revit.
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You can control where dimensions are placed by default. In the 

Manage tab>Settings panel, expand  (Additional Settings) 

and click  (Temporary Dimensions) to open the Temporary 
Dimension Properties dialog box, as shown in Figure 1–13.

Figure 1–13

Temporary dimensions can be attached to Centerlines, 
Faces, the center or face of the core objects in Walls, and the 
center lines or openings of Doors and Windows.

You can set up these properties in the template file or modify 
them at any time. They do not affect existing elements in your 
project. 

You can control the size of the temporary dimension text in 
the Options dialog box on the Graphics tab, as shown in 
Figure 1–14.

Figure 1–14
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Practice 1a Preparing Templates
In this practice you will create a new template file, modify the 
units, snaps, and temporary dimensions, and add several new 
levels, as shown in Figure 1–15.

Estimated time for 
completion: 10 minutes.

Figure 1–15

1. In the Application Menu, click  (New).

2. In the New Project dialog box, select the default template file 
and Project template, as shown in Figure 1–16, and click 

.

Figure 1–16
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3. In the Quick Access Toolbar, click  (Save) and save the 
template in your class directory as Midrise Template.rte. 

4. In the Manage tab>Settings panel, click  (Project Units) 
or type UN. In the Project Units dialog box, set the formats as 
follows:

5. Click  to close the Units dialog box.

6. Set the Snaps and Temporary Dimensions as needed.

7. Switch to an elevation view and add three more levels above 
the current levels, at 10’-0” apart. Add two more levels below 
Level 1 named Basement 1 and Basement 2. These are 
also 10’-0” apart. Creating the levels also creates their views.

If you draw the levels using  (Level), you can select 
the Make Plan View option in the Options Bar to create 
the associated views.
If you copy the existing levels, you need to create the 
plan views and ceiling plan views. In the View tab> 

Create panel, expand  (Plan Views) and click 

 (Floor Plan) and/or  (Reflected Ceiling Plan).

8. Switch back to the Level 1 floor plan view and save the 
template.

Length:

Units Feet and Fractional Inches

Rounding To the nearest 1/8”

Suppress 0 feet Check

Angle:

Rounding 0 decimal places
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1.2 Presetting Annotation Styles

Another set of elements you can customize in your template file 
is Annotation Styles. These range from how the arrowheads look 
to dimensions, text types, and tags, as shown in Figure 1–17.

Figure 1–17

Text, Dimensions, and Arrowheads are all system families. This 
means they have a standard set of parameters, which you can 
modify and save as a type. Callout, Section, and Elevation tags 
can be modified slightly within Revit. Most tags are created using 
families.

Creating Text 
Types

Text types are used to standardize text formatting (such as the 
font, text height, etc.), as shown in Figure 1–18. They apply to 
both standard text and Model Text in Revit.

Figure 1–18

The Text command places text at the height you need for the 
final plot (e.g., 1/8” high). The view scale controls the height 
of the standard text in the views.
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The Model Text command places text that is typically used 
on the building, such as the signage shown in Figure 1–19. 
Text types for Model Text should be the full height of the text 
and are not affected by the view scale.

Figure 1–19

How to: Create a Text Type
1. Start the Text or Model Text command. (Place the Model 

Text and select it.)

2. In Properties, click .

3. In the Type Properties dialog box, click .
4. Type a new name.
5. Modify the parameters as needed for the new type, as shown 

for annotation text in Figure 1–20.

Figure 1–20

6. Click  if you want to create another type.

7. Click  twice if you are finished.
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Dimensions Dimensions are one of the more complex system families in 
terms of the number of parameters you can modify. You can 
create three typical types: linear, radial, and angular, as shown in 
Figure 1–21, as well as types for Spot Elevation, Coordinate, 
and Slope.

Figure 1–21

Values for the parameters (such as text size, witness line 
extension, etc.) are the actual plot size for these elements. 
The view scale controls how large they are in the drawing.

How to: Create Dimension Types
1. In the Annotate tab>Dimension panel, expand the Dimension 

panel title, as shown in Figure 1–22, and click  next to the 
dimension type you want to create.

Figure 1–22
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2. In the Type Properties dialog box, click  to 
create a new type.

3. Modify the parameters as needed for the new type. 

4. Click  when you are finished.

Dimension Type Options

The dimension type parameters include the Graphics of the 
dimension (such as Tick Mark and Line Weight), as shown in 
Figure 1–23 for Linear dimensions, and the Text formatting 
(scroll down to view).

Figure 1–23

You can specify a Text Background option. If you set the 
value to opaque, it automatically masks any elements behind 
the text. If it is set to transparent, anything the text overlaps 
is still visible.

You can set the units for Linear/Radial dimensions and 
Angular dimensions. For example, if you are drawing a detail, 
you might want to create a dimension type that displays the 
distance in 1/16" inch rather than a project standard of 1/8".
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If you are dimensioning doors and windows by their widths 
rather than their centers, you can also have the opening 
height displayed with the dimension. Select the Show 
Opening Height option.

Arrowheads A variety of arrowhead types are supplied with Revit, including 
open and filled arrow styles, tick marks, and dots. You can also 
create custom styles by duplicating an existing style and defining 
the parameters, such as the Arrow Style shown in Figure 1–24. 

In the Manage tab>Settings panel, expand  (Additional 

Settings) and click  (Arrowheads) to open the dialog box.

Figure 1–24

Arrowheads are used by both text (with a leader) and 
dimensions.

Callout, 
Elevation, and 

Section Tags

Callout, Elevation, and Section tags can be modified to suit an 
office standard. In the Manage tab>Settings panel, expand 

 (Additional Settings) and click  (Callout),  (Elevation), 

or  (Section). Then, in the Type Properties dialog box, 
duplicate an existing tag and make changes to the type 
parameters.

The Callout Tags parameters specify a Callout Head and the 
Corner Radius of the callout box, as shown in Figure 1–25. 

Figure 1–25 
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The Elevation Tags parameter is the Elevation Mark. You can 
choose from a variety of types that come with Revit, as shown in 
Figure 1–26. For example, you may want to set the exterior 
elevation mark to display a square body and the detail number 
on the sheet where it is placed.

Figure 1–26

The Section Tags parameters include both the Section Head 
and Section Tail, as well as the Broken Section Display Style, as 
shown in Figure 1–27.

Figure 1–27

Once you set up these tags, you can connect them with the 

tag types used in the  (Callout),  (Elevation), and  

(Section) commands. In Properties, click  and set 
up the type parameters, as shown for a Building Elevation in 
Figure 1–28.

Figure 1–28
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Loaded Tags Tags are graphical information about elements in your drawing, 
such as the door, window, and wall tags shown in Figure 1–29. 
You can load tags from the Library to use in a project. Just as 
having text and dimension types set up is helpful, having the 
specific tags required for your projects set up in the template file 
is also helpful.

Figure 1–29

Tags are created as separate drawings and stored in the Library. 
In the Tags dialog box, you can easily load the tags you need 
from the Library into the project template, as shown in 
Figure 1–30. Therefore, when you start the Tag command, the 
one you need is available.

Figure 1–30
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How to: Specify Loaded Tags
1. In the Annotate tab>Tag panel, expand the panel title and 

click  (Loaded Tags).

2. In the Tags dialog box, click .

3. In the Library, open the Annotations folder.

4. Select the required tags and click . Hold down 
<Ctrl> to select multiple tags.

5. When you have loaded all of the tags that you typically need 

for a project, click .
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Practice 1b Presetting Annotation Styles
In this practice you will create several text types, add a 
dimension style that uses arrows, as shown in Figure 1–31, and 
load typical tags into the template file.

Estimated time for 
completion: 10 minutes.

Figure 1–31

1. Continue working in the template Midrise Template.rte.

If you did not complete the previous practice, open Midrise 
Template-Annotation.rte from your class folder.

2. Create the following text types:

3. Create a dimension style that uses arrowheads for radial and 
angular dimensions. Modify other parameters if desired. You 
can create an additional arrow type if time permits.

4. Load the following tags into the template:

5. Save the template.

1/8” Arial Use the default, but set the Height to 1/8”.

1/8” Hand Use a hand-lettering Font, such as Comic Sans MS, and 
select Italic.

3/32” 
Hand

Same as above with a Height of 3/32”.

1/4” Title Use the font of your choice, in bold.

Architectural Casework, furniture, and furniture systems

Civil Parking and planting
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1.3 Creating Title Blocks

Title blocks contain information about the company and 
consultants designing the project, project information, and 
sheet-specific information, as shown in Figure 1–32. This 
information might include but is not limited to the following: the 
project name, address, number, sheet number, revisions, and 
other parameters. Some of this information never change, some 
change by project, and some change for each sheet.

Labels and Revision 
Schedules are 
specifically used in title 
blocks.

Figure 1–32

You can create permanent information in the title block by 
sketching lines and adding text, symbols, and regions. The 
variable information is stored in labels. 

How to: Create a Title Block

1. In the Application Menu, expand  (New) and click  

 (Title Block).
You can choose from 
several preset sizes or 
create a custom size.

2. In the New Title Block - Select Template File dialog box, 

select a template file from the list and click . A 
new family drawing file opens and the Family tools display in 
the Ribbon, as shown in Figure 1–33. 

Figure 1–33
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If you select a template with a standard size, a rectangle 
of that size displays in the view.
If you select New Size, a rectangle with dimensions 
displays. Edit the dimensions to modify the size.

3. Add dimensions, lines, filled regions, symbols, text, labels, 
etc., as needed.

4. Save the file and close it.

Dimensions in the family file are not displayed when the title 
block is inserted.

Adding Labels Labels are a special kind of text that is added to title blocks or 
tags that you can change without modifying the rest of the 
elements. For example, you would use annotation text for the 
words Drawn By: and a label for the initials of the person who 
did the drawing (by default displaying DRW in Figure 1–34), 
because that varies from drawing to drawing.

Figure 1–34

The title block template comes with one text type and one 
label type already defined. You can create additional types in 
Properties. The Text and Label parameters are the same, but 
you must create separate types for each of them.

How to: Create a Label
1. In the Family Editor, in the Home tab>Text panel, click  

 (Label).
2. In the Modify|Place Label tab>Format panel, specify the 

alignments: Left, Center, Right, Top, Center Middle, or 
Bottom, as shown in Figure 1–35.

Figure 1–35
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3. Click in the drawing area to place the label, as shown in 
Figure 1–36. 

Figure 1–36

4. In the Edit Label dialog box shown in Figure 1–37, select a 
label in the Category Parameters list and double-click or click 

 (Add parameter[s] to label). You can select more than 
one by holding down <Ctrl>. 

Figure 1–37

5. Enter the Sample Value and specify any other options as 
needed.

If you are using several parameters in one label, select 
the Wrap between parameters only and Break (in 
column) options to separate them while still permitting a 
word wrap.

Click  (Add Parameter) to create a new parameter 
for the project.

Click  (Move parameter up) and  (Move 
parameter down) to reorder multiple labels.

6. Click .
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7. Rotate or stretch the label as needed (as shown in 
Figure 1–38), or select a point for an additional label.

Figure 1–38

8. Click  (Modify) or press <Esc> twice to finish the 
command.

Adding 
Revision 

Schedules

A table of revisions included in a project and/or sheet is typically 
added to a company title block. In Revit you can create a 
Revision Schedule that is then linked to the Revision Table in the 
project. 

How to: Add Revision Schedules to Title Blocks
1. In the Family Editor, in the View tab>Create panel, click 

 (Revision Schedule). 
2. In the Revision Properties dialog box, select the fields you 

want to use. Several are already selected for you, as shown 
in Figure 1–39.

Figure 1–39

3. Modify the options in the Sorting/Grouping and Formatting 
tabs as needed. 
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4. In the Appearance tab, select how you want to build the 
schedule: from the Top-down or Bottom-up. You can also 
set the Height to Variable or User-Defined.

5. Click . The schedule view displays.
6. In the Project browser, open the Sheet view (it has no name).
7. Drag and drop the schedule onto the sheet and modify the 

controls, as shown in Figure 1–40.

If the height is set to 
User-Defined, an 
additional control is 
displayed at the bottom of 
the schedule. Use it to set 
the height of the 
schedule.

Figure 1–40

In the Options Bar, you can change the Rotation on the Sheet 
to None, 90° Clockwise, or 90° Counterclockwise.

Using a Custom 
Title Block in a 

Template

You can set up templates using the custom title block in two 
ways. You can add all or most of the sheets typically needed in a 
project, or you can create a Sheet List Schedule that can be 
used to automatically create sheets when they are needed.

How to: Load a Title Block into a Template
1. Open the template.
2. Return to the custom title block family. In the Family Editor 

panel, click  (Load into Project).
3. In the Load into Projects dialog box, select the project you 

want the title block loaded into and click . If only 
one project is open, it is loaded into the project automatically.

4. The title block is now available when you create a sheet.

If the title block family is not open in Revit, then you can use 

 (Load Family) to access it or  in the New 
Sheet dialog box.
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When you save a title block, it should be on the network 
where everyone has access to it. That way, it is not deleted if 
someone reinstalls Revit. Set the default location for the 
family template files in the Options dialog box, in the File 
Locations tab, as shown in Figure 1–41.

Figure 1–41

How to: Create a Sheet List Schedule
1. Open a template file (or a project).

2. In the View tab>Create panel, expand  (Schedules) and 

click  (Sheet List).
3. In the Sheet List Properties dialog box, Fields tab, select the 

Sheet Number and Sheet Name and add them to the 
Scheduled fields list. Put them in the order shown in 
Figure 1–42.

Figure 1–42
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4. Depending on the complexity of your sheet naming scheme, 
you can also modify items on the Filter and Sorting/Grouping 
tabs.

5. Click  when you are finished.
6. You are placed in the schedule view with the two parameters 

displayed. Stretch out the columns as shown in Figure 1–43.

Figure 1–43

7. In the Modify Sheet List tab, as shown in Figure 1–44, in the 

Rows panel, click  (New).

Figure 1–44

8. A new row is added below the schedule names. If no sheets 
are in the drawing, it comes in automatically as A101 and 
Unnamed.

9. Add as many rows as you have sheets. If you are using a 
numbering scheme such as A1xx for site plans, A2xx for 
Floor Plans, A3xx for Detail plans, etc., then you should 
rename the sheet number for the first row of a set before 
creating more rows so that they increment automatically.

10.Enter the name of each sheet. Once you have added a new 
name, it is available in the drop-down list, as shown in 
Figure 1–45.

Figure 1–45
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How to: Use Sheet List Tables
1. Create a new sheet. In the Sheet List Schedule view, in the 

Modify Sheet List tab>Create panel, click  (New Sheet), 
You can also access the command on the View tab or 
right-click on Sheets in the Project browser.

2. In the New Sheet dialog box, select the placeholder sheets 
you want to use, as shown in Figure 1–46. To select more 
than one, hold down <Ctrl> or <Shift> as you select.

Figure 1–46

3. Click . The new sheets are created in the project.

This sheet list is available in all projects based on the 
template where it was created.

You can import the sheet list schedule into another project, 
but it does not import the associated sheets. That is because 
they are part of the project, not the schedule view.
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Practice 1c Creating Title Blocks
In this practice you will create a new title block by adding lines, 
text, labels, a logo, and a Revision Schedule, as shown in 
Figure 1–47. You will then load it into a template file and create 
several standard sheets as well as a Sheet List Schedule.

Estimated time for 
completion: 15 minutes.

Figure 1–47

Task 1 - Create a title block.

1. In the Application Menu, expand  (New) and click  

 (Title Block). 

2. Load the D-sized template.
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3. In the Home tab>Detail panel, click  (Line) and create 
lines on the inside of the existing rectangle 1/4" away from 
the top, bottom, and right sides. Draw a line 1" away on the 
left margin. Trim the lines as needed.

4. Draw lines in the lower right corner of the title block, as 
shown in Figure 1–48.

Figure 1–48

5. In the Home tab>Text panel, click  (Text). 

6. In Properties, click  and create the following Text 
types:

7. In the Home tab>Text panel, click  (Label).

8. In Properties, click  and create the following Label 
types:

Type Name Font Size Bold Background

Arial 1/16" Arial 1/16" No Transparent

Logo Your choice 1/4" Yes Transparent

Type Name Font Size Bold Background

Arial 1/8” Arial 1/8” No Transparent

Arial 1/4” Arial 1/4" No Transparent
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9. Using the graphic shown in Figure 1–49 and the steps 
outlined below, add text, labels, and graphics to the title 
block.

Figure 1–49

Use  (Text) with the text type Arial 1/16" to add text 
in the lower right spaces for the Date, Project Number, 
Drawn By, and Sheet Number.

Use  (Label) with the label type Arial 1/4” and 

 (Align Center) justification to add the Sheet Name, 
Project Name, and Sheet Number. Move and stretch the 
labels to fit in the title block.

Using the label type Arial 1/8” and  (Align Center) 
justification, add the Project Address below the Project 
Name.

Using the label type Arial 1/8” and  (Align Right) 
justification, add the Project Issue Date, Project Number, 
and Drawn By. 
Add the Logo text in the box on the lower left side, 
shown as Site, Inc. in the title block. Draw lines and add 
a filled region for a graphic logo as needed.

10.Save the title block in your class directory with the name 
TBLK-D.rfa.
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Task 2 - Add a Revision Schedule.

1. In the title block Family Editor, in the View tab>Create panel, 

click  (Revision Schedule).

2. In the Revision Properties dialog box, Fields tab, set up the 
fields as shown in Figure 1–50. 

Figure 1–50

3. Accept the defaults for the Sorting/Grouping and Formatting 
tabs. 

4. Select the Appearance tab and change the Height to User 
defined.

5. Click .

6. In the Project browser, expand Views (all) to see the 
Schedules and Sheets (all) sections, as shown in 
Figure 1–51. In the Sheets (all) section, open the - view.

Figure 1–51

7. Drag and drop the Revision Schedule onto the sheet.
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8. Move it above the sheet name and resize it to display several 
lines, as shown in Figure 1–52.

Figure 1–52

9. Save and close the title block.

Task 3 - Set up sheets in a template using the new title 
block.

1. Open the template Midrise Template.rte that you created in 
the previous practice.

If you did not complete the previous practice, open Midrise 
Template - Title Block.rte from your class folder.

2. In the View tab>Sheet Composition panel, click  (Sheet).

3. In the Select a title block dialog box, click . 
Navigate to your class folder, select TBLK-D.rfa that you just 

created, and click . 

If you did not complete the previous task, open TBLK-D-1.rfa 
from your class folder.

4. Select the title block that you just loaded and click .

No elements are on the 
view, but it acts as a 
placeholder on the sheet. 
Elements are displayed 
as they are drawn.

5. In the Project browser, select the sheet and rename it to 
A101 – Site Plan.

6. Open the new sheet view. Drag the Site floor plan view onto 
the sheet. 

7. Create another sheet with the new title block and name it 
A201 – First Floor Plan.
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8. Open this sheet view. Drag the Level 1 floor plan view onto 
the sheet, as shown in Figure 1–53.

Figure 1–53

Task 4 - Create a Sheet List.

1. In the View tab>Create panel, expand  (Schedules) and 

click  (Sheet List).

2. In the Sheet List Properties dialog box, Fields tab, select the 
Sheet Number and Sheet Name and add them to the 
Scheduled fields list, as shown in Figure 1–54.

Figure 1–54

3. Click .
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4. The Sheet List schedule opens with the two existing sheets 
listed. Stretch out the columns, as shown in Figure 1–55.

Figure 1–55

5. In the Modify Sheet List tab>Rows panel, click  (Row).

6. Add floor plans to match the levels, as shown in Figure 1–56.

Figure 1–56

7. In the Modify Sheet List tab>Create panel, click  (Sheet). 
The list of plans you added to the Sheet List display, but the 
sheets already in the project do not, as shown in Figure 1–57.

Figure 1–57

8. Cancel out of the dialog box.

9. If time permits, create additional placeholder sheets for 
various other views. 

10.Open the Level 1 floor plan view.

11. Save the template.



Creating Custom Templates

© 2010. Do not duplicate.                                            1–37

1.4 Creating Object Styles

Every element in Revit contains object styles that control how its 
components display in various views. For example, the Doors 
element includes the Elevation Swing, Frame/Mullion, Glass, 
Hidden Lines, Opening, Panel, and Plan Swing as components, 
as shown in Figure 1–58. The Elevation Swing is set to a light 
line weight, displayed in black with a dashed line pattern. It does 
not have any material attached to it, but the Glass component 
does. 

Figure 1–58

In the Manage tab>Settings panel, click  (Object Styles) to 
open the Object Styles dialog box.

To modify an object style, select the element to change and 
then select an option in the appropriate column in the 
drop-down list or dialog box.
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Line Weights

Line weights for model elements can be set for a Projection (in 
elevations) or Cut (in section and plan). For example, a wall 
displays a heavy line weight while the door and window cuts are 
lighter, as shown in Figure 1–59. 

Figure 1–59

Annotation elements are only set for projection.

Hint: Setting Line Weights
In the Manage tab>Settings panel, expand 

 (Additional Settings) and click  (Line Weights) to open 
the Line Weights dialog box, as shown in Figure 1–60. It 
contains three tabs: Model Line Weights (vary by scale), 
Perspective Line Weights (control elements like walls and 
windows in perspective views), and Annotation Line Weights 
(not dependent on the scale).

Figure 1–60

You can customize the line weights in each tab and add scales 
as needed for the model line weights.
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Line Color When you select the Line Color option in Object Styles or 
elsewhere, the Color dialog box opens, as shown in Figure 1–61. 

Figure 1–61

You can select from thousands of colors, including options from 
the Pantone color system, as shown in Figure 1–62. Typically, 
most elements in Revit are black for printing purposes. When 
you shade and render, the elements take on the color of the 
assigned material. Therefore, these dialog boxes are opened 
when you create materials.

Figure 1–62
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Line Patterns Line Patterns can be specified for various components in the 
Object Styles dialog box. In the example in Figure 1–63, you see 
the line pattern Dash 1/16" used for the elevation door swing 
and the line pattern Dash Dot 3/16" used for the callout bubble.

Figure 1–63

How to: Create Line Patterns 
A wide variety of patterns are supplied with Revit and you can 
create your own with a series of dashes, spaces, and dots. 

1. In the Manage tab>Settings panel, expand  (Additional 

Settings) and click  (Line Patterns) to open the Line 
Patterns dialog box.

2. In the Line Patterns dialog box, click  and type a 
name for the pattern.

3. In the Line Pattern Properties dialog box, add a list of dashes, 
spaces, and/or dots and specify their values, as shown in 
Figure 1–64. Space is always the option after a dash or dot. 
You do not have to enter a value for dots.

Figure 1–64
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Line Styles Line styles are a specific type of object style used with the 
sketching tools. They are not part of the Object Styles dialog box, 
but are created in a similar way. 

In the Manage tab>Settings panel, expand  (Additional 

Settings) and click  (Line Styles). In the Line Styles dialog 
box, as shown in Figure 1–65, specify the Line Weight, Line 
Color, and Line Pattern for each line style.

Figure 1–65
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1.5 Materials and Fill Patterns

When you shade or render Revit models, their appearance 
depends on the materials that have been associated with the 
elements, as shown in Figure 1–66. Materials can be assigned 
to an element using object styles, family types, or they can be 
assigned directly to the faces. You can use materials supplied 
with Revit or create custom materials.

Figure 1–66

Materials can be assigned in several ways: using  (Paint) 
on faces, setting it in the layers of system families (such as 
walls and floors), and in object styles. You also assign 
materials when you create other component families, such as 
doors and furniture.

New materials are only stored in the project. Therefore, if you 
are creating materials to be used again, create them in a 
template file.

Materials used in Revit are consistent with materials used in 
AutoCAD, Inventor, and 3ds Max.
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How to: Create a Material

1. In the Manage tab>Settings panel, click  (Materials). The 
Materials dialog box opens, as shown in Figure 1–67. Select 
a material from the list, similar to the one you want to create.

Use the Search field to 
find a material or narrow 
the material list by 
Material Class to help you 
find materials quickly. 
 
The dialog box can be 
resized.

Figure 1–67

2. In the Materials dialog box, click  (Duplicate). Type a new 
name for the material.

3. In the Graphics tab, set up the Shading, Surface Pattern, and 
Cut Pattern as needed.

4. In the Render Appearance tab, set up the rendering design, 
including the properties of the elements to be rendered.

5. In the Identity tab, set up information such as the related 
keynote, model, manufacturer, and other schedule-related 
items.

6. In the Physical tab, specify the type of properties. Predefined 
types are Generic (no properties), Concrete, Steel, and 
Wood.

7. Click  and add additional materials as needed.

8. Click  when you are finished.
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The Graphics Tab

In the Graphics tab shown in Figure 1–68, you set how a 
material displays in either shade or hidden line mode.

Figure 1–68

The Shading section controls how the material displays when 
an element is shaded. If you want the shaded view to 
resemble the rendered view, select the Use Render 
Appearance for Shading option. The color and other 
options are modified to match the Render Appearance 
selection. Alternatively, you can set up a color and 
transparency ratio.

The Surface Pattern and Cut Pattern sections enable you to 
select a fill pattern and color to display on a surface or in a 
section cut. Surface patterns stay true to size. Cut patterns 
are drafting patterns, which change size according to the 
view scale. 
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The Render Appearance Tab

In the Render Appearance tab, you set up the many aspects of a 
rendered material. You can choose how to display the preview of 
the material, as shown in Figure 1–69.

Figure 1–69

In the Render Appearance Based On section, click 

 to open the Render Appearance Library. An 
extensive list of rendered materials are available within Revit.

Once you have selected the render appearance, you can 
modify the Preview as needed and define the Glazing 
Properties. The properties change according to the type of 
material selected.



Revit Architecture 2011 BIM Management

1–46                                                                                                                                   © 2010. Do not duplicate.

The Identity Tab

In the Identity tab, you set up the Material Class, Description, 
Product Information, and Keynote for the material, as shown in 
Figure 1–70. This information can be used in material takeoff 
schedules.

Figure 1–70

The Physical Tab

In the Physical tab, you can specify information about the 
physical properties of the material, as shown in Figure 1–71. 
Several types are created, including Steel, Wood, and 
Concrete. You can create custom types by filling out the 

modifiable parameters and clicking .

Figure 1–71
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Creating Fill 
Patterns

Fill patterns are used by the various Filled Region commands 
and material specifications. In the Manage tab>Settings panel, 

expand  (Additional Settings) and click  (Fill Patterns). 
Select from two types: Drafting and Model.

Drafting patterns are symbolic. The view scale controls the size 
of the pattern. Basic patterns include hatching and cross- 
hatching, as well as designs that show material (such as 
aluminum or concrete), as shown in Figure 1–72. These are 
used in details and in plan or section cuts. 

Figure 1–72

Model patterns are full scale to the actual elements they 
represent. They do not change if the view scale changes. You 
can select brick, various sizes of tile, lines that are a specific 
distance apart, roof shakes, etc., as shown in Figure 1–73. 
These patterns are primarily used in elevation and plan views.

Figure 1–73
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How to: Create a New Simple Fill Pattern

1. In the Manage tab>Settings panel, expand  (Additional 

Settings) and click  (Fill Patterns).
2. In the New Pattern dialog box, select the type of pattern you 

want to create: Drafting or Model.

3. Click .
4. In the New Pattern dialog box, specify the Orientation of the 

pattern to the Host Layers and specify the Simple pattern 
style, as shown in Figure 1–74.

Figure 1–74

5. Type a name for the new pattern.
6. Type values for the Line angle and Line spacing, and select 

the Parallel lines or Crosshatch option.

7. Click  to finish. The pattern can now be used to 
create a filled region type or used in a material.

Filled regions can have either Opaque or Transparent 
backgrounds. This is set up in the Type Properties of the filled 
region.
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How to: Create a New Custom Fill Pattern

1. In the Manage tab>Settings panel, expand  (Additional 

Settings) and click  (Fill Patterns).
2. In the Fill Patterns dialog box, select the type of pattern you 

want to create: Drafting or Model.

3. Click .
4. In the New Pattern dialog box, select the Custom option, as 

shown in Figure 1–75.

Figure 1–75

5. Click  and select a PAT file. This file can be created 
specifically for Revit or it can be based on an AutoCAD PAT 
file.

6. Once the file is imported, a list of available patterns is 
displayed. Select the pattern. The name is automatically 
assigned. You can change the name after it has been 
selected.

7. Set the scale as needed.

8. Click  to finish.



Revit Architecture 2011 BIM Management

1–50                                                                                                                                   © 2010. Do not duplicate.

Importing Patterns from AutoCAD 
Pattern files (PAT) can be imported from AutoCAD, such as the 
Escher pattern shown in Figure 1–76.

Figure 1–76

One change must be made in the pattern file for it to be usable in 
Revit. Open the PAT file and add the following line after the title 
of a custom hatch, as shown in Figure 1–77.

Figure 1–77

A line with a semicolon in front it is ignored by AutoCAD, 
while the type is specified for Revit.

Any pattern in the Acad.pat file can be automatically brought 
in as a drafting pattern. However, you must add the string 
above to specify model patterns.
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Practice 1d Creating Object Styles, 
Materials, and Patterns
In this practice you will modify the object style of doors and door 
tags, as shown in Figure 1–78, and create a new line style. You 
will also create a fill pattern, two materials using the fill pattern, 
and two floor types using the materials. 

Estimated time for 
completion: 25 minutes.

Figure 1–78

Task 1 - Modify object styles.

1. Continue working in the template file Midrise Template.rte.

If you did not complete the previous practice, open 
Midrise-Template-Object-Styles.rte from your class folder.

2. In the Floor Plans section, open the Level 1 view. Draw a wall 
and place a door in it. This is just for viewing purposes and 
will be deleted later.

3. In the Manage tab>Settings panel, click  (Object Styles).

4. In the Object Styles dialog box, change the Doors>Plan 
Swing subcategory to display with a dashed line pattern.

5. In the Annotation Objects tab, change the Door tag to display 
with a color.

6. Click  to apply the changes. The door swing and 
tag change.

7. Add another door to the wall. It should display the same 
object styles.

8. Delete the wall and doors.
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Task 2 - Create line styles.

1. In the Manage tab>Settings panel, expand 

 (Additional Settings) and click  (Line Styles).

2. In the Line Styles dialog box, click  and create a 
new line style named Property Line as a Subcategory of 
Lines.

3. Set the Line Weight Projection to 6.

4. Select a Color for the line.

5. Set the Line Pattern to Dash Dot Dot 1/8”, as shown in 
Figure 1–79.

Figure 1–79

6. Click  to close the dialog box.

7. In the Home tab>Model panel, click  (Model Line). In the 
Line Style panel, set the Line Style to Property Line.

8. Draw some lines using this style and one other style to see 
the difference.

9. Delete the lines.

10.Zoom to fit.

11. Save the template file.

Task 3 - Create a fill pattern.

1. Continue working in the template file.

2. In the Manage tab>Settings panel, expand 

 (Additional Settings) and click  (Fill Patterns).

3. In the Pattern Type section of the dialog box, select the 

Model option. Click .
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4. In the Add Surface Pattern dialog box, select the Custom 

option and click .

5. In the Import Fill Pattern dialog box, from your class directory, 

select Acad_For_Revit.pat and click .

6. Three model patterns are available. Select AR-HBONE.

7. In the Name field, rename the pattern to Herringbone.

8. Click  twice to finish.

Task 4 - Create materials.

1. In the Manage tab>Settings panel, click  (Materials).

2. Select any material and click  (Duplicate). Name the 
material Herringbone – Brick.

3. In the Graphics tab, select the Use Render Appearance for 
Shading option. This automatically assigns a color and other 
information, similar to the render color for shading.

4. Set the Surface Pattern to the new Herringbone pattern.

5. Set the Cut Pattern to Diagonal Down.

6. In the Render Appearance tab, click .

7. In the Render Appearance Library dialog box, type in 
herringbone in the search field, as shown in Figure 1–80. 
(Do not press <Enter>.)

Figure 1–80
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8. Select the Herringbone-Gray swatch and click .

9. In the Identity tab, set the Material Class to Brick and the 
Keynote to 32 14 00.A1 4"x8"x 1 1/2" Brick Paver (under 
Division 32), as shown in Figure 1–81.

Figure 1–81

10.Click .

11. Duplicate the new material and name it Herringbone – 
Wood.

12. In the Graphics tab, set the Cut Pattern to None.

13. In the Render Appearance tab, click . 

14.Find the material Oak-Herringbone and click .

15. In the Identity tab, set the Material Class to Wood and set the 
Keynote to 09 64 00.B1 - 3/8” Hardwood Flooring (under 
Division 09 – Finishes).

16.Click  to close the Materials dialog box.

Task 5 - Test the new fill pattern and materials.

1. Open a floor plan view and draw a simple floor (not walls).

2. In Properties, set the floor style to Wood Joist 10” – Wood 
Finish.

3. Click .

4. In the Type Properties dialog box, create a new floor type 
named Wood Joist 10” – Wood Herringbone.

5. Next to the Structure parameter, click .
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6. In the Edit Assembly dialog box, set the Finish 1[4] material 
to Herringbone – Wood, as shown in Figure 1–82.

Figure 1–82

7. Click .

8. Duplicate this floor type and name it Wood Joist 10” – Brick 
Herringbone.

9. Edit the structure of this floor type. Set the Finish 1 material to 

Herringbone – Brick and click  twice to close the 
dialog boxes.

10.Zoom in on the floor you created. You should see the 
herringbone pattern.

11. Turn on  (Shaded with Edges) to see the color of the floor.

12.Modify the floor and change it to the other Herringbone floor 
type. The floor color changes because the material has 
changed, as shown in Figure 1–83.

Figure 1–83

13.Delete the floor and Zoom to Fit. 

14.Save the file.
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Chapter Review Questions

1. What are the various types of units you can set up in a 
template?

2. Where do you set up a new text type? A new dimension 
type? 

3. What is a label?

4. What is the difference between a line pattern and a line style? 

5. What are the two types of fill patterns and how do they differ? 

6. In the Materials dialog box, what is the purpose of the Use 
Render Appearance for Shading option?
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Command Summary
Button Command Location

Options Application Menu

Project Units Ribbon: Manage tab>Settings 
panel
Shortcut: UN

Snaps Ribbon: Manage tab>Settings 
panel

Temporary 
Dimensions

Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Dimension 
Types

Linear
Angular
Radial
Spot 
Elevation
Spot 
Coordinate
Spot Slope

Ribbon: Annotate tab> 
Dimensions panel>expand the 
panel title

Arrowheads Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Loaded Tags Ribbon: Annotate tab>Tag 
panel>expand the panel title

Floor Plan Ribbon: View tab>Create panel> 
expand Plan Views

Reflected 
Ceiling Plan

Ribbon: View tab>Create panel> 
expand Plan Views

Label Family Editor
Ribbon: Create tab>Text panel

Text Family Editor
Ribbon: Create tab>Text panel

Revision 
Schedule

Family Editor
Ribbon: View tab>Create panel

New Title 
Block

Application Menu: expand 
New>Title block

Materials Ribbon: Manage tab>Settings 
panel
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Object Styles Ribbon: Manage tab>Settings 
panel

Line Weights Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Line Patterns Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Line Styles Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Fill Patterns Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Callout Tags Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Elevation 
Tags

Ribbon: Manage tab>Settings 
panel>expand Additional Settings

Section Tags Ribbon: Manage tab>Settings 
panel>expand Additional Settings




