AutoCAD® 2012 Tutorial
Second Level: 3D Modeling

Randy H. Shih
Oregon Institute of Technology

www.SDCpublications.com
Schroff Development Corporation
Visit the following websites to learn more about this book:

- SDC Publications
- amazon.com
- BARNES&NOBLE
- Google books
Chapter 3
3D Wireframe Modeling

Learning Objectives
♦ Using the Setup Wizard
♦ Create Wireframe Models
♦ Apply the Box Method in Creating Models
♦ Construct with the Copy Command
♦ Understand the Available 3D Coordinates Input Options
♦ Using the View Toolbar
♦ Setup and Using the TRIM options
Introduction

The first true 3D computer model created on CAD systems in the late 1970s was the 3D wireframe model. Computer generated 3D wireframe models contain information about the locations of all the corners and edges in space coordinates. The 3D wireframe models can be viewed from any direction as needed and are in general reasonably good representations of 3D design. But because surface definition is not part of a wireframe model, all wireframe images have the inherent problem of ambiguity. For example, in the figure displayed below, which corner is in front, corner A or corner B? The ambiguity problem becomes much more serious with complex designs that have many edges and corners.

Wireframe Ambiguity: Which corner is in front, A or B?

The main advantage of using a 3D wireframe modeler to create 3D models is its simplicity. The computer hardware requirements for wireframe modelers are typically much lower than the requirements for surface and solid modelers. A 3D wireframe model, also known as a stick-figure model or a skeleton model, contains only information about the locations of all the corners and edges of the design in space coordinates. You should also realize that, in some cases, it could be quite difficult to locate some of the corner locations while creating a 3D wireframe model. Note that 3D wireframe modelers are usually used in conjunction with surface modeling, which we will discuss in the later chapters of this text, to eliminate the problem of ambiguity.

With most CAD systems, creating 3D wireframe models usually starts with constructing 2D entities in 3D space. Two of the most commonly used methods for creating 3D wireframe models are the Box method and the 2D Extrusion method. As the name implies, the Box method involves the creation of a 3D box with the edges constructed from the overall height, width and depth dimensions of the design. The 3D wireframe model is typically completed by locating and connecting corners within the box.
The 2D Extrusion method involves making copies of 2D geometries in specific directions. This method is similar to the 2½D extrusion approach illustrated in the previous chapter (Chapter 2) with several differences. First of all, we do not really extrude the wireframe entities; instead we simply make copies of wireframe entities in the desired directions. Secondly, constructed wireframe entities have true 3D space coordinates, while the thickness approach creates entities with no true 3D coordinates. And lastly, no surfaces are created in the 3D wireframe models.

In this chapter, we will illustrate the general procedure to construct a 3D wireframe model using both the box method and the 2D extrusion method. To illustrate the AutoCAD 3D construction environment, we will create the wireframe model using only the default UCS system, which is aligned to the world coordinate system. Repositioning and/or reorienting the User Coordinate System can be useful in creating 3D models. But it is also feasible to create 3D models referencing only a single coordinate system. One important note about creating wireframe models is that the construction techniques mostly concentrate on locating the space coordinates of the individual corners of the design. The ability to visualize designs in the form of 3D wireframe models is extremely helpful to designers and CAD operators. It is hoped that the experience of thinking and working on 3D wireframe models, as outlined in this chapter, will enhance one’s 3D visualization ability.

The Locator Design
Starting Up AutoCAD® 2012

1. Select the **AutoCAD 2012** option on the Program menu or select the **AutoCAD 2012** icon on the Desktop. Once the program is loaded into the memory, the AutoCAD® 2012 drawing screen will appear on the screen.

Using the Startup Options

- In **AutoCAD® 2012**, we can use the Startup dialog box to establish different types of drawing settings. The Startup dialog box can be activated through the use of the **STARTUP** system variable.

The STARTUP system variable can be set to either 0 or 1:
- 1: displays the *Create New Drawing* dialog box.
- 0: displays the *Select Template* dialog box (default).

1. In the command prompt area, enter the system variable name:

```
STARTUP [ENTER]
```

2. Enter 1 as the new value for the **STARTUP** system variable.
3. To show the effect of the *Startup* option, **exit** AutoCAD by clicking on the **Close** icon as shown.

4. Restart AutoCAD by selecting the **AutoCAD 2012** option through the **Start** menu.

5. The **Startup** dialog box appears on the screen with different options to assist the creation of drawings. Move the cursor on top of the four icons and notice the four options available:
   1. **Open a Drawing**
   2. **Start from Scratch**
   3. **Use a Template** and
   4. **Use a Setup Wizard**.

6. In the **Startup** dialog box, select the **Start from Scratch** option as shown in the figure.

7. Choose **Imperial** to use the **Standard English** units setting.

8. Click **OK** to accept the setting.
Creating the Rectangular Base of the Design

- We will first construct the wireframe geometry defining the rectangular base of the design.

1. In the Status Bar area, reset the options and turn ON the Grid, Polar, Object Snap, Object Snap Tracking, Dynamic Input and Lineweight options.

2. Select the Rectangle icon in the Draw toolbar.

3. Place the first corner-point of the rectangle at the origin of the world coordinate system.
   
   Command: _line
   Specify first point: 0,0 [ENTER]
   (Type 0,0 and press the [ENTER] key once.)

4. We will create a 4.5” × 3.0” rectangle by entering the absolute coordinates of the second corner.
   
   Specify other corner point or [Dimension]: 4.5,3 [ENTER]

- The Rectangle command creates rectangles as polyline features, which means the four segments of a rectangle, are created as a single object. In AutoCAD, rectangles are wireframe entities.
5. In the Menu Bar, select:
[View] → [3D Views] → [SE Isometric]

- Notice the orientation of the sketched 2D rectangle in relation to the displayed AutoCAD user coordinate system. By default, the 2D sketch-plane is aligned to the XY plane of the world coordinate system.

Create a 3D Box

- We will create a 3D box to define the 3D boundary of the design. We will do so by placing a copy of the base rectangle at the corresponding height elevation of the design. The dimensions of the 3D box are therefore based on the height, width and depth dimensions of the design.

1. Click on the Copy Object icon in the Modify toolbar.
2. In the command prompt area, the message “Select objects:” is displayed. Pick any edge of the sketched rectangle.
3. Inside the graphics window, right-mouse-click once to accept the selection.
4. In the command prompt area, the message “Specify base point or displacement, or [Multiple]:” is displayed. Pick any corner of the sketched rectangle as a base point to create the copy.

5. In the command prompt area, the message “Specify second point of displacement or <use first point as displacement>:” is displayed.
   Enter: @0,0,2.5 [ENTER]
   (The three values are the X, Y and Z coordinates of the new location.)

6. Select the [Zoom] → [Extents] option in the View pull-down menu to view the constructed geometry.

7. Select the Line icon in the Draw toolbar.

8. In the command prompt area, the message “_line Specify first point:” is displayed.
   Command: _line Specify first point: 0,0 [ENTER]

9. In the command prompt area, the message “Specify next point or [Undo]:” is displayed.
   Command: _line Specify first point: 0,0,2.5 [ENTER]
Notice the Line command correctly identified the entered 3D coordinates of the second point. The default Z-coordinate, which is set by the AutoCAD UCS, is applied automatically whenever the Z-coordinates are omitted.

10. Inside the graphics window, right-mouse-click to activate the option menu and select **Enter** with the left-mouse-button to end the Line command.

11. Inside the graphics window, **right-mouse-click** to bring up the popup option menu.

12. Pick **Repeat Line** with the left-mouse-button in the popup menu to repeat the last command.

13. Move the cursor on top of the top front corner as shown. Note that the AutoCAD’s **Object Snap** and **Object Snap Tracking** features identify geometric features, such as endpoints, automatically.

14. Left-click once to select the endpoint as shown.

15. Create a line connecting to the endpoint directly below the previously selected point.

16. On your own, complete the 3D box by creating the two lines connecting the back corners of the 3D box as shown.
Object Snap Toolbar

1. In the Menu Bar select [Tools] → [Toolbars] → [AutoCAD]

   AutoCAD provides many toolbars for access to frequently used commands, settings, and modes. The Standard, Object Properties, Draw, and Modify toolbars are displayed by default. The check marks in the list identify the toolbars that are currently displayed on the screen.

2. Select Object Snap, with the left-mouse-button, to display the Object Snap toolbar on the screen to assist the construction of the floor plan.

   Object Snap is an extremely powerful construction tool available on most CAD systems. During an entity's creation operations, we can snap the cursor to points on objects such as endpoints, midpoints, centers, and intersections. For example, we can turn on Object Snap and quickly draw a line to the center of a circle, the midpoint of a line segment, or the intersection of two lines.

Using the Snap Options to Locate the Top Corners

   We will use the Object Snap options to identify the locations of the top corners of the model.
1. Select the **Line** icon in the *Draw* toolbar.

2. In the command prompt area, the message “_line Specify first point:” is displayed. Select **Snap From** in the *Object Snap* toolbar.

3. Select the **top back corner** as the reference point as shown.

4. In the command prompt area, the message “_line Specify first point: from Base point:<Offset>.” is displayed.

   *Command: @0.75,0,0 [ENTER]*

   By using the relative coordinate input method, we can locate the position of any point in 3D space. Note that the entered coordinates are measured relative to the current UCS.

5. In the command prompt area, the message “Specify next point or [Undo].” is displayed.

   *Command: Specify next point or [Undo]: @0,-2,0 [ENTER]*

6. Move the cursor toward the left to create a perpendicular line. Select a location that is on the back line as shown, notice the displayed *Object Snap/Tracking* tips: **Polar**: Intersection.

7. In the command prompt area, the message “Specify next point or [Undo]:” is displayed. Select **Snap From** in the *Object Snap* toolbar.
8. Select the **top front corner** as the reference point as shown.

9. In the command prompt area, the message “Specify next point or [Close/Undo]: from Base point <Offset>:” is displayed.

   **Command:** @0,0,-1 [ENTER]

10. In the command prompt area, the message “Specify next point or [Undo]:” is displayed.

   **Command:** @0.75,0,0 [ENTER]

11. Move the cursor to the top corner as shown in the figure.

   ✷ Using the **Object Snap** options and the **relative coordinate input method** allow us to quickly locate points in 3D space.

12. Inside the graphics window, right-mouse-click to activate the option menu and select **Enter** with the left-mouse-button to end the **Line** command.

### Using the **Copy** Option to Create Additional Edges

🌷 The **Copy** option can also be used to create additional edges of the wireframe model.

1. Click on the **Copy Object** icon in the **Modify** toolbar.

2. In the command prompt area, the message “Select objects:” is displayed. Pick any edge of the bottom rectangle.

3. Inside the graphics window, **right-mouse-click** once to accept the selection.

4. In the command prompt area, the message “Specify base point or displacement, or [Multiple]:” is displayed. Pick any corner of the base rectangle to be used as a base point to create the copy.
5. In the command prompt area, the message “Specify second point of displacement or <use first point as displacement>.” is displayed. Enter: @0,0,0.75 [ENTER]

6. Inside the graphics window, right-mouse-click to bring up the popup option menu.

7. Pick **Repeat Copy Object** with the left-mouse-button in the popup menu to repeat the last command.

8. Pick the two **vertical lines** on the right side of the 3D box as shown.

9. Inside the graphics window, **right-mouse-click** once to accept the selection.

10. In the command prompt area, the message “Specify base point or displacement, or [Multiple].” is displayed. Pick the **top back corner** of the wireframe as a base point to create the copy.
11. In the command prompt area, the message “Specify second point of displacement or <use first point as displacement>:” is displayed. Pick the top back corner of the wireframe model as shown.

The copy option is an effective way to create additional edges of wireframe models, especially when multiple objects are involved. With wireframe models, the emphasis is placed on the corners and edges of the model.

Using the Trim Command

The Trim command can be used to shorten objects so that they end precisely at selected boundaries.

1. Select the Trim command icon in the Modify toolbar. In the command prompt area, the message “Select boundary edges... Select objects:” is displayed.

   First we will select the objects that define the boundary edges to which we want to trim the object.

2. Pick the highlighted edges as shown in the figure; these edges are the boundary edges.

3. Inside the graphics window, right-mouse-click once to accept the selection of boundary edges and proceeds with the Trim command.
4. Inside the graphics area, right-mouse-click once to bring up the option menu and select **Project** as shown.

5. Inside the graphics area, right-mouse-click once to bring up the option menu and select **View** to allow trimming option based on the displayed view.

6. The message “Select object to trim or shift-select object to extend or [Project/Edge/Undo]:” is displayed in the command prompt area. Pick the portions of the entities to be trimmed so that the model appears as shown.

   - Note that in AutoCAD 2012, the default AutoCAD trim projection setting is set to **UCS**, which allows us to trim objects that are perpendicular to the **UCS plane**.

7. Inside the graphics window, right-mouse-click to bring up the option menu and select **Enter** to end the **Trim** command.

8. On your own, use the **Line** command to complete the inside corner of the wireframe model as shown.
Using the View Toolbar

1. In the Menu Bar select [Tools] → [Toolbars] → [AutoCAD]

2. Select View, with the left-mouse-button, to display the View toolbar on the screen.

   The View toolbar contains two sections of icons that allow us to quickly switch to standard 2D and 3D views.

Dynamic Rotation – Free Orbit

1. Select Free Orbit in the View pull-down menu:

   [Orbit] → [Free Orbit]

   The Free Orbit view displays an arcball, which enables us to manipulate the view of 3D objects by clicking and dragging with the left-mouse-button.

2. Inside the arcball, press down the left-mouse-button and drag it up and down to rotate about the screen X-axis. Dragging the mouse left and right will rotate about the screen Y-axis.

3. Move the cursor to different locations on the screen, outside the arcball or on one of the four small circles, and experiment with the real-time dynamic rotation feature of the Free Orbit command.
Using the **Offset** Command to Create Parallel Edges

- The AutoCAD **Offset** option can also be used to create edges that are at specific distances to existing 3D wireframe edges. Prior to creating the parallel edges, we will first convert one of the polylines to individual line segments.

1. Pick the top right edge of the wireframe model.

- **AutoCAD® 2012** provides a flexible graphical user interface that allows users to select graphical entities **BEFORE** the command is selected (Pre-selection), or **AFTER** the command is selected (Post-selection). The polyline we have pre-selected consists of three line-segments.

2. Select the **Explode** command in the **Modify** pull-down menu as shown.

3. Pick **Offset** in the **Modify** toolbar as shown.

4. In the command prompt area, the message **“Specify offset distance or [Through]<Through>”** is displayed. Enter: **0.5 [ENTER]**

5. Select the front line segment of the polyline we just exploded.

6. In the command prompt area, the message **“Specify point on side to offset”** is displayed. Pick a location that is above the line to create the first parallel line.

7. Select the back line segment of the polyline we exploded and create another parallel line as shown.
8. On your own, repeat the above steps and create another parallel line (distance: 1.5) as shown.

- In creating parallel edges, the Offset command can be viewed as an alternative to the Copy command. In 3D wireframe modeling, the focus is on identifying the edges and corners of the model. Most of the 2D construction tools are also applicable in 3D environment.

9. Select the Trim command icon in the Modify toolbar.

10. In the command prompt area, the message “Select boundary edges... Select objects:” is displayed. Pick the highlighted edges as shown in the figure; these edges are the boundary edges.

11. Inside the graphics window, right-click to accept the selection of boundary edges and proceeds with the Trim command.

12. On your own, trim the line segments so that the wireframe model appears as shown.
Creating a Circle above the UCS Sketch Plane

1. Select the **Circle** command icon in the *Draw* toolbar.
   - By default, the XY plane of the UCS defines the sketching plane for constructing 2D geometric entities.

2. In the command prompt area, the message “_circle Specify center point for circle or[3P/2P/Ttr (tan tan radius)].” is displayed. Select **Snap From** in the Object Snap toolbar.

3. Select the top right corner as the reference point as shown.

4. In the command prompt area, the message “Specify next point or [Close/Undo]: from Base point <Offset>.” is displayed.
   
   **Command:** @-2.67,1.5 [ENTER]

5. In the command prompt area, the message “Specify radius of circle or [Diameter]:” is displayed.

   **Command:** 0.375 [ENTER]
   - The circle is created above the sketching plane with the **Snap From** option.
Completing the Wireframe Model

1. Click on the **Copy Object** icon in the **Modify** toolbar.

2. In the command prompt area, the message “Select objects:” is displayed. Pick the edges and the circle as shown in the figure.

3. Inside the graphics window, right-mouse-click once to accept the selection.

4. In the command prompt area, the message “Specify base point or displacement, or [Multiple]:” is displayed. Pick the front right corner as shown.

5. In the command prompt area, the message “Specify second point of displacement or <use first point as displacement>:” is displayed. Pick the bottom-right corner as shown.
6. Select the **Line** icon in the *Draw* toolbar.

7. On your own, create the lines connecting the corners of the created edges as shown in the figure below.

8. Use the **Snap to Quadrant** option to create edges in between the two circles.

9. Select the **Trim** command icon in the *Modify* toolbar.

10. On your own, trim the center portion of the bottom right edge and complete the wireframe model as shown.

- On your own, save the **Locator** design (Locator.dwg), this model will be used again in the *Surface Modeling* chapter.
Questions:

1. Describe some of the control options available with the **Free Orbit** command.

2. List and describe two different methods to create 3D edges from existing 3D edges in **AutoCAD® 2012**.

3. How many of the UCS options were used to create the 3D model in this chapter and how many were used to create the model in the previous chapter?

4. When and why would you use the **Trim-Project-View** option?

5. Identify the following commands:

   (a)
   ![Image](image1)

   (b)
   ![Image](image2)

   (c)
   ![Image](image3)

   (d)
   ![Image](image4)
Exercises: All dimensions are in inches.

1.

![Diagram of a 3D object with dimensions marked: R1.59, R1.09, 2.00, 4.00, 1.00, 2.50, and 5.00. Rounds & Fillets: R.25.]

2.

![Diagram of another 3D object with dimensions marked: R1.00, Ø1.00, 2.50, 2.50, and 1.50. Rounds & Fillets: R.75.]
