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Chapter 2 
Basic Drawing and Editing Tools

In this chapter you learn about drawing aids, selecting elements, using controls 
and temporary dimensions. You also learn how to use editing commands 
including Move, Copy, Rotate, Array, Align, Split, Trim, and Offset.

This chapter introduces:

General Drawing Tools
Editing Revit MEP Elements
Basic Modifying Tools
Additional Editing Tools
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2.1 General Drawing Tools

When you start a drawing command, the contextual Ribbon, 
Options Bar, Type Selector and Properties palette enable you to 
set up features for each element you are placing in the drawing. 
As you are drawing, several features called drawing aids display, 
as shown in Figure 2–1. They help you to create designs quickly 
and accurately. 

Figure 2–1

User
Interface Tools

Contextual Ribbon

When you select a command, the Ribbon displays the Modify tab 
with the contextual tools. For example, when you start the Duct 
command, the Modify | Place Duct tab opens, as shown in part in 
Figure 2–2. 

Figure 2–2

The Modify tools are always displayed to the left of the 
Ribbon and the contextual tools to the right with a green 
panel title.

In the Select panel, click  (Modify) to end the command 
and return to the main tab at any time.
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Options Bar

The Options Bar displays the most used options for an element, 
as shown in Figure 2–3. These options are also typically found in 
the Properties palette.

Figure 2–3

Properties Palette

The Properties palette and the Type Selector display the current 
element type. You can select other types and modify some of the 
related parameters for the selected object, as shown in 
Figure 2–4.

Some of the properties 
parameters are only 
available when you are 
editing an element. They 
are grayed out when you 
are creating an element.

Figure 2–4

The Properties palette can be floated and moved around the 
screen. If it is turned off, you can open it by starting a 
command. You can also type PP to toggle the Properties 
palette on or off.

Changes in the palette do not take effect until you click 

 or move your cursor onto the screen. If you 
click in the window, it applies the change but also deselects 
the element. 
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Drawing Aids As soon as you start drawing in Autodesk® Revit® MEP program, 
three drawing aids display on the screen: alignment lines, 
temporary dimensions, and snaps. These are available with 
most drawing and many modification commands.

Alignment Lines

Dashed alignment lines display as soon as you select your first 
point, as shown in Figure 2–5. They help keep lines horizontal, 
vertical, or at a specified angle. They also line up with the implied 
intersections of walls and other elements.

Angles display at 90, 45, 
15, 5, and 1 degree 
increments. The order of 
the angle list controls the 
power level of the snap. 
For example, the 90 
degree angle is most 
likely to display if you are 
close to horizontal or 
vertical.

Figure 2–5

Hold down <Shift> to force the alignments to be orthogonal.

Temporary Dimensions

Along with alignment lines, temporary dimensions display as you 
draw to help you place linear elements (such as walls) at the 
proper length and location, as shown in Figure 2–6.

You can move the cursor 
to the exact dimension, or 
place it approximately 
and then modify the 
dimension as needed. 
This enables you to 
sketch the building and 
then come back and use 
the parametric engine to 
update the model with 
greater precision.

Figure 2–6

Temporary dimensions only work in the active file, not against 
elements in a linked file.
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For Imperial measurements (feet and inches), Revit MEP 
program understands a default of feet. For example, when 
you type 4, it assumes 4’-0”. To indicate inches, type the inch 
mark (”) after the distance. For a distance such as 4’-6”, you 
can type any of the following: 4’-6”, 4’6, 4-6, or 4 6 (numbers 
separated by a space).

The increments displayed for dimensions change as you 
zoom in closer to the elements. These dimension snap 
increments are for both linear and angular dimensions, and 
can be set in the Snaps dialog box.

Temporary dimensions disappear as soon as you finish 
drawing linear elements. If you want to make them 
permanent, select the control shown in Figure 2–7.

Dimensions are a 
powerful tool to help you 
create and annotate the 
model.

Figure 2–7

The size of the temporary dimensions, in pixels, can be set in 
the Options dialog box in the Graphics tab.

Snaps

Snaps are key points that help you reference existing elements 
to exact points when drawing, as shown in Figure 2–8.

Figure 2–8

The Point Snap is used to 
snap to the various pipe, 
duct, and electrical 
connectors.

They include Endpoints, Midpoints, Nearest, Work Plane 
Grid, Quadrants, Intersections, Centers, Perpendicular, 
Tangents, and Points. When you move your cursor over an 
element, the Snap symbol displays. Each snap location type 
displays with a different symbol.

To modify the snap settings, in the Manage tab>Settings 

panel, click  (Snaps). This opens the Snaps dialog box, in 
which you can set which snap points are active, as well as 
the snap distances (for dimension and angular increments). It 
also displays the keyboard shortcuts for each snap, which 
you can use to override the automatic snapping.
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Reference
Planes

As you develop designs in Revit MEP program, there are times 
when you need additional temporary lines to help you define 
certain locations. You can draw reference planes (the dashed 
lines) to host the height of sinks or to help you define centerlines 
and paths for ductwork, as shown in Figure 2–9. You can snap to 
reference planes and they display in associated views.

Figure 2–9

How to: Sketch with Reference Planes

1. In the Home tab>Work Plane panel, click  (Ref Plane). 
2. In the Modify | Place Reference Plane tab>Draw panel, click 

 (Line) or  (Pick Lines) and create the reference planes.

3. Click  (Modify) when you have created all of the required 
reference planes.

If you create reference planes while working in a sketch (e.g., 
a floor), the reference planes only display in sketch mode.

You can name reference planes. Select the reference plane 
and in the Identity Data area in Properties, type a name. 

Reference Plane
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2.2 Editing Revit MEP Elements

Building design projects typically involve extensive changes to 
the positions of walls, floors, and ceilings, and thus to the 
mechanical, electrical, and plumbing layout. Revit MEP program 
has been designed to make such changes easy. First, you select 
the element(s) you want to modify and then select from a variety 
of options including temporary dimensions, controls, and 
contextual tools in the Ribbon.

To start editing elements, click  (Modify). It is on the far left 
in every Ribbon tab. This command works with all of the 
different element types. 

Selecting
Elements

You can select elements in several ways:

To select a single element, place your cursor over it and 
select it.

To add another element to a selection set, hold down <Ctrl> 
and select another item. 

To remove an element from a selection set, hold down 
<Shift> and select the element.

If you click and drag the cursor to window around elements, 
you have two selection options, as shown in Figure 2–10. If 
you drag from left to right, you only select the elements 
completely inside the window. If you drag from right to left, 
you select elements both inside and crossing the window.

Figure 2–10

Revit MEP program filters architectural categories from 
Window selections.
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If several elements are on or near each other, press <Tab> to 
cycle through them before you click. If there are elements 
that might be linked to each other, such as connected 
ductwork, press <Tab> to select the chain of elements.

Press <Ctrl> + <Left Arrow> to reselect the previous selection 
set. You can also right-click in the drawing window with 
nothing selected and select Select Previous.

To select all of the elements of a specific type, right-click on 
an element and select Select All Instances>Visible in View 
or In Entire Project, as shown in Figure 2–11.

Figure 2–11

MEP elements in views often cannot be selected when 
Architectural objects are displayed in the Hidden Line Visual 
Style. Change the Visual Style to Wireframe.

Standard
Editing Tools

With the Modify command active, there are a number of ways to 
change an element when you select it, as shown in Figure 2–12:

Modify commands and element-specific tools display in the 
contextual tab in the Ribbon.

The Properties palette displays the element type and 
associated parameters.

Temporary dimensions enable you to change the element’s 
dimensions.

Controls enable you to drag, flip, lock, and rotate the element.

Figure 2–12

When you hover your cursor over an element, a tooltip 
displays information about it.

Temporary dimensions

Controls (and connectors)
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Connectors are frequently linked to controls. Therefore, when 
the control is moved the connector is as well. Be careful not 
to disconnect systems when moving these controls. 

To delete an element, select it and press <Delete> or click 

 (Delete) in the Modify panel.

When working with temporary dimensions, the default 
location of the dimension line might not be correct. For 
example, as shown on the left in Figure 2–13, instead of 
setting the distance of the selected element from the center 
of the left wall, you might want to modify the distance from the 
grid line. Drag the control (also called the witness line) to the 
grid line, as shown on the right in Figure 2–13.

Figure 2–13

You can click on the control to move the witness line from one 
part of the selected wall to another.

The new location of a temporary dimension is remembered 
as long as you are in the same Revit MEP session.

Since temporary dimensions do not respond to linked 
architectural data, place permanent dimensions between 
linked objects and MEP elements. Then the designer can to 
select and edit objects through the temporary dimensions 
connected to the permanent dimensions.

Hint: Press & Drag

You can move elements by dragging them to a new location. To 
do this without selecting them first, make sure the Press & 
Drag option is selected in the Status Bar, as shown in 
Figure 2–14.

Figure 2–14
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Modifying
Multiple

Elements

When multiple element types are selected, the Multi-Select 
contextual tab opens in the Ribbon, as shown in Figure 2–15. 
This gives you access to all of the Modify tools and the Filter 
command.

Figure 2–15

The Properties palette displays tools that are common to all 
available element types. You can also just select one type 
and make modifications to its properties, as shown in 
Figure 2–16.

Figure 2–16

Filtering Selection Sets

The Filter command enables you to specify the types of 
elements to select. For example, you might only want to select 
lighting fixtures, as shown in Figure 2–17.

Figure 2–17
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How to: Filter a Selection Set
1. Select everything in the required area.
2. In the Modify | Multi-Select tab or in the Status Bar, click

 (Filter). The Filter dialog box opens, as shown in 
Figure 2–18.

The Filter dialog box 
displays all of the element 
types in the original 
selection.

Figure 2–18

3. Click  to clear all of the options and then 
select the element types that you want to include in the 
selection.

4. Click . The selection set is now limited to the 
specified elements.

In the Status Bar,  (Filter) displays the number of 
elements you have selected.
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2.3 Basic Modifying Tools

Revit MEP software contains controls and temporary dimensions 
that enable you to edit elements. Additional modifying tools can 
be used with individual elements or any selection of elements. 
They are found in the Modify tab>Modify panel, as shown in 
Figure 2–19, and in contextual tabs.

You can either select the 
elements and start the 
command or start the 
command, select the 
elements, and press 
<Enter> to finish the 
selection set. Figure 2–19

Moving
and Copying

Elements

The Move and Copy commands enable you to select the 
element(s) and move or copy them from one place to another. 
You can use alignment lines, temporary dimensions, and snaps 
to help place the elements, as shown in Figure 2–20.

Figure 2–20

How to: Move or Copy Elements

If you start  (Move) 
and hold down <Ctrl>, the 
elements are copied.

1. Select the elements that you want to move or copy.

2. In the Modify panel, click  (Move) or  (Copy). A 
boundary box displays around the selected elements.

3. Select a move start point on or near the element.
4. Select a second point. Use alignment lines and temporary 

dimensions to help place the elements.
5. The last copied elements remain highlighted, enabling you to 

copy them again, start another command, or press <Esc> to 
end the command.
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Move/Copy Elements
The Move and Copy commands have several options that 
display in the Options Bar, as shown in Figure 2–21.

Figure 2–21

With the exception of the Multiple option, the options revert 
to their defaults each time you restart the command. 

These commands only work within the current view, not 
between views or projects. To copy between views or 

projects, use  (Copy to Clipboard) and  (Paste).

Constrain Restricts the movement of the cursor to horizontal or vertical, 
or along the axis of an item that is at an angle. This keeps 
you from selecting a point at an angle by mistake. Constrain 
is off by default.

Disjoin 
(Move only)

Breaks any connections between the elements being moved 
and other elements. If Disjoin is on, the elements move 
separately. If it is off, the connected elements also move or 
stretch. Disjoin is off by default.

Multiple 
(Copy only)

Enables you to make multiple copies of one selection. 
Multiple is off by default.

Hint: Pinning Elements

If you do not want elements to be moved, you can  (Pin) 
them in place, as shown in Figure 2–22. Pinned elements can 
still be copied.

Figure 2–22

Select the element and click  (Unpin) to free it.

Pinned elements can be deleted or changed to another 
type.
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Rotating
Elements

The Rotate command enables you to rotate selected elements 
around a center point or origin. You can use alignment lines, 
temporary dimensions, and snaps to help specify the origin point 
and rotation. You can also create copies of the element that is 
rotated.

How to: Rotate Elements
1. Select the element(s) you want to rotate.

2. In the Modify panel, click  (Rotate) or type RO.
3. The origin is automatically set to the center of the element or 

group of elements, as shown on the left in Figure 2–23. To 
change the origin as shown on the right in Figure 2–23, use 
the following steps:

Click  (Center of Rotation) control and drag it to a new 
point.

In the Options Bar, next to Origin, click  and use 
snaps to move the origin.
Press the <Spacebar> to select the origin.

Figure 2–23

To start the Rotate command with an automatic prompt 
that enables you to select the center of rotation, type R3.

4. In the Options Bar, specify if you want to make a Copy and 
type an angle in the Angle field, as shown in Figure 2–24, 
and press <Enter>. You can also specify the angle on screen.

To specify the angle on 
screen, select a point for 
the rotate start ray—the 
reference line for the 
rotation angle. Then 
select a second point, 
using the temporary 
dimension to help you set 
the angle.

Figure 2–24

5. The rotated element(s) remain highlighted, enabling you to 
start another command, or press <Esc> to finish.

The Disjoin option breaks any connections between the 
elements being rotated and other elements. If Disjoin is on, 
the elements rotate separately. If it is off, the connected 
elements also move or stretch. Disjoin is off by default.
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Mirroring
Elements

The Mirror command enables you to mirror elements, as shown 
in Figure 2–25, about an axis defined by a selected element or 
by selected points.

Figure 2–25

How to: Mirror Elements
1. Select the element(s) to mirror.
2. In the Modify panel, select the method you want to use:

Click  (Mirror - Pick Axis) or type MM. This prompts 
you to select an element as the Axis of Reflection 
(mirror line).

Click  (Mirror - Draw Axis) or type DM. This prompts 
you to select two points to define the axis about which the 
elements mirror.

3. The new mirrored element(s) remain highlighted, enabling 
you to start another command, or press <Esc> to end the 
command.

By default, the original elements that were mirrored remain. 
To delete the original elements, clear the Copy option in the 
Options Bar.

Hint: Scale

Revit MEP program is designed with full-size elements. 

Therefore, not much can be scaled. However, you can use  
(Scale) in reference planes, images, and imported files from 
other programs.



Basic Drawing and Editing Tools

© Do not duplicate.                                                      2–17

Creating Linear
and Radial

Arrays

The Array command creates multiple copies of selected 
elements in a linear or radial pattern, as shown in Figure 2–26. 
For example, you can array a row of columns to create a row of 
evenly spaced columns on a grid, or array a row of parking 
spaces. The arrayed elements can be grouped or placed as 
separate elements.

A linear array creates a straight line pattern of elements, 
while a radial array creates a circular pattern around a center 
point.

Figure 2–26

How to: Create a Linear Array
1. Select the element(s) to array. 

2. In the Modify panel, click  (Array). 

3. In the Options Bar, click  (Linear).
4. Specify the other options as needed.
5. Select a start point and an end point to set the spacing and 

direction of the array. The array is displayed.

If you have the Group and Associate option toggled on, you 
are prompted again for the number of items, as shown in 
Figure 2–27. 

Type a new number or 
click on the screen to end 
the command.

Figure 2–27

Linear Array

Radial Array
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To make a linear array in two directions, you need to array 
one direction first, select the arrayed elements, and then 
array them again in the other direction.

Array Options

In the Options Bar, set up the Array options for the Linear Array 
or Radial Array, as shown in Figure 2–28.

Figure 2–28

Linear Array 
Options

Radial Array 
Options

Group and 
Associate

Creates a group element out of all arrayed elements. Groups 
can be selected by selecting any element in the group.

Number Specifies how many instances you want in the array.

Move To: 2nd specifies the distance or angle between the center 
points of the two elements.
Last specifies the overall distance or angle of the entire 
array.

Constrain Restricts the direction of the array to only vertical or 
horizontal (Linear only).

Angle Specifies the angle (Radial only).

Origin Specifies a location for the origin of rotation (Radial only).
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How to: Create a Radial Array
1. Select the element(s) to array. 

2. In the Modify panel, click  (Array).

3. In the Options Bar, click  (Radial).

4. Click and drag the  (Center of Rotation) control or use 

 to move the origin to the appropriate location, as 
shown in Figure 2–29.

Remember to set the 
center point rotation 
control first, because it is 
easy to forget to move it 
before specifying the 
angle.

Figure 2–29

5. Specify the other options as needed.
6. In the Options Bar, type an angle and press <Enter>, or 

specify the rotation angle by selecting points on the screen.

Modifying Arrays

When you select an element in an array that is created as a 
group, the associated shape controls and dimensions display, as 
shown in Figure 2–30. You can modify the number of instances 
and, for radial arrays, the distance to the center.

Figure 2–30

To remove the constraint on the group, select one of the 

elements in the group and click  (Ungroup) in the Group 
panel contextual tab.
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2.4 Additional Editing Tools

As you work on a project, some additional tools in the Modify 
tab>Modify panel, as shown in Figure 2–31, can help you with 
placing, modifying, and constraining elements. Align, Split, 
Trim, and Offset can be used with ducts and other elements.

Figure 2–31

Aligning
Elements

The Align command enables you to line up one element with 
another, as shown in Figure 2–32. Most Revit MEP elements can 
be aligned. 

Figure 2–32

How to: Align Elements

1. In the Modify tab>Modify panel, click  (Align) or type the 
shortcut AL.

2. Select a line or point on the element that is going to remain 
stationary. For walls, make sure you select the proper wall 
face. For ducts or pipes, press <Tab> to select the edges or 
center lines.

3. Select a line or point on the element to be aligned. The 
second element moves into alignment with the first one.

The Align command works in both plan and elevation views.

The Align command also works in 3D views. Make sure you 
select the correct component of the elements to align. For 
example, to line up two windows vertically, select the side of 
the frame of each window. Zoom in if needed.

Second PickFirst Pick

Before During After
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You can lock alignments so that the elements move together 
if either one is moved. Once you have created the alignment, 
a padlock is displayed. Click on the padlock to lock it, as 
shown in Figure 2–33.

Figure 2–33

Select the Multiple Alignment option to select multiple 
elements to align with the first element, as shown in 
Figure 2–34. You can also hold down <Ctrl> to make multiple 
alignments.

For walls, you can specify whether you want the command to 
prefer Wall centerlines, Wall faces, Center of core, or 
Faces of core, as shown in Figure 2–34. The core refers to 
the structural members of a wall as opposed to facing 
materials, such as sheetrock.

Figure 2–34

Splitting Linear
Elements

The Split command enables you to break a duct, wall, or line at 
a specific point. You can use alignment lines, snaps, and 
temporary dimensions to help place the split point. After you 
have split the element, you can use other editing commands to 
modify it, such as changing the wall type in one section, as 
shown in Figure 2–35.

Figure 2–35

There are two commands:  (Split Element) and  (Split 
with Gap).
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How to: Split an Element

1. In the Modify tab>Modify panel, click  (Split Element) or 
type the shortcut SL.

2. In the Options Bar, select or clear the Delete Inner Segment 
option, as needed.

3. Move the cursor to the point you want to split and select the 
point.

4. Repeat for any additional split locations.
5. Modify the items that were split, as needed.

The Delete Inner Segment option is used when you select 
two split points along an element. When the option is 
selected, the segment between the two split points is 
automatically removed.

 (Split with Gap) splits a wall at the point you select, as 
shown in Figure 2–36, but also creates a Joint Gap specified 
in the Options Bar.

Figure 2–36

Ducts and Pipes add a transition fitting to the open end of the 
split segments.Typically, you need to delete these fittings 
before doing any further editing.

Split

Split with Gap
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Trim and
Extend

The Trim command enables you to either trim or extend 
elements. There are three trim methods: Trim/Extend to 
Corner, Trim/Extend Single Element, and Trim/Extend 
Multiple Elements.

When selecting elements to trim, click the part of the element 
that you want to keep. The opposite part of the line is then 
trimmed.

How to: Trim/Extend to Corner

1. In the Modify tab>Modify panel, click  (Trim/Extend to 
Corner) or type the shortcut TR.

2. Select the first element on the side you want to keep.
3. Select the second element on the side you want to keep, as 

shown in Figure 2–37.

Figure 2–37

How to: Trim/Extend a Single Element

1. In the Modify tab>Modify panel, click  (Trim/Extend Single 
Element).

2. Select the cutting or boundary edge.
3. Select the element to be trimmed or extended, as shown in 

Figure 2–38.

Figure 2–38

Ducts, Pipes, Conduit, and Cable Tray create fittings at each 
connection point based on the family types being edited.

Pick 1

Pick 2

Before During After

Before During After

Pick 1

Pick 2
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How to: Trim/Extend Multiple Elements

1. In the Modify tab>Modify panel, click  (Trim/Extend 
Multiple Elements).

2. Select the cutting or boundary edge.
3. Select the elements that you want to trim or extend. For 

trimming, select the side you want to keep, as shown in 
Figure 2–39.

Figure 2–39

You can click in a blank space to clear the selection and 
select another cutting edge or boundary.

Offsetting
Elements

The Offset command is an easy way of creating parallel copies 
of elements at a specified distance, as shown in Figure 2–40. 
Beams, braces, and lines can also be offset.

Figure 2–40

Before During After

Pick 3

Pick 2
Pick 1

Pick 4
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The offset distance can be set by typing the distance (Numerical 
method shown in Figure 2–41) or by selecting points on the 
screen (Graphical method).

Figure 2–41

How to: Offset using the Numerical Method
The Copy option (on by 
default) makes a copy of 
the element being offset. 
If this option is off, the 
Offset command moves 
the element.

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut OF.

2. In the Options Bar, select the Numerical option.
3. In the Options Bar, type the required distance in the Offset 

field.
4. Move the cursor over the element you want to offset. A 

dashed line previews the offset location. Move the cursor to 
flip the sides, as needed.

5. Click to create the offset.
6. Repeat Steps 4 and 5 to offset other elements by the same 

distance, or to change the distance for another offset.
7. Press <Esc> or start another command to finish.

How to: Offset using the Graphical Method

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut OF.

2. In the Options Bar, select the Graphical option.
3. Select the element to offset.
4. Select two points that define the distance of the offset and 

which side to apply it. You can type an override for the 
temporary dimension for the second point.

With the Numerical option, you can select multiple 
connected elements for offsetting. Hover your cursor over 
one element and press <Tab> until the required elements are 
highlighted. Select the elements to offset them. This enables 
you to offset all of them at once.

Elements connected at a corner, if offset to the outside of the 
corner, automatically extend to meet at the offset distance as 
shown in Figure 2–42.

Figure 2–42
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Hint: Hiding Elements in Views

As you are working, you can hide individual elements or entire 
categories of elements to clarify the display. They remain 
hidden until you display them again.

Select the element(s) that you want to hide, right-click, and 
select Hide in view>Elements or Category.

The Elements option only hides the selected elements, 
while the Category option hides all of the elements in that 
category. For example, you can select one grid line and use 
Hide in view>Category to hide all of the grid lines.

To display the elements or category again, in the View 

Control Bar, click  (Reveal Hidden Elements). The 
border and any hidden elements are displayed in magenta, 
while visible elements in the view are grayed out, as shown 
in Figure 2–43. Select the hidden elements that you want to 
restore, right-click, and select Unhide in View>Elements or 
Category.

Figure 2–43
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Practice 2a Basic Drawing and Editing
Estimated time for 
completion: 15 minutes

In this practice you will use temporary dimensions, controls, and 
snaps to modify the location of elements. You will than copy and 
move elements as well as rotate and align elements. The final 
version of the project is shown in Figure 2–44.

Figure 2–44

Task 1 - Use temporary dimensions and controls to modify 
elements.

1. Open the project file Simple-Building.rvt, found in the 
Chapter 2 folder of your class folder.

2. Select the AHU-1 unit in the hall of the building.

3. Zoom in to the connectors/controls. Select the temporary 
dimension above the unit and change the distance to 2’-0", 
as shown in Figure 2–45.

The temporary 
dimensions work with the 
walls in this project 
because they are part of 
the project, not linked in.

Figure 2–45
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4. The unit moves and the ducts move with it because the 
connectors control the location of the duct fittings and ducts. 

5. Pan over to the lower left room in the building. Select the tag 
that overlaps the ductwork as shown on the left in 
Figure 2–46.

6. In the Options Bar, select Leader.

7. Use the Move control to move the tag outside the room to a 
position in which it is not overlapping anything as shown on 
the right in Figure 2–46.

Figure 2–46

8. Zoom out to display the entire building.

9. Select the blue horizontal duct and use the Drag control to 
lengthen the duct so that it reaches into the room on the far 
right.

10.Click in empty space to clear the duct selection.

11. The Endcap of the duct did not move, as shown in 
Figure 2–47. Select and drag it to the endpoint of the duct.

Figure 2–47
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12.Undo the change in duct length.

13.Select the duct endcap.

Because there is only one 
type of element selected, 
the specific type of 
element is displayed in 
the contextual tab.

14. In the Modify | Duct Fittings tab>Modify panel, click 

 (Move).

15.For the base point, select the duct endpoint.

16.Move it into the other room again. This time the endcap 
moves and the duct, which has a connector to the endcap, 
resizes as well.

Task 2 - Copy elements.

1. Select the Air Terminals and associated ductwork as shown 
in Figure 2–48.

Figure 2–48

Because there is more 
than one type of element 
selected the contextual 
tab displays as 
Multi-Select.

2. In the Modify | Multi-Select tab>Modify panel, click  
(Copy).

3. In the Options Bar, select the Multiple option.
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4. For the base point, select the endpoint of one of the vertical 
ducts as shown in Figure 2–49.

5. Copy the elements into the last room, as shown in 
Figure 2–49.

Figure 2–49

6. Press <Esc> twice to end the command.

Task 3 - Align and rotate elements.

1. In the Project Browser, open the view 1- Ceiling Mech (found 
in the Mechanical>HVAC>Ceiling Plans folder).

2. The air terminal locations do not match the ceiling grids as 
shown in Figure 2–50.

Figure 2–50

3. Zoom in on the room to the left.

Base point for copy
Base 
point
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4. In the Modify tab>Modify panel, click  (Align).

5. Select a vertical grid line and then the edge of the air terminal 
as shown in Figure 2–51. The air terminal now lines up with 
the vertical pattern of the ceiling grid.

Figure 2–51

6. Repeat the process with the air terminal and the horizontal 
grid location. Select the edge of the grid line first and then the 
air terminal.

7. Repeat the process in both rooms so that the air terminals 
line up with the grids shown in Figure 2–52.

Figure 2–52

8. In the last room the ceiling grid is rotated. In this case you 
need to rotate the air terminals as well.
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9. Select one of the air terminals in the room with the rotated 
ceiling grid.

10. In the Modify | Air Terminals tab>Modify panel, click

 (Rotate).

11. In the Options Bar, set the angle to 45.

12.Use the Align command to move the air terminal to match 
the ceiling grid location. First you will select the ceiling grid 
line and then the edge of the air terminal.

13.The flex duct moves with the air terminal as shown 
Figure 2–53.

Figure 2–53

14.Without rotating the air terminal, start  (Align).

15.Select a grid line close to one of the other air terminals and 
then select the edge of the air terminal. The air terminal 
moves to touch the grid line and also rotates to match the 
angle of the grid line.

16.Finish aligning all of the air terminals in this room. The exact 
location is up to you.

17.Zoom out to display the entire building.
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18.Switch to the 1 - Mech floor plan view. The rotated terminals 
and flex duct display correctly in this view as well as shown in 
Figure 2–54.

Figure 2–54

19.Zoom out to display the entire building.

20.Save the project.
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Chapter Review Questions

1. What is the purpose of an alignment line?

2. How do you edit a temporary dimension when you are 
drawing?

3. How do you only select Air Terminals in a view?

4. Where do you change an element’s type?

5. Which editing command would you use to remove part of a 
duct?
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Command Summary
Button Command Location

Align Ribbon: Modify tab>Modify panel> 
Align
Shortcut: AL

Array Ribbon: Modify tab>Modify panel>
Array
Shortcut: AR

Copy Ribbon: Modify tab>Modify panel>
Copy
Shortcut: CO

Copy to 
Clipboard

Ribbon: Modify tab>Clipboard panel>
Copy to Clipboard
Shortcut: <Ctrl>+C

Delete Ribbon: Modify tab>Modify panel>
Delete
Shortcut: DE

Filter Ribbon: Modify | Multi-Select tab>
Filter panel>Filter
Status Bar

Mirror - Draw 
Axis

Ribbon: Modify tab>Modify panel>
Mirror
Shortcut: DM

Mirror - Pick 
Axis

Ribbon: Modify tab>Modify panel>
Mirror
Shortcut: MM

Move Ribbon: Modify tab>Modify panel>
Move
Shortcut: MV

Offset Ribbon: Modify tab>Modify panel> 
Offset
Shortcut: OF

Paste Ribbon: Modify tab>Clipboard panel>
Paste
Shortcut: <Ctrl>+V

Pin Ribbon: Modify tab>Modify panel>
Pin
Shortcut: PN

Reference 
Plane

Ribbon: Home tab>Work Plane panel

Rotate Ribbon: Modify tab>Modify panel>
Rotate
Shortcut: RO and R3
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Scale Ribbon: Modify tab>Modify panel>
Scale
Shortcut: RE

Split Ribbon: Modify tab>Modify panel> 
Split
Shortcut: SL

Trim/Extend to 
Corner

Ribbon: Modify tab>Modify panel> 
Trim/Extend to Corner
Shortcut: TR

Trim/Extend 
Multiple 
Elements

Ribbon: Modify tab>Modify 
panel>Trim/Extend Multiple Elements

Trim/Extend 
Single Element

Ribbon: Modify tab>Modify panel> 
Trim/Extend Single Element
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