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Chapter 2
Connecting to Geospatial Data

In this chapter, you connect to existing geospatial data and create a surface from 
it to determine which data should be collected during the field survey.

This chapter contains the following topics:

Introduction to the Planning and Analysis Workspace

Coordinate Systems

Geospatial Data Connection

Create a Surface from GIS Data
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2.1 Introduction to the Planning 
and Analysis Workspace

The Planning and Analysis Workspace in the AutoCAD® Civil 

3D® software contains tools that are also found in the AutoCAD® 

Map 3D® software. They help you to attach and analyze GIS 
data for more efficient planning of projects before starting a 
design.

Map Workflow The following workflow is one of many workflows that can be 
used. It only covers a small portion of the AutoCAD Map 3D 
software capabilities.

1. Start a new drawing from a Civil 3D template that includes all 
of the necessary styles.

2. Assign a Coordinate System to the drawing file.
3. Attach Image and Digital Elevation Models (DEM) files using 

the Data Connect command.
4. Attach other source data using the Data Connect command.
5. Create AutoCAD Civil 3D surfaces from source data.
6. Style the layers for presentation or publication purposes.
7. Analyze the data.
8. Create labels and legends to annotate the drawing.

A typical workflow using the Planning and Analysis workspace 
includes setting up a drawing with the coordinates assigned, and 
then connecting to file-based data sources (.SHP or .SDF files) 
or to a database (Oracle or Microsoft SQL Server). Data can be 
queried as it is added to the drawing file to ensure that only the 
area of interest or items of interest are incorporated into the 
drawing file.

Once data is included in the drawing, it can be displayed using 
themes and symbols for proper representation of the entities. 
Analysis can be done on the entities to determine which entities 
are within a specific distance of another (buffer analysis) or 
which entities overlay another (overlay analysis).

Learning Objective

Identify where tools are found within the Planning and 
Analysis Workspace.
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The Map Setup tab>Coordinate System panel is used to assign 
a coordinate system to the drawing file, as shown in Figure 2–1. 

Figure 2–1

The Home tab>Data panel is used to connect to source data, 
such as images, file sources, and database sources, as shown in 
Figure 2–2. 

Figure 2–2

Creating a surface from source data is done using the Civil 3D 
workspace in the Home tab>Create Ground Data panel, as 
shown in Figure 2–3. 

Figure 2–3
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2.2 Coordinate Systems

Coordinate systems are used in engineering and mapping to 
uniquely identify the position of geographical elements. Different 
systems project elements differently to accommodate the 
curvature of the earth’s surface. Therefore, it is vitally important 
to set the coordinate system for the drawing in which you plan to 
work. 

Coordinate systems communicate to the computer where the 
project is located in the world, along with mathematical 
equations used to account for the curvature of the earth. Once 
the drawing coordinate system has been set, any GIS or Survey 
data that is connected to the drawing automatically re-projects 
and lines up properly in the current drawing.

How to: Set the Drawing Coordinate System in the Planning and 
Analysis Workspace

1. In the Quick Access Toolbar, change the workspace to 
Planning and Analysis, as shown in Figure 2–4. 

Figure 2–4

2. In the Map Setup tab>Coordinate System panel, click 

 (Assign) to assign a coordinate system to the drawing 
file, as shown in Figure 2–5. 

Figure 2–5

Learning Objective

Set the drawing coordinate system for a new drawing.



AutoCAD Civil 3D 2014 for Surveyors

2–6 © 2013, ASCENT - Center for Technical Knowledge®

3. Search for the code required by your project and select it, as 
shown in Figure 2–6. 

Figure 2–6

4. Click .

How to: Set the Drawing Coordinate System in the Civil 3D 
Workspace

1. In the Quick Access Toolbar, change the workspace to Civil 
3D, as shown in Figure 2–7. 

Figure 2–7
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2. In the Settings tab in the Toolspace, right-click on the drawing 
name and select Edit Drawing Settings, as shown in 
Figure 2–8. 

Figure 2–8

3. In the Drawing Setting dialog box, in the Units and Zone tab, 
select the category and coordinate system for the drawing, as 

shown in Figure 2–9. Click .

Figure 2–9
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Practice 2a Start a New Project

Estimated time for 
completion: 5 minutes

In this practice, you will create a new drawing and assign a 
coordinate system to the drawing.

Task 1 - Start a new file.

1. Click  (Application Menu) and select New to start an new 
drawing file.

2. Select _AutoCAD Civil 3D (Imperial) NCS.dwt, which ships 
with the software, as shown in Figure 2–10. 

Figure 2–10

3. Click  (Application Menu) and select SaveAs. Type 
BaseMap for the filename, browse to C:\Civil 3D Projects\

Civil3D-Training, and click .

Task 2 - Set the drawing coordinates.

1. Continue working with the drawing from the previous task or 
open GEO-A2-GIS.dwg.

2. In the Quick Access Toolbar, change the workspace to 
Planning and Analysis, as shown in Figure 2–11. 

Figure 2–11

Learning Objective

Display the current conditions by connecting to GIS data.
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3. In the Map Setup tab>Coordinate System panel, click 

 (Assign) to assign a coordinate system to the drawing 
file, as shown in Figure 2–12. 

Figure 2–12

4. In the Search field, type CA83 and select CA83-VIF from the 

list of code, as shown in Figure 2–13. Click .

Figure 2–13

5. Save the drawing.
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2.3 Geospatial Data Connection

Geospatial data is collected and maintained by a large number of 
organizations using a variety of different software. The AutoCAD 
Civil 3D software can connect to many of these data sources 
using the Feature Data Object (FDO) connection in Display 
Manager tab>AutoCAD Map 3D Task pane or the Home tab in 
the Planning and Analysis workspace. The types of data that can 
be connected include: ArcSDE, Enterprise Industry Models, 
MySQL, ODBC, Oracle, PostgreSQL, Raster Image or Surface 
Connection, Spatial Data Files, ESRI Shape files, SQL Server 
Spatial, SQLite, WFS, WMS.

Connect to
GIS Data

The process of connecting to GIS data is similar among data 
types. First you select the type of data to which to connect, and 
then you select the number of files that are going to connect at 
the same time. You can connect to one file at a time or to an 
entire directory of files at the same time. If a database 
connection is selected (such as Oracle or ArcSDE) you might 
need to input your login credentials, as shown in Figure 2–14. 

Figure 2–14

Learning Objective

Display the current conditions by connecting to GIS data.
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Finally, you need to ensure that the coordinate system of the 
source file registers as you connect to it. If the coordinate system 
for the source file is listed as <unknown> (as shown in 
Figure 2–15), it did not register properly. Therefore, you need to 
assign the source coordinate system manually so that it 
re-projects automatically in the drawing and displays in the 
correct location.

Figure 2–15

How to: Connect to GIS Data 

There are multiple locations in which you can access the Data 
Connection palette. The first is the Home tab in the Planning and 
Analysis workspace, the second is in the Map Task pane.

1. In the Home tab>Data panel in the Planning and Analysis 

workspace, click  (Connect), as shown in Figure 2–16. 

Figure 2–16

Alternatively, you can do the following:

1. In the Home tab>expanded Palettes panel in the Civil 3D 

workspace, click  (Map Task Pane), as shown in 
Figure 2–17. 

Figure 2–17
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2. In the Display Manager tab in the Map Task Pane, click

 (Data) and select Connect to Data, as shown in 
Figure 2–18. 

Figure 2–18

3. In the Data Connect palette, select the proper connect type.

4. Type a name for the connection and click  (Browse for 

source file) or  (Browse for source folder), as shown in 
Figure 2–19. 

Figure 2–19

5. Select the file or folder and click .

6. In the Data Connect palette, click .
7. In the Coordinate System column, double-click on 

<unknown> to edit the coordinate system that is registered 
with the source file, as shown in Figure 2–20.
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Figure 2–20

8. In the Edit Spatial Contexts dialog box, select <unknown> 

and click , as shown in Figure 2–21. 

Figure 2–21

9. Select the required coordinate system from the list of codes, 

as shown in Figure 2–22. Click . Click .

Figure 2–22

10. In the Data Connect palette, click .
11. Continue adding data sources as required.
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Stylize GIS Data The available styles for a GIS layer depend on the type of GIS 
data being displayed. Point features (such as points of interest 
within a city) can use block symbols as the point style while 
linear features (such as roads) use linetypes and linewidths to 
communicate differences between feature types. If an area 
feature (such as a city boundary or parcel) is used, both hatch 
patterns and linetypes/linewidths are used to communicate 
differences between feature types, as shown in Figure 2–23.

Figure 2–23

How to: Modify an Area Style

1. In the View tab>Palettes panel, click  (Map Task Pane) as 
shown in Figure 2–24.

Figure 2–24

2. In the Task Pane, in the Display Manager tab, double-click on 
the area layer.

3. In the Style Editor palette, in the Style column, click

 (Browse) as shown in Figure 2–25.
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Figure 2–25

4. In the Style Polygon dialog box, change the border color and 
fill color or add additional borders and fills as required, as 

shown in Figure 2–26. Click  and close the Style 
Polygon dialog box and Style Editor palette.

Figure 2–26

Draw Order Setting the drawing order of the layer determines which layer is 
displayed on top of another. If an aerial photograph or other 
raster file is displayed, it is useful to move it to the background so 
that other layers are visible. 
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How to: Change the Draw Order of GIS Layers

1. In the Task Pane, in the Display Manager tab, select Draw 
Order and drag the layers above or below the others to 
ensure that they all display, as shown in Figure 2–27.

Figure 2–27

2. In the Draw Order dialog box that opens, select Continue 
action and allow Draw Order to control layer position 
from now on.
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Practice 2b Connect to GIS Data

Estimated time for 
completion: 10 minutes

In this practice, you will create a new drawing and assign a 
coordinate system to the drawing.

Task 1 - Connect to an image file.

1. Continue working with the drawing from the previous practice 
or open GEO-B1-GIS.dwg.

2. In the Home tab>Data panel, click  (Connect), as shown 
in Figure 2–28. 

Figure 2–28

3. In the Data Connect palette, select Add Raster Image or 
Surface Connection, for Connection name, type Aerial 

Image, and click  (browse for image file), as shown in 
Figure 2–29. 

Figure 2–29

4. Select the Main Site Imperial.jpg in C:\Civil 3D Projects\

Civil3D-Training\Images\. Click .

5. In the Data Connect palette, click .

Learning Objective

Connect to an aerial image file using AutoCAD Map 3D 
tools.
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6. In the Coordinate System column, double-click on 
<unknown> to edit the coordinate system that is registered 
with the image file.

7. In the Edit Spatial Contexts dialog box, select <unknown> 

and click , as shown in Figure 2–30. 

Figure 2–30

8. In the Search field, type CA83, and in the list of code, select 

CA83-VIF, as shown in Figure 2–31. Click . Click 

.

Figure 2–31

9. In the Data Connect palette, click , close the 
Data Connect palette, and save the drawing.

Task 2 - Connect to a Shape file.

1. Continue working with the drawing from the previous task or 
open GEO-B2-GIS.dwg.
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2. In the Home tab>Data panel, click  (Connect), as shown 
in Figure 2–32. 

Figure 2–32

3. In the Data Connect palette, select Add SHP Connection. 
For the Connection name, type Parcels, and click

 (Browse for shp file), as shown in Figure 2–33. 

Figure 2–33

4. Select the Properties.shp in C:\Civil 3D Projects\

Civil3D-Training\Geospatial\. Click .

5. In the Data Connect palette, click .

6. In the Data Connect palette, click . Close the 
Data Connect palette and save the drawing.

7. If the Map Task Pane is not displayed, click  (Map Task 
Pane) in the View tab>Palettes panel, as shown in 
Figure 2–34.

Figure 2–34
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8. In the Task Pane, in the Display Manager tab, double-click on 
the Properties layer.

9. In the Style Editor palette, in the Style column, click

 (Browse) as shown in Figure 2–35.

Figure 2–35

10. In the Style Polygon dialog box, change the border color to 
Cyan and the fill color to No Color, as shown in Figure 2–36. 

Click  and close the Style Polygon dialog box and 
Style Editor palette.

Figure 2–36



Connecting to Geospatial Data

© 2013, ASCENT - Center for Technical Knowledge® 2–21

11. In the Task Pane, in the Display Manager tab, select Draw 
Order and then drag the Map Base layer above the 
Properties layer, as shown in Figure 2–37.

Figure 2–37

12. In the Draw Order dialog box that opens, select Continue 
action and allow Draw Order to control layer position 
from now on.

13.Save the drawing.
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2.4 Create a Surface from GIS 
Data

An AutoCAD Civil 3D surface can be created from GIS data. 
Once created, the surface can be used to create surface profiles 
and act as a target for corridor models and grading groups. It is 
recommended that you request any available metadata when 
obtaining GIS layers that could be used for creating a 3D surface 
model. The metadata should indicate how accurate the data is 
and whether it can be used in detailed design drawings. GIS 
surfaces are not often used for detailed design because they are 
typically mapping grade rather than survey grade, but that is 
changing rapidly. Having a surface from GIS data can be useful 
in the project planning phase of a project, even if it is not survey 
grade. Data source types that can be used to create a surface 
include: ArcSDE, Oracle, and ESRI Shape Files

How to: Create an AutoCAD Civil 3D Surface from SHP files

1. In the Quick Access Toolbar, select Civil 3D for the 
workspace.

2. In the Home tab>Create Ground Data panel, expand the 

Surfaces drop-down list and click  (Create Surface from 
GIS Data), as shown in Figure 2–38. 

Figure 2–38

Learning Objective

Create a surface from a shape file containing elevation data.
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3. In the Object Options page, for the Civil 3D object type, select 
Surface. Type a name and select the required styles for 
displaying the surface, as shown in Figure 2–39. Click 

.

Figure 2–39

4. In the Connect to Data page, for the Data source type, select 

SHP, click  (Browse for file) and select a shape file that 
includes vector data for the contours and elevation data in 
the database file, as shown in Figure 2–40. Click 

 and click .

Figure 2–40
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5. In the Schema and Coordinates page, select the Contours 
feature class and ensure that the Contours Coordinate 

system is set, as shown in Figure 2–41. Click .

Figure 2–41

6. In the Geospatial Query page, clear the Define area of 
interest option so that the entire Contours shape file is used 
to create a surface, as shown in Figure 2–42. Click 

.

Figure 2–42

7. In the Data Mapping page, expand the drop-down list and 
select the field that holds the surface elevation values, as 

shown in Figure 2–43. Click .

Figure 2–43

Contour data is available from many sources. Large sites are 
often surveyed using aerial photogrammetry, which provides 
contour polylines and spot elevations. When contour data is 
used from other GIS data types, the AutoCAD Civil 3D software 
interprets the imported linework as polylines with elevations.
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In the AutoCAD Civil 3D software, polylines with elevation are 
useful as custom contour objects. Whether using polylines or 
other GIS contour objects, the AutoCAD Civil 3D software builds 
a surface by triangulating between contours. The end of each 
triangle side connects to a vertex of two different contours.

Contour Issues Note the following issues when working with contour data: bays 
and peninsulas within the contours and the lack of high and low 
point elevations. These issues affect triangulation and the quality 
of a surface.

Bays and peninsulas within contours represent gullies or isolated 
high points on a surface. As long as there is data to work with, 
the AutoCAD Civil 3D software builds a surface by triangulating 
between contours of different elevations. When the software 
cannot triangulate between different contours, the triangulation 
switches to connecting vertices on the same contour.

The Minimize Flat Faces command helps mitigate this situation 
by forcing the triangulation to target different contours, as shown 
in Figure 2–44. However, this method, similar to the edge swap 
method, does not correct every problem on a contour surface.

 To launch the Minimize Flat Faces command, right-click on 
the Edits heading in the Definition collection of a surface and 
select the command.

Figure 2–44
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The second issue with contour data regards the loss of high and 
low points. Contours represent an elevation interval (120, 122, 
123, etc.). However, the top of a hill could be 123.04 or 136.92 
and the only contours present are for the elevations of 123 or 
136. Spot elevations are needed in the surface data to help 
correctly resolve the high and low spots of a surface.

 Flat spots and the loss of high and low points affect the 
calculation of volumes for earthworks, as shown in 
Figure 2–45.

Figure 2–45

Minimizing Flat
Triangle

Strategies

By default, the Minimize flat areas by: options shown in 
Figure 2–46 are selected in the Add Contour Data dialog box.

 
Figure 2–46
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Together, these three methods attempt to detect and resolve 
peninsulas, bays, and other issues by adding additional points 
and filling in gaps based on surface trends. Generally, these 
provide the most expected results. The Swapping edges option 
is provided as a way of emulating how other terrain modeling 
software (such as AutoCAD Land Desktop) traditionally 
approached minimizing flat areas. The AutoCAD Civil 3D 
software automatically applies three of the four Minimize flat 
area options as it creates the surface from GIS data.

Draping Images
On a Surface

Images and other 2D linework can be draped on a surface. 
Draping a 2D image on a surface gives it the appearance of 
being 3D and provides a better visualization of what is 
happening on the project site.

How to: Drape an Image on an AutoCAD Civil 3D Surface

1. In Model Space, select the GIS Data surface. In the 

contextual Surface tab>Surface Tools panel, click  (Drape 
Image), as shown in Figure 2–47.

Figure 2–47

2. In the Drape Image dialog box, ensure that the Main Site 
Imperial image is selected and that the GIS Data surface is 

selected, as shown in Figure 2–48. Click .

Figure 2–48
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Practice 2c Create a Surface from a Shape 
File

Estimated time for 
completion: 5 minutes

In this practice, you will create a new drawing and assign a 
coordinate system to the drawing.

Task 1 - Create a surface from a Shape file.

1. Continue working with the drawing from the previous practice 
or open GEO-C1-GIS.dwg.

2. In the Quick Access Toolbar, for the workspace, select Civil 
3D.

3. In the Home tab>Create Ground Data panel, expand the 

Surfaces drop-down list and click  (Create Surface from 
GIS Data), as shown in Figure 2–49. 

Figure 2–49

4. In the Object Options page, for the Name, type GIS Data. 
Leave all of the other settings as their defaults, as shown in 

Figure 2–50. Click .

Learning Objective

Create a surface from a shape file containing elevation data.
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Figure 2–50

5. In the Connect to Data page, for the Data source type, select 

SHP. Click  (Browse for file) and select Contours.shp in 
C:\Civil 3D Projects\Civil3D-Training\Geospatial\, as shown 

in Figure 2–51. Click . Then click 

.

Figure 2–51

6. On the Schema and Coordinates page, select the Contours 
feature class and ensure that the Contours Coordinate 
system is set to NAD83 California State Planes, Zone VI, 

US Foot, as shown in Figure 2–52. Click .

Figure 2–52
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7. In the Geospatial Query page, clear the Define area of 
interest option so that the entire Contours shape file is used 
to create a surface, as shown in Figure 2–53. Click 

.

Figure 2–53

8. In the Data Mapping page, expand the Elev drop-down list 
and select Elevation, as shown in Figure 2–54. Click 

.

Figure 2–54

9. Save the drawing.

Task 2 - Drape an image on the surface.

1. Continue working with the drawing from the previous task or 
open GEO-C2-GIS.dwg.

2. In Model Space, select the GIS Data surface. In the 

contextual Surface tab>Surface Tools panel, click  (Drape 
Image), as shown in Figure 2–55.

Figure 2–55



Connecting to Geospatial Data

© 2013, ASCENT - Center for Technical Knowledge® 2–31

3. In the Drape Image dialog box, ensure that the Main Site 
Imperial image is selected and that the GIS Data surface is 

selected, as shown in Figure 2–56. Click .

Figure 2–56

The image might not 
look the same in the 
object view. Use 3D 
Orbit to display the 
results of draping an 
image.

4. In the View tab>Navigate 2D panel, click  (Orbit). Orbit the 
drawing as shown in Figure 2–57. Press <Esc>.

Figure 2–57

5. Save the drawing.
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Chapter Review Questions

1. In which workspace is the Coordinate System panel located?

a. Civil 3D

b. 2D Drafting and Annotation

c. 3D Modeling

d. Planning and Analysis

2. What type of data cannot be connected using the Data 
Connection palette?

a. ArcSDE

b. Oracle

c. Microstation DGN file

d. ESRI Shape File

3. You have to be in the Planning and Analysis workspace to 
access the Data Connect palette.

a. True

b. False

4. In which workspace is the Create Surface from GIS Data 
command located?

a. Civil 3D

b. 2D Drafting and Annotation

c. 3D Modeling

d. Planning and Analysis

5. What toolspace do you need to be in to drape an image on a 
surface? 

a. Civil 3D

b. 3D Modeling

c. Planning and Analysis

d. It does not matter because the Surface contextual tab 
displays when you select a surface no matter which 
workspace you are using.
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Command Summary
Button Command Location

Assign  Workspace: Planning and Analysis

 Ribbon: Map Setup tab>Coordinate 
System panel

 Command Prompt: MAPCSASSIGN

Create Surface 
from GIS Data

 Workspace: Civil 3D

 Ribbon: Home tab>Create Ground 
Data panel

 Command Prompt: 
CreateSurfaceFromGISData

Data Connect  Workspace: Planning and Analysis

 Ribbon: Home tab>Data panel

 Command Prompt: MAPCONNECT

Drape Image  Ribbon: Contextual Surface tab>
Surface Tools panel

Map Task Pane  Workspace: Civil 3D

 Ribbon: Home tab>Expanded Palettes 
panel

 Command Prompt: MapWSpace


