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Chapter 1

Creating Custom Templates

In this chapter you learn how to prepare project templates, create preset
annotation styles, create title blocks, and create and apply view templates. You
also review settings for structural, mechanical, and electrical projects.

This chapter contains the following topics:

v'Preparing Project Templates

v'Customizing Annotation Styles

v'Creating Title Blocks

v'View Templates

v'Settings for Mechanical and Electrical Projects
v'Settings for Structural Projects

1-1






Creating Custom Templates

1.1 Preparing Project Templates

Learning Objectives

Create project templates that include basic information and
settings.

Customize units, snap settings, temporary dimension
settings, and typed in shortcuts.

A project template is an existing file that contains preloaded
families, settings, views, sheets, schedules, and sometimes
geometry, that can be used to create a new project. You can
have several project templates for different types of projects or
building types, such as residential, commercial, and industrial. If
you do a lot of work for a specific client (e.g., a school system),
you can also create a template specifically for their projects with
associated title blocks and other information. The aim is to save
time with standards so that you can concentrate on the design.

B Defining Levels in a project template is helpful. They could be
just a few basic levels for a residential project, as shown in
Figure 1-1, or 100 stories for a high-rise.

First Floor
—— e — - Titior g

Foundation
o

Bazement
T

T.0. Footing

- - - - ooting el
B.0. Footing
a0

Figure 1-1
How to: Create a Project Template File

1. In the Application Menu, expand 3 (New) and click
Ind (Project).
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2. In the New Project dialog box, select a template file to build
from or select None to use a blank project file.

3. Inthe Create new area, select Project template, as shown in
Figure 1-2.

Project template. files New Project =
have the extension
RTE. Template file

Construction Template v| | Browse... |

Create new

Project @) Project template

[ QK ] | Cancel | | Help

Figure 1-2

Click L9 |

If you select <None> in the Template file list, you are
prompted to specify the initial unit system for the project:
Imperial or Metric, as shown in Figure 1-3.

o~

Undefined System of Measurement

Which system of measurement do you want to
use in your project?

=< Imperial

2 Metric

Figure 1-3

Add settings, families, views, etc., as needed to the new file.
Save the project template file.

No

B To save time, use an existing project or template that includes
some of the basics you need rather than starting from
scratch.

Managing Most of the settings stored in a template file are found in the

. Manage tab>Settings panel as shown in Figure 1-4. These
Settlngs settings include Units, Snaps, Temporary Dimensions, Object
Styles (Lineweights, Line color, and Line patterns), Line Styles,
Materials, Fill Patterns, etc.

1-4 © 2013, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

I @ % (8 & @
e = -
Modify | Materials Ej';_ m Additional k‘
I A BE - | Settings (Eh
Select = Settings )
@ Fill Patterns
Medify | Place Text
Properties (3 | Material Assets
Text ( !ﬁ) Analysis Display Styles
3/32" Anal
J - Sheet Issues/Revisions
MNew Text '] B E3 )
_/LmeSt_yles
m— Line Weights
—
=— Line Patterns
D Halftone / Underlay
Figure 1-4

B Specific Structural Settings, MEP Settings, and Panel
Schedule Templates are also included in this grouping.

System Walls, Wall Foundations, Floors, Slabs, Ceilings, and Roofs as
eye well as Duct, Pipe, Cable Tray and Conduit types are created by

Families duplicating and modifying an existing type as shown in

Figure 1-5. These are considered System Families because

they are created in the system rather than in a separate family

file. Annotation Styles for Text and Dimensions are also system

families and are modified in Type Properties as well.

To open Type f _ :
Properties, select a type P [l
and, in th.e Modify tat.) Family: [System Family: Basic Wall v] =
>Properties panel, click
(1 _ Type: | Exterior - Brick on CMU »| | oDuplicate... |
(Type Properties) or
in Properties, click | Rename... |
. Type Parameters
(Edit Type).
Parameter | Value | &
Construction ]
Structure [ Edit...
Wrapping at Inserts Do not wrap
Wrapping at Ends Mone
Width 1 71/2"
Function Exterior -

Figure 1-5
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Views and
Sheets

B System Families can also be added when a project is in
process, but it helps to have company standards created in
the template.

B Component Families, such as furniture, trees, beams,
columns, mechanical equipment, and electrical devices can
be loaded directly in a template file if there are types and
sizes that are used frequently. Otherwise, they can be loaded
from a library as the project progresses.

Additional items that you can setup in a template include Views
and Sheets. You can place empty views on sheets that are going
to be filled in as you proceed through a project. Views can be a
few basic floor and/or ceiling plans for a residential project, as
shown on the left in Figure 1-6, or a more complex mix of
Mechanical, Electrical, and Plumbing categories as shown on
the right in Figure 1-6

Praject Browser - Project? x Project Browser - Project3 =
=3, Views (all) » =3, Views [Discipling) -
=] Floor Plans = Mechanical

B.C. Footing = HVAC

Basement —|.-- Floor Plans

Bacement Electrical 1- Mech

First Floor 2 - Mech

First Floor Electrical = - Ceiling Plans £

First Floor Framing 1 - Ceiling Mech

Foundation 2 - Ceiling Mech

Roof Framing - 30 Views

Roof Plan {30

Second Floor = Elevations (Building Elevation)

Second Floor Electrical East - Mech

Second Floor Framing Morth - Mech

Site Plan South - Mech

T.0. Footing West - Mech

Figure 1-6

B You can create as many sheets as are typically used in a
project or you can create a sheet schedule and populate it
with sheet names that can be used as placeholder sheets.

Presetting a Starting View

When you create a project template or project, it can help to
specify a starting view. This can be any of the standard views,
such as plan, elevation, 3D view, or one that is specifically
created. This is often a Drafting View (as shown in Figure 1-7),
or a Legend View with information about the project or the cover
sheet for the project.

1-6
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New Project Name

Project Address
Project Addrass 2

Architect:
Structural Engineer:
MEFP Engmeear:

Ehvf Enginear:

Figure 1-7

How to: Set a Starting View

1. Set up the view or sheet that you want to use as the starting
view.

2. In the Manage tab>Manage Project panel, click & (Starting
View).

3. In the Starting View dialog box, select the view or sheet that
you want to use as shown in Figure 1-8.

Starting View [ 5| [mES]
Select a starting view, which will be the default view when Revit opens
the model,

If worksets are enabled, once you save this setting to the central model,
it will be shared by all local models after Synchronize with Central.

[«:J_ast Viewed = v]

<Last Viewed =
Elevation: East :]
Elevation: Maorth

Elevation: South

Floor Plan: Basement 1

Flrnr Plam: Razement 2

Figure 1-8

4. click L%,

5. Save the project or project template. The file opens to this
view, when it is next opened.
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Setting Default Template Files

If your company uses several different templates, you can create
a list that displays in the New Project dialog box, as shown in
Figure 1-9. The top five templates also display on the Recent

Files page.
[ Mew Project @
Template file
[Mid.l'ise Template v] [ Browse... ]
=None:=
Midrise Temﬁlate
Clglle D
! {-h:spital Template : -
[ oK ] [ Cancel ] [ Help ]
Figure 1-9
B To set the project template file list, in the Application Menu,

click "% |n the Options dialog box, in the left pane, select

File Locations, as shown in Figure 1-10. Specify the Name

and Path for each template. Use i (Add Value) to select
additional templates.

Options

X3

General

User Interface

Check Spelling

SteeringWheels

WViewCube

Mame Path
Graphics Construction Tem... ; Ch\ProgramData\Autodesk\RVT 2014\ Tem...
Architectural Tem... : C\ProgramData\Autodesk\RVT 2014°\Tem...
] g Structural Ternplate | CA\ProgramDatabAutodeskARVT 20045\ Tem...
Rendering

Project template files: The first five project templates will appear as links on the
Recent Files page.

Mechanical Templ...: CA\ProgramDatabAutodeskdRVT 20145\ Tem...

Figure 1-10

Use 1 (Move Rows Up) and i (Move Rows Down) to
order the templates. Move the templates that are used most
often to the top.

If you do not require a template anymore, select it and click

(Remove Value).

1-8
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Specifying Even though you select Imperial or Metric units when you create

. the project template, you can set up the Project Units with
Units | specific formats and options. For example, if you are working on
a Civil project where everything is set up in feet, you specify
Decimal Feet as the Length Format. For an international metric
project, you can specify the length units as Meters, Centimeters,
or Millimeters.

How to: Set Up Project Units

1. Inthe Manage tab>Settings panel, click (Project Units) or
type UN.

2. In the Project Units dialog box, as shown on the left in
Figure 1-11, in the Format column, click the button next to
the unit type that you want to modify. The related Format
dialog box opens, as shown on the right in Figure 1-11.

Project Units @ Farmat @
Discipline: |Common - | Use project settings
Units Format - Units: |Feet and fractional inches hd |
Length [ 1'-511/32" Rounding:
Area [ 1235 SF — Py |
Vaolume [ 123457 CE o the nearest 1/
Angle [ 12.35°
Slope [ 171/2" /12"
Currency [ 1234.57
Mass Density [ 123457 |b/ft Suppress trailing 0's
[7] suppress 0 feet
Show + for positive values
[ use digit grouping
[T suppress spaces
oK ] | Cancel
Dedmal symbol/digit grouping:
[ 123,456,789.00 -
[ oK ] | Cancel | | Help

Figure 1-11

3. Set the Units, Rounding, and other options as needed.

4. In the Project Units dialog box, you can also select the
Discipline (Common by default) and change the Unit format
for each discipline. The other options are Structural, HVAC,
Electrical, Piping, and Energy. The options vary according
to the discipline-specific software in use.

5. Click lLl to close each dialog box.
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Format Options

Each unit has specific formatting options. The option is grayed
out if it is not applicable to that unit type.

Units

Select the type of units in the Units drop-down list, as
shown in Figure 1-12.

Units: [Feet and fractional inches v]
Decimal feet

Rounding: Feet and fractional inches
. —1mqe Dedmalinches
To the nearest 1/32 Fractional inches

Meters

Centimeters

Milimeters
Meters and centimeters

Figure 1-12

Rounding

Specify how precisely you want the dimensions to be
rounded. The options depend on the Units you
selected.

Unit Symbol

If you are using metric units, you can select a unit
symbol, such as em for centimeters or None.

Suppress trailing
0’s

(For decimal-based units) If selected, this option
removes any trailing 0Os. For example, it displays 1.5
instead of 1.50 if you are using two decimal places.

Suppress 0 feet

(Imperial Units only) If selected, this option removes
the 0 in front of a dimension in inches only. For
example, the dimension displays as 0’-4”, rather than
4,

Use digit
grouping

If selected, the unit uses the Decimal symbol/digit
grouping specified in the Project Units dialog box, as
shown in Figure 1-13.

Dedmal symbol/digit grouping:
123,456,7539.00 -

123,456,789.00
123.456.789,00

123 456 759,00 [
123'456'739.00
12,34,56,789.00
12.34.56.789,00

12 34 56 739.00
12'34'56'789.00

Figure 1-13

Suppress spaces

(Imperial Units only) If selected, this option removes
the spaces between the feet and inches, so that a
dimension reads 1°-2", rather than 1’ - 2".

B The Use project settings and Show + for positive values
options are grayed out when setting units for the project. This
dialog box is used when creating dimension styles or
specifying label formats when the options are available.
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Snap Settings

The Snaps dialog box controls Dimension Snaps, which are the
increments you see in temporary dimensions, and Object Snaps,
which are the points on elements that you can select. It also lists
temporary snap overrides that can be used as keyboard

shortcuts within an active command. In the Manage tab>Settings

panel, click @ (Snaps) to open the dialog box, as shown in

Figure 1-14.
Snaps (=53

Snaps Off (50)
Dimension Snaps

Snaps adjust as views are zoomed.

The largest value that represents less than 2mm on screen is used.

W |Length dimension snap increments

4.0 67,0 17;0 01/47;

| Angular dimension snap increments

90.000® ; 45.000° ; 15.000° ; 5.000® ; 1.000%;
Object Snaps

| Endpoints (5E) |¥|Intersections (1)
| Midpaoints (M) || Centers (5C)
| Nearest (SM) || Perpendicular (5F)
| Work Plane Grid (5wW) |¥|Tangents (5T)
| Quadrants (5Q) |¥|Points (5X)
Checkal | |  Chedknane
| Snap to Remote Objects (SR)
Temporary Cverrides
While using an interactive tool, keyboard shortcuts (shown in parentheses) can be
used to spedfy a snap type for a single pick.
Object snaps Use shortouts listed above
Close (52)
Turn Override Off (55)
Cyde through snaps (TAB)
Force horizontal and vertical (SHIFT)
[ (0]4 l | Cancel | | Help
Figure 1-14

B Snap overrides are listed as keyboard shortcuts in
parentheses, next to the corresponding snap. When a snap
override is used, the cursor finds that specified snap type in
your view until something is selected.

B Snap overrides can be used while inside a command by
right-clicking and selecting Snap Overrides and then
selecting the one that you want to use from the list.
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Temporary
Dimension
Settings

Temporary dimensions display when you draw or edit building
elements in the software. By default, they measure from the
center lines of walls to the center lines of openings, as shown in
Figure 1-15.

g_qgn T_g"
[ ] ] = ]

| au-N
| [

Figure 1-15

B When you move a witness line to another element or part of
an element, the location is remembered within the current
session of program.

You can control where temporary dimensions are placed by
default. In the Manage tab>Settings panel, expand

I~

y (Additional Settings) and click I (Temporary Dimensions)
to open the Temporary Dimension Properties dialog box, as
shown in Figure 1-16.

=

Temporary Dimension Properties

Temparary dimensions measure from:
Walls
@ Centerlines Faces
Center of Core Faces of Core

Doors and Windows

@ Centerlines Openings

[ oK ] | Cancel |

Figure 1-16

B Temporary dimensions can be attached to Centerlines,
Faces, the center or face of the core objects in Walls, and the
center lines or openings of Doors and Windows.

B You can set up these properties in the project template file or
modify them at any time. They do not affect existing elements
in your project.

B You can control the size of the temporary dimension text in
the Options dialog box in the Graphics area.

© 2013, ASCENT - Center for Technical Knowledge®
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1.2 Customizing Annotation
Styles

Learning Objectives

0/ Create standard text and dimension types for use in your
project templates.

0/ Modify callout, elevation, and section tags and specify which
tags are loaded.

You can customize Annotation styles in your project template file
including dimensions, text types, and tags, as shown in
Figure 1-17.

Foom _Qum é y
[= 1] [+ ] :.;muz his ]fD *
: da, /

7

B @[ I |
5 ) é} é E (%B AT
; H E:' n : Foom
;; GI 1 Foom i % lII ] I:T:J ;-I“
B
I T
G / 1> 5] \ 5]
):E-:Ishmsln —‘II = = IP-VREnolE hirek Tom
Eniyand h v iz wed oy,
Figure 1-17

Text, Dimensions, and Arrowheads are all system families. This
means they have a standard set of parameters, which you can
modify and save as a type. Callout, Section, and Elevation tags
can be modified within the Autodesk Revit software. Most other
tags are created using families.

Creating Text Text types are used to standardize text formatting (such as the
font, text height, etc.), as shown in Figure 1-18. They can be
Types | created for to both annotative text and Model Text.

A FANCY FONT AT 1/4°

AHANE LETTERING FONT AT 1/ 8"
AHAND LETERNG FONT AT 5/ 52"

Figure 1-18
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B The Text command places text at the height you need for the
final plot. The view scale controls the height of the standard
text in the views.

B The Model Text command places text that is typically used
on the building, such as the signage shown in Figure 1-19.
Text types for Model Text should be the full height of the text
and are not affected by the view scale.

i Fi Fi O s s o o s I o rmrm_
ILLI

Figure 1-19

How to: Create a Text Type

]
1. Start the Text command. In Properties, click (Edit Type)

or in the Annotate tab>Text panel title, click * (Text Types).
For Model Text you first have to place an instance, select it,
and modify the type properties.

Duplicate. .. ]

In the Type Properties dialog box, click [

2.
3. Type a new name.
4. Modify the parameters as needed for the new type, as shown
for annotation text in Figure 1-20.
Type Parameters
Parameter | Value

Graphics 2

Color M Elack

Line Weight 1

Background Opaque

Show Border

Leader/Border Offset 5/64"

Leader Arrowhead Arrow 30 Degree

Text A

Text Font Arial

Text Size 1/4"

Tab 5ize 12"

Bold

Italic

Underline

Width Factor 1000000

Figure 1-20
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Creating Custom Templates

5. Click if you want to create another type.
6. Click twice if you are finished.

Dimensions Dimensions are one of the more complex system families in
terms of the number of parameters you can modify. You can
create types for each dimension method.

How to: Create Dimension Types
1. Inthe Annotate tab>Dimension panel, expand the Dimension

panel title (as shown in Figure 1-21), and click &7 next to
the dimension type you want to create.

m Architecture  Structure  Systems  Insert  Annotate  Analy

[y f "_" ﬁ (%, Radial AP Spot Elevation [

] ; ] @ Diameter . Spot Coordinate 1
Medify | Aligned Linear Angular
[ Arc Length ] Spot Slope £
Select -

Modi Linear Dimension Types
e ﬁ f’ Spot Elevation Types —

f’ Spot Coordinate Types
f’ Spot Slope Types

Properties f’ Angular Dimension Types
f’ Radial Dimension Types

f’ Diameter Dimension Types

|-[H Dirmension
Mew Walls vl EdltT}"pE |
Figure 1-21

2. In the Type Properties dialog box, click [ Dupleate... | to

create a new type.
3. Modify the parameters as needed for the new type.

4. Click when you are finished.

© 2013, ASCENT - Center for Technical Knowledge® 1-15
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Dimension Type Options

The dimension type parameters include the Graphics of the
dimension (such as Tick Mark and Line Weight), as shown in
Figure 1-22, for Linear dimensions, and the Text formatting
(scroll down in the Type Parameter dialog box to view).

Values for parameters Y =2
(such as text size,
. . . Family: |System Family: Linear Dimension Style |
witness line extension,
etc) are the actual ,D/Ot Type: |Diagonal-3,f32‘ Arial - Line Leader - Inli v| | Duplicate. .. |
size for these elements. Rename...
The view scale controls Type Parameters
how large they are in Parameter Value | -
i [ Graphics 2

the sPeCIﬂC view. Dimension String Type Continuous

Leader Type Line

Shoulder Length 14"

Leader Tick Mark Maone E

Show Leader When Text Mowves

Away From Origin

Tick Mark

Diagonal 3/64"

Line Weight

1

Tick Mark Line Weight

5

Dimension Line Extension

Flipped Dimension Line Extensio {3,

332"

Witness Line Control

Witness Line Length

Gap to Element

1/16"

Witness Line Gap to Element

‘Witness Line Extension 332"
Centerline Symbol MNone
Centerline Pattern Solid
Centerline Tick Mark Default

Interior Tick Mark

Diagonal 3/64"

AR

] | Cancel

Figure 1-22

B For Linear dimensions, you can specify a Leader Type,
Shoulder Length, Leader Tick Mark, and Show Leader When
Text Moves that is used when the text is pulled away from the
dimension string. You can also specify the text inserted for
Equality Text (the default is still EQ).

B You can specify a Text Background option. If you set the
value to opaque, it automatically masks any elements behind
the text. If it is set to transparent, anything the text overlaps
is still visible.

B If you are dimensioning doors and windows by their widths
rather than their centers, you can also have the opening
height displayed with the dimension. Select the Show
Opening Height option.

© 2013, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

Arrowheads A variety of arrowhead types are supplied with the Autodesk
Revit software, including open and filled arrow styles, tick marks,
and dots. You can also create custom styles by duplicating an
existing style and defining the parameters, such as the Arrow
Style shown in Figure 1-23. In the Manage tab>Settings panel,

5 —
expand 9 (Additional Settings) and click = (Arrowheads) to
open the dialog box.

Type Parameters
Parameter Value

Graphics ]
Arrow Style Arrow

Fill Tick

Arrow Width Angle 30.000°

Tick Size 1/8"

Heavy End Pen Weight 7

Figure 1-23
B Arrowheads are used by both text (with a leader) and
dimensions.

B The MEP templates include loop leaders that can be set as
Tick Mark for dimensions and Leader Arrowhead for text, as
shown in Figure 1-24. You can also create an Arrow Style
using Loop in the Arrowhead settings.

ALL-THREAD
WITH ISOLATORS

Figure 1-24

Callout, Callout, Elevation, and Section tags can be modified to suit an
. office standard. In the Manage tab>Settings panel, expand
Elevation, and

Section Tags (Additional Settings) and click (Callout), (Elevation),

or Q (Section). Then, in the Type Properties dialog box,
duplicate an existing tag and make changes to the type
parameters.

© 2013, ASCENT - Center for Technical Knowledge® 1-17
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The Callout Tags parameters specify a Callout Head and the
Corner Radius of the callout box, as shown in Figure 1-25.

Type Parameters
Parameter | YValue |
Graphics ]
Callout Head Callout Head
Corner Radius 1/8"

Figure 1-25

The Elevation Tags parameter is the Elevation Mark. You can
select from a variety of types that come with the Autodesk Revit
software, as shown in Figure 1-26. For example, you might want
to set the exterior elevation mark to display a square body and
the detail number on the sheet where it is placed.

Type Parameters
Parameter | Value |
Graphics 2
Elevation Mark ark Body_Square : Detail Numhel

Elevation Mark Body_Circle: Filled Arrow -
Elevation Mark Body_Circle : Filled Arrow and View Name

_Square : Detail Number
Elevation Mark Body_Square : Detail Murmber and View Name | =
Elevation Mark Body_Square: Filled Arrow
Elevation Mark Body_Square : Filled Arrow and View Mame

Figure 1-26

The Section Tags parameters include both the Section Head
and Section Tail, as well as the Broken Section Display Style, as
shown in Figure 1-27.

Type Parameters
Parameter YValue
Graphics ]
Section Head Section Head - Filled
Section Tail Section Tail - Filled : 3/32" x 3/8"
Broken Section Display Style Gapped
Figure 1-27

© 2013, ASCENT - Center for Technical Knowledge®
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B Once you set up these tags, you can connect them with the
<&
tag types used in - (Callout), @ (Elevation), and

]
Q (Section). In Properties, click (Edit Type) and set up
the type parameters, as shown for a Building Elevation in
Figure 1-28.

Type Properties @

Family: |System Family: Elevation b | Load...

Type: |Building Elevation - | | Duplicate... |

Rename...

Type Parameters

Parameter Value |
Graphics H
Elevation Tag 1/2" Square
Callout Tag Callout Head w 1/8" Corner Radi
Reference Label Sim

Figure 1-28

Loaded Tags You can load tags, such as door, window, and wall tags (as

shown in Figure 1-29), into a project template. Having the
specific tags required for your projects increases adherence to
company standards.

1R
Sy = %
<B> || stair1

[T1]

Conference UP .
| == )
3
=
—_
I
Figure 1-29
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Tags are created as separate family files (RFA) and stored in the
Library. In the Tags dialog box, as shown in Figure 1-30, you can
easily load the tags you need from the Library into the project
template Therefore, when you start the Tag command, the one
you need is available.

Tags @

Select an available Tag Family for each Family Category listed

Mote: Multi-Category Tag Families are not shown below.

Category Loaded Tags o Load...

Areas Area Tag

Casework Mo Tag Loaded E
Ceilings Mo Tag Loaded

Curtain Panels Mo Tag Loaded

Detail Iterns Mo Tag Loaded

Doors Door Tag

Electrical Equipment Mo Tag Loaded

Electrical Fixtures Mo Tag Loaded

Floors Mo Tag Loaded

Furniture Mo Tag Loaded

Furniture Systems Mo Tag Loaded

Generic Models Mo Tag Loaded 18

[7] show categories from all disdplines

[ oK ] [ Cancel ] I Help

Figure 1-30

How to: Specify Loaded Tags
1. In the Annotate tab>Tag panel, expand the panel title and

click i (Loaded Tags).

Load Family... I

In the Tags dialog box, click I
In the Library, open the Annotations folder.

4. Select the required tags and click . Hold down

<Ctrl> to select multiple tags.
5. When you have loaded all of the tags that you typically need

for a project, click .

w N
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Practice 1a

LY{.SILY

Estimated time for
completion: 15 minutes

Preparing Templates

Learning Objectives

Create a new project template file and specify the units and
levels.

0/ Setup text and dimension types and also load tags.

In this practice you will create a new project template file, modify
the units, snaps, temporary dimensions, and add several new
levels. You will create several text types, add a dimension style
that uses arrows (as shown in Figure 1-31), and load typical
tags into the project template file.

1/8" Arial 1/8" Hand

332" Avial 3/32" Hand

1/4 “Title 140"
Figure 1-31

Task 1 - Establish a project template file.

1. In the Application Menu, expand 3 (New) and click
Ind (Project).

2. Inthe New Project dialog box, select an existing template file

and Project template and click .

3. In the Quick Access Toolbar, click =1 (Save) and save the
template in your class directory as Midrise-Template.rte.

4. Inthe Manage tab>Settings panel, click (Project Units)
or type UN.

© 2013, ASCENT - Center for Technical Knowledge® 1-21
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5. In the Project Units dialog box, set the Length formats as

follows:
Length:
Units Feet and Fractional Inches
Rounding To the nearest 1/16"

Suppress 0 feet Check

Angle:

Rounding 0 decimal places

Click to close the Units dialog box.

Set the Snaps and Temporary Dimensions as needed.

Open an elevation view.

© © N O

Change Level 2 to 16’-0". Add three more levels above the
current levels at 12’-0” apart. Add two levels below Level 1
and set them 10°-0” apart. Rename them as Basement 1
and Basement 2, as shown in Figure 1-32.

Levels: Level : Level 1

Figure 1-32

B If you draw the levels using (Level), you can select
the Make Plan View option in the Options Bar to create

the associated views.

B |f you copy the existing levels, you need to create the plan
views and ceiling plan views. In the View tab>Create

panel, expand =) (Plan Views) and click (Floor Plan),
(Structural Plan), and/or s (Reflected Ceiling Plan).
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match the other levels in the HVAC sub-discipline (3 -
Mech, 4 - Mech, etc) and expand the ??? node and select
all of the new ceiling plans. In Properties, change the
Sub-Discipline to HVAC.

E B Rename above ground levels and corresponding views to

10. Switch back to the original plan view and save the project
template.

Task 2 - Preset annotation types.

1. Create the following text types:

1/8” Arial Use the default, but set the Height to 1/8”.

1/8” Hand Use a hand-lettering Font, such as Comic Sans MS, and
select /talic.

3/32” Hand | Same as above with a Height of 3/32”.

1/4” Title Use the font of your choice, in bold.

1" Title Duplicate 1/4" Title and change the Height to 1"

2. Create or modify a Linear Dimension type and change the
Units Format Rounding to the nearest 1/8". Modify the
angular dimension type to use arrowheads. Modify other
parameters if required. You can create an additional arrow
type if time permits.

3. Load the following tags into the project template:

E Architectural ‘ Casework, furniture, and furniture systems
Civil ‘ Parking and planting
E Fire Protection | Sprinkler
Electrical Lighting fixture and panel name
E Architectural Wall and Floor
Structural Select any different Structural tags you might want to
use in place of those already loaded.

4. Save the project template.
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Labels and Revision
Schedules are

specifically used in title
blocks.

How to:

1.3 Creating Title Blocks

Learning Objectives

Create title blocks including detail lines, text, labels,
symbols, regions, and revision schedules.

0/ Create sheets and sheet list schedules.

0/ Preset a starting view.

Title blocks contain information about the company and
consultants designing the project, project information, and
sheet-specific information, as shown in Figure 1-33. This
information might include but is not limited to the following: the
project name, address, number, sheet number, revisions, and
other parameters. Some of these parameters never change,
some are project-specific, and some are sheet-specific.

e

=

5

e
§
i

i

iy i

Figure 1-33

B Create the title block by sketching detail lines and adding
text, symbols, and regions, as well as image files for
company logos. The variable information is stored in labels.

Create a Title Block

1. In the Application Menu, expand [ (New) and click
L= (Title Block).

1-24
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You can select from
several preset sizes or
create a custom size.

m Create  Insert  View Manage Add-Ins
VEEISHIN Al
Maodify Qgg Line gritua;'

Select ~ | Properties Detail

Adding Labels

How to:

2. In the New Title Block - Select Template File dialog box,

select a template file size from the list and click .

A new family file opens and the Family tools display in the
Ribbon, as shown in Figure 1-34.

Modify &

BEHTAROFAAY w '\ @F K&

Symbol Masking Filled | Aligned Angular Radial Diarneter Arc Label Text Check Find/ Reference| Set Show | Loadinto
Regiocn Region Length Spelling Replace Line Project

Dimension ~ Text 3| Datum Work Plane | Family Editor
Figure 1-34

B If you select a template with a standard size, a rectangle
of that size displays in the view.

B If you select New Size, a rectangle with dimensions
displays. Edit the dimensions to modify the size.

3. Add lines, filled regions, symbols, text, labels, etc., as
needed.
4. Save the file and close it.

B You can use dimensions to help place the elements in the title
block family, they are not displayed when the title block is
inserted.

Labels are not just text but elements that are assigned to specific
parameters and can be added to title blocks or tags. They can
change without modifying the rest of the elements. For example,
you would use annotation text for the words Drawn By: and a
label for the initials of the person who did the work (by default
displaying DRW in Figure 1-35), because that varies from sheet
to sheet.

DRAWN BY: D RW

Figure 1-35

B The title block template comes with one text type and one
label type already defined. You can create additional types in
Properties by duplicating types. The Text and Label
parameters are similar, but you must create separate types
for each of them.

Create a Label
1. In the Family Editor, in the Create tab>Text panel, click

A (Label).
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2. In the Modify | Place Label tab>Format panel, specify the
alignments: Left, Center, Right, Top, Center Middle, or
Bottom, as shown in Figure 1-36.

(B Create Vinsert | Wiew ' "Manage | Add-ins | Modify | Place Label [NC=)"

[l 0O [ P =h o = =

o e HL San- 5 |3 & DQ‘DDTSE' === 1

Modify |[THI M loin ~ N e == oohb f = Load into

H Hy g G % o NEEES ' = = Poea
Select | Properties | Clipboard | Geometry [ Modify | Measure | Create | Format | Family Editor |

Figure 1-36
3. Click in the view window to place the label, as shown in
Figure 1-37.

R A

Figure 1-37
4. In the Edit Label dialog box shown in Figure 1-38, select a
label in the Category Parameters list and double-click or click

> (Add parameter(s) to label). You can select more than
one by holding down <Citrl>.

Edit Label -5 |l
Select parameters to add to the label. Parameters will be combined into a single label.
Enter sample values to represent this label in the family environment. [~ Wrap between parameters only
Category Parameters Label Parameters
Appraved By - Parameter Mame Sample Value
Checked B - | ; —
— Clent Neme R Ciient Name
Current Revision
Current Revision Date E
Current Revision Description

Current Revision Issued
Current Revision Issued By
Current Revision Issued To
Date/Time Stamp

Designed By

Drawn By

File Path

Project Address

Project Issue Date

Project Name

Project Number
Droviert Sahia

[l

m

[ ok || cameel || apply

Figure 1-38

5. Enter the Sample Value and specify any other options as
needed.

B If you are using several parameters in one label, select
Wrap between parameters only and Break (in column)
options to separate them while still permitting a word
wrap.
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Adding
Revision
Schedules

How to:

L
m Click O (Add Parameter) to create a new parameter for
the project.

m Click ft (Move parameter up) and A& (Move
parameter down) to reorder multiple parameters.

i)
B If you select a numerical parameter, click *  (Edit
parameter’s units format) to change, if necessary.

6. Click when you have finished editing the label.

7. Rotate or stretch the label as needed (as shown in
Figure 1-39), or select a point for an additional label.

2
+DRW o

Figure 1-39

8. Click & (Modify) or press <Esc> twice to finish the
command.

A table of revisions included in a project and/or sheet is typically
added to a company title block, as shown in Figure 1-40. In the
Autodesk Revit software, you can create a Revision Schedule
that is then linked to the Revision Table in the project.

Mo, Description Date

Figure 1-40

Add Revision Schedules to Title Blocks
1. In the Family Editor, in the View tab>Create panel, click

‘e (Revision Schedule).
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2. In the Revision Properties dialog box, select the fields you
want to use. Several are already selected for you, as shown
in Figure 1-41.

Revision Properties @
Fields |50rh’nngrouping I Formatting I Appearance|
Available fields: Scheduled fields (in order):
Add —> Revision Sequence
Issued to — Revision Number
Select available fields from:
Revision - Mave Up Mawve Down
Include elements in linked files
[ (0]4 ] ’ Cancel ] [ Help ]
Figure 1-41

3. Modify the options in the Sorting/Grouping and Formatting
tabs as needed.

4. Inthe Appearance tab, select how you want to build the
schedule: from the Top-down or Bottom-up. You can also
set the Height to Variable or User-Defined.

5. Click . The schedule view displays.

6. Inthe Project Browser, open the Sheet view (it has no name).

7. Drag and drop the schedule onto the sheet and modify the
controls, as shown in Figure 1-42.

If the height is set to
User-Defined, an Revision Schedule
additional control is Revision
displayed at the bottom Number Revision Description Revision Date
of the schedule. Use it
to set the height of the
schedule.
Figure 1-42

B In the Options Bar, you can change the Rotation on the Sheet
to None, 90° Clockwise, or 90° Counterclockwise.
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Add|ng Sheets You can set up project templates using the custom title block in

two ways. Add all or most of the sheets typically needed for a

to Project | roject, or create a Sheet List Schedule that can be used to
Templates automatically create sheets when they are needed.

In most cases, it is best to create sheets that are always used in
projects in the template and even put typical views on them, as
shown in Figure 1—43. Note that the view is empty in the
template, but as you draw elements in the project they
automatically display in the view and on the sheet.

Autodesk Revit

Q ———

sy g A A i

|

T T T

mmmmmmmmm

nnnnnnn

Figure 1-43

How to: Load a Title Block into a Project Template

1.
2.

Open the project template.
Return to the custom title block family. In the Family Editor

panel, click L) (Load into Project).
In the Load into Projects dialog box, select the project you

want the title block loaded into and click |L|. If only
one project is open, it is loaded into the project automatically.

. The title block is now available when you create a sheet.

If the title block family is not open, select Insert tab>Load

from Library panel and click E (Load Family) to access it, or

Load...

click | | in the New Sheet dialog box.
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How to:

B When you save a title block, it should be on the network

where everyone
someone reinsta

has access to it. That way, it is not deleted if
lls the Autodesk Revit software. Set the

default location for the family template files in the Options
dialog box, in the File Locations tab, as shown in

Figure 1-44.

Options

==

General
User Interface

Graphics

File Locations
Rendering
Check Spelling
SteeringWheels
ViewCube

Macros

Project template files: The first five project templates will appear as links on the
Recent Files page.

Name Path
Construction Tem... | C\ProgramData’\Autodesk\RVT 2014\ Tem...
Architectural Tem... | C:\ProgramData\Autodesk\RVT 2014\Tem...
= Structural Template | C:\ProgramData‘\Autodesk\RVT 2014\Tem...
Mechanical Templ...! C\ProgramData\Autodesk\RVT 2014\Tem...

Default path for user files:
C:\Users\uzer\Documents

Browse...
Default path for family template flles:
C:\ProgramData'\Autodesk\RVT 2014\Family Templates\English_

Figure 1-44

Create a Sheet List Schedule
1. Open a project template file (or a project).

2. In the View tab>Create panel, expand = (Schedules) and

click = (Sheet
3. In the Sheet List
select the Sheet

List).
Properties dialog box, in the Fields tab,
Number and Sheet Name and add them to

the Scheduled fields list as shown in Figure 1-45.

Sheet List Properties

[EX

Fields |Fi|ter | Sorting/Grouping I Formatting I Appearance‘

Available fields:

Scheduled fields (in arder):

Checked By

Count

Current Revision
Current Revision Date

Current Revision Description
Current Revision Issued

Current Revision Issued By E
Current Revision Issued To

Designed By

Drawn By Add Parameter...
Guide Grid

Sheet Issue Date - Calculated Value. ..

J s T ——

Sheet Name

Select available fields from:

[Sheeis

= Move Up Move Down

[ 1ndude elements in

linked files

[ QK ][ Cancel ][ Help ]

4. Depending on th
you can also mo
tabs.

Figure 1-45

e complexity of your sheet naming scheme,
dify items on the Filter and Sorting/Grouping
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Click lLl when you are finished.

5.
6. You are placed in the schedule view with the two parameters
displayed. Stretch out the columns as shown in Figure 1-46.
If sheets are already in Sheet List
the project, they display Sheet Number | Sheet Name
here. .
Figure 1-46
7. In the Modify Schedule/Quantities tab>Rows panel, expand
o 8 -
(Insert) and click (Data Row) as shown in
Figure 1-47.
] Sheets M 5| X - o) 3t Insert -
= £ ¢ I8
; eet Mame = . . ™ AL e Calar
Properties Calculated | Insert Delete Resize Hide Above Selected
Properties Parameters Colurmns = Below Selected ]
Modify Schedule/Quantities
P rti b4 Ly Data Row ul
i =Sheet List= :j s
A B
Sheet Name Sheet Number
Figure 1-47

Sheet lists are often
used by architects to
display all of the sheets
in a building project
including consultant
sheets that are not in
the Autodesk Revit
project file. In that case,
they would only be in
the Sheet List schedule
and not created as
actual sheets.

8.

9.

A new row is added below the schedule names. If no sheets
are in the project, it comes in automatically as A101 and
Unnamed.

Add as many rows as you have sheets. If you are using a
numbering scheme such as A1xx for site plans, A2xx for
Floor Plans, A3xx for Detail plans, etc., then you should
rename the sheet number for the first row of a set before
creating more rows so that they increment automatically.

10. Enter the name of each sheet. Once you have added a new

name, it is available in the drop-down list, as shown in
Figure 1-48.

<Sheet List=
A B
Sheet Number Sheet Name
C3000 Cover Sheet
A2 First Floor Plan
A202 Second Fioor Plan] 13
AZ03 Fifth Floor Plan
AZ04 First Fleor Plan
205 Fouth Floor Plan
H Second Floo F
i‘fg?< Site Plan T
: Sith Floor Plan
Third Floor Plan &2
Figure 1-48
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How to: Use Sheet List Tables

1. Create a new sheet. In the Sheet List Schedule view, in the

Modify Schedule/Quantities tab>Create panel, click i (New
Sheet), You can also access the command on the View tab or
right-click on Sheets in the Project Browser.

2. Inthe New Sheet dialog box, select the placeholder sheets
you want to use, as shown in Figure 1-49. To select more
than one, hold down <Ctrl> or <Shift> as you select.

5| Mew Sheet 5
Select tileblocks:

E1 30 x 42 Horizontal : E1 30x42 Horizontal

Mong

Select placeholder sheets:

Mew e
A102 - Site Plan

AZ201 - Floor Plan

AZ202 - Floor Plan

AZ203 - Floor Plan

A204 - Floor Plan c
A301 - Elevations 1
A302 - Elevations

A3J03 - Elevations

A304 - Elevations

A401 - Sections

A402 - Sections B
A403 - Sections il
A4NA - Sartinne

[ OK l ’ Cancel
Figure 1-49

3. Click . The new sheets are created in the project.

B This sheet list is available in all projects based on the project
template where it was created.

B You can import the sheet list schedule into another project,
but it does not import the associated sheets. That is because
they are part of the project, not the schedule view.
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Practice 1b Creating Title Blocks

Learning Objectives

create a sheet list.

Setup sheets in the template using the new title block and

Draw a custom title block including detail lines, text, labels,
and a revision table.

In this practice you will create a new title block by adding lines,
m m m text, labels, logo, and a Revision Schedule similar to

EStlmate.d time fOf Rewvizion Schedule
completion: 15 minutes Revision Revision Revision
Mumber Description Date

First Floor Plan

Project Name

Enter addregs here

Site, Inc.

owa

legue Date

THaiEct Number

Orwan Sy

Author

Shast Mum e

A201

Figure 1-50

Figure 1-50. You will then load it into a project template file and
create several standard sheets as well as a Sheet List Schedule.

Task 1 - Create a title block.

L= (Title Block).

1. In the Application Menu, expand [ (New) and click

© 2013, ASCENT - Center for Technical Knowledge®
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2. In the New Title Block - Select Template File dialog box,

select D 22 x34 Horizontal.rft and click |Qp$|.

3. In the Create tab>Detail panel, click AN (Line) and create
lines on the inside of the existing rectangle 1/4" away from
the top, bottom, and right sides. Draw a line 1" away on the
left margin. Trim the lines as needed.

4. Draw lines in the lower right corner of the title block, as
shown in Figure 1-51.

1;‘2"

1II

11/72"

174"

X

i\

\

Sy

o)

112" 112" L —1/4"
Figure 1-51

5. In the Create tab>Text panel, click A (Text).

6. In Properties, click and create the following Text types:

Type Name Font Size Bold Background
Arial 1/16" Arial 1/16" No Transparent
Title Comic Sans 1" Yes Transparent
Logo Your choice 1/4" Yes Transparent

7. In the Create tab>Text panel, click l\ (Label).

]
8. In Properties, click (Edit Type) and create the following

Label types:
Type Name Font Size Bold Background
Arial 1/8” Arial 1/8” No Transparent
Arial 1/4” Arial 1/4" No Transparent

1-34
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9. Create a graphic and company name of your own design in
the lower left box, for example with Site, Inc. as shown in
Figure 1-52. Using the following steps, add text, labels, and
graphics to the title block.

Sheet Name

Project Name

Project Address

“Project Issue Date

""" Project Number
— Drawn By: DRW

Sheet Number:

A101

JepsontJohnson
Archilecls

Figure 1-52

B Use A (Text) with the text type Arial 1/16" to add text in
the lower right spaces for the Date, Project Number,
Drawn By, and Sheet Number.

B Use l\ (Label) with the label type Arial 1/4" and

(Align Center) justification to add the Sheet Name,
Project Name, and Sheet Number. Move and stretch the
labels to fit in the title block.

B Using the label type Arial 1/8" and (Align Center)
justification, add the Project Address below the Project
Name.

B Using the /abel type Arial 1/8" and (Align Right)
justification, add the Project Issue Date, Project Number,
and Drawn By.

B Add the Logo text in the box on the lower left side, shown
as Site, Inc. in the title block. Draw lines and add a filled
region for a graphic logo as needed.

10. Save the title block in your class directory with the name
TBLK-D.rfa.
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Task 2 - Add a Revision Schedule.

1. In the title block Family Editor, in the View tab>Create panel,
click Q:' (Revision Schedule).

2. In the Revision Properties dialog box, Fields tab, set up the
fields as shown in Figure 1-53.

Revision Properties @
Fields |SorﬁngIGrouping I Formatting I Appearancel
Available fields: Scheduled fields (in order):
Issued by [ s>
Issued to = Revision Description
Revision 5eq £ | < Remove | Revision Date
Figure 1-53

3. Accept the defaults for the Sorting/Grouping and Formatting
tabs.

4. Select the Appearance tab and change the Height to User
defined.

5. Click %

6. In the Project Browser, expand Views (all) to display the
Schedules and Sheets (all) areas, as shown in Figure 1-54.
In the Sheets (all) area, open the - view.

Project Browser - TELK-D *

= :D: Wiews [all)
= Schedules
Revision Schedule

= Sheets (all)

5 Families
[®] Groups
& Revit Links

Figure 1-54

7. Drag and drop the Revision Schedule onto the sheet.
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8. Move it above the sheet name and resize it to display several
lines, as shown in Figure 1-55.

Revision Schedule
Revizion Revizion Rewision
Number Description Date

Sheet Name

Figure 1-55

9. Save and close the title block.

Task 3 - Set up sheets in a project template using the new
title block.

1. Open the project template Midrise-Template.rte that you
created in the previous practice. If you did not complete the
previous practice, open the template found in your class files
folder:

B /Architectural/Midrise-Template-A.rte
®m /MEP/Midrise-Template-MEP.rte
B /Structural/Midrise-Template-S.rte

2. In the View tab>Sheet Composition panel, click 3 (Sheet).

3. In the New Sheet dialog box, click .

4. In the Load Family dialog box, navigate to your class files
folder, select TBLK-D.rfa (that you just created), and click

[ ] ifyou did not complete the previous task, open

the title block found in your class files folder:

B /Architectural/TBLK-D-A.rte
m /MEP/TBLK-D-MEP.rte
B /Structural/TBLK-D-S.rte

5. Select the title block that you just loaded and click .
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6. In the Project Browser, select the sheet and rename it as
CS000 — Cover Sheet.

7. Using the Title text type, add placeholder text for the project
name and address, as shown in Figure 1-56.

Project Name

Project Address
City, State, Zip

Figure 1-56

8. In the Manage tab>Manage Project panel, click & (Starting
View).

9. In the Starting View dialog box, select Sheet: CS000 - Cover
Sheet as shown in Figure 1-57.

Starting View B[]
Select a starting view, which will be the default view when Revit opens
the model.

If worksets are enabled, once you save this setting to the central model,
it will be shared by all local models after Synchronize with Central.

Sheet: CS000 - Cover Sheet -

[ oK ] | Cancel |

Figure 1-57

10. Create another sheet with the new title block and name it
according to your discipline:

A201 — First Floor Plan

M201 - First Floor Plan Mechanical
E201 - First Floor Plan Electrical
P201 - First Floor Plan Plumbing
S201 - First Floor Plan Structural

1-38

© 2013, ASCENT - Center for Technical Knowledge®



Creating Custom Templates

11. Open this sheet view. Drag the associated Level 1 floor plan
view onto the sheet, as shown in Figure 1-58.

No elements are on the
view, but it acts as a .
placeholder on the
sheet. Elements are
displayed as they are
drawn.

&y

Figure 1-58

Task 4 - Create a Sheet List.

1. In the View tab>Create panel, expand = (Schedules) and
click L& (Sheet List).

2. In the Sheet List Properties dialog box, in the Fields tab,
select the Sheet Number and Sheet Name and add them to
the Scheduled fields list, as shown in Figure 1-59.

Sheet List Properties @

Fields |Fi|ter | Sorting/Grouping I Formatting I Appearance‘

Available fields: Scheduled fields (in order):
Checked By O e
Count Sheet Name
Current Revision Date SoRewove
Current Revision Description
Current Revision Issued
Current Revision Issued By =
Current Revision Issued To
Designed By
Drawn By Add Parameter...

Guide Grid
Sheet Tssue Date - Calculated Value. ..

Select avallable fields from:

[T itndude elements in linked files

[ oK ][ Cancel ][ Help ]

Figure 1-59

3. Click L% |
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4. The Sheet List schedule opens with the two existing sheets
listed. Stretch out the columns, as shown for an architectural
project in Figure 1-60.

=<Sheet List>
A B
Sheet Number Sheet Name
Cs000 Cover Sheet
A2 First Floor Plan
Figure 1-60

5. In the Modify Schedule/Quantities tab>Rows panel, expand
" (Insert) and click " (New).

6. Add floor plans to match the levels, as shown for an
architectural project in Figure 1-61.

<Sheet List=
A B
Sheet Number Sheet Name
CS000 Cover Sheet
A201 First Floor Plan
A202 Second Floor Plan
A203 Third Floor Plan
A204 Fouth Floar Plan
A205 Fifth Floor Plan
A206 Sixth Floor Plan
Figure 1-61

7. In the Modify Schedule/Quantities tab>Create panel, click

5 (New Sheet). The list displays the plans you added to the
Sheet List display, but the sheets already in the project do
not, as shown in Figure 1-62.

Select placeholder sheets:

A202 - Second Floor Plan
A203 - Third Floor Plan
A204 - Fourth Floer Plan
A205 - Fifth Floar Plan
A206 - Sixth Floor Plan

[ OK ] ’ Cancel

Figure 1-62
8. Close the dialog box.
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9. Open the Cover Sheet.

10.Drag and drop the Sheet List schedule, as shown in
Figure 1-63, onto the sheet.

Sheet List

Sheet

Mumber Sheet Mame
Al01 Site Plan
vy 1=t Floor Plan
P02 2nd Floor Plan
ik 3rd Floor Plan
i dth Floor Plan
ik Sth Floor Plan
cooo Cower Sheet

Figure 1-63

11. Add another sheet or two that are not on the sheet list.

12.Return to the Cover Sheet. The new sheets are added to the
sheet list as shown in Figure 1-64.

Sheet List
Sheet
Mumber Sheet Mame
Al01 Site Plan
vy 1=t Floor Plan
P02 2nd Floor Plan
ik 3rd Floor Plan
i dth Floor Plan
ik Sth Floor Plan
cooo Cower Sheet
5201 Structural Plan
hi2 02 hizchanical Plan
Figure 1-64

13.1f time permits, create additional sheets for various other
views.

14.Save the project template.
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1.4 View Templates

Learning Objectives

0/ Apply and set view templates to views.

0/ Create view templates.

Setup Visibility/Graphic override filters for various categories
of elements.

View templates enable you to specify all of the view properties
and visibility options for a view by selecting another view or a
view template as a base. For example, you can create a furniture
plan view template that sets the scale, detail level, and visibility
of objects so that everything except the furniture displays in
halftone, as shown in Figure 1-65.

] —
L

-
]
Figure 1-65

View templates can be applied to specific views when you create
a project template file and as you work in a project. You can also
specify a view template in view properties that restricts you from
making changes, such as the Detail Level shown in Figure 1-66.
This is useful for views that have been setup for printing.

Coarse
Medium
Fine
O "% = R E e 9 @
Figure 1-66
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App|y|ng View | There are two typical ways to use view templates. The first is
while you are working to display different view parameters in the
Templates | same view. For example, you might want to display the spaces in
a section and use a view template to switch to the mechanical
layout in the same section, as shown in Figure 1-67. You can
continue to make changes to the views even after the view
template has been applied. The other way is to preset a view
using a default view template so you cannot make changes to it.

Figure 1-67

How to: Apply a Temporary View Template Override

1. Select one or more views in the Project Browser. (Hold down
<Ctrl> or <Shift> to select multiple views.)

2. Right-click in the Project Browser and select Apply Template
Properties, or on the View tab>Graphics panel, expand

B 4.3
5 (View Template) and click (Apply Template
Properties to Current View).
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3. In the Apply View Template dialog box, select the view
template you want to use from the Names list, as shown in
Figure 1-68. Several standard view templates are available
when you create a project using one of the Autodesk Revit
project templates.
5| Apply View Template @
View Templates View Properties
Discipline filter: Number of views with this template assigned: 0
[<a||> "] Parameter Value Include |T
. Display Model Normal
View type fiter: Detail Level Coarse N
|Floor, Structural, AreaPlans  ~| Parts Visibility Show Original
Mames: V/G Overrides Model | Edit...
V/G Overrides Annotati | Edit...
Blectrical Plan V/G Overrides Analytic | Edit... B
;’}E:bfi‘gggll:f” V/G Overrideslrtnpnrt [ Edit... 1
V/G Overrides Filters | Edit... l:}
Model Display [ Edit...
Shadows [ Edit...
Lighting [ Edit...
Photographic Exposure | Edit... n
Underlay Qrientation : Plan [F]
View Range [ Edit...
Orientation Project North
o Phase Filter Show All
l'_D Ij DShOW WEE Micrinline Architertiral =] |v
[ 0K ] ’ Cancel ] [Apply Properﬁesl [ Help ]
Figure 1-68
4. If you do not want the entire view template to be applied to
the selected view, clear the check mark in the Include column
for the parameters you do not want to include. You can also
create overrides to the view template by changing parameter
values.
5. Click to finish.
B To limit the number of view templates that display, filter the

list by selecting an option in the Discipline filter and View type
filter drop-down lists, as shown in Figure 1-69.

Discipline filter: View type filter:
<all= - [Floor, Structural, Area Plans 1:]@
<all=
Architectural 3D Views, Walkthroughs
Ceiling Plans
azi:;ri?; Elevations, Sections, Detail Views
Electrical Floor Structural, Area Flans

Plumbing
Coordination

Figure 1-69
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B You can apply view templates to any view as many times as
needed only if it is not set as the default template in the view
properties.

How to: Set the Default View Template for a View

1. Select one or more views in the Project Browser. (Hold down
<Ctrl> or <Shift> to select multiple views.)

2. In Properties, in the Identity Data section, click the button
next to View Template, as shown in Figure 1—-70. The name
on the button varies according to any template that has
already been applied.

L)

b

Identity Data
View Template [ <Mone>

Yiew Mame Level 2

Dependency Independent
Figure 1-70
3. Inthe Apply View Template dialog box, select the appropriate

template and click .

4. The view is now locked using the parameters setup in the
view template.

B View Templates can also be set by the type properties of a
view. For example, in a view’s Type Properties, duplicate a
view type, such as Space Plan shown in Figure 1-71. Apply
the appropriate template and select New views are
dependent on template.

Type Properties @
Farmily: [System Family: Floar Flan V] Load...
Type: |space Plan -] | Duplicate... |

Floaor Plan
S — | Reanc.. ]

Type Parameters

Parameter | Value |
Graphics ]
Callout Tag Callout Head w 1/8" Corner Radiu
Reference Label Sirmn
Identity Data 2
View Template applied to new views | Space Plan
Mew views are dependent on templa

Figure 1-71
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B When you use the View type, the view modifies to match the
view template and is also placed in its own group in the
Project Browser, as shown in Figure 1-72.

Midrise-Template-A-M - Project Browser ]
=0 Views (all)
+- Floor Plans
=8 Floor Plans (Space Plan)
Basement 1
Level 1- Spaces

+-- Ceiling Plans

Figure 1-72

Creating View Many view templates come with the Autodesk Revit software,

but you might need to create your own custom view types that
Templates are best applied by view template. You can create a view
template from the view settings in an existing view or through the
View Template dialog box.

How to: Create a View Template from an Existing View

1. Set up a view the way you want it with Scale, Detail Level,
Visibility Graphic Overrides, and other View Settings.

2. In the Project Browser, right-click on the view and select
Create View Template from View or, on the View tab>

5
Graphics panel, expand [:q (View Template) and click

£1]

-

5 (Create Template from Current View).

3. Inthe New View Template dialog box, type a name for the
view template.

Click L% |

In the View Template dialog box, make other adjustments as

needed and click lLl.

o~

How to: Create a View Template

o
1. Inthe View tab>Graphics panel, expand 5 (View Template)

and click & (Manage View Templates).
2. In the Apply View Template dialog box, in the Names list,
select a view similar to the one you want to create and click

™ (Duplicate).
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3. In the New View Template dialog box, type a new name for

the view template and click .

4. Select the new view template as shown in Figure 1-73, and
modify the View Properties parameter values as needed.

m_] Apply View Template

=X

D x|j [T show views

View Templates View Properties
Discipline filter: MNumber of views with this template assigned: 0
[<all> '] Parameter Value Include B
. Display Model MNermal
View type fiter: Detail Level Coarse
|Floor, Structural, Area Plans 7] Parts Visibility Show Original
Names: V/G Overrides Model | Edit...
Architectural Plan V/G Overrides Annotati | Edit...
Electrical Plan V/G Owerrides Analytic | Edit...
Eﬁﬂhﬁgicgll:fn V/G Overrides Import | Edit... =
= V/G Overrides Filters | Edit...
Structural Plan Model Display [ Edit...
Shadows [ Edit...
Lighting [ Edit...
Photographic Exposure || Edit... 0
Underlay Orientation  : Plan [
View Range [ Edit...
Orientation Project North
Phase Filter Show All
[e7]

Mizrinline

Architectiral

CK ] [ Cancel

] [Apply Properties] [

Help

)

Figure 1-73

5. Click to finish.

B Not all view types have the same view parameters. For
example, 3D views have options for Rendering and
Perspectives that plans do not have. When you apply a view
template across view types, only the options that are mutual
are updated.

B If you want to start a new view template based on an existing
view, select Show Views. The Names list expands to include
all of the related views in the project.
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Visibility/
Graphic
Overrides
Filters

B One of the parameters in views is the Detail Level. There are
three options: Coarse, Medium, and Fine. You can modify
the table of scales that are related to the levels. In the

<
Manage tab>Project Settings panel, expand 9 (Additional
Settings) and select Detail Level. The View scale-to-detalil
level correspondence dialog box opens, as shown in

Figure 1-74.
View scale-to-detail level correspondence @
|Use this table to contral the detail level used for new views by scale,
Coarse Medium Fine
1" = 400'-0 o] | 33" =10 s] [ 112 =10
1" = 300'0 /2" =10 3" =10
1" = 200'0 1| 34" =10 — 1le" =140
1" = 160'0 s 1" =10 s 12" =10
1" = 100'0
1" = 80'-0
1fa4" = 10
Figure 1-74

B The only parameter saved to a view template for schedule
views is the appearance of the schedule.

Visibility/Graphic Overrides filters can speed up the process of
specifying categories that are modified in View Templates. Any
view has is a filter for modifying the visibility of graphics by
element type. You might want to display certain elements in
halftone, or with a different color or lineweight in specific views.
For example, a fire evacuation plan might have walls with
different fire ratings that display with thicker lineweights, as
shown in Figure 1-75. By creating these filters and then applying
them in a view template, you can reuse them without having to
recreate them each time.

—

= il

Figure 1-75
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How to:

If you are using the
non-discipline specific
version of the Autodesk
Revit software, an
additional Filters dialog
box opens in which you
can create new filters,
edit, rename, or delete
them without having to
open the full Filters
dialog box.

Create Filters

1. Inthe View tab>Graphics panel, click = (Filters). The Filters

dialog box opens as shown in Figure 1-76.

Filters @
Filters Categories Filter Rules
- Select one or more categories to be . e —
m:z:::::: . ‘;I;tpfnr: induded in the filter. Pa?amebers Filter by: | System Classificaon  ~ I—I
Mechanical - Exhaust common to these _categnries will be |ccntains - |
available for defining filter rules.
Domestic
Saritary Filter list: - supply
Hydronic Hide un-checked categories ————————————————— —
Domestic Cold Water And: | (none) - I_I
Domestic Hot Water L1 Ar Terminals i
Interior O Areas =
Vert [J Callouts 3
[J Detail tems
Duct Accessories
Duct Fittings (none)
Duct Insulations
Duct Linings
[J Duct Placehclders -

[ Y

[ checkal | [ chedcnone |
[ OK. ] | Cancel Apply Help
Figure 1-76

In the Filters area, click [ (New) or N (Duplicate). Name

the new filter and click lLl.

In the Categories area, filter the list by discipline and then

select the categories to include in the filter. Use
and to help select the categories.

In the Filter Rules area, select what you what to Filter by, the
filter operator(s), and the value for the filter. If more than one
category is selected, the Filter by list is limited to parameters
shared by the categories you selected. You can create more
than one filter rule. They are applied in order. Set Filter by to
None if you do not want to filter by parameters. Filter
operators are shown in Figure 1-77.

Filter Rules

Filter by: \|=L.||-1r_ﬁm'1—v, B

equals vﬂ

quals
does not equal
is greater than
And: s greater than or equal to
- is less than
is less than or equal to

Figure 1-77

5. Click to save the changes and remain in the

dialog box, or click lLl to finish.
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How to: Apply Visibility/Graphic Overrides Filters

Figure 1-78.

1. Type VG or VV or in the View tab>Graphics panel, click

e (Visibility/Graphics) to open the Visibility/Graphic
Overrides dialog box. Select the Filters tab, as shown in

Visibility/Graphic Overrides for Floor Plan: Level 1

Mods| Categories I Annotation Categories I Analytical Model Categories I Imported Categories | Filters |

. Projection/Surface Cut
Mame Visibility - - Halftone
Lines ‘ Patterns | Transparen... Lines Patterns
Furmniture
Interior [m]

MName

Add ] [ Remove Up

All document filters are defined and

wn

Figure 1-78

Click to add a filter to the list.

In the Add Filters dialog box, select the filter(s) you want to

add and click .

B [f the filter you want is not defined, click [ ] to
open the Filters dialog box, where you can define a new
filter or edit an existing one.

In the Visibility/Graphic Overrides dialog box, assign the
overrides you want for the filter. For example, you might want
items to be Halftone, as shown in Figure 1-79.

Edit/Mew. ..

— Projection/Surface Cut
Visibility - - Halftone
Lines | Patterns | Transparen... Lines Patterns

Fumniture
Interior

]

Figure 1-79

5. Click %]
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Practice 1c

LSILY

Autodesk® Revit®
Architecture and

Autodesk® Revit®
Structure

Estimated time for
completion: 15 minutes

In the non-discipline
specific Autodesk Revit
software, an additional
Filters dialog box opens.

Click LM | ong
name the new filter.

Select Define Criteria

and click |L|.
This opens the full
Filters dialog box.

View Templates for Architectural
and Structural Projects

Learning Objectives

0/ Create visibility filters.

0/ Create a view template and apply it to several views.

In this practice you will create filters that you will use in a
structural view template, and apply the view template to several
structural plan views, as shown in Figure 1-80. When the filter is
working correctly you can add the same information to a project
template file.

v s g e e T v s

g,__{,#_,l:_fh___d.!_"i,_ .;}_4,_ S _;__4,__;__*_ _!h_lrh___ﬂ__j,_ ____ )

o {44 011 | e d b1 |

e el e e e e 2
. ' H: o0 T i

SR I LV NS S S R F Lok g
5 5 ) SEHETES b S

Figure 1-80

Task 1 - Create filters.

1. Open the project found in your class files folder:

B /Architectural/Office-A.rvt
B /Structural/Office-S.rvt

2. In the View tab>Graphics panel, click & (Filters).

3. In the Filters dialog box, click (i (New), name the new filter
All But Structural, and click L% |

4. Inthe Categories area, set the Filter list to Architecture and
Structure.

5. Click , and clear Columns, all categories starting
with Analytical, Structural, and Walls. Click .
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6. Click 1 (New). Name the new filter Non-Structural Walls

and click |L|.

7. In the Categories area, click and select Walls.

8. Inthe Filter Rules area, set Filter by to Structural Usage,
equals, and Non-bearing, as shown in Figure 1-81.

Filter Rules

Filter by: |S1Iuc1ura| Usage v| |_|
|equals v|
|Nnn—bearing v|

Figure 1-81

9. Click |L| to close the Filters dialog box.

Task 2 - Create a View Template.

1. In the Project Browser, in the Floor Plans area, right-click on
the Level 1 view and select Create View Template From
View.

2. Name the new view template Structural Plan and click

[ oo |

3. In the View Templates dialog box, set the View Scale to
1/16"=1’-0" and the Detail Level to Coarse.

4. Next to VIG Override Filters, click | Edit... I The
Visibility/Graphic Overrides dialog box opens with the Filter
tab selected.

5. Click 4]

6. Inthe Add Filters dialog box, select the two filters you just

created and click |L|.

7. Place a check mark in the Halftone column for both filters.
Continue working in the Visibility/Graphics Overrides dialog
box.

8. In the Annotation Categories tab, turn off everything except
Grids and all Structural annotations and tags.
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9.

In the Model Categories tab, turn off items, such as
Casework, Furniture, Furniture Systems and Plumbing,
and Mechanical equipment.

10.Click % | to close the Visibility/Graphic Overrides

0K

dialog box, and click | | to complete the view

template.

Task 3 - Apply a View Template to several views.

1.

In the Floor Plans area, use Duplicate with Detailing on the
Level 1, Level 2, Level 3, and Level 4 views. Rename them
as Structural — Level 1, Structural — Level 2, Structural —
Level 3, and Structural — Level 4.

Select the new Structural views.
Right-click and select Apply View Template.
In the Apply View Template dialog box, select the Structural

oK | to

Plan view template you just created and click |
apply it.

Look at the different views and compare them to the standard
floor plan views. Finish with the Level 1 view.

Save the project.
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Practice 1d

A

Autodesk Revit MEP only

Estimated time for
completion: 15 minutes

View Templates for MEP Projects

Learning Objectives

0/ Create visibility filters.

0/ Create a view template and apply it to several views.

In this practice you will create velocity based filters for ductwork
that you will use in a mechanical view template, and apply the
view template to a duplicated plan view, as shown in

Figure 1-82. When the filter is working correctly, you can add the
same information to a project template file.

Figure 1-82

Task 1 - Create filters.

1. Open the project /MEP/Office-MEP.rvt found in your class
files folder.

2. In the View tab>Graphics panel, click & (Filters).

3. If you are using the non-discipline specific version of the
Autodesk Revit software, an additional Filters dialog box

W

opens. Click |ME—| name the new filter, select Define

Criteria, and click |L|. This opens the full Filters
dialog box.
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4. If you are using the Autodesk Revit MEP software, in the
Filters dialog box, click [ (New), name the new filter
Mechanical - Low Velocity, and click Lo |

5. In the Categories area, set the Filter list to Mechanical.
Select Ducts and Flex Ducts.

6. Inthe Filter Rules area, set Filter by to Velocity, is less than
or equal to, and 900 FPM, as shown in Figure 1-83.

Filter Rules
Filter by: | Velocity =] o]
|is less than or equal to - |
900.00 FPM -

Figure 1-83

7. Click w and remain in the Filters dialog box.

8. Select the new Mechanical-Low Velocity filter and click
[N (Duplicate). Right-click on the duplicated filter and click
(Rename). In the Rename dialog box type
Mechanical-Medium/High Velocity and click lLl.

9. Inthe Filter Rules area, set Filter by to Velocity, is greater
than, and 1900 FPM, as shown in Figure 1-84.

Filter Rules
Filter by: | Velocity =] o]
|is greater than - |
900.00 FPM -

Figure 1-84

10.Click lLl twice to close the Filters dialog boxes.

Task 2 - Create a View Template.

1. In the Project Browser, in the Mechanical>Floor Plans area,
right-click on the 1 - Mech view and select Create View
Template From View.
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2.

8.

Name the new view template Velocity Duct Plan and click
Ok

Next to VIG Override Filters, click | Edit... I The
Visibility/Graphic Overrides dialog box opens with the Filter
tab selected.

Click L4 |

In the Add Filters dialog box, select the two filters you just

created and click lLl.

For the Mechanical-Low Velocity filter, in the
Projection/Surface>Lines column, select Override.

In the Line Graphics dialog box, change Weight to 6 and the
Color to an orange, as shown in Figure 1-85. Click lL.

Line Graphics @
Lines
Weight: 6 -
Color: [ res 255-125-064 |
Pattern: <No Override = - \:l
Clear Overrides | oK | | Cancel |
Figure 1-85

Repeat for the Mechanical-Medium/High Velocity filter and
set the Weight to 6 and the Color to a green. Click lLl.
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9. In the Visibility/Graphics Overrides dialog box, move the new
filters to the top of the list. For Mechanical-Exhaust, in the
Visibility column, clear the checkbox as shown in
Figure 1-86.
Visibility/Graphic Overrides for Velocity Duct Plan [
| Model Categories I Annotation Categories I Analytical Model Categories I Imported Categories | Filters |Revit Links
N Projection/Surface Cut
Mame Visibility - - Halftone
Lines | Patterns | Transparen... Lines Patterns
Mechanical - Medium/High V...
Mechanical - Low Velocity
Domestic O
Sanitary O
Mechanical - Supply
Mechanical - Retum
| Mechanical -Ehaust W | |_Override... |_Override..

Figure 1-86

10.Click to close the Visibility/Graphic Overrides

dialog box, and click to complete the view

template.

Task 3 - Apply a View Template the views.

1.

In the Project Browser, use Duplicate with Detailing to
duplicate the 1 - Mech view. Rename it 1 - Mech - Velocity.

Right-click and select Apply View Template.

In the Apply View Template dialog box, select the Velocity
Duct Plan view template you just created and click

to apply it.

. Compare the new floor plan view with the existing 1 - Mech

view.

Duplicate the 2 - Mech view, rename it as 2 - Mech -
Velocity, and apply the same view template to it.

Finish with the 1 - Mech view.

Save the project.
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A

1.5 Settings for Mechanical and
Electrical Projects

Learning Objective

Review Mechanical settings for ducts and pipes and
Electrical settings for wiring, cable trays, and conduit.

In addition to the standard settings common to all Autodesk Revit
projects, the Autodesk Revit MEP software also has specific
Mechanical and Electrical settings that can be setup in a

Autodesk Revit MEP only template or a project.
B In the Autodesk Revit MEP software, the settings are found in
the Manage tab>Project Settings panel. Expand (MEP
Settings) and click (Mechanical Settings) or
(Electrical Settings).
B Additional types of settings include Load Classifications,
Demand Factors, and Building/Space Type Settings.
Mechanical Mechanical settings enable you to preset many items relating to
. duct and pipe sizes, conversion settings, and other key defaults,
Settlngs as shown in Figure 1-87.
Mechanical Settings @
Setting Value
= Duct Settings Draw MEP Hidden Lines 7
2”9'85 , Line Style Thin Lines
F{Z:::;E:;r Inside Gap 1/16"
Oval Outside Gap 1/16"
Round Single Line 1/18"
Calculation
= Pipe Settings
Angles
Conwversion
Segments and Sizes
Fluids
Slopes
Calculation
[ OK ] | Cancel
Figure 1-87
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Hidden Line

If the Draw MEP Hidden Lines option is selected, hidden lines
are displayed to indicate pipes and ducts that are below other
pipes and ducts, as shown in Figure 1-88.

Figure 1-88

The Line Style, Inside Gap, and Outside Gap options enable
you to specify how the hidden lines are displayed.

Angles

New In the Angles category you can specify the limits on the angles
in 2014 that can be used as ducts or pipes are being drawn, as shown in

Figure 1-89. This is most often used with piping.

Mechanical Settings @
Hidden Line Fitting angle
=1 Duct Settings
Angles Use any angle
Conversion Revit will use any angle supported by fitting content.
Rectangular @) Use spedfic angles
Oval
R:jnd Revit will use only the angles spedfied.
Calculation Angle Use in Layout
=] Pipe Settings 90.000°
2“9'95 _ 60.000° v
onversion =
Segments and Sizes 45.000 =
Fluids 30.000° v
Slopes 22.500° ¥
Calculation 11.250° 7
Figure 1-89
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Duct Settings

For the Single Line Fittings option, the first two settings relate
to how fittings are displayed in a single line view, as shown in
Figure 1-90. If the Use Annot. Scale for Single Line Fittings
option is selected, the single line fittings are displayed at the
same size on every sheet, regardless of the view scale. The
Duct Fitting Annotation Size option enables you to specify the
size at which the fittings should be displayed.

Setting Value
Use Annot. Scale for Single Line Fittings{[7
Duct Fitting Annotation Size 1/8"
Air Density 0.0751 Ib/ft*
Air Viscosity 002 cP
Rectangular Duct Size Separator x

Rectangular Duct Size Suffix
Round Duct Size Prefix
Round Duct Size Suffix -]

Duct Connector Separator

Owal Duct Size Separator
Oval Duct Size Suffix
Duct Rise / Drop Annotation Size 1/8"

Figure 1-90

The Air Density and Air Viscosity options are used when sizing
the ducts. The remaining options set the separators and suffixes
that are used for duct objects.

Conversion

The Conversion area is used to set the routing solutions for
ductwork. The settings for the Main and Branch options can be
set separately for each system type. You can specify the Duct
Type, Offset from level, and Flex Duct Type settings (this is
only applicable to branches), as shown in Figure 1-91.
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Mechanical Settings @
Hidden Line
=) Duct Seftings System Classification: Supply Air -
Angles —
Conversion Main Return Air
Rectangular Setting Exhaust Air
Owval
Round Duct Type Oval Duct : Default
Calculation Offset g -p"
=) Pipe Settings
Angles
Conwversion
Segments and Sizes
Fluids
Slopes Branch
Calculation Setting Value
Duct Type Oval Duct : Default
Offzet g -0
Flex Duct Type Mone
Maximurmn Flex Duct Length 6 -0"

Figure 1-91

Rectangular, Oval, and Round

The Rectangular, Oval, and Round options enable you to
adjust the sizing tables. The Size column lists all of the sizes.

You can click [ New Size..

] to add a size to the list and

[__DeeteSze ] 4 remove sizes from the list.

In addition, you can specify whether a size is displayed in the
size lists (to be available when you place a new duct or select
existing ducts) or if the size is used by the sizing routine

(automatic sizing of duct branches and systems), as shown in

Figure 1-92.
Mechanical Settings @
Hidden Line

= Duct Settings Mew Size... ] [ Delete Size ]
Angles
Conversion Size Used in Size Lists Used in Sizing &
o 5 3
Round 31/2°
Calculation 4

Figure 1-92

B For example, if you do not want the sizing routine to use any
odd numbered sizes, clear the Used in Sizing option for all
odd-numbered sizes.
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Pipe Settings

Most of the options in the Pipe Settings area are identical to or
similar to those in the Duct Settings area.

Pipe Segments and Sizes

Pipe segment and size settings are more complex due to the
many different materials and connections available. Each
material has its own roughness, connection types,
schedule/types, and sizes that correspond to each combination,
as shown in Figure 1-93. For example, Schedule 40 Carbon
Steel with a Flanged Connection can have different sizes than
Schedule 80 Carbon Steel with a Flanged Connection.

Mechanical Settings @
Hidden Line & o
=] Duct Settings Segment: Copper -K v| |j |j
Angles i
Conversion =
Rectangular Roughness: 0.00010%
Oval
Round Segment Description:
Calculation
=l Pipe Settings Size Catalog
Angles
Conversion New Size... | | Delete Size |
mdﬁzw Nominal 1D oD Used in Size Lists | Used in Sizing | +
Slopes 1/4" 5/16" 3/8"
Calculation 3/8" 13/32" 172"
1/2" 17/32"  15/8"
374" 34" 7/8"
1" 1" 11/8"
11/4" 114" 13/8"
11/2" :115/32" {15/8"
2 131327 21/8"
21/2" 127716 125/8"
3 229732 131/8"
4 327/32" 41/8" -
[ Ok ] | Cancel
Figure 1-93

The actual size lists are identical in function to those for ducts,
except for the inclusion of the ID (inside diameter) and OD
(outside diameter) parameters.
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L
m Click O (Create New Pipe Segment) to open the New
Segment dialog box (as shown in Figure 1-94), where you
specify new Material, and/or Schedule/Type for the segment.

Mew Segment

Create New:

Material:

Schedule/Type:
Duplicate size catalog from

Preview of segment name:

(@ Material

| Schedule/Type

[ 7 |(mSa)

A new segment requires a new Materal, a new Schedule/Type, ar both.

(") Material and Schedule/Type

| Schedule 40

. |Carbon Steel - Schedule 40

- Schedule 40

Fluids

Figure 1-94

4
B To delete a segment, click O (Delete Pipe Segment).

The Fluids area enables you to specify the viscosity and density
of fluids at different temperatures, as shown in Figure 1-95. You
can add or delete fluid types, and for each type, add or delete

temperatures.
Mechanical Settings @
Hidden Line )

B Duct Settings il = ’Water v] i
Angles
Conversion Mew Temperature. .. ] [ Delete Temperature ]
Rectangular Temperature Viscosity Density -
Oval 3020 °F 179 P 62.4200 Ib/ft
Flound 40,00 °F 156 ¢p 62.4200 Tb/ft
Calculation .

(- Pipe Settings 50.00 °F 131 cP 624100 Ib/ft’
Angles 60.00 °F 112 cP 62.3600 Ib/ft*
Conversion 70.00 °F 0.98 cP 62.3000 Ib/ft*
Segments and Sizes 80.00 =F 0.86 cP 62,2100 Ib/ft*
 Fluids | 90.00 °F 076 ¢P 62.1100 Tb/ft
Slopes 100.00 *F 0.68 cP 61.9900 Ib/ft*
Calculation 190 AN =g el o £1 aann T e

Figure 1-95
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Slopes

In the Slopes area, you can add or delete typical slopes used in
a project, as shown in Figure 1-96.

Mechanical Settings
Hidden Line - -
= Duct Settings Delete Slope

Angles
Conwversion
Rectangular
Owval
Round
Calculation
=) Pipe Settings
Angles
Conwversion
Segments and Sizes
Fluids

Calculation

Slope Values -

om /a2

1/8" F12"
14" /12"
1/2" f12"

= | owa| | =

Figure 1-96

Electrical In the Electrical Settings dialog box, you can preset many

. options relating to wiring, voltage, cable trays and conduits as
Settlngs well as Load Calculations and Panel Schedules, as shown in
Figure 1-97. Setting these up in the template for all of the
commonly used electrical settings, saves time for individual
projects and increases consistency.

Electrical Settings -? :
- Setting Value
f:”lee':' Draw MEP Hidden Lines
.g_ Line Style MEP Hidden
=1~ Wiring
=)~ Wire Sizes Inside Gap 1/64"
Comection Factor Outside Gap 1igi
Ground Conductors Single Line 1764
Wiring Types

Voltage Definitions
Distribution Systems
(=) Cable Tray Settings
(=) Rise Drop
Single Line Symbology
Two Line Symbology
Size:
-~ Conduit Settings
[=--- Rise Drop
Single Line Symbology
Two Line Symbology
Size:
Load Calculations
Panel Schedules

OK ] [ Cancel

Figure 1-97
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General

The parameters in the General area affect the display of
electrical information. The Electrical Data Style option sets how
the power information is displayed in the Electrical Data
parameter in the Instance Properties of the electrical component.
The Circuit Description option sets the formatting of the circuit
description.

Wiring
The Wiring area enables you to specify the ambient temperature
for wiring and some annotation settings related to wiring. The

Tick Mark families need to be preloaded into the template so
that they can be selected in this area, as shown in Figure 1-98.

Two Line Symbology

Electrical Settings @
Hidden Line Setting Value
i:;;':l Ambient Temperature 86 °F

= m Gap of Wiring Crossing 0 -01/16"
=1~ Wire Sizes Hot Wire Tick Mark
Cormection Factor —
Ground Conductors Ground Wire Tick Mark
Wiring Types MNeutral Wire Tick Mark
Voltage Definitions Slanted Line across Tick Marks Mo
Distribution Systems -
51 Cable Tray Settings Show Tick Marks Always
—|--- Fise Drop Max Voltage Drop For Branch Circuit Wire Sizing 2.00%
Single Line Symbology Max Voltage Drop For Feeder Circuit Wire Sizing 3.00%

Figure 1-98

Wire Sizes

The Wire Size settings enable you to create new wire materials,
temperature ratings, and insulation types. You can then specify
the ampacity, size, diameter, and if the size is used by the wire
sizing tools.

B The functionality in the Wire Sizes area is similar to that in the
Pipe Sizes and Fluids areas.
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Correction Factor

The Correction Factor area enables you to specify the correction
factors for different temperatures and for each wire type, as

shown in Figure 1-99.

Electrical Settings

Hidden Line
General
Angles
=1 Wirng
=] Wire Sizes
Comection Factor
Ground Conductars
Wiring Types
Voltage Definitions
Distribution Systems
=] Cable Tray Settings

Material: [Numinium

Temperature: [Gﬂ

New Comection Fador...J IDelete Comection Factor

7 s

Ground Conductors

Temperature Correction Factor
79°F 1.08
88 °F 1.00
97 °F 091
Figure 1-99

The Autodesk Revit software sizes ground conductors according
to their circuit rating. The Ground Conductors area enables you

to customize the sizes it uses for each wire material and

ampacity, as shown in Figure 1-100.

Electrical Settings

Hidden Line
General
Angles
=1 Wiring
=1 Wire Sizes
Comection Factor
Ground Conductors
Wiring Types
Voltage Definitions
Distribution Systems
=] Cable Tray Settings

Moo P

[ s

Material: I.Numinium -

Mew Ampacity .. I [ Delete Ampacity

Ampacity Conductor Size o
154 12
204 10
60 A
100 A
Figure 1-100
Wiring Types

The Wiring Types area enables you to create wiring types by

clicking and to delete them by clicking . You

can also specify their properties.
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Voltage Definitions

In the Voltage Definitions area, you can specify the minimum and
maximum voltages of devices that can be added to the
distribution systems of a specified voltage. For example, the
Autodesk Revit software permits devices ranging from 110V to
130V on a 120V distribution system, as shown in Figure 1-101.
You can also add or delete definitions.

Electrical Settings

Hidden Line

General

Angles

=1 Wiring

= Wire Sizes
Comection Factor
Ground Conductors

Wiring Types

(>
MName Value Minimum Maximum -
1 |120 12000V 110,00V 130,00V
2 |208 208,00V 200,00V 22000V
3 (240 24000V 22000V 250,00 v
4 (277 27700V 260,00V 280,00V
5 |[480 480,00V 460,00 v 490,00 v
Figure 1-101

Distribution Systems

The Distribution Systems area sets the distribution systems that
are available in your project, as shown in Figure 1-102. You can
edit the names by selecting them. The options for Phase are
preset and affect the options that are available in the
Configuration and Wires columns and whether L-L Voltage is
available. You can add more systems and delete existing
systems if they are not assigned to devices in the current project.

Electrical Settings

Hidden Line

General

Angles

=1 Wiring

=1 Wire Sizes
Comection Factor
Ground Conductors

Wiring Types
Voltage Definitions

(9
Name Phase Configuration| Wires | L-L Voltage L-G Voltage | =
120/208 Wye Three Wye + 208 120
120/240 Single Single MNone 3 240 120
480/277 Wye Three Wye + 480 277
Figure 1-102
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Cable Tray and Conduit Settings

Cable Trays and Conduits settings include annotation, Rise Drop

Symbology, and sizing, as shown in Figure 1-103.

Electrical Settings

=]

=]

=]

Hidden Line

General

Angles

Wiring

= Wire Sizes
Comection Factor
Ground Conductors

Wiring Types

Voltage Defintions

Digtribution Systems

Cable Tray Settings

=) Rise Drop
Single Line Symbology
Two Line Symbology

Size

Conduit Settings

=) Rise Drop
Single Line Symbology
Two Line Symbology

Load Calculations

Panel Schedules

Standard:

El

- h B

Modify Size...

e =

Trade Size 1D oD Minimum Bend Radius | Used in Size Lists
152" 5/8" 237327 411/32"
34" 13/16" 15/16" 431/32"
1" 11/16" 15/32" 611/32"
11/4" 13/8" 11/2" g"
11/2" 15/8" 137" g1/8"
2" 21/716" 23/16" 1019/32"
21/2" 22332 27/8" 1115/16"
3" 311/32" 31/2" 14 374"
31/2" 327/32" 4" 17"
4" 411/32" 41/2" 181/4"

Figure 1-103
Load Calculations and Panel Schedules

The Load Calculations area gives you access to additional dialog
boxes where you can setup Load Classifications and Demand
Factors.

The Panel Schedules area enables you set up labels and other
options for the default panel schedule.
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1.6 Settings for Structural
Projects

Learning Objective
\/ Review structural specific settings including symbolic
representation, load cases and combinations, analytical
model settings, and boundary conditions.

products, the Autodesk Revit Structure software has structural

E In addition to the standard settings common to all Autodesk Revit
settings that need to be customized. To access them, click

Autodesk Revit Structure L—‘
only Wy (Structural Settings) in the Manage tab>Project Settings
panel.

Symbolic Representation

There are several tabs at the top of the Structural Settings dialog
box, as shown in Figure 1-104. The first tab, Symbolic
Representation Settings, contains options that are mainly used
for the graphical model and the common defaults.

Structural Settings @

Symbolic Representation Settings | Load Cases I Load Combinations | Analytical Model Settings | Boundary Conditions Settings |

Symbolic Cutback Distance

Brace: 15/32"] Column: ifi8"
Beam/Truss: 337
Brace Symbols Connection Symbaols
Flan representation: Display Symbols for:
Parallel Lina - Beams and Braces -
Parallel line offset: Connection Type: Annotation Symbol:
3327 Moment Frame Connection-Moment-
Cantilever Moment Connection-Moment-

Show brace above
Symbol:

IConnecﬁon—Brace-Parallel - I

Show brace below
Symbol:

IConnecﬁon—Brace-Parallel A I

Kicker brace symbaol:

IConnecﬁon-Brace-lGdcer - I fj Bl Load...

[ OK H Cancel H Help

Figure 1-104
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The Symbolic Cutback Distance setting represents the
distance that cuts a framing member back from a column or into
another framing member. This cutback distance is symbolic and
does not affect the 3D view. For example, in plan, beams do not
extend into the column and there is a gap between them, as
shown in Figure 1-105. The same connection in 3D displays the
beams back from the column, which is more consistent with a
real-world situation.

. W12X26 W12X26
: D a

=3 | | = 8 8
= /"- = = =

\“‘- = W12X26 W12X26
o n] o
b 8 &
' = = =

W12X26 W12X26

(]

Figure 1-105

The Brace Symbols and Connection Symbols areas enable you
to specify the kinds of symbols that are shown for the braces in
plan, and for frame and shear connections. For many of these
items, only one symbol is loaded into the default template.

Load Cases and Load Combinations

Two tabs are related to setting up Load Cases and Load
Combinations. These vary by project and by region and typically
requires the input of a company’s engineer.

Analytical Model Settings

The process of modeling a building simultaneously creates a
digital model and its corresponding analytical model. As this is
done, the software can check for consistency between these two
models. The Analytical Model Settings tab contains settings for
automatic checks, tolerances, and checks, as shown in

Figure 1-106.
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Structural Settings @

| Symbolic Representation Settings I Load Cases | Load Combinations | Analytical Model Settings |Bt:L.|ndar\)-I Conditions Settings

Automatic Chedks
[T Member Supparts [ Analytical / Physical Model Consistency
Tolerances
Support distance: 1 07 Horizontal auto detect:  1' 07
Analytical-to-physical model distance: 0 87 Vertical auto detect:  1' 07

Analytical adjustment distance: 1 07

Member Supports Check
Circular references

Analytical f Physical Model Consistency Chedk

Analytical model connectivity

Analytical model adjusted away from default location
Analytical Beam and Floor overlap check

Possible instability based on release conditions
Analytical model outside physical model

[7] valid Physical Material Asset

Analytical Model Visibility
Differentiate ends of linear analytical models

[ oK H Cancel H Help I

Figure 1-106

It is a best practice not to enable Automatic Checks in the
template, as in the early stages of design there might be many
elements that are not supported, causing many warning boxes to
open. Automatic Checks are very useful when most of the
structure has been modeled and should be enabled at that time.

The values in the Tolerances area informs the kind of tolerance
that is permitted for supports, differences between the analytical
and physical distance, adjusting, and auto-detects. For example,
when the Analytical Model parameters for a wall are set to
auto-detect, the software adjusts the analytical lines, provided it
can do so within the specified tolerances.

The Analytical/Physical Model Consistency Check area enables
you to specify the kinds of consistencies to be checked for.
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Boundary Condition Settings

In the last tab, you can select the family symbols used for
boundary conditions, as shown in Figure 1-107 (from left to
right: Fixed, Pinned, Roller, and User).

- T

Figure 1-107

The structural templates typically include four boundary
condition families: Fixed, Pinned, Roller, and Variable. They
are assigned to the corresponding boundary conditions, as
shown in Figure 1-108.

Structural Settings

X3

Symbolic Representation Settings | Load Cases | Load Combinations | Analytical Model Settings | Boundary Conditions Settings

Family Symbal

Fixed
Pinned
Roller

User Defined

Area and Line Symbaol Spacing:

| Boundary Condition-Fixed

| Boundary Condition-Pinned

| Boundary Condition-Raoller

| Boundary Condition-Variable

1=

Figure 1-108

B You can create new boundary condition families, load them

into the template, and select them from the drop-down lists as

needed.
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Chapter Review Questions

1. Which of the following items are NOT setup in a template
file?

a. Units

b. Annotation Types
c. Title blocks

d. Keyboard Shortcuts

2. What is a label?
a. A texttype used in title blocks.
b. A dimension with text instead of numbers.
c. Atype of text with variable information.

3. When you want to create new Text Types, such as those
shown in Figure 1-109, you need to copy an existing one.

A FANCY FONT AT 1/4°

AHAND LETTERING FONT AT 1/ 8"
A AN LETERING FONT AT 5/ 52"

Figure 1-109
a. True
b. False

4. Which of the following enables you to assign a view template
consistently to a view so that no changes can be made to the
view parameters?

a. Inthe View Status Bar, lock the view.
b. In Properties, select a View Template.

c. In the Project Browser, right-click on the view and select
Lock.

d. Inthe Apply View Template dialog box, select a template.

© 2013, ASCENT - Center for Technical Knowledge® 1-73



Autodesk Revit 2014 BIM Management: Template and Family Creation

5. Which of the following parameters are included in a View
Template (as shown in Figure 1-110)? (Select all that apply.)

[ "Iy | (i@ Visibility/ Graphics [} Show Hidder
D r—
: i [ Filters |j! Remove Hid
Modify View | *
Templates :-E Thin Lines @ Cut Profile

Select =

: Apply Ternplate Properties to Current View

Properties [:h@ Create Template from Current View

% Manage View Termplates

Figure 1-110

View Scale
V/G Overrides
Project Units

a0 T w

Detail Level
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Command Summary

Button

Command

Location

&

ApplyTemplate
Properties to
Current View

B Ribbon: View tab>Graphics panel>
expand View Templates

B Project Browser: (right-click on a
view) Apply Template Properties...

— Arrowheads B Ribbon: Manage tab>Settings panel>
— expand Additional Settings

o Callout Tags B Ribbon: Manage tab>Settings panel>
- expand Additional Settings

@ Create View B Ribbon: View tab>Graphics panel>

Template From
View

expand View Templates

B Project Browser: (right-click on a
view)

Dimension

Types

B Linear

H Angular

B Radial

B Spot
Elevation

B Spot
Coordinate

B Spot Slope

B Ribbon: Annotate tab>Dimensions
panel>expand the panel title

Electrical
Settings

Autodesk Revit MEP
B Ribbon: Manage tab>Settings panel
expand MEP Settings

Elevation Tags

B Ribbon: Manage tab>Settings
panel>expand Additional Settings

Floor Plan B Ribbon: View tab>Create panel>
expand Plan Views
& Keyboard B Ribbon: View tab>Windows panel>
U Shortcuts expand User Interface
B Application Menu
Label Family Editor

B Ribbon: Create tab>Text panel

Loaded Tags

B Ribbon: Annotate tab>Tag panel>
expand the panel title

Manage View

B Ribbon: View tab>Graphics panel>

Templates expand View Templates
T Mechanical Autodesk Revit MEP
Settings B Ribbon: Manage tab>Settings panel

expand MEP Settings
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r\ New Title Block | B Application Menu: expand New>
= Title block
Options Options m Application Menu
Project Units B Ribbon: Manage tab>Settings panel
B Shortcut: UN
30 Revision Family Editor
B Schedule B Ribbon: View tab>Create panel
Q Section Tags B Ribbon: Manage tab>Settings panel>
expand Additional Settings
Ta Structural Autodesk Revit Structure
Settings B Ribbon: Manage tab>Settings panel
’._.( Temporary B Ribbon: Manage tab>Settings panel>
@ Dimensions expand Additional Settings
A Text Family Editor
B Ribbon: Create tab>Text panel
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