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Chapter 2
Basic Drawing and Editing Tools

In this chapter you learn how to use the basic drawing and editing tools that apply 
to almost all types of elements. These tools also include alignment lines, 
temporary dimensions, snaps, and the Properties palette. You learn how to select 
elements for editing. You also learn how to move, copy, rotate, mirror, and array 
elements.

This chapter contains the following topics:

General Drawing Tools

Editing Elements

Basic Modifying Tools
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2.1 General Drawing Tools

When you start a drawing command, the contextual Ribbon, 
Options Bar, and Properties palette enable you to set up features 
for each element you are placing in the drawing. As you are 
drawing, several features called drawing aids display, as shown 
in Figure 2–1. They help create designs quickly and accurately. 

Figure 2–1

Contextual Ribbon

In the Select panel, click 

 (Modify) to finish the 
command and return to 
the main tab at any time.

When you select a command, the Ribbon displays the Modify tab 
with the contextual tools. For example, when you click

 (Wall), the Modify | Place Wall tab opens, as shown in 
Figure 2–1. 

 The Modify tools are always displayed to the left of the 
Ribbon and the contextual tools to the right with a green 
panel title.

Learning Objectives

Use contextual Ribbon tabs, the Options Bar and Properties 
as you draw and modify.

Draw elements using draw and pick tools.

Use drawing aids including alignment lines, temporary 
dimensions and snaps.
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Options Bar

The Options Bar displays the most used options for an element, 
as shown in Figure 2–2. These options are also typically found in 
the Properties palette.

Figure 2–2

Properties Palette

The Properties palette displays the current element type in the 
Type Selector. You can select other types and modify some of 
the related parameters for the selected object, as shown in 
Figure 2–3.

Some of the properties 
parameters are only 
available when you are 
editing an element. 
They are grayed out 
when you are creating 
an element.

Figure 2–3

 Changes in the palette do not take effect until you click  
or move your cursor away from the palette. If you click in the 
window, it applies the change but clears the elements.
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 The Properties palette can be floated and moved around the 
interface. You can also dock it on top of the Project Browser 
and then switch between them using the tabs at the bottom of 
the palette, as shown in Figure 2–4. 

To dock the palette, 
drag the titlebar over the 
titlebar of the Project 
Browser.

Figure 2–4

 If the Properties palette is toggled off, you can toggle it on by 

clicking  (Properties) in the Modify tab>Properties panel 
or by typing PP. This is an on/off toggle.

Draw Tools Draw tools are used to draw linear elements, such as the walls 
shown in Figure 2–5. They display in the contextual Ribbon 
when you start a command to draw any element. The available 
tools vary according to the element being drawn.

Linear elements include 
walls, lines, detail lines, 
and sketches for floors, 
roofs, stairs, and 
railings.

Figure 2–5

 Two styles of tools are available: one where you draw the 
element using a geometric form, and another where you pick 
an existing element (such as a line, face, or wall) as the basis 
for the new element’s geometry.
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How to: Draw Linear Elements

1. Start the command you want to use, such as  (Wall).
2. In the contextual tab>Draw panel, select a drawing tool, such 

as  (Line), as shown in Figure 2–6. Select points to define 
the walls using other drawing aids, such as temporary 
dimensions, alignment lines, and snaps.

You can change from 
one Draw tool to 
another in the middle of 
a command.

Figure 2–6

 You can also select a pick tool, such as  (Pick Lines), 

and select an element.  (Pick Face) is only available if 
you are in a 3D view.

3. Click  (Modify) to finish the command.

Draw Tools

Line Draws a straight linear element defined by the 
first and last points. If Chain is enabled, you 
can continue selecting end points for multiple 
segments.

Rectangle Draws four linear elements defined from two 
opposing corner points. You can adjust the 
dimensions after selecting both points.

Inscribed 
Polygon

Draws a polygon inscribed in a hypothetical 
circle with the number of sides specified in the 
Options Bar.

Circumscribed 
Polygon

Draws a polygon circumscribed around a 
hypothetical circle with the number of sides 
specified in the Options Bar.

Circle Draws a circular linear element defined by a 
center point and radius.

Start-End-
Radius Arc

Draws a curved linear element defined by a 
start, end, and radius of the arc. The outside 
dimension shown is the included angle of the 
arc. The inside dimension is the radius.

Center-ends Arc Draws a curved linear element defined by a 
center, radius, and included angle. The 
selected point of the radius also defines the 
start point of the arc.
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Pick Tools

Draw Options

When you are in Drawing mode, several options display in the 
Options Bar, as shown in Figure 2–7.

Other options display 
according to the type of 
element you are 
drawing.

Figure 2–7

 The Chain option controls how many segments are drawn in 
one process. If it is not selected, the Line and Arc tools only 
draw one segment at a time. If it is selected, you can continue 
drawing segments until you select the command again.

 The Offset field enables you to enter values to draw the linear 
elements at a specified distance from the selected points. For 
example, set Offset to 10’-0" and select the end points of an 
existing wall to create a new wall 10’-0" away.

Tangent End 
Arc

Draws a curved linear element tangent to 
another element. Select an end point for the 
first point, but do not select the intersection of 
two or more elements. Then select a second 
point based on the included angle of the arc.

Fillet Arc Draws a curved linear element defined by two 
other linear elements and a radius. Because it 
is difficult to select the correct radius by 
clicking, this command automatically moves to 
edit mode. Select the dimension and then 
modify the radius of the fillet.

Spline Draws a curved linear element based on 
selected points. The curve does not actually 
touch the points (Model and Detail Lines only).

Ellipse Draws an ellipse from a primary and secondary 
axis (Model and Detail Lines only).

Partial Ellipse Draws only one side of the ellipse, like an arc. 
A partial ellipse also has a primary and 
secondary axis (Model and Detail Lines only).

Pick 
Lines

Use this option to select existing linear elements in the 
project. This is useful when you start the project from an 
imported 2D drawing.

Pick 
Face

Use this option to select the face of a 3D massing 
element (walls and 3D views only).

Pick 
Walls

Use this option to select an existing wall in the project to 
be the basis for a new sketch line (floors, ceilings, etc.).
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 When using a radial draw tool, you can select the Radius 
option and add a radius in the edit field.

 To draw angled lines, move your cursor to the desired angle 
shown by the temporary dimensions, and type the distance 
value. The angle increments shown vary depending on how 
far in or out the view is zoomed.

Drawing Aids As soon as you start drawing in the software, three drawing aids 
display on the screen: alignment lines, temporary dimensions, 
and snaps. These are available with most drawing and many 
modification commands.

Alignment Lines

Dashed alignment lines display as soon as you select your first 
point, as shown in Figure 2–8. They help keep lines horizontal, 
vertical, or at a specified angle. They also line up with the implied 
intersections of walls and other elements.

Angles display at 90, 45, 
15, 5, and 1 degree 
increments. The order 
of the angle list controls 
the power level of the 
snap. For example, the 
90 degree angle is most 
likely to display if you 
are close to horizontal 
or vertical.

Figure 2–8

 Hold down <Shift> to force the alignments to be orthogonal.

Hint: Reference Planes

Reference planes are infinite planes that extend through other 
views. For example, when a reference plane is drawn in a first 
floor plan, it displays in all other floor plans, corresponding 
elevations, and sections. This can be very helpful when lining 
up elements in the model. are construction lines that do not 

plot. In the Home tab>Work Plane panel, click  (Ref Plane) 
or type RP and then draw or pick lines. 
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Temporary Dimensions

Along with alignment lines, temporary dimensions display as you 
draw to help place linear elements (such as walls) at the proper 
length and location, as shown in Figure 2–9.

You can move the 
cursor to the exact 
dimension, or place it 
approximately and then 
modify the dimension as 
needed. This enables 
you to sketch the 
building and then come 
back and use the 
parametric engine to 
update the model with 
greater precision.

Figure 2–9

 For Imperial measurements (feet and inches), the software 
understands a default of feet. For example, when you type 4, 
it assumes 4’-0”. To indicate inches, type the inch mark (”) 
after the distance. For a distance such as 4’-6”, you can type 
any of the following: 4’-6”, 4’6, 4-6, or 4 6 (the numbers 
separated by a space). 

 The increments displayed for dimensions change as you 
zoom in closer to the elements. These dimension snap 
increments are for both linear and angular dimensions, and 
can be set in the Snaps dialog box.

 Temporary dimensions disappear as soon as you finish 
drawing linear elements. If you want to make them 
permanent, select the control shown in Figure 2–10.

Dimensions are a 
powerful tool to help 
create and annotate the 
model.

Figure 2–10

 The size of the temporary dimensions, in pixels, can be set in 
the Options dialog box on the Graphics tab.
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Snaps

Snaps are key points that help you reference existing elements 
to exact points when drawing, as shown in Figure 2–11.

Figure 2–11

They include Endpoints, Midpoints, Nearest, Work Plane Grid, 
Quadrants, Intersections, Centers, Perpendicular, Tangents, and 
Points. When you move your cursor over an element, the Snap 
symbol displays. Each snap location type displays with a 
different symbol.

 To modify the snap settings, in the Manage tab>Settings 

panel, click  (Snaps). This opens the Snaps dialog box, 
where you can set which snap points are active, as well as 
the snap distances (for dimension and angular increments). It 
also shows the keyboard shortcuts for each snap, which you 
can use to override the automatic snapping.

Hint: Temporarily Overriding Snap Settings

You can use shortcut key combinations (displayed in the Snaps 
dialog box) or right-click and select Snap Overrides to 
temporarily override snap settings. Temporary overrides only 
affect a single pick but can be very helpful when there are 
snaps nearby other than the one you want to use. 
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2.2 Editing Elements

Building design projects typically involve extensive changes to 

the positions of walls, doors, and other elements. The Autodesk® 

Revit® software was designed to make such changes easy. 

 (Modify) works with all of the different element types.

 When you select an element during an active command, 
there are a number of ways to change it, as shown in 
Figure 2–12:

 Modify commands and element-specific tools display in 
the contextual tab in the Ribbon.

The Type Selector can 
also be found in the 
Modify tab of the Ribbon 
or on the Quick Access 
Toolbar.

 The Properties palette displays the Type Selector and 
associated parameters.

 Temporary dimensions enable you to change the 
element’s dimensions.

 Controls enable you to drag, flip, lock, and rotate the 
element.

 When you hover your cursor over an element, a tooltip 
displays information about it.

Figure 2–12

 To delete an element, select it and press <Delete>, right-click 

and select Delete, or click  (Delete) in the Modify panel.

Learning Objectives

Select elements to modify.

Modify elements using the Ribbon, Properties, temporary 
dimensions, and controls.

Filter selection sets.

Temporary 
dimensions

Controls
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 When working with temporary dimensions, the default 
location of the dimension line might not be where you need it. 
For example, as shown on the left in Figure 2–13, instead of 
setting the distance of the selected wall from the center of the 
left wall, you might want to modify the distance from the grid 
line. Drag the square control (also called the witness line) to 
the grid line, as shown on the right in Figure 2–13.

Figure 2–13

 You can click on the square control to move the witness line 
from one part of the selected wall to another or drag it to a 
new location.

 The new location of a temporary dimension is remembered 
as long as you are in the same session of the software.

Selecting
Elements

You can select elements in several ways:

 To select a single element, place your cursor on the edge of 
the element and click to select.

 To add another element to a selection set, hold down <Ctrl> 
and select another item. 

 To remove an element from a selection set, hold down 
<Shift> and select the element.

Hint: Nudge

Nudge is a feature that is often overlooked. It enables you to 
move an element in short increments. When an element is 
selected, you can press one of the four arrow (direction) keys to 
move the element in that direction. The snap increments 
specified in the Snap dialog box determine the distance that is 
applied each time the arrow keys are pressed, depending how 
far in or out you are zoomed. This is very useful with annotation 
elements.



Basic Drawing and Editing Tools

© 2013, ASCENT - Center for Technical Knowledge® 2–13

 If you click and drag the cursor to window around elements, 
you have two selection options, as shown in Figure 2–14. If 
you drag from left to right, you only select the elements 
completely inside the window. If you drag from right to left, 
you select elements both inside and crossing the window.

Figure 2–14

 If several elements are on or near each other, press <Tab> to 
cycle through them before you click. If there are elements 
that might be linked to each other, such as walls that are 
connected, pressing <Tab> selects the chain of elements.

 Press <Ctrl>+<Left Arrow> to reselect the previous selection 
set. You can also right-click in the drawing window with 
nothing selected and select Select Previous.

 To select all elements of a specific type, right-click on an 
element and select Select All Instances>Visible in View or 
In Entire Project, as shown in Figure 2–15.

Figure 2–15
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Hint: Selection Options

You can control how the software selects specific elements in a 
project by toggling them on and off on Status Bar or in the 
expanded Modify icon as shown in Figure 2–16.

Figure 2–16

  Select links: When toggled on, you can selected linked 
drawings or Autodesk Revit models. When it is toggled off 
you cannot select them when using Modify or Move.

  Select underlay elements: When toggled on, you can 
select underlay elements. When toggled off, you cannot 
select them when using Modify or Move.

  Select pinned elements: When toggled on, you can 
selected pinned elements. When toggled off, you cannot 
select them when using Modify or Move.

  Select elements by face: When toggled on you can 
select elements (such as the floors or walls in an elevation) 
by selecting the interior face or selecting an edge. When 
toggled off, you can only select elements by selecting an 
edge.

  Drag elements on selection: When toggled on, you 
can hover over an element, select it, and drag it to a new 
location. When toggled off, the Crossing or Box select mode 
starts when you press and drag, even if you are on top of an 
element. Once elements have been selected they can still 
be dragged to a new location.
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Modifying
Multiple

Elements

When multiple element types are selected, the Multi-Select 
contextual tab opens in the Ribbon, as shown in Figure 2–17. 
This gives you access to all of the Modify tools, as well as the 
Filter command and tools to create and use selection sets. 

Figure 2–17

 The Properties palette displays tools that are common to all 
element types if they are available. You can also select just 
one type and make modifications, as shown in Figure 2–18.

Figure 2–18

Filtering Selection Sets

The Filter command enables you to specify the types of 
elements to select. For example, you might only want to select 
doors, as shown in Figure 2–19.

Figure 2–19
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How to: Filter a Selection Set

1. Select everything in the required area.

2. Click  (Filter) in the Modify | Multi-Select tab or in the 
Status Bar. The Filter dialog box opens, as shown in 
Figure 2–20.

The Filter dialog box 
displays all types of 
elements in the original 
selection.

Figure 2–20

3. Click  to clear all of the options and then 
select the element types that you want included in the 
selection.

4. Click . The selection set is now limited to the 
elements you specified.

 In the Status Bar,  (Filter) displays how many elements 
you selected.
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Reusing Selection Sets

When multiple elements types are selected you can save the 
selection set so that it can be reused. For example, a structural 
column and an architectural column need to move together. 
Instead of picking each element, create a selection set that you 
can quickly access as shown in Figure 2–21. You can also edit 
selection sets to add or remove elements from the set.

Selection sets are a 
type of filter.

Figure 2–21

How to: Save Selection Sets

1. Select the elements that you want to include in the selection 
set.

2. In the Modify | Multi-Select tab>Selection panel, click

 (Save). 
3. In the Save Selection dialog box, type a name for the set as 

shown in Figure 2–22, and click .

Figure 2–22
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How to: Retrieve Selection Sets

1. Select any other elements you might want to use. In the 

Modify | Multi-Select tab>Selection panel, click  (Load). 
Alternatively, without any other selection, in the Manage tab>

Selection panel, click  (Load).
2. In the Retrieve Filters dialog box (shown in Figure 2–23), 

select the set that you want to use and click .

Figure 2–23

3. The elements are selected and you can continue to select 
other elements or use the selection.

How to: Edit Selection Sets

1. If elements are selected, in the Modify | Multi-Select tab>

Selection panel, click  (Edit). Alternatively, without any 

selection, in the Manage tab>Selection panel, click  (Edit).
2. In the Filters dialog box (shown in Figure 2–24), select the set 

that you want to edit and click .

Some filters in this 
dialog box are not 
selection sets but apply 
to categories of 
elements, such as the 
Interior filter shown in 
Figure 2–24.

Figure 2–24
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 If you want to modify the name of the Filter, click 

.

3. The selection set elements remain black while the rest of the 
elements are grayed out. The Edit Selection Set contextual 
tab displays as well, as shown in Figure 2–25.

Figure 2–25

4. Use  (Add to Selection) to select additional elements for 

the set and  (Remove from Selection) to delete elements 
from the set.

5. When you have finished editing, click  (Finish Selection).

6. In the Filters dialog box, click  to finish.
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Practice 2a General Drawing and Editing

Estimated time for 
completion: 10 minutes

In this practice you will use the Wall command along with Draw 
tools and drawing aids, such as temporary dimensions and 
snaps. You will use the Modify command and modify the walls 
using grips, temporary dimensions, the Type Selector, and 
Properties. You will add a door and modify it using temporary 
dimensions and controls. You will also add a structural and an 
architectural column and use them to create a selection set. The 
completed drawing is shown in Figure 2–26.

Figure 2–26

Task 1 - Draw and modify walls.

1. In the Application Menu, click  (New)>  (Project).

2. In the New Project dialog box, select Architectural Template 

in the Template file drop-down list, and click .

Learning Objectives

Create walls using draw tools and drawing aids.

Add and modify a door.

Add a column.

Create a selection set.
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3. In the Quick Access Toolbar, click  (Save). When 
prompted, name the project Simple Building.rvt.

4. In the Architecture tab>Build panel, click  (Wall).

5. In the Modify | Place Wall tab>Draw panel, click|

 (Rectangle) and draw a rectangle approximately 
100’ x 70’. You do not have to be precise because you can 
change the dimensions later.

6. Note that the dimensions are temporary. Select the vertical 
dimension text and type 70’ 0", as shown in Figure 2–27. 
Press <Enter>.

Figure 2–27

7. The dimensions are still displayed as temporary. Click the 
dimension controls of both the dimensions to make them 
permanent, as shown in Figure 2–28.

Figure 2–28

 You will change the horizontal wall dimension using the 
permanent dimension. 

8. In the Select panel, click  (Modify).
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9. Select either vertical wall. The horizontal dimension becomes 
active (changes to blue). Click the dimension text and type 
100’ 0", as shown in Figure 2–29.

Figure 2–29

10.Click in an empty space to end the selection. You are still in 
the Modify command.

11. In the Architecture tab>Build panel, click  (Wall). In the 

Draw panel, verify that  (Line) is selected. Draw a wall 
horizontally from midpoint to midpoint of the vertical walls.

12.Draw another horizontal wall 8’-0" above the middle 
horizontal wall. You can use temporary dimensions or the 
Offset field to do this.

13.Draw a vertical wall exactly 16’-0" from the left wall, as 
shown in Figure 2–30.

Figure 2–30
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14. In the Draw panel, click  (Circle) and draw a 14’-0" radius 
circular wall at the midpoint of the lower interior horizontal 
wall, as shown in Figure 2–31.

Figure 2–31

15.Click  (Modify) to finish the command.

16.Hover your cursor over one of the outside walls, press <Tab> 
to highlight the chain of outside walls, and click to select the 
walls.

17. In the Type Selector, select Basic Wall: Generic-12", as 
shown in Figure 2–32. The thickness of the outside walls 
change.

Figure 2–32

18.Click in empty space to release the selection.
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19.Select the vertical interior wall and change it to one of the 
small interior partition styles.

20.Click in an empty space to release the selection.

Task 2 - Add and modify a door.

1. Zoom in on the room in the upper left corner.

2. In the Architecture tab>Build panel, click  (Door).

3. In the Modify | Place Door tab>Tag panel, click  (Tag on 
Placement) if it is not already selected.

4. Place a door anywhere along the wall in the hallway.

5. Click  (Modify) to finish the command.

6. Select the door. Use temporary dimensions to move it so that 
it is 2’-6" from the right interior vertical wall. If required, use 
controls to flip the door so that it swings into the room, as 
shown in Figure 2–33.

Figure 2–33

7. Type ZE to zoom out to the full view.

8. Save the project.

Task 3 - Add Columns and create a selection set.

1. In the Architecture tab>Build panel, expand  (Column) 

and click  (Structural Column).

2. In the Type selector, verify that W-Wide Flange - Column: 
W10x49 is selected.

Temporary 
Dimensions

Flip Control
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3. In the Options Bar, set the Height (not Depth) to Level 2, as 
shown in Figure 2–34.

Figure 2–34

4. Place it in the lower left corner outside the building as shown 
in Figure 2–35. The exact location does not matter.

Figure 2–35

5. In the Architecture tab>Build panel, expand  (Column) 

and click  (Column: Architectural).

6. In the Type Selector, verify that Rectangular Column:24" x 
24" is selected.

7. Place it using the Midpoint and Midpoint snaps as shown in 
Figure 2–36.

Figure 2–36

8. Click  (Modify).

9. Use the mouse to create a selection window around the 
columns so that both the structural and architectural columns 
are selected.
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10. In the Modify | Multi-Select tab>Selection panel, click

 (Save). 

11. In the Save Selection dialog box, enter the name Column 
Set as shown in Figure 2–37.

Figure 2–37

12.Click .

13. In the Manage tab>Selection panel, click  (Load 
Selection).

14. In the Retrieve Filters dialog box, select Column Set and 

click .

15.Both columns are selected as shown in Figure 2–38.

Figure 2–38

16.Click in empty space to release the selection.

17.Double-click the mouse wheel to zoom out the view.

18.Save the project.
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2.3 Basic Modifying Tools

The Autodesk Revit software contains controls and temporary 
dimensions that enable you to edit elements. Additional 
modifying tools can be used with individual elements or any 
selection of elements. They are found in the Modify tab>Modify 
panel, as shown in Figure 2–39, and in contextual tabs.

You can either select 
the elements and start 
the command or start 
the command, select 
the elements, and press 
<Enter> to finish the 
selection set.

Figure 2–39

 The Move, Copy, Rotate, Mirror, and Array commands are 
covered in this topic. Other tools are covered later.

Moving
and Copying

Elements

The Move and Copy commands enable you to select the 
element(s) and move or copy them from one place to another. 
You can use alignment lines, temporary dimensions, and snaps 
to help place the elements, as shown in Figure 2–40.

Figure 2–40

Learning Objectives

Move and copy elements.

Rotate elements around the center or an origin.

Mirror elements by picking an axis or by drawing an axis.

Create Linear and Radial Arrays of elements.
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How to: Move or Copy Elements

If you click  (Move) 
and hold down <Ctrl>, 
the elements are 
copied.

1. Select the elements you want to move or copy.

2. In the Modify panel, click  (Move) or  (Copy). A 
boundary box displays around the selected elements.

3. Select a move start point on or near the element.
4. Select a second point. Use alignment lines and temporary 

dimensions to help place the elements.
5. The elements remain highlighted, enabling you to start 

another command, or press <Esc> to finish.

Move/Copy Elements

The Move and Copy commands have several options that 
display in the Options Bar, as shown in Figure 2–41. 

Figure 2–41
 

 These commands only work within the current view, not 
between views or projects. To copy between views or 

projects, use  (Copy to Clipboard) and  (Paste).

Constrain Restricts the movement of the cursor to horizontal or vertical, 
or along the axis of an item that is at an angle. This keeps 
you from selecting a point at an angle by mistake. Constrain 
is off by default.

Disjoin 
(Move only)

Breaks any connections between the elements being moved 
and other elements. If Disjoin is on, the elements move 
separately. If it is off, the connected elements also move or 
stretch. Disjoin is off by default.

Multiple 
(Copy only)

Enables you to make multiple copies of one selection. 
Multiple is off by default.

Hint: Pinning Elements

If you do not want elements to be moved, you can  (Pin) 
them in place, as shown in Figure 2–42. Pinned elements can 
still be copied.

Figure 2–42

Select the element and click  (Unpin) to free it.
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Rotating
Elements

The Rotate command enables you to rotate selected elements 
around a center point or origin. You can use alignment lines, 
temporary dimensions, and snaps to help specify the center of 
rotation and the angle. You can also create copies of the element 
as it is being rotated.

How to: Rotate Elements

1. Select the element(s) you want to rotate.

2. In the Modify panel, click  (Rotate) or type RO.
3. The center of rotation is automatically set to the center of the 

element or group of elements, as shown on the left in 
Figure 2–43. To change the center of rotation, as shown on 
the right in Figure 2–43, use the following:

 Drag the  (Center of Rotation) control to a new point.

 In the Options Bar, next to Center of rotation, click  
and use snaps to move it to a new location.

 Press the <Spacebar> to select the center of rotation and 
click to move it to a new location.

Figure 2–43

 To start the Rotate command with an automatic prompt to 
select the center of rotation, type R3.

4. In the Options Bar, specify if you want to make a Copy (select 
Copy option), type an angle in the Angle field (as shown in 
Figure 2–44), and press <Enter>. You can also specify the 
angle on screen.

To specify the angle on 
screen, select a point for 
the rotate start ray (the 
reference line for the 
rotation angle). Then 
select a second point, 
using the temporary 
dimension to help you 
set the angle.

Figure 2–44

5. The rotated element(s) remain highlighted, enabling you to 
start another command, or press <Esc> to finish.

 The Disjoin option breaks any connections between the 
elements being rotated and other elements. If Disjoin is on 
(selected), the elements rotate separately. If it is off (cleared), 
the connected elements also move or stretch. Disjoin is off 
by default.
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Mirroring
Elements

The Mirror command enables you to mirror elements about an 
axis defined by a selected element, as shown in Figure 2–45, or 
by selected points.

Figure 2–45

How to: Mirror Elements

1. Select the element(s) to mirror.
2. In the Modify panel, select the method you want to use:

 Click  (Mirror - Pick Axis) or type MM. This prompts 
you to select an element as the Axis of Reflection (mirror 
line).

 Click  (Mirror - Draw Axis) or type DM. This prompts 
you to select two points to define the axis about which the 
elements mirror.

3. The new mirrored element(s) remain highlighted, enabling 
you to start another command, or press <Esc> to finish.

 By default, the original elements that were mirrored remain. 
To delete the original elements, clear the Copy option in the 
Options Bar.

Hint: Scale

The Autodesk Revit software is designed with full-size 
elements. Therefore, not much can be scaled. However, you 

can use  (Scale) in reference planes, images, and imported 
files from other programs.
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Creating Linear
and Radial

Arrays

The Array command creates multiple copies of selected 
elements in a linear or radial pattern, as shown in Figure 2–46. 
For example, you can array a row of columns to create a row of 
evenly spaced columns on a grid, or array a row of parking 
spaces. The arrayed elements can be grouped or placed as 
separate elements.

A linear array creates a 
straight line pattern of 
elements, while a radial 
array creates a circular 
pattern around a center 
point.

Figure 2–46

How to: Create a Linear Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array). 

3. In the Options Bar, click  (Linear).
4. Specify the other options as needed.
5. Select a start point and an end point to set the spacing and 

direction of the array. The array is displayed.

 If you have the Group and Associate option toggled on, you 
are prompted again for the number of items, as shown in 
Figure 2–47. 

Type a new number or 
click on the screen to 
finish the command.

Figure 2–47

 To make a linear array in two directions, you need to array 
one direction first, select the arrayed elements, and then 
array them again in the other direction.

Linear Array

Radial Array
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Array Options

In the Options Bar, set up the Array options for Linear Array 
(top of Figure 2–48) or Radial Array (bottom of Figure 2–48).

Figure 2–48

How to: Create a Radial Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array).

3. In the Options Bar, click  (Radial).

4. Drag  (Center of Rotation) or use  to the move the 
center of rotation to the appropriate location, as shown in 
Figure 2–49.

Remember to set the 
Center of Rotation 
control first, because it 
is easy to forget to move 
it before specifying the 
angle.

Figure 2–49

5. Specify the other options as needed.
6. In the Options Bar, type an angle and press <Enter>, or 

specify the rotation angle by selecting points on the screen.

Group and 
Associate

Creates a group element out of all arrayed elements. Groups 
can be selected by selecting any elements in the group.

Number Specifies how many instances you want in the array.

Move To: 2nd specifies the distance or angle between the center 
points of the two elements.

Last specifies the overall distance or angle of the entire 
array.

Constrain Restricts the direction of the array to only vertical or 
horizontal (Linear only).

Angle Specifies the angle (Radial only).

Center of 
rotation 

Specifies a location for the origin about which the elements 
rotate (Radial only).
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Modifying Arrays

When you select an element in an array that is created as a 
group, the associated shape controls and dimensions display, as 
shown in Figure 2–50. You can modify the number of instances 
and for radial arrays you can modify the distance to the center.

Figure 2–50

 To remove only the array constraint on the group, select one 

of the elements in the group and click  (Ungroup) in the 
Modify contextual tab>Group panel. This only ungroups the 
array but not the groups created when the array was created. 
To ungroup all of the elements, select the elements, use

 (Filter) to only select the groups, and click  (Ungroup). 
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Practice 2b Modifying Tools

Estimated time for 
completion: 10 minutes

In this practice you will use Move, Copy, Mirror, and Array to 
modify and add elements to a simple building, as shown in 
Figure 2–51.

Figure 2–51

Task 1 - Modify walls and doors.

1. Open the project Simple-Building-1.rvt from your class 
folder.

2. Select the top arc of the circular wall.

3. In the Modify panel, click  (Delete). The walls that the 
circular wall crossed are automatically cleaned up.

4. Select the vertical interior wall, door, and door tag. Hold down 
<Ctrl> to select more than one element.

Learning Objectives

Copy walls to create a series of offices and mirror a door for 
the last office.

Draw and array a series of cubicles and modify the last 
cubicle so that it fits the space.

Load a selection set and use it to create an array of columns 
across the front of the building.
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5. In the Modify panel, click  (Copy).

6. In the Options Bar, select the Multiple option.

7. For the base point, select the upper left inside corner of the 
room, as shown in Figure 2–52.

8. For the distance to place the wall, select the corner of the 
interior wall on the right side, as shown in Figure 2–52.

Figure 2–52

9. The wall, door, and door tag are copied to the right side of the 
first interior wall and the door tag displays 2.

10.Select the corner of the newly copied interior wall on the right 
side to place another partition wall, door, and door tag to its 
right.

Base point for copy Second point



Autodesk Revit Architecture 2014 Fundamentals

2–36 © 2013, ASCENT - Center for Technical Knowledge®

11. Continue copying until you place the fifth wall, as shown in 
Figure 2–53.

Figure 2–53

12.Press <Esc> twice to finish the command.

13.Zoom in on the room to the far right.

14.Select the door and door tag 5 in the room left to it.

15. In the Modify panel, click  (Mirror - Pick Axis).

16.Select the vertical wall between the rooms as the mirror axis 
and place the new door, as shown in Figure 2–54.

Figure 2–54

17.Click in empty space to release the selection set.

Task 2 - Draw and array cubicles.

1. Pan to the lower left corner of the building.

2. In the Architecture tab>Build panel, click  (Wall).

Mirror axis
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3. In the Type Selector, select Basic Wall: Interior - 3-1/8" 
Partition (1 hr). Draw the cubicle shown in Figure 2–55 and 
press <Esc> twice to finish the command.

You can also click 

 (Modify) in the 
Selection panel to finish 
a command.

Figure 2–55

4. Select the two cubicle walls.

5. In the Modify panel, click  (Array).

6. In the Options Bar, click  (Linear) and set the Number to 
10 and Move to: to 2nd.

7. In the drawing area, select a point on the top horizontal 
cubicle wall and another point 8’-0" to the right of the wall. 
The array displays as shown in Figure 2–56.

Figure 2–56

8. Enough room is available to add more cubicles. Type 12 at 
the number prompt and press <Enter> to finish the 
command.
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9. Zoom in on the last cubicle and select it. It is part of a group, 
as shown in Figure 2–57.

Figure 2–57

10. In the Modify | Model Groups tab>Group panel, click 

 (Ungroup). This separates the last element from the rest 
of the group.

11. Delete the vertical wall and use the end control to drag the 
horizontal wall to the exterior wall, as shown in Figure 2–58.

Figure 2–58

12.Zoom out to display the entire view.

Task 3 - Select and array the column set.

1. In the Manage tab>Selection panel, click  (Load).
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2. In the Retrieve Filters dialog box, select Column Set (as 

shown in Figure 2–59), and click .

Figure 2–59

3. Zoom in on the selected column set in the lower left corner on 
the outside of the building. 

4. In the Modify | Multi-Select tab>Modify panel, click 

 (Move).

5. For the move start point, select the top endpoint of the 
architectural column. Move your cursor to the left. For the end 
point, select the Horizontal and Extension of the center of 
the wall as shown in Figure 2–60.

Figure 2–60

6. Do not release the selection. 

7. In the Modify | Multi-Select tab>Modify panel, click 

 (Array).

8. In the Options Bar, click  (Linear), clear Group and 
Associate, set the Number to 10, and set Move To: to Last.
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9. For the start point, click the top endpoint of the column. For 
the endpoint of the array, select the Horizontal and 
Extension of the center of the far right wall as shown in 
Figure 2–61.

Figure 2–61

10.Zoom out to display the entire building.

11. The columns are arrayed evenly across the front of the 
building as shown in Figure 2–62.

Figure 2–62

12.Save the project.
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Chapter Review Questions

1. What is the purpose of an alignment line?

a. Displays when the new element you are placing or 
drawing is aligned with the grid system.

b. Indicates that the new element you are placing or drawing 
is aligned with an existing object.

c. Displays when the new element you are placing or 
drawing is aligned with a selected tracking point.

d. Indicates that the new element is aligned with true north 
rather than project north.

2. How do you edit a temporary dimension, such as that shown 
in Figure 2–63, when you are drawing?

Figure 2–63

a. Select the temporary dimension and enter a new value.

b. Type a new value and press <Enter>.

c. Type a new value in the Distance/Length box in the 
Options Bar and press <Enter>.

3. How do you select only doors in a view?

a. In the Family node in the Project Browser, select the Door 
category.

b. Select one door, right-click and select Select All 
Instances>Visible in View.

c. Select all of the objects in the view and use  (Filter) to 
clear the other categories.

d. Select one door, and click  (Select Multiple) in the 
Ribbon.
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4. What are the two methods for starting  (Move) or 

 (Copy)?

a. Start the command first and then select the objects, or 
select the objects and then start the command.

b. Start the command from the Modify tab, or select the 
object and then select Move or Copy from the right-click 
menu.

c. Start the command from the Modify tab, or select the 
objects and select Auto-Move.

d. Use the Move/Copy command or Cut/Copy and Paste 
using the Clipboard.

5. Where do you change the wall type for a selected wall as 
shown in Figure 2–64?

Figure 2–64

a. In the Modify | Walls tab> Properties panel, click

 (Type Properties) and select a new wall type in the 
dialog box.

b. In the Options Bar, click .

c. Select the dynamic control next to the selected wall and 
select a new type in the drop-down list.

d. In Properties, select a new type in the Type Selector 
drop-down list.
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6. Both  (Rotate) and  (Array) with  (Radial) have a 
center of rotation that defaults to the center of the element or 
group of elements you have selected. How do you move the 
center of rotation to another point as shown in Figure 2–65? 
(Select all that apply.)

Figure 2–65

a. Select the center of rotation and drag it to a new location.

b. In the Options Bar, click  and select the new point.

c. In the Modify tab> Placement panel, click  (Center) and 
select the new point.

d. Right-click and select Snap Overrides>Centers and 
select the new point.
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Command Summary

Button Command Location
Add to 
Selection

 Ribbon: Edit Selection Set tab>Edit 
Selection panel

Array  Ribbon: Modify tab>Modify panel>
Array

 Shortcut: AR

Copy  Ribbon: Modify tab>Modify panel>
Copy

 Shortcut: CO

Copy to 
Clipboard

 Ribbon: Modify tab>Clipboard panel>
Copy to Clipboard

 Shortcut: <Ctrl>+<C>

Drag elements 
on selection

 Status Bar

 Expanded Select panel

Delete  Ribbon: Modify tab>Modify panel>
Delete

 Shortcut: DE

Edit (Selection)  Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Filter  Ribbon: Modify | Multi-Select tab>
Filter panel>Filter

 Status Bar

Load 
(Selection)

 Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Mirror - Draw 
Axis

 Ribbon: Modify tab>Modify panel>
Mirror

 Shortcut: DM

Mirror - Pick 
Axis

 Ribbon: Modify tab>Modify panel>
Mirror

 Shortcut: MM

Move  Ribbon: Modify tab>Modify panel>
Move

 Shortcut: MV

Paste  Ribbon: Modify tab>Clipboard panel>
Paste

 Shortcut: <Ctrl>+<V>

Pin  Ribbon: Modify tab>Modify panel>
Pin

 Shortcut: PN

Remove from 
Selection

 Ribbon: Edit Selection Set tab>Edit 
Selection panel
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Rotate  Ribbon: Modify tab>Modify panel>
Rotate

 Shortcut: RO

Save (Selection)  Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Scale  Ribbon: Modify tab>Modify panel>
Scale

 Shortcut: RE

Select Elements 
By Face

 Status Bar

 Expanded Select panel

Select Links  Status Bar

 Expanded Select panel

Select Pinned 
Elements

 Status Bar

 Expanded Select panel

Select Underlay 
Elements

 Status Bar

 Expanded Select panel
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