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Chapter 2
Basic Drawing and Modify Tools

In this chapter you learn how to use the basic drawing and modify tools that apply 
to almost all types of elements. These tools include alignment lines, temporary 
dimensions, snaps, and the Properties palette. You learn how to select elements 
for editing and how to move, copy, rotate, mirror, and array them. You also learn to 
align, split, trim, extend, and offset elements.

This chapter contains the following topics:

• Using General Drawing Tools

• Editing Elements

• Working with Basic Modify Tools

• Working with Additional Modify Tools
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2.1 Using General Drawing Tools

When you start a command, the contextual Ribbon tab, Options 
Bar, and Properties palette enable you to set up features for 
each new element you are placing in the project. As you are 
drawing, several features called drawing aids display, as shown 
in Figure 2–1. They help you to create designs quickly and 
accurately. 

Figure 2–1

Contextual Ribbon

When you select a command or an element in the model, the 
Modify tab displays with additional contextual tools. For example, 

when you start the  (Wall) command, the Modify | Place Wall 
tab displays, as shown in Figure 2–2. 

Figure 2–2

Learning Objectives

• Use contextual Ribbon tabs, the Options Bar and 
Properties as you draw and modify.

• Draw elements using draw and pick tools.

• Use drawing aids including alignment lines, temporary 
dimensions and snaps.
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• The standard Modify tools are always displayed to the left in 
the ribbon, while the contextual tools are displayed to the 
right with a green panel title.

• To finish a command and return to the standard ribbon tabs at 

any time, in the Select panel, click  (Modify).

Options Bar

The Options Bar, located just below the ribbon, displays the most 
used options for the element, as shown in Figure 2–3. Some of 
these options are also found in the Properties palette.

Figure 2–3

Properties Palette

The Properties palette displays the current element’s family and 
type in the Type Selector. Click the Type Selector to expand the 
list of available families and types. In the lower part of the 
properties palette you can modify parameters for the selected 
object, as shown in Figure 2–4.

Some parameters are 
only available when you 
are editing an element. 
These parameters are 
grayed out when you 
are creating an element.

Figure 2–4

• Changes in the palette do not take effect until you click  
or move the cursor away from the palette.

Type Selector
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• The Properties palette can be floated and moved around the 
interface. You can also dock it on top of other browsers and 
then switch between them using the tabs at the bottom of the 
palette, as shown in Figure 2–5. 

To dock the palette, 
drag the titlebar over the 
titlebar of the other 
browser.

Figure 2–5

The Properties palette can be toggled on and off using the 
following methods:

• Right-click and select Properties in the contextual menu.

• In the Modify tab>Properties panel click  (Properties).

• In the View tab, expand  (User Interface), and select 
Properties.

• Use the shortcut by pressing <P> twice.

Drawing Aids As soon as you start drawing in the software, three drawing aids 
display: alignment lines, temporary dimensions, and snaps. 
These are available with most drawing and many modification 
commands.

Alignment Lines

Dashed alignment lines display as soon as you select your first 
point, as shown in Figure 2–6. They help keep lines horizontal, 
vertical, or at a specified angle. They also line up with the implied 
intersections of walls and other elements.

Figure 2–6
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• Hold <Shift> to force the alignments to be orthogonal (90 
degree angles only).

Temporary Dimensions

Along with alignment lines, temporary dimensions display as you 
draw to help place linear elements at the correct length, angle 
and location, as shown in Figure 2–7.

You can type in the 
dimension, move the 
cursor until you see the 
dimension you want, or 
place the element and 
then modify the 
dimension as required.

Figure 2–7

• For Imperial measurements (feet and inches), the software 
understands a default of feet. For example, when you type 4 
and press <Enter>, it assumes 4’-0”.For a distance such as 
4’-6”, you can type any of the following: 4’-6”, 4’6, 4-6, or 4 6 
(the numbers separated by a space). To indicate distances 
less that one foot, type the inch mark (”) after the distance, or 
enter 0, a space, and then the distance.

• The increments displayed for temporary dimensions change 
as you zoom in or out on the elements. These dimension 
snap increments are for both linear and angular dimensions, 
and can be set in the Snaps dialog box.

• Temporary dimensions disappear as soon as you finish 
drawing linear elements. If you want to make them 
permanent, select the control shown in Figure 2–8.

Dimensions are a 
powerful tool to help 
create and annotate the 
model.

Figure 2–8

• The size of the temporary dimensions, in pixels, can be set in 
the Options dialog box on the Graphics tab.
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Snaps

Snaps are key points that help you reference existing elements 
to exact points when drawing, as shown in Figure 2–9.

Figure 2–9

They include Endpoints, Midpoints, Nearest, Work Plane Grid, 
Quadrants, Intersections, Centers, Perpendicular, Tangents, and 
Points. When you move the cursor over an element, the Snap 
symbol displays. Each snap location type displays with a 
different symbol.

• To modify the snap settings, in the Manage tab>Settings 

panel, click  (Snaps). This opens the Snaps dialog box, 
where you can set which snap points are active, as well as 
the snap distances (for dimension and angular increments). It 
also displays the keyboard shortcuts for each snap, which 
you can use to override the automatic snapping.

Reference
Planes

As you develop designs in Autodesk Revit, there are times when 
you need lines that don’t print to help you define certain 
locations. You can draw reference planes (displayed as dashed 
green lines) to host the height of sinks or to help you define the 
centerlines and paths for ductwork, as shown in Figure 2–10. 

Figure 2–10

Hint: Snap Overrides

You can use shortcut key combinations (displayed in the Snaps 
dialog box) or right-click and select Snap Overrides to 
temporarily override snap settings. Temporary overrides only 
affect a single pick but can be very helpful when there are 
snaps nearby other than the one you want to use. 
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• Reference lines display in associated views because they are 
infinite planes, and not just lines. However, reference planes 
do not display in 3D views.

How To: Sketch with Reference Planes

1. In the Architecture tab>Work Plane panel, click  (Ref 
Plane) or use the shortcut by pressing <R> and then pressing 
<P>. 

2. In the Modify | Place Reference Plane tab>Draw panel, click 

 (Line) or  (Pick Lines).

• For  (Line), select two points that define the reference 
plane. 

• For  (Pick Lines), select any linear element and a 
reference plane is created that matches the length of that 
element.

• In the Options Bar, the Offset field enables you to enter 
values to draw the reference plane at a specified distance 
from a selected point. For example, set Offset to 10’-0" 
and select the end points of an existing wall to create a 
reference plane 10’-0" away. You can also use Offset with 
Pick Lines. 

3. When you have created all of the required reference planes, 

end the command by clicking  (Modify) or by using one of 
the other options.

• To change the length of a reference plane, drag the circle at 
either end.

• You can name reference planes to keep track of their 
purpose. This also enables you to use a reference plane as a 
work plane when creating or placing other elements in the 
project. Select the reference plane and in the Properties 
palette, in the Identity Data area, enter a name, as shown in 
Figure 2–11. 

Figure 2–11
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Draw Tools MEP tools (i.e., ducts, pipes, and conduits) are strictly straight, 
linear elements that are automatically connected to elbows or 
tees. However, if you are working with walls (as shown in 
Figure 2–12) or lines used in details, legends, and schematic 
drawings, additional tools are available. These tools display in 
the contextual Ribbon, and vary according to the element being 
drawn.

Figure 2–12

• Two styles of tools are available: one where you draw the 
element using a geometric form, and another where you pick 
an existing element (such as a line, face, or wall) as the basis 
for the new element’s geometry.

How To: Draw Linear Elements

1. Start the command you want to use, such as  (Wall).
2. In the contextual tab>Draw panel, select a drawing tool, such 

as  (Line), as shown in Figure 2–13. Select points to 
define the elements using other drawing aids, such as 
temporary dimensions, alignment lines, and snaps.

You can change from 
one Draw tool shape in 
the middle of a 
command.

Figure 2–13

 (Pick Face) is used 
with conceptual mass 
elements and is only 
available in a 3D view.

• Use  (Pick Lines) to create an element by selecting an 
existing wall, line or edge. This is often used with an offset 
distance to add the element a specified distance away 
from the selected element.

3. Finish the command. You can click  (Modify), press <Esc> 
twice, or right-click and select Cancel twice.
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Draw Tools

Line Draws a straight linear element defined by the 
first and last points. If Chain is enabled, you 
can continue selecting end points for multiple 
segments.

Rectangle Draws four linear elements defined from two 
opposing corner points. You can adjust the 
dimensions after selecting both points.

Inscribed 
Polygon

Draws a polygon inscribed in a hypothetical 
circle with the number of sides specified in the 
Options Bar.

Circumscribed 
Polygon

Draws a polygon circumscribed around a 
hypothetical circle with the number of sides 
specified in the Options Bar.

Circle Draws a circular linear element defined by a 
center point and radius.

Start-End-
Radius Arc

Draws a curved linear element defined by a 
start, end, and radius of the arc. The outside 
dimension shown is the included angle of the 
arc. The inside dimension is the radius.

Center-ends Arc Draws a curved linear element defined by a 
center, radius, and included angle. The 
selected point of the radius also defines the 
start point of the arc.

Tangent End 
Arc

Draws a curved linear element tangent to 
another element. Select an end point for the 
first point, but do not select the intersection of 
two or more elements. Then select a second 
point based on the included angle of the arc.

Fillet Arc Draws a curved linear element defined by two 
other linear elements and a radius. Because it 
is difficult to select the correct radius by 
clicking, this command automatically moves to 
edit mode. Select the dimension and then 
modify the radius of the fillet.

Spline Draws a curved linear element based on 
selected points. The curve does not actually 
touch the points (Model and Detail Lines only).

Ellipse Draws an ellipse from a primary and secondary 
axis (Model and Detail Lines only).

Partial Ellipse Draws only one side of the ellipse, like an arc. 
A partial ellipse also has a primary and 
secondary axis (Model and Detail Lines only).



Basic Drawing and Modify Tools

© 2014, ASCENT - Center for Technical Knowledge® 2–11

Pick Tools

Draw Options

When you are in Drawing mode, several options display in the 
Options Bar, as shown in Figure 2–14.

Different options display 
according to the type of 
element that is selected, 
or the command that is 
active.

Figure 2–14

• The Chain option controls how many segments are drawn in 
one process. If it is not selected, the Line and Arc tools only 
draw one segment at a time. If it is selected, you can continue 
drawing segments until you select the command again.

• The Offset field enables you to enter values to draw the linear 
elements at a specified distance from the selected points. 

• When using a radial draw tool, you can select the Radius 
option and add a radius in the edit field.

• To draw angled lines, move the cursor to the desired angle 
shown by the temporary dimensions, and type the distance 
value. The angle increments shown vary depending on how 
far in or out the view is zoomed.

Pick 
Lines

Use this option to select existing linear elements in the 
project. This is useful when you start the project from an 
imported 2D drawing.

Pick 
Face

Use this option to select the face of a 3D massing 
element (walls and 3D views only).

Pick 
Walls

Use this option to select an existing wall in the project to 
be the basis for a new sketch line (floors, ceilings, etc.).
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2.2 Editing Elements

Building design projects typically involve extensive changes to 
the positions of walls, doors, and other elements. The Autodesk 
Revit software was designed to make such changes quickly and 
efficiently. When you select an element there are a number of 
ways to change it, as shown in Figure 2–15:

When you hover the 
cursor over an element, 
a tooltip displays its 
family and type.

• Controls enable you to drag, flip, lock, and rotate the 
element.

• Temporary dimensions enable you to change the 
element’s dimensions.

• Modify commands and element-specific tools display in 
the contextual tab in the Ribbon.

• The Properties palette displays the Type Selector and 
associated parameters.

Figure 2–15

Learning Objectives

• Select elements to modify.

• Modify elements using the Ribbon, Properties, temporary 
dimensions, and controls.

• Filter selection sets.

Type Selector

Properties

Contextual Tab

Temporary dimensions

Controls (and connectors)
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• Connectors are frequently linked to controls. When a control 
is moved, the connector is moved with it. You should not 
disconnect systems when moving a control.

• To delete an element, select it and press <Delete>, right-click 

and select Delete, or in the Modify panel, click  (Delete).

• When working with temporary dimensions, the default 
location of the dimension line might not be where you need it 
to be. You can click on the circular control to move the 
witness line to another part of the element (such as a different 
layer in a multilayer wall), or drag it to a new element. In the 
example shown on the left in Figure 2–16, the dimension is 
from the center of the left wall to the selected wall. To change 
the dimension so that it touches the grid line, drag the circular 
control (also called the witness line) so that it touches the grid 
line, as shown on the right in Figure 2–16.

Figure 2–16

• The new location of a temporary dimension for an element is 
remembered as long as you are in the same session of the 
software.

Selecting
Elements

You can select elements in several ways:

• To select a single element, place the cursor on the edge of 
the element and click to select.

Hint: Nudge

Nudge enables you to move an element in short increments. 
When an element is selected, you can press one of the four 
arrow keys to move the element in that direction. The distance 
the element moves depends on how far in or out you are 
zoomed. This is very useful with annotation elements.
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• To add another element to a selection set, hold <Ctrl> and 
select another item. 

• To remove an element from a selection set, hold <Shift> and 
select the element.

• If you click and drag the cursor to window around elements, 
you have two selection options, as shown in Figure 2–17. If 
you drag from left to right, you only select the elements 
completely inside the window. If you drag from right to left, 
you select elements both inside and crossing the window.

Figure 2–17

• If several elements are on or near each other, press <Tab> to 
cycle through them before you click. If there are elements 
that might be linked to each other, such as walls that are 
connected, pressing <Tab> selects the chain of elements.

• Press <Ctrl>+<Left Arrow> to reselect the previous selection 
set. You can also right-click in the drawing window with 
nothing selected and select Select Previous.

• To select all elements of a specific type, right-click on an 
element and select Select All Instances>Visible in View or 
In Entire Project, as shown in Figure 2–18.

Figure 2–18
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Hint: Selection Options

You can control how the software selects specific elements in a 
project by toggling them on and off on Status Bar, or in any 
Ribbon tab expand the Select panel’s title as shown in 
Figure 2–19.

Figure 2–19

•  Select links: When toggled on, you can selected linked 
drawings or Autodesk Revit models. When it is toggled off 
you cannot select them when using Modify or Move.

•  Select underlay elements: When toggled on, you can 
select underlay elements. When toggled off, you cannot 
select them when using Modify or Move.

•  Select pinned elements: When toggled on, you can 
selected pinned elements. When toggled off, you cannot 
select them when using Modify or Move.

•  Select elements by face: When toggled on you can 
select elements (such as the floors or walls in an elevation) 
by selecting the interior face or selecting an edge. When 
toggled off, you can only select elements by selecting an 
edge.

•  Drag elements on selection: When toggled on, you 
can hover over an element, select it, and drag it to a new 
location. When toggled off, the Crossing or Box select mode 
starts when you press and drag, even if you are on top of an 
element. Once elements have been selected they can still 
be dragged to a new location.
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Selecting
Multiple

Elements

When multiple element types are selected, the Multi-Select 
contextual tab opens in the Ribbon, as shown in Figure 2–20. 
This gives you access to all of the Modify tools, as well as the 
Filter command. 

Figure 2–20

• The Properties palette displays tools that are common to all 
element types if they are available. You can also select just 
one type and make modifications, as shown in Figure 2–21.

Figure 2–21

Filtering Selection Sets

The Filter command enables you to specify the types of 
elements to select. For example, you might only want to select 
lighting fixtures, as shown in Figure 2–22.

Figure 2–22
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How To: Filter a Selection Set

1. Select everything in the required area.
2. in the Modify | Multi-Select tab>Selection panel, or in the 

Status Bar, click  (Filter). The Filter dialog box opens, as 
shown in Figure 2–23.

The Filter dialog box 
displays all types of 
elements in the original 
selection.

Figure 2–23

3. Click  to clear all of the options and then 
select the element types that you want included in the 
selection.

4. Click . The selection set is now limited to the 
elements you specified.

• In the Status Bar, the number of elements selected displays 
beside the Filter icon, as shown in Figure 2–24. You can also 
see the number of selected elements in the Properties 
palette.

Figure 2–24
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2.3 Working with Basic Modify 
Tools

The Autodesk Revit software contains controls and temporary 
dimensions that enable you to edit elements. Additional 
modifying tools can be used with individual elements or any 
selection of elements. They are found in the Modify tab>Modify 
panel, as shown in Figure 2–25, and in contextual tabs.

Figure 2–25

• The Move, Copy, Rotate, Mirror, and Array commands are 
covered in this topic. Other tools are covered later.

• For most modify commands, you can either select the 
elements and start the command, or start the command, 
select the elements, and press <Enter> to finish the selection 
and move to the next step in the command.

Moving
and Copying

Elements

The Move and Copy commands enable you to select the 
element(s) and move or copy them from one place to another. 
You can use alignment lines, temporary dimensions, and snaps 
to help place the elements, as shown in Figure 2–26.

Figure 2–26

Learning Objectives

• Move and copy elements.

• Rotate elements around the center or an origin.

• Mirror elements by picking an axis or by drawing an axis.

• Create Linear and Radial Arrays of elements.
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How To: Move or Copy Elements

1. Select the elements you want to move or copy.

You can also use the 
shortcut for the Move 
command by pressing 
<M> and pressing <V>, 
or for the Copy 
command by pressing 
<C> and pressing <O>.

2. In the Modify panel, click  (Move) or  (Copy). A 
boundary box displays around the selected elements.

3. Select a move start point on or near the element.
4. Select a second point. Use alignment lines and temporary 

dimensions to help place the elements.
5. When you are finished, you can start another modify 

command using the elements that remain selected, or switch 
back to Modify to end the command.

• If you start the Move command and hold <Ctrl>, the elements 
are copied.

Move/Copy Elements

The Move and Copy commands have several options that 
display in the Options Bar, as shown in Figure 2–27. 

Figure 2–27
 

• These commands only work within the current view, not 
between views or projects. To copy between views or 

projects, use  (Copy to Clipboard) and  (Paste).

Constrain Restricts the movement of the cursor to horizontal or 
vertical, or along the axis of an item that is at an angle. This 
keeps you from selecting a point at an angle by mistake. 
Constrain is off by default.

Disjoin 
(Move only)

Breaks any connections between the elements being 
moved and other elements. If Disjoin is on, the elements 
move separately. If it is off, the connected elements also 
move or stretch. Disjoin is off by default.

Multiple
(Copy only)

Enables you to make multiple copies of one selection. 
Multiple is off by default.
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Rotating
Elements

The Rotate command enables you to rotate selected elements 
around a center point or origin. You can use alignment lines, 
temporary dimensions, and snaps to help specify the center of 
rotation and the angle. You can also create copies of the element 
as it is being rotated.

How To: Rotate Elements

1. Select the element(s) you want to rotate.

2. In the Modify panel, click  (Rotate) or use the shortcut by 
pressing <R> and pressing <O>.

3. The center of rotation is automatically set to the center of the 
element or group of elements, as shown on the left in 
Figure 2–29. To change the center of rotation, as shown on 
the right in Figure 2–29, use the following:

• Drag the  (Center of Rotation) control to a new point.

• In the Options Bar, next to Center of rotation, click  
and use snaps to move it to a new location.

• Press the <Spacebar> to select the center of rotation and 
click to move it to a new location.

Hint: Pinning Elements

If you do not want elements to be moved, you can pin them in 
place, as shown in Figure 2–28. Select the elements and in the 

Modify tab, in the Modify panel, click  (Pin). Pinned 
elements can be copied, but not moved. If you try to delete a 
pinned element, a warning dialog displays reminding you that 
you must unpin the element before the command can be 
started.

Figure 2–28

Select the element and click  (Unpin) or use the shortcut by 
pressing <U> and pressing <P> to free it.
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Figure 2–29

• To start the Rotate command with an automatic prompt to 
select the center of rotation, select the elements first and 
type R3.

4. In the Options Bar, specify if you want to make a Copy (select 
Copy option), type an angle in the Angle field (as shown in 
Figure 2–30), and press <Enter>. You can also specify the 
angle on screen.

To specify the angle on 
screen, select a point for 
the rotate start ray (the 
reference line for the 
rotation angle). Then 
select a second point, 
using the temporary 
dimension to help you 
set the angle.

Figure 2–30

5. The rotated element(s) remain highlighted, enabling you to 
start another command, or return to Modify to finish.

• The Disjoin option breaks any connections between the 
elements being rotated and other elements. If Disjoin is on 
(selected), the elements rotate separately. If it is off (cleared), 
the connected elements also move or stretch. Disjoin is off 
by default.

Mirroring
Elements

The Mirror command enables you to mirror elements about an 
axis defined by a selected element, as shown in Figure 2–31, or 
by selected points.

Figure 2–31
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How To: Mirror Elements

1. Select the element(s) to mirror.
2. In the Modify panel, select the method you want to use:

• Click  (Mirror - Pick Axis) or use the shortcut by 
pressing <M> twice. This prompts you to select an 
element as the Axis of Reflection (mirror line).

• Click  (Mirror - Draw Axis) or use the shortcut by 
pressing <D> and pressing <M>. This prompts you to 
select two points to define the axis about which the 
elements mirror.

3. The new mirrored element(s) remain highlighted, enabling 
you to start another command, or return to Modify to finish.

• By default, the original elements that were mirrored remain. 
To delete the original elements, clear the Copy option in the 
Options Bar.

Creating Linear
and Radial

Arrays

The Array command creates multiple copies of selected 
elements in a linear or radial pattern, as shown in Figure 2–32. 
For example, you can array a row of columns to create a row of 
evenly spaced columns on a grid, or array a row of parking 
spaces. The arrayed elements can be grouped or placed as 
separate elements.

• A linear array creates a straight line pattern of elements, 
while a radial array creates a circular pattern around a center 
point.

Figure 2–32

Hint: Scale

The Autodesk Revit software is designed with full-size 
elements. Therefore, not much can be scaled. However, you 

can use  (Scale) in reference planes, images, and imported 
files from other programs.

Linear Array

Radial Array
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How To: Create a Linear Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array). 

3. In the Options Bar, click  (Linear).
4. Specify the other options as required.
5. Select a start point and an end point to set the spacing and 

direction of the array. The array is displayed.
6. If the Group and Associate option is selected, you are 

prompted again for the number of items, as shown in 
Figure 2–33. Type a new number or click on the screen to 
finish the command.

Figure 2–33

• To make a linear array in two directions, you need to array 
one direction first, select the arrayed elements, and then 
array them again in the other direction.

Array Options

In the Options Bar, set up the Array options for Linear Array 
(top of Figure 2–34) or Radial Array (bottom of Figure 2–34).

Figure 2–34

Group and 
Associate

Creates an array group element out of all arrayed elements. 
Groups can be selected by selecting any elements in the 
group.

Number Specifies how many instances you want in the array.

Move To: 2nd specifies the distance or angle between the center 
points of the two elements.

Last specifies the overall distance or angle of the entire 
array.
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How To: Create a Radial Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array).

3. In the Options Bar, click  (Radial).

4. Drag  (Center of Rotation) or use  to the move the 
center of rotation to the appropriate location, as shown in 
Figure 2–35.

Remember to set the 
Center of Rotation 
control first, because it 
is easy to forget to move 
it before specifying the 
angle.

Figure 2–35

5. Specify the other options as required.
6. In the Options Bar, type an angle and press <Enter>, or 

specify the rotation angle by selecting points on the screen.

Modifying Array Groups

When you select an element in an array that has been grouped, 
you can change the number of instances in the array, as shown 
in Figure 2–36. For radial arrays you can also modify the 
distance to the center.

Figure 2–36

Constrain Restricts the direction of the array to only vertical or 
horizontal (Linear only).

Angle Specifies the angle (Radial only).

Center of 
rotation 

Specifies a location for the origin about which the elements 
rotate (Radial only).
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• Dashed lines surround the element(s) in a group, and the XY 
control lets you move the origin point of the group

If you move one of the elements within the array group, the other 
elements move in response based on the distance and/or angle, 
as shown in Figure 2–37 

 
Figure 2–37

• To remove the array constraint on the group, select all of the 
elements in the array group and, in the Modify contextual 

tab>Group panel, click  (Ungroup).

• If you select an individual element in an array and click 

(Ungroup), the element you selected is removed from the 
array, while the rest of the elements remain in the array 
group.

• You can use  (Filter) to ensure that you are selecting only 
Model Groups. 
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Practice 2a Work with Basic Modify Tools

Estimated time for 
completion: 15 minutes

In this practice you will use temporary dimensions and controls 
to modify the location of elements. You will than move and copy 
elements, as shown in Figure 2–38.

Figure 2–38

Task 1 - Use temporary dimensions and controls to modify 
elements.

1. In the C:\Autodesk Revit 2015 MEP Fundamentals Class 
Files\Basics\ folder, open Simple-Building.rvt.

2. Select the AHU-1 unit in the hall of the building.

3. Zoom in to the connectors/controls. Select the temporary 
dimension above the unit and change the distance to 3’-0", 
as shown in Figure 2–39.

Learning Objectives

• Use various drawing aids to modify the location of 
elements.

• Move and copy elements.
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The temporary 
dimensions work with 
the walls in this project 
because they are part of 
the project, not linked in.

Figure 2–39

4. The unit moves and the ducts move with it because the 
connectors control the location of the duct fittings and ducts. 

5. Pan over to the lower left room in the building. Select the tag 
that overlaps the ductwork as shown on the left in 
Figure 2–40.

6. In the Options Bar, select Leader.

7. Use the Move control to move the tag outside the room to a 
position in which it is not overlapping anything as shown on 
the right in Figure 2–40.

Figure 2–40

8. Zoom out to display the entire building. (Hint: Double-click the 
mouse wheel.)

9. Select the blue horizontal duct and use the Drag control to 
lengthen the duct so that it reaches into the room on the far 
right.

10.Click in empty space to clear the duct selection.
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11. The endcap of the duct did not move, as shown in 
Figure 2–41. Select and drag it to the endpoint of the duct.

Figure 2–41

12.Undo the change in duct length.

13.Select the duct endcap.

Because there is only 
one type of element 
selected, the specific 
type of element is 
displayed in the 
contextual tab.

14. In the Modify | Duct Fittings tab>Modify panel, click 

 (Move).

15.For the base point, select the duct endpoint.

16.Move it into the other room again. This time the endcap 
moves and the duct, which has a connector to the endcap, 
resizes as well.

17.Save the project.

Task 2 - Copy elements.

1. Select the two Air Terminals, associated ductwork, and tags, 
as shown in Figure 2–42.

Figure 2–42



Basic Drawing and Modify Tools

© 2014, ASCENT - Center for Technical Knowledge® 2–29

Because there is more 
than one type of 
element selected the 
contextual tab displays 
as Multi-Select.

2. In the Modify | Multi-Select tab>Modify panel, click

 (Copy).

3. In the Options Bar, select the Multiple option.

4. For the base point, select the endpoint of one of the vertical 
ducts as shown in Figure 2–43.

5. Copy the elements into the last room, as shown in 
Figure 2–43.

Figure 2–43

To end a command, you 
can also right-click and 
select Cancel twice, or 
in the Select panel, click 

(Modify). Some 
commands require you 
to cancel twice, while 
others end after one 
cancel command.

6. Press <Esc> twice to end the command 

7. Save the project.

Base point for 

Base 
point
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2.4 Working with Additional 
Modify Tools

As you work on a project, some additional tools on the Modify 
tab>Modify panel, as shown in Figure 2–44, can help you with 
placing, modifying, and constraining elements. Align can be 
used with a variety of elements, while Split Element, 
Trim/Extend, and Offset can only be used with linear elements.

Figure 2–44

Aligning
Elements

The Align command enables you to line up one element with 
another. Most elements in the Autodesk Revit software can be 
aligned. For example, you can line up an air terminal with ceiling 
grids, as shown in Figure 2–45.

 
Figure 2–45

Learning Objective

• Use modify tools to align, split, trim, and offset walls and 
other elements.
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How To: Align Elements

1. In the Modify tab>Modify panel, click  (Align) or use the 
shortcut by pressing <A> and then pressing <L>.

2. Select a line or point on the element that is going to remain 
stationary. For walls, press <Tab> to select the correct wall 
face.

3. Select a line or point on the element to be aligned. The 
second element moves into alignment with the first one.

• The Align command works in both plan and elevation views.

• The Align command also works in 3D views. Ensure you 
select the correct component of the elements to align. For 
example, to line up two windows vertically select the side of 
the frame of each window. Zoom in if needed.

• You can lock alignments so that the elements move together 
if either one is moved. Once you have created the alignment, 
a padlock is displayed. Click on the padlock to lock it, as 
shown in Figure 2–46.

Locking elements 
enlarges the size of the 
project file, so use this 
option carefully.

Figure 2–46

• Select the Multiple Alignment option to select multiple 
elements to align with the first element, as shown in 
Figure 2–47. You can also hold <Ctrl> to make multiple 
alignments.

• For walls, you can specify if you want the command to prefer 
Wall centerlines, Wall faces, Center of core, or Faces of 
core, as shown in Figure 2–47. The core refers to the 
structural members of a wall as opposed to facing materials, 
such as sheetrock.

Figure 2–47
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Splitting Linear
Elements

The Split Element command enables you to break a linear 
element at a specific point. You can use alignment lines, snaps, 
and temporary dimensions to help place the split point. After you 
have split the linear element, you can use other editing 
commands to modify the two parts, or change the type of one 
part, as shown with walls in Figure 2–48.

Figure 2–48

• There are two commands:  (Split Element) and  (Split 
with Gap).

How To: Split Linear Elements

1. In the Modify tab>Modify panel, click  (Split Element) or 
use the shortcut by pressing <S> and pressing <L>.

2. In the Options Bar, select or clear the Delete Inner Segment 
option.

3. Move the cursor to the point you want to split and select the 
point.

4. Repeat for any additional split locations.
5. Modify the elements that were split, as required.

• The Delete Inner Segment option is used when you select 
two split points along a linear element. When the option is 
selected, the segment between the two split points is 
automatically removed.
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•  (Split with Gap) splits the linear element at the point you 
select (as shown in Figure 2–49), but also creates a Joint 
Gap specified in the Options Bar.

This command is 
typically used with 
structural precast slabs.

Figure 2–49

Trimming and
Extending

There are three trim/extend methods that you can use with linear 
elements: Trim/Extend to Corner, Trim/Extend Single 
Element, and Trim/Extend Multiple Elements.

• When selecting elements to trim, click the part of the element 
that you want to keep. The opposite part of the line is then 
trimmed.

How To: Trim/Extend to Corner

1. In the Modify tab>Modify panel, click  (Trim/Extend to 
Corner) or use the shortcut by pressing <T> and pressing 
<R>.

2. Select the first linear element on the side you want to keep.
3. Select the second linear element on the side you want to 

keep, as shown in Figure 2–50.

Figure 2–50

How To: Trim/Extend a Single Element

1. In the Modify tab>Modify panel, click  (Trim/Extend Single 
Element).

2. Select the cutting or boundary edge.

Split

Split with Gap

Pick 1

Pick 2
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3. Select the linear element to be trimmed or extended, as 
shown in Figure 2–51.

Figure 2–51

How To: Trim/Extend Multiple Elements

1. In the Modify tab>Modify panel, click  (Trim/Extend 
Multiple Elements).

2. Select the cutting or boundary edge.
3. Select the linear elements that you want to trim or extend by 

selecting one at a time, or by using a crossing window, as 
shown in Figure 2–52. For trimming, select the side you want 
to keep.

Figure 2–52

• You can click in an empty space to clear the selection and 
select another cutting edge or boundary.

Pick 1

Pick 2

Pick 3

Pick 2

Pick 1
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Offsetting
Elements

The Offset command is an easy way of creating parallel copies 
of linear elements at a specified distance, as shown in 
Figure 2–53. Walls, beams, braces, and lines are among the 
elements that can be offset.

Figure 2–53

• If you offset a wall that has a door or window embedded in it, 
the elements are copied with the offset wall.

The offset distance can be set by typing the distance (Numerical 
method shown in Figure 2–54) or by selecting points on the 
screen (Graphical method).

Figure 2–54

How To: Offset using the Numerical Method

The Copy option (which 
is on by default) makes 
a copy of the element 
being offset. If this 
option is not selected, 
the Offset command 
moves the element the 
set offset distance.

1. In the Modify tab>Modify panel, click  (Offset) or use the 
shortcut by pressing <O> and pressing <F>.

2. In the Options Bar, select the Numerical option.
3. In the Options Bar, type the desired distance in the Offset 

field.
4. Move the cursor over the element you want to offset. A 

dashed line previews the offset location. Move the cursor to 
flip the sides, as required.

5. Click to create the offset.
6. Repeat Steps 4 and 5 to offset other elements by the same 

distance, or to change the distance for another offset.
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• With the Numerical option, you can select multiple 
connected linear elements for offsetting. Hover the cursor 
over an element and press <Tab> until the other related 
elements are highlighted, as shown in Figure 2–55. Select 
the element to offset all of the elements at the same time.

Figure 2–55

How To: Offset using the Graphical Method

1. Start the Offset command.
2. In the Options Bar, select the Graphical option.
3. Select the linear element to offset.
4. Select two points that define the distance of the offset and 

which side to apply it. You can type an override in the 
temporary dimension for the second point.

• When working with MEP elements, the offset element might 
not automatically connect to other nearby elements, as 
shown on the left in Figure 2–56. To form the connection, 
drag the end of the new element away from the other element 
and then back again. It should connect as shown on the right 
in Figure 2–56. 

Figure 2–56
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Hint: Hiding Elements in Views

As you are working, you can hide individual elements or entire 
categories of elements to clarify the display. They remain 
hidden until you display them again. Hidden elements do not 
print.

• Select the element(s) you want to hide, right-click and select 
Hide in view>Elements or Hide in view>Category.

• The Elements option hides only the elements that you 
selected, while the Category option hides all elements in 
that category. For example, you can select one grid line and 
use Hide in view>Category to hide all of the grid lines.

• To display the elements or category again, in the View 

Control Bar, click  (Reveal Hidden Elements). The 
border and all hidden elements are displayed in magenta, 
while displayed elements in the view are grayed out, as 
shown in Figure 2–57. Select the hidden elements you want 
to restore, right-click, and select Unhide in View>Elements 
or Unhide in View>Category or in the Modify | contextual 

tab> Reveal Hidden Elements panel click  (Unhide 

Element) or  (Unhide Category).

Figure 2–57

When you are finished, in the View Control Bar, click  (Close 
Reveal Hidden Elements) or, in the Modify | contextual tab> 

Reveal Hidden Elements panel click  (Toggle Reveal 
Hidden Elements Mode).
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Practice 2b Work with Additional Modify 
Tools

Estimated time for 
completion: 10 minutes

In this practice you will align air terminals to the ceiling grid, as 
shown in Figure 2–58.

Figure 2–58

Task 1 - Align and rotate elements.

1. In the C:\Autodesk Revit 2015 MEP Fundamentals Class 
Files\Basics\ folder, open Simple-Building-1.rvt.

2. In the Project Browser, open the view Mechanical>HVAC>
Ceiling Plans: 1- Ceiling Mech.

3. The air terminal locations do not match the ceiling grids as 
shown in Figure 2–59.

Learning Objective

• Align and rotate elements.
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Figure 2–59

4. Zoom in on the room to the left.

5. In the Modify tab>Modify panel, click  (Align).

6. Select a vertical grid line and then the edge of the air terminal 
as shown in Figure 2–60. The air terminal now lines up with 
the vertical pattern of the ceiling grid.

Figure 2–60

7. Repeat the process with the air terminal and the horizontal 
grid location. Select the edge of the grid line first and then the 
air terminal.
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8. Repeat the process in both rooms so that the air terminals 
line up with the grids shown in Figure 2–61.

Figure 2–61

9. In the last room the ceiling grid is rotated. In this case you 
need to rotate the air terminals as well.

10.Select one of the air terminals in the room with the rotated 
ceiling grid.

11. In the Modify | Air Terminals tab>Modify panel, click

 (Rotate).

12. In the Options Bar, set the angle to 45.

13.Use the Align command to move the air terminal to match 
the ceiling grid location. First you will select the ceiling grid 
line and then the edge of the air terminal.

14.The flex duct moves with the air terminal as shown 
Figure 2–62.

Figure 2–62
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15.Without rotating the air terminal, click  (Align).

16.Select a grid line close to one of the other air terminals and 
then select the edge of the air terminal. The air terminal 
moves to touch the grid line and also rotates to match the 
angle of the grid line.

17.Finish aligning all of the air terminals in this room. The exact 
location is up to you.

18.Zoom out to display the entire building.

19.Switch to the Mechanical>HVAC>Floor Plans>1 - Mech view. 
The rotated terminals and flex duct display correctly in this 
view as well as shown in Figure 2–63.

Figure 2–63

20.Zoom out to display the entire building.

21.Save and close the model.
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Chapter Review Questions

1. What is the purpose of an alignment line?

a. Displays when the new element you are placing or 
drawing is aligned with the grid system.

b. Indicates that the new element you are placing or drawing 
is aligned with an existing object.

c. Displays when the new element you are placing or 
drawing is aligned with a selected tracking point.

d. Indicates that the new element is aligned with true north 
rather than project north.

2. When you are drawing (not editing) a linear element, how do 
you edit the temporary dimension, as that shown in 
Figure 2–64?

Figure 2–64

a. Select the temporary dimension and enter a new value.

b. Type a new value and press <Enter>.

c. Type a new value in the Distance/Length box in the 
Options Bar and press <Enter>.

3. How do you select all lighting fixture types, but no other 
elements in a view?

a. In the Project Browser, select the Lighting Fixture 
category.

b. Select one lighting fixture, right-click and select Select All 
Instances>Visible in View.

c. Select all of the objects in the view and use  (Filter) to 
clear the other categories.

d. Select one lighting fixture, and click  (Select Multiple) 
in the Ribbon.
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4. What are the two methods for starting  (Move) or 

(Copy)?

a. Start the command first and then select the objects, or 
select the objects and then start the command.

b. Start the command from the Modify tab, or select the 
object and then select Move or Copy from the shortcut 
menu.

c. Start the command from the Modify tab, or select the 
objects and select Auto-Move.

d. Use the Move/Copy command or Cut/Copy and Paste 
using the Clipboard.

5. Where do you change the type for a selected element, as 
shown in Figure 2–65?

Figure 2–65

a. In the Modify | <contextual> tab> Properties panel, click 

(Type Properties) and select a new type in the dialog 
box.

b. In the Options Bar, click .

c. Select the dynamic control next to the selected element 
and select a new type in the drop-down list.

d. In Properties, select a new type in the Type Selector 
drop-down list.
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6. Both  (Rotate) and  (Array) with  (Radial) have a 
center of rotation that defaults to the center of the element or 
group of elements you have selected. How do you move the 
center of rotation to another point as shown in Figure 2–66? 
(Select all that apply.)

Figure 2–66

a. Select the center of rotation and drag it to a new location.

b. In the Options Bar, click  and select the new point.

c. In the Modify tab> Placement panel, click  (Center) and 
select the new point.

d. Right-click and select Snap Overrides>Centers and 
select the new point.

7. Which command would you use to break part of a duct so 
that you can change the duct type?

a. .  (Align)

b.  (Split)

c. .  (Trim)

d.  (Offset)
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8. All of the Trim commands can also be used to extend 
elements.

a. True

b. False

9. In the Mirror command, how do you remove the original 
element(s) if you do not want to keep them?

a. You must delete them separately from the command.

b. Use the Demolish tool.

c. Clear the Copy option in the Options Bar.

d. Select the Delete Original option in the Options Bar.

10.Which command do you use if you want two pipes that are 
not touching to come together, as shown in Figure 2–67?

Figure 2–67

a.  (Edit Joins)

b.  (Trim/Extend to Corner)

c.  (Join Geometry)

d.  (Edit Profile)

Before After
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Command Summary

Button Command Location
Draw Tools

Line • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Rectangle • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Inscribed 
Polygon

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Circumscribed 
Polygon

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Circle • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Start-End-Radiu
s Arc

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Center-ends 
Arc

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Tangent End 
Arc

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Fillet Arc • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Spline • Ribbon: Modify | Place Lines, Place 
Detail Lines, and various boundary 
sketches>Draw panel

Ellipse • Ribbon: Modify | Place Lines, Place 
Detail Lines, and various boundary 
sketches>Draw panel

Ellipse Arc • Ribbon: Modify | Place Lines, Place 
Detail Lines, and various boundary 
sketches>Draw panel

Pick Lines • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Pick Faces • Ribbon: Modify | Place Wall> Draw 
panel

Pick Walls • Ribbon: Modify | (various boundary 
sketches)>Draw panel

Modify Tools

Align • Ribbon: Modify tab>Modify panel

• Shortcut: <A> and <L>

Array • Ribbon: Modify tab>Modify panel

• Shortcut: <A> and <R>

Copy • Ribbon: Modify tab>Modify panel

• Shortcut: <C> and <O>

Copy to 
Clipboard

• Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctrl>+<C>



Basic Drawing and Modify Tools

© 2014, ASCENT - Center for Technical Knowledge® 2–47

Delete • Ribbon: Modify tab>Modify panel

• Shortcut: <D> and <E>

Mirror - Draw 
Axis

• Ribbon: Modify tab>Modify panel

• Shortcut: <D> and <M>

Mirror - Pick 
Axis

• Ribbon: Modify tab>Modify panel

• Shortcut: <M> and <M>

Move • Ribbon: Modify tab>Modify panel

• Shortcut: <M> and <V>

Offset • Ribbon: Modify tab>Modify panel

• Shortcut: <O> and <F>

Paste • Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctrl>+<V>

Pin • Ribbon: Modify tab>Modify panel

• Shortcut: <P> and <N>

Rotate • Ribbon: Modify tab>Modify panel

• Shortcut: <R> and <O>

Scale • Ribbon: Modify tab>Modify panel

• Shortcut: <R> and <E>

Split Element • Ribbon: Modify tab>Modify panel

• Shortcut: <S> and <L>

Split with Gap • Ribbon: Modify tab>Modify panel

Trim/Extend to 
Corner

• Ribbon: Modify tab>Modify panel

• Shortcut: <T> and <R>

Trim/Extend 
Multiple 
Elements

• Ribbon: Modify tab>Modify panel

Trim/Extend 
Single Element

• Ribbon: Modify tab>Modify panel

Unpin • Ribbon: Modify tab>Modify panel

• Shortcut: <U> and <P>

Select Tools

Drag elements 
on selection

• Ribbon: All tabs>Expanded Select 
panel

• Status Bar

Filter • Ribbon: Modify | Multi-Select tab>
Filter panel>Filter

• Status Bar

Select Elements 
By Face

• Ribbon: All tabs>Expanded Select 
panel

• Status Bar

Select Links • Ribbon: All tabs>Expanded Select 
panel

• Status Bar
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Select Pinned 
Elements

• Ribbon: All tabs>Expanded Select 
panel

• Status Bar

Select Underlay 
Elements

• Ribbon: All tabs>Expanded Select 
panel

• Status Bar

Selection Sets: 
Add to 
Selection

• Ribbon: Edit Selection Set tab>Edit 
Selection panel 

Selection Sets: 
Load

• Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Selection Sets: 
Edit

• Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Selection Sets: 
Remove from 
Selection

• Ribbon: Edit Selection Set tab>Edit 
Selection panel 

Selection Sets: 
Save

• Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel




