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Chapter 2 - Sketching, Constraining and Dimensioning

Chapter 2 - Sketching, Constraining,
and Dimensioning

INTRODUCTION

Most 3D parts in Autodesk Inventor start from a 2D sketch. This chapter first provides a look at
the application options for creating a part file and sketching. It then covers the three steps in
creating a 2D parametric sketch: sketching a rough 2D outline of a part, applying geometric
constraints, and then adding parametric dimensions. Lastly, you learn how to use 2D AutoCAD
data in a sketch.

OBJECTIVES

After completing this chapter, you will be able to do the following:

J

o O o o O d

Change the part and sketch Application Options to meet your needs
Sketch an outline of a part

Create geometric constraints to a sketch to control design intent
Use construction geometry to help constrain a sketch

Dimension a sketch

Change a dimension’s value in a sketch

Insert AutoCAD DWG data into a part’s sketch
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PART AND SKETCH APPLICATION OPTIONS

Before you start a new part, examine the part and sketch options in Autodesk Inventor that will
affect how the part file will be created and how the sketching environment will look and act.
While learning Autodesk Inventor, refer back to these option settings to determine which ones

work best for you—there is no right or wrong settings.

Part Options

You can customize Autodesk Inventor Part options to your preferences. Click the Inventor
Application Menu > Options button, and click on the Part tab, as shown in the following image.
Descriptions of a couple of the most common Part options follow. For more information about the
Application Options consult the help system. These settings are global—they will affect all active

and new Autodesk Inventor documents.

Application Options

)

Sketch on y-z plane

Sketch on x-z plane

[¥] Auto-hide in-line work features
V| Auto-consume work features and surface features
[ ] pisplay extended information after feature node name in browser
3D grips
| Enable 3D grips

V| Display grips on selection

Dimensional constraints Geometric constraints
Never relax Q) Never break
@) Relax if no equation Always break
Always relax Prompt
Prompt
Figure 2-1

A common option that you may want to change is the first option; Sketch on New Part Creation.

| General I Save l File l Colors | Display [ Hardware | Prompts | Drawing ] Notebook | Sketch
Part | iFeature Assembly Content Center
Sketch on new part creation Construction
@) No new sketch | Opaque surfaces
Sketch on x-y plane | Enable Construction Environment

This option controls if and how a sketch is created when a part file is created.

No new sketch

When checked, Inventor does not set a sketch plane when you create a new part (this is the

default setting).

Sketch on x-y plane

When checked, Inventor sets the x-y plane as the current sketch plane when you create a new

part.

38
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Sketch on y-z plane
When checked, Inventor sets the y-z plane as the current sketch plane when you create a new
part.

Sketch on x-z plane
When checked, Inventor sets the x-z plane as the current sketch plane when you create a new
part.

Sketch Options

Autodesk Inventor sketching options can be customized to your preferences. Click Inventor
Application Menu > Options, and then click on the Sketch tab, as displayed in the following
image. Descriptions of the most common Sketch options follow. For more information about the
Application Options consult the help system. These settings are global, and all of them affect
currently active Autodesk documents and Autodesk Inventor documents you open in the future.

Application Options ﬁ

. Part I iFeature I Assembly ’ Content Center |
General I Save l File l Colors I Display l Hardware | Prompts [ Drawing l Notebook | Sketch
2D Sketch

Constraint Settings Display
[ Settings... | [ Grid lines

| Minor grid lines
Spline fit method

| Axes
) i [] Coordinate system indicator
AutoCAD
Minimum Energy - Default Tension Heads-Up Display
U [¥] Enable Heads-Up Display (HUD)
0 100 [ Settings...
| Snap to grid

[¥] Autoproject edges during curve creation

[ Autoproject edges for sketch creation and edit
| Look at sketch plane on sketch creation

[¥] Autoproject part origin on sketch create

[¥] Point alignment

3D Sketch
7] Auto-bend with 3D line creation

Figure 2-2
Following are descriptions of the common settings that you may want to change.

Constraint Settings
Click the Settings button to control how sketch constraints and dimensions behave.
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Display

Grid lines
Toggles both minor and major grid lines on the screen on and off. To set the grid distance, click
the Tools tab > Options panel > Document Settings command, and on the Sketch tab of the
Document Settings dialog box, change the Snap Spacing and Grid Display.

Minor grid lines
Toggles the minor grid lines displayed on the screen on and off.

Axes
Toggles the lines that represent the X and Y-axis of the current sketch on and off.

Coordinate system indicator
Toggles the icon on and off that represents the X-, Y-, and Z-axes at the 0, 0, 0 coordinates of the
current sketch.

Snap to Grid
When checked, endpoints of sketched objects snap to the intersections of the grid as the cursor
moves over them.

Autoproject edges during curve creation

When checked, and while sketching, place the cursor over an object and it will be projected onto
the current sketch. You can also toggle Autoproject on and off while sketching by right-clicking
and selecting Autoproject from the menu.

Autoproject edges for sketch creation and edit
When checked, automatically projects all of the edges that define that plane onto the sketch plane
as reference geometry when you create a new sketch.

Look at sketch plane on sketch creation and edit
When checked, automatically changes the view orientation to look directly at the new or active
sketch.

Autoproject part origin on sketch create
When checked, the parts origin point will automatically be projected when a new sketch is
created. It is recommended to keep this setting on.

Point alignment

When checked, automatically infers alignment (horizontal and vertical) between endpoints of
newly created geometry. No sketch constraint is applied. If this option is not checked, points can
still be inferred; this technique is covered later in this chapter in the Inferred Points section.

UNITS

Autodesk Inventor uses a default unit of measurement for every part and assembly file. The
default unit is set from the template file from which you created the part or assembly file. When
specifying numbers in dialog boxes with no unit, the default unit will be used. You can change
the default unit in the active part or assembly document by clicking the Tools tab > Options panel
> Document Settings button and click the Units tab as shown in the following image. The unit
system values change for all of the existing values in that file.
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r R’
Partl Document Settings ﬁ
| Standard | Units | Sketch I Modeling l Bill of Materials ] Default Tolerance |
Units
Length Time
[inch v ] [second - }
Angle Mass
[degree V] [Ibmass v]
Figure 2-3

TIP: In a drawing file, the appearance of dimensions is controlled by dimension styles.
= Drawing settings are covered in Chapter 5.

You can override the default unit for any value by entering the desired unit. If you were working
in a metric file whose unit is set to mm, for example, and you placed a 20 mm horizontal
dimension as shown in the following image on the left, and you edited the dimension to 1 in
(adding the unit) as shown in the middle image, the dimension would appear on the screen in the
default units which would be 25.4 as shown in the right image.

= 20 £ = 20 e =3 25.4 £

20 mm

(EditDimension:dO ﬁ Edit Dimension : dO ﬁ‘
b I ‘1in , ‘

Figure 2-4

When you edit a dimension, the overridden unit appears in the Edit Dimension dialog box. For
the previous example when the 25.4 mm dimension is edited, 1 in is displayed in the Edit
Dimension dialog box as shown in the following image.

= 25.4 E=

1lin

Edit Dimension: do  SNE.SN
y [

Figure 2-5

TEMPLATES

Each new file is created from a template. You can modify existing templates or add your own
templates. As you work, make note of the changes that you make to each file. You then create a
new template file or modify an existing file that contains all of the changes and save that file to
your template directory, which by default in Windows 7 is C:\Users\Public\Public Documents)
Autodesk\Inventor 2015\Templates. You can also create a new subdirectory under the templates
folder, and place any Autodesk Inventor file in this new directory. After adding an Inventor file
the new tab will appear, and it will be available as a template.
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You can use one of two methods to share template files among many users. You can modify the
location of templates by clicking the Inventor Application Menu > Options button > File tab, and
modifying the Templates location as shown in the following image. The Templates location will
need to be modified for each user who needs access to templates that are not stored in the local
location.

Default templates

Configure Default Template...

%PUBLICDOCUMENT S%\Autodesk\Inventor 2015\Templates)

Figure 2-6

You can also change the unit of measurement (inches or millimeters) for the default part and
assembly template files and set the default drawing standard (ANSI, DIN, ISO, etc.) for the
default drawing template by clicking Application Option Menu > File tab > Configure Default
Template button as shown in the previous image or click Configure Default Templates from the
My Home screen as shown in the following image on the left. Then make the changes in the
Configure Default Template dialog box as shown in the following image on the right.

More Templates r N
Configure Default Template ﬁ
{b Measurement Units - Default
B [y B0 gos g
5 v E‘ ‘E’ | BE| coe o @ Inches
Millimeters

Drawing Standard - Default
@) ANSI BSI DIN GB
GOST 1S0 JIS

Figure 2-7

You can also set the Templates location in each project file. This method is useful if you need
different template files for each project. While editing a project file, change the Templates
location in the Folder Options area. The following image shows the default location in Windows
7. The Template location in the project file takes precedence over the Templates option in the
Application Options, File tab.

= % Folder Options
(11 Design Data (Styles, etc.) = [Default]

@) Templates = [De‘gull]
[ Content Center Fifés = .\Content Center Files\,

@ Options [ C:\Users\Public\Documents\Autodesk\Inventor 2015\ Templates), ]

Figure 2-8

TIP: Template files have file extensions that are identical to other files of the same
type, but they are located in the template directory. Template files should not be used as
production files.
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CREATING A PART FILE

The first step in creating a part is to start or create a new part file in an assembly. You can use the
following methods to create a new part file:

ARl -

In the Quick Access toolbar click the down arrow on the New icon, and click Part as
shown in the following image on the left. This creates a new part file based on the default
unit as was discussed in the previous Templates section.

Click Part on the Home page as shown in the middle image.

From the Inventor Application menu click New > Part as shown in the image on the right.

Search Commands

% Assembly
@ Drawing

@ Part [} D New »

-

[
lj Create a file from ¢
(D) .
Presentation Open »
& % % Assembly
H-
EB Drawing
g Save As »
G Part
I =p Export » N

Figure 2-9

8

TIP: The default unit for the part and assembly templates and the standard for the
drawing template is set in the Application Options dialog box > File tab > Configure
Default Template.

You can also create a part file from a template that is not the default location by clicking the New
file command from one of these areas:

Quick Access toolbar as shown in the following image on the left
Inventor Application menu, as shown in the image second on the left

Get Started tab > Launch Panel as shown in the image, third from the left.
On the Home page, as shown in the image, on the right.

Or press CTRL + N.
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% H H Get Started I

o) B
O B ‘
‘ D New I} New | Open Projects

= "Te P

: m
Get Started [{elel I II(e]s [

B

Figure 2-10

The Create New File dialog box appears. Then click the desired templates folder on the left side
of the Create New File dialog box and then from the Part section on the right side of the dialog
box click on the desired part template file, as shown in the following image.

[ L Create New File
%5 {3} C:\Users\Public\Documents\Autodesk\Inventor 2015\Templates\

4 | Templates
I English

Metric
Mold Design @ m
Sheet Standard

Metal (in).ipt
(in).ipt

¥ Part — Create 2D and 3D objects

Figure 2-11

After starting a new part file using one of the previous methods, Autodesk Inventor’s screen will
change to reflect the part environment.

Sketches and Origin (Default) Planes

Before you start sketching, you select a plane on which to draw. A sketch is a plane on which 2D
objects are sketched. You can use any planar part face or work plane to create a sketch. By
default, when you create a new part file no sketch is created, and you will select an origin plane to
sketch on. You can change the default plane on which you will create the sketch by selecting the
Inventor Application Menu > Options and clicking on the Part tab. Select the sketch plane to
which new parts should default.

Each time you create a new Autodesk Inventor part or assembly file, there are three planes (XY,
YZ, and XZ), three axes (X, Y, and Z), and the center (origin) point at the intersection of the three
planes. You can use these default planes to create an active sketch. To see the planes, axes, or
center point, expand the Origin entry in the browser by clicking on the left side of the text. You
can then move the cursor over the names, and they will appear in the graphics window. The
following image on the left and the middle image illustrates the default planes, axes, and center
point. To leave the visibility of the planes or axes on, right-click in the browser while the cursor is
over the name and click Visibility from the menu. When a plane is visible you can display the
plane’s label by moving the cursor over a plane in the browser or in the graphics window as
shown in the following image on the right.
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[ Fartz
'F_'?u\-'iew: Master
= [ Origin

— [ vz Flane
— [ %z Flane
— [ %Y Flane
— Jelx axis

— Jely Axis

— ez Axis

'— <2 Center Point
Figure 2-12

Origin 3D Indicator

When working in 3D, it is common to get your orientation turned around. By default in the lower
left corner of the graphics screen, there is an XYZ axis indicator that shows the default (world)
coordinate system as shown in the following image on the left. The direction of these planes and
axes cannot be changed. The arrows are color-coded:

e Red arrow = X axis
e QGreen arrow =Y axis
e Blue arrow = Z axis

In the Application Options dialog box > Display tab, you can turn the axis indicator and the axis
labels on and off as shown in the following image on the right.

Origin 30 indicator
Show Qrigin 30 indicator
Show Origin XYZ axis labels
Figure 2-13

By default, Inventor will automatically project the origin point (0,0) when a new sketch is created
in a part file. The origin point can be used to constrain a sketch to the 0, 0 point of the sketch. If
desired, you can turn this option off by clicking the Tools tab > Application Options or the
Application Menu > Options > Sketch tab, and then uncheck Autoproject part origin on sketch
create as displayed in the following image.

[¥] Autoproject part origin on sketch create
Figure 2-14

New Sketch

By default, when you create a new part file no sketch is active. You can define a plane from the
origin folder to be the default by selecting a default plane from the Inventor Application Menu >
Options > Part tab. Issue the 2D Sketch command to create a new sketch on a planar part face or a
work plane or to activate a non-active sketch in the part. When you are in a part file that does not
have a sketch defined and when you start the 2D Sketch command, the origin planes will be
displayed in the graphics window, and you can select one of these planes to create the sketch on.
To create a new sketch or make an existing sketch active, use one of these methods:
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e Click the 3D Model tab > Sketch panel > Start 2D Sketch as shown in the following
image on the left or from the Sketch tab > Sketch panel > Start 2D Sketch. Then click a
planar face, a work plane, or an existing sketch in the browser.

e Press the S key (a keyboard shortcut) and click a planar face of a part, a work plane, or an
existing sketch in the browser.

e  While not in the middle of an operation, right-click in the graphics window, and select
New Sketch from the marking menu as shown in the middle image. Then click a planar
face, a work plane, or an existing sketch in the browser.

e While not in the middle of an operation, click a planar face of a part, a work plane, or an
existing sketch in the browser. Then right-click in the graphics window, and click 2D
Sketch from the mini-toolbar as shown in the following image on the right.

TIP: You can either start the command first, and then select a plane or you can select a
£ | plane and then start the command.

Ljcean Qe 2B
3D Model Measure = | (17 extrude ) l:'

Create Sketch
U,? N GI Undo <R ) = Revolve

Start Extrude Work Plane [ ) Hole )
2D Sketch

(I3 New Sketch )
Sketch

Figure 2-15

After creating a sketch, a Sketch entry will appear in the browser as shown in the following
image, and a Sketch tab will appear in the ribbon. By default after you have defined a sketch, the
X and Y-axes will align automatically to this plane, and you can begin to sketch.

x

(2]
T | é4
[ Part1
'F_'?u\-'iew: Master
DOrigin
2] Sketchi
O End of Part

Figure 2-16

STEP 1 — SKETCH THE 2D OUTLINE OF THE PART

As stated at the beginning of this chapter, 3D parts usually start with a 2D sketch of the outline
shape of the part. You can create a sketch with lines, arcs, circles, splines, or any combination of
these elements. The next section will cover sketching strategies, commands, and techniques.

Sketching Overview

When deciding what outline to start with, analyze how the finished shape will look. Look for the
2-dimensional shape that best describes the part. When looking for this outline, try to look for a
flat 2-dimensional shape that can be extruded or revolved to create a shape that other features can
be added to, to create the finished part. It is usually easier to sketch 2-dimensional geometry than
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3-dimensional geometry. As you gain modeling experience, you can reflect on how you created
the model and think about other ways that you could have built it. There is usually more than one
way to generate a given part.

When sketching, draw the geometry so that it is close to the desired shape and size— you do not
need to be concerned about exact dimensional values. Even though Inventor allows islands in the
sketch (closed objects that lie within another closed object) it is NOT recommended to sketch
islands (when you extrude a sketch, island(s) may become voids in the solid). A better method is
to place features, which make editing a part easier. For example, instead of sketching a circle
inside a rectangle to represent a hole, extrude a rectangle the then place a hole feature.

The following guidelines will help you successfully generate sketches:

o Select a 2-dimensional outline that best represents the part. The 2D outline will be used to
create the base feature. A base feature is the first feature and to which other features will
add or remove material from.

e Draw the geometry close to the finished size. If you want a 20-inch square, for example,
do not draw a 200-inch square. Use dynamic input to define the size of the geometry.
Dynamic input is covered in a later section in this chapter.

e Create the sketch proportional in size to the finished shape. When drawing the first
object, verify its size in the lower-right corner of the status bar. Use this information as a
guide.

e Draw the sketch so that it does not have geometry over geometry, that is, a line on top of
another line.

e Do not allow the sketch to have a gap; the geometry should start and end at a single point,
just as the start and end points of a rectangle share the same point.

o Keep the sketches simple. Leave out fillets and chamfers when possible. You can easily
place them as features after the sketch turns into a solid. The simpler the sketch, the fewer
the number of constraints and dimensions that will be required to constrain the model.

Sketching Commands

Before you start sketching the outline of the part, examine the 2D sketching commands that are
available. After creating a sketch, the 2D sketch tab is current in the ribbon. The most frequently
used commands will be explained throughout this chapter. Consult the help system for
information about the remaining commands.

3D Model LG Inspect  Tools Manage View  Environments BIM  GetStarted  Autodesk 360 - -

A / @ !/" [ [ Fillet + & s Move XsTrim [ Scale | 2 Rectangular r—1 Sy © @ B mage | K Qf
% =) - N
03 - o = — ~[3
Text ~ Coj -2| Extend [4} Stretch | &P Circular . 83 = 2 Points | €F |4
Start Lline Circle Arc  Rectangle A Project @ Copy | [A = Dimension 7 < 1 @ ’ Finish
2D Sketch ~ M M - -+ Point Geometry” | () Rotate -I- Split & Offset | jl§ Mirror & O %1 = @ AcaD | 8 Show Format | Sketch

Sketch Create v Modify Pattern Constrain « Insert Format « Exit

Figure 2-17

Using the Sketch Commands

After starting a new part, a sketch will automatically be active so that you can now use the sketch
commands to draw the shape of the part. To start sketching, issue the sketch command that you
need, click a point in the graphics window, and follow the prompt on the lower-left corner of the
status bar. The sections that follow will introduce techniques that you can use to create a sketch.

Dynamic Input in the sketch environment makes a Heads-Up Display (HUD), which shows
information near the cursor for many sketching commands that helps you keep your eyes on the
screen. While using the Line, Circle, Arc, Rectangle, or Point commands, you can enter values in
the input fields. You can toggle between the value input fields by pressing the TAB key. The
following image shows examples of entering Cartesian coordinates and Polar coordinates.
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TIP: If no data is entered in the input fields and you click in the graphics window to
locate geometry, dimensions will NOT automatically be placed. You can manually place
dimensions and constraints after the geometry is sketched.

20,000 mm |9

Polar Coordinates Cartesian Coordinates

Figure 2-18

Dimension Input

When defining lengths and angles for a second point. The dimensional values change as you
move the cursor. Press TAB to move to the next input field or click in another cell. After entering
a value and pressing the Tab key, the value will be locked and a lock icon will appear to the right
of the value as shown in the following image. After a dimension’s value is locked, the parametric
dimension will be created after clicking a point or pressing the Enter key. You can change the
value in an input field by either clicking in the field or pressing the Tab key until the field is
highlighted and then typing in a new value.

Figure 2-19

Line Command

The Line command is one of the most powerful commands that you will use to sketch. Not only
can you draw lines with it, but you can also draw an arc from the endpoint of a line segment. To
start sketching lines, click the Line command from the Sketch tab > Create panel as shown in the
following image on the left, or right-click in a blank area in the graphics window and click Create
Line from the marking menu as shown in the middle image, or press the L key on the keyboard.
After starting the Line command you will be prompted to click a first point, select a point in the
graphics window, and then click a second point. The image on the right shows the line being
created with the dynamic input as well as the horizontal constraint.

7 T

| Center Point Cirde (=) | | Two Point Rectangle [T |

Line
v | Unde <5 ) | Trim M )
Creat= Mamerson ot Broiect Eeomelny A= -
0.00 deg

Figure 2-20

You can continue drawing line segments, or you can sketch an arc from the endpoint. Move the
cursor over the endpoint of a line segment or arc, and a small gray circle will appear at that
endpoint as shown in the following image on the left. Click on the small circle, and with the left
mouse button pressed down, move the cursor in the direction that you want the arc to go. Up to
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eight different arcs can be drawn, depending upon how you move the cursor. The arc will be

tangent to the horizontal or vertical edges that are displayed from the selected endpoint. The

following image on the right shows an arc that is normal to the sketched line being drawn.
A

AT

Figure 2-21

TIP: When sketching, look at the bottom-right corner of the status bar (bottom of the
screen) to see the coordinates, length, and angle of the objects that you are drawing. The

=
following image shows the status bar when a line is being drawn.

1.500 in, 0.000 in x=1.500in y=0.000 in

Figure 2-22

Object Tracking - Inferred Points

If the Point Alignment On option is checked, from the Sketch tab of the Application Options,
dashed lines will appear on the screen as you sketch. These dotted lines represent the endpoints;
midpoints; and theoretical intersections of lines, arcs, and center points of arcs and circles that
represent their horizontal, vertical, or perpendicular positions. As the cursor gets close to these
inferred points, it will snap to that location. If that is the point that you want, click that point;
otherwise, continue to move the cursor until it reaches the desired location. When you select
inferred points, no constraints (geometric rules such as horizontal, vertical, collinear, and so on)
are applied from them. Using inferred points helps create more accurate sketches. The following
image shows the inferred points from two midpoints that represent their horizontal and vertical
position.

o515 o]}

Figure 2-23

Automatic Constraints

As you sketch, a small constraint symbol appears that represents geometric constraint(s) that will
be applied to the object. If you do not want a constraint to be applied hold down the CTRL key
when you click to create the geometry. The following image shows a line being drawn from the
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arc, tangent to the arc, and parallel to the angled line, and the dynamic input is also displayed.
The symbol appears near the object from which the constraint is coming. Constraints will be
covered in the next section.

I0.788 in o i{:}
; »_//? =
¢ L
B - |

Figure 2-24

Scrubbing

As you sketch, you may prefer to apply a constraint different from the one that automatically
appears on the screen. You may want a line to be perpendicular to a given line, for example,
instead of being parallel to a different line. The technique to change the constraint is called
scrubbing. To place a different constraint while sketching, move the cursor so it touches (scrubs)
the other object to which the constraint should be related. Move the cursor back to its original
location, and the constraint symbol changes to reflect the new constraint. The same constraint
symbol will also appear near the scrubbed object, representing that it is the object to which the
constraint is matched. Continue sketching as normal. The following image shows the top
horizontal line being drawn with a parallel constraint that was scrubbed from the bottom
horizontal line. Without scrubbing the bottom horizontal line, the applied constraint would have
been perpendicular to the right vertical line.

[&]

7

Figure 2-25

Common Sketch Commands

The following table lists common 2D sketch commands. Some commands are available by
clicking the down arrow in the lower-right corner of the top command in the panel. Consult the
help system for more information about these commands.

Command Function

Center-point Creates a circle by clicking a center point for the circle and then a point on the

Circle circumference of the circle.

Tangent Circle Creates a circle that will be tangent to three lines or edges by clicking the lines or edges.

Three-Point Arc | Creates an arc by clicking a start and endpoint and then a point that will lie on the arc.

Tangent Arc Creates an arc that is tangent to an existing line or arc by clicking the endpoint of a line or
arc and then clicking a point for the other endpoint of the arc.

Center-Point Arc | Creates an arc by clicking a center point for the arc and then clicking a start and endpoint.

Two-Point Creates a rectangle by defining a point and then clicking another point to define the
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Rectangle

opposite side of the rectangle. The edges of the rectangle will be horizontal and vertical. If
values were entered, dimensions will be placed on the rectangle.

Three-Point

Creates a rectangle by clicking two points that will define an edge and then clicking a

Rectangle point to define the third corner. You can also type values to define the three points of the
rectangle, and dimensions will be created that define the size of the rectangle.
Two-Point Creates a rectangle by defining a center point and another point to define the rectangle’s

Center Rectangle

size or type values for the center point and its X and Y values of the rectangle. The edges
of the rectangle will be horizontal and vertical, and if values were entered, dimensions
will be created.

Three-Point
Center Rectangle

Creates a rectangle by defining a center point, a point to define the rectangle’s starting
point and its angle and another point size or type values for the center point, and size of
the rectangle. The edges of the rectangle will be horizontal and vertical, and if values
were entered, dimensions will be created.

Center To Center
Slot

Creates a slot by defining the center-to-center distance, angle, and then the diameter.

Overall Slot

Creates a slot by defining the overall distance, angle, and then the diameter.

Center Point Slot

Creates a slot by defining the center-to-center distance, angle, and then the diameter.

Three Point Arc
Slot

Creates an arc slot by defining a start point, end point and an angle, a radius of the center
of the slot and then the diameter of the slot.

Center Point Arc
Slot

Creates an angled slot by defining a radius of the center of the slot and a starting angle, an
ending angle and then the diameter of the slot.

Fillet Creates a fillet between two nonparallel lines, two arcs, or a line and an arc at a specified
radius. If you select two parallel lines, a fillet is created between them without specifying
a radius. When the first fillet is created, a dimension will be created. If many fillets are
placed in the same operation, you choose to either apply or not apply an equal constraint.

Chamfer Creates a chamfer between lines. There are three options to create a chamfer: both sides
equal distances, two defined distances, or a distance and an angle.

Polygon Creates an inscribed or a circumscribed polygon with the number of faces that you
specify. The polygon’s shape is maintained as dimensions are added.

Mirror Mirrors the selected objects about a centerline. A symmetry constraint will be applied to
the mirrored objects.

Rectangular Creates a rectangular array of a sketch with a number of rows and columns that you

Pattern specify.

Circular Pattern

Creates a circular array of a sketch with a number of copies and spacing that you specify.

Offset

Creates a duplicate of the selected objects that are a given distance away. By default, an
equal-distance constraint is applied to the offset objects.

Trim

Trims the selected object to the next object it finds. Click near the end of the object that
you want trimmed. While using the Trim command, hold down the SHIFT key to extend
objects. If desired, hold down the CTRL key to select boundary objects. While in the
Trim command you can also hold down the left mouse button and move the cursor to
dynamically trim geometry. While in the Dynamic mode you can hold down the Shift key
to dynamically extend geometry.

Extend

Extends the selected object to the next object it finds. Click near the end of the object that
you want extended. While using the Extend command, hold down the SHIFT key to trim
objects. If desired, hold down the CTRL key to select boundary objects. While in the
Extend command you can also click and hold down the left mouse button and move the
cursor to dynamically extend geometry. While in the Dynamic mode you can hold down
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‘ the Shift key to dynamically trim geometry.

Selecting Objects

After sketching objects, you may need to move, rotate, or delete some or all of the objects. To
edit an object, it must be part of a selection set. There are multiple methods that you can use to
place objects into a selection set.

CTRL or SHIFT Keys. You can select objects individually by clicking on them. To
manually select multiple individual objects, hold down the CTRL key or SHIFT key
while clicking the objects. You can remove selected objects from a selection set by
holding down the CTRL or SHIFT key and reselecting them. As you select objects, their
color will change to show that they have been selected.

Window. You can select multiple objects by defining a selection window. Not all
commands allow you to use the selection window technique and only allow single
selections. To define the window, click a starting point. With the left mouse button
depressed, move the cursor to define the box. If you draw the selection window from left
to right (solid lines), as shown in the following image on the left, only the objects that are
fully enclosed in the window will be selected.

Crossing window. If you draw the selection window from right to left (dashed lines), as
shown in the following image on the right, a crossing window is used and all of the
objects that are fully enclosed in the selection window and the objects that are touched by
the window will be selected.

You can use a combination of the methods to create a selection set.

When you select an object, its color will change according to the color style that you are using.
To remove all of the objects from the selection set, click in a blank section of the graphics

window.
N T T
g I |
| |
| |
| |
| |
| |
| |
- % -
Window Crossing
Figure 2-26
Deleting Objects

To delete objects first cancel the command that you are in by pressing the ESC key. Then select
objects to delete, and either press the DELETE key or right-click and click Delete from the menu
as shown in the following image.
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Figure 2-27

Distance Commands

Distance (measure) commands can assist in analyzing sketch, part, and assembly models. The
distance command is not a replacement for dimensions; they are additional tools to give you more
information. You can measure distances, angles, and loops, and you can perform area
calculations. You can start the measure command first and then select the geometry, or select the
geometry and then start a measure command.

The Distance commands are located on the Tools tab > Measure panel as shown in the following
image on the left. It can also be added to the Quick Access toolbar by clicking the down arrow to
the right of the Quick Access toolbar and click Distance from the menu as shown in the middle
image. Once the Distance option is added you can access the distance commands as shown in the
image on the right.
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Customize Quick Access Toolbar

3D Model  Sketch [EGl«lat

== Distance

L l | | v L,
—_—l rd 2
X [»_Angle
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Distance Angle Loop Area Region + Parameters [I P

Properties Area

Distance NS . Lo
Measure (8 Region Properties

Figure 2-28

Below is a description of measuring loop, area and region properties commands that you could
use with 2D geometry. The Distance command will also be covered in Chapter 6 Assemblies.

Measure Loop

Measures the length of closed or open loops defined by face boundaries or other geometry. When
moving your cursor over a part face, all edges of the face will become highlighted. Clicking on
this face will calculate the closed loop or perimeter of the shape.

Measure Area

Measures the area of enclosed regions or faces. Moving your cursor inside the closed outer shape
will cause the outer shape and all holes (referred to as “islands™) to also become highlighted.
Clicking inside this shape will calculate the area of the shape.

When you click the arrow beside the Measure dialog box, a menu will appear as shown in the
following image.
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Measure Area

Figure 2-29

Region Properties
While in a sketch you can determine the properties such as the area, perimeter, and Moment of
Inertia of a closed 2D sketch. All measurements are taken from the sketch coordinate system
(0,0). The properties can be displayed in dual units, the default unit of the document, or a unit of
your choice. The following image shows the region properties of two circles.
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Figure 2-30
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EXERCISE 2-1: CREATING A SKETCH WITH LINES

In this exercise, you create a new part file, and 2D Sketch geometry using basic construction

techniques. In this exercise no dimensions will be created.

1. Click the New command on the Quick Access toolbar, click the English folder, and then
double-click Standard (in).ipt or if inch is the default unit; from the left side of the Quick
Access toolbar you can click the down arrow on the New icon and click Part.

2. Click the Start 2D Sketch command on the 3D Model tab > Sketch panel and then select
the XY origin plane in the graphics window as shown in the following image.
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Figure 2-31

3. Start the Line command from the Sketch tab > Create panel.

Click on the origin point in the graphics window, move the cursor to the right
approximately 4 inches, and, when the horizontal constraint symbol displays, click to
specify a second point as shown in the following image. You may need to zoom back and
pan the screen to see the entire line.

Figure 2-32

TIP: Symbols indicate the geometric constraints. In the image above, the symbol

indicates that the line is horizontal. When you create the first entity in a sketch, make it
close to final size.

5. Move the cursor up until the perpendicular constraint symbol displays beside the first line
and then click to create a perpendicular line that is approximately 2 inches as shown in
the following image on the left.

6. Move the cursor to the left and create a horizontal line approximately 1 inch, that is,

parallel to the first horizontal line. The perpendicular constraint symbol is displayed as
shown in the following image on the right.
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7. Move the cursor down, and create a line that is perpendicular to the top horizontal line
and is approximately 1 inch.

8. Move the cursor left to create a line that is approximately 2 inches long and is
perpendicular to the inside vertical line.

9. Move the cursor up and notice the perpendicular constraint symbol is displayed, to apply
a parallel constraint instead, move (scrub) the cursor over the inside vertical line to create
a relationship to it. Then click when an inferred line (horizontal dotted line) appears from
the top point as shown in the following image on the left.

10. Move the cursor to the left until the perpendicular constraint symbol is displayed, and an
inferred vertical line appears from the bottom left point the as shown in the following
image on the right and then click to locate the point.

Figure 2-34

11. To close the profile right-click and click Close from the menu.
12. Your screen should resemble the following image.

13. Right-click in the graphics screen, and click Finish 2D Sketch.
14. Close the file. Do not save changes. End of exercise.

Figure 2-35
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EXERCISE 2-2: CREATING A SKETCH WITH TANGENCIES

In this exercise, you create a new part file, and then you create a profile consisting of lines and
tangent arcs.

1.

W

b

9]

o

Click the New command, and then double-click Standard (inch).ipt; or if inch is the
default unit, from the left side of the Quick Access toolbar you can click the down arrow
of the New icon, and select Part.

Click the Start 2D Sketch command on the 3D Model tab > Sketch panel and then select
the XY origin plane.

Start the Line command by right-clicking in a blank area in the graphics window and
click Create Line from the marking menu.

Click on the projected origin point in the middle of the graphics window, and create a
horizontal line to the right of the origin point and type 3 (inches will be assumed as the
unit because the part file is based on the unit of inch) in the input field. Press the tab key
and move the cursor until the horizontal constraint symbol appears and then click. If the
second point of the line lies off the screen, roll the mouse wheel away from you to zoom
out, hold down the mouse wheel, and drag to pan the view.

Create a perpendicular line, move the cursor up until the perpendicular constraint
appears, type 1.5 in the input field as shown in the following image on the left, and then
press enter.

In this step, you infer points, meaning that no sketch constraint is applied. Move the
cursor to the intersection of the midpoints of the right-vertical line and bottom horizontal
line. Dotted lines (inferred points) appear as shown in image on the right, and then click
to create the line. No dimension was created since a value was not entered.

: B 1.500

3,000~ = = 3.000- .y
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Figure 2-36

7.

8.

9.

Next you create a line that is parallel to the bottom line. If needed scrub the bottom line
by moving the cursor over the bottom line (do NOT click), and then move the cursor up
and to the left until the vertical inferred line and the constraints are displayed as shown in
the following image on the left, and then click to create the line.

Next you sketch an arc while in the line command. While still in the Line command
move the cursor over the left endpoint of the top horizontal line until the gray circle
appears, click on the gray dot at the left end of the line, and hold and drag the cursor to
the left and then down preview a tangent arc. Do not release the mouse button.

Move the cursor over the left endpoint of the first line segment until a coincident
constraint (green circle) and the two tangent constraints at start and end points of the arc
are displayed as shown in the following image on the right.
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10. Release the mouse button to create the arc.

11. Right-click in the graphics window, and then click OK from the marking menu. Later in
this chapter you will learn how to create dimensions.

12. Click Finish Sketch from the Sketch tab > Exit panel.
13. Close the file. Do not save changes. End of exercise.

STEP 2 — CONSTRAINING THE SKETCH

After you draw the sketch, you may want to add geometric constraints to it to add design intent.
Geometric constraints apply behavior to a specific object or create a relationship between two
objects. An example of using a constraint is applying a vertical constraint to a line so that it will
always be vertical. You could apply a parallel constraint between two lines to make them parallel
to one another; then, as the angle of one of the lines changes, so will the angle of the other line.
You can apply a tangent constraint to a line and an arc or to two arcs.

When you add a constraint, the number of constraints or dimensions that are required to fully
constrain the sketch will decrease. On the bottom-right corner of Autodesk Inventor, the number
of constraints or dimensions will be displayed similar to what is shown in the following image. A
fully constrained sketch is a sketch whose objects cannot move or stretch.

4 dimensions needed 1 1

Figure 2-38

Constrain to the Origin Point

When sketching, it is recommended to constrain a point on the sketch to the origin point with a
coincident constraint or dimension a point on the sketch to the origin point so it cannot move.
You could apply a fix constraint instead of using the origin point, but it is not recommended.
When a sketch is constrained to the origin point, Inventor will change the color of constrained
objects. If the sketch is not constrained to the origin point, objects are free to move in the sketch
and the color of the objects will not change.

TIP: Autodesk Inventor does not force you to fully constrain a sketch. However, it is
& | recommended that you fully constrain a sketch, as this will allow you to better predict
how the change will affect the sketch and part.
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Constraint Types
Autodesk Inventor has 12 geometric constraints that you can apply to a sketch. The following
image shows the constraint types that can be applied from the Sketch tab > Constrain panel.

Constrain =

Figure 2-39

I_v © &
7 |7
o 3 312

|

The following chart describes the geometric constraints.

Icon Constraint Function

| Coincident A point is constrained to lie on another point or curve (line, arc, etc.).

o—

N Collinear Two selected lines will line up along a single line; if the first line moves, so will

he the second. The two lines do not have to be touching.

I.’C) Concentric Arcs and/or circles will share the same center point.

f ] Fix Applying a fix constraint to a point will prevent the selected point from moving.
Multiple points in a sketch can be fixed. If you select a line segment, the angle of
the line will be fixed and only its length can change.

/ Parallel Lines will be repositioned so that they are parallel to one another.

\/ Perpendicular | Lines will be positioned at 90° angles to one another.

7777 | Horizontal Line is positioned parallel to the X-axis, or a horizontal constraint can be applied
between any two points in the sketch. The selected points will be aligned such
that a line drawn between them will be parallel to the X-axis.

2‘ Vertical Line is positioned parallel to the Y-axis, or a vertical constraint can be applied
between any two points in the sketch. The selected points will be aligned such
that a line drawn between them will be parallel to the Y-axis.

®\ Tangent An arc, circle, or line will become tangent to another arc or circle.

\% Smooth (G2) | A spline and another spline, line, or arc that connect at an endpoint with a
coincident constraint will represent a smooth G2 (continuous curvature)
condition.

|: | :I Symmetry Selected points defining the selected geometry are made symmetric about a

I selected line.

— | Equal If two arcs or circles are selected, they will have the same radius or diameter. If
two lines are selected, they will become the same length. If one of the objects
changes, so will the other object to which the Equal constraint has been applied.
If the Equal constraint command is applied after one of the arcs, circles, or lines
has been dimensioned, the second arc, circle, or line will take on the size of the
first one. If you select multiple similar objects (lines, arcs, etc.) before selecting
this command, the constraint is applied to all of them.
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Adding Constraints

As stated previously in this chapter, you can apply constraints while you sketch objects. You can
also apply additional constraints after the sketch is drawn. However, Autodesk Inventor will not
allow you to over-constrain the sketch or add duplicate constraints. If you add a constraint that
would conflict with another, you will be warned with the message, “Adding this constraint will
over-constrain the sketch.” For example, if you try to add a vertical constraint to a line that
already has a horizontal constraint, you will be alerted. To add a constraint, follow these steps:

1. Click a constraint from the Constrain panel, or right-click in the graphics window and
click Create Constraint from the menu. Then click the specific constraint from the menu
as shown in the previous image before the chart.

2. Click the object or objects then apply the constraint.

Showing Constraints
To display the geometric constraints that are applied to a sketch, do one of the following:

o Select the geometry in the graphics window by selecting individual objects or by using
the window or crossing selection method that was described in the Selecting Objects
section that was covered earlier in this chapter.

e  Click the Show Constraints command from the Status Bar as shown in the following
image on the left or from the Constrain panel as shown in the middle image.

e Right-click in a blank area in the graphics window and click Show All Constraints from
the menu.

e Press the F8 key.

The constraints on the selected geometry will be displayed. The yellow squares represent
coincident constraints; move the cursor over a yellow square to display the two coincident
constraints for the point. The image on the right shows all the constraints in a sketch.
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Figure 2-40

Modifying Constraint Size

You can modify the size of the constraint icons displayed on the screen by clicking Tools tab >
Application Options > General tab, and then modify the size of the Annotation Scale. The
following image shows the Annotation Scale increased from 1.0 to 1.5. This setting also changes
the size of the dimensions in a sketch.

1.5 -%| Annotation scale

Figure 2-41
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Deleting Constraints

To delete the constraint(s), select a constraint or multiple constraints using one of the selection
methods. Right-click and click Delete from the menu as shown in the following image on the left.
As an alternate method to deleting constraint, you can press the Delete key once the constraint is
selected.

e To delete all constraints except the coincident constraints, use the window or crossing
selection technique, right-click and click Delete Constraints from the menu as shown in
the image on the right.

( Qelete )
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Figure 2-42

Hiding Constraints
You can hide the display symbol for individual or all geometric constraints. To perform this task,
do one of the following:

To hide a constraint:

e Move the cursor over a constraint, right-click and click Hide from the marking menu as
shown in the following image on the left.

To hide all constraints, do one of the following:

e Move the cursor over a constraint, right-click and click Hide All Constraints from the
marking menu as shown in the image, second from the left.

e (lick Hide All Constraints on the Status Bar as shown in the image, third from the left.
This is the same icon you selected to Show All Constraints.

e Right-click in a blank area in the graphics window and click Hide All Constraints on the
menu as shown in the following image on the right.

e Press the F9 key
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Figure 2-43

Construction Geometry

Construction geometry can help you create sketches that would otherwise be difficult to
constrain. You can constrain and dimension construction geometry like normal geometry, but the
construction geometry will not be recognized as a profile edge in the part when you turn the
sketch into a feature. When you sketch, the sketches by default have a normal geometry style,
meaning that the sketch geometry is visible in the feature. Construction geometry can reduce the
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number of constraints and dimensions required to fully constrain a sketch, and it can help to
define the sketch. For example, a construction circle that is tangent to the inside of a hexagon
(drawn with individual lines and not the Polygon command) can drive the size of the hexagon.
Without construction geometry, the hexagon would require six constraints and dimensions. With
construction geometry, it would require only three constraints and dimensions; the circle would
have tangent or coincident constraints applied to it and the hexagon. You create construction
geometry by changing the line style before or after you sketch geometry in one of the following
two ways:

o After creating the sketch, select the geometry that you want to change and click the
Construction icon on the Format panel as shown in the following image.

o Before sketching, click the Construction icon on the Format panel, as shown in the
following image. All geometry created will be construction until the Construction
command is deselected. If you do this, remember to click the Construction icon to turn it
off.

= H Finish

E Show Format | Sketch

| Format « | Exit |

Figure 2-44

After turning the sketch into a feature, the construction geometry will be consumed with the
sketch and is maintained in the sketch. When you edit a feature’s sketch that you created with
construction geometry, the construction geometry will reappear during editing and disappear
when the part is updated. You can add or delete construction geometry to or from a sketch just
like any geometry that has a normal style. In the graphics window, construction geometry will be
displayed as a dashed line, lighter in color, and thinner in width than normal geometry. The
following image on the left shows a sketch with a construction line for the angled line. The
angled line has a coincident constraint applied to every endpoint that it touches. The image on the
right shows the sketch after it has been extruded. Notice that the construction line was not
extruded.

Figure 2-45

Number of Required Constraints or Dimensions
While constraining and dimensioning a sketch, there are multiple ways to determine the number
of constraints or dimensions that are required to fully constrain the sketch. When you add a
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constraint or dimension the number of constraints or dimensions needed to constrain the sketch
decreases. A fully constrained sketch is a sketch whose geometry cannot move or stretch.

On the bottom-right corner of the status bar, the number of constraints or dimensions to fully
constrain the sketch is displayed similar to what is shown in the following image on the left.
When no constraints or dimensions can be added to the sketch, the message Fully Constrained
will appear in the bottom-right corner of the status bar as shown in the middle image and in the
browser, a pushpin icon will appear to the left of the Sketch entry as shown in the image on the
right.

5 dimensions needed Fully Constrained — @ Sketch1

Figure 2-46

Degrees of Freedom

To see the areas in the sketch that are NOT constrained, you can display the degrees of freedom.
While a sketch is active, click Show Degree of Freedom on the status bar, as shown in the
following image on the left, or right-click in a blank area in the graphics window and click Show
All Degrees of Freedom from the menu. Lines and arcs with arrows will appear as shown in the
middle image. As constraints and dimensions are added to the sketch, degrees of freedom will
disappear. To remove the degree of freedom symbols from the screen, click Hide All Degrees of
Freedom on the bottom of the status bar, as shown in the following image on the right, or right-
click in a blank area in the graphics window and click Hide All Degrees of Freedom from the
menu.
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Figure 2-47

Dragging a Sketch

Another method to determine whether or not an object is constrained is to try to drag it to a new
location. While not in a command, click a point or an edge, or select multiple objects on the
sketch. With the left mouse button depressed, drag it to a new location. If the geometry stretches,
it is under constrained. For example, if you draw a rectangle that has two horizontal and two
vertical constraints applied to it and you drag a point on one of the corners, the size of the
rectangle will change, but the lines will maintain their horizontal and vertical behaviors. If
dimensions are set on the object, they will prevent the object from stretching.

EXERCISE 2-3: ADDING AND DISPLAYING CONSTRAINTS

In this exercise, you add geometric constraints to sketch geometry to control the shape of the
sketch.

1. Click the New command, click the English folder, and double-click Standard (in).ipt.

2. Click the Start 2D Sketch command on the 3D Model tab > Sketch panel and then select
the XY origin plane.
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3. Sketch the geometry as shown in the following image, with an approximate size of 2
inches in the X (horizontal) direction and 1 inch in the Y (vertical) direction. Do not
apply dimensions dynamically. Place the lower-left corner of the sketch on the origin
point. Right-click in the graphics window, and then click OK. By starting the line at the
origin point, that point is constrained to the origin with a coincident constraint.

4. Click Show All Constraints on the Status Bar, or press the F8 key. Your screen should
resemble the following image.

o

G

Figure 2-48

5. [If another constraint appears, place the cursor over it, right-click, and then click Delete
from the marking menu.

6. On the Constrain panel, click the Parallel constraint icon.

7. Select the two angled lines. Depending upon the order in which you sketched the lines,
the angles may be opposite of the following image on the left. The constraints that are
applied are previewed

8. Press the ESC key twice to stop adding constraints.

9. The new constraints you just added are not displayed. Press the F8 key to refresh the
visible constraints. Your screen should resemble the following image.

&
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Figure 2-49

10. Select the top horizontal line in the sketch and drag the line. Notice how the sketch
changes its size, but not its general shape. Try to drag the bottom horizontal line. The line
cannot be dragged as it is constrained.

11. Select the endpoint on the bottom-right horizontal line, and drag the endpoint. The lines
remain parallel due to the parallel constraints.

12. Place the cursor over the icon for the parallel constraint on the right-angled line, right-
click, and click Delete from the marking menu as shown in the following image on the
left. The parallel constraint that was applied to both angled lines is deleted.

13. On the Sketch Tab > Constrain panel, click the Perpendicular constraint icon.

14. Select the bottom horizontal line and the angled line on the right side. Even though it may

appear that the rectangle is fully constrained, the left vertical line is still unconstrained
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and can move. Notice on the bottom-right of the Status Bar that 3 dimensions are needed
to fully constrain the sketch.

15. While still in the Perpendicular Constraint command, select the bottom horizontal line
and the left vertical line and then right-click and click OK on the marking menu. Notice
on the bottom-right the Status Bar is down to 2 dimensions to fully constrain the sketch.
Dimensions would be added to fully constrain the sketch.

16. Press the F8 key to refresh the visible constraints. Your screen should resemble the
following image on the right.

& &

( Delete

4 undo 5 ) | 4 &) Hide

= & W N

I

mali)

Figure 2-50

17. Click Hide All Constraints on the Status Bar, or press the F9 key.

18. Drag the point at the upper-right corner of the sketch to verify that the rectangle can
change size in both the horizontal and vertical directions, but its shape is maintained.

19. Press down the CTRL key and select the four lines or use the window selection technique
to select the four lines. Right-click and click Delete from the marking menu.

20. Use the Line command to sketch the geometry as shown in the following image with an
approximate size of 2 inches in the X direction and 1.375 inches in the Y direction. Place
the lower-left point of the sketch on the projected center point. Do not apply dimensions
dynamically. Right-click in the graphics window, and then click OK.
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Figure 2-51

21. Inspect the constraints by dragging different points and edges.

22. Next you make the arcs equal in size. On the Constrain panel, click the Equal constraint
command or press the = key on the keyboard.

a. Select the arc on the left and the bottom arc.
b. Select the arc on the left and the arc on the right side.
c. Select the arc on the left and the arc on the top.
23. Next you align the line segments if necessary. On the Constrain panel, click the Collinear
constraint command.
. . . . W .
If the endpoints and center point of the arcs are aligned horizontally or vertically
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D
D when sketched you will receive a message “Adding this constraint will over-constrain
the sketch”, if you see this message click Cancel in the dialog box for steps 23 a. b. c. and

d.
a. Select the two bottom horizontal lines.
b. Select the two top horizontal lines.
c. Select the two left vertical lines.

d. Select the two right vertical lines.

24. To stop applying the collinear constraint, either right-click and click Cancel (ESC) from
the marking menu or press the ESC key.

25. Next you will align the arcs. On the Constrain panel, click the Vertical constraint
command.

26. Select the center point of the bottom arc, and then click the center point of the top arc.
27. On the Constrain panel, click the Horizontal constraint command.
28. Click the center point of the left arc, and then click the center point of the right arc.

29. To stop applying the constraints, right-click and click Cancel (ESC) from the marking
menu, or press the ESC key. If desired you can move the arcs by clicking and dragging
on them.

30. Display all of the constraints by pressing the F8 key. Your screen should resemble the
following image.
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Figure 2-52

31. Hide all of the constraints by pressing the F9 key.

32. Click on an endpoint in the sketch and drag the endpoint. Try dragging different points,
and notice how the sketch changes.

33. Next you delete the geometry as shown in the following image on the left. Press the ESC
key twice to cancel any command, click a point above and to the left of the top arc, drag a
window so it encompasses the arc on the right, release the mouse button, and press the
Delete key on the keyboard.

34. Close the open line segments. Drag the open endpoints onto each other until your sketch
resembles the following image on the right. A green circle will appear when the two
endpoints are near each other; this applies a coincident constraint.
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Figure 2-53

35. Next you center the arcs in the middle of the sketch. On the Constrain panel, click the
Vertical constraint command.

36. Click the center point on the bottom arc and the midpoint of the top horizontal line as
shown in the following image on the left.

37. On the Constrain panel, click the Horizontal constraint command.

38. Click the center point on the left arc and the midpoint of the right vertical line as shown
in the following image on the right.

R

Figure 2-54

39. Click on different points and drag them, notice how the sketch changes shape, but the
arcs are always centered as shown in the following image.

=
Figure 2-55

N

40. Close the file. Do not save changes. End of exercise. Note that dimensions would be
added to fully constrain the sketch. Dimensions are covered in the next section.

STEP 3 — ADDING DIMENSIONS MANUALLY

The last step to constraining a sketch is to add dimensions that were not added dynamically. The
dimensions you place will control the size of the sketch and can also appear in the part drawing
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views when they are generated. When placing dimensions, try to avoid having extension lines go
through the sketch, as this will require more clean up when drawing views are generated. Click
near the side from which you anticipate the dimensions will originate in the drawing views.

All dimensions that you create are parametric as well as the dynamic dimensions that are placed
automatically when sketching geometry. Parametric means that they will change the size of the
geometry.

Scale Sketch

If the sketch is not constrained to the origin point and no dimension was dynamically added to the
sketch when it was created, then the entire sketch will be uniformly scaled when the first
dimension is added.

General Dimensioning

The General Dimension command can create linear, angle, radial, or diameter dimensions one at
a time. The following image on the left shows an example of a dimensioned sketch. To start the
General Dimension command, follow one of these techniques:

o  Click the General Dimension command from the Sketch tab > Constrain panel as shown
in the following image in the middle.

e Right-click in the graphics window and click General Dimension from the marking menu
as shown in the image on the right.

e  Press the shortcut key D.

%6.500431 /" Create Line

) ) Center Point Circle () = Two Poin
- g ¢ Undo <R 2B Trim
4.000 & Constrain « (General Dimension MJ% %’ Project C
110.00 +" Finish 2D Sketch |
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Figure 2-56

When you place a linear dimension, the extension line of the dimension will snap automatically to
the nearest endpoint of a selected line; when an arc or circle is selected, it will snap to its center
point. To dimension to a tangent point of an arc or circle, see “Dimensioning to a Tangent of an
Arc or Circle,” later in this chapter.

After you select the General Dimension command, follow these steps to place a dimension:

1. Select the geometry to be dimensioned.

2. After selecting the geometry, a preview image will appear attached to your cursor
showing the type of dimension. If the dimension type is not what you want, right-click,
and then select the correct style from the menu. After changing the dimension type, the
dimension preview will change to reflect the new style.

3. Click to place the dimension.

4. Enter a value for the dimension.

The next sections cover how to dimension specific objects and how to create specific types of
dimensioning with the Dimension command.
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Dimensioning Lines
There are multiple techniques for dimensioning a line. Issue the Dimension command and do one
of the following:

e Click near two endpoints, move the cursor until the dimension is in the correct location,
and click.

e To dimension the length of a line, click anywhere on the line; the two endpoints will be
selected automatically. Move the cursor until the dimension is in the correct location and
click.

e To dimension between two parallel lines, click one line and then the next, and then click
a point to locate the dimension.

e To create a dimension whose extension lines are perpendicular to the line being
dimensioned, click the line and then right-click. Click Aligned from the menu, and then
click a point to place the dimension.

Dimensioning Angles

To create an angular dimension, issue the General Dimension command, click on two lines whose
angle you want to define, move the cursor until the dimension is in the correct location, and place
the dimension by clicking on a point.

Dimensioning Arcs and Circles

To dimension an arc or circle, issue the General Dimension command, click on the circle’s
circumference, move the cursor until the dimension is in the correct location, and click. By
default, when you dimension a circle, the default is a diameter dimension; when you dimension
an arc, the result is a radius dimension. To change a radial dimension to diameter or a diameter to
radial, right-click before you place the dimension and select the other style from the Dimension
Type menu.

You can dimension the angle of the arc. Start the Dimension command, click on the arc’s
circumference, click the center point of the arc, and then place the dimension or click the center
point and then click the circumference of the arc.

For arcs you can also add an arc length dimension by starting the dimension command: click on
the arc, right-click and click Arc Length from the Dimension Type menu, and then click a point
to locate the dimension.

120.0 1.047
mﬂ M Dimension Type » ' Radius
5130 + Edit Dimension Diameter

“— Previous View 5 Arclength

= = (o} Home View F&

How To...

Diameter Radius Angle Arc Length Dimension Type Menu
Figure 2-57

Dimensioning to a Tangent of an Arc or Circle
To dimension to a tangent of an arc or circle, follow these steps:

1. Start the General Dimension command.
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Select a line that is parallel to the tangent arc or circle that will be dimensioned, labeled
(1) in the following image on the left.

Move the cursor over the arc or circle until the tangent constraint symbol labeled (2) in
the following image on the left.

Then move the cursor until the dimension is in the correct location and click to create the
dimension, labeled (3) in the following image on the right.

®

. @ .
S

@)= 2.000 =

Figure 2-58

To dimension to two tangents, follow these steps:

1.
2.

®

Start the General Dimension command.

Select an arc or circle that includes one of the tangents to which it will be dimensioned.
The following image illustrates an example of dimensioning a slot, the first selection is
labeled (1).

Move the cursor over a second arc or circle until the tangent constraint symbol appears,
as shown in the following image on the left, labeled (2).

Click to select the tangent point and then move the cursor until the dimension is in the
correct location. Then click to create the dimension, labeled (3) in the following image on
the right.
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Figure 2-59

Entering and Editing a Dimension Value

After placing the dimension, you can change its value. Depending on your setting for editing
dimensions when you created them, the Edit Dimension dialog box may or may not appear
automatically after you place the dimension. To set the Edit Dimension option, do one of the
following:

Click the Tools tab > Options panel > Application Options. On the Sketch tab of the
Application Options dialog box, from the Constrain Settings area, click the Settings
button and then click the box next to Edit dimension when created as shown in the
following image on the left.

Or set this option by right-clicking in the graphics window while placing a dimension and
click Edit Dimension from the menu as shown in the following image on the right. This
method will change the application option Edit Dimension when created as previously
described.
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If the Edit dimension when created option is checked, the Edit Dimension dialog box will appear
automatically after you place the dimension. Otherwise, the dimension will be placed with the
default value.

Dimension Dimension Type 2

Edit Dimension h

L

Edit dimension when created

Figure 2-60

To edit a dimension that has already been created, double-click on the dimension, and the Edit
Dimension dialog box will appear, as shown in the following image. Enter the new value and unit
for the dimension; then either press ENTER or click the checkmark in the Edit Dimension dialog
box. If no unit is entered, the units that the file was created with will be used. When inputting
values, enter the exact value — do not round up or down. The accuracy of the dimension that is
displayed in a sketch is set in the Document Setting. For example, if you want to enter 4 1/16
decimally enter 4.0625 not 4.06.

Edit Dimension : d3 S9N
4.0625 in ) [7"

Figure 2-61

Fractions

Inventor also allows you to enter a fraction anywhere a value is required. When the Length unit in
the Tools tab > Options panel > Document Settings > Units tab is set to any non-metric unit, as
shown in the following image on the left, and a fraction is entered, a fraction will display in the
graphics window and will be maintained in the Edit Dimension dialog box. If the Length unit is
set to a metric unit and a fraction is entered, the decimal equivalent will be displayed in the
graphics window but the fraction will be maintained in the Edit Dimension dialog box. After
inputting a fraction you can click on the right-faced arrow and set the type of dimension to
display: Decimal, Fractional, or Architectural as shown in the middle of the following image.
When entering fractions do not use a dash to separate the fraction, just add a space. For example,
enter 4 1/16, not 4-1/16, Inventor would interpret the — as part of an equation and would return
the value 3.9375. The following image on the right shows the fraction displayed in the graphics
window.
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Figure 2-62

TIP: When placing dimensions, it is recommended that you place the smallest
g%rnen.sions first. This will help prevent the geometry from flipping in the opposite
1rection.
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Repositioning a Dimension
Once you place a dimension, you can reposition it, but the origin points cannot be moved. Follow
these steps to reposition a dimension:

1. Exit the current operation either by pressing ESC twice or right-clicking and then
clicking Cancel (ESC) from the marking menu.

2. Move the cursor over the dimension until the move symbol 4 appears as shown in the
following image.

3. With the left mouse button depressed, move the dimension to a new location and release
the button.

Figure 2-63

Fully Constrained Sketch

As was described in the “Constraining the Sketch” section, as you add constraints and dimensions
to a sketch, the number of required dimensions is decreased. When no more constraints or
dimensions are needed to constrain the sketch, the number in the “dimensions needed” section on
the bottom-right of the status bar will display Fully Constrained as shown in the following image
on the left. The icon to the left of the Sketch entry in the browser will also display a pushpin
when the sketch is fully constrained as shown in the following image on the right.

({JPart7
Tgn View: Master

7] origin > 23
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Figure 2-64

Over Constrained Sketch

As explained in the “Adding Constraints” section, Autodesk Inventor will not allow you to over-
constrain a sketch or add duplicate constraints. The same is true when adding dimensions. If you
add a dimension that will conflict with another constraint or dimension, you will be warned that
this dimension will over-constrain the sketch or that it already exists. You can either cancel the
operation and no dimension will be placed, or accept the warning and a driven dimension will be
created.

A driven dimension is a reference dimension. It is not a parametric dimension—it reflects the size
of the points to which it is dimensioned. If the part changes, the driven dimension will be updated
to reflect the new value. A driven dimension will appear with parentheses around the dimensions
value—for example, (2.500). When you place a dimension that will over-constrain a sketch, a
dialog box will appear similar to the following image.
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Figure 2-65

Relax Mode

When you try to place a constraint or add a dimension and you receive the over constraint
message, and if you want the constraint or dimension to take precedence, you can turn on relax
mode. When relax mode is on and you reapply the constraint or add the dimension, it will be
applied or created and the conflicting constraint will automatically be deleted, except for
Coincident, Smooth, Tangent, Symmetry, Pattern, and Project constraints, and any conflicting
dimension will become a driven dimension. While in relax mode, and you are not able to add the
new constraint or dimension, you may need to manually delete one of the Coincident, Smooth,
Tangent, Symmetry, Pattern, and Project constraints.

Turn on relax mode by clicking the Relax Mode icon on the Status Bar as shown in the following
image on the left. When you apply a constraint or dimension that would have over constrained a
sketch, a dialog box will appear stating that a constraint or dimension will be deleted to solve the
conflict as shown in the following image on the right.

Another method to remove conflicting constraints or dimensions is to drag a point or edge while
in Relax Mode and conflicting constraints or dimensions will be deleted.

When done editing the constrained sketch, turn off relax mode. If relax mode is left on, a
constrained sketch can inadvertently be altered by dragging constrained objects.

Autodesk Inventor Professional ﬁ

Adding this dimension will over-constrain the sketch.

To solve conflicts, highlighted constraints will be removed,
and highlighted dimensions will be changed to Driven dimension.

Would you like to continue?
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Figure 2-66

For illustration, the following image on the left shows a fully constrained rectangle with the
geometric constraints visible. Relax Mode was turned on and a 120 degree angle dimension was
located and after clicking Yes in the warning dialog box the dimension was created and the
perpendicular constraint in the lower-right corner was deleted as shown in the middle image. To
return the geometry back to a rectangle, a perpendicular constraint was applied to the bottom
horizontal line and left vertical line and the 120 degree dimension was automatically changed to a
driven dimension as shown in the image on the right.
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TIP: When done editing the constrained sketch turn off Relax Mode. This returns
= Inventor to its original editing state. If this is not done, sketches can accidentally be
changed by dragging points and objects in the sketch.

Driven Dimension

Another option for creating driven dimensions is to use the Driven Dimension option. A driven
dimension does NOT reduce the number of dimensions needed to constrain the sketch it only
reflects the length of the object. You would use this option to show reference dimensions.

If you select the Driven Dimension icon from the Sketch tab > Format panel, as shown in
following image on the left, any dimension you create will be a driven dimension. Driven
dimensions are represented in the sketch with parenthesis around the value, whereas parametric
dimensions do not have parenthesis around the value. If the Driven Dimension option is not
active, regular parametric dimensions will be created, which is the default.

The same Driven Dimension option can be used to change an existing dimension to either a
driven dimension or back to a normal dimension by selecting the dimension and clicking the
Driven Dimension option. The following image on the right shows an example of a 5.250 driven
dimension referencing the overall length of the sketch. The three parametric dimensions control
the length of the sketch. If one of the parametric dimension values change, the driven dimension’s
value will update to reflect the new overall length.
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Figure 2-68

TIP: Avoid over using driven dimensions as they do not parametrically control the size
= of the sketch, they are only used for reference.

EXERCISE 2-4: CONSTRAINING AND DIMENSIONING A
SKETCH

In this exercise, you add dimensional constraints to a sketch. Note: this exercise assumes that the
“Edit dimension when created” and “Autoproject part origin on sketch create” options are
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checked in the Application Options dialog box under the Sketch tab. Experiment with Autodesk
Inventor’s color schemes to see how the sketch objects change color when they are constrained.

4. Click the New command and click the English folder, and then double-click Standard
(in).ipt.

5. Click the Start 2D Sketch command on the 3D Model tab > Sketch panel and then select
the XY origin plane.

6. Start sketching by starting the line command in the Sketch tab > Create panel and click
the origin point, move the cursor to the right, type 5 in the distance input field, press the
Tab key, and then click a point when the horizontal constraint is previewed above the
input field for degrees as shown in the following image on the left.

7. Next you place an angle line and a dynamic dimension to define the angle. Press the tab
key and type 150 for the angle input field, press the Tab key, and then click a point to the
upper right as shown in the following image on the right. The distance should be about 2
inches but the dimension is not needed to define this sketch.

150.00 deg |

o [5.000 in W] : — 5000 = /@

0.00 de
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Figure 2-69

8. Sketch the geometry as shown in the following image. When sketching, ensure that a
perpendicular constraint is not applied between the two angled lines. If needed, hold
down the CTRL key while sketching the top angle line to prevent sketch constraints from
being applied. The arc should be tangent to both adjacent lines.

ﬂ—S.OOOTVﬁFO . :

Figure 2-70

9. Add a horizontal constraint between the midpoint of the left vertical line and the center of
the arc by clicking the Horizontal Constraint command from the Sketch tab > Constrain
panel and select the midpoint of the line and the center point of the arc as shown in the
following image on the left.

10. Start the Vertical Constraint command from the Sketch tab > Constrain panel and add a

vertical constraint between the endpoints of the angled lines nearest to the right side of
the sketch as shown in the following image on the right.
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Figure 2-71

11.

12.

13.

Make the two angled lines equal in length by adding an equal constraint, press the = key
and then select the two angled lines.

Click the General Dimension command in the Sketch tab > Constrain panel and add a
radial dimension by selecting the arc. Move the cursor until the dimension is positioned
near the lower right corner of the sketch and then click a point and then enter 1.5 for its
value (if the Edit Dimension dialog box did not appear, double-click on the dimension
and change the dimension to 1.5), and click the checkmark in the Edit Dimension dialog
box.

TIP: To set the Edit Dimension dialog box to appear when placing dimensions, while
placing a dimension, right-click in the graphics window and click Edit Dimension from
the menu.

While still in the General Dimension command, add a vertical dimension by selecting the
vertical line, position the dimension to the left, click a point to locate it, enter 5, and click
the checkmark. When complete, your sketch should resemble the following image on the
left. Notice on the bottom right of the Status Bar, 1 dimension is required to fully
constrain the sketch as shown in the following image on the right.
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Figure 2-72

14.

Add a horizontal dimension by selecting the left vertical line and then select the center
point of the arc or on the top of the arc, locate the dimension to the top of the sketch and
enter 10 for the value as shown in the following image.
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Figure 2-73
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15. Press the ESC key twice to end the command. In the Status Bar the, in the number of
dimensions required section, it should display “Fully Constrained,” and the icon to the
left of the sketch in the browser should have a pushpin on it.

16. Try to click and drag on different points on the sketch. The points will not change
because they are constrained or dimensioned.

17. Turn relax mode on by clicking the Relax Mode icon in the Status Bar, as shown in the
following image.
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Figure 2-74

18. Click and drag on different points on the sketch. The dimensions will change to reflect
their new value.

19. Return the sketch to the values shown in step 14 by using the Undo command in the
Quick Access toolbar.

20. While still in Relax Mode, add an overall horizontal dimension using the General
Dimension command by clicking the vertical line (not an endpoint), move the cursor near
the right tangent point of the arc until the glyph of dimension with a circle appears, as
shown in the following image on the left. Locate the dimension above the 10.000
dimension and accept the default length of 11.500. The 10.000 was automatically
changed to a driven dimension and the sketch should still be fully constrained. Your
sketch should resemble the following image on the right.

=3 11.500 £
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Figure 2-75

21. Edit the value of some of the sketch dimensions by double-clicking on the dimension’s
value and type in a new value and then press ENTER on the keyboard or click the green
check mark in the Edit Dimension dialog box, and examine how the sketch changes. The
arc should always be in the middle of the vertical line. Notice how the driven dimension
changes when the horizontal, angle or radial dimension values changes.

22. Delete the horizontal constraint between the center of the arc and the midpoint of the
vertical line by selecting the center point of the arc, select the horizontal constrain above
the center point, right-click and click Delete from the menu as shown in the following
image.
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Figure 2-76

23. Turn relax mode off by clicking the Relax Mode icon in the Status Bar, as shown in the
following image.

Bp & ro- d HNE

Figure 2-77

24. Display the visibility of all of the constraints by window selecting all of the geometry.
25. Click in a blank area in the graphics window and the constraints will disappear.

26. In the Status Bar click the Show All Constraints command, as shown in the following
image, and practice deleting and adding other constraints.

Figure 2-78

27. Practice adding and deleting dimensions.
28. Close the file. Do not save changes. End of exercise.

INSERTING AUTOCAD FILES

You may have legacy AutoCAD files or receive AutoCAD files that you need to convert into
Inventor parts. In this section you learn how to insert AutoCAD data into a sketch. When
importing a 2D DWG file into Autodesk Inventor, you can either copy the contents from the
DWG file to the clipboard via Autodesk Inventor or AutoCAD and paste the contents into
Autodesk Inventor, or use an import wizard that guides you through the process. In this section
you learn how to insert AutoCAD 2D data into a sketch in an Inventor part file.

TIP: AutoCAD does not need to be installed to import AutoCAD geometry into
= | Inventor.
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Inserting 2D AutoCAD Data into a Sketch

In this section you learn how to insert AutoCAD 2D data into the active sketch in a part or
drawing. To insert AutoCAD data into the active sketch, follow these steps:

1. Start a new Inventor part file or open an existing part file.
2. Create a new sketch or make an existing sketch active.

3. Click the Insert AutoCAD File command on the Sketch tab > Insert panel as shown in the
following image.
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Figure 2-79

4. The Open dialog box will appear. Browse to and either double-click the desired DWG
file or click on the DWG file and then click Open.
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Figure 2-80

5. The Layers and Objects Import Options dialog box appears. In the Selective import
section in the upper-left corner of the dialog box, uncheck the layer names you do not
want data imported from as shown in the following image.

6. To select specific objects to insert, uncheck the All option, and then select the desired
data in the preview window. In the preview window you can zoom and pan as needed.

7. You can change the background color of the preview image by clicking the black or
white icon at the top-right corner of the dialog box.
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Figure 2-81

8. Click the Next button to go to the next step. In the Import Destination Options dialog box
specify the units in which the data was created as shown in the following image.

Check the options to Constrain End Points and Apply geometric constraints as shown in

the following image. The Apply geometric constraints option will add sketch constraints

to geometry that is parallel, perpendicular and tangent.

80

© 2014 SDC Publications



Chapter 2 - Sketching, Constraining and Dimensioning
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Figure 2-82

10. To import the data, click Finish.

11. Use the Zoom All command or double-click the wheel to see all the geometry.

12. Delete unnecessary geometry, constraints, and dimensions.

13. Add geometry (if needed), constraints, and dimensions to fully constrain the sketch.

OPEN OTHER FILE TYPES

Autodesk Inventor can also open parts and assemblies exported from other CAD systems. When
files from other CAD systems are opened in Inventor they will be imported as solids or surface
models depending upon the original file and the components will NOT have feature history and
an assembly will NOT have any assembly constraints. You can add features to imported parts and
edit the geometry by using Inventor’s Direct Edit command. For files that are imported as an
assembly, you can add assembly constraints. To open file types such as DXF, Alias, Catia, IDF
Board Files, IGES, JT, Parasolids, PRO/E, SAT, STEP, SolidWorks, and Unigraphics NX, click
the Inventor Application Menu > Open or click Open on the Quick Access toolbar. You can also
use the Import DWG command from the Application Menu > Open; this command will import
AutoCAD data into a new drawing, title block, border, symbol or part file without having to first
create a new file.
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In the Open dialog box, click the desired file format in the Files of type list. See the help system
for more information about the different file types.

Quick Launch

Osm

Files of type:

Project File:

Autodesk Inventor Files (*.iam;".idw.".dwg.".ipt™.ipn.".ide) 1y

Autodesk Inventor Files (*.iam;*.idw.*.dwg:*.ipt™".ipn;*.ide
Ir Autodesk Inventor Assemblies (".iam)

Autodesk Inventor Drawings (*.dwg; *.idw)

Autodesk Inventor Parts (*.ipt)

Autodesk Inventor Presentations (*.ipn)

Autodesk Inventor iFeatures (*.ide)

Alias Files (".wire)

AutoCAD DWG Files (*.dwg)

CATIA V4 Files (".model.".session;".exp:".dlv3)

CATIA V5 Files (~.CATPart*. CATProduct*.cgr)

Figure 2-
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DWF Markup Files (*.dwf.*.dwx)

DXF Files (*.dxf)

IDF Board Files (*.brd:*.emn;* bdf*.idb)

IGES Files (".igs;".ige;".iges)

JT Files (*jt)

NX Files (*.prt)

Parasolid Binary Files (*.x_b)

Parasolid TextFiles (*x_{)

Pro/ENGINEER Granite Files (*.g)
Pro/ENGINEER Neutral Files (*.neu®)
Pro/ENGINEER and Creo Parametric Files (*.prt".".asm")
Revit Project Files (*.rvt)

Rhino Files (*.3dm)

SAT Files (*.sat)

STEP Files (*.stp:* ste;* step)

STLFiles (".stl.".stla;™.stlb)

SolidWorks Files (*.prt* sldprt.*.asm:*.sldasm)
AllFiles (")

EXERCISE 2-5: INSERTING AUTOCAD DATA

In this exercise, you insert AutoCAD data into a sketch and add constraints to fully constrain the

:

p ][ concal ]

sketch.

1. Click the New command, click the English tab, and then double-click Standard (in).ipt, or
if inch is the default unit; from the left side of the Quick Access toolbar you can click the
down arrow of the New icon, and select Part.

2. Click the Start 2D Sketch command on the 3D Model tab > Sketch panel and then select
the XY origin plane.

3. Click the Insert AutoCAD command from the Sketch tab > Insert panel.

4. From the Frequently Used Subfolder area (upper left corner of the dialog box) click the
Chapter 02 subfolder and then in the file area double-click on the file AutoCAD 2D
Bracket.dwg

[ IL Open ﬂ1
@ Frequently Used Subfold « Lookin: | Chapter02 - O @2 E

("] Chapter 01 = .

{1 Chapter 02 Name Date modified Type

(] Chapter 03 ~| |3 AutoCAD 2D Bracketdwg [ 12/27/2011 10:27 AM DWG Filt

4 m 2
Figure 2-84
5. In the Layers and Objects Import Options dialog box you uncheck the layers that are not

needed. In the upper left corner of the dialog box uncheck layers; 0, Border (ANSI) and
Hidden (ANSI) as shown in the following image labeled (1).
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6. In the Selection area near the bottom left corner of the dialog box uncheck All, labeled
(2) in the following image.

7. Select the geometry and dimensions to insert, use the window selection (click and drag
from the left to right) technique to select all of the geometry and dimensions in the top
view labeled (3) in the following image.

Layers and Objects Import Options ﬁ
Selective import Import Preview E] D
[]o
| Border (ANSI)
|| Dimension (ANST)

Hidden (ANSI) )
|/ Visible (ANST) 1 6.00
|| Defpoints
=150 3.00
ok
I
3.00 T
I
Lo A famY f)._
050 = AN
‘ f ‘H‘\H\“-rzo.so
-—.1.50 —= —2.00 —= [*—1.50 —=
ks
2 ©

Selection |
DA”A/ Y

0 total % !

L

Figure 2-85

8. In the Selection area of the dialog box, verify that 27 total objects are selected as shown

in the following image. If not, reselect all of the data in the top view.
Selection

[C] A

27 total

Figure 2-86

9. Click the Next button on the bottom of the dialog box.

10. In the Import Destination Options dialog ensure inch is set as the detected unit and check

the Constrain End Points and the Apply geometric constraints options as shown in the
following image.
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Import Files Units
(@) Detected Units

|inch
(*) Spedify Units

mim >

[] Constrain End Points
Apply geometric constraints

Figure 2-87

11. Click the Finish button on the bottom of the dialog box.

12. Apply a horizontal constraint between the center points of the two circles labeled (1) in
the following image.

13. Apply a collinear constraint between the two middle horizontal lines labeled (2).
14. Press the ESC key twice to cancel the command.

15. The sketch is free to move. To constrain the sketch, drag the lower-left corner of the
sketch labeled (3) in in the following image to the origin point of the sketch (0,0). Or you
could add a coincident constraint between the origin point and the left point on the
bottom line.

=—6.000——=
=1.500=p=+—-3.000—==

3.000 !2! ( )
$ 1.4oo /?)‘DE
7 .500 b |

7
®'/ 500—}&=H
=1.500= ~=+2.00 ~=1,500~

Figure 2-88

16. On the lower-right corner of the Status Bar, the text should state that “1 dimensions
needed” to constrain the sketch.

17. Drag up the top-right endpoint of the top horizontal line up; the sketch will be rotated
slightly as shown in the following image on the left.

18. Apply a horizontal constraint to the lower horizontal line, and this will fully constrain the
sketch as shown in the following image on the right. The dimensions can be repositioned
as needed.
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Figure 2-89

19. Press the F8 key to see all constraints.
20. Press the F9 key to hide all constraints.

21. The AutoCAD dimensions on the sketch are now parametric and can be edited. Practice
editing the values of the dimensions by double-clicking on a dimension’s value and enter
a new value.

22. Close the file. Do not save changes. End of exercise.

APPLYING YOUR SKILLS

Skills Exercise 2-1

In this exercise, you create a sketch and then add geometric and dimensional constraints to
control the size and shape of the sketch. Start a new part file based on the Standard (in).ipt, create
a sketch on the XY plane, and create the fully constrained sketch as shown in the following
image. Assume that the top and bottom horizontal lines are collinear, the center points of the arcs
are aligned vertically, and the sketch is symmetric about the left and right sides. The bottom
angled lines should be coincident with the center point of the lower arc (if the arc is drawn via the
line command, the center point of the arc will automatically be coincident with the line it was
drawn from). When done, close the file and do not save the changes.
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Figure 2-90

Skills Exercise 2-2

In this exercise, you create a sketch with linear and arc shapes, and then add geometric and
dimensional constraints to fully constrain the sketch. Start a new part file based on the Standard
(in).ipt template. Create a sketch on the XY plane, and create the fully constrained sketch as
shown in the following image. First create the two circles and align their center points
horizontally. Then create the two lines, and place a vertical constraint between the line endpoints
on both ends. When done, close the file and do not save the changes.

Figure 2-91

CHECKING YOUR SKILLS

Use these questions to test your knowledge of the material in this chapter.

1. True False While sketching, by default, geometric constraints are not applied to the
sketch.

2. True False  When you sketch and a point is inferred, a constraint is applied to
represent that relationship.

3. True False Itis recommended to never fully constrain a sketch.
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True  False  When working on a millimeter part, you cannot input inch units.

True False  After a sketch is fully constrained; you cannot change a dimension’s
value.

True False A driven dimension is another name for a parametric dimension.
True False Dimensions placed dynamically are not parametric.

True False You can only import 2D AutoCAD data into Autodesk Inventor.
Explain how to draw an arc while using the Line command.

. Explain how to remove a geometric constraint from a sketch.
. Explain how to change a vertical dimension to an aligned dimension while placing the

dimension.

. Explain how to create a dimension that is tangent to two arcs.
. True__ False_ AutoCAD needs to be installed to insert AutoCAD geometry.
. True__ False  When a sketch is extruded that contains construction geometry, the

construction geometry is deleted.
Explain how to change the unit type in a part file.
Explain where you would turn on Relax Mode.

True False When a pushpin appears in the Sketch entry in the browser, the sketch is
fully constrained.

True  False By default an arc length dimension can only be a driven dimension.
Explain how to draw a rectangle that is centered on the origin point.

True False When creating the first 2D sketch, you must select an origin plane to
sketch on.
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