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Assembling Project Files

The files used in the Autodesk® 3ds Max® software can be modeled directly in the
software, referenced by linking, or directly imported from another source. Linking
files enables you to incorporate objects or other scene files into the current scene
by externally referencing them. Once referenced, the connection between the two
files can be maintained. If files are imported, they are merged with the project and
no link is established. Understanding the benefits and drawbacks of using external
data helps you decide how to best reference it in a project.

Learning Objectives in this Chapter

» Understand the difference between File Linking and File Importing, and edit the linked data
files.

+ Combine entities from .DWG, .DXF, .FBX, and .RVT files into an active Autodesk 3ds Max
scene.

« Understand how to link AutoCAD® DWG, DXF, generic FBX files, and Autodesk® Revit®
RVT/FBX files.

+ Create and modify presets.

* Incorporate objects or other scene files into the current scene by externally referencing them.

* Manage data using the asset tracking systems.
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3.1 Data Linking and Importing

Although the Autodesk 3ds Max software has a robust 2D and
3D modeling system, it might be efficient to link or import some
or all of the design data from other Autodesk software, such as

AutoCAD®, Autodesk® Revit® Architecture, AutoCAD®
Architecture, or Autodesk® Inventor®.

Linking VS. You can link or import files using the File Link and Import tools.
You can link files such as .DWG, .DXF, .FBX, and .RVT, and

|mp°rt| ng import files such as Autodesk® Inventor® (.IPT, .IAM), Autodesk®

Alias® .Wire, Autodesk® Showcase® .APF (Autodesk Packet
File), LandXML and DEM data files, and Adobe lllustrator (.Al).

» Linked geometry differs from imported geometry in that it
remains connected to the source file. If the source file is
edited, the Autodesk 3ds Max Scene can be updated to show
those changes. Imported geometry maintains no connection
to the source file.

» If a source .DWG, .DXF, .FBX, or .RVT file is likely to change
(or you would prefer to make changes in the .DWG, .DXF,
.FBX, or .RVT directly), then using File Linking might be the
best way to incorporate this data into the Autodesk 3ds Max
software.

* Importing can be used as a faster alternative to linking to
bring large amounts of data into the software. Complex
geometry might be faster to reimport than to update through a
file link.

* File links and imports are launched from the Application
Menu (as shown in Figure 3—1):

+ Expand E (Application Menu), expand Import, and
select Link Revit/Link FBX/Link AutoCAD, or

+ Expand E (Application Menu), expand Import, and
select Import.
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Figure 3-1

Editing Linked * Linked geometry can be edited but not directly deleted from a

scene file. Alternatively, the layer on which the objects are
Data placed might be ignored during a reload, or set to Hide in the
Layer dialog box.

» Edits applied to linked geometry (such as through modifiers)
are reapplied after a link is updated. Some complex
modifications might not apply as expected, so you should
always review your geometry carefully after a link is updated.

» Links to drawing files are not bi-directional, so that changes
you make to the data in the Autodesk 3ds Max software do
not update the original .DWG, .FBX, .DXF, or .RVT file.

* Inlinked files that are bound, the geometry stays in the scene
file as-is, but the connection to the source file is dropped.

Importing You can equrt an .FBX file from the Autodesk Revit spftware .

and import it in Autodesk 3ds Max software. The FBX importer is
an independent plug-in that is frequently updated. In the FBX
Import dialog box, use Web Update to check for web updates,
download the latest updates, and install them. Close 3ds Max
when you do the install.
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Merging
Autodesk 3ds
Max Scene
Files

Objects already saved in Autodesk 3ds Max scenes (.MAX files)
are imported into the current scene using the Merge option
(Application Menu>Import>Merge). Merging files is a
one-directional transfer that does not maintain any connection
between the two files. Using the Merge option, you can either
load a few objects from a scene or you can load a complete
scene into the current one.
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Practice 3a

Estimated time for
completion: 20 minutes

You have to initialize
Civil View once.

Ground Surfaces using Civil
View

Practice Objective

Open a Civil 3D data file in a scene file.

In this practice you will open a .VSP3D file for importing ground
surfaces using Civil View. You will then modify the material
assignment for various ground surfaces using the Civil View
Explorer.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Initialize Civil View.

It is recommended that you import 3D ground surfaces from
Civil/Survey products, such as AutoCAD Civil 3D or Land
Desktop using the vsp3d data format.

1. In the menu bar, select Civil View>Initialize Civil View. If
you have already initialized Civil View, go to Step 5.

2. In the Initialize Autodesk Civil View dialog box, set the
System Unit to Feet because the civil project that you will be
opening uses Feet as its unit of measurement. Verify that
Don’t warn me about System Units again is selected.

3. Inthe Select a Country Resource Kit area, select US
IMPERIAL and verify that Start Mode for Civil View is set to
Manual. Click OK. In the Information dialog box, click OK.

4. Exit and then restart the Autodesk 3ds Max software.

5. Start Civil View by selecting Civil View>Start Civil View.
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The objects listed
include surfaces, site/
grading featurelines,
corridor (surfaces,
baselines, featurelines
etc.),and point groups,
etc.

Hint: Starting Civil View

Although Civil View is initialized next time you launch the
Autodesk 3ds Max software, you are still required to start Civil
View if the Start Mode for Civil View is set as Manual. You can
change this setting in the Civil View Preferences dialog box, in
the General tab, by select Automatically start Civil View?, as
shown in Figure 3-2.

E 1 Civil view Preferences 2 |
J General ] Localization | Colors | Resource Kit Paths | Materials | Import Options |
v Automatically start Civil View? Default Frame Rate: |25 ﬂ
Marker Size: |2 ﬂ
v Show icons in Civil View Explorer Panel? Civil View Explorer Width: |2[Js ﬂ
Tree Variation (%%): |15 ﬂ

Figure 3-2

6. Open Civil Base XRef.max from the ...\scenes folder. If a

Mismatch dialog box opens, click OK to accept the default
values. If prompted again, click OK. This is an empty scene
in which the System Unit Scale has been set to 1 Unit=1.0
Feet.

7. In the menu bar, select Civil View>Geometry Import>Civil

3D (VSP 3D) File, as shown in Figure 3-3.

Civil View | Rendering  Customize  Scriptng  Help
Civil View 4 3 Y% w
Geometry Import r Civil 3D (VSP3D) File... %
e ’ Maodel File...
Figure 3-3

8. In the Civil 3D Import Panel dialog box, click Open. In the

Select a VSP3D File dialog box, browse to the ...\import
folder (if required) and open Civil surfaces.vsp3d file.

9. In the Civil 3D Import Panel dialog box, a list of objects that

are in the AutoCAD Civil 3D file are listed. In the left pane,
select Surfaces [9] to display all of the surfaces in the right
pane. Select Building Pad, hold <Shift>, and select Parking
Lot Surface to highlight the first seven surfaces. Select the
checkbox for Building Pad to select all seven highlighted
surfaces, as shown in Figure 3—4. You can select them
individually as well.

3-6
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F 1 Civil 3D Import Panel [Civil surfaces.vsp3d]

Open | ICurridur Baseline hd Q g |* | ﬂ g

|___"'| RenusSite.dwg
[ Paint Groups [0]
'] Pipe Networks [0]

-_* Alignments [0]
"2 Centerline Alignments [0]
= 5_: + Offset Alignments [0]

I';'l-- Corridors [1]
-- Road

It takes a few minutes to
load the file.

Right-click on the title
bar and select
Dock>Left.

----- +._\"'l Corner Radius Alignments [0]

ame Ohject Type Points | Splines/Faces
Building Pad Surface 1089
1gGround Surface 47571

=

Curbing Surface 7029
Inside Grading Surface 1125
Cutside Curhing Surface 4599
Qutside Grading Surface 14850
Parking Lot Surface Surface 4077

KRR E]E]

¥ @Rﬂad Surface - (1) Surface 7320 a80
O] &y water Surface 702 78
Figure 3—-4

10. You will select the corridor surfaces and the baseline. In the
left pane, select Corridors [1] and in the right pane, click in
the checkboxes for PrimaryAccess, Region(1), Region(2),
and Region(3), as shown in Figure 3-5.

|:| JHingE_Eut Corridor Feature Line 6
. jH'nﬂg Cut Corridor Feature Line 65
=|-'= PrimaryAccess Corridor Baseline 57
@Rﬁginn (1) Corridor Surface 306
@Rﬁginn ()] Corridor Surface 42
@Rﬁginn (3 Corridor Surface 159
[ [5= Top_Curb Caorridor Feature Line 34
¥ +/"'Tuz:qt.'-_l::urlz:l Corridor Feature Line 6
Figure 3-5

11. Click OK. In the Civil View Information, click Yes to accept
the global shift values.

12.Click Yes to proceed without a feature interpretation style.

13.In the Warning dialog box, click OK. In the Error dialog box,
click OK.

14.The ground surfaces, building pad, corridor, and parking lot
are displayed in all of the viewports. If they are not, click

53. (Zoom Extents All). Note that only the corridor displays
the right surface material but the rest of the surfaces display
a checkerboard material.

15.1n the menu bar, select Civil View>Civil View>Civil View
Explorer to open the Civil & View Explorer. Dock it along the
left side of the screen.
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A material is not
required for the first
three corridor regions.

The complete list might
not be visible in the
Explorer. Hover the
cursor in empty space in
the information area
until it displays as a
hand cursor. Grab and
slide the hand cursor or
the scroll button to slide
up or down to display all
of the information.

16. Verify that the Civil Explorer tab is selected. Expand Civil
View Objects>Imported Objects, if not already expanded.
Select Surfaces and note that the corridor is selected in the
viewports. The Object List rollout opens with all of the
surfaces listed, as shown in Figure 3—6.

[= Ohbject List |
Surfaces (10) O

C3Dsurface-Road-Region (1) all
C3Dsurface-Road-Region (2) ;l
C3Dsurface-Road-Region (3) —
C3Dsurface-C-TOPO-Building Pad |

Right-dick item for pop-up menu
Figure 3—6
17.In the Object List rollout, select C3Dsurface-C-TOPO-

Building Pad. In the Surface Parameters rollout, select the

Statistics tab and note that in the Face Selection Sets, in By

Material ID, [31] Ground Type 4 has been assigned, as
shown in Figure 3—7.

Object List |

Surfaces (10)

C3Dsurface-Road-Region (1)
C3Dsurface-Road-Region (2)
C3Dsurface-Road-Region (3)
C3Dsurface-C-TOPO-Building Pad [l

Right-dick item for pop-up menu

[

Surface Parameters |-|

Surface Statistics
r~Surface Parameters
Face Count: 121
Vertex Count: 123
Area: 7112.742676 sq. feet

@ Face Selection Sets
=-£7] By Material ID
i\ (B [31] Ground Typg 3
:[I By Link Code
Figure 3-7
18. Right-click on [31] Ground Type 4 and select Modify
Material ID Assignment, as shown in Figure 3-8.

e T - _
Surface Statistics

Modify Material ID Assignment... %

r~Surface Parameters
Face Count: 121 Modify Tiling Parameters. ..
Vertex Count: 123

Area: 7112.742676 sq. fest Modify Smoothing Threshold (degrees)...

Calculate Surface Area...
{53 Face Selection Sets SHulate suriace Area

=] By Material ID
R [31] Ground Type

Delete TrianglesFaces. ..

Figure 3-8
19.Click Yes in the Warning dialog box.

3-8
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A material is not
required for the first
three corridor regions.

20.In the Modify material channel dialog box, select [22]
Concrete Type 1 as shown in Figure 3-9. Click OK.

* ] Modify material channel x|

Select a new material channel

[18] Asphalt Type 1
[19] Red Asphalt
[20] Water Type 1
21] Water T 2

[

[23] Paving Type 11
[24] Paving Type 12
[25] Road Markings

[31] Ground Type 4

|«

Figure 3-9

21.In the Perspective viewport, use Zoom and Pan to zoom
into the building pad. Note how the new material is applied.

22.If required, select Surfaces again and in the Object List
rollout, select C3Dsurface-C-TOPO-Existing Ground. In the
Surface Parameters rollout, in the Stafistics tab, right-click on
[31] Ground Type 4, and select Modify Material ID
Assignment. In the Warning dialog box, click Yes.

23. In the Modify material channel dialog box, select [28] Ground
Type 3 and click OK. In the Perspective viewport, note that
the new ground type material is applied to the ground
surface.

24. Similarly, for the other surfaces, apply the material types as
follows.

+ C3Dsurface-C-TOPO-Inside Curbing: [38] Concrete
Type 3

» C3Dsurface-C-TOPO-Inside Grading: [28] Ground
Type 3

» C3Dsurface-C-TOPO-Outside Curbing: [38] Concrete
Type 3

» C3Dsurface-C-TOPO-Outside Grading: [28] Ground
Type 3

» C3Dsurface-C-TOPO-Parking Lot Surface:[39] Asphalt
Type 4

25.Close the Civil View Explorer.
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26.Click ﬂﬂ (Zoom Extents All). In the Perspective view, the

scene displays as shown in Figure 3—10.

[+ ][Perspective ] [Shaded ]

Figure 3-10

27.Save your work as MyCivil Base XRef.max.
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3.2 Linking Files

File Linking is used to incorporate data from other Autodesk
software such as Autodesk Revit and AutoCAD into the
Autodesk 3ds Max scene. If the incorporated data is changed in
the originating software, the file link enables you to update those
changes in the 3ds Max scene. File linking is useful when you
are working on a visualization project and know that all design
decisions have not yet been made. You can link files using the
Manage Links dialog box that can be opened as follows:

. m (Application Menu)>Import>Link Revit: Links the .RVT
files from the Autodesk Revit Architecture software.

. m (Application Menu)>Import>Link FBX: Links the .FBX
files that can be created in the Autodesk Revit, Autodesk
MotionBuilder, Autodesk Maya, and Autodesk Mudbox
software.

. m (Application Menu)>Import>Link AutoCAD: Links the
.DWG and .DXF files from the AutoCAD software.

* You can also open the Manage Links dialog box outside of
the Link commands (Application Menu>References>
Manage Links) and modify the Link settings.

Linking DWG In CAD data files it is common to have large numbers of objects.

. When linking or importing AutoCAD .DWG or .DXF files, it is
Files efficient to combine multiple, related objects together into a
single Autodesk 3ds Max object to control their display and
visibility.

+  When multiple entities are combined into compound
Autodesk 3ds Max shapes (2D objects) and meshes (3D
objects), you can still access and adjust the original geometry
using the Sub-object level modifiers, such as Edit Spline,
Edit Mesh, and Edit Poly.

* Once multiple entities are combined, you can detach objects
or portions of an objects to form new ones for individual
editing control.
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Linking FBX
and RVT Files

Manage Links
Options

The Autodesk Revit and Autodesk 3ds Max software share a
mental ray renderer. Both products use the Autodesk Material
Library materials.

The .RVT and .FBX file format supports the import of
photometric lights, both interior artificial lights and exterior
daylight systems.

Detailed .RVT and .FBX file formats can become very large in
size and importing them as single files cannot be
accomplished. In such cases, use a section box in the 3D
View in the Autodesk Revit software to limit the amount of the
scene you are exporting.

The Manage Links dialog box (shown in Figure 3—11) contains
the following tabs:

Manage Links

J.Atlach ] Files ]Presets ]

He...

I C:\Autodesk 3ds Max Design Fundamentals Class Files\import\3D Parking Lot Deta |

Preset:
IDWG File Saved from AutoCAD v

v Rescale
Incoming file units:

IFeet b

Select Layers to indude... |

Attach this file |

Figure 3-11

Attach Tab

The options available in the Attach tab are described as follows:

File... enables you to open a file ((DWG, .DXF, .FBX, or .RVT)
for linking. The selected filename and its path display in the
File drop-down list. If the file that you selected is a .RVT file
with more than one camera view, you are prompted to select
a camera view.

© 2015, ASCENT - Center for Technical Knowledge®
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The Preset drop-down list enables you to select the preset
settings. The Presets listed here can be created or modified
using the Presets tab. You can set the units by selecting them
in the Incoming file units drop-down list.

Select Layers to include is only available with . DWG and
.DXF file formats and enables you to select the layers that
you want included with the drawing file.

Attach this file links the selected file with the specified
preset settings to the current Autodesk 3ds Max scene.

Files Tab

The Files tab displays a list of files that are linked to the current
scene with a specific status icon.

If the linked file has been modified, [ displays with the linked
filename.

™ indicates that the linked file is unchanged and does not
have any errors.

When a file is highlighted, the following options are available:

Reload... When the original file has been changed, it displays the
changes in the current scene.

Detach... Use when you want to remove the link with the original file.
This option removes all geometry associated with the linked
file.

Bind... Removes the link with the original file, but the geometry stays

in the current scene, although the link between the original file
is broken. Changes made to the original linked file cannot be
reloaded.

Presets Tab

Many options are available before files are linked to your current
scene. These options are configured and saved as Presets and
can be used when linking files at a later stage. Many of these
options require trial and error to find the most appropriate
settings. You can link a file and then reload (or detach and relink)
with different settings until you achieve the required results.

© 2015, ASCENT - Center for Technical Knowledge® 3-13



Autodesk 3ds Max 2016 Fundamentals

If you are linking a file
for the first time, it is
recommended that you
create a new preset.

File Link
Settings: DWG
Files

The Presets tab lists all existing presets and contains options for
creating new presets, modifying existing presets, copying
existing ones, renaming and deleting them. You need to select a
preset for the Modify, Copy, Rename, and Delete options to be
available, as shown in Figure 3—12. If no preset is selected,
Copy is replaced by New and is the only available option.

# Manage Links

Atlach| Files |Presets

Named Presets:

Autodesk Revit files (RVT or FBX :
Autodesk Revit - Combine By Revit Material m
Autodesk Revit - Combine By Revit Category G
Autodesk Revit - Combine By Revit Family Type opY...
Autodesk Revit - As One Object
Autndesk Revit - Do Not Combine Entities R
Revit Preset

Autodesk FBY files Delete...
Autodesk FBX (Generic) files

AutoCAD Drawings

DWG File Saved from AutoCAD

DWG File Exported from Revit

DWG File Saved from AutoCAD Architecture
AutoCAD - Derive by Layer

Figure 3-12

Depending on the type of preset selected (.RVT, .FBX, or
.DWG), clicking Modify... opens a specific File Link Settings
dialog box, which enables you to define the way you want the
geometry to be linked, what portions of the file are to be modified
on Reload, and how the geometry is combined.

In the Manage Links dialog box, in the Presets tab, selecting an
AutoCAD DWOG file preset and clicking Modify... opens the File
Link Settings: DWG Files dialog box, as shown in Figure 3—13.

F 1 File Link Settings: DWG Files

DWG File Saved from AutoCAD

J Basic ]Advanced lSpIine Rendering ]

[ cap dosed splines

[V Weld nearby vertices Weld threshold: IU'U' J
¥ Auto-smooth adjacent faces Smooth-angle: |15.0 J

[ orient normals of adjacent faces consistently

Texture mapping: IGenerabe coordinates for all objects |

ik

ik

Curve steps: | 10 ﬂ

Maximum surface deviation for 3D solids: IO:L'— ﬂ
Indude
¥ External references [™ Lights
[ Hatches [~ sun and sky
v Paints [V Views and Cameras
™ UcCSss (grids)

Cancel

Figure 3-13
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You can adjust
smoothing later if you
still encounter
smoothing issues after
import.

Basic Tab

The options available in the Basic tab are described as follows:

Weld nearby vertices and Weld threshold: Welding joins
together vertices of the same object that fall in the weld
threshold. If the objects are joined by layer, this option
removes duplicate vertices so that the adjacent 2D objects on
the same layer are automatically combined into splines.
Adjacent 3D objects that are welded become faces in a single
mesh that share common vertices.

Auto-smooth adjacent face and Smooth-angle:
Auto-smooth enables adjacent faces in the same 3D mesh to
display smooth if the angles of separation between their face
normals (a directional vector perpendicular to the face) is
equal to or less than the Smooth-angle. Otherwise, the
adjacent faces have a faceted edge between them. This is
the same smoothing process used in the Edit Mesh and Edit
Poly modifiers.

Orient normals of adjacent faces consistently: This option
coordinates the face normals of linked objects. This option
should be left off by default unless some faces of your 3D
objects are missing after the link.

Cap closed splines: It assigns an Extrude modifier to all
closed 2D geometry (e.g., circles and closed polylines).

Texture mapping: Texture mapping is used to locate texture
maps on objects. Two options are available:

Generate * Links objects without adding any texture mapping.
coordinates « Adds the mapping when it is first called for by the
on-demand software.

» Enables a faster link but might cause some

discrepancies.

Generate » Adds texture mapping to all objects at the time of the
coordinates link, matching any that might have existed in the
for all objects original drawing file.

* Curve steps:

This setting defines the number of segments to

subdivide each 2D curve segment into if they are later
extruded in the Autodesk 3ds Max software. This setting
applies to circles, arcs, polyline curves, spines, and similar
curved objects.

© 2015, ASCENT - Center for Technical Knowledge®
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+ Maximum surface deviation for 3D solids: This setting
defines the allowed deviation distance from a parametric
AutoCAD 3D curve (such as a curved AutoCAD extrusion)

This value can be set as and the resulting Autodesk 3ds Max mesh. The lower the

low, (0.01). value, the more a 3D curve is subdivided. In the Autodesk

3ds Max software, all 3D curves must be segmented.

* Include area options: These options enable you to select
the type of objects to be brought into the scene. Note that the
Lights option only brings in Lights from AutoCAD drawings
pre-2007. If you have Sun and Sky checked, a daylight
system is created based on the information in the incoming
DWG file from the Autodesk Revit 2009 software.

Advanced Tab
The Advanced tab (shown in Figure 3—14) controls the import of

AutoCAD primitives and the effect of scene materials while
importing.

b ] File Link Settings: DWG Files

DWG File Saved from AutoCAD

Basic | Advanced ] Spline Rendering ]

Derive AutoCAD Primitives by:
ILayer, Blocks as Node Hierarchy, Split by Materia| »

Select Lavers o indude ‘

[ Create helper at drawing origin

[™ Use Extrude modifier to represent thickness
[™ Create one scene object for each AutoCAD Architecture one
[ Use scene material definitions

[ Use scene material assignments on Reload

Figure 3-14
The options available in the Advanced tab are described as
follows:

* Derive AutoCAD Primitives by: Controls how AutoCAD
objects are combined when linked.

3-16 © 2015, ASCENT - Center for Technical Knowledge®
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Layer

Creates one object for each AutoCAD layer. Each
AutoCAD block links as a single object called a
VIZBlock.

Layer, Blocks
as Node
Hierarchy

This option preserves material assignments in linked
AutoCAD blocks. It structures each as a hierarchy of
objects rather than single objects.

Layer, Blocks
as Node
Hierarchy,
Split by
Material

This option works similarly to the one above but takes
into account drawings that have more than one material
applied to objects on the same layer. Separate
hierarchies are created for each material type on each
layer.

Entity, Blocks

This option includes all non-blocks as separate,

as Node individual objects. Blocks are preserved as hierarchies,

Hierarchy however, organized by layer.

Color Combines AutoCAD objects by color. All objects of one
color are joined in as a single object, regardless of layer.

Entity Does not combine AutoCAD objects at all. Instead, each
AutoCAD object becomes an individual object.

One Object This option combines all AutoCAD objects into a single

object.

* Create helper at drawing origin: Adds an origin point helper
at the origin of the current coordinate system. All of the linked
geometry is part of a hierarchy parented by this helper, so all
of the linked objects can be repositioned as one by
transforming the helper.

* Use Extrude modifier to represent thickness: When
disabled, linking 2D AutoCAD objects with a non-zero
thickness value translates the objects into the Autodesk 3ds
Max software as a 3D mesh. When enabled, objects translate
as 2D objects with a parametric extrude modifier. The
resulting geometry is the same but when this option is
enabled, the extrusion properties (such as height) can be
modified after the link or imported using the modifier stack.

* Create one scene object for each AutoCAD Architecture
one: When unchecked, AutoCAD Architecture (formerly
ADT) and AutoCAD MEP objects are subdivided into
separate objects by material. It is recommended to leave this
option unchecked, since AutoCAD Architecture objects often
contain more than one material. Linking each AutoCAD
Architecture object as a single Autodesk 3ds Max object
would require you to configure Multi/Sub-Object materials to
show different materials on different parts of the same object.
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+ Use scene material definitions: When unchecked, the
Autodesk 3ds Max software includes the current state of any
material applied to the linked objects in the AutoCAD
software. If selected and the current scene has a material
with the same exact name as the AutoCAD material, the
scene material is used instead.

+ Use scene material assignments on Reload: When
unchecked, the Autodesk 3ds Max software re-loads the
current state of any AutoCAD materials present in the
drawing file when the link is updated. When enabled, the
Autodesk 3ds Max software maintains the current state of
any materials in the scene file after a link is updated. Select
this option if you intend to adjust linked materials in the
Autodesk 3ds Max software or leave it unchecked if you
intend to adjust them the AutoCAD software.

+ Selective Reload: Enables you to reload a subset of the
original file. You can select objects to reload by selecting
them in the scene or by selecting them from a list. If you
select Selected in List, and click Linked Objects a list
opens.

Spline Rendering Tab

The options available in the Spline Rendering tab (shown in
Figure 3—15) enable linear objects (2D and 3D lines, polylines,
etc.) to display as extruded 3D objects in the viewports or
rendering. Normally, splines cannot be rendered because they
do not have surface area to interact with scene lighting. These
options enable splines to link into the Autodesk 3ds Max
software as 3D linear objects with a cross-sectional radius or a
rectangular length and width. This provides the surface area for
rendering.

File Link Settings: DWG Files.
DWG File Saved from AutoCAD
Basic I Advanced ISpIirle Rendering
[~ Enable in Renderer " Viewport —% Renderer
™ Enable in Viewport & Radial
I~ | Use Viewport Settings Thidcness:IU'l'—ﬂ
[ Generate Mapping Coords. Sides: |12 ﬂ
¥ Real-World Map Size Angle: |0,o ﬂ
[¥ Auto-smooth  Rectangular
Threshold:l"l(].o ﬂ Lenath I—: 5 ﬂ
wect:[50 2|8
Figure 3-15
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» If splines are to be rendered with materials then options such
as smoothing, mapping coordinates, and/or real-world map
size are often important.

+  When enabled, all of the splines linked with this setting are
renderable, and all have the same cross-section geometry.

« To make only certain 2D objects renderable (or want some to
render differently than others) you could apply a Renderable
Spline modifier directly to those objects after linking, as
shown in Figure 3—16.

i

Figure 3-16

Hint: Hierarchies and File Linking

Autodesk 3ds Max Hierarchies are collections of objects linked
together into parent/child relationships where transform applied
to a parent are automatically passed on to its children.
Connecting multiple objects in a hierarchical chain can enable
sophisticated animations in the Autodesk 3ds Max software,
such as the motion of jointed robotic arms.

In the case of the hierarchy file link options, incoming
AutoCAD blocks are brought into the Autodesk 3ds Max
software as multiple objects so that they can maintain multiple
material assignments from the AutoCAD software. They display
together with a Block/Style Parent object, enabling you to
transform the block as a unit by selecting the parent. The
parent object itself does not have any geometry and does not
render. Most modifiers (such as Substitute) must be applied to
the objects in the hierarchy rather than the parent.
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File Link
Settings: Revit
Files (RVT or
FBX)

In the Manage Links dialog box, in the Presets tab, selecting an
Autodesk Revit file and clicking Modify... opens the File Link
Settings: Revit Files (RVT or FBX) dialog box, as shown in
Figure 3—17. Additionally, you can also select the Autodesk FBX
(Generic) file preset and click Modify....This opens the File Link
Settings: FBX Files dialog box, as shown in Figure 3—18. This
dialog box is similar to the Autodesk Revit Files (.RVT and .FBX)
but without a Geometry area for controlling the segments and
smoothing the linked geometry.

File Link Settings: Revit Files (RVT or FEX)

Combine Entities:

|Aubodesk Revit - Combing By Revit Material

# ] File Link Settings: FBX Files

F\utodesk FBX (Generic) files

[By Revit Material

— Objects

[# Lights
[+ Daylight System
|+ Cameras

¥ Create Helper at Model Origin

~Objects
[V Create Helper at Model Origin
[ Lights

[¥ Daylight System

v Cameras

—Geometry

Curved Objects Detail:

[¥ Auto-Smooth adjacent faces

It is recommended that
you combine entities to
reduce the number of
objects.

""" j o o ~Materials
[™ Keep 3ds Max scene materials parameters on reload
L ™ Keep 3ds Max scene material assignments on reload
—Materials
[ Keep 3ds Max scene materials parameters on reload Save | Cancel

[ Keep 3ds Max scene material assignments on reload

Figure 3-17

Figure 3-18

The options available in the File Link Settings: Revit Files (RVT
or FBX) dialog box are described as follows:

Combine Entities list: Enables you to select the Autodesk
Revit entities that you want to combine, as shown in

Figure 3—19. For example, if you select By Revit Material, all
of the entities that have the same material are linked in the
current Autodesk 3ds Max scene as a single object.

Combine Entities:
By Revit Material

By Rewit Category
By Revit Family Type
As One Object

Do Mot Combine

Figure 3-19

3-20
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* Objects area: The selected options in this area are linked
from the .RVT file to your current scene. If the .RVT file or
.FBX file contains photometric lights, interior artificial lights,
cameras, and exterior daylight systems, you can select the
associated options in the File Link Settings dialog box. While
linking the daylight system from the .RVT/.FBX file, the
Autodesk 3ds Max software recommends that you toggle on
the exposure control, as shown in Figure 3-20.

" 1 paylight System Creation

¥ou are creating a Daylight system.

It is recommended that you use the mr Photographic Exposure Control set to an Exposure Value of EV = 15,
Exposure Control settings can be adjusted from the Environment & Effects dialog.

Would you like to change this now?

Yes MNo

[~ Do not show this message anymore (for this session)

Figure 3-20
» Geometry area: Enables you to set the number of segments
for your curved entities and apply auto-smoothing to them.

* Materials area: Enables you to control the material
definitions and assignment settings.
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Practice 3b

Estimated time for
completion: 20 minutes

If a dialog box opens
prompting you about a
File Load: Mismatch,
click OK to accept the
default values.

If no preset is selected,

only New... is available.

Linking an AutoCAD DWG

Practice Objectives

Create a preset to link an AutoCAD .DWG file and reposition it.
Revise the link settings and reload the linked file.

In this practice you will link AutoCAD geometry to represent the
parking lot details, such as pavement markings and other details.
You will reposition this file using the Helper object, and will create
3D markings by projecting 2D lines to the elevation of a terrain
model.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Link an AutoCAD .DWG File.

1. Open Civil Base.max from the ...\scenes folder.

2. Select Application Menu>Import>Link AutoCAD. In the
Open dialog box, browse and open the ...\import folder.
Select 3D Parking Lot Detail.dwg and click Open. The
Manage Links dialog box opens with the path and the
filename displayed, as shown Figure 3—-21.

Manage Links

Attach | Files |Presets
I C:\Autodesk 3ds Max Fundamentals Practice Filesimport\3D Parking Lot Detail.dwg ¥
Preset:
DWG File Saved from AutoCAD v
Figure 3-21

3. Select the Presets tab and click New... to create a new link
preset.

4. Inthe New Settings Preset dialog box, set New Name as
AutoCAD - Derive by Layer. Note that the Format is
selected as AutoCAD Drawings. Click OK.

3-22
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The Create Helper at
drawing origin option
adds a helper object at
the origin of the linked

file.

5. In the Manage Links dialog box, select the new AutoCAD -
Derive by Layer preset, as shown in Figure 3-22. Click
Modify....

5 Manage Links

Atlachl Files [Prééﬂ]

| Autodesk Revit files (RVT or FBX)

Autodesk Revit - As One Object

Autodesk FBX files
Autodesk FBX (Generic) files
| AutoCAD Drawings
DWG File Saved from AutoCAD
DW File Exported from Revit

AutoCAD - Derive by

(clear).

F 1 File Link Settings: DWG Files

Autodesk Revit - Combine By Revit Material
Autodesk Revit - Combine By Revit Category
Autodesk Revit - Combine By Revit Family Type

Autodesk Revit - Do Not Combine Entities

DWG File Saved from AutoCAD Architecture

Figure 3-22

F 1 File Link Settings: DWG Files

6. In the File Link Settings: DWG Files dialog box, in the Basic
tab, set the link options, as shown in Figure 3—23. Select the
Advanced tab and select Create helper at drawing origin,
as shown in Figure 3—-24. Leave all other options as defaults

Iﬂ.utoCAD - Derive by Layer

J Basic l.ﬁ.d'u'anced ]Spline Rendering ]

Iﬂ.utoCAD - Derive by Layer

[ Basic l.ﬁ.d'u'anced ]Spline Rendering ]

Weld threshaold: |U'0‘ ﬂ
Smooth-angle: |4ﬂ,|:| ﬂ

[™ Orient normals of adjacent faces consistently
[” Cap dosed splines
Texture mapping: IGenerate coordinates for all objects |

Curve steps: | 10 ﬂ

Maximum surface deviation for 30 solids: |U'0 Fja" ﬂ

¥ Weld nearby vertices
v Auto-smooth adjacent faces

Indude

¥ External references [ Lights

[~ Hatches [ Sun and sky

I Points ™ Views and Cameras

[ ucss (grids)

Save Cancel

Derive AutoCAD Primitives by:
ILayer, Blocks as Node Hierarchy, Split by Materia| »

Select Layers to indude... |

W Create helper at drawing origin

[~ Use Extrude modifier to reprezent thickness

[” Create one scene object for each AutoCAD Architecture one
™ Use scene material definitions

™ Use scene material assignments on Reload

Save Cancel

Figure 3-23

Figure 3-24
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7. Select the Spline Rendering tab and verify that the link
options are set as shown in Figure 3-25.

F] File Link Settings: DWG Files

AutoCAD - Derive by Layer
| Basic | Advanced | Spline Rendering |
[ Enable in Renderer ™ Viewport —® Renderer -
™ Enable in Viewport % Radial
= Use Viewpaort Setings Thid . W ﬂ
[~ Generate Mapping Coorde. Sides: |12 ﬂ
¥ Real-World Map Size Angle:[00 2
v Auto-smooth ¢ Rectangular
Threshold: |40.EJ ﬂ Length: ID'G’— ﬂ
Width: [0'2° 2
Angle: ID.IZI =
Aspect: |3.IZI ﬂﬂ
Save Cancel
Figure 3-25
8. Click Save.

9. In the Manage Links dialog box, select the Attach tab. Set
Preset to AutoCAD - Derive by Layer, as shown in
Figure 3-26. Click Select Layers to include....

| Manage Links

C:\Autodesk 3ds Max Fundamentals Practice Filesimport)\3D Parking Lot Detail.dwg

DWG File Saved from AutoCAD

Figure 3-26
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You might need to start
Civil View, if it is not set
to start automatically.

10.In the Select Layers dialog box, select Select from list. Clear
0 and DEFPOINTS and leave all other layers as selected, as
shown in Figure 3-27. Click OK.

Select Layers

T
g
g
g
g
g
g
g
g
g
g o

L L ML L L L, A

Figure 3-27

11. In the Manage Links dialog box, click Attach this file. Close
the Manage Links dialog box. Note that the parking lot details
have been added to the scene, but are located far away from
the origin, as shown in the Top viewport in Figure 3—28.

[+1[Top ] [Wireframe ]

Figure 3-28

Task 2 - Relocate the Linked Geometry.

1. You need to move the parking lot details by the global shift
values in Civil View. In the menu bar, select Civil View>Civil
View>Civil View Explorer.
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If the Scene Explorer is
not displayed, select
Tools>Scene Explorer
and then dock it.

2,

In the Civil View Explorer, select Scene Settings, as shown
in Figure 3—29. In the Scene Settings rollout, note the Global
Import Shift values for X Shift and Y Shift (-9901), as shown
in Figure 3—30. Close the Civil View Explorer.

= Civil View Explorer |

JCiuiI Explorer ]Resuur::es ] Tools ]
@ Civil View Explarer

------ Scene Settings

= Scene Settings |

£ Civil View Materials (1) % Shift:
EIE] Civil View Objects (11) ¥ Shift:

El Environment and Lighting |'G|uba| Impaort Shift

o o

- =] Imported Objects (11)
Figure 3-29

Figure 3-30

+
O
In the Main Toolbar, click (Select and Move).

. In the Scene Explorer, (D (Display None) and = (Display

Helpers)) select the helper object 3D Parking Lot
Detail.dwg, as shown in Figure 3—-31. Note that the User
Coordinate System icon located at the origin is selected, as
shown in Figure 3-32.

(7) |Name (Sorted Ascending)

& ¢ ©L] 3D Parking Lot Detail.dwg
Ly

5

=

Figure 3-31

Figure 3-32

In the Status Bar, verify that [ (Absolute Mode Transform)
is displayed. Set the following, as shown in Figure 3—-33:

« Xedit box: -9901°0"
* Y edit box: -9901°0"

[ x|-os0r0”  2lv:|EENE :lz:foo”
Figure 3-33
Press <Enter>.

Click IEEI (Zoom Extents All). Note how the parking lot details
are placed exactly on the parking lot surface.

3-26
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In the Files tab, if the
linked file has been

modified, [ displays.
You can use:

Reload... to update the
file in the scene.
Detach... to remove a
linked drawing from the
scene.

Bind... to insert the
drawing as is and
removes the
connection.

The 2D linework should
no longer display,
keeping the scene
smaller.

. . Q! i .
8. Inthe Perspective viewport, use (Zoom) and <+ (Orbit)

to zoom into the Parking lot area and tilt the view to display
the area below the surfaces, similar to that shown in
Figure 3—-34. Note that in addition to the 3D pavement
markings, 2D line markings are imported through the link.

Figure 3-34

Task 3 - Revise the Link Settings.

1.

Click Application Menu>References>Manage Links to
open the Manage Links dialog box.

In the Manage Links dialog box, select the Files tab and note

that the linked file displays D, indicating that the file has not
changed. (Although the linked file has not changed, use
Reload... to revise the link settings.) Verify that Show
Reload options is selected, and click Reload....

The File Link Settings: DWG Files dialog box opens. In the
Advanced tab, click Select Layers to include.... Clear the
2D layers (C-MARK-WHITE-2Dand C-MARK-YELLOW-
2D), and the two LIGHTPOLE layers, as shown in

Figure 3-35.

Select Layers

 Skip all frozen layers @ Select from list
o Voo Al

 IDPROI PRl

" C-MARK-SYM-3D 5 o 0 .
C-MARK-WHITE-2D T % L

" C-MARK-WHITE-3D oA L
C-MARK-YELLOW-2D 7 # 0

" C-MARK-YELLOW-3D 7 o

" C-PARK-CURB ¢ oo
DEFPOINTS @ oo
LIGHTPOLE_DOUBLE T
LIGHTPOLE_SINGLE (YA )

Figure 3-35

4. Click OK twice to close both dialog boxes. Click to

close the Manage Links dialog box.

5. Save your work as MyCivil Base.max.
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Practice 3c

Estimated time for
completion: 20 minutes

If a dialog box opens
prompting you about a
File Load: Mismatch,
click OK to accept the
default values.

It might take a few
minutes to load the file.

Linking and Reloading Autodesk
Revit File

Practice Objectives

Link and reposition an Autodesk Reuvit file to the current scene.
* Reload a modified .RVT file.

In this practice you will link a .RVT file into a 3ds Max scene. You
will reposition the Reuvit file using the Helper object. You will then
reload a modified version of the .RVT linked file to incorporate
the changes made to the original Autodesk Revit file using
Reload.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Link an Autodesk Revit (.RVT) file.

1. Open Civil Base Link.max from the ...\scenes folder.
2. Select Application Menu>Import>Link Revit.

3. In the Open dialog box, in the ...\import folder, select Revit
Building-1.rvt and click Open.

4. The Status Bar is replaced by the Loading file bar, indicating
the progress of the file as it loads. Once loaded, the Select
Revit View dialog box opens, as shown in Figure 3-36.

E] select Revit View... =reTx

Front Exterior 3D View

OK I Cancel
Figure 3-36

5. Select Front Exterior 3D View and click OK.
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The Create Helper at
Model Origin option
adds a helper object at
the origin of the linked
file. Selecting and
applying transforms
(move, rotate, or scale)
to the helper object
applies the transform to
the linked geometry
together.

. In the Manage Links dialog box, select the Presets tab. Click

New... to create a new preset. In the New Settings Preset
dialog box, set the following:

* New Name: Revit Preset
» Format:. Autodesk Revit (*.rvt,*.fbx).

. Click OK.

. In the Manage Links dialog box, select Revit Preset and click

Modify.

. In the File Link Settings dialog box, do the following, as

shown in Figure 3-37:

* In the Combine Entities drop-down list, select By Revit
Category.
* In the Objects area, clear Lights and Daylight System.

* Inthe Objects area, select Create Helper at Model
Origin and Cameras.

* In the Geometry area, set Curved Objects Detail to 6.

* In the Materials area, verify that Keep 3ds Max scene
materials parameters on reload and Keep 3ds Max
scene material assignments on reload are cleared.

b ] File Link Settings: Revit Files (RVT or FEX)

Fevit Preset

Combine Entities:

IBY Revit Category w

—Objects
¥ Create Helper at Model Origin
[~ Lights

[~ Daylight System

[¥ Cameras

— Geometry
Curved Objects Detail:

[~ Auto-Smooth adjacent faces

—Materials
[~ Keep 3ds Max scene materials parameters on reload

[~ Keep 3ds Max scene material assignments on reload

Save | Cancel

Figure 3-37

10.Click Save.
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(It might take a few
minutes to load the file).

If the Scene Explorer is
not displayed, select
Tools>Scene Explorer
and then dock it.

The position of the
building pad from the
origin has been
calculated.

Grid has been hidden
for clarity. Press <G>.

11. Select the Attach tab. Expand the Preset drop-down list and
select Revit Preset.

12.Click Attach this file. Note that the Autodesk Revit building
and camera are loaded at the 0,0,0 location in the viewports.

[F—
13.Click to close the Manage Links dialog box.

14.1n the Scene Explorer toolbar, (D (Display None) and 2.
(Display Helper)) select the helper object Revit
Building-1.rvt, as shown in Figure 3-38.

O Name (Sorted Ascending)

% Q [Z% | 3D Parking Lot Detail.dwg
< ‘.. J O | Revit Building-1.rvt

=

=

o

Figure 3-38
15.Right-click on the Top viewport to make it active and to

maintain the selection. In the Main Toolbar, click (Select
and Move). The Transform gizmo is displayed at the helper
location, which is the origin of the linked Autodesk Revit file.

16.In the Status Bar, verify that ] (Absolute Mode Transform)
is displayed. Set the following, as shown in Figure 3—-39:

« X edit box: 800°0"
e Y edit box: 382°0"
 Zedit box: 154°6"

@x:|snn'n' ﬂv:|3&2‘n' ﬂz:| ﬂ|
Figure 3-39

17.Press <Enter>.

18.Click 53 (Zoom Extents All). Note how the building is placed
on the building pad.

19.1n the Front viewport, use “Q. (Zoom Region) and create a
rectangular window around the building to zoom into the
building. Select the Wireframe Visual Style label and select
Realistic. The building should display similar to that shown in
Figure 3—40.
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Figure 3-40

20.In the Perspective viewport, use Cf (Zoom) and &. (Orbit)
to zoom into the building and parking lot area, as shown in
Figure 3—42.

21.In the Left viewport, select the Wireframe Visual Style label
and select Shaded. Select the Left Point of View label, and
select Cameras>Views: Front Exterior 3D View, as shown

in Figure 3—41.
: Cameras k Views: Front Exterior 3D View I}
Lights r Views: {30}

Figure 3-41

22.Use (2d Pan Zoom) and . (Field-of-View) to display the
complete building in the Left viewport, as shown in
Figure 3—42.

Figure 3—42
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Task 2 - Reload the variation of the .RVT file.

#& Manage Links

1.
2.

Attach | Files |Presets |

A variation to the .RVT linked file (windows have been added)
has been included in the ...\import folder.

In Windows Explorer, open the ...\import folder.

Right-click on Revit Building-1.rvt and select Rename.
Rename the file as Revit Building-1_ORIGINAL.rvt.

Right-click on Revit Building-2.rvt, and select Copy. Paste a
copy of this file into the same directory. Right-click on the
copied file, select Rename, and rename the file as Revit
Building-1.rvt. This must be the same name as the original
file that was linked to indicate that the original linked file has
changed.

Return to the Autodesk 3ds Max software. Select
Application Menu>References>Manage Links to open the
Manage Links dialog box.

In the Manage Links dialog box, select the Files tab. Note

that [ displays in front of the .RVT filename (as shown in
Figure 3—-43), indicating that changes have been made to the
original linked file.

1 C:\autodesk 3ds Max Fundamentals Practice Files\import3D Parking Lot Detail. dwg
J\utodesk 3ds Max Fundamentals Practice FilesimportiRevit Building-1.rvt (Front Exterior 30 View)

[

Figure 3-43

6. Select the complete path of Revit Building -1.rvt (if not

already selected) and click Reload.... The Loading file bar
displays the progress.

In the File Link Settings dialog box that opens, in the
Materials area, select Keep 3ds Max scene material
assignments on reload. Click OK. The scene is refreshed
with the new changes.
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8. In the Manage Links dialog box, in the Files tab, the icon has

changed to B, as shown in Figure 3—44. This indicates that
there are no differences between the original file and the
linked file.

5 Manage Links

[ C:\Autodesk 3ds Max Fundamentals Practice Files\import\3D Parking Lot Detail.dwa
i ¢ :\Autodesk 3ds Max Fundamentals Practice Files\import\Revit Building-1.rvt (Front Exterior 30 View)

Figure 3-44
9. Close the Manage Links dialog box.

10.In the viewports, the modified building is displayed. Note that
more windows have been added to the building, as shown in
Figure 3—-45.

Figure 3-45

11. Save the file as MyCivil Base Link.max.
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External
References
(XRef)

Data
Management
and Asset
Tracking

3.3 References

Autodesk 3ds Max Scene files can reference data from other
.MAX scene files by expanding Application Menu>
References>XRef Objects or XRef Scene. The XREF data
remains linked to the source (.MAX) scene file so that changes in
the source file can be reflected in any scene that contains the
XREF.

External References are useful to break up large projects into
more manageable pieces, permit more than one person to
work on the same project at the same time in separate files,
and to enable the same core scene geometry to be used in
multiple files.

XRef Scenes bring in the entire scene. All of the XREF
objects are non-selectable and cannot be modified.

XRef Objects enable you to select individual objects (or all)
from an XREF scene. These objects remain selectable and
modifiable in the XREF scene file.

You can snap to XREF and use XREF objects with AutoGrid.
You can also use XREF objects as alignment targets and you
can select an XREF object’s coordinate system for object
transformation. XREF support parameter wiring and you can
XREF the controllers.

Objects in scenes (.MAX) are imported into other . MAX
scenes using the Merge option.

The Autodesk 3ds Max software enables you to manage your
data through Data Management (DM) solutions, referred to as
Asset Tracking Systems (ATSs).

DM solutions such as the Autodesk® Vault software enables
you to store scene files and any supporting data (such as
material maps) in a single database repository.

These systems can be accessed simultaneously by multiple
users with different rights assigned based on their project
responsibilities. Data can be checked out for editing by one
individual at a time while still being referenced by other users.
Users can see who is editing which portion of the project at
any time.
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* By centralizing the files in a DM system it is much easier to
adjust paths for external files such as image maps.

» Data files can be versioned through DM solutions, so that the
older versions can be readily accessed, if required.

* For more information see Asset Tracking in the Autodesk 3ds
Max Help files. Asset Tracking is available through the
Application Menu>References> Asset Tracking.
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Practice 3d

Estimated time for
completion: 15 minutes

If an unsaved scene is

open, you need to save
or discard the changes
to the scene.

XRef and Merge Objects

Practice Objective

Link an AutoCAD .DWG file and incorporate objects from another scene
file into the current scene.

In this practice create a new scene file that will contain linked
AutoCAD objects and XRef objects from the Civil Base scene.
You will then merge obijects into the current scene file.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Assemble the Data.

1. Click Application Menu>Reset and click Yes to reset the
scene.

2. For this scene, set the System Unit Scale to Inches. Select
Customize>Units Setup. In the dialog box, verify that the
following is set:

» Display Unit Scale: US Standard, Feet w/ Fractional
Inches

» Default Units: Inches
» Lighting Units: American

3. Click System Unit Setup. In the System Unit Setup dialog
box, set System Unit Scale to Inches. Click OK in both the
dialog boxes.

4. Expand Application Menu>References and select Manage
Links.

5. Inthe Manage Links dialog box, in the Aftach tab, click File....
In the ...\import folder, select Exterior AutoCAD
Architectural Model.dwg. Click Open.
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The AutoCAD - Derive
by Layer preset was
created in the Practice:
Linking an AutoCAD
DWG. Complete the
above mentioned
practice to create the
preset if not already
done so.

You select objects to
XREF rather than the
entire scene because
XREF scene objects
cannot be individually
selected or modified.

6. Inthe Preset drop-down list, select AutoCAD — Derive by
Layer and click Attach this file. Once the file has been
loaded, close the Manage Links dialog box.

« The AutoCAD Architectural objects were not joined
together by layer. Each was subdivided by material type
into different objects. Materials previously assigned in
AutoCAD Architecture were preserved on these separate
objects.

7. Click (Maximize Viewport Toggle) or use <Alt>+<W> to
display the four viewport view.

8. Click 53 (Zoom Extents All) to display all of the objects in all
of the viewports.

9. In the Front viewport, select all of the objects by creating a
window around the objects. In the Main Toolbar, in the
Named Selection Sets field, enter exterior AutoCAD
Architectural building, as shown in Figure 3-46. Press
<Enter>.

\ u,-"gﬁ Elﬁ | {},?[Exterinr AutoCAD A v|| D|q

ABC

Figure 3-46
10.Click Application Menu>References>XRef Objects. In the

XRef Objects dialog box, click (Create XRef Record from
File) as shown in Figure 3—47.

F] xref Objects

{jgx#c%ﬁa ”

g!‘:"l;i!l
&g

F Create XRef Record from File... ] ‘

Figure 3-47

11. In the Open File dialog box, select Parking Lot Detail.max
(from the ...\import folder) and click Open.

12.1f the Units Mismatch dialog box opens, click OK. This
rescales the XRef objects to the system units.
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Alternatively, you can
use the Scene Explorer

13.The Duplicate Material Name dialog box opens prompting
you that there is an incoming material with the same name as
an existing scene material. Select Apply to All Duplicates to
keep both materials, as shown in Figure 3—48. Click
Auto-Rename Merged Material.

Duplicate Material Name

& material name assigned to a merging object is a duplicate of a material in the scene.
Do you want to:

Rename Merged Material: | Global

[ Use Merged Material l Apply to All Duplicates

[ Use Scene Material l

L Auto-Rename Merged Material ]

Figure 3-48
14.In the XRef Objects dialog box, note that the .MAX filename
[F—
is displayed. Click to close the dialog box.

15.Click 53 (Zoom Extents All). Note that the Civil Base objects
are located far from the origin. This is a coordinate system
discrepancy and not a scale issue. It is common for
Architectural drawings to be based in a different coordinate
system and scale than the accompanying Civil/Survey
drawings.

Task 2 - Coordinate the Data.

In this task you will relocate the Civil Base in the Architectural
Data. To line up the data accurately you will need the exact
coordinate translation and rotation. You can measure ahead of
time in programs, such as AutoCAD by comparing the
coordinates of points common to both files.

1. In the Scene Explorer (D (Display None) and

tob,se’f"t all the XRef 9] (Display Object XRefs)), select all of the XRef objects in
ObJects. the list (use <Shift> and then select the first and last).
2. With these XRef objects selected, select Group>Group from
the menu bar.
3. In the Group dialog box, set the Group name to Site XRef
and click OK.
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The translation
coordinates have
already been measured
in AutoCAD.

+
. In the Main Toolbar, click (Select and Move). In the

Reference Coordinate System, select World, as shown in
O
Figure 3—49. Click E*-w (Use Transform Coordinate Center).

’Tﬁ* o I:I’_j : World v L]

Figure 3-49

. In the Status Bar, verify that (Absolute Mode) is

displayed. In the Transform Type-in area, set the following, as
shown in Figure 3-50:

« X -197°4”
« Y:-30°0”
. Z:-411”

x:|—19?4‘ ¢v:|—3&'n' ¢z:| =

Figure 3-50

. Press <Enter>.

. In the Main Toolbar, click % (Select Object) to exit the

Move transform operation.

. Click 53 (Zoom Extents All). In the Perspective viewport,

+
use & (Zoom), &. (Orbit), and Pan to zoom into the
parking lot and building area (as shown in Figure 3-51), and
verify that the building is located on the building pad.
Although the XREF had a different Unit Scale (feet), it scaled
correctly to the active scene (in inches).

Figure 3-51
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Merge enables both
objects to have the
same name, Skip
ignores the incoming
object, and Delete Old
removes the original
object.

9. Save your work as MyArchitectural Scene.max.

Task 3 - Merging Objects.

1. Expand Application Menu>Import>Merge. In the Merge
File dialog box, select Light Poles for Project1.max from
the ...\scenes folder. Click Open.

2. In the Merge dialog box, click All, as shown in Figure 3-52.
Click OK.

El Merge - Light Poles for Project1.max

—
—
—

|
|
|
|
|
|
|
|
I |

Figure 3-52

3. The Duplicate Name dialog box opens, prompting you that an
object with the same name already exists in the scene. Select
Apply to all Duplicates and click Auto-Rename.

4. The light poles are displayed in the scene, as shown in
Figure 3-53.

i
%

Figure 3-53

5. Save your work.

340
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Chapter Review Questions

1. The following file formats can be linked to the current
Autodesk 3ds Max scene:

a. .DWG, .0OBJ, .APF, .FBX
b. .DWG, .DXF, .FBX, .RVT
c. .DWG, .DXF, .MAX, .RVT
d. .DWG, .OBJ, .FBX, .RVT

2. In the Manage Links dialog box, in the Files tab, which of the
following options do you use to remove the link with the
original linked file but maintain its geometry in the current
scene?

a. Reload...
b. Detach...
c. Bind...

3. Which command do you use to combine objects from a saved
Autodesk 3ds Max scene (.MAX file) into your current .MAX

scene?

a. Import
b. Link
c. Open
d. Merge

4. While linking Autodesk Revit files in the current Autodesk 3ds
Max scene, which of the following options are provided in the
Combine Entities List? (Select all that apply.)

a. By Revit Material
b. By Revit Layer
c. As One Object
d. By Revit Camera

5. When an entire .MAX scene is brought into the current scene
using XREF Scenes, the XREF objects are selectable but
cannot be modified.

a. True
b. False
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Command Summary

Button Command Location

= Absolute » Status Bar

1
Mode

N/A Asset » Application Menu: References
Tracking

N/A Import * Application Menu: Import

N/A Link AutoCAD | - Application Menu: Import

N/A Link FBX * Application Menu: Import

Link Revit * Application Menu: Import
Manage Links | + Application Menu: References

Merge * Application Menu: Import

Select by * Main Toolbar
Name

Main Toolbar

N/A
N/A
N/A
=3
C@* Select Object

0 Use ¢ Main Toolbar
+, Transform

Coordinate

Center

N/A XRef Objects » Application Menu: References
N/A XRef Scene * Application Menu: References
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