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Assembling Project Files

The files used in the Autodesk® 3ds Max® software can be modeled directly in the
software, referenced by linking, or directly imported from another source. Linking
files enables you to incorporate objects or other scene files into the current scene
by externally referencing them. Once referenced, the connection between the two
files can be maintained. If files are imported, they are merged with the project and
no link is established. Understanding the benefits and drawbacks of using external
data helps you decide how to best reference it in a project.

Learning Objectives in this Chapter

» Understand the difference between File Linking and File Importing, and edit the linked data
files.

« Combine entities from .DWG, .DXF, .FBX, and .RVT files into an active Autodesk 3ds Max
scene.

« Understand how to link AutoCAD® DWG, DXF, generic FBX files, and Autodesk® Revit®
RVT/FBX files.

* Create and modify presets.
* Incorporate objects or other scene files into the current scene by externally referencing them.
* Manage data using the asset tracking systems.
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3.1 Data Linking and Importing

Although the Autodesk 3ds Max software has a robust 2D and
3D modeling system, it might be efficient to link or import some
or all of the design data from other Autodesk software, such as
AutoCAD®, Autodesk® Revit® Architecture, AutoCAD®
Architecture, or Autodesk® Inventor®.

Linking VS. You can link or import files using the File Link and Import tools.
. You can link files such as .DWG, .DXF, .FBX, and .RVT, and
|mp0I‘tl ng import files such as Autodesk® Inventor® (.IPT, .IAM), Autodesk®
Alias® .Wire, Autodesk® Showcase® .APF (Autodesk Packet
File), LandXML and DEM data files, and Adobe lllustrator (.Al).

» Linked geometry differs from imported geometry in that it
remains connected to the source file. If the source file is
edited, the Autodesk 3ds Max Scene can be updated to show
those changes. Imported geometry maintains no connection
to the source file.

« If a source .DWG, .DXF, .FBX, or .RVT file is likely to change
(or you would prefer to make changes in the .DWG, .DXF,
.FBX, or .RVT directly), then using File Linking might be the
best way to incorporate this data into the Autodesk 3ds Max
software.

* Importing can be used as a faster alternative to linking to
bring large amounts of data into the software. Complex
geometry might be faster to reimport than to update through a
file link.

* File links and imports are launched from the Application

Menu (as shown in Figure 3—1):

+ Expand W (Application Menu), expand Import, and
select Link Revit/Link FBX/Link AutoCAD, or

+ Expand w (Application Menu), expand Import, and
select Import.
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Editing Linked
Data

Importing

Merging
Autodesk 3ds
Max Scene
Files
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E Export » Link FBX
—_— F Inserta link to a FBX file into the current
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Send to 3
@ Link AutoCAD
A Inserta link to @ DWG or DXF file into the
current scene.
References  #

» Linked geometry can be edited but not directly deleted from a
scene file. Alternatively, the layer on which the objects are
placed might be ignored during a reload, or set to Hide in the
Layer dialog box.

» Edits applied to linked geometry (such as through modifiers)
are reapplied after a link is updated. Some complex
modifications might not apply as expected, so you should
always review your geometry carefully after a link is updated.

« Links to drawing files are not bi-directional, so that changes
you make to the data in the Autodesk 3ds Max software do
not update the original .DWG, .FBX, .DXF, or .RVT file.

* Inlinked files that are bound, the geometry stays in the scene
file as-is, but the connection to the source file is dropped.

You can export an .FBX file from the Autodesk Revit software
and import it in Autodesk 3ds Max software. The FBX importer is
an independent plug-in that is frequently updated. In the FBX
Import dialog box, use Web Update to check for web updates,
download the latest updates, and install them. Close 3ds Max
when you do the install.

Objects already saved in Autodesk 3ds Max scenes (.MAX files)
are imported into the current scene using the Merge option
(Application Menu>Import>Merge). Merging files is a
one-directional transfer that does not maintain any connection
between the two files. Using the Merge option, you can either
load a few objects from a scene or you can load a complete
scene into the current one.
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Practice 3a

Estimated time for
completion: 20 minutes

You have to initialize
Civil View once.

Ground Surfaces using Civil
View

Practice Objective

Open a Civil 3D data file in a scene file.

In this practice you will open a .VSP3D file for importing ground
surfaces using Civil View. You will then modify the material
assignment for various ground surfaces using the Civil View
Explorer.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Initialize Civil View.

It is recommended that you import 3D ground surfaces from
Civil/Survey products, such as AutoCAD Civil 3D or Land
Desktop using the vsp3d data format.

1. In the menu bar, select Civil View>Initialize Civil View. If
you have already initialized Civil View, go to Step 5.

2. In the Initialize Autodesk Civil View dialog box, set the
System Units to Feet because the civil project that you will be
opening uses Feet as its unit of measurement. Verify that
Don’t warn me about System Units again is selected.

3. Inthe Select a Country Resource Kit area, select US
IMPERIAL and verify that Start Mode for Civil View is set to
Manual. Click OK. In the Information dialog box, click OK.

4. Exit and then restart the Autodesk 3ds Max software.

5. Start Civil View by selecting Civil View>Start Civil View.
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Hint: Starting Civil View

Although Civil View is initialized next time you launch the
Autodesk 3ds Max software, you are still required to start Civil
View if the Start Mode for Civil View is set as Manual. You can
change this setting in the Civil View Preferences dialog box, in
the General tab, by select Automatically start Civil View?, as
shown in Figure 3-2.

£] Civil View Preferences 2 |
J General ] Localization | Colors | Resource Kit Paths | Materials | Import Options |
v Automatically start Civil View? Default Frame Rate: |25 ﬂ
Marker Size: |2 ﬂ
v Show icons in Civil View Explorer Panel? Civil View Explorer Width: |2[Js ﬂ
Tree Variation (%%): |15 ﬂ
Figure 3-2

Task 2 - Opening a Civil 3D File.

1. Open Civil Base XRef.max from the ...\scenes folder. If a
Mismatch dialog box opens, click OK to accept the default
values. If prompted again, click OK. This is an empty scene
in which the System Unit Scale has been set to 1 Unit=1.0
Feet.

2. In the menu bar, select Civil View>Geometry Import>Civil
3D (VSP 3D) File, as shown in Figure 3-3.

Civil View  Customize  Scripting Content Help

Civil View r

Geometry Import k

Civil 30 (VSP3D) File.. L\\,

[
Traffic Import Model File...
| Genio File...
Figure 3-3

3. In the Civil 3D Import Panel dialog box, click Open. In the
Select a VSP3D File dialog box, browse to the ...\import
folder in the practice files folder and open Civil
surfaces.vsp3d.
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The objects listed 4.
include surfaces, site/
grading featurelines,
corridor (surfaces,
baselines, featurelines
etc.),and point groups,
elc.

In the Civil 3D Import Panel dialog box, a list of objects that
are in the AutoCAD Civil 3D file are listed. In the left pane,
select Surfaces [9] to display all of the surfaces in the right
pane. Select Building Pad, hold <Shift>, and select Parking
Lot Surface to highlight the first seven surfaces. Select the
checkbox for Building Pad to select all seven highlighted
surfaces, as shown in Figure 3—4. You can select them
individually as well.

H Civil 3D Import Panel [Civil surfaces.vsp3d]

(Y RenusSite.dwg Name Object Type Points | Splines/Faces
8] Paint Groups 0] > Building Pad Surface
ﬁnﬂ Pipe Networks [0] ., ExistingGround
...@.-Sur.faces [a] 2 Inside Clirbing i
7 ::} Wm{n] s [0] B, Inside Grading Surface
£ i Outside Curbine Surface
5 Ot 2
i _\lf Emﬂ ::I{E}]H] F.:rklru:l Lot Surface
- ] £ Road Sorface - Ih)
= Sites
= By EE]:L ] & water Surface 702 73
= [B] Corridors [1]
= [P Road
Figure 3-4
5. You will select the corridor surfaces and the baseline. In the
left pane, select Corridors [1] and in the right pane, click in
the checkboxes for PrimaryAccess, Region(1), Region(2),
and Region(3), as shown in Figure 3-5.
|:| JHingE_Eut Corridor Feature Line 6
[1. jH'nﬂg Cut Corridor Feature Line 65
=|-'= PrimaryAccess Corridor Baseline 57
@Rﬁginn (1) Corridor Surface 306
@Rﬁginn ()] Corridor Surface 42
@Rﬁginn (3 Corridor Surface 159
L1,/ Tep_Curb Caorridor Feature Line 34
¥ +/"'Tuz:qt.'-_l::urlz:l Corridor Feature Line 6
Figure 3-5
6. Click OK. In the Civil View Information, click Yes to accept
the global shift values.
7. Click Yes to proceed without a feature interpretation style.
8. In the Warning dialog box, click OK. In the Error dialog box,
click OK.
3-6 © 2016, ASCENT - Center for Technical Knowledge®
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It takes a few minutes to
load the file.

Right-click on the title
bar and select
Dock>Left.

A material is not
required for the first
three corridor regions.

9. The ground surfaces, building pad, corridor, and parking lot
are displayed in all of the viewports. If they are not, click

¥, (Zoom Extents All). In the Perspective viewport, note that
only the corridor displays the right surface material but the
rest of the surfaces display a checkerboard material.

10.In the menu bar, select Civil View>Civil View>Civil View
Explorer to open the Civil & View Explorer. Dock it along the
left side of the screen.

Task 3 - Modify Material Assignment.

1. Verify that the Civil Explorer tab is selected. Expand Civil
View Objects>Imported Objects, if not already expanded.
Select Surfaces and note that the corridor is selected in the
viewports. The Object List rollout opens with all of the
surfaces listed, as shown in Figure 3—6.

+ Object List

Surfaces (10)
C3Dsurface-Road-Region (1)
C3Dsurface-Road-Region ()

C3Dsurface-Road-Region (3)
C3Dsurface-C-TOPO-Building Pad >

Right-dick item for pop-up menu

O

Figure 3-6

2. In the Object List rollout, select C3Dsurface-C-TOPO-
Building Pad. In the Surface Parameters rollout, select the
Statistics tab and note that in the Face Selection Sets, in By
Material ID, [31] Ground Type 4 has been assigned, as
shown in Figure 3-7.

+ Object List
Surfaces (10)
C3Dsurface-Road-Region (1)

| e o

C3Dsurface-Road-Region (2)
C3Dsurface-Road-Region
C3Dsurface-C-TOPO-Building Pad [

Right-dick item for pop-up menu
+ Surface Parameters

Source ISE:tish'cs I Draping
Surface Statistics
Surface Parameters
Face Count: 121
Vertex Count: 123
Area: 7112.742676 sq. feet

@ Face Selection Sets

= £7] By Material ID
(D [31] Ground Type 4

E] By Link Code

Figure 3-7
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The complete list might
not be visible in the
Explorer. Hover the
cursor in empty space in
the information area
until it displays as a Pan
(hand) cursor. Slide up
or down, using the hand
cursor or the scroll
button to display all of
the information.

3. Right-click on [31] Ground Type 4 and select Modify
Material ID Assignment, as shown in Figure 3-8.

Surface Statistics

Surface P b Maodify Material ID Assignment. .. %
Face Count: 121 Modify Tiling Parameters...
Vertex Count: 123
Modify Smoothing Threshold (degrees)...
Area: 7112, 742676 sq. feel fy . (deg )
Calculate Surface Area...
(" Face Selection Sets
BE' By Material ID Delete Triangles/Faces. ..
|
----- £ By Link Code

Figure 3-8
4. Click Yes in the Warning dialog box.

5. In the Modify material channel dialog box, select [22]
Concrete Type 1 as shown in Figure 3-9. Click OK.

H Modify material channel
Select a new material channel

[18] Asphalt Type 1 3
[15] Red Asphalt =
[20] Water Type 1 IE]

[31] Ground Type 4 =

Figure 3-9

6. Inthe Perspective viewport, use Zoom and Pan to zoom
into the building pad. Note how the new material is applied.

7. Select Surfaces again and in the Object List rollout, select
C3Dsurface-C-TOPO-Existing Ground. In the Surface
Parameters rollout, in the Statistics tab, right-click on [31]
Ground Type 4, and select Modify Material ID Assignment.
In the Warning dialog box, click Yes.

8. In the Modify material channel dialog box, select [28] Ground

Type 3 and click OK. In the Perspective viewport, note that
the new ground type material is applied to the ground
surface.
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A material is not
required for the first
three corridor regions.

You might need to
undock the explorer first
to close it.

9. Similarly, for the other surfaces, apply the material types as
follows:

» C3Dsurface-C-TOPO-Inside Curbing:
[38] Concrete Type 3

» C3Dsurface-C-TOPO-Inside Grading:
[28] Ground Type 3

» C3Dsurface-C-TOPO-Outside Curbing:
[38] Concrete Type 3

« C3Dsurface-C-TOPO-Outside Grading:
[28] Ground Type 3

« C3Dsurface-C-TOPO-Parking Lot Surface:
[39] Asphalt Type 4

10. Close the Civil View Explorer.

11. Click ¥, (Zoom Extents All). In the Perspective view, the
scene displays as shown in Figure 3—10.

Figure 3-10

12.Save your work as MyCivil Base XRef.max.
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Linking DWG
Files

3.2 Linking Files

File Linking is used to incorporate data from other Autodesk
software such as Autodesk Revit and AutoCAD into the
Autodesk 3ds Max scene. If the incorporated data is changed in
the originating software, the file link enables you to update those
changes in the 3ds Max scene. File linking is useful when you
are working on a visualization project and know that all design
decisions have not yet been made. You can link files using the
Manage Links dialog box that can be opened as follows:

. W (Application Menu)>Import>Link Revit: Links the .RVT
files from the Autodesk Revit Architecture software.

. W (Application Menu)>Import>Link FBX: Links the .FBX
files that can be created in the Autodesk Revit, Autodesk
MotionBuilder, Autodesk Maya, and Autodesk Mudbox
software.

. W (Application Menu)>Import>Link AutoCAD: Links the
.DWG and .DXF files from the AutoCAD software.

* You can also open the Manage Links dialog box outside of
the Link commands (Application Menu>References>
Manage Links) and modify the Link settings.

In CAD data files it is common to have large numbers of objects.
When linking or importing AutoCAD .DWG or .DXF files, it is
efficient to combine multiple, related objects together into a
single Autodesk 3ds Max object to control their display and
visibility.

*  When multiple entities are combined into compound
Autodesk 3ds Max shapes (2D objects) and meshes (3D
objects), you can still access and adjust the original geometry
using the Sub-object level modifiers, such as Edit Spline,
Edit Mesh, and Edit Poly.

* Once multiple entities are combined, you can detach objects
or portions of an objects to form new ones for individual
editing control.
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Linking FBX | The Autodesk Revit and Autodesk 3ds Max software share a

. mental ray renderer. Both products use the Autodesk Material
and RVT Files | Library materials.

 The .RVT and .FBX file format supports the import of
photometric lights, both interior artificial lights and exterior
daylight systems.

* Detailed .RVT and .FBX file formats can become very large in
size and importing them as single files cannot be
accomplished. In such cases, use a section box in the 3D
View in the Autodesk Revit software to limit the amount of the
scene you are exporting.

Manage Links The Manage Links dialog box (shown in Figure 3—11) contains
. the following tabs:
Options

Manage Links

J.Atlach ] Files ]Presets ]

He...

I C:\Autodesk 3ds Max Design Fundamentals Class Files\import\3D Parking Lot Deta |

Preset:
IDWG File Saved from AutoCAD v

v Rescale
Incoming file units:

IFeet b

Select Layers to indude... |

Attach this file |

Figure 3-11
Attach Tab

The options available in the Attach tab are described as follows:

* File... enables you to open a file (.DWG, .DXF, .FBX, or .RVT)
for linking. The selected filename and its path display in the
File drop-down list. If the file that you selected is a .RVT file
with more than one camera view, you are prompted to select
a camera view.
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The Preset drop-down list enables you to select the preset
settings. The Presets listed here can be created or modified
using the Presets tab. You can set the units by selecting them
in the Incoming file units drop-down list.

Select Layers to include is only available with . DWG and
.DXF file formats and enables you to select the layers that
you want included with the drawing file.

Attach this file links the selected file with the specified
preset settings to the current Autodesk 3ds Max scene.

Files Tab

The Files tab displays a list of files that are linked to the current
scene with a specific status icon.

If the linked file has been modified, [ displays with the linked
filename.

™ indicates that the linked file is unchanged and does not
have any errors.

When a file is highlighted, the following options are available:

Reload... When the original file has been changed, it displays the
changes in the current scene.

Detach... Use when you want to remove the link with the original file.
This option removes all geometry associated with the linked
file.

Bind... Removes the link with the original file, but the geometry stays

in the current scene, although the link between the original file
is broken. Changes made to the original linked file cannot be
reloaded.

Presets Tab

Many options are available before files are linked to your current
scene. These options are configured and saved as Presets and
can be used when linking files at a later stage. Many of these
options require trial and error to find the most appropriate
settings. You can link a file and then reload (or detach and relink)
with different settings until you achieve the required results.

© 2016, ASCENT - Center for Technical Knowledge®
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If you are linking a file
for the first time, it is
recommended that you
create a new preset.

File Link
Settings: DWG
Files

The Presets tab lists all existing presets and contains options for
creating new presets, modifying existing presets, copying
existing ones, renaming and deleting them. You need to select a
preset for the Modify, Copy, Rename, and Delete options to be
available, as shown in Figure 3—12. If no preset is selected,
Copy is replaced by New and is the only available option.

| Manage Links

Preses

Mamed Presets:

Autodesk Revit files (RVT or FB
Autodesk Revit - Combine By Revit Material
Autodesk Revit - Combine By Revit Category
Autodesk Revit - Combine By Revit Family Type
Autodesk Revit - As One Object
Autodesk Revit - Do Mot Combine Entities
Autodesk FEX files
Autodesk FEX (Generic) files
AutoCAD Drawings
DWG File Saved from AutoCAD
DWG File Exported from Revit
DWG File Saved from AutoCAD Architecture

Figure 3-12

Depending on the type of preset selected (.RVT, .FBX, or
.DWG), clicking Modify... opens a specific File Link Settings
dialog box, which enables you to define the way you want the
geometry to be linked, what portions of the file are to be modified
on Reload, and how the geometry is combined.

In the Manage Links dialog box, in the Presets tab, selecting an
AutoCAD DWG file preset and clicking Modify... opens the File
Link Settings: DWG Files dialog box, as shown in Figure 3—13.

El File Link Settings: DWG Files

DWG File Saved from AutoCAD

J Basic IAdvanced ISpIine Rendering ]

¥ Weld nearby vertices Weld threshold: @™ %
¥ Auto-smooth adjacent faces Smooth-angle: (158 %
|71 Qrient normals of adjacent faces consistently

[ Cap dosed splines

Texre moppe: | Genratecordnates o sl s+
Curye steps: (39700

Maximum surface deviation for 30 solids: 02 %
Indude
 External references [T Lights
[ Hatches [ 5un and sky
¥ Points W Views and Cameras
[ UCSs (grids)

Figure 3-13
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Basic Tab

The options available in the Basic tab are described as follows:

* Weld nearby vertices and Weld threshold: Welding joins
together vertices of the same object that fall in the weld
threshold. If the objects are joined by layer, this option
removes duplicate vertices so that the adjacent 2D objects on
the same layer are automatically combined into splines.
Adjacent 3D objects that are welded become faces in a single
mesh that share common vertices.

You can adjust + Auto-smooth adjacent face and Smooth-angle:
smoothing later if you Auto-smooth enables adjacent faces in the same 3D mesh to
still encounter display smooth if the angles of separation between their face
smoothing issues after normals (a directional vector perpendicular to the face) is
import. equal to or less than the Smooth-angle. Otherwise, the

adjacent faces have a faceted edge between them. This is
the same smoothing process used in the Edit Mesh and Edit
Poly modifiers.

« Orient normals of adjacent faces consistently: This option
coordinates the face normals of linked objects. This option
should be left off by default unless some faces of your 3D
objects are missing after the link.

« Cap closed splines: It assigns an Extrude modifier to all
closed 2D geometry (e.g., circles and closed polylines).

+ Texture mapping: Texture mapping is used to locate texture
maps on objects. Two options are available:

Generate * Links objects without adding any texture mapping.
coordinates + Adds the mapping when it is first called for by the
on-demand software.

» Enables a faster link but might cause some
discrepancies.

Generate + Adds texture mapping to all objects at the time of the
coordinates link, matching any that might have existed in the
for all objects original drawing file.

* Curve steps: This setting defines the number of segments to
subdivide each 2D curve segment into if they are later
extruded in the Autodesk 3ds Max software. This setting
applies to circles, arcs, polyline curves, spines, and similar
curved objects.
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This value can be set as
low, (0.01).

Maximum surface deviation for 3D solids: This setting
defines the allowed deviation distance from a parametric
AutoCAD 3D curve (such as a curved AutoCAD extrusion)
and the resulting Autodesk 3ds Max mesh. The lower the
value, the more a 3D curve is subdivided. In the Autodesk
3ds Max software, all 3D curves must be segmented.

Include area options: These options enable you to select
the type of objects to be brought into the scene. Note that the
Lights option only brings in Lights from AutoCAD drawings
pre-2007. If you have Sun and Sky checked, a daylight
system is created based on the information in the incoming
DWG file from the Autodesk Revit 2009 software.

Advanced Tab

The Advanced tab (shown in Figure 3—14) controls the import of
AutoCAD primitives and the effect of scene materials while
importing.

E File Link Settings: DWG Files

DWG File Saved from AutoCAD

Basic IAdvar‘tced ISpIine Rendering ]
Derive AutoCAD Primitives by:

Select Layers to indude...

¥ Create helper at drawing origin

[ Use Extrude modifier to represent thickness

[ Create one scene object for each AutoCAD Architecture one
[ Uze scene material definitions

[ Use scene material assignments on Reload

Selective Reload

Selected in Scene
® Selected in List Linked Qbjects...

Figure 3-14
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The options available in the Advanced tab are described as

follows:

* Derive AutoCAD Primitives by: Controls how AutoCAD
objects are combined when linked.

Layer

Creates one object for each AutoCAD layer. Each
AutoCAD block links as a single object called a
VIZBlock.

Layer, Blocks
as Node
Hierarchy

This option preserves material assignments in linked
AutoCAD blocks. It structures each as a hierarchy of
objects rather than single objects.

Layer, Blocks

This option works similarly to the one above but takes

as Node into account drawings that have more than one material
Hierarchy, applied to objects on the same layer. Separate

Split by hierarchies are created for each material type on each
Material layer.

Entity, Blocks

This option includes all non-blocks as separate,

as Node individual objects. Blocks are preserved as hierarchies,

Hierarchy however, organized by layer.

Color Combines AutoCAD objects by color. All objects of one
color are joined in as a single object, regardless of layer.

Entity Does not combine AutoCAD objects at all. Instead, each
AutoCAD object becomes an individual object.

One Object This option combines all AutoCAD objects into a single

object.

* Create helper at drawing origin: Adds an origin point helper

at the origin of the current coordinate system. All of the linked
geometry is part of a hierarchy parented by this helper, so all
of the linked objects can be repositioned as one by
transforming the helper.

Use Extrude modifier to represent thickness: \When
disabled, linking 2D AutoCAD objects with a non-zero
thickness value translates the objects into the Autodesk 3ds
Max software as a 3D mesh. When enabled, objects translate
as 2D objects with a parametric extrude modifier. The
resulting geometry is the same but when this option is
enabled, the extrusion properties (such as height) can be
modified after the link or imported using the modifier stack.

Create one scene object for each AutoCAD Architecture
one: When unchecked, AutoCAD Architecture and AutoCAD
MEP objects are subdivided into separate objects by
material.

© 2016, ASCENT - Center for Technical Knowledge®
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* Use scene material definitions: When unchecked, the
Autodesk 3ds Max software includes the current state of any
material applied to the linked objects in the AutoCAD
software. If selected and the current scene has a material
with the same exact name as the AutoCAD material, the
scene material is used instead.

+ Use scene material assignments on Reload: When
unchecked, the Autodesk 3ds Max software re-loads the
current state of any AutoCAD materials present in the
drawing file when the link is updated. When enabled, the
Autodesk 3ds Max software maintains the current state of
any materials in the scene file after a link is updated. Select
this option if you intend to adjust linked materials in the
Autodesk 3ds Max software or leave it unchecked if you
intend to adjust them the AutoCAD software.

+ Selective Reload: Enables you to reload a subset of the
original file. You can select objects to reload by selecting
them in the scene or by selecting them from a list. If you
select Selected in List, and click Linked Objects a list
opens.

Hint: Hierarchies and File Linking

Autodesk 3ds Max Hierarchies are collections of objects linked
together into parent/child relationships where transform applied
to a parent are automatically passed on to its children.
Connecting multiple objects in a hierarchical chain can enable
sophisticated animations in the Autodesk 3ds Max software,
such as the motion of jointed robotic arms.

In the case of the hierarchy file link options, incoming
AutoCAD blocks are brought into the Autodesk 3ds Max
software as multiple objects so that they can maintain multiple
material assignments from the AutoCAD software. The parent
object itself does not have any geometry and does not render.
Most modifiers (such as Substitute) must be applied to the
objects in the hierarchy rather than the parent.
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Spline Rendering Tab

The options available in the Spline Rendering tab (shown in
Figure 3—15) enable linear objects (2D and 3D lines, polylines,
etc.) to display as extruded 3D objects in the viewports or
rendering. Normally, splines cannot be rendered because they
do not have surface area to interact with scene lighting. These
options enable splines to link into the Autodesk 3ds Max
software as 3D linear objects with a cross-sectional radius or a
rectangular length and width. This provides the surface area for
rendering.

El File Link Settings: DWG Files

DWG File Saved from AutoCAD
Basic I Advanced | Spline Rendering ]
[ Enable in Renderer Viewport @ Renderer
[7Enable in Viewport @ Radial
Use Viewport Settings Thickness: _
|| Generate Mapping Coards. Sides: 123
¥ Real-World Map Size Angle: [0 3
¥ Auto-smooth ' Rectangular
Threshold: 4007 Length: [0 s
Width: 0°2° =
Angle: 0.0 &
Aspect: 3.0 8
Figure 3-15

» If splines are to be rendered with materials then options such
as smoothing, mapping coordinates, and/or real-world map
size are often important.

»  When enabled, all of the splines linked with this setting are
renderable, and all have the same cross-section geometry.

« To make only certain 2D objects renderable (or want some to
render differently than others) you could apply a Renderable
Spline modifier directly to those objects after linking.
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File Link
Settings: Revit
Files (RVT or
FBX)

In the Manage Links dialog box, in the Presets tab, selecting an
Autodesk Revit file and clicking Modify... opens the File Link
Settings: Revit Files (RVT or FBX) dialog box, as shown in
Figure 3—16. Additionally, you can also select the Autodesk FBX
(Generic) file preset and click Modify....This opens the File Link
Settings: FBX Files dialog box, as shown in Figure 3—17. This
dialog box is similar to the Autodesk Revit Files (.RVT and .FBX)
but without a Geometry area for controlling the segments and
smoothing the linked geometry.

ile Link Settings: Revit Files (RYT or FBX)
EF'I Link Settings: Revit Files (RYT or FBX)

El File Link Settings: FBX Files

Figure 3-16 Figure 3-17

It is recommended that
you combine entities to
reduce the number of
objects.

The options available in the File Link Settings: Revit Files (RVT
or FBX) dialog box are described as follows:

+ Combine Entities list: Enables you to select the Autodesk
Revit entities that you want to combine, as shown in
Figure 3—18. For example, if you select By Revit Material, all
of the entities that have the same material are linked in the
current Autodesk 3ds Max scene as a single object.

By Revit Material

Figure 3-18
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* Objects area: The selected options in this area are linked
from the .RVT file to your current scene. If the .RVT file or
.FBX file contains photometric lights, interior artificial lights,
cameras, and exterior daylight systems, you can select the
associated options in the File Link Settings dialog box.

+ Geometry area: Enables you to set the number of segments
for your curved entities and apply auto-smoothing to them.

* Materials area: Enables you to control the material
definitions and assignment settings.
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Practice 3b

Estimated time for
completion: 20 minutes

If a dialog box opens
prompting you about a
File Load: Mismatch,
click OK to accept the
default values.

If no preset is selected,

only New... is available.

Linking an AutoCAD DWG

Practice Objectives

* Create a preset to link an AutoCAD .DWG file and reposition it.
* Revise the link settings and reload the linked file.

In this practice you will link AutoCAD geometry to represent the
parking lot details, such as pavement markings and other details.
You will reposition this file using the Helper object, and will create
3D markings by projecting 2D lines to the elevation of a terrain
model.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Link an AutoCAD .DWG File.

1. Open Civil Base.max from the ...\scenes folder.

2. Select Application Menu>Import>Link AutoCAD. In the
Open dialog box, browse and open the ...\import folder in the
Practice Files folder. Select 3D Parking Lot Detail.dwg and
click Open. The Manage Links dialog box opens with the
path and the filename displayed, as shown Figure 3—19.

#5 Manage Links

jamm ] Files ]Presets ]

Preset:

Figure 3-19

3. Select the Presets tab and click New... to create a new link
preset.

4. In the New Settings Preset dialog box, set New Name as
AutoCAD - Derive by Layer. Note that the Format is
selected as AutoCAD Drawings. Click OK.

© 2016, ASCENT - Center for Technical Knowledge® 3-21



Autodesk 3ds Max 2017: Fundamentals

5. In the Manage Links dialog box, select the new AutoCAD -
Derive by Layer preset, as shown in Figure 3—-20. Click
Modify....

Manage Links

Attach | Fles |

AutoCAD - Derive by Layer

Figure 3-20
The Create Helper at 6. In the File Link Settings: DWG Files dialog box, in the Basic
drawing origin option tab, set the link options, as shown in Figure 3—21. Select the
adds a helper object at Advanced tab and select Create helper at drawing origin,
the origin of the linked as shown in Figure 3-22. Leave all other options as defaults

file. (clear).

D File Link Settings: DWG Files E] File Link Settings: DWG Files

Figure 3-21 Figure 3-22
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7. Select the Spline Rendering tab and verify that the link
options are set to the defaults, as shown in Figure 3—-23.

D File Link Settings: DWG Files

Figure 3-23
8. Click Save.

9. In the Manage Links dialog box, select the Attach tab. Set
Preset to AutoCAD — Derive by Layer, as shown in
Figure 3—24. Click Select Layers to include....

#5 Manage Links

[Fies [preses |

AutoCAD - Derive by Layer h‘

Figure 3-24
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10.In the Select Layers dialog box, select Select from list. Clear
0 and DEFPOINTS and leave all other layers as selected, as
shown in Figure 3-25. Click OK.

Select Layers

T

Figure 3-25

11. In the Manage Links dialog box, click Attach this file. Close
the Manage Links dialog box. Note that the parking lot details
have been added to the scene, but are located far away from
the origin, as shown in the Top viewport in Figure 3—26.

You might need to start
Civil View, if it is not set
to start automatically.

Figure 3-26

Task 2 - Relocate the Linked Geometry.

1. You need to move the parking lot details by the global shift
values in Civil View. In the menu bar, select Civil View>Civil
View>Civil View Explorer.

3-24
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If the Scene Explorer is
not displayed, select
Tools>Scene Explorer
and then dock it.

2,

In the Civil View Explorer, select Scene Settings, as shown
in Figure 3—27. In the Scene Settings rollout, note the Global
Import Shift values for X Shift and Y Shift (-9901), as shown
in Figure 3—28. Close the Civil View Explorer.

Civil &View =

= Civil View Explorer

JﬁuiEuplnra' ] Resources l Tools ] - Setti
s Global Import Shift
£ Envir t and Lighting ¥ Shift: 9901+
i ¥ Shift: g901 4
=-F] Civil View Objects (11)

Figure 3-27 Figure 3-28

In the Main Toolbar, click ‘*’ (Select and Move).

In the Scene Explorer, click ( ] (Display None) and

L (Display Helpers)), and then select the helper object
3D Parking Lot Detail.dwg, as shown in Figure 3—29. Note
that the User Coordinate System icon located at the origin
is selected, as shown in Figure 3-30.

@ |Name (Sorted Ascending)
@ ©°h
4
[ ]
N
=
Figure 3-29 Figure 3-30

In the Status Bar, ensure that B (Absolute Mode
Transform) is displayed. Set the following, as shown in
Figure 3—-31:

+ X edit box: -9901°0"

* Y edit box: -9901°0"

BH x: Cssntio™ % v: [s0to™ ¥z oot %

Figure 3-31

Press <Enter>.

Click 53 (Zoom Extents All). Note how the parking lot details
are placed exactly on the parking lot surface.
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In the Files tab, if the
linked file has been

modified, &) displays.

You can use:

Reload... to update the
file in the scene.
Detach... to remove a
linked drawing from the
scene.

Bind... to insert the
drawing as is and
removes the
connection.

The 2D linework should
no longer display,
keeping the scene
smaller.

. . Q! i :
8. Inthe Perspective viewport, use (Zoom) and <=+ (Orbit)

to zoom into the Parking lot area and tilt the view to display
the area below the surfaces, similar to that shown in
Figure 3—-32. Note that in addition to the 3D pavement
markings, 2D line markings are imported through the link.

Figure 3-32

Task 3 - Revise the Link Settings.

1.

Click Application Menu>References>Manage Links to
open the Manage Links dialog box.

In the Manage Links dialog box, select the Files tab and note

that the linked file displays B, indicating that the file has not
changed. (Although the linked file has not changed, use
Reload... to revise the link settings.) Verify that Show
Reload options is selected, and click Reload....

The File Link Settings: DWG Files dialog box opens. In the
Advanced tab, click Select Layers to include.... Clear the
2D layers (C-MARK-WHITE-2Dand C-MARK-YELLOW-
2D), and the two LIGHTPOLE layers, as shown in

Figure 3-33.

Select Layers

@ skip all frozen layers ® Select from list
] e
V(g_)m}_ :8 ] £ -
¥ cumarsD ¥ 2| (el
i S5 5 Em
C-MARK-YELLOW-2D Qd%ﬂ
" C-MARK-YELLOW-3D qoa
v C-PARK-CURB O
Kyl
LIGHTPOLE_DOUBLE O
LIGHTPOLE_SINGLE o R w i

Figure 3-33

Click OK twice to close both dialog boxes. Click . to close
the Manage Links dialog box. In the Perspective viewport,
note that the 2D line markings are not displayed.

Save your work as MyCivil Base.max.

3-26
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Practice 3c

Estimated time for
completion: 20 minutes

If a dialog box opens
prompting you about a
File Load: Mismatch,
click OK to accept the
default values.

It might take a few
minutes to load the file.

Linking and Reloading Autodesk
Revit File

Practice Objectives

Link and reposition an Autodesk Reuvit file to the current scene.
* Reload a modified .RVT file.

In this practice you will link a .RVT file into a 3ds Max scene. You
will reposition the Reuvit file using the Helper object. You will then
reload a modified version of the .RVT linked file to incorporate
the changes made to the original Autodesk Revit file using
Reload.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Link an Autodesk Revit (.RVT) file.

1. Open Civil Base Link.max from the ...\scenes folder.
2. Select Application Menu>Import>Link Revit.

3. In the Open dialog box, in the ...\import folder, select Revit
Building-1.rvt and click Open.

4. The Status Bar is replaced by the Loading file bar, indicating
the progress of the file as it loads. Once loaded, the Select
Revit View dialog box opens, as shown in Figure 3—-34.

B Select Revit View...

{30}
Front Exterior 3D View

( ok J[ cancel

Figure 3-34
5. Select Front Exterior 3D View and click OK.
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The Create Helper at
Model Origin option
adds a helper object at
the origin of the linked
file. Selecting and
applying transforms
(move, rotate, or scale)

6.

In the Manage Links dialog box, select the Presets tab. Click
New... to create a new preset. In the New Settings Preset
dialog box, set the following:

*  New Name: Revit Preset
* Format. Autodesk Revit (*.rvt,*.fbx).

Click OK.

In the Manage Links dialog box, select Revit Preset and click
Modify.

In the File Link Settings dialog box, do the following, as
shown in Figure 3-35:

* In the Combine Entities drop-down list, select By Revit
Category.
* In the Objects area, clear Lights and Daylight System.

* In the Objects area, select Create Helper at Model
Origin and Cameras.

to the helper object
applies the transform to * Inthe Geometry area, set Curved Objects Detail to 6.
the linked geometry * In the Materials area, verify that Keep 3ds Max scene
together. materials parameters on reload and Keep 3ds Max

scene material assignments on reload are cleared.

El File Link Settings: Revit Files (RVT or FBX)
Figure 3-35
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(It might take a few
minutes to load the file).

If the Scene Explorer is
not displayed, select
Tools>Scene Explorer
and then dock it.

The position of the
building pad from the
origin has been
calculated.

10.Click Save.

11. Select the Attach tab. Expand the Preset drop-down list and
select Revit Preset.

12.Click Attach this file. Note that the Autodesk Revit building
and camera are loaded at the 0,0,0 location in the viewports.

13.Click .. to close the Manage Links dialog box.

14.1n the Scene Explorer, click ] (Display None) and

L (Display Helpers) and then select the helper object Revit
Building-1.rvt, as shown in Figure 3—36.

Mame (Sorted Ascending) ¥

WP e oD e
Q
i

Figure 3-36

15. Right-click on the Top viewport to make it active and to

maintain the selection. In the Main Toolbar, click Q. (Select
and Move). The Transform gizmo is displayed at the helper
location, which is the origin of the linked Autodesk Revit file.

16.In the Status Bar, verify that B (Absolute Mode Transform)
is displayed. Set the following, as shown in Figure 3-37:

« X edit box: 800°0"
e Y edit box: 382°0"
 Zedit box: 154°6"

B x:lsooo™ % v: (3200 #z: 1548 5
Figure 3-37
17.Press <Enter>.

18.Click ¥, (Zoom Extents All). Note how the building is placed
on the building pad.
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Grid has been hidden
for clarity. Press <G>.

19.In the Front viewport, use o (Zoom Region) and create a
rectangular window around the building to zoom into the
building. Select the User Defined Visual Style label and
select High Quality. Select the Wireframe Visual Style label
and select Default Shading. Select the Default Shading
Visual Style label again and select Edged Faces to define
the windows and doors. The building should display similar to
that shown in Figure 3—38.

[T IErant] [Hiah Qe ] [ EdaediFaces |

Figure 3-38

20.In the Left viewport, select the Wireframe Visual Style label
and select Default Shading and then Edged Faces.

21.Select the Left Point of View label, and select
Cameras>Views: Front Exterior 3D View, as shown in
Figure 3-39.

Cameras k Views: Front Exterior 3D View I}
Lights r Views: {30}
Figure 3-39

22.Use (Pan Camera) and 2, (Field-of-View) to display the
complete building in the Left viewport, similar to that as
shown in Figure 3—40.

23.In the Perspective viewport, use P (Zoom) and e, (Orbit)
to zoom into the building and parking lot area so that the
display is similar to that shown in Figure 3—40.
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[ 1 [Views: Erant Extenian; S0View || [User; Befined ]| [Edaed Faces | [+ 1 [Perspective ] [User Defined ] [Default Shading ]

Figure 3—40

Task 2 - Reload the variation of the .RVT file.

1.
2.

[T C:\Autodesk 3ds Max Fundamentals Practice Files\import\3D Parking Lot Detail.dwg
[3 ¢ :‘Autodesk 3ds Max Fundamentals Practice Files\mportiRevit Building-1.rvt (Front Exterior 3D View)

A variation to the .RVT linked file (windows have been added)
has been included in the ...\import folder.

In Windows Explorer, open the ..\import folder.

Right-click on Revit Building-1.rvt and select Rename.
Rename the file as Revit Building-1_ORIGINAL.rvt.

Right-click on Revit Building-2.rvt, and select Copy. Paste a
copy of this file into the same directory. Right-click on the
copied file, select Rename, and rename the file as Revit
Building-1.rvt. This must be the same name as the original
file that was linked to indicate that the original linked file has
changed.

Return to the Autodesk 3ds Max software. Select
Application Menu>References>Manage Links to open the
Manage Links dialog box.

In the Manage Links dialog box, select the Files tab. Note

that [ displays in front of the .RVT filename (as shown in
Figure 3—41), indicating that changes have been made to the
original linked file.

Figure 3-41
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6. Select the complete path of Revit Building -1.rvt (if not
already selected) and click Reload.... The Loading file bar
displays the progress.

7. In the File Link Settings dialog box that opens, in the
Materials area, select Keep 3ds Max scene material
assignments on reload. Click OK. The scene is refreshed
with the new changes.

8. In the Manage Links dialog box, in the Files tab, the icon has

changed to B, as shown in Figure 3—42. This indicates that
there are no differences between the original file and the
linked file.

(19 C:\Autodesk 3ds Max Fundamentals Practice Files\import\3D Parking Lot Detail. dwg
@ \Autodesk 3ds Max Fundamentals Practice Files\import\Revit Building-1.rvt (Front Exterior 30 View)

Figure 3—42
9. Close the Manage Links dialog box.

10. In the viewports, the modified building is displayed. More
windows are added to the building, as shown in Figure 3—43.

[ [IPErspective d| User Defined | [Edged Faces | [+ 1 [Perspective ] [User Defined ] [ Default Shading ]

Figure 3—43

11. Save the file as MyCivil Base Link.max.
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3.3 References

External Autodesk 3ds Max Scene files can reference data from other

.MAX scene files by expanding Application Menu>

References References>XRef Objects or XRef Scene. The XREF data
(XRef) remains linked to the source (.MAX) scene file so that changes in

the source file can be reflected in any scene that contains the
XREF.

External References are useful to break up large projects into
more manageable pieces, permit more than one person to
work on the same project at the same time in separate files,
and to enable the same core scene geometry to be used in
multiple files.

XRef Scenes bring in the entire scene. All of the XREF
objects are non-selectable and cannot be modified.

XRef Objects enable you to select individual objects (or all)
from an XREF scene. These objects remain selectable and
modifiable in the XREF scene file.

You can snap to XREF and use XREF objects with AutoGrid.
You can also use XREF objects as alignment targets and you
can select an XREF object’s coordinate system for object
transformation. XREF support parameter wiring and you can
XREF the controllers.

Objects in scenes (.MAX) are imported into other . MAX
scenes using the Merge option.
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Data
Management
and Asset
Tracking

The Autodesk 3ds Max software enables you to manage your
data through Data Management (DM) solutions, referred to as
Asset Tracking Systems (ATSs).

DM solutions such as the Autodesk® Vault software enables
you to store scene files and any supporting data (such as
material maps) in a single database repository.

These systems can be accessed simultaneously by multiple
users with different rights assigned based on their project
responsibilities. Data can be checked out for editing by one
individual at a time while still being referenced by other users.
Users can see who is editing which portion of the project at
any time.

By centralizing the files in a DM system it is much easier to
adjust paths for external files such as image maps.

Data files can be versioned through DM solutions, so that the
older versions can be readily accessed, if required.

For more information see Asset Tracking in the Autodesk 3ds
Max Help files. Asset Tracking is available through the
Application Menu>References> Asset Tracking.
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Practice 3d

Estimated time for
completion: 15 minutes

If an unsaved scene is

open, you need to save
or discard the changes
to the scene.

XRef and Merge Objects

Practice Objective

Link an AutoCAD .DWG file and incorporate objects from another scene
file into the current scene.

In this practice create a new scene file that will contain linked
AutoCAD objects and XRef objects from the Civil Base scene.
You will then merge obijects into the current scene file.

You must set the paths to locate the External files and Xrefs
used in the practice. If you have not done this already, return to
Chapter 1: Introduction to Autodesk 3ds Max and complete
Task 1 to Task 3 in Practice 1a: Organizing Folders and
Working with the Interface. You only have to set the user paths
once.

Task 1 - Assemble the Data.

1. Click Application Menu>Reset and click Yes to reset the
scene.

2. For this scene, set the System Unit Scale to Inches. Select
Customize>Units Setup. In the dialog box, verify that the
following is set:

» Display Unit Scale: US Standard, Feet w/ Fractional
Inches
» Default Units: Inches

» Lighting Units: American

3. Click System Unit Setup. In the System Unit Setup dialog
box, set System Unit Scale to Inches. Click OK in both the
dialog boxes.

4. Expand Application Menu>References and select Manage
Links.

5. In the Manage Links dialog box, in the Attach tab, click File....
In the ...\import folder, select Exterior AutoCAD
Architectural Model.dwg. Click Open.
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The AutoCAD - Derive
by Layer preset was
created in the Practice:
Linking an AutoCAD
DWG. Complete the
above mentioned
practice to create the
preset if not already
done so.

You select objects to
XREF rather than the
entire scene because
XREF scene objects
cannot be individually

6. In the Preset drop-down list, select AutoCAD — Derive by
Layer and click Attach this file. Once the file has been
loaded, close the Manage Links dialog box.

» The AutoCAD Architectural objects were not joined
together by layer. Each was subdivided by material type
into different objects. Materials previously assigned in
AutoCAD Architecture were preserved on these separate
objects.

7. Click (Maximize Viewport Toggle) or use <Alt>+<W> to
display the four viewport view.

8. Click 5, (Zoom Extents All) to display all of the objects in all
of the viewports.

9. In the Front viewport, select all of the objects by creating a
window around the objects. In the Main Toolbar, in the
Named Selection Sets field, enter exterior AutoCAD
Architectural building, as shown in Figure 3—44. Press
<Enter>.

Figure 3-44
10.Click Application Menu>References>XRef Objects. In the

XRef Objects dialog box, click =L (Create XRef Record from
File) as shown in Figure 3—45.

selected or modified. E XRef Objects E |@E|
Bx+Cc® % b N @
|r[ Create XRef Record from File... I |
Figure 3-45
11. In the Open File dialog box, select Parking Lot Detail.max
(from the ...\import folder) and click Open.
12.1f the Units Mismatch dialog box opens, click OK. This
rescales the XRef objects to the system units.
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Alternatively, you can
use the Scene Explorer
to select all the XRef
objects.

13.The Duplicate Material Name dialog box opens prompting
you that there is an incoming material with the same name as
an existing scene material. Select Apply to All Duplicates to
keep both materials, as shown in Figure 3—46. Click
Auto-Rename Merged Material.

Duplicate Material Name

& material name assigned to a merging object is a duplicate of a material in the scene.
Do you want to:

Figure 3-46

14.In the XRef Objects dialog box, note that the .MAX filename
is displayed. Click . to close the dialog box.

15.Click -5, (Zoom Extents All). Note that the Civil Base objects
are located far from the origin. This is a coordinate system
discrepancy and not a scale issue. It is common for
Architectural drawings to be based in a different coordinate
system and scale than the accompanying Civil/Survey
drawings.

Task 2 - Coordinate the Data.

In this task you will relocate the Civil Base in the Architectural
Data. To line up the data accurately you will need the exact
coordinate translation and rotation. You can measure ahead of
time in programs, such as AutoCAD by comparing the
coordinates of points common to both files.

1. In the Scene Explorer ( [ (Display None) and

e (Display Object XRefs)), select all of the XRef objects in
the list (use <Shift> and then select the first and last).

2. With these XRef objects selected, select Group>Group from

the menu bar.
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3. In the Group dialog box, set the Group name to Site XRef
and click OK.

4. In the Main Toolbar, click ‘*’ (Select and Move). In the
Reference Coordinate System, select World, as shown in

[ |
Figure 3—47. Click ""*4 (Use Transform Coordinate Center).

o] @ )i

Figure 3-47
The translation &
coordinates have 5. In the Status Bar, verify that (Absolute Mode) is
already been measured displayed. In the Transform Type-in area, set the following, as
in AutoCAD. shown in Figure 3—48:
« X:-197°4”
° y.. _30’0”
. Z:-411”
R . [SEB7EE v [S60°E 2 [
Figure 3-48

6. Press <Enter>.

7. In the Main Toolbar, click -3 (Select Object) to exit the
Move transform operation.
8. Click ¥ (Zoom Extents All).

9. In the Perspective viewport, change the Standard visual
display to High Quality to display the materials.
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10.In the Perspective viewport, use a, (Orbit Point of Interest)
and click to place a point on the building and then orbit
around that point. Using Pan and Zoom, zoom into the
parking lot and building area (as shown in Figure 3—49), and
verify that the building is located on the building pad.
Although the XREF had a different Unit Scale (feet), it scaled
correctly to the active scene (in inches).

Figure 3—49

11. Save your work as MyArchitectural Scene.max.

Task 3 - Merging Objects.

1. Expand Application Menu>Import>Merge. In the Merge
File dialog box, select Light Poles for Project1.max from
the ...\scenes folder. Click Open.
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2. In the Merge dialog box, click All, as shown in Figure 3-50.
Click OK.

® Alphabetical
By Type
By Color

¥ Match Layers by Mame and Parent

¥ Rescale Objects to System Unit Scale - -
e

Figure 3-50
Merge enables both 3. The Duplicate Name dialog box opens, prompting you that an
objects to have the object with the same name already exists in the scene. Select
same name, Skip Apply to all Duplicates and click Auto-Rename.
ignores the incoming ] . ) ]
object, and Delete Old 4. The light poles are displayed in the scene, as shown in
removes the original Figure 3-51.
object.

Figure 3-51

5. Save your work.
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Chapter Review Questions

1. The following file types can be linked to the current Autodesk
3ds Max scene:

.DWG, .OBJ, .APF, .FBX
.DWG, .DXF, .FBX, .RVT
.DWG, .DXF, .MAX, .RVT
d. .DWG, .0OBJ, .FBX, .RVT

© T o

2. In the Manage Links dialog box, in the Files tab, which of the
following options do you use to remove the link with the
original linked file but maintain its geometry in the current

scene?

a. Reload...
b. Detach...
c. Bind...

3. Which command do you use to combine objects from a saved
Autodesk 3ds Max scene (.MAX file) into your current .MAX

scene?

a. Import
b. Link
c. Open
d. Merge

4. While linking Autodesk Revit files in the current Autodesk 3ds
Max scene, which of the following options are provided in the
Combine Entities List? (Select all that apply.)

By Revit Material
By Revit Layer
As One Obiject

By Revit Camera

a0 T w

5. When an entire .MAX scene is brought into the current scene
using XREF Scenes, the XREF objects are selectable but
cannot be modified.

a. True
b. False
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Autodesk 3ds Max 2017: Fundamentals

Command Summary

Button Command Location

o Absolute » Status Bar
Mode
N/A Asset * Application Menu: References
Tracking
N/A Import * Application Menu: Import
N/A Link AutoCAD | + Application Menu: Import
N/A Link FBX * Application Menu: Import
N/A Link Revit * Application Menu: Import
N/A Manage Links | + Application Menu: References
N/A Merge * Application Menu: Import
— Select by * Main Toolbar
=5 Name

.‘} Select Object | « Main Toolbar

I. Use ¢ Main Toolbar
+ Transform

Coordinate
Center

N/A XRef Objects » Application Menu: References

N/A XRef Scene » Application Menu: References
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