Visit the following websites to learn more about this book:
Chapter 3
Constructive Solid Geometry Concepts

Learning Objectives

♦ Understand Constructive Solid Geometry Concepts
♦ Create a Binary Tree
♦ Understand the Basic Boolean Operations
♦ Set up Grid and Snap Intervals
♦ Understand the Importance of Order of Features
♦ Create Placed Features
♦ Use the Different Extrusion Options
Autodesk Inventor Certified User Exam Objectives Coverage

Parametric Modeling Basics
Constructive Solid Geometry.................................3-3
Boolean Operations...............................................3-3
Binary Tree ...........................................................3-4
Base Feature .........................................................3-8
Model Dimensions Format .....................................3-12
Using the Measure Tools .......................................3-14
Region Properties ..................................................3-15
Home View ............................................................3-20

Section 3: Sketches
Objectives: Creating 2D Sketches, Draw Tools, Sketch Constraints, Pattern Sketches, Modify Sketches, Format Sketches, Sketch Doctor, Shared Sketches, Sketch Parameters
GRID Intervals Setup.............................................3-9
Two Point Rectangle..............................................3-10
Modifying Dimensions .........................................3-12
Repositioning Dimensions .....................................3-13
Center Point Circle...............................................3-19

Section 4: Parts
Objectives: Creating parts, Work Features, Pattern Features, Part Properties
Extrude - Join.......................................................3-21
Sketched Feature ..................................................3-25
Placed Feature .....................................................3-25
Hole Tool ............................................................3-25
Cut Feature ..........................................................3-28
**Introduction**

In the 1980s, one of the main advancements in **solid modeling** was the development of the **Constructive Solid Geometry (CSG)** method. CSG describes the solid model as combinations of basic three-dimensional shapes (**primitive solids**). The basic primitive solid set typically includes Rectangular-prism (Block), Cylinder, Cone, Sphere, and Torus (Tube). Two solid objects can be combined into one object in various ways using operations known as **Boolean operations**. There are three basic Boolean operations: **JOIN (Union)**, **CUT (Difference)**, and **INTERSECT**. The **JOIN** operation combines the two volumes included in the different solids into a single solid. The **CUT** operation subtracts the volume of one solid object from the other solid object. The **INTERSECT** operation keeps only the volume common to both solid objects. The CSG method is also known as the **Machinist's Approach**, as the method is parallel to machine shop practices.
Binary Tree

The CSG is also referred to as the method used to store a solid model in the database. The resulting solid can be easily represented by what is called a binary tree. In a binary tree, the terminal branches (leaves) are the various primitives that are linked together to make the final solid object (the root). The binary tree is an effective way to keep track of the history of the resulting solid. By keeping track of the history, the solid model can be re-built by re-linking through the binary tree. This provides a convenient way to modify the model. We can make modifications at the appropriate links in the binary tree and re-link the rest of the history tree without building a new model.
The Locator Design

The CSG concept is one of the important building blocks for feature-based modeling. In Autodesk Inventor, the CSG concept can be used as a planning tool to determine the number of features that are needed to construct the model. It is also a good practice to create features that are parallel to the manufacturing process required for the design. With parametric modeling, we are no longer limited to using only the predefined basic solid shapes. In fact, any solid features we create in Autodesk Inventor are used as primitive solids; parametric modeling allows us to maintain full control of the design variables that are used to describe the features. In this lesson, a more in-depth look at the parametric modeling procedure is presented. The equivalent CSG operation for each feature is also illustrated.

Before going through the tutorial, on your own make a sketch of a CSG binary tree of the Locator design using only two basic types of primitive solids: cylinder and rectangular prism. In your sketch, how many Boolean operations will be required to create the model? What is your choice of the first primitive solid to use, and why? Take a few minutes to consider these questions and do the preliminary planning by sketching on a piece of paper. Compare the sketch you make to the CSG binary tree steps shown on the next page. Note that there are many different possibilities in combining the basic primitive solids to form the solid model. Even for the simplest design, it is possible to take several different approaches to creating the same solid model.
Modeling Strategy – CSG Binary Tree
Starting Autodesk Inventor

1. Select the **Autodesk Inventor** option on the *Start* menu or select the **Autodesk Inventor** icon on the desktop to start Autodesk Inventor. The Autodesk Inventor main window will appear on the screen.

2. Select the **New File** icon with a single click of the left-mouse-button in the *Launch* toolbar.

Every object we construct in a CAD system is measured in units. We should determine the value of the units within the CAD system before creating the first geometric entities. For example, in one model, a unit might equal one millimeter of the real-world object; in another model, a unit might equal an inch. In Autodesk Inventor, the **Choose Template** option is used to control how Autodesk Inventor interprets the coordinate and angle entries.

3. Select the **Metric** tab as shown below. We will use the millimeter (mm) setting for this example.

4. In the *New File – Part Template* area, select the **Standard(mm).ipt** icon as shown.

5. Confirm the **Parametric-Modeling** project is activated; note the **Projects** button is available to view/modify the active project.

6. Pick **Create** in the *Startup* dialog box to accept the selected settings.
Base Feature

In *parametric modeling*, the first solid feature is called the **base feature**, which usually is the primary shape of the model. Depending upon the design intent, additional features are added to the base feature.

Some of the considerations involved in selecting the base feature are:

- **Design intent** – Determine the functionality of the design; identify the feature that is central to the design.

- **Order of features** – Choose the feature that is the logical base in terms of the order of features in the design.

- **Ease of making modifications** – Select a base feature that is more stable and is less likely to be changed.

1. Activate the **Start 2D Sketch** icon with a single click of the left-mouse-button.

2. Move the cursor over the edge of the *XY Plane* in the graphics area. When the *XY Plane* is highlighted, click once with the **left-mouse-button** to select the *Plane* as the sketch plane for the new sketch.
GRID Display Setup

1. In the Ribbon toolbar panel, select [Tools] → [Document Settings].

2. In the Document Settings dialog box, click on the Sketch tab as shown in the below figure.

3. Set the X and Y Snap Spacing to 5 mm.

4. Change Grid Display to display one major line every 5 minor lines.

5. Pick OK to exit the Sketch Settings dialog box.

- Note that the above Snap Spacing settings actually set the grid spacing in Autodesk Inventor. Although the Snap to grid option is also available in Autodesk Inventor, its usage in parametric modeling is not recommended.

- On your own, use the dynamic Zoom function to view the grid setup. Refer to Page 2-26 on how to switch on the grid lines display options if necessary.
A rectangular block will be first created as the base feature of the Locator design.

6. Switch back to the Sketch tab and select the Two point rectangle command by clicking once with the left-mouse-button.

7. Create a rectangle of arbitrary size by selecting two locations on the screen as shown below.

8. Inside the graphics window, click once with the right-mouse-button to bring up the option menu.

9. Select OK to end the Rectangle command.

10. Activate the General Dimension command by clicking once with the left-mouse-button. The General Dimension command allows us to quickly create and modify dimensions.
11. Inside the graphics window, click once with the right-mouse-button to bring up the option menu and click **Edit Dimension** to turn **OFF** the editing option while creating dimensions.

12. The message “Select Geometry to Dimension” is displayed in the **Status Bar** area at the bottom of the Autodesk Inventor window. Select the bottom horizontal line by left-clicking once on the line.

13. Move the graphics cursor below the selected line and left-click to place the dimension. (Note that the value displayed on your screen might be different than what is shown in the above figure.)

14. On your own, create a vertical size dimension of the sketched rectangle as shown.

15. Inside the graphics window, click once with the right-mouse-button to bring up the option menu and click **OK** to end the **Dimension** command.
Model Dimensions Format

1. In the Ribbon tabs, select [Tools] → [Document Settings].

2. In the Document Settings dialog box, set the Modeling Dimension Display to Display as value as shown in the figure.

3. Also set the precision to no digits after the decimal point for both the linear dimension and angular dimension displays as shown in the above figure.

4. Pick OK to exit the Document Settings dialog box.

Modifying the Dimensions of the Sketch

1. Select the height dimension that is to the right side of the sketch by double-clicking with the left-mouse-button on the dimension text.
2. In the *Edit Dimension* window, the current length of the line is displayed. Enter **50** to set the selected length of the sketch to 50 millimeters.

3. Click on the *Accept* icon to accept the entered value.

> Autodesk Inventor will now update the profile with the new dimension value.

4. On your own, repeat the above steps and adjust the dimensions so that the sketch appears as shown below. Also **exit** the *Dimension* command.

**Repositioning Dimensions**

1. Move the cursor near the vertical dimension; note that the dimension is highlighted. Move the cursor slowly until a small marker appears next to the cursor, as shown in the figure.

2. Drag with the left-mouse-button to reposition the selected dimension.

3. Repeat the above steps to reposition the horizontal dimension.
Using the Measure Tools

Autodesk Inventor also provides several measuring tools that allow us to measure area, perimeter and additional information of the constructed 2D sketches.

1. In the *Inspect Ribbon tab*, left-click once on the **Measure** option as shown.
   - Note that **other** measurement options are also available in the toolbar.

2. Click on the top edge of the rectangle as shown.

3. The associated length measurement of the selected geometry is displayed in the *Length* dialog box as shown.

4. Inside the *graphics window*, right-click once to bring up the **Option menu** and select **Restart** as shown.

5. Move the cursor on top of any of the edges and click once with the right-mouse-button to bring up the **Option menu** and choose **Select Other...** as shown.
6. In the Selection list, left-click once to pick the **Curve Loop** option as shown.

   ![Selection list with Curve Loop option highlighted]

- The **perimeter** of the rectangle is displayed as shown.

7. Click on the [X] icon to end the Measure command as shown.

   ![Measure command with [X] icon]

8. In the **Inspect Ribbon tab**, left-click once on the **Region Properties** option as shown.

   ![Inspect Ribbon tab with Region Properties option highlighted]
9. Click on the inside of the rectangle; notice the region is highlighted as the cursor is moved inside the rectangle, as shown.

10. In the **Region Properties** dialog box, click on the **Calculate** button to perform the calculations of the associated geometry information.

   - In the **Region Properties** dialog box, the detailed region properties are calculated and displayed, including the *Area Moments of Inertia*, *Area* and *Perimeter*.

11. Click **Done** to exit the **Region Properties** command.

12. Select **Finish Sketch** in the **Ribbon** to end the Sketch option.
Completing the Base Solid Feature

1. In the 3D Model tab select the Extrude command by clicking the left-mouse-button on the icon.

2. In the Extrude pop-up window, enter 15 as the extrusion distance. Notice that the sketch region is automatically selected as the extrusion profile.

3. Click on the OK button to proceed with creating the 3D part. Use the Dynamic Viewing options to view the created part. Press F6 to change the display to the isometric view as shown before going to the next section.
Creating the Next Solid Feature

1. In the 3D Model tab select the **Start 2D Sketch** command by left-clicking once on the icon.

2. In the Status Bar area, the message “Select plane to create sketch or an existing sketch to edit” is displayed. Autodesk Inventor expects us to identify a planar surface where the 2D sketch of the next feature is to be created. Move the graphics cursor on the 3D part and notice that Autodesk Inventor will automatically highlight feasible planes and surfaces as the cursor is on top of the different surfaces.

3. Use the **ViewCube** to adjust the display viewing the bottom face of the solid model as shown below.

4. Pick the bottom face of the 3D model as the sketching plane.

- Note that the sketching plane is aligned to the selected face. Autodesk Inventor automatically establishes a User-Coordinate-System (UCS) and records its location with respect to the part on which it was created.
5. Select the **Center Point Circle** command by clicking once with the left-mouse-button on the icon in the *Sketch* tab.

- We will align the center of the circle to the midpoint of the base feature.

6. Inside the graphics window, click once with the **right-mouse-button** to bring up the option menu and choose the snap to **Midpoint** option.

7. Select the left edge of the base feature to align the center point of the new circle.

8. Select the green dot to align the midpoint of the line.

9. Select the top corner of the base feature to create a circle as shown in the figure.

10. Inside the *graphics window*, click once with the right-mouse-button to display the option menu. Select **OK** to end the Circle command.

11. In the *Ribbon* toolbar, select **Finish Sketch** to exit the Sketch mode.
12. Press the function key **F6** once or select **Home View** in the **ViewCube** to change the display to the isometric view as shown.

13. In the 3D Model tab, select the **Extrude** command by left-clicking the icon.

14. In the **Extrude** pop-up control, the **Profile** button is activated as shown; Autodesk Inventor expects us to identify the profile to be extruded. Move the cursor inside the circle we just created and select the region as the profile to be extruded.
15. In the *Extrude* pop-up control, enter **40** as the blind extrusion distance as shown below. Set the solid operation to **Join**. Click on the **Direction 2** button to reverse the direction of extrusion (upward) as shown below.

- Note that most of the settings can also be set through the icons displayed on the screen.

16. Click on the **OK** button to proceed with the **Join** operation.

- The two features are joined together into one solid part; the **CSG-Union** operation was performed.
Creating a Cut Feature

We will create a circular cut as the next solid feature of the design. We will align the sketch plane to the top of the last cylinder feature.

1. In the 3D Model tab select the **Start 2D Sketch** command by left-clicking once on the icon.

2. Pick the top face of the cylinder as shown.

3. Select the **Center Point Circle** command by clicking once with the **left-mouse-button** on the icon in the **Sketch tab** of the Ribbon toolbar.

4. Select the **Center** point of the top face of the 3D model as shown.
5. Sketch a circle of arbitrary size inside the top face of the cylinder as shown to the left.

6. Use the right-mouse-button to display the option menu and select OK in the pop-up menu to end the Circle command.

7. Inside the graphics window, click once with the right-mouse-button to display the option menu. Select the General Dimension option in the pop-up menu.

8. Create a dimension to describe the size of the circle and set it to 30mm.

9. Inside the graphics window, click once with the right-mouse-button to display the option menu. Select OK in the pop-up menu to end the Dimension command.

10. Inside the graphics window, click once with the right-mouse-button to display the option menu. Select Finish 2D Sketch in the pop-up menu to end the Sketch option.
11. In the 3D Model tab, select the **Extrude** command by left-clicking on the icon.

12. In the Extrude pop-up window, the **Profile** button is pressed down; Autodesk Inventor expects us to identify the profile to be extruded. Move the cursor inside the **circle** we just created and left-click once to select the inside region as the profile to be extruded.

13. In the Extrusion pop-up window, set the operation option to **Cut**. Select **Through All** as the **Extents** option, as shown below. Confirm the arrowhead points downward.

14. Click on the **OK** button to proceed with the **Cut** operation.

- The circular volume is removed from the solid model; the **CSG-Cut** operation resulted in a single solid.
Creating a Placed Feature

In Autodesk Inventor, there are two types of geometric features: **placed features** and **sketched features**. The last cut feature we created is a **sketched feature**, where we created a rough sketch and performed an extrusion operation. We can also create a hole feature, which is a placed feature. A **placed feature** is a feature that does not need a sketch and can be created automatically. Holes, fillets, chamfers, and shells are all placed features.

1. In the **Create** toolbar, select the **Hole** command by left-clicking on the icon.

2. In the **Hole** window, notice the **Face** button is pressed down.

3. Pick a location inside the horizontal surface of the base feature as shown.

4. Enter **20 mm** as the diameter of the hole as shown. **Do Not** click the OK button yet.

5. In the **Hole dialog box**, click the **Reference 1** button.
6. Pick the right-edge of the top face of the base feature as shown. This will be used as the first reference for placing the hole on the plane.

7. Enter 30 mm as the distance as shown. Do Not click the OK button yet.

8. Pick the adjacent edge of the top face as shown. This will be used as the second reference for placing the hole on the plane.

9. Enter 25 mm as the distance as shown.

10. In Holes dialog box, set the Termination option to Through All.

11. Click on the OK button to proceed with the Hole feature.

- The circular volume is removed from the solid model; the CSG-Cut operation resulted in a single solid.
Creating a Rectangular Cut Feature

Next create a rectangular cut as the last solid feature of the **Locator**.

1. In the 3D Model tab select the **Start 2D Sketch** command by left-clicking once on the icon.

2. Pick the right face of the base feature as shown.

3. Select the **Two point rectangle** command by clicking once with the left-mouse-button on the icon in the Sketch tab of the Ribbon toolbar.

4. Create a rectangle that is aligned to the top and bottom edges of the base feature as shown. (Hit [F6] to set the display orientation if necessary.)

5. On your own, create and modify the two dimensions as shown.

6. Select **Finish Sketch** in the Ribbon toolbar to end the Sketch option.
7. In the 3D Model tab, select the **Extrude** command by left-clicking on the icon.

8. In the *Extrude* pop-up window, the **Profile** button is pressed down; Autodesk Inventor expects us to identify the profile to be extruded. Move the cursor inside the rectangle we just created and left-click once to select the region as the profile to be extruded.

9. In the *Extrude* pop-up window, set the operation option to **Cut**. Select **To Next** as the Extents option as shown. Set the arrowhead points toward the center of the solid model.

10. Click on the **OK** button to create the **Cut** feature and complete the design.
Save the Model

1. Select **Save** in the *Quick Access Toolbar*, or you can also use the “**Ctrl-S**” combination (hold down the “**Ctrl**” key and hit the “**S**” key once) to save the part.

2. Switch to the **Parametric Modeling folder** if it is not the current folder.

3. In the *Save As* dialog box, **right-click** once in the *list area* to bring up the *option menu*.

4. In the *option list*, select **New** as shown.

5. In the second *option list*, select **Folder** to create a subfolder.

6. Enter **Chapter3** as the new folder name as shown.

7. **Double-click** on the **Chapter3** folder to open it.

8. In the *file name* editor box, enter **Locator** as the file name.

9. Click on the **Save** button to save the file.
Review Questions: (Time: 20 minutes.)

1. List and describe three basic Boolean operations commonly used in computer geometric modeling software.

2. What is a primitive solid?

3. What does CSG stand for?

4. Which Boolean operation keeps only the volume common to the two solid objects?

5. What is the main difference between a CUT feature and a HOLE feature in Autodesk Inventor?

6. Create the following 2D Sketch and measure the associated area and perimeter.

7. Using the CSG concepts, create Binary Tree sketches showing the steps you plan to use to create the two models shown on the next page:
**Exercises:** Create and save the exercises in the Chapter3 folder.
(Time: 180 minutes.)

1. **Latch Clip** (Dimensions are in inches. Thickness: 0.25 inches.)

   ![Latch Clip Diagram]

2. **Guide Plate** (Dimensions are in inches. Thickness: 0.25 inches. Boss height 0.125 inches. The two diameter 1.00 holes are through holes.)

   ![Guide Plate Diagram]
3. **Angle Slider** (Dimensions are in Millimeters.)

4. **Coupling Base** (Dimensions are in inches.)
5. **Indexing Guide** (Dimensions are in inches.)

![Indexing Guide Diagram]

6. **L-Bracket** (Dimensions are in inches.)

![L-Bracket Diagram]