Visit the following websites to learn more about this book:
Chapter 7

Structural Framing

The skeleton of a building is its structural framing. Together, elements such as columns, beams, bracing, and trusses give buildings the stability they need. While the basic process of adding these elements to the project is simple, you also need to complete more complex tasks, such as manipulating connections (by setting bearing offsets, cantilevers, cut backs, and justifications), applying beam coping, and editing beam joins.

Learning Objectives in this Chapter

• Sketch individual beams for girders connecting columns and structural walls.
• Create Beam Systems of multiple similar sized beams spaced at equal intervals to speed up adding joists.
• Add Bracing to support the integrity of other framing members.
• Make changes to framing members so that the connections fit the exact situation.
• Add trusses to support long spans of open space.
7.1 Modeling Structural Framing

The Autodesk® Revit® software enables you to frame a building with wood, concrete, and steel framing and bracing, such as the steel example shown in Figure 7–1. You can add individual beams, as well as beam systems and bracing elements.

- Framing types include: Concrete, Light Gauge Steel, Precast Concrete, Steel, and Wood.

- In views set to a Coarse detail level, the software assigns a lineweight to the structural members based on their structural usage. For example, a Girder displays in a heavier lineweight than a Joist, while a Purlin displays with a dashed line, as shown in Figure 7–2.
How To: Add Beams

1. In the **Structure** tab>Structure panel, click \(\text{_beam} \) (Beam).
2. In the Type Selector, select a beam type.
3. In the Options Bar, specify the options, as shown in Figure 7–3 and described below.

![Figure 7–3](image)

- **Placement Plane:** Defaults to the current level if you are in a plan view but can be modified to other levels.
- **Structural Usage:** Select a type (as shown in Figure 7–3), or accept the default of <Automatic>.
- **3D Snapping:** Select this if you want to draw a beam from one point to another at different heights.
- **Chain:** Select this if you want to draw a series of beams in a row. To stay in the command and start another chain, press <Esc> once.

4. For automatic tagging, in the **Modify | Place Beam** tab>Tag panel, click \(\text{Tag on Placement} \)
5. In the **Modify | Place Beam** tab>Draw panel, use the Draw tools to draw the beams.

How To: Add Multiple Beams on Grid Lines

1. Start the **Beam** command and specify the type and other options, as outlined above.
2. In the **Modify | Place Beam** tab>Multiple panel, click \(\text{On Grids} \).
3. Select the grids where you want to locate the beams. A beam is placed between each grid intersection, as shown in Figure 7–4. Hold <Ctrl> to select more than one grid, or use a pick and drag window to select multiple grids at one time. Columns must be in place to support the beams for this to work.

4. In the Modify | Place Beam>On Grid Line tab>Multiple panel, click (Finish).

   - Sometimes this can be the quickest way to add beams. If you need to use various sizes of beams, when you are finished, select those beams and make any changes in the Type Selector.

Beam Systems

Beam Systems are layouts of parallel beams placed between other beams, as shown in Figure 7–5. Typically used in joist layouts, beam systems can be set up to use either a fixed distance or number of beams.

   - Beam systems can be created automatically with sufficient bounding elements (other beams). You can also sketch the boundary for a beam system.
How To: Add Automatic Beam Systems

1. In the Structure tab>Structure panel, click (Beam System) or type BS.
2. The Modify | Place Structural Beam System tab>Beam System panel, click (Automatic Beam System).
3. When (Tag on Placement) is selected, in the Options Bar, set the Tag Style as shown in Figure 7–6.
   • **Framing**: Tags each individual member.
   • **System**: Places one tag for the entire framing system.

![Figure 7–6](image)

4. In the Options Bar (shown in Figure 7–7), set the Beam Type, Justification, and Layout Rule.

![Figure 7–7](image)

- The Layout Rules include: Clear Spacing, Fixed Distance, Fixed Number, and Maximum Spacing. Set the required distance or number.
- Make changes in Properties or in the Options Bar as required to establish the required beam system.
5. Move the cursor over an existing beam until the guide lines display in the correct area and direction, as shown vertically and horizontally in Figure 7–8. This can also identify angled lines.

6. Select the existing beam to place the system.
7. Repeat this step in other bays as required.

• The Beam System is one uniform group. You can change beam’s type, spacing, and elevation in Properties or in the Options Bar.

• If a grid line is moved, the beams automatically space themselves. If the bay increases beyond the minimum spacing, a beam is added. If the bay shrinks below the allowable spacing, a beam is removed.

• If you need to change the system to individual beams, in the Modify | Structural Beam Systems tab>Beam System panel, click (Remove Beam System). The individual beams remain but are no longer grouped together.
How To: Sketch a Beam System

1. In the Structure tab>Structure panel, click 🏗️ (Beam System).
2. In the Modify | Place Structural Beam System tab>Beam System panel, click 🏗️ (Sketch Beam System).
3. In the Modify | Create Beam System Boundary tab>Draw panel, click 🍃 (Pick Supports) or use one of the other drawing tools.
4. In the Draw panel, click ⬅️ (Beam Direction) and select one of the sketch lines that runs as you want the system to run, as shown on the top horizontal beam in Figure 7–9.

![Figure 7–9](image)

5. Clean up all of the corners so that there are no overlaps or gaps.
6. In the Modify | Create Beam System Boundary tab>Mode panel, click ✔️ (Finish Edit Mode).
7. Make changes in Properties or in the Options Bar as required to establish the required beam system.
   - To include an opening in a beam system, draw another opening inside the original sketched boundary.
Adding Bracing

Braces automatically attach to other structural elements, such as beams, columns, and walls. They recognize typical snap points such as the end point of a column and the middle of a beam, as shown in Figure 7–10.

![Figure 7–10](image)

- Bracing can be added in plan view or, more typically, in a framing elevation view.

**How To: Add Bracing**

1. Create and open a framing elevation.
2. In the **Structure** tab>Structure panel, click (Brace).
3. In the Type Selector, select a brace type.
4. Pick two points for the end points of the brace.

- Work from the centerline of all of framing members so that the analytical line extends into the adjacent framing, even though the graphical member stops at the edge of the column or beam, as shown in Figure 7–11.

![Figure 7–11](image)
Cross Bracing Settings

In plan view, cross bracing needs to be displayed graphically, usually by hidden lines. The software has a separate setting that controls cross bracing as viewed in plan. These settings enable you to display bracing above, below, or both. The bracing can be displayed as parallel lines or as a line at an angle, as shown in Figure 7–12.

Figure 7–12

• In the Manage tab>Settings panel, expand (Structural Settings) and click (Structural Settings). In the Structural Settings dialog box, in the Symbolic Representation Settings tab, select the Brace Symbol options, as shown in Figure 7–13.

![Figure 7–13](image)
Hint: Copying Elements to Multiple Levels

Instead of drawing the same elements on each level, you can copy them to the clipboard and then paste them aligned to the other levels.

1. Select the required elements.
2. In the **Modify** tab>Clipboard panel, click \(\text{COPY TO CLIPBOARD}\) (Copy to Clipboard).
3. In the **Modify** tab>Clipboard panel, expand \(\text{PASTE}\) (Paste) and click \(\text{ALIGNED TO SELECTED LEVELS}\) (Aligned to Selected Levels).
4. In the Select Levels dialog box, as shown in Figure 7–14, select the levels to which you want to copy the beams.

5. Click **OK**.

- This command is for copying model elements only. If you want to include tags or other annotation, use **PASTE>ALIGNED TO SELECTED VIEWS**.
Practice 7a  Model Structural Framing

Practice Objectives

- Place beams and beam systems.
- Copy framing to additional levels.
- Create a framing elevation.
- Add bracing

In this practice, you will add framing for one floor of a building (as shown in Figure 7–15), and then copy and paste the framing to the levels above. You will then add bracing to one part of the structure.

Figure 7–15

- This graphic is modified for clarity.

Task 1 - Place perimeter beams.

1. Open the project Syracuse-Suites-Beams.rvt.
2. Open the Structural Plans: TOS-1ST FLOOR view.
3. In Properties, in the Underlay area, set the Range: Base Level to T.O. FOOTING so that you can see the outline of the building.
4. In the View Control Bar set the Detail Level to (Medium).
5. In the Structure tab>Structure panel, click (Beam).
6. In the Type Selector, select **W-Wide-Flange: W14x30**.

7. Add framing between each column (and in some cases between beams), as shown in Figure 7–16. You can use a variety of techniques to place the beams.

![Figure 7–16](image)

- If you use **At Grids** (At Grids), ensure that you select the correct grids. Delete beams that are not used.
- If you are sketching the beams, in the Options Bar, select **Chain** to keep the sketching active between picks. Press <Esc> once to end the chain but remain in the command.
- To place the curved beams, use either **Pick Lines** (Pick Lines) or the **Start-End-Radius Arc** tool.
- Use **Split Element** (Split Element) to break each curved beam into two beams at the midpoint.
- Select the curved beams and in Properties, in the **Structural** section, change the **Structural Usage** to **Girder**.

8. Save the project.
Task 2 - Create Beam Systems.

1. In the Structure tab>Structure panel, click (Beam System).

2. In the Modify | Place Structural Beam System tab, verify that (Automatic Beam System) is selected.

3. In the Tag panel, if required, click (Tag on Placement) to toggle it off.

4. In the Options Bar, set the following:
   - Beam Type: **W12x26**
   - Layout Rule: **Maximum Spacing of 6'-0”**

5. Click inside each bay, ensuring that the beams are running in a West-East direction. Exclude the bays shown in Figure 7–17.

6. Use (Sketch Beam System) for any bays that cannot be applied automatically.
   - In Properties, in the Identity Data area, set Tag new members in view to None.

7. Once all of the framing is in place end the command.

8. Save the project.
Task 3 - Copy the framing to the other levels.

1. Select **everything** on the first floor except the grid lines.

2. In the Status Bar, click 
   (Filter).

3. In the Filter dialog box, clear the **Structural Columns** category as shown in Figure 7–18. If elements other than framing are displayed, clear those categories as well.

4. Click **OK**.

5. In the **Modify | Multi-Select** tab>Clipboard panel, click 
   (Copy to Clipboard).

6. In the Clipboard panel, expand 
   (Paste) and click 
   (Aligned to Selected Levels).

7. In the Select Levels dialog box, select **TOS-2ND FLOOR** to **TOS-13TH FLOOR**, as shown in Figure 7–19. (Hint: Hold <Ctrl> or <Shift> to select multiple levels.)
8. Click OK. This will take some time to process.

9. Open the **Structural Plans: TOS-13TH FLOOR** view.

10. Only the Girder beams of each bay are required on the roof level. With a crossing window, select everything and filter out everything but **Structural Framing (Girder)**.

11. Press <Ctrl> + C (the **Copy to Clipboard** shortcut).

12. In the Clipboard panel, expand ✂️ (Paste) and click 📋 (Aligned to Selected Levels).

13. In the Select Levels dialog box, select **TOS-14 ROOF** and click OK.

14. Open the **TOS-14 Roof** view and set the **Detail Level** to **Medium** so you can see the girder placement.

15. Open a 3D view to see the full model, as shown in Figure 7–20.

16. Save the project.

*This graphic is shown at the Coarse detail level with **Show Analytical Model** on for clarity.*
Task 4 - Create a framing elevation.

1. Open the **TOS-1st FLOOR** structural plan view.

2. In the **View** tab>**Create** panel, expand **(Elevation)** and click **(Framing Elevation)**.

3. Select the beam along **Grid 1** between **Grid B** and **Grid C**, as shown in Figure 7–21.

4. In the Project Browser, expand **Elevations (Framing Elevation)** and rename Elevation 1 – a as **West Bracing**.

5. Open the framing elevation.

6. Modify the crop region to display the columns.

7. In the View Control Bar, set the **Detail Level** to **(Fine)**.

8. Zoom in to display the **00 GROUND FLOOR** and **TOS-1ST FLOOR** level heads.

9. Save the project.
Task 5 - Add bracing.

1. In the Structure tab>Structure panel, click (Brace).

2. In the Type Selector, select **HSS Hollow Structural Section: HSS6X6X1/2**.

3. Draw from the centerline of the base of the column on the left to the midpoint of the beam located on the 1st Floor, as shown in Figure 7–22. Repeat this step on the other side.

4. Click (Modify) and select the two new braces.

5. Copy the braces to the clipboard and use **Paste Aligned** to place them on each of the levels from **00 GROUND FLOOR** to **TOS-12TH FLOOR**. (Do not include the **T.O.FOOTING** level)

6. Pan up to the top level.

7. Select the top two braces, if required.

*Note that the entrance level is listed as **Ground Floor**. This is typical in some Canadian and British naming schemes.*
8. Drag the circular control up to the beam above it, as shown in Figure 7–23.

9. Zoom out to see the entire framing elevation.

10. Save the project.
7.2 Modifying Structural Framing

The default connections of columns, beams, and braces might need to be modified to suit specific situations, such as when the beams are offset from their associated level, or cantilevered beyond a framing member. Modifications can be made by using graphical controls and shape handles, the Properties, or special tools found on the *Modify | Structural Framing* tab, as shown in Figure 7–24.

- The *Detail Level* of a view impacts the way in which framing members display, as shown in Figure 7–25. Some editing tools only work in a Medium or Fine detail view.
• The Location Line can be used as a visual reference, as shown in Figure 7–26. In the Visibility/Graphics dialog box, in the Model Categories tab, expand Structural Framing and select Location Line.

• Alternatively, you can view structural connections using Analytical Lines, as shown in Figure 7–27. In the View Control Bar, click (Show/Hide Analytical Model) to toggle this on and off.

• When you draw framing members, the start/end orientation is based on the first and second points picked. In some modification instances it is important to know the start point verses the end point. In the analytical model, the start point is green and the end point is red, as shown in Figure 7–28.

• To flip the start and end points, in a 3D view, right-click on the member and select Flip Structural Framing ends.
Sloping and Offsetting Beams

Beams can be modified to slope or offset from the level where they are placed. This can be done by using the *Start/End Level Offset* control, as shown on the left in Figure 7–29, or in Properties, as shown on the right in Figure 7–29.

- Setting the offset at only one end slopes the beam as shown in Figure 7–30.

- The *Cross-Section Rotation* option rotates the beam along its axis at the angle specified in Properties.
Hint: Using 3D Snapping

When you draw beams, you can toggle on 3D Snapping and then snap to other beams or structural walls of different heights. You can also do this with beam systems when you use the Automatic Beam System method. On the left in Figure 7–31, the 3D and Walls Define Slope options are selected, while on the right, they are not.

Figure 7–31

- Setting the Start/End Level Offset the same at each end raises or lowers the entire beam. For example, when Wide Flange Beams are supporting Open Web Steel Joists (as shown in Figure 7–32), you need to offset that increment based on the specific joist’s seat.

Figure 7–32
Adding Beam Cantilevers and Cutbacks

It is common to need a joist extension that cantilevers a bearing member. In the example shown in Figure 7–33, the joist seat needs to extend past the beam it bears on to frame into a cantilevered ridge beam. By modifying the individual joists, you can extend either end to meet the requirements.

Figure 7–33

To cantilever or cutback a beam that is joined to other structural elements, use the shape handles to drag it to a new location, or set the Start/End Join Cutback in Properties, as shown in Figure 7–34,

Figure 7–34

- The Cutbacks only displays if the Detail Level is set to (Medium) or (Fine).
To cantilever a beam when the beam is not joined to other elements, you can use the **Drag Structural Framing Component End** shape handle (as shown in Figure 7–35), or in Properties set the **Start or End Extension**.

![Dragging Structural Framing Component End](image)

**Figure 7–35**

- When working with Beam Systems you first need to unpin the individual beam you want to work with. Select it and click the (Prevent or allow change of element position) icon.

**Hint: Structural Connections and Fabrication**

Over 150 standard structural connections can be added to framing joins to share in-depth information about the join with the contractor and fabricator. You can also add fabrication elements such as plates, bolts, and welds and modify plates and other steel elements using copes and other cuts. These tools, which are beyond the scope of this learning guide, are found on the **Steel** tab, as shown in Figure 7–36.

![Steel Tab](image)

**Figure 7–36**
Another way to modify the join connection of structural framing is to change the cutback from the connected element. For example, the default cutback of the column shown in Figure 7–37 is the bounding box of the column, not the vertical support. You can change the reference to a more appropriate part of the framing.

You can select more than one element to adjust as long as they are connected to the same reference.

How To: Adjust the Cutback of Structural Framing

1. Select the structural framing member you want to modify.
2. In the Modify | Structural Framing tab>Join Tools panel, click (Change Reference).
3. Select the reference point for alignment, as shown on the left in Figure 7–38. This can be another beam, a structural column, or a structural wall.
4. The end of the framing, the member moves to the new reference location, as shown on the right in Figure 7–38.
5. In Properties modify the Start Join Cutback or End Join Cutback distance as required.

• To return the beam end to its default setback position, click (Change Reference) again, and then select the bounding box (dashed lines) of the other element.

You can changing the reference in 2D and 3D views if the Display Level is set to Medium or Fine.
Another modification you can make to beams is to change their justification. You can set the horizontal (y) and vertical (z) justification points to one of nine different points, such as **Origin Left**, shown in Figure 7–39. The Location Line remains in place, with the framing element moved to the new justification. You can also change the offset from the justification point in either the **y** (left to right), or **z** (top to bottom) directions. Both of these options can be modified either graphically or through Properties.

**How To: Set the Justification of Framing Elements Graphically**

1. Select the beam you want to modify.
2. In the **Modify | Structural Framing** tab>Justification panel, click **(Justification Points)**, or type **JP**.
3. Select the Justification points you want to use, as shown in Figure 7–40.
• The location line does not change, but the framing element repositions to the selected justification point.

• You can also modify the Justification points using the $y$ Justification and $z$ Justification parameters in Properties, as shown in Figure 7–41.

![Figure 7–41](image)

**How To: Change the Justification Offset Graphically**

1. Select the structural framing element.
2. In the Modify | Structural Framing tab>Justification panel:
   - Modify the horizontal offset and distance by clicking $y$ Offset, or type $JY$.
   - Modify the vertical offset and distance by clicking $z$ Offset, or type $JZ$.
3. Select the offset start point and then the offset end point.
   - You can also modify the offset values in Properties by using the $y$ Offset Value and $z$ Offset Value.
- The yz Justification can be set to **Uniform** (where the same justification offset is applied to both ends) or **Independent** (where the justification offset can be different for each end). When this is selected you can set both the **Start y (or z) Offset Value** and the **End y (or z) Offset Values** in Properties, as shown in Figure 7–42.

<table>
<thead>
<tr>
<th>Geometric Position</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Extension</td>
<td>0' 0&quot;</td>
</tr>
<tr>
<td>End Extension</td>
<td>0' 0&quot;</td>
</tr>
<tr>
<td>yz Justification</td>
<td>Independent</td>
</tr>
<tr>
<td>Start y Justification</td>
<td>Origin</td>
</tr>
<tr>
<td>Start y Offset Value</td>
<td>0' 0&quot;</td>
</tr>
<tr>
<td>Start z Justification</td>
<td>Top</td>
</tr>
<tr>
<td>Start z Offset Value</td>
<td>0' 0&quot;</td>
</tr>
<tr>
<td>End y Justification</td>
<td>Origin</td>
</tr>
<tr>
<td>End y Offset Value</td>
<td>0' 0&quot;</td>
</tr>
<tr>
<td>End z Justification</td>
<td>Top</td>
</tr>
<tr>
<td>End z Offset Value</td>
<td>0' 0&quot;</td>
</tr>
</tbody>
</table>

**Figure 7–42**
Attaching a Column to a Beam

The columns that support the cantilever can be attached to the bottom of the framing member, as shown in Figure 7–45. This removes the need to estimate the actual bearing depth of the framing member, and ensures that the column always remains connected to the beam.

Hint: Viewing Justifications

At the Coarse Detail Level, when you select the beam, the justification line is displayed, as shown in Figure 7–43.

When working in the Medium (or Fine) Detail Level, along with toggling on the Location Line in Visibility/Graphics it can help to display the analytical model, as shown in Figure 7–44. In the View Control Bar, click (Show Analytical Model).
**How To: Attach a Column to the Bottom of a Beam**

1. Select a column.
2. In the *Modify Structural Columns* tab>Modify Column panel, click (Attach Top/Base).
3. In the Options Bar, set the options as required. If you need to add a bearing plate, set the *Offset from Attachment* value.
4. Select the beam that the column will attach to.

- You can also use this command to attach the base of a beam to structural footings. When the footing moves in height, the length of the column resizes to match.

When one beam connects with another beam you might need to modify the connection. In the example shown in Figure 7–46, the lower joist-bearing beam runs into the perimeter beam. This is a coping situation.

![Figure 7–46](image)

**How To: Cope Beams**

1. Open a 3D view, section, or detail view.
2. Zoom in to a beam to beam (or beam to column) connection.
3. In the *Modify* tab>Geometry panel, expand (Cope) and select (Apply Coping).
4. Select the beam to be coped first followed by the column/beam from which to cut. The cope is then completed.
- You can change the *Coping Distance* setting in Properties.
Editing Beam Joins

When you add beams to a project there is a default layout to the beam joins. However, you might need to override the joins. You can do this by using Change Beam Status, as shown in Figure 7–47.

![Figure 7–47](image)

How To: Edit Beam Joins

1. In the Modify tab>Geometry panel, click (Beam/Column Joins). The work area switches to Sketch mode.
   - Only the beams and/or columns that can be changed are highlighted.
   - You cannot use this tool on beams that are attached to vertical columns.
2. In the Options Bar, specify the types of beams that you want to work with as shown in Figure 7–48.

![Figure 7–48](image)

3. Click the Change Beam Status control to toggle the join.
4. Click (Beam/Column Joins) again to toggle the command off.
• If you are mitering a corner, you can lock the miter as shown in Figure 7–49.

![Unlocked Locked](image)

Figure 7–49

**Hint: Join Status**

You can modify the *Join Status* of structural framing to position framing that butts against a wall or other beams. Right-click on the join control (the circle), select *Disallow Join* (as shown on the left in Figure 7–50), and make the required modifications. Click *Allow Join* to rejoin the elements.

![Disallow Join](image)

Figure 7–50

• *Join Status* is a field that can be used in schedules. You can modify the status in the schedule.
Practice 7b Modify Structural Framing

Practice Objectives

- Modify beam level offsets.
- Sketch Beam Systems.

In this practice, you will modify beam level offsets for correct joist bearing and add beam systems using the automatic method where you can and sketch beam systems in areas where they cannot be automatically placed, as shown in Figure 7–51.

Task 1 - Modify beam level offsets.

1. Open Syracuse-Suites-Framing.rvt.
2. Open the Structural Plans: TOS-14 ROOF view.
3. Hide the grids.
4. For this level you need to lower the perimeter beams of each bay in the North-South direction for the joist bearing. Select all of the vertical beams in the plan, excluding the beams along the far right, as shown in Figure 7–52.

If you selected bracing element, you need to filter them out.

5. In Properties, change the Start Level and End Level Offsets to (negative) \(-2 \frac{1}{2}"\).

6. Click Apply.

7. Open a 3D view and zoom in on one of the top floor intersections. The North-South girders should be displayed below the East-West girders as shown in Figure 7–53.

8. Save the project.
Task 2 - Sketch beam systems.

1. Switch to Structural Plans: TOS-14 ROOF view.

2. In the Insert tab>Load from Library panel, click 📁 (Load Family).

3. In the Load Family dialog box, browse to the Structural Framing>Steel folder, select K-Series Bar Joist-Rod Web.rfa, and click Open.

4. In the Specify Types dialog box, select 16K7 from the list and click OK.

5. In the Structure tab>Structure panel, click ⌋ (Beam System). In the Options Bar and Properties, set the following parameters:
   - Beam Type: 16K7
   - Layout Rule: Maximum Spacing
   - Maximum Spacing: 6’-0”

6. Hover the cursor over the lower left girder as shown in Figure 7–54. The Beam System does not stop at the boundary of the other girders as expected because of the lower bearing offset. Do not select the beam.

7. In the Modify | Place Structural Beam System tab>Beam System panel, click 🏗️ (Sketch Beam System).

8. In Properties, In the Identity Data section, change Tag new members in view to None.
9. In the **Modify | Place Beam System Boundary** tab>Draw panel, click 🔄 (Pick Supports).

10. Draw a boundary with the beam direction running **West** to **East** as shown in Figure 7–55. Use 🛠️ (Trim) to clean up overlapping lines.

![Figure 7–55](image)

11. In the Mode panel, click 🔴 (Finish Edit Mode).

12. Repeat this procedure for the rest of the bays, as shown in Figure 7–56.

![Figure 7–56](image)
• Use (Automatic Beam System) where you can. If you have trouble placing the joists because of the bearing offset, use (Sketch Beam System).

• If the error shown in Figure 7–57 opens, the space for the joist might be too small to be created by the Beam System command. Click Delete Type. You can add a beam separately as required.

**Figure 7–57**

13. Save the project.
7.3 Adding Trusses

A truss can be added to a project using the same basic method as placing a beam. Trusses are typically comprised of one or more triangular sections, as shown in Figure 7–58. These sections are constructed with structural members whose ends are connected at joints, which are referred to as nodes. As various forces act on these nodes, the triangular shape provides structural stability to prevent bending.

![Figure 7–58](image)

Truss elements include:

- **Bottom Chord**, the lower horizontal member.
- **Top Chord**, the upper horizontal member.
- **Web**, the series of structural framing elements that stabilize the truss.

The **Top** and **Bottom Chords** fulfill the same function as a beam's top and bottom flanges. The **Web** takes the place of the beam’s continuous plate.

**How To: Add Trusses**

1. In the **Structure** tab>**Structure panel** click (Structural Trusses).
2. In the **Type Selector**, select the type of truss you want to use.
3. Click (Load Family) and navigate to the **Structural Trusses** folder to add families to the project.
4. In the **Modify | Place Truss** tab>**Draw panel**, click (Line) or (Pick Lines) and add the trusses to the project.
Attaching Trusses to Roofs

Trusses can be attached to roofs or floor slabs. They can also follow the slope of the roof and automatically extend to fit, as shown in Figure 7–59.

![Figure 7–59](image)

**How To: Attach Trusses to Roofs**

1. In the *Modify ‣ Structural Trusses* tab ‣ Modify Truss panel, click **Attach Trusses to Top or Bottom**.
2. In the Options Bar, set *Attach Trusses* to **Top** or **Bottom**.
3. Select the roof or floor element. The truss attaches to the element and follows the angle or slope, as shown in Figure 7–60.

![Figure 7–60](image)

- The top chord must be one continuous line in the family. If it is broken into segments, attaching it might not work properly.
- Verify that the bottom chord is specified as the bearing chord in the element properties of the truss. This ensures that the roof loads are carried throughout the truss appropriately.
- If the roof/floor slab does not cover the length of the truss, an error message opens and you might have to detach the truss.
When truss families are created they can include structural framing members for the chords and webs. However, they often just use default members. Therefore, you need to specify the precise framing types you want to use in the project.

In the Type Properties dialog box, select the **Structural Framing Type** from a list of families loaded into the project, as shown in Figure 7–61. Set the **Structural Framing Type** for the **Top Chords**, **Vertical Webs**, **Diagonal Webs**, and **Bottom Chords**.
• To select an entire truss, ensure that the dashed lines are displayed, as shown on the left in Figure 7–62. To select one element of the truss, press <Tab> until the element that you want to select is highlighted, as shown on the right in Figure 7–62.

• Individual Truss members are pinned to the truss framework. If you want to modify one of these you need to click ✖️ (Prevent or allow change of element position) to unpin only that member.

• You can rotate Trusses. and specify if the chords rotate with the truss. In Properties, type in a Rotation Angle and select or clear Rotate Chords with Truss, as shown in Figure 7–63.
Practice 7c Add Trusses

Practice Objectives

- Set up a truss type.
- Add trusses to a project.
- Attach trusses to a roof.

In this practice, you will setup a truss using specific structural framing types for the chords and webs. You will then draw a truss and array it across an open span. Finally, you will attach the trusses to an existing roof element, as shown in Figure 7–64.

![Structural Trusses: Howe Flat Truss: Skylight](Figure 7–64)

Task 1 - Set up a Truss Type

1. Open **Syracuse-Suites-Trusses.rvt**.

2. In the **Structure** tab>Structure panel, click **Truss**.

3. In the Type Selector, select **Howe Flat Truss: Standard** and click **Edit Type**.

4. In the Type Properties dialog box, click **Duplicate**.

5. In the Name dialog box, type **Skylight**, and click **OK**.
6. In the Type Properties dialog box, set the following properties as shown in Figure 7–65:
   - **Top Cords and Bottom Chords:**
     Set the *Structural Framing Type* to **2L6X4X5/8LLBB**.
   - **Vertical Webs and Diagonal Webs:**
     Set the *Structural Framing Type* to **2L3X2-1/2X1/2LLBB**.

![Type Properties dialog box](image)

**Figure 7–65**

7. Click **OK**.

8. Save the project.
Task 2 - Add Trusses.

1. Open the Structural Plans: TOS-14 ROOF view. Some of the structural framing has been removed in this plan to make way for a large skylight, as shown in Figure 7–66.

![Figure 7–66](image)

2. Start the (Truss) command.

3. In the Type Selector, verify that the Howe Flat Truss: Skylight is selected.

4. In Properties, set the Bearing Chord to Bottom and the Truss Height to 4’-0”.

5. Draw the first truss, as shown in Figure 7–67.

![Figure 7–67](image)
6. Click ☐ (Modify) and select the new truss.

7. In the Modify | Structural Trusses tab>Modify panel, click ☐ (Array).

8. In the Options Bar, ensure that ☐ (Linear) is selected and Group and Associate is cleared. Set the Number to 15 and the Move To: to Last.

9. To specify the length of the array, click on Grid C and then on Grid E.

10. Open the 3D Views: Roof and Skylight view to see the trusses, as shown in Figure 7–68.

11. Save the project.

**Task 3 - Attach the Trusses to a Roof.**

1. Open the Visibility Graphic Overrides dialog box and toggle on Roofs. An existing roof (referencing the location of the skylight) displays.

2. In the Quick Access Toolbar, click ☐ (Close Inactive Windows) so that only the 3D view displays.

3. Open the Elevations (Building Elevations): East and South views.

4. Type WT to tile the three views and ZA so that they are all zoomed out fully.
5. Zoom in on the skylight roof in the two elevation views, similar to that shown in Figure 7–69.

6. In the Elevation: East view, use a crossing window to select all of the trusses and other overlapping elements and then filter out everything but the trusses.

7. In the Modify | Structural Trusses tab>Modify Truss panel, click \(\text{(Attach Top/Bottom)}\).

8. Select the roof. Allow time for it all to process until the trusses expand to touch the roof, as shown in Figure 7–70.

9. Make the 3D View: Roof and Skylight view active and type TW to return to the tabbed view.

10. Save the project.
Chapter Review Questions

1. When placing a beam, which of the following is NOT an option?
   a. Structural Usage
   b. Placement Plane
   c. 3D Snapping
   d. At Columns

2. Which of the following describes a Beam System?
   a. Parallel beams grouped together after they are placed.
   b. Parallel beams placed at the same time.
   c. All beams in a bay grouped together after they are placed.
   d. All beams in a bay placed at the same time.

3. In a plan view, which of the following changes the display to show the stick symbol for beams, as shown in Figure 7–71?
   a. Detail Level: Coarse
   b. Detail Level: Medium
   c. Visual Style: Wireframe
   d. Visual Style: Hidden

Figure 7–71
4. How do you create sloped beams such as those shown in Figure 7–72?

   a. Specify the Slope before you start drawing the beam.
   b. Specify the Start/End Level Offset before you start drawing the beam.
   c. Change the Slope after you have drawn the beam.
   d. Change the Start/End Level Offset after you have drawn the beam.

5. Where do you assign the structural member types and sizes for the components of a truss, such as that shown in Figure 7–73? (Select all that apply.)

   a. In Family Types
   b. In Properties
   c. In Type Properties
   d. In the Options Bar
# Command Summary

<table>
<thead>
<tr>
<th>Button</th>
<th>Command</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Clipboard</strong></td>
<td></td>
</tr>
<tr>
<td>![Clipboard]</td>
<td>Copy to Clipboard</td>
<td>• Ribbon: <em>Modify</em> tab&gt;Clipboard panel</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Shortcut: &lt;Ctrl&gt;+C</td>
</tr>
<tr>
<td>![Clipboard]</td>
<td>Paste</td>
<td>• Ribbon: <em>Modify</em> tab&gt;Clipboard panel</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Shortcut: &lt;Ctrl&gt;+&lt;V&gt;</td>
</tr>
<tr>
<td>![Clipboard]</td>
<td>(Paste) Aligned to Selected Levels</td>
<td>• Ribbon: <em>Modify</em> tab&gt;Clipboard panel</td>
</tr>
<tr>
<td>![Clipboard]</td>
<td>(Paste) Aligned to Selected View</td>
<td>• Ribbon: <em>Modify</em> tab&gt;Clipboard panel</td>
</tr>
<tr>
<td></td>
<td><strong>Structural Framing Elements</strong></td>
<td></td>
</tr>
<tr>
<td>![Beam]</td>
<td>Beam</td>
<td>• Ribbon: <em>Structure</em> tab&gt;Structure panel</td>
</tr>
<tr>
<td>![Beam System]</td>
<td>Beam System</td>
<td>• Ribbon: <em>Structure</em> tab&gt;Structure panel</td>
</tr>
<tr>
<td>![Brace]</td>
<td>Brace</td>
<td>• Ribbon: <em>Structure</em> tab&gt;Structure panel</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Shortcut: BR</td>
</tr>
<tr>
<td>![Trusses]</td>
<td>Structural Trusses</td>
<td>• Ribbon: <em>Structure</em> tab&gt;Structure panel</td>
</tr>
<tr>
<td></td>
<td><strong>Structural Framing Modification</strong></td>
<td></td>
</tr>
<tr>
<td>![Apply Coping]</td>
<td>Apply Coping</td>
<td>• Ribbon: <em>Modify</em> tab&gt;Geometry panel, expand Cope</td>
</tr>
<tr>
<td>![Attach Top/Base]</td>
<td>Attach Top/Base</td>
<td>• Ribbon: <em>Modify</em></td>
</tr>
<tr>
<td>![Attach Top/Bottom]</td>
<td>Attach Top/Bottom</td>
<td>• Ribbon: <em>Modify</em></td>
</tr>
<tr>
<td>![Beam/Column Joins]</td>
<td>Beam/Column Joins</td>
<td>• Ribbon: <em>Modify</em> tab&gt;Geometry panel</td>
</tr>
<tr>
<td>![Change Reference]</td>
<td>Change Reference</td>
<td>• Ribbon: <em>Modify</em></td>
</tr>
<tr>
<td>![Connection]</td>
<td>Connection</td>
<td>• Ribbon: <em>Structure</em> tab&gt;Connection panel</td>
</tr>
<tr>
<td>![Detach Top/Base]</td>
<td>Detach Top/Base</td>
<td>• Ribbon: <em>Modify</em></td>
</tr>
<tr>
<td>![Detach Top/Bottom]</td>
<td>Detach Top/Bottom</td>
<td>• Ribbon: <em>Modify</em></td>
</tr>
<tr>
<td>![Justification Points]</td>
<td>Justification Points</td>
<td>• Ribbon: <em>Modify</em></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Shortcut: JP</td>
</tr>
<tr>
<td>Offset</td>
<td>• <strong>Ribbon:</strong> Modify</td>
<td>Structural Framing&gt; Justification panel</td>
</tr>
<tr>
<td>--------</td>
<td>-----------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>y Offset</td>
<td>• <strong>Ribbon:</strong> Modify</td>
<td>Structural Framing&gt; Justification panel</td>
</tr>
<tr>
<td></td>
<td>• <strong>Shortcut:</strong> JY</td>
<td></td>
</tr>
<tr>
<td>z Offset</td>
<td>• <strong>Ribbon:</strong> Modify</td>
<td>Structural Framing&gt; Justification panel</td>
</tr>
<tr>
<td></td>
<td>• <strong>Shortcut:</strong> JZ</td>
<td></td>
</tr>
</tbody>
</table>