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C h a p t e r

Assembling Project Files

The files used in the Autodesk® 3ds Max® software can be modeled directly in the 
software, referenced by linking, or directly imported from another source. Linking 
files enables you to incorporate objects or other scene files into the current scene 
by externally referencing them. Once referenced, the connection between the two 
files can be maintained. If files are imported, they are merged with the project and 
no link is established. Understanding the benefits and drawbacks of using external 
data helps you decide how to best reference it in a project.

Learning Objectives in this Chapter

• Understand the difference between File Linking and File Importing, and edit the linked data 
files.

• Combine entities from .DWG, .DXF, .FBX, and .RVT files into an active Autodesk 3ds Max 
scene.

• Understand how to link AutoCAD® DWG, DXF, generic FBX files, and Autodesk® Revit® 
RVT/FBX files. 

• Create and modify presets.

• Incorporate objects or other scene files into the current scene by externally referencing them.

• Manage data using the asset tracking systems.
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3.1 Data Linking and Importing
Although the Autodesk 3ds Max software has a robust 2D and 
3D modeling system, it might be efficient to link or import some 
or all of the design data from other Autodesk software, such as 
AutoCAD®, Autodesk® Revit® Architecture, AutoCAD® 
Architecture, or Autodesk® Inventor®. 

Linking vs.
Importing

You can link or import files using the File Link and Import tools. 
You can link files such as .DWG, .DXF, .FBX, and .RVT, and 
import files such as Autodesk® Inventor® (.IPT, .IAM), Autodesk® 
Alias® .Wire, LandXML and DEM data files, and Adobe Illustrator 
(.AI). 

• Linked geometry differs from imported geometry in that it 
remains connected to the source file. If the source file is 
edited, the Autodesk 3ds Max Scene can be updated to show 
those changes. Imported geometry maintains no connection 
to the source file. 

• If a source .DWG, .DXF, .FBX, or .RVT file is likely to change 
(or you would prefer to make changes in the .DWG, .DXF, 
.FBX, or .RVT directly), then using File Linking might be the 
best way to incorporate this data into the Autodesk 3ds Max 
software.

• Importing can be used as a faster alternative to linking to 
bring large amounts of data into the software. Complex 
geometry might be faster to reimport than to update through a 
file link.

• File links and imports are launched from the File>Import in 
the Menu bar, as shown in Figure 3–1.
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Figure 3–1

Editing Linked
Data

• Linked geometry can be edited but not directly deleted from a 
scene file. Alternatively, the layer on which the objects are 
placed might be ignored during a reload, or set to Hide in the 
Layer Explorer.

• Edits applied to linked geometry (such as through modifiers) 
are reapplied after a link is updated. Some complex 
modifications might not apply as expected, so you should 
always review your geometry carefully after a link is updated.

• Links to drawing files are not bi-directional, so that changes 
you make to the data in the Autodesk 3ds Max software do 
not update the original .DWG, .FBX, .DXF, or .RVT file.

• In linked files that are bound, the geometry stays in the scene 
file as-is, but the connection to the source file is dropped.

Importing You can export an .FBX file from the Autodesk Revit software 
and import it in Autodesk 3ds Max software. The FBX importer is 
an independent plug-in that is frequently updated. In the FBX 
Import dialog box, use Web Update to check for web updates, 
download the latest updates, and install them. Close 3ds Max 
when you do the install.
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Merging
Autodesk 3ds

Max Scene
Files

Objects already saved in Autodesk 3ds Max scenes (.MAX files) 
are imported into the current scene using the Merge option 
(File>Import>Merge). Merging files is a one-directional transfer 
that does not maintain any connection between the two files. 
Using the Merge option, you can either load a few objects from a 
scene or you can load a complete scene into the current one.

Civil View Civil View enables you to import 3D geometry from Civil/Survey 
products, such as AutoCAD Civil 3D, Land Desktop, and other 
formats such as BentleyMX files. 

Initializing Civil View

You only have to 
initialize Civil View once.

To use Civil View the first time, you are required to initialize it by 
selecting Civil View>Initialize Civil View. In the Initialize 
Autodesk Civil View dialog box that opens (as shown in 
Figure 3–2), you can set the System Units and the Country 
Resource Kit based on the civil project that you will be opening. 
After initializing the Civil View, you are required to exit and restart 
the Autodesk 3ds Max software.

Figure 3–2
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Although Civil View is initialized, if the Start Mode for Civil View is 
set to Manual, next time you launch the Autodesk 3ds Max 
software, you will still be required to start Civil View. You can 
change this setting in the Civil View Preferences dialog box, 
which can be accessed by selecting Civil View>Civil View> 
Preferences, in the General tab of the dialog box, selecting 
Automatically start Civil View?, as shown in Figure 3–3.

Figure 3–3

Using Civil View

• You can open the interface from the Menu bar by selecting 
Civil View>Start Civil View. 

• Once Civil View is started, you can import the required 
geometry by selecting Civil View>Geometry Import as 
shown in Figure 3–4.

Figure 3–4
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Civil View Explorer

You can use the Civil View Explorer (shown in Figure 3–5) to 
access the visualization aspects of the objects in the scene. It 
also contains all the editing commands for the selected objects. 
The objects that are imported retain a link to the original source 
file. The civil View visualization model retains a link to the original 
source file and updates the model whenever a design changes.

Figure 3–5
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Practice 3a Ground Surfaces using Civil 
View

In this practice, you will open a .VSP3D file for importing ground 
surfaces using Civil View. You will then modify the material 
assignment for various ground surfaces using the Civil View 
Explorer.

You must set the paths to locate the External files and Xrefs 
used in the practice. If you have not done this already, return to 
Chapter 1 and complete Task 1 to Task 3 in Practice 1a: 
Organizing Folders and Working with the Interface. You only 
have to set the user paths once.

Task 1 - Initialize Civil View.

It is recommended that you import 3D ground surfaces from 
Civil/Survey products, such as AutoCAD Civil 3D or Land 
Desktop using the vsp3d data format.

You have to initialize 
Civil View once.

1. In the menu bar, select Civil View>Initialize Civil View. If 
you have already initialized Civil View, go to Step 5.

2. In the Initialize Autodesk Civil View dialog box, set the 
System Units to Feet because the civil project that you will be 
opening uses Feet as its unit of measurement. Verify that 
Don’t warn me about System Units again is selected.

3. In the Select a Country Resource Kit area, select US 
IMPERIAL and verify that Start Mode for Civil View is set to 
Manual. Click OK. In the Information dialog box, click OK.

4. Exit and then restart the Autodesk 3ds Max software.

5. Select Civil View>Start Civil View to start Civil View. 

Practice Objective

• Open a Civil 3D data file in a scene file.
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Task 2 - Opening a Civil 3D File.

1. Open Civil Base XRef.max from the ...\scenes folder. If a 
Mismatch dialog box opens, click OK to accept the default 
values. If prompted again, click OK. This is an empty scene 
in which the System Unit Scale has been set to 1 Unit=1.0 
Feet.

2. In the menu bar, select Civil View>Geometry Import>Civil 
3D (VSP 3D) File, as shown in Figure 3–6.

Figure 3–6

3. In the Civil 3D Import Panel dialog box, click Open. In the 
Select a VSP3D File dialog box, browse to the ...\import 
folder in the practice files folder and open Civil 
surfaces.vsp3d.

The objects listed 
include surfaces, site/
grading objects, 
corridors, (surfaces, 
baselines, featurelines 
etc.),and point groups, 
etc.

4. In the Civil 3D Import Panel dialog box, a list of objects that 
are in the AutoCAD Civil 3D file are listed. In the left pane, 
select Surfaces [9] to display all of the surfaces in the right 
pane. Select Building Pad, hold <Shift>, and select Parking 
Lot Surface to highlight the first seven surfaces. Select the 
checkbox for Building Pad to select all seven highlighted 
surfaces, as shown in Figure 3–7. You can select them 
individually as well.

Figure 3–7
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5. You will select the corridor surfaces and the baseline. In the 
left pane, select Corridors [1] and in the right pane, click in 
the checkboxes for PrimaryAccess, Region(1), Region(2), 
and Region(3), as shown in Figure 3–8.

Figure 3–8

6. Click OK. In the Civil View Information, click Yes to accept 
the global shift values. 

7. Click Yes to proceed without a feature interpretation style.

It takes a few minutes to 
load the file.

8. The ground surfaces, building pad, corridor, and parking lot 

display in all of the viewports. If they are not, click (Zoom 
Extents All). In the Perspective viewport, note that only the 
corridor displays the right surface material but the rest of the 
surfaces display a checkerboard material.

Right-click on the title 
bar and select Dock> 
Left.

9. In the menu bar, select Civil View>Civil View>Civil View 
Explorer to open the Civil & View Explorer. Dock it along the 
left side of the screen.

Task 3 - Modify Material Assignment.

1. Verify that the Civil Explorer tab is selected. Expand Civil 
View Objects>Imported Objects, if not already expanded. 
Select Surfaces and note that the corridor is selected in the 
viewports. The Object List rollout opens with all of the 
surfaces listed, as shown in Figure 3–9.

Figure 3–9
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A material is not 
required for the first 
three corridor regions.

The complete list might 
not be visible in the 
Explorer. Hover the 
cursor in empty space in 
the information area 
until it displays as a Pan 
(hand) cursor. Slide up 
or down, using the hand 
cursor or the scroll 
button to display all of 
the information.

2. Scroll or pan down to display the rest of parameters, as 
shown in Figure 3–10.

3. In the Object List rollout, select C3Dsurface-C-TOPO-
Building Pad.

4. In the Surface Parameters rollout, select the Statistics tab 
and note that in the Face Selection Sets, in By Material ID, 
[31] Ground Type 4 has been assigned, as shown in 
Figure 3–11.

5. Right-click on [31] Ground Type 4 and select Modify 
Material ID Assignment, as shown in Figure 3–12.

Figure 3–12

6. Click Yes in the Warning dialog box.

Figure 3–10 Figure 3–11
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7. In the Modify material channel dialog box, select [22] 
Concrete Type 1 as shown in Figure 3–13. Click OK. 

Figure 3–13

8. In the Perspective viewport, use Zoom and Pan to zoom 
into the building pad. Note how the new material is applied. 

9. Select Surfaces again and in the Object List rollout, select 
C3Dsurface-C-TOPO-Existing Ground. In the Surface 
Parameters rollout, in the Statistics tab, right-click on [31] 
Ground Type 4, and select Modify Material ID Assignment. 
In the Warning dialog box, click Yes. 

10. In the Modify material channel dialog box, select [35] 
Ground Type 6 and click OK. In the Perspective viewport, 
note that the new ground type material is applied to the 
ground surface.

A material is not 
required for the first 
three corridor regions.

11. Similarly, for the other surfaces, apply the material types as 
follows:

• C3Dsurface-C-TOPO-Inside Curbing: 
[38] Concrete Type 3

• C3Dsurface-C-TOPO-Inside Grading: 
[35] Ground Type 6

• C3Dsurface-C-TOPO-Outside Curbing: 
[38] Concrete Type 3

• C3Dsurface-C-TOPO-Outside Grading: 
[35] Ground Type 6

• C3Dsurface-C-TOPO-Parking Lot Surface:
[39] Asphalt Type 4
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You might need to 
undock the explorer first 
to close it.

12.Close the Civil View Explorer.

13.Click  (Zoom Extents All). In the Perspective view, the 
scene displays as shown in Figure 3–14.

Figure 3–14

14.Save your work as MyCivil Base XRef.max.
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3.2 Linking Files
 File Linking is used to incorporate data from other Autodesk 
software such as Autodesk Revit and AutoCAD into the 
Autodesk 3ds Max scene. If the incorporated data is changed in 
the originating software, the file link enables you to update those 
changes in the 3ds Max scene. File linking is useful when you 
are working on a visualization project and know that all design 
decisions have not yet been made. You can link files using the 
Manage Links dialog box that can be opened as follows:

• File>Import>Link Revit: Links the .RVT files from the 
Autodesk Revit Architecture software.

• File>Import>Link FBX: Links the .FBX files that can be 
created in the Autodesk Revit, Autodesk MotionBuilder, 
Autodesk Maya, and Autodesk Mudbox software.

• File>Import>Link AutoCAD: Links the .DWG and .DXF files 
from the AutoCAD software.

• You can also open the Manage Links dialog box outside of 
the Link commands (File>Reference> Manage Links) and 
modify the Link settings.

Linking DWG
Files

In CAD data files it is common to have large numbers of objects. 
When linking or importing AutoCAD .DWG or .DXF files, it is 
efficient to combine multiple, related objects together into a 
single Autodesk 3ds Max object to control their display and 
visibility. 

• When multiple entities are combined into compound 
Autodesk 3ds Max shapes (2D objects) and meshes (3D 
objects), you can still access and adjust the original geometry 
using the Sub-object level modifiers, such as Edit Spline, 
Edit Mesh, and Edit Poly.

• Once multiple entities are combined, you can detach objects 
or portions of an objects to form new ones for individual 
editing control.
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Linking FBX
and RVT Files

The Autodesk Revit and Autodesk 3ds Max software share the 
Autodesk Material Library materials. 

• The .RVT and .FBX file format supports the import of 
photometric lights, both interior artificial lights and exterior 
daylight systems. 

• Detailed .RVT and .FBX file formats can become very large in 
size and importing them as single files cannot be 
accomplished. In such cases, use a section box in the 3D 
View in the Autodesk Revit software to limit the amount of the 
scene you are exporting.

Manage Links
Options

The Manage Links dialog box (shown in Figure 3–15) contains 
the following tabs:

Figure 3–15

Attach Tab

The options available in the Attach tab are described as follows:

• File... enables you to open a file (.DWG, .DXF, .FBX, or .RVT) 
for linking. The selected filename and its path display in the 
File drop-down list. If the file that you selected is a .RVT file 
with more than one camera view, you are prompted to select 
a camera view. 
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• The Preset drop-down list enables you to select the preset 
settings. The Presets listed here can be created or modified 
using the Presets tab. You can set the units by selecting them 
in the Incoming file units drop-down list. 

• Select Layers to include is only available with .DWG and 
.DXF file formats and enables you to select the layers that 
you want included with the drawing file. 

• Attach this file links the selected file with the specified 
preset settings to the current Autodesk 3ds Max scene.

Files Tab

The Files tab displays a list of files that are linked to the current 
scene with a specific status icon. 

• If the linked file has been modified,  displays with the linked 
filename. 

•  indicates that the linked file is unchanged and does not 
have any errors. 

• When a file is highlighted, the following options are available: 

Presets Tab

Many options are available before files are linked to your current 
scene. These options are configured and saved as Presets and 
can be used when linking files at a later stage. Many of these 
options require trial and error to find the most appropriate 
settings. You can link a file and then reload (or detach and relink) 
with different settings until you achieve the required results.

Reload... When the original file has been changed, it displays the 
changes in the current scene. 

Detach... Use when you want to remove the link with the original file. This 
option removes all geometry associated with the linked file. 

Bind... Removes the link with the original file, but the geometry stays in 
the current scene, although the link between the original file is 
broken. Changes made to the original linked file cannot be 
reloaded.
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If you are linking a file 
for the first time, it is 
recommended that you 
create a new preset.

The Presets tab lists all existing presets and contains options for 
creating new presets, modifying existing presets, copying 
existing ones, renaming and deleting them. You need to select a 
preset for the Modify, Copy, Rename, and Delete options to be 
available, as shown in Figure 3–16. If no preset is selected, 
Copy is replaced by New and is the only available option.

Figure 3–16

Depending on the type of preset selected (.RVT, .FBX, or 
.DWG), clicking Modify... opens a specific File Link Settings 
dialog box, which enables you to define the way you want the 
geometry to be linked, what portions of the file are to be modified 
on Reload, and how the geometry is combined.

File Link
Settings: DWG

Files

In the Manage Links dialog box, in the Presets tab, selecting an 
AutoCAD DWG file preset and clicking Modify... opens the File 
Link Settings: DWG Files dialog box, as shown in Figure 3–17.
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Figure 3–17

Basic Tab

The options available in the Basic tab are described as follows:

• Weld nearby vertices and Weld threshold: Welding joins 
together vertices of the same object that fall in the weld 
threshold. If the objects are joined by layer, this option 
removes duplicate vertices so that the adjacent 2D objects on 
the same layer are automatically combined into splines. 
Adjacent 3D objects that are welded become faces in a single 
mesh that share common vertices. 

You can adjust 
smoothing later if you 
still encounter 
smoothing issues after 
import.

• Auto-smooth adjacent face and Smooth-angle: 
Auto-smooth enables adjacent faces in the same 3D mesh to 
display smooth if the angles of separation between their face 
normals (a directional vector perpendicular to the face) is 
equal to or less than the Smooth-angle. Otherwise, the 
adjacent faces have a faceted edge between them. This is 
the same smoothing process used in the Edit Mesh and Edit 
Poly modifiers. 
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• Orient normals of adjacent faces consistently: This option 
coordinates the face normals of linked objects. This option 
should be left off by default unless some faces of your 3D 
objects are missing after the link.

• Cap closed splines: It assigns an Extrude modifier to all 
closed 2D geometry (e.g., circles and closed polylines).

• Texture mapping: Texture mapping is used to locate texture 
maps on objects. Two options are available:

• Curve steps: This setting defines the number of segments to 
subdivide each 2D curve segment into if they are later 
extruded in the Autodesk 3ds Max software. This setting 
applies to circles, arcs, polyline curves, spines, and similar 
curved objects.

This value can be set as 
low, (0.01).

• Maximum surface deviation for 3D solids: This setting 
defines the allowed deviation distance from a parametric 
AutoCAD 3D curve (such as a curved AutoCAD extrusion) 
and the resulting Autodesk 3ds Max mesh. The lower the 
value, the more a 3D curve is subdivided. In the Autodesk 
3ds Max software, all 3D curves must be segmented. 

• Include area options: These options enable you to select 
the type of objects to be brought into the scene. Note that the 
Lights option only brings in Lights from AutoCAD drawings 
pre-2007. If you have Sun and Sky checked, a daylight 
system is created based on the information in the incoming 
DWG file from the Autodesk Revit 2009 software.

Advanced Tab

The Advanced tab (shown in Figure 3–18) controls the import of 
AutoCAD primitives and the effect of scene materials while 
importing.

Generate 
coordinates 
on-demand

• Links objects without adding any texture mapping.

• Adds the mapping when it is first called for by the 
software.

• Enables a faster link but might cause some 
discrepancies.

Generate 
coordinates 
for all objects

• Adds texture mapping to all objects at the time of the 
link, matching any that might have existed in the 
original drawing file.
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Figure 3–18

The options available in the Advanced tab are described as 
follows:

• Derive AutoCAD Primitives by: Controls how AutoCAD 
objects are combined when linked. 

Layer Creates one object for each AutoCAD layer. Each 
AutoCAD block links as a single object called a 
VIZBlock.

Layer, Blocks 
as Node 
Hierarchy

This option preserves material assignments in linked 
AutoCAD blocks. It structures each as a hierarchy of 
objects rather than single objects.

Layer, Blocks 
as Node 
Hierarchy, 
Split by 
Material

This option works similarly to the one above but takes 
into account drawings that have more than one material 
applied to objects on the same layer. Separate 
hierarchies are created for each material type on each 
layer.

Entity, Blocks 
as Node 
Hierarchy

This option includes all non-blocks as separate, 
individual objects. Blocks are preserved as hierarchies, 
however, organized by layer.

Color Combines AutoCAD objects by color. All objects of one 
color are joined in as a single object, regardless of layer.
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• Create helper at drawing origin: Adds an origin point helper 
at the origin of the current coordinate system. All of the linked 
geometry is part of a hierarchy parented by this helper, so all 
of the linked objects can be repositioned as one by 
transforming the helper.

• Use Extrude modifier to represent thickness: When 
disabled, linking 2D AutoCAD objects with a non-zero 
thickness value translates the objects into the Autodesk 3ds 
Max software as a 3D mesh. When enabled, objects translate 
as 2D objects with a parametric extrude modifier. The 
resulting geometry is the same but when this option is 
enabled, the extrusion properties (such as height) can be 
modified after the link or imported using the modifier stack.

• Create one scene object for each AutoCAD Architecture 
one: When unchecked, AutoCAD Architecture and AutoCAD 
MEP objects are subdivided into separate objects by 
material. 

• Use scene material definitions: When unchecked, the 
Autodesk 3ds Max software includes the current state of any 
material applied to the linked objects in the AutoCAD 
software. If selected and the current scene has a material 
with the same exact name as the AutoCAD material, the 
scene material is used instead.

• Use scene material assignments on Reload: When 
unchecked, the Autodesk 3ds Max software re-loads the 
current state of any AutoCAD materials present in the 
drawing file when the link is updated. When enabled, the 
Autodesk 3ds Max software maintains the current state of 
any materials in the scene file after a link is updated. Select 
this option if you intend to adjust linked materials in the 
Autodesk 3ds Max software or leave it unchecked if you 
intend to adjust them the AutoCAD software.

• Selective Reload: Enables you to reload a subset of the 
original file. You can select objects to reload by selecting 
them in the scene or by selecting them from a list. If you 
select Selected in List, and click Linked Objects a list 
opens.

Entity Does not combine AutoCAD objects at all. Instead, each 
AutoCAD object becomes an individual object.

One Object This option combines all AutoCAD objects into a single 
object. 
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Spline Rendering Tab

The options available in the Spline Rendering tab (shown in 
Figure 3–19) enable linear objects (2D and 3D lines, polylines, 
etc.) to display as extruded 3D objects in the viewports or 
rendering. Normally, splines cannot be rendered because they 
do not have surface area to interact with scene lighting. These 
options enable splines to link into the Autodesk 3ds Max 
software as 3D linear objects with a cross-sectional radius or a 
rectangular length and width. This provides the surface area for 
rendering.

Figure 3–19

Hint: Hierarchies and File Linking

Autodesk 3ds Max Hierarchies are collections of objects linked 
together into parent/child relationships where transform applied 
to a parent are automatically passed on to its children. 
Connecting multiple objects in a hierarchical chain can enable 
sophisticated animations in the Autodesk 3ds Max software, 
such as the motion of jointed robotic arms.

In the case of the hierarchy file link options, incoming 
AutoCAD blocks are brought into the Autodesk 3ds Max 
software as multiple objects so that they can maintain multiple 
material assignments from the AutoCAD software. The parent 
object itself does not have any geometry and does not render. 
Most modifiers (such as Substitute) must be applied to the 
objects in the hierarchy rather than the parent.
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• If splines are to be rendered with materials then options such 
as smoothing, mapping coordinates, and/or real-world map 
size are often important.

• When enabled, all of the splines linked with this setting are 
renderable, and all have the same cross-section geometry.

• To make only certain 2D objects renderable (or want some to 
render differently than others) you could apply a Renderable 
Spline modifier directly to those objects after linking. 

File Link
Settings: Revit

Files (RVT or
FBX)

In the Manage Links dialog box, in the Presets tab, selecting an 
Autodesk Revit file and clicking Modify... opens the File Link 
Settings: Revit Files (RVT or FBX) dialog box, as shown in 
Figure 3–20. Additionally, you can also select the Autodesk FBX 
(Generic) file preset and click Modify....This opens the File Link 
Settings: FBX Files dialog box, as shown in Figure 3–21. This 
dialog box is similar to the Autodesk Revit Files (.RVT and .FBX) 
but without a Geometry area for controlling the segments and 
smoothing the linked geometry.

Figure 3–20 Figure 3–21
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The options available in the File Link Settings: Revit Files (RVT 
or FBX) dialog box are described as follows:

It is recommended that 
you combine entities to 
reduce the number of 
objects.

• Combine Entities list: Enables you to select the Autodesk 
Revit entities that you want to combine, as shown in 
Figure 3–22. For example, if you select By Revit Material, all 
of the entities that have the same material are linked in the 
current Autodesk 3ds Max scene as a single object. 

Figure 3–22

• Objects area: The selected options in this area are linked 
from the .RVT file to your current scene. If the .RVT file or 
.FBX file contains photometric lights, interior artificial lights, 
cameras, and exterior daylight systems, you can select the 
associated options in the File Link Settings dialog box. 

• Geometry area: Enables you to set the number of segments 
for your curved entities and apply auto-smoothing to them.

• Materials area: Enables you to control the material 
definitions and assignment settings.
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Practice 3b Linking an AutoCAD DWG

In this practice, you will link AutoCAD geometry to represent the 
parking lot details, such as pavement markings and other details. 
You will reposition this file using the Helper object, and will create 
3D markings by projecting 2D lines to the elevation of a terrain 
model.

You must set the paths to locate the External files and Xrefs 
used in the practice. If you have not done this already, return to 
Chapter 1 and complete Task 1 to Task 3 in Practice 1a: 
Organizing Folders and Working with the Interface. You only 
have to set the user paths once.

Task 1 - Link an AutoCAD .DWG File.

If a dialog box opens 
prompting you about a 
File Load: Mismatch, 
click OK to accept the 
default values.

1. Open Civil Base.max from the ...\scenes folder.

2. Select File>Import>Link AutoCAD. In the Open dialog box, 
browse and open the ...\import folder in the practice files 
folder. Select 3D Parking Lot Detail-Civil.dwg and click 
Open. The Manage Links dialog box displaying the partial 
path, as shown in Figure 3–23.

Figure 3–23

Practice Objectives

• Create a preset to link an AutoCAD .DWG file and reposition it.

• Revise the link settings and reload the linked file.
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At the time of the 
printing of this guide, the 
full path of the linked file 
is required to display 
such that the software 
finds the file in the 
Manage Links dialog 
box.

3. To display the full path, click on File to reopen the Open 
dialog box, select C:\Autodesk 3ds Max Fundamentals 
Practice Files\Import from the History drop-down list and 
select the 3D Parking Lot Detail.dwg again. Click Open 
again. The complete path should display as shown in 
Figure 3–24.

Figure 3–24

If no preset is selected, 
only New... is available.

4. Select the Presets tab and click New... to create a new link 
preset.

5. In the New Settings Preset dialog box, set New Name as 
AutoCAD – Derive by Layer. Note that the Format is 
selected as AutoCAD Drawings. Click OK. 

6. In the Manage Links dialog box, select the new AutoCAD – 
Derive by Layer preset, as shown in Figure 3–25. Click 
Modify....

 
Figure 3–25



Autodesk 3ds Max 2019: Fundamentals

3–26 © 2018, ASCENT - Center for Technical Knowledge®

The Create Helper at 
drawing origin option 
adds a helper object at 
the origin of the linked 
file.

7. In the File Link Settings: DWG Files dialog box, in the Basic 
tab, set the link options, as shown in Figure 3–26. Select the 
Advanced tab and select Create helper at drawing origin, 
as shown in Figure 3–27. Leave all other options as defaults 
(clear).

Figure 3–26 Figure 3–27
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8. Select the Spline Rendering tab and verify that the link 
options are set to the defaults, as shown in Figure 3–28. 

Figure 3–28

9. Click Save.

10. In the Manage Links dialog box, select the Attach tab. Set 
Preset to AutoCAD – Derive by Layer, as shown in 
Figure 3–29. Click Select Layers to include....

Figure 3–29
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11. In the Select Layers dialog box, select Select from list. Clear 
0 and DEFPOINTS and leave all other layers as selected, as 
shown in Figure 3–30. Click OK.

Figure 3–30

12. In the Manage Links dialog box, click Attach this file. Close 
the Manage Links dialog box. Note that the parking lot details 
have been added to the scene, but are located far away from 
the origin, as shown in the Top viewport in Figure 3–31. 

Figure 3–31
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Task 2 - Relocate the Linked Geometry.

You might need to start 
Civil View, if it is not set 
to start automatically.

1. You need to move the parking lot details by the global shift 
values in Civil View. In the menu bar, select Civil View>Civil 
View>Civil View Explorer.

2. In the Civil View Explorer, select Scene Settings, as shown 
in Figure 3–32. In the Scene Settings rollout, note the Global 
Import Shift values for X Shift and Y Shift (-9901), as shown 
in Figure 3–33. Close the Civil View Explorer.

3. In the Main Toolbar, click  (Select and Move).

If the Scene Explorer is 
not displayed, select 
Tools>Scene Explorer 
and then dock it.

4. In the Scene Explorer, click (  (Display None) and 

(Display Helpers)), and then select the helper object 
3D Parking Lot Detail - Civil.dwg, as shown in Figure 3–34. 
Note that the User Coordinate System icon located at the 
origin is selected, as shown in Figure 3–35.

Figure 3–32 Figure 3–33

Figure 3–34 Figure 3–35
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Ensure that the feet 
symbol is added with 
the values.

5. In the Status Bar, ensure that  (Absolute Mode 
Transform) displays. Set the following, as shown in 
Figure 3–36:

• X edit box: -9901’0"

• Y edit box: -9901’0"

Figure 3–36

6. Press <Enter>.

7. Click  (Zoom Extents All). Note how the parking lot details 
are placed exactly on the parking lot surface.

In the Main toolbar, use 

 (Select Object) to 
exit any command.

8. In the Perspective viewport, use  (Orbit) to tilt the view to 
display the area below the surfaces, similar to that shown in 
Figure 3–37. Use Zoom to zoom into the area. Note that in 
addition to the 3D pavement markings, 2D line markings are 
imported through the link.

Figure 3–37
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Task 3 - Revise the Link Settings.

In the Files tab, if the 
linked file has been 

modified,  displays. 

You can use:
Reload... to update the 
file in the scene. 
Detach... to remove a 
linked drawing from the 
scene. 
Bind... to insert the 
drawing as is and 
removes the 
connection.

1. Click File>Reference>Manage Links to open the Manage 
Links dialog box.

2. In the Manage Links dialog box, select the Files tab and note 

that the linked file displays , indicating that the file has not 
changed. Although the linked file has not changed, you can 
use Reload... to revise the link settings. Verify that Show 
Reload options is selected and click Reload....

3. The File Link Settings: DWG Files dialog box opens. In the 
Advanced tab, click Select Layers to include.... Clear the 
2D layers (C-MARK-WHITE-2D and C-MARK-YELLOW- 
2D), and the two LIGHTPOLE layers, as shown in 
Figure 3–38.

Figure 3–38

The 2D linework should 
no longer display, 
keeping the scene 
smaller. 

4. Click OK twice to close both dialog boxes. Click to close 
the Manage Links dialog box. In the Perspective viewport, 
note that the 2D line markings do not display any longer.

5. Save your work as MyCivil Base.max.
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Practice 3c Linking and Reloading Autodesk 
Revit File

In this practice, you will link a .RVT file into a 3ds Max scene. 
You will reposition the Revit file using the Helper object. You will 
then reload a modified version of the .RVT linked file to 
incorporate the changes made to the original Autodesk Revit file 
using Reload. 

You must set the paths to locate the External files and Xrefs 
used in the practice. If you have not done this already, return to 
Chapter 1 and complete Task 1 to Task 3 in Practice 1a: 
Organizing Folders and Working with the Interface. You only 
have to set the user paths once.

Task 1 - Link an Autodesk Revit (.RVT) file.

If a dialog box opens 
prompting you about a 
File Load: Mismatch, 
click OK to accept the 
default values.

1. Open Civil Base Link.max from the ...\scenes folder. The file 
contains the ground surfaces, building pad, and parking lot 
details.

2. Select File>Import>Link Revit.

3. In the Open dialog box, in the ...\import folder, select Revit 
Building-1.rvt and click Open. 

It might take a few 
minutes to load the file. 

4. The Status Bar is replaced by the Loading file bar, indicating 
the progress of the file as it loads. Once loaded, the Select 
Revit View dialog box opens, as shown in Figure 3–39. 

Figure 3–39

5. Select Front Exterior 3D View and click OK.

Practice Objectives

• Link and reposition an Autodesk Revit file to the current scene.

• Reload a modified .RVT file.
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6. In the Manage Links dialog box, select the Presets tab. Click 
New... to create a new preset. In the New Settings Preset 
dialog box, set the following:

• New Name: Revit Preset 

• Format: Select Autodesk Revit (*.rvt,*.fbx)

7. Click OK.

8. In the Manage Links dialog box, select Revit Preset and click 
Modify.

The Create Helper at 
Model Origin option 
adds a helper object at 
the origin of the linked 
file. Selecting and 
applying transforms 
(move, rotate, or scale) 
to the helper object 
applies the transform to 
the linked geometry 
together.

9. In the File Link Settings dialog box, do the following, as 
shown in Figure 3–40: 

• In the Combine Entities drop-down list, select By Revit 
Category. 

• In the Objects area, clear the Lights and Daylight 
System options.

• In the Objects area, select Create Helper at Model 
Origin and Cameras. 

• In the Geometry area, set Curved Objects Detail to 6.

• In the Materials area, verify that Keep 3ds Max scene 
materials parameters on reload and Keep 3ds Max 
scene material assignments on reload are cleared.

Figure 3–40
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10.Click Save.

11. Select the Attach tab. Expand the Preset drop-down list and 
select Revit Preset.

It might take a few 
minutes to load the file. 

12.Click Attach this file. Note that the Autodesk Revit building 
and camera are loaded at the 0,0,0 location in the viewports.

13.Click to close the Manage Links dialog box.

If the Scene Explorer is 
not displayed, select 
Tools>Scene Explorer 
and then dock it.

14. In the Scene Explorer, click  (Display None) and 

(Display Helpers), if required, and then select the helper 
object Revit Building-1.rvt, as shown in Figure 3–41.

Figure 3–41

15.Right-click on the Top viewport to make it active and to 

maintain the selection. In the Main Toolbar, click  (Select 
and Move). The Transform gizmo displays at the helper 
location, which is the origin of the linked Autodesk Revit file.

The position of the 
building pad from the 
origin has been 
calculated.

16. In the Status Bar, verify that  (Absolute Mode Transform) 
displays. Set the following, as shown in Figure 3–42:

• X edit box: 800’0"

• Y edit box: 382’0"

• Z edit box: 154’6"

Figure 3–42

17.Press <Enter>.
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18.Click  (Zoom Extents All). Note how the building is placed 
on the building pad.

Grid has been hidden 
for clarity. Press <G>.

In the Main toolbar, use 

 (Select Object) to 
exit any command.

19. In the Front viewport, use  (Zoom Region) and create a 
rectangular window around the building to zoom into the 
building. Verify that the Standard shading label displays. 
Select the [Wireframe] Per View label and select Default 
Shading. Then, select Default Shading again and select 
Edged Faces to define the windows and doors. The building 
should display similar to that shown in Figure 3–43.

Figure 3–43

20. In the Left viewport, select the [Wireframe] Per View label 
and select Default Shading and then Edged Faces. 

21.Select the [Left] Point of View label, and select 
Cameras>Views: Front Exterior 3D View, as shown in 
Figure 3–44. 

Figure 3–44
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22.Use  (Orbit Camera) and  (Field-of-View) to display 
the complete building in the Left viewport, similar to that as 
shown in Figure 3–45.

23. In the Perspective viewport, use  (Zoom),  (Orbit) 
and Pan to zoom into the building and parking lot area so that 
the display is similar to that shown in Figure 3–45.

Figure 3–45

Task 2 - Reload the variation of the .RVT file.

A variation to the .RVT linked file (windows have been added) 
has been included in the ...\import folder.

1. In Windows Explorer, open the ...\import folder in the practice 
files folder.

2. Right-click on Revit Building-1.rvt and select Rename. 
Rename the file as Revit Building-1_ORIGINAL.rvt.

3. Right-click on Revit Building-2.rvt, and select Copy. Paste a 
copy of this file into the same directory. Right-click on the 
copied file, select Rename, and rename the file as Revit 
Building-1.rvt. This must be the same name as the original 
file that was linked to indicate that the original linked file has 
changed.

4. Return to the Autodesk 3ds Max software. Select 
File>Reference>Manage Links to open the Manage Links 
dialog box.

5. In the Manage Links dialog box, select the Files tab. Note 

that  displays in front of the .RVT filename (as shown in 
Figure 3–46), indicating that changes have been made to the 
original linked file.
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Figure 3–46

6. Select Revit Building -1.rvt (if not already selected) and 
click Reload.... The Loading file bar displays the progress. 

7. In the File Link Settings dialog box that opens, in the 
Materials area, select Keep 3ds Max scene material 
assignments on reload. Click OK. The scene is refreshed 
with the new changes. 

8. In the Manage Links dialog box, in the Files tab, the icon has 

changed to , as shown in Figure 3–47. This indicates that 
there are no differences between the original file and the 
linked file.

Figure 3–47

9. Close the Manage Links dialog box.

10. In the viewports, the modified building displays. More 
windows are added to the building, as shown in Figure 3–48.

Figure 3–48

11. Save the file as MyCivil Base Link.max.
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3.3 References

External
References

(XRef)

Autodesk 3ds Max Scene files can reference data from other 
.MAX scene files by expanding File> Reference>XRef Objects 
or XRef Scene. The XREF data remains linked to the source 
(.MAX) scene file so that changes in the source file can be 
reflected in any scene that contains the XREF. 

• External References are useful to break up large projects into 
more manageable pieces, permit more than one person to 
work on the same project at the same time in separate files, 
and to enable the same core scene geometry to be used in 
multiple files.

• XRef Scenes bring in the entire scene. All of the XREF 
objects are non-selectable and cannot be modified.

• XRef Objects enable you to select individual objects (or all) 
from an XREF scene. These objects remain selectable and 
modifiable in the XREF scene file.

• You can snap to XREF and use XREF objects with AutoGrid. 
You can also use XREF objects as alignment targets and you 
can select an XREF object’s coordinate system for object 
transformation. XREF support parameter wiring and you can 
XREF the controllers.

• Objects in scenes (.MAX) are imported into other . MAX 
scenes using the Merge option.

Data
Management

and Asset
Tracking 

The Autodesk 3ds Max software enables you to manage your 
data through Data Management (DM) solutions, referred to as 
Asset Tracking Systems (ATSs).

• DM solutions such as the Autodesk® Vault software enables 
you to store scene files and any supporting data (such as 
material maps) in a single database repository.

• These systems can be accessed simultaneously by multiple 
users with different rights assigned based on their project 
responsibilities. Data can be checked out for editing by one 
individual at a time while still being referenced by other users. 
Users can see who is editing which portion of the project at 
any time.
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• By centralizing the files in a DM system it is much easier to 
adjust paths for external files such as image maps.

• Data files can be versioned through DM solutions, so that the 
older versions can be readily accessed, if required.

• For more information see Asset Tracking in the Autodesk 3ds 
Max Help files. Asset Tracking is available through the 
File>Reference> Asset Tracking Toggle.
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Practice 3d XRef and Merge Objects

In this practice, create a new scene file that will contain linked 
AutoCAD objects and XRef objects from the Civil Base scene. 
You will then merge objects into the current scene file.

You must set the paths to locate the External files and Xrefs 
used in the practice. If you have not done this already, return to 
Chapter 1 and complete Task 1 to Task 3 in Practice 1a: 
Organizing Folders and Working with the Interface. You only 
have to set the user paths once.

Task 1 - Assemble the Data.

If an unsaved scene is 
open, you need to save 
or discard the changes 
to the scene.

1. Click File>Reset and click Yes to reset the scene.

2. For this scene, set the System Unit Scale to Inches. Select 
Customize>Units Setup. In the dialog box, verify that the 
following is set:

• Display Unit Scale: US Standard, Feet w/ Fractional 
Inches

• Default Units: Inches

• Lighting Units: American 

3. Click System Unit Setup. In the System Unit Setup dialog 
box, set System Unit Scale to Inches. Click OK in both the 
dialog boxes.

4. Expand File>Reference and select Manage Links. 

The AutoCAD – Derive 
by Layer preset was 
created in the Practice: 
Linking an AutoCAD 
DWG. Complete the 
above mentioned 
practice to create the 
preset if not already 
done so.

5. In the Manage Links dialog box, in the Attach tab, click File.... 
In the ...\import folder, select Exterior AutoCAD 
Architectural Model.dwg. Click Open.

6. In the Preset drop-down list, select AutoCAD – Derive by 
Layer and click Attach this file. Once the file has been 
loaded, close the Manage Links dialog box.

• The AutoCAD objects were not joined together by layer. 
Each was subdivided by material type into different 
objects. Materials previously assigned in AutoCAD were 
preserved on these separate objects.

Practice Objective

• Link an AutoCAD .DWG file and incorporate objects from another scene 
file into the current scene.
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7. Click  (Zoom Extents All) to display all of the objects in all 
of the viewports.

8. In the Front viewport, select all of the objects by creating a 
window around the objects. In the Main Toolbar, in the 
Named Selection Sets field, enter exterior AutoCAD 
Architectural building, as shown in Figure 3–49. Press 
<Enter>.

Figure 3–49

You select objects to 
XREF rather than the 
entire scene because 
XREF scene objects 
cannot be individually 
selected or modified.

9. Click File>Reference>XRef Objects. In the XRef Objects 

dialog box, click  (Create XRef Record from File) as 
shown in Figure 3–50.

Figure 3–50

10. In the Open File dialog box, select Parking Lot Detail.max 
(from the ...\import folder) and click Open.

11. If the Units Mismatch dialog box opens, click OK. This 
rescales the XRef objects to the system units.

12.The Duplicate Material Name dialog box opens prompting 
you that there is an incoming material with the same name as 
an existing scene material. Select Apply to All Duplicates to 
keep both materials, as shown in Figure 3–51. Click 
Auto-Rename Merged Material.

Figure 3–51
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13. In the XRef Objects dialog box, note that the .MAX filename 

displays. Click to close the dialog box.

14.Click  (Zoom Extents All). Note that the Civil Base objects 
are located far from the origin. This is a coordinate system 
discrepancy and not a scale issue. The AutoCAD drawing is 
based in a different coordinate system and scale than the 
accompanying Civil drawing. 

Task 2 - Coordinate the Data.

In this task you will relocate the Civil Base in the Architectural 
Data. To line up the data accurately you will need the exact 
coordinate translation and rotation. You can measure ahead of 
time in programs, such as AutoCAD by comparing the 
coordinates of points common to both files.

1. Verify that no object is selected. In the Scene Explorer, click 

 (Display None) and  (Display Object XRefs). Select all 
of the XRef objects in the list (use <Shift> and then select the 
first and last).

2. With these XRef objects selected, select Group>Group from 
the menu bar.

3. In the Group dialog box, set the Group name to Site XRef 
and click OK.

4. In the Main Toolbar, click  (Select and Move). In the 
Reference Coordinate System, select World, as shown in 

Figure 3–52. Click  (Use Transform Coordinate Center).

Figure 3–52
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The translation 
coordinates have 
already been measured 
in AutoCAD.

5. In the Status Bar, verify that  (Absolute Mode) displays. In 
the Transform Type-in area, set the following, as shown in 
Figure 3–53:

• X: -197’4”

• Y: -30’0”

• Z: -4’11”

Figure 3–53

6. Press <Enter>.

7. In the Main Toolbar, click  (Select Object) to exit the 
Move transform operation.

8. Click  (Zoom Extents All). 

9. In the Perspective viewport, use  (Orbit Point of Interest) 
and click to place a point on the building and then orbit 
around that point. Using Pan and Zoom, zoom into the 
parking lot and building area (as shown in Figure 3–54), and 
verify that the building is located on the building pad. 
Although the XREF had a different Unit Scale (feet), it scaled 
correctly to the active scene (in inches).

Figure 3–54

10.Save your work as MyArchitectural Scene.max.
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Task 3 - Merging Objects.

1. Select File>Import>Merge. In the Merge File dialog box, 
select Light Poles for Project1.max from the ...\scenes 
folder. Click Open. 

2. In the Merge dialog box, click All, as shown in Figure 3–55. 
Click OK.

Figure 3–55

Merge enables both 
objects to have the 
same name, Skip 
ignores the incoming 
object, and Delete Old 
removes the original 
object.

3. The Duplicate Name dialog box opens, prompting you that an 
object with the same name already exists in the scene. Select 
Apply to all Duplicates and click Auto-Rename. 
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4. The light poles display in the scene, as shown in Figure 3–56.

Figure 3–56

5. Save your work.
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Chapter Review Questions

1. The following file formats can be linked to the current 
Autodesk 3ds Max scene:

a. .DWG, .OBJ, .APF, .FBX

b. .DWG, .DXF, .FBX, .RVT

c. .DWG, .DXF, .OBJ, .RVT

d. .DWG, .OBJ, .FBX, .RVT

2. In the Manage Links dialog box, in the Files tab, which of the 
following options do you use to remove the link with the 
original linked file but maintain its geometry in the current 
scene?

a. .Reload...

b. .Detach... 

c. .Bind...

3. Which command do you use to combine objects from a saved 
Autodesk 3ds Max scene (.MAX file) into your current .MAX 
scene?

a. .Import

b. .Link

c. .Open

d. .Merge

4. While linking Autodesk Revit files in the current Autodesk 3ds 
Max scene, which of the following options are provided in the 
Combine Entities List? (Select all that apply.)

a. By Revit Material

b. By Revit Layer

c. As One Object

d. By Revit Camera

5. When an entire .MAX scene is brought into the current scene 
using XREF Scenes, the XREF objects are selectable but 
cannot be modified.

a. True

b. False
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Command Summary

Button Command Location
Absolute 
Mode

• Status Bar

N/A Civil View • Menu Bar: Civil View

N/A Asset 
Tracking

• Menu Bar: File>Reference

N/A Import • Menu Bar: File>Import

N/A Link AutoCAD • Menu Bar: File>Import

N/A Link FBX • Menu Bar: File>Import

N/A Link Revit • Menu Bar: File>Import

N/A Manage Links • Menu Bar: File>Reference

N/A Merge • Menu Bar: File>Import

Select by 
Name

• Main Toolbar

Select Object • Main Toolbar

Use 
Transform 
Coordinate 
Center

• Main Toolbar

N/A XRef Objects • Menu Bar: File>Reference

N/A XRef Scene • Menu Bar: File>Reference
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