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Structural Framing

The skeleton of a building is its structural framing. Together, elements such as
columns, beams, bracing, and trusses give buildings the stability they need. While
the basic process of adding these elements to the project is simple, you also need
to complete more complex tasks, such as manipulating connections (by setting
bearing offsets, cantilevers, cut backs, and justifications), applying beam coping,
and editing beam joins.

Learning Objectives in this Chapter

Sketch individual beams for girders connecting columns and structural walls.

Create Beam Systems of multiple similar sized beams spaced at equal intervals to speed up
adding joists.

Add Bracing to support the integrity of other framing members.
Make changes to framing members so that the connections fit the exact situation.
Add trusses to support long spans of open space.
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7.1 Modeling Structural Framing

The Autodesk® Revit® software enables you to frame a building
with wood, concrete, and steel framing and bracing, such as the
steel example shown in Figure 7—1. You can add individual
beams, as well as beam systems and bracing elements.
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Figure 7-1

Framing types include: Concrete, Light Gauge Steel,
Precast Concrete, Steel, and Wood.

In views set to a Coarse detail level, the software assigns a
lineweight to the structural members based on their structural
usage. For example, a Girder displays in a heavier lineweight
than a Joist, while a Purlin displays with a dashed line. as
shown in Figure 7-2.
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Figure 7-2
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How To: Add Beams

1. In the Structure tab>Structure panel, click 7 (Beam).

2. In the Type Selector, select a beam type.

3. In the Options Bar, specify the options, as shown in
Figure 7-3 and described below.

Properties x

Meodify | Place Beam Placement Plane: Level : Level 2

- ‘ Structural Usage:[t:ﬁ.utomaﬁc:- v] | [713D Snapping | [] Chain

Mew Structural Framing (<Automatic > v] Edit Type

Constraints 2 oa

Reference Level i E
Geometric Position A

Start Extension o o"

End Extension oo

\ W Shapes =
W12X26

<Automatic>
Girder

Horizontal Bracini

Other
Purlin

Figure 7-3

» Placement Plane: Defaults to the current level if you are in
a plan view but can be modified to other levels.

» Structural Usage: Select a type (as shown in Figure 7-3),
or accept the default of <Automatic>.

+ 3D Snapping: Select this if you want to draw a beam
from one point to another at different heights.

* Chain: Select this if you want to draw a series of beams in
a row. To stay in the command and start another chain,
press <Esc> once.

4. For automatic tagging, in the Modify | Place Beam tab>Tag

panel, click [ (Tag on Placement).
5. In the Modify | Place Beam tab>Draw panel, use the Draw
tools to draw the beams.

How To: Add Multiple Beams on Grid Lines

1. Start the Beam command and specify the type and other
options, as outlined above.

ol
2. In the Modify | Place Beam tab>Multiple panel, click Oﬁ (On
Grids).

© 2019, ASCENT - Center for Technical Knowledge®

7-3



Autodesk Revit 2020 Structure Fundamentals

Columns must be in
place to support the
beams for this to work.

Beam Systems

3. Select the grids where you want to locate the beams. A beam
is placed between each grid intersection, as shown in
Figure 7—4. Hold <Ctrl> to select more than one grid, or use a
pick and drag window to select multiple grids at one time.
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Figure 7-4
4. Inthe Modify | Place Beam>0On Grid Line tab>Multiple panel,

click v (Finish).

« Sometimes this can be the quickest way to add beams. If you
need to use various sizes of beams, when you are finished,
select those beams and make any changes in the Type
Selector.

Beam Systems are layouts of parallel beams placed between
other beams, as shown in Figure 7-5. Typically used in joist
layouts, beam systems can be set up to use either a fixed
distance or number of beams.

+ Beam systems can be created automatically with sufficient
bounding elements (other beams). You can also sketch the
boundary for a beam system.

| . : : ;

- ——
- | ©
Ot ©
Structural Beam Systerns : Structural Beam Systemn :
— Structural Framing System

Figure 7-5
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How To: Add Automatic Beam Systems

1. In the Structure tab>Structure panel, click il (Beam
System) or type BS.
2. The Modify | Place Structural Beam System tab>Beam

System panel, click [ (Automatic Beam System).

3. When [ (Tag on Placement) is selected, in the Options
Bar, set the Tag Style as shown in Figure 7—6.

* Framing: Tags each individual member.
« System: Places one tag for the entire framing system.

Tag Style: Framing - Tag Style: System -
| 1 1
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W 2X26 .
YAZHZE ‘g‘
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W 2K25
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] L I
Figure 7-6

4. Inthe Options Bar (shown in Figure 7-7), set the Beam Type,
Justification, and Layout Rule.

Beam Type: W12X26 »  Justification: Center »  Layout Rule: Fixed Distance = &' 0"
Figure 7-7

» The Layout Rules include: Clear Spacing, Fixed
Distance, Fixed Number, and Maximum Spacing. Set
the required distance or number.

» Make changes in Properties or in the Options Bar as
required to establish the required beam system.

© 2019, ASCENT - Center for Technical Knowledge® 7-5
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5. Move the cursor over an existing beam until the guide lines

display in the correct area and direction, as shown vertically
and horizontally in Figure 7-8. This can also identify angled
lines.

= =

Figure 7-8

. Select the existing beam to place the system.
. Repeat this step in other bays as required.

The Beam System is one uniform group. You can change
beam’s type, spacing, and elevation in Properties or in the
Options Bar.

If a grid line is moved, the beams automatically space
themselves. If the bay increases beyond the minimum
spacing, a beam is added. If the bay shrinks below the
allowable spacing, a beam is removed.

If you need to change the system to individual beams, in the
Modify | Structural Beam Systems tab>Beam System panel,

click Ha (Remove Beam System). The individual beams
remain but are no longer grouped together.

7-6
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How To: Sketch a Beam System

1. In the Structure tab>Structure panel, click il (Beam
System).
2. In the Modify | Place Structural Beam System tab>Beam

System panel, click il (Sketch Beam System).
3. In the Modify | Create Beam System Boundary tab>Draw

panel, click E (Pick Supports) or use one of the other
drawing tools.

4. In the Draw panel, click IM” (Beam Direction) and select one
of the sketch lines that runs as you want the system to run, as
shown on the top horizontal beam in Figure 7-9.

Figure 7-9

5. Clean up all of the corners so that there are no overlaps or

gaps.
6. Inthe Modify | Create Beam System Boundary tab>Mode

panel, click v (Finish Edit Mode).
7. Make changes in Properties or in the Options Bar as required
to establish the required beam system.

* To include an opening in a beam system, draw another
opening inside the original sketched boundary.

© 2019, ASCENT - Center for Technical Knowledge® -7
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Adding Bracing

Braces automatically attach to other structural elements, such as
beams, columns, and walls. They recognize typical snap points
such as the end point of a column and the middle of a beam, as
shown in Figure 7-10.

1

Figure 7-10

Bracing can be added in plan view or, more typically, in a
framing elevation view.

How To: Add Bracing

1.

BN

Create and open a framing elevation.

In the Structure tab>Structure panel, click 2 (Brace).
In the Type Selector, select a brace type.
Pick two points for the end points of the brace.

»  Work from the centerline of all of framing members so that
the analytical line extends into the adjacent framing, even
though the graphical member stops at the edge of the
column or beam, as shown in Figure 7-11.

v

Figure 7-11

7-8
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Cross Bracing
Settings

In plan view, cross bracing needs to be displayed graphically,
usually by hidden lines. The software has a separate setting that
controls cross bracing as viewed in plan. These settings enable
you to display bracing above, below, or both. The bracing can be
displayed as parallel lines or as a line at an angle, as shown in
Figure 7-12.

Parallel

- s
L o o ¢

Line with angle
Figure 7-12

* In the Manage tab>Settings panel, expand (Structural

Settings) and click (Structural Settings). In the Structural
Settings dialog box, in the Symbolic Representation Settings
tab, select the Brace Symbol options, as shown in

Figure 7-13.

Brace Symbols

Plan representation:

[Parallel Line -

Parallel line offset:

332"

Show brace above
Symbal;

[Cnnnecﬁnn—BracE—ParallEl - ]

Show brace below
Symbal;

[Cnnnecﬁnn—BracE—ParallEl - ]

Kicker brace symbal;

[Cnnnecﬁnn—BracE—iGdcer - ]

Figure 7-13
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Hint: Copying Elements to Multiple Levels

Instead of drawing the same elements on each level, you can
copy them to the clipboard and then paste them aligned to the
other levels.

1. Select the required elements.
2. In the Modify <contextual> tab>Clipboard panel, click

rl_—hl (Copy to Clipboard).

3. In the Modify tab>Clipboard panel, expand @ (Paste) and

click (Aligned to Selected Levels).
4. In the Select Levels dialog box, as shown in Figure 7—-14,
select the levels to which you want to copy the beams.

Select Levels X

00 GROUND FLOOR.
T.0. FOOTING
5-15T FLOOR.

D FLOOR
TOS5-4TH FLOOR.
TOS5-5TH FLOOR
TO5-6TH FLOOR
TO5-7TH FLOOR
TO5-8TH FLOOR.
TO5-9TH FLOOR.
TO5-10TH FLOOR
TO5-11TH FLOOR
TO5-12TH FLOOR
TO5-13TH FLOOR
TO5-14 ROOF

cance

Figure 7-14

5. Click OK.

* This command is for copying model elements only. If you
want to include tags or other annotation, use
Paste>Aligned to Selected Views.
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Practice 7a Model Structural Framing

Practice Objectives

Place beams and beam systems.
« Copy framing to additional levels.
» Create a framing elevation.
* Add bracing

In this practice, you will add framing for one floor of a building (as
shown in Figure 7-15), and then copy and paste the framing to
the levels above. You will then add bracing to one part of the
structure.

Figure 7-15
» This graphic is modified for clarity.

Task 1 - Place perimeter beams.

1. Open the project Syracuse-Suites-Beams.rvt.
2. Open the Structural Plans: TOS-1ST FLOOR view.

3. In Properties, in the Underlay area, set the Range: Base
Level to T.0. FOOTING so that you can see the outline of the
building.

4. In the View Control Bar set the Detail Level to B2 (Medium).

5. In the Structure tab>Structure panel, click 7 (Beam).

© 2019, ASCENT - Center for Technical Knowledge® 7-11
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6. In the Type Selector, select W-Wide-Flange: W14x30.

7. Add framing between each column (and in some cases
between beams), as shown in Figure 7-16. You can use a
variety of techniques to place the beams.
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Figure 7-16

&0
* If you use O‘& (At Grids), ensure that you select the
correct grids. Delete beams that are not used.

» If you are sketching the beams, in the Options Bar, select
Chain to keep the sketching active between picks. Press
<Esc> once to end the chain but remain in the command.

+ To place the curved beams. use either A (Pick Lines) or
the £~ (Start-End-Radius Arc) tool

.« Use “” (Split Element) to break each curved beam into
two beams at the midpoint.

» Select the curved beams and in Properties, in the
Structural section, change the Structural Usage to Girder.

8. Save the project.
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This graphic has been
modified for clarity.

Task 2 - Create Beam Systems.

. In the Structure tab>Structure panel, click il (Beam

System).

. In the Modify | Place Structural Beam System tab, verify that

I (Automatic Beam System) is selected.

. In the Tag panel, if required, click [ (Tag on Placement) to

toggle it off.

. In the Options Bar, set the following:

+ Beam Type: W12x26
* Layout Rule: Maximum Spacing of 6’-0”

. Click inside each bay, ensuring that the beams are running in

a West-East direction. Exclude the bays shown in
Figure 7-17.

Figure 7-17

. Use il (Sketch Beam System) for any bays that cannot be

applied automatically.

* In Properties, in the Identity Data area, set Tag new
members in view to None.

. Once all of the framing is in place end the command.

. Save the project.
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Task 3 - Copy the framing to the other levels.

1.

Select everything on the first floor except the grid lines.

In the Status Bar, click ¥ (Filter).

In the Filter dialog box, clear the Structural Columns
category as shown in Figure 7—18. If elements other than
framing are displayed, clear those categories as well.

Filter >
Category: Count:

[«]5tructural Beam Systems Chedk all

[l tructural Columns

[«]5tructural Framing (Girder) Ched: Mone

[«]5tructural Framing (Joist) 101
[«]5tructural Framing (Other) 13

Figure 7-18
Click OK.
In the Modify | Multi-Select tab>Clipboard panel, click
= (Copy to Clipboard).
In the Clipboard panel, expand L (Paste) and click
(Aligned to Selected Levels).

In the Select Levels dialog box, select TOS-2ND FLOOR to
TOS-13TH FLOOR, as shown in Figure 7-19. (Hint: Hold
<Ctrl> or <Shift> to select multiple levels.)

Select Levels >

00 GROUND FLOOR,
T.0. FOOTIMNG
TOS5-15T FLOOR.
TOS5-2MD FLOOR.
TOS5-3RD FLOOR.
TOS5-4TH FLOOR.
TOS5-5TH FLOOR.

TOS-12TH FLOOR
TOS-13TH FLOOR
TOS-14 ROOF

Figure 7-19
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This graphic is shown at
the Coarse detail level
with Show Analytical
Model on for clarity.

8. Click OK. This will take some time to process.
9. Open the Structural Plans: TOS-13TH FLOOR view.

10.Only the Girder beams of each bay are required on the roof
level. With a crossing window, select everything and filter out
everything but Structural Framing (Girder).

11. Press <CtrI>+<C> (the Copy to Clipboard shortcut).

12.1n the Clipboard panel, expand L (Paste) and click
(Aligned to Selected Levels).

13.In the Select Levels dialog box, select TOS-14 ROOF and
click OK.

14.0Open the TOS-14 Roof view and set the Detail Level to
Medium so you can see the girder placement.

15.0pen a 3D view to see the full model, as shown in
Figure 7-20.

FiTl

Figure 7-20

16.Save the project.

© 2019, ASCENT - Center for Technical Knowledge® 7-15
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Task 4 - Create a framing elevation.

1.

Open the TOS-1st FLOOR structural plan view.

In the View tab>Create panel, expand 6 (Elevation) and

o—

click 6 (Framing Elevation).

Select the beam along Grid 1 between Grid B and Grid C,
as shown in Figure 7-21.

' Bevalon 1-a

O

In the Project Browser, expand Elevations (Framing
Elevation) and rename Elevation 1 — a as West Bracing.

Figure 7-21

Open the framing elevation.

Modify the crop region to display the columns.

In the View Control Bar, set the Detail Level to @ (Fine).

Zoom in to display the 00 GROUND FLOOR and TOS-1ST
FLOOR level heads.

Save the project.

© 2019, ASCENT - Center for Technical Knowledge®
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TOS-1ST FLOOR

Task 5 - Add bracing.

1. In the Structure tab>Structure panel, click 2 (Brace).
2. In the Type Selector, select HSS Square: HSS6X6X1/2.

3. Draw from the centerline of the base of the column on the left
to the midpoint of the beam located on the 1st Floor, as
shown in Figure 7—22. Repeat this step on the other side.

|
TOS-1ST FLOOR

14r _?u

2nd point

14r _?u

1st poim\
00 GROUND

4th point

3rd point

|* 00 GROUND

e _FLOOR _ FLOOR
OI — 0“ L 1"; ST - e g t ‘A OI - 0“
F - _.'g.-_.a. . ., ‘: ‘ X . : L : L
Bt E
T.0. FOOTING _ St l e 0 0 1 1.0 FOOTING
_15!_0" I comhEi A i o LT e T e Ta T PN | _15|_U|1

Note that the entrance
level is listed as Ground
Floor. This is typical in
some Canadian and
British naming
schemes.

Figure 7-22

4. Click b (Modify) and select the two new braces.

5. Copy the braces to the clipboard and use Paste Aligned to
place them on each of the levels from TOS-1ST FLOOR to
TOS-13TH FLOOR. Note: Do not include the T.O.FOOTING
level.

6. Pan up to the top level.

7. Select the top two braces, if required.

© 2019, ASCENT - Center for Technical Knowledge® 7-17
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8. Drag the circular control up to the beam above it, as shown in
Figure 7-23.

| | | |
T T T " T
ey

it —

Before After

Figure 7-23

9. Zoom out to see the entire framing elevation.

10.Save the project.
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Madify | Structural Framing

=

) i

7.2 Modifying Structural Framing

The default connections of columns, beams, and braces might
need to be modified to suit specific situations, such as when the
beams are offset from their associated level, or cantilevered
beyond a framing member. Modifications can be made by using
graphical controls and shape handles, the Properties, or special
tools found on the Modify | Structural Framing tab, as shown in
Figure 7-24.

it B o

Edit Highlight Change Justification = Offeet Edit Pick
Family Analytical Reference Points EETEE Work Plane | New
Mode Analytical Join Tools Justification Work Plane
Properties £ F—Control
% e anoe ~ 0 Shape handles

Structural Framing (Girder) (1)

v] Edit Type

N

1L}

Constraints )
Reference Level Level 2
Work Plane Level : Level 2
Start Level Offset 0" 0"
End Level Offset 0o
Orientation MNormal
Cross-5Section Rotation 0.000°
Geometric Position H
Start Extension 0o
End Extension 0o
Start Join Cutback 0o
End Join Cutback 0oz
yz Justification Uniform
y Justification Crigin
y Offset Value 0o

Properties help

Apply

Figure 7-24

* The Detail Level of a view impacts the way in which framing
members display, as shown in Figure 7-25. Some editing
tools only work in a Medium or Fine detail view.

Coarse detail level

Medium detail level
Figure 7-25

© 2019, ASCENT - Center for Technical Knowledge®
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Location Lines

Figure 7-26

For a visual reference, you can use either location lines
(shown in Figure 7—26) or analytical lines (shown in
Figure 7-27).

+ To show location lines, in the Visibility/Graphics dialog
box>Model Categories tab, expand Structural Framing,
and then select Location Line.

» To toggle the display of Analytical lines, in the View

]

Control Bar, click (Show/Hide Analytical Model).

Figure 7-27

When you draw framing members, the start/end orientation is
based on the first and second points picked. In some
modification instances it is important to know the start point
verses the end point. In the analytical model, the start point is
green and the end point is red, as shown in Figure 7-28.

Start Point (green,
End Point (red)

Figure 7-28

To flip the start and end points:

* In a plan view, click the Flip Structure Framing Ends
icon, as shown in Figure 7-29.

* In a 3D view, right-click on the member and select Flip
Structural Framing ends.

i

T Flip Structural Framing ends

Figure 7-29

7-20
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Sloping and
Offsetting
Beams

DI EII
I Start Level Offset

Figure 7-30

Beams can be modified to slope or offset from the level where
they are placed. This can be done by using the Start/End Level
Offset control, as shown in Figure 7-30, or in Properties, as
shown in Figure 7-31.

Properties =

W-Wide Flange -
W12x26

Structural Framing (Girder) (1) v] Edit Type

Constraints Ros
Reference Level Level 2 1
Start Level Offset 0 a"

End Level Offset a o
Cross-5ection Rotation 0.000*
Figure 7-31

» Setting the offset at only one end slopes the beam as shown
in Figure 7-32.

sl

Figure 7-32

+ The Cross-Section Rotation option rotates the beam along
its axis at the angle specified in Properties.

© 2019, ASCENT - Center for Technical Knowledge®
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Hint: Using 3D Snapping

When you draw beams, you can toggle on 3D Snapping and
then snap to other beams or structural walls of different
heights. You can also do this with beam systems when you use
the Automatic Beam System method. On the left in

Figure 7-33, the 3D and Walls Define Slope options are
selected, while on the right, they are not.

Figure 7-33

» Setting the Start/End Level Offset the same at each end
raises or lowers the entire beam. For example, when Wide
Flange Beams are supporting Open Web Steel Joists (as
shown in Figure 7-34), you need to offset that increment
based on the specific joist’s seat.

Entire Beam lowered

Joist sea

Figure 7-34

7-22 © 2019, ASCENT - Center for Technical Knowledge®
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Adding Beam
Cantilevers and
Cutbacks

Use this method to
extend joists for a fascia
system, or in any
situation in which a roof
or slab extends past the
main structure.

It is common to need a joist extension that cantilevers a bearing
member. In the example shown in Figure 7-35, the joist seat
needs to extend past the beam it bears on to frame into a
cantilevered ridge beam. By modifying the individual joists, you
can extend either end to meet the requirements.

Figure 7-35

To cantilever or cutback a beam that is joined to other structural
elements, use the shape handles to drag it to a new location, or
set the Start/End Join Cutback in Properties, as shown in
Figure 7-36.

a.

Structural Framing : W-Wide Flange : W12326 : Shape
handle

1]

Properties x

\ W-Wide Flange -
W12X26

Structural Framing (Girder) (1) v] Edit Type

Constraints
Geometnic Position

Start Extension
0 o1z

UI

End Extension i
ﬂl
LIniform

Start Join Cutback
Figure 7-36

£

-

hf i

End Join Cutback
vz Justification
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To cantilever a beam when the beam is not joined to other
elements, you can use the Drag Structural Framing
Component End shape handle (as shown in Figure 7-37), or in
Properties set the Start or End Extension.

[ Drag Structural Framing Component End l

Figure 7-37

When working with Beam Systems you first need to unpin the
individual beam you want to work with. Select it and click the

o . .
== (Prevent or allow change of element position) icon.

Hint: Structural Connections and Fabrication

Over 150 standard structural connections can be added to
framing joins to share in-depth information about the join with
the contractor and fabricator. You can also add fabrication
elements such as plates, bolts, and welds and modify plates
and other steel elements using copes and other cuts. These
tools, which are beyond the scope of this learning guide, are
found on the Steel tab, as shown in Figure 7-38.

ReEHG -G-7-8 £-2 @ A -5 O, E-5 Projecl-Stuctral Plan: Level |

File Architecture  Structure  Steel  Systems  Insert  Annotate  Analyze  Massing & Site Collaborate V|

i BB ANPoZoez I @ 4

Modify Connection Plate Bolts Welds Cormer Cope Shorten Contour Cope  Miter  Cut Through Cut By
T Cut  Skewed Cut T

Select = Connection = 1 Fabrication Elements Modifiers Parametric Cuts

Figure 7-38

7-24
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Changing the
Cutback

You can select more
than one element to
adjust as long as they
are connected to the
same reference.

Another way to modify the join connection of structural framing is
to change the cutback from the connected element. For
example, the default cutback of the column shown in

Figure 7-39 is the bounding box of the column, not the vertical
support. You can change the reference to a more appropriate
part of the framing.

o |l
- —_ _{_ -

——

Before After
Figure 7-39

* You can changing the reference in 2D and 3D views if the
Display Level is set to Medium or Fine.

How To: Adjust the Cutback of Structural Framing

1. Select the structural framing member you want to modify.
2. In the Modify | Structural Framing tab>Join Tools panel, click

I (Change Reference).

3. Select the reference point for alignment, as shown on the left
in Figure 7—40. This can be another beam, a structural
column, or a structural wall.

] - - - B - - -

Structural Columns : W-Wide Flange-Column :
Reference

aE

Before After
Figure 7-40
4. The end of the framing, the member moves to the new
reference location, as shown on the right in Figure 7—40.

5. In Properties modify the Start Join Cutback or End Join
Cutback distance as required.

« To return the beam end to its default setback position, click

I (Change Reference) again, and then select the bounding
box (dashed lines) of the other element

© 2019, ASCENT - Center for Technical Knowledge® 7-25
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Changing
Justifications

Another modification you can make to beams is to change their
justification. You can set the horizontal (y) and vertical (z)
justification points to one of nine different points, such as Origin
Left, shown in Figure 7—41. The Location Line remains in place,
with the framing element moved to the new justification. You can
also change the offset from the justification point in either the y
(left to right), or z (top to bottom) directions. Both of these options
can be modified either graphically or through Properties.

Potential
justification points

Figure 7-41

How To: Set the Justification of Framing Elements
Graphically

-_—

. Select the beam you want to modify.
2. in the Modify | Structural Framing tab>Justification panel,

click ﬁ['r (Justification Points), or type JP.
3. Select the Justification points you want to use, as shown in
Figure 7-42.

Origin Left

Figure 7-42
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The location line does not change, but the framing element
repositions to the selected justification point.

You can also modify the Justification points using the
y Justification and z Justification parameters in Properties, as
shown in Figure 7—43.

Properties x
\ W-Wide Flange -
WI1226
Structural Framing (Girder) (1) v] Edit Type
Geometric Position hooa
Start Extension o o"
End Extension o o"
Start Join Cutback 0012 =
yz Justification Uniform
y Justification Left
y Offset Value oo
z Justification
z Offset Value
Materials and Finishes -Cropt
St.ructur.al E»S:t:rrn
Dimensions
Figure 7-43

How To: Change the Justification Offset

Graphically

Select the structural framing element.
In the Modify | Structural Framing tab>Justification panel:

» Modify the horizontal offset and distance by clicking

f= (y Offset), or type JY.
* Modify the vertical offset and distance by clicking

E (z Offset), or type JZ.
Select the offset start point and then the offset end point.

You can also modify the offset values in Properties by using
the y Offset Value and z Offset Value.
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You can set the yz Justification (shown in Figure 7—44) to the

following:

» Uniform: The same justification offset is applied to both
ends.

* Independent: The justification offset can be different for
each end.

When the yz Justification is selected, you can set the Start y
(or Start z) Offset Value and the End y (or End z) Offset
Value in Properties.

g

Geometric Position

Start Extension o 0"
End Extension o 0"
yz Justification Independent
Start y Justification Origin
Start y Offset Value oo
Start z Justification Top
Start z Offset Value o 0"
End y Justification Origin
End y Offset Value o on
End z Justification Top
End z Offset Value o o"
Figure 7-44
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Attaching a
Column to a
Beam

Hint: Viewing Justifications
At the Coarse Detail Level, when you select the beam, the
justification line is displayed, as shown in Figure 7—45.

ustification Line

° KJBeam (with a Left
(Justification)

Figure 7-45

When working in the Medium (or Fine) Detail Level, along with
toggling on the Location Line in Visibility/Graphics it can help to
display the analytical model, as shown in Figure 7—46. In the

View Control Bar, click i (Show Analytical Model).

Justification Line

Beam (with a Left
Justification)

Figure 7-46

The columns that support the cantilever can be attached to the
bottom of the framing member, as shown in Figure 7—47. This
removes the need to estimate the actual bearing depth of the
framing member, and ensures that the column always remains
connected to the beam.

Figure 7-47
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Applying
Beam Coping

How To: Attach a Column to the Bottom of a Beam

1.
2.

Select a column.
In the Modify Structural Columns tab>Modify Column panel,

N
click & (Attach Top/Base).

In the Options Bar, set the options as required. If you need to
add a bearing plate, set the Offset from Attachment value.
Select the beam that the column will attach to.

You can also use this command to attach the base of a beam
to structural footings. When the footing moves in height, the
length of the column resizes to match.

When one beam connects with another beam you might need to
modify the connection. In the example shown in Figure 7—48, the
lower joist-bearing beam runs into the perimeter beam. This is a
coping situation.

Figure 7-48

How To: Cope Beams

1.
2.

3.

Open a 3D view, section, or detail view.
Zoom in to a beam to beam (or beam to column) connection.

In the Modify tab>Geometry panel, expand Ie (Cope) and

select Ie (Apply Coping).
Select the beam to be coped first followed by the
column/beam from which to cut. The cope is then completed.

* You can change the Coping Distance setting in
Properties.
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Editing When you add beams to a project there is a default layout to the
. beam joins. However, you might need to override the joins. You

Beam Joins | can do this by using Change Beam Status, as shown in

Figure 7—-49.

Change Bearn Status

Figure 7-49

How To: Edit Beam Joins

1. In the Modify tab>Geometry panel, click = (Beam/Column
Joins). The work area switches to Sketch mode.

* Only the beams and/or columns that can be changed are
highlighted.

* You cannot use this tool on beams that are attached to
vertical columns.

2. In the Options Bar, specify the types of beams that you want
to work with as shown in Figure 7-50.

Show beam joins containing: [¥]Steel [¥|Wood [¥] Precast Concrete [V] Other
Figure 7-50
3. Click the Change Beam Status control to toggle the join.

4. Click = (Beam/Column Joins) again to toggle the command
off.
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« If you are mitering a corner, you can lock the miter as
shown in Figure 7-51.

i

I

Unlocked Locked
Figure 7-51

Hint: Join Status

You can modify the Join Status of structural framing to position
framing that butts against a wall or other beams. Right-click on
the join control (the circle), select Disallow Join (as shown on
the left in Figure 7-52), and make the required modifications.
Click Allow Join to rejoin the elements.

 —— ||

Repeat [ Beam]

Recent Commands 4 %llgw]gin i
Drag Structural Framing Component

Disallow Join I} ‘

Hide in View *
Override Graphics in View » |
Figure 7-52

» Join Status is field that can be used in schedules. You can
modify the status in the schedule.
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Practice 7b Modify Structural Framing

Practice Objectives

* Modify beam level offsets.
* Add Beam Systems.

In this practice, you will modify beam level offsets for correct joist
bearing and add beam systems using the automatic method
where you can and sketch beam systems in areas where they
cannot be automatically placed, as shown in Figure 7-53.

Figure 7-53

Task 1 - Modify beam level offsets.

1. Open Syracuse-Suites-Framing.rvt.
2. Open the Structural Plans: TOS-14 ROOF view.
3. Hide the grids.

© 2019, ASCENT - Center for Technical Knowledge® 7-33



Autodesk Revit 2020 Structure Fundamentals

If you selected bracing
element, you need to
filter them out.

4. For this level you need to lower the perimeter beams of each
bay in the North-South direction for the joist bearing. Select
all of the vertical beams in the plan, excluding the beams
along the far right, as shown in Figure 7-54.

AN / "\

|
)

S~

Figure 7-54

5. In Properties, change the Start Level and End Level Offsets
to (negative) -2 1/2”.

6. Click Apply.

7. Open a 3D view and zoom in on one of the top floor
intersections. The North-South girders should be displayed
below the East-West girders as shown in Figure 7-55.

Figure 7-55

8. Save the project.
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Hint: In the Load Family
dialog box, in the left
pane, select Imperial
Library. This takes you
to the top level of the
Autodesk Revit family
folders.

Task 2 - Add beam systems.

1.

Switch to Structural Plans: TOS-14 ROOF view.

. In the Insert tab>Load from Library panel, click E (Load

Family).

In the Load Family dialog box, browse to the Structural
Framing>Steel folder, select K-Series Bar Joist-Rod
Web.rfa, and click Open.

In the Specify Types dialog box, select 16K7 from the list and
click OK.

In the Structure tab>Structure panel, click il (Beam
System). In the Options Bar and Properties, set the following
parameters:

* Beam Type: 16K7
» Layout Rule: Maximum Spacing
*  Maximum Spacing: 6’-0”

Use [ (Automatic Beam System) to fill in as many bays as
possible, as shown in Figure 7-56.

AN 7\

Figure 7-56
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» If the error shown in Figure 7-57 opens, the space for the
joist might be too small to be created by the Beam
System command. Click Delete Type. You can add a
beam separately as required.

Errors such as this Autodesk Revit
occur, so you should not Error - cannot be ignored - 1 Error, 4 Warnings
neglect potential Can't make type "K-Series Bar Joist-Rod Web : 16K7".

problems. They are an
important part of using
the BIM model process.

£ lofs == Show Mare Info Expand =
Figure 7-57

« If you end up with areas where the automatic method
does not work (such as the example shown in

Figure 7-58), switch to il (Sketch Beam System). When
sketching beam systems, in Properties, in the Identity
Data section, change Tag new members in view to None.

/ )

1 3 1 I 1 1 1

! J//_»FI\ | |

Figure 7-58

7. Save the project.
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7.3 Adding Trusses

A truss can be added to a project using the same basic method
as placing a beam. Trusses are typically comprised of one or
more triangular sections, as shown in Figure 7-59. These
sections are constructed with structural members whose ends
are connected at joints, which are referred to as nodes. As
various forces act on these nodes, the triangular shape provides
structural stability to prevent bending.

Top Chord Web members

Figure 7-59

Truss elements include:

« Bottom Chord, the lower horizontal member.
 Top Chord, the upper horizontal member.

* Web, the series of structural framing elements that
stabilize the truss.

The Top and Bottom Chords fulfill the same function as a
beam’s top and bottom flanges. The Web takes the place of the
beam’s continuous plate.

How To: Add Trusses

1. In the Structure tab>Structure panel click AW (Structural
Trusses).
2. In the Type Selector, select the type of truss you want to use

+ Click E (Load Family) and navigate to the Structural
Trusses folder to add families to the project.

3. Inthe Modify | Place Truss tab>Draw panel, click 7 (Line) or
A (Pick Lines) and add the trusses to the project.
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Attaching Trusses can be attached to roofs or floor slabs. They can also

follow the slope of the roof and automatically extend to fit, as
Trusses to | shown in Figure 7-60.

Roofs

Figure 7-60

How To: Attach Trusses to Roofs
1. In the Modify | Structural Trusses tab>Modify Truss panel,

dlick L' (Attach Top/Bottom).
2. In the Options Bar, set Attach Trusses to Top or Bottom.
3. Select the roof or floor element. The truss attaches to the
element and follows the angle or slope, as shown in
Figure 7-61.

Figure 7-61

* The top chord must be one continuous line in the family. If it is
broken into segments, attaching it might not work properly.

Verify that the bottom chord is specified as the bearing chord
in the element properties of the truss. This ensures that the
roof loads are carried throughout the truss appropriately.

If the roof/floor slab does not cover the length of the truss, an
error message opens and you might have to detach the truss.
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Setting Framing
Types in
Trusses

When truss families are created they can include structural
framing members for the chords and webs. However, they often
just use default members. Therefore, you need to specify the
precise framing types you want to use in the project.

In the Type Properties dialog box, select the Structural Framing
Type from a list of families loaded into the project, as shown in

Figure 7-62. Set the Structural Framing Type for the Top
Chords, Vertical Webs, Diagonal Webs, and Bottom Chords.

Type Properties x
Family: |Huwe Flat Truss ~ | | Load.. |
Type: | Standard o | | Duplicate... |

Rename... |
Type Parameters
Parameter | Value |:| ~

Analytical Vertical Projection

Center of Beam

Structural Framing Type

W Shapes:W12X26

Start Release

End Release ShapesW16X26
W Shapes:W14X30
Angl
NS W Shapes:WaX10

Structural Framing Type

Concrete-Rectangular Bearn: 16 x 32
Concrete-Rectangular Beam:12x 24

Start Release P AN T —
End Release Pinned
Angle 0.00°

Structural Framing Type

Set Framing Type

Start Release User Defined
End Release Pinned
Angle 0.00°

Analytical Vertical Projection

Center of Beam

Structural Framina Tvoe

What do these properties do?

Set Framina Tvoe

<< Preview | |

| | Cancel

Apply

Figure 7-62
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To select an entire truss, ensure that the dashed lines are
displayed, as shown on the left in Figure 7—63. To select one
element of the truss, press <Tab> until the element that you
want to select is highlighted, as shown on the right in

Figure 7-63.

1.0

[

it
i
|

T n

NN

Properties

Structural Framing : W-Wide Flange : WL2X26

Figure 7-63

Individual Truss members are pinned to the truss framework.
If you want to modify one of these you need to click

© (Prevent or allow change of element position) to unpin
only that member.

You can rotate Trusses. and specify if the chords rotate with
the truss. In Properties, type in a Rotation Angle and select or
clear Rotate Chords with Truss, as shown in Figure 7-64.

Howe Flat Truss

Standard

Structural Trusses (1)

v] Edit Type

Structural

5 e

Create Top Chord
Create Bottom Chord
Bearing Chord Bottom
Rotation Angle 20.000°
Rotate Chords With Truss ;| [7]
Bearing Vertical Justifica...; Center

m

= o
Chords not rotated Chords rotated

Stick Symbol Location

Bearing Chord

Figure 7-64
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Practice 7c Add Trusses

Practice Objectives

» Set up a truss type.
+ Add trusses to a project.
» Attach trusses to a roof.

In this practice, you will setup a truss using specific structural
framing types for the chords and webs. You will then draw a truss
and array it across an open span. Finally, you will attach the
trusses to an existing roof element, as shown in Figure 7-65.

Figure 7-65

Task 1 - Set up a Truss Type

1. Open Syracuse-Suites-Trusses.rvt.

2. In the Structure tab>Structure panel, click AW (Truss).

3. In the Type Selector, select Howe Flat Truss: Standard and
click £8 (Edit Type).

4. In the Type Properties dialog box, click Duplicate.

5. In the Name dialog box, type Skylight, and click OK.
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6. Inthe Type Properties dialog box, set the following properties
as shown in Figure 7—66:

» Top Cords and Bottom Chords:
Set the Structural Framing Type to LL-Double
Angle:2L6X4X5/8LLBB.

* Vertical Webs and Diagonal Webs:
Set the Structural Framing Type to LL-Double
Angle:2L3X2-1/2X1/2LLBB.

Type Properties x
Family: |Huwe Flat Truss V| | Load... |
Type: skylight v | Duplicate... |

| Rename... |

Type Parameters

Parameter Value =| ™
Analytical Vertical Projection Center of Beam
Structural Framing Type LL-Double Angle:2LEX4X5/8LLEE
Start Release Pinned
End Release Pinned
Angle 0.00°
Structural Framing Type LL-Double Angle:2L3X2-1/2X1/2LLE
Start Release Pinned
End Release Pinned
Angle 0.00°
Structural Framing Type LL-Double Angle:2L3X2-1/2X1/2LLE
Start Release Pinned
End Release Pinned
Angle 0.00°
Analytical Vertical Projection Center of Beam
Structural Framing Type LL-Double Angle:2L6X4X5/8LLEE
Start Release Pinned “

What do these properties do?

<< Preview | | Ok || Cancel Apply

Figure 7-66
7. Click OK.

8. Save the project.
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Task 2 - Add Trusses.

1. Open the Structural Plans: TOS-14 ROOF view. Some of
the structural framing has been removed in this plan to make
way for a large skylight, as shown in Figure 7-67.

F A O £ N GRS O AR (¢

e T E o e e e 174 [N A H S
O I 2 | FaN I B— 3
s ! | |
o | | !
| | |
- i | R o
! ! '
! !

|
i
| !
@"_r_ J — N ‘! _____ I T :}
P . ! ! !
s i ! . /
- : R o
T
i ]

E}__ _____ - —
i |
S T I A | A i - T ©
L Y A O A e v A OV AN AP
b b d & bbdd 54
Figure 7-67

2. Start the AW (Truss) command.

3. In the Type Selector, verify that the Howe Flat Truss:
Skylight is selected.

4. In Properties, set the Bearing Chord to Bottom and the Truss
Height to 4’-0".

5. Draw the first truss, as shown in Figure 7—-68.

L A A SR SRR O
I L

®_ ___________ e
| | AN | N
o AN AN
i | |
O : | !
i i
— +—
I Structural Trusses : Howe Flat Truss : Skylight ]—
| |
| | |
T N o
Figure 7-68
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6.
7.

Click b (Modify) and select the new truss.
In the Modify | Structural Trusses tab>Modify panel, click

oo

B0 (Array).

In the Options Bar, ensure that g (Linear) is selected and
Group and Associate is cleared. Set the Number to 15 and
the Move To: to Last.

To specify the length of the array, click on Grid C and then on
Grid E.

10.Open the 3D Views: Roof and Skylight view and rotate the

view to display the trusses, as shown in Figure 7—69.

Figure 7-69

11. Save the project.

Task 3 - Attach the Trusses to a Roof.

1.

Open the Visibility Graphic Overrides dialog box and toggle
on Roofs. An existing roof (referencing the location of the
skylight) displays.

o
In the Quick Access Toolbar, click "=* (Close Inactive
Windows) so that only the 3D view displays.

Open the Elevations (Building Elevations): East and
South views.

Type WT to tile the three views and ZA so that they are all
zoomed out fully.
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5. Zoom in on the skylight roof in the two elevation views,
similar to that shown in Figure 7—70.

A East ¥ fiJ Roof and Skylight

> 4l

| | | -

O ATTTTFTTIIIT]

i i
g1 DR RGN ¢ e TE <

T~

yer=10" (PR KERE 2 9 (B E < > 187 = 10" F ATk T FRE R 9 Rl E < »

Figure 7-70

6. Inthe Elevation: East view, use a crossing window to select
all of the trusses and other overlapping elements and then
filter out everything but the trusses.

7. In the Modify |Structural Trusses tab>Modify Truss panel,
=
click &~ (Attach Top/Bottom).

8. Select the roof. Allow time for it all to process until the trusses
expand to touch the roof, as shown in Figure 7-71.

] | ||

Figure 7-71

9. Make the 3D View: Roof and Skylight view active and type
TW to return to the tabbed view.

10.Save the project.
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Chapter Review Questions

1.

When placing a beam, which of the following is NOT an
option?

a. Structural Usage
b. Placement Plane
c. 3D Snapping
d. At Columns

Which of the following describes a Beam System?

a. Parallel beams grouped together after they are placed.

b. Parallel beams placed at the same time.

c. All beams in a bay grouped together after they are placed.

d. All beams in a bay placed at the same time.

In a plan view, which of the following changes the display to
show the stick symbol for beams, as shown in Figure 7727

| |

Figure 7-72
. Detail Level: Coarse

=

. Detail Level: Medium
Visual Style: Wireframe
Visual Style: Hidden

BN
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4. How do you create sloped beams such as those shown in
Figure 7-737?

Figure 7-73
a. Specify the Slope before you start drawing the beam.

b. Specify the Start/End Level Offset before you start
drawing the beam.

c. Change the Slope after you have drawn the beam.

d. Change the Start/End Level Offset after you have drawn
the beam.

5. Where do you assign the structural member types and sizes
for the components of a truss, such as that shown in
Figure 7-747? (Select all that apply.)

Figure 7-74

In Family Types
In Properties
In Type Properties

a0 T w

In the Options Bar
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Command Summary

Button \ Command \ Location
Clipboard
|._ Copy to * Ribbon: Modify tab>Clipboard panel
O Clipboard * Shortcut: <Ctr>+C
Paste » Ribbon: Modify tab>Clipboard panel

« Shortcut: <Ctr>+<V>

(Paste) Aligned
to Selected
Levels

* Ribbon: Modify tab>Clipboard panel

(Paste) Aligned
to Selected
View

* Ribbon: Modify tab>Clipboard panel

Structural Framing Elements

17

Beam

» Ribbon: Structure tab>Structure panel

Beam System

» Ribbon: Structure tab>Structure panel

Brace * Ribbon: Structure tab>Structure panel
% » Shortcut: BR

Structural » Ribbon: Structure tab>Structure panel
NSN Trusses

Structural Framing Modification

r Apply Coping * Ribbon: Modify tab>Geometry panel,
IE‘-._ expand Cope
=F Attach * Ribbon: Modify | Structural Columns>
L] Top/Base Modify Column panel
=F Attach » Ribbon: Modify | Structural Trusses>
] Top/Bottom Modify Truss panel
4l Beam/Column * Ribbon: Modify tab>Geometry panel
= Joins

+— Change » Ribbon: Modify | Structural Framing>
I[— Reference Join Tools panel
% Connection » Ribbon: Structure tab>Connection

panel

— Detach » Ribbon: Modify | Structural Columns>
=4 Top/Base Modify Column panel
= Detach * Ribbon: Modify | Structural Trusses>
=4 Top/Bottom Modify Truss panel
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Ribbon: Modify | Structural Framing>
Justification panel

Shortcut: JP

Ribbon: Modify | Structural Framing>
Justification panel

Ribbon: Modify | Structural Framing>
Justification panel

Shortcut: JY

ﬁ Justification

' Points
Offset

E:

Trj.I y Offset

E z Offset

Ribbon: Modify | Structural Framing>
Justification panel

Shortcut: JZ
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