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C h a p t e r

Structural Framing

The skeleton of a building is its structural framing. Together, elements such as 
columns, beams, bracing, and trusses give buildings the stability they need. While 
the basic process of adding these elements to the project is simple, you also need 
to complete more complex tasks, such as manipulating connections (by setting 
bearing offsets, cantilevers, cut backs, and justifications), applying beam coping, 
and editing beam joins. 

Learning Objectives in This Chapter

• Sketch individual beams for girders connecting columns and structural walls.

• Create beam systems of multiple similar sized beams spaced at equal intervals to speed up 
adding joists.

• Add bracing to support the integrity of other framing members.

• Make changes to framing members so that the connections fit the exact situation.

• Add trusses to support long spans of open space.
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7.1 Modeling Structural Framing

The Autodesk® Revit® software enables you to frame a building 
with wood, concrete, and steel framing and bracing, such as the 
steel example shown in Figure 7–1. You can add individual 
beams, as well as beam systems and bracing elements.

Figure 7–1

• Framing types include Concrete, Light Gauge Steel,
Precast Concrete, Steel, and Wood.

• In views set to a Coarse detail level, the software assigns a
line weight to the structural members based on their
structural usage. For example, a Girder displays in a heavier
line weight than a Joist, while a Purlin displays with a dashed
line, as shown in Figure 7–2.

Figure 7–2

Girder

Joist

Purlin
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How To: Add Beams

1. In the Structure tab>Structure panel, click  (Beam).
2. In the Type Selector, select a beam type.
3. In the Options Bar, specify the options, as shown in 

Figure 7–3 and described below.

Figure 7–3

• Placement Plane: Defaults to the current level if you are in a 
plan view but can be modified to other levels. 

• Structural Usage: Select a type (as shown in Figure 7–3), or 
accept the default of <Automatic>.

• 3D Snapping: Select this if you want to draw a beam from 
one point to another at different heights.

• Chain: Select this if you want to draw a series of beams in a 
row. 

• To stay in the command and start another chain, press 
<Esc> once. 

4. For automatic tagging, in the Modify | Place Beam tab>Tag 

panel, click  (Tag on Placement).
5. In the Modify | Place Beam tab>Draw panel, use the Draw 

tools to draw the beams.

How To: Add Multiple Beams on Grid Lines

1. Start the Beam command and specify the type and other 
options, as outlined above. 

2. In the Modify | Place Beam tab>Multiple panel, click  (On 
Grids).
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3. Select the grids where you want to place the beams. A beam
is placed between each grid intersection, as shown in
Figure 7–4. Hold <Ctrl> to select more than one grid, or use a
selection window to select multiple grids at one time.
Columns must be in place in order to add multiple beams at
the same time.

Figure 7–4

4. In the Modify | Place Beam>On Grid Line tab>Multiple panel,

click  (Finish).

• Sometimes this can be the quickest way to add beams. If you
need to use various sizes of beams, when you are finished,
select those beams and make any changes in the Type
Selector.

Beam Systems Beam systems are layouts of parallel beams within a structural 
quadrant giving the structure added support, as shown in 
Figure 7–5. Typically used in joist layouts, beam systems can be 
set up to use either a fixed distance or number of beams. 

• Beam systems can be created automatically with sufficient
bounding elements (other beams). You can also sketch the
boundary for a beam system.

• To utilize the automatic beam system, you need to have
framing in the model already.

Window around 
entire grid line
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Figure 7–5

How To: Add Automatic Beam Systems

1. In the Structure tab>Structure panel, click  (Beam 
System) or type BS.

2. The Modify | Place Structural Beam System tab>Beam 

System panel, click  (Automatic Beam System).

• If you do not have framing in the level, you are directed to 
the Modify | Create Beam System Boundary tab, where 
you will need to create your bay boundary.

3. When  (Tag on Placement) is selected, in the Options 
Bar, set the Tag Style as shown in Figure 7–6. 

• Framing: Tags each individual member.

• System: Places one tag for the entire framing system.

Figure 7–6

4. In the Options Bar (shown in Figure 7–7), set the Beam Type, 
Justification, and Layout Rule.

Figure 7–7
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• The Layout Rules include Clear Spacing, Fixed
Distance, Fixed Number, and Maximum Spacing. Set
the required distance or number.

• Make changes in Properties or in the Options Bar as
needed to establish the required beam system.

5. Move the cursor over an existing beam until the guide lines
display in the correct area and direction, as shown vertically
and horizontally in Figure 7–8. This can also identify angled
lines.

Figure 7–8

6. Select the existing beam to place the system.
7. Repeat this step in other bays as needed.

• The Beam System is one uniform group. You can change the
beam type and spacing in the Options Bar or within
Properties.

• If a grid line is moved, the beams automatically space
themselves. If the bay increases beyond the minimum
spacing, a beam is added. If the bay shrinks below the
allowable spacing, a beam is removed.

• If you need to change the system to individual beams, in the
Modify | Structural Beam Systems tab>Beam System panel,

click  (Remove Beam System). The individual beams
remain but are no longer grouped together.
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How To: Sketch a Beam System

1. In the Structure tab>Structure panel, click  (Beam 
System).

2. In the Modify | Place Structural Beam System tab>Beam 

System panel, click  (Sketch Beam System).
3. In the Modify | Create Beam System Boundary tab>Draw 

panel, click  (Pick Supports) or use one of the other 
drawing tools. The first beam that you select will be the beam 
direction.

4. To modify the beam direction, from the Draw panel, click 

(Beam Direction) and select one of the sketch lines that 
you want the system to run parallel to, as shown on the top 
horizontal beam in Figure 7–9.

Figure 7–9

5. Clean up all of the corners so that there are no overlaps or 
gaps.

6. In the Modify | Create Beam System Boundary tab>Mode 

panel, click  (Finish Edit Mode).
7. Make changes in Properties or in the Options Bar as needed 

to establish the required beam system.

• To include an opening in a beam system, select the beam 
system and from the Modify | Structural Beam Systems 

tab>Mode panel, click  (Edit Boundary). From the Draw 

panel, select  (Boundary Line) and draw another opening 
inside the original sketched boundary.

Beam direction



Autodesk Revit 2021 Structure Fundamentals

7–8 © 2020, ASCENT - Center for Technical Knowledge®

Adding Bracing Braces automatically attach to other structural elements, such as 
beams, columns, and walls. They recognize typical snap points 
such as the end point of a column and the middle of a beam, as 
shown in Figure 7–10.

Figure 7–10

• Bracing can be added in plan view or, more typically, in a
framing elevation view.

How To: Add Bracing

1. Create and open a framing elevation.

2. In the Structure tab>Structure panel, click  (Brace).
3. In the Type Selector, select a brace type.
4. Pick two points for the end points of the brace.

• Work from the centerline of all of framing members so that
the analytical line extends into the adjacent framing, even
though the graphical member stops at the edge of the
column or beam, as shown in Figure 7–11.

Figure 7–11
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Cross Bracing
Settings

In plan view, cross bracing needs to be displayed graphically, 
usually by hidden lines. The software has a separate setting that 
controls cross bracing as viewed in plan. These settings enable 
you to display bracing above, below, or both. You can set the 
bracing to be displayed as parallel lines or as a line at an angle, 
as shown in Figure 7–12.

Figure 7–12

• In the Manage tab>Settings panel, expand  (Structural 

Settings) and click  (Structural Settings). In the Structural 
Settings dialog box, in the Symbolic Representation Settings 
tab, select the Brace Symbol options, as shown in 
Figure 7–13.

Figure 7–13

Parallel

Line with angle
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Hint: Copying Elements to Multiple Levels

Instead of drawing the same elements on each level, you can 
copy them to the clipboard and then paste them aligned to the 
other levels.

1. Select the required elements.
2. In the Modify <contextual> tab>Clipboard panel, click

(Copy to Clipboard).

3. In the Modify tab>Clipboard panel, expand  (Paste) and 

click  (Aligned to Selected Levels).
4. In the Select Levels dialog box, as shown in Figure 7–14,

select the levels to which you want to copy the beams.

Figure 7–14

5. Click OK.

• This command is for copying model elements only. If you
want to include tags or other annotation, use
Paste>Aligned to Selected Views.



Structural Framing

© 2020, ASCENT - Center for Technical Knowledge® 7–11

Practice 7a Model Structural Framing

In this practice, you will add framing for one floor of a building (as 
shown in Figure 7–15), and then copy and paste the framing to 
the levels above. You will then add bracing to one part of the 
structure.

This graphic is modified 
for clarity.

Figure 7–15

Practice Objectives

• Place beams and beam systems.

• Copy framing to additional levels.

• Create a framing elevation.

• Add bracing.
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Task 1 - Place perimeter beams.

In this task, you will add framing between each column (and in 
some cases, between beams), as shown in Figure 7–16. 

Figure 7–16

1. Open Beams-Syracuse-Suites.rvt from the practice files
folder.

2. Open the Structural Plans: TOS-1ST FLOOR view.

3. In Properties, in the Underlay area, set the Range: Base
Level to T.O. FOOTING so that you can see the outline of the
building.

4. In the View Control Bar set the Detail Level to  (Medium).

5. In the Structure tab>Structure panel, click  (Beam).

6. In the Type Selector, select W-Wide-Flange: W14x30.

7. Use the following techniques to place the beams:

• If you use  (At Grids), ensure that you select the 
correct grids. Delete beams that are not used. 



Structural Framing

© 2020, ASCENT - Center for Technical Knowledge® 7–13

• If you are sketching the beams, in the Options Bar, select 
Chain to keep the sketching active between picks. Press 
<Esc> once to end the chain but remain in the command. 

• To place the curved beams, use either  (Pick Lines) or 

the  (Start-End-Radius Arc) tool.

8. Use  (Split Element) to break each curved beam into two 
beams at the midpoint.

9. Select the curved beams and in Properties, in the Structural 
section, change the Structural Usage to Girder.

10.Save the project.

Task 2 - Create beam systems.

1. In the Structure tab>Structure panel, click  (Beam 
System).

2. In the Modify | Place Structural Beam System tab, verify that 

 (Automatic Beam System) is selected.

3. In the Tag panel, if required, click  (Tag on Placement) to 
toggle it off.

4. In the Options Bar, set the following:

• Beam Type: W12x26

• Layout Rule: Maximum Spacing of 6'-0"

5. Click inside each bay, ensuring that the beams are running in 
a West-East direction. Exclude the bays on the corners of the 
east end shown in Figure 7–17.

This graphic has been 
modified for clarity.

Figure 7–17

No beam system
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6. Use  (Sketch Beam System) for any bays that cannot be 
applied automatically.

• In Properties, in the Identity Data area, set Tag new
members in view to None.

7. Once all of the framing is in place end the command.

8. Save the project.

Task 3 - Copy the framing to the other levels.

1. Select everything on the first floor except the grid lines.

2. In the Status Bar, click  (Filter). 

3. In the Filter dialog box, clear the Structural Columns
category as shown in Figure 7–18. If elements other than
framing are displayed, clear those categories as well.

Figure 7–18

4. Click OK.

5. In the Modify | Multi-Select tab>Clipboard panel, click

(Copy to Clipboard).

6. In the Clipboard panel, expand  (Paste) and click 

(Aligned to Selected Levels). 

7. In the Select Levels dialog box, select TOS-2ND FLOOR to
TOS-13TH FLOOR, as shown in Figure 7–19. (Hint: Hold
<Ctrl> or <Shift> to select multiple levels.)
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Figure 7–19

8. Click OK. This will take some time to process.

9. Open the Structural Plans: TOS-13TH FLOOR view.

10.Only the Girder beams of each bay are required on the roof 
level. With a crossing window, select everything and filter out 
everything but Structural Framing (Girder).

11. Press <Ctrl>+<C> (the Copy to Clipboard shortcut).

12. In the Clipboard panel, expand  (Paste) and click 

(Aligned to Selected Levels).

13. In the Select Levels dialog box, select TOS-14 ROOF and 
click OK.

14.Open the TOS-14 Roof view and set the Detail Level to 
Medium so you can see the girder placement.
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15.Open a 3D view to see the full model, as shown in
Figure 7–20.

This graphic is shown at 
the Coarse detail level 
with Show Analytical 
Model on for clarity.

Figure 7–20

16.Save the project.

Task 4 - Create a framing elevation.

1. Open the TOS-1st FLOOR structural plan view.

2. In the View tab>Create panel, expand  (Elevation) and 

click  (Framing Elevation).

3. Select the beam between Grid B1 and Grid C1, as shown in
Figure 7–21.
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Figure 7–21

4. In the Project Browser, expand Elevations (Framing 
Elevation) and rename Elevation 1 – a as West Bracing.

5. Open the framing elevation.

6. Modify the crop region to display the columns.

7. In the View Control Bar, set the Detail Level to  (Fine).

8. Zoom in to display the 00 GROUND FLOOR and TOS-1ST 
FLOOR level heads.

9. Save the project.

Task 5 - Add bracing.

1. In the Structure tab>Structure panel, click  (Brace).

2. In the Type Selector, select HSS Square: HSS6X6X1/2.
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3. Draw from the centerline of the base of the column on the left
to the midpoint of the beam located on TOS-1ST FLOOR, as
shown in Figure 7–22. Repeat this step on the other side.

Figure 7–22

4. Click  (Modify) and select the two new braces.

Note that the entrance 
level is listed as Ground 
Floor. This is typical in 
some Canadian and 
British naming 
schemes.

5. Copy the braces to the clipboard and use Paste>Aligned to
Selected Levels to place them on each of the levels from
TOS-1ST FLOOR to TOS-13TH FLOOR. Exclude the
00 GROUND FLOOR, T.O.FOOTING, and TOS-14 ROOF
levels.

6. In the West Bracing elevation, pan up to the top level.

7. Select the top two braces and drag the circular control to the
midpoint of the beam above it, as shown in Figure 7–23.

2nd point

1st point

4th point

3rd point

Base column Base column
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Figure 7–23

8. Zoom out to see the entire framing elevation.

9. Save and close the project.

Before After
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7.2 Modifying Structural Framing
The default connections of columns, beams, and braces might 
need to be modified to suit specific situations, such as when the 
beams are offset from their associated level, or cantilevered 
beyond a framing member. Modifications can be made by using 
graphical controls and shape handles, the Properties, or special 
tools found on the Modify | Structural Framing tab, as shown in 
Figure 7–24.

Figure 7–24

• The Detail Level of a view impacts the way in which framing
members display, as shown in Figure 7–25. Some editing
tools only work in a Medium or Fine detail view.

Figure 7–25

End level offset

Shape handles

Coarse detail level

Medium detail level
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• For a visual reference, you can use either location lines 
(shown in Figure 7–26) or analytical lines (shown in 
Figure 7–27). 

• To show location lines, in the Visibility/Graphic Overrides 
dialog box>Model Categories tab, expand Structural 
Framing, and then select Location Line.

• To toggle the display of Analytical lines, in the View 

Control Bar, click (Show/Hide Analytical Model).

• When you draw framing members, the start/end orientation is 
based on the first and second points picked. In some 
modification instances it is important to know the start point 
verses the end point. In the analytical model, the start point is 
green and the end point is red, as shown in Figure 7–28.

Figure 7–28

• To flip the start and end points:

• In a plan view, click the Flip Structure Framing Ends 
icon, as shown in Figure 7–29.

• In a 3D view, right-click on the member and select Flip 
Structural Framing ends.

Figure 7–29

Figure 7–26 Figure 7–27

Location lines Analytical lines

Start Point (green)

End Point (red) 



Autodesk Revit 2021 Structure Fundamentals

7–22 © 2020, ASCENT - Center for Technical Knowledge®

Sloping and
Offsetting

Beams

Beams can be modified to slope or offset from the level where 
they are placed. This can be done by first unpinning the beam, 

selecting it, and clicking the  (Prevent or allow change of 
element position) icon in the view, and then using the Start/End 
Level Offset control, as shown in Figure 7–30, or modifying 
Start/End Level Offset within Properties, as shown in 
Figure 7–31. 

• Setting the offset at only one end slopes the beam as shown
in Figure 7–32.

Figure 7–32

• The Cross-Section Rotation option in Properties rotates the
beam along its axis at the angle specified.

• Setting the Start/End Level Offset the same at each end
raises or lowers the entire beam. For example, when Wide
Flange Beams are supporting Open Web Steel Joists (as
shown in Figure 7–33), you need to offset that increment
based on the specific joist’s seat.

Figure 7–30 Figure 7–31

Sloped beams
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Figure 7–33

Hint: Using 3D Snapping

When you draw beams, you can toggle on 3D Snapping from 
the Options Bar. This allows you to snap to other beams or 
structural walls of different heights. 

You can also use 3D Snapping when placing beam systems 
using the Automatic Beam System tool. When you toggle on 
3D Snapping, you have an additional option which is Walls 
Define Slope. When selected, this option allows you to use 
walls to define the slop of your beam system. 

On the left in Figure 7–34, the 3D Snapping and Walls Define 
Slope options are selected, while on the right, they are not.

Figure 7–34

Entire Beam lowered

Joist seat
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Adding Beam
Cantilevers and

Cutbacks

It is common to need a joist extension that cantilevers a bearing 
member. In the example shown in Figure 7–35, the joist seat 
needs to extend past the beam it bears on to frame into a 
cantilevered ridge beam. By modifying the individual joists, you 
can extend either end to meet the requirements.

Use this method to 
extend joists for a fascia 
system, or in any 
situation in which a roof 
or slab extends past the 
main structure. 

Figure 7–35

To cantilever or cutback a beam that is joined to other structural 
elements, use the shape handles to drag it to a new location, or 
set the Start/End Join Cutback in Properties, as shown in 
Figure 7–36.

Figure 7–36

To cantilever a beam when the beam is not joined to other 
elements, you can use the Drag Structural Framing 
Component End shape handle (as shown in Figure 7–37), or in 
Properties set the Start or End Extension. 
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Figure 7–37

• When modifying beams, you first need to unpin the individual 
beam you want to work with. Select it and click the 

(Prevent or allow change of element position) icon.

Changing the
Cutback

Modifying the join connection of structural framing can be done 
by changing the cutback from the connected element. For 
example, the default cutback of the column shown in 
Figure 7–39 is the bounding box of the column, not the vertical 
support. You can change the reference to a more appropriate 
part of the framing. 

You can select more 
than one element to 
adjust as long as they 
are connected to the 
same reference.

Figure 7–39

• You can change the reference in plan and 3D views if the 
Display Level is set to Medium or Fine.

Hint: Structural Connections and Fabrication

Over 150 standard structural connections can be added to 
framing joins to share in-depth information about the join with 
the contractor and fabricator. You can also add fabrication 
elements such as plates, bolts, and welds and modify plates 
and other steel elements using copes and other cuts. These 
tools, which are beyond the scope of this learning guide, are 
found on the Steel tab, as shown in Figure 7–38.

Figure 7–38

Before After
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How To: Adjust the Cutback of Structural Framing

1. Select the structural framing member you want to modify.
2. In the Modify | Structural Framing tab>Join Tools panel, click

 (Change Reference).
3. Select the reference point for alignment, as shown on the left

in Figure 7–41. This can be another beam, a structural
column, or a structural wall.

Figure 7–41

• The end of the member lengthens to the new reference
location (it does not move the beam), as shown on the right in
Figure 7–41.

4. In Properties, modify the Start Join Cutback or End Join
Cutback distance as needed.

Hint: Bounding Boxes

An element bounding box is an invisible rectangular box 
around the element that defines a single element and how it 
reacts to other elements. Figure 7–40 shows the bounding box 
for a column in dashed lines.

Figure 7–40

Before After
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• To return the beam end to its default setback position, click 

 (Change Reference) again, and then select the bounding 
box (dashed lines) of the other element. 

Changing
Justifications

Modifying the location of a framing element can be done by 
modifying the justification. You can set the horizontal (y) and 
vertical (z) justification points to one of nine different points, such 
as Origin Left, shown in Figure 7–42. The Location Line 
remains in place, with the framing element moved to the new 
justification. You can also change the offset from the justification 
point in either the y (left to right), or z (top to bottom) directions. 
Both of these options can be modified either graphically or 
through Properties.

Figure 7–42

How To: Set the Justification of Framing Elements 
Graphically

1. Select the beam you want to modify.
2. in the Modify | Structural Framing tab>Justification panel, 

click  (Justification Points), or type JP.

Location line

Potential 
justification points
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3. Select the Justification points you want to use, as shown in
Figure 7–43.

Figure 7–43

• The location line does not change, but the framing element
repositions to the selected justification point.

• You can also modify the Justification points using the
y Justification and z Justification parameters in Properties, as
shown in Figure 7–44.

Figure 7–44
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How To: Change the Justification Offset 
Graphically

1. Select the structural framing element.
2. In the Modify | Structural Framing tab>Justification panel: 

• Modify the horizontal offset and distance by clicking 

(y Offset), or type JY.

• Modify the vertical offset and distance by clicking 

(z Offset), or type JZ.

3. Select the offset start point and then the offset end point. 

• You can also modify the offset values in Properties by using 
the y Offset Value and z Offset Value.

• You can set the yz Justification (shown in Figure 7–45) to the 
following:

• Uniform: The same justification offset is applied to both 
ends.

• Independent: The justification offset can be different for 
each end.

When the yz Justification is selected, you can set the Start y 
(or Start z) Offset Value and the End y (or End z) Offset Value 
in Properties.

Figure 7–45
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Attaching a
Column to a

Beam

The columns that support the cantilever can be attached to the 
bottom of the framing member, as shown in Figure 7–48. This 
removes the need to estimate the actual bearing depth of the 
framing member, and ensures that the column always remains 
connected to the beam.

Figure 7–48

Hint: Viewing Justifications

At the Coarse Detail Level, when you select the beam, the 
justification line is displayed, as shown in Figure 7–46. 

Figure 7–46

When working in the Medium (or Fine) Detail Level, along with 
toggling on the Location Line in Visibility/Graphic Overrides, it 
can help to display the analytical model, as shown in 

Figure 7–47. In the View Control Bar, click  (Show Analytical 
Model). 

Figure 7–47

Justification line

Beam (with a Left 
Justification)

Justification line

Beam (with a Left 
Justification)



Structural Framing

© 2020, ASCENT - Center for Technical Knowledge® 7–31

How To: Attach a Column to the Bottom of a Beam

1. Select a column.
2. In the Modify Structural Columns tab>Modify Column panel, 

click  (Attach Top/Base).
3. In the Options Bar, set the options as needed. If you need to 

add a bearing plate, set the Offset from Attachment value.
4. Select the beam that the column will attach to.

• You can also use this command to attach the base of a beam 
to structural footings. When the footing moves in height, the 
length of the column resizes to match.

Applying
Beam Coping

When one beam connects with another beam you might need to 
modify the connection. In the example shown in Figure 7–49, the 
lower joist-bearing beam runs into the perimeter beam. This is a 
coping situation.

Figure 7–49

How To: Cope Beams

1. Open a 3D view, section, or detail view.
2. Zoom in to a beam to beam (or beam to column) connection.

3. In the Modify tab>Geometry panel, expand  (Cope) and 

select  (Apply Coping).
4. Select the beam to be coped first followed by the 

column/beam from which to cut. The cope is then completed.

• You can change the coping distance by selecting the 
beam and changing the Coping Distance value in 
Properties.
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Editing
Beam Joins

When you add beams to a project there is a default layout to the 
beam joins. However, you might need to override the joins. You 
can do this by adjusting how the beams frame into each other, as 
shown in Figure 7–50.

Figure 7–50

How To: Edit Beam Joins

1. In the Modify tab>Geometry panel, click  (Beam/Column 
Joins). The work area switches to Sketch mode. 

• Only the beams and/or columns that can be changed are
highlighted.

• You cannot use this tool on beams that are attached to
vertical columns.

2. In the Options Bar, specify the types of beams that you want
to work with as shown in Figure 7–51.

Figure 7–51

3. Click the Change Beam Status control to toggle the join as
shown in Figure 7–52.

Figure 7–52
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4. Click  (Beam/Column Joins) again or click  (Modify) to 
toggle the command off.

• If you are mitering a corner, you can lock the miter as 
shown in Figure 7–53.

Figure 7–53

Hint: Join Status

You can modify the Join Status of structural frames to position 
framing that butts against a wall or other beams. Right-click on 
the join control (the circle), select Disallow Join (as shown on 
the left in Figure 7–54), and make the required modifications. 
Click Allow Join to rejoin the elements.

Figure 7–54

• Join Status is a field that can be used in schedules. You can 
modify the join status in the schedule and it will update in 
the model.

LockedUnlocked
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Practice 7b Modify Structural Framing

In this practice, you will modify beam level offsets for correct joist 
bearing and add beam systems using the automatic method 
where you can. Then, sketch beam systems in areas where they 
cannot be automatically placed, as shown in Figure 7–55.

Figure 7–55

Task 1 - Modify beam level offsets.

1. Open Framing-Syracuse-Suites.rvt from the practice files
folder.

2. Open the Structural Plans: TOS-14 ROOF view.

3. Hide the grids.

Practice Objectives

• Modify beam level offsets.

• Add beam systems.
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4. For this level you need to lower the perimeter beams of each 
bay in the North-South direction for the joist bearing. Select 
all of the vertical beams in the plan, excluding the beams 
along the far right, as shown in Figure 7–56.

If you selected bracing 
element, you need to 
filter them out. 

Figure 7–56

5. In Properties, change the Start Level and End Level Offsets 
to (negative) -2-1/2".

6. Click Apply.

7. Open a 3D view and zoom in on one of the top floor 
intersections. The North-South girders should be displayed 
below the East-West girders as shown in Figure 7–57.

Figure 7–57

8. Save the project.
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Task 2 - Add beam systems.

1. Switch to Structural Plans: TOS-14 ROOF view.

2. In the Insert tab>Load from Library panel, click  (Load 
Family).

3. In the Load Family dialog box, navigate to the Revit 2021
Fundamentals for Structure Practice Files>Custom Library
folder and select K-Series Bar Joist-Rod Web.rfa, then click
Open.

4. In the Specify Types dialog box, select 16K7 from the list and
click OK.

5. In the Structure tab>Structure panel, click  (Beam
System). In the Options Bar, set the following parameters:

• Beam Type: 16K7

• Layout Rule: Maximum Spacing

• Maximum Spacing: 6'-0"

6. Use  (Automatic Beam System) to fill in as many bays as 
possible, as shown in Figure 7–58.

Figure 7–58

Do not add 
beam systems 
in these bays
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These errors occur so 
you are aware of 
potential problems, and 
they should be 
addressed. They are an 
important part of using 
the BIM model process.

• If the error shown in Figure 7–59 opens, the space for the 
joist might be too small to be created by the Beam 
System command. Click Delete Type. You can add a 
beam separately as needed.

Figure 7–59

• If you end up with areas where the automatic method 
does not work (such as the example shown in 

Figure 7–60), switch to  (Sketch Beam System). When 
sketching beam systems, in Properties, in the Identity 
Data section, change Tag new members in view to None.

Figure 7–60

7. Switch to the 3D view to see the newly placed joists.

8. Save and close the project.
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7.3 Adding Trusses
A truss can be added to a project using the same basic method 
as placing a beam. Trusses are typically comprised of one or 
more triangular sections, as shown in Figure 7–61. These 
sections are constructed with structural members whose ends 
are connected at joints, which are referred to as nodes. As 
various forces act on these nodes, the triangular shape provides 
structural stability to prevent bending.

Figure 7–61

Truss elements include:

• Bottom Chord, the lower horizontal member.

• Top Chord, the upper horizontal member.

• Web, the series of structural framing elements that
stabilize the truss.

The Top and Bottom Chords fulfill the same function as a 
beam’s top and bottom flanges. The Web takes the place of 
the beam’s continuous plate.

How To: Add Trusses

1. In the Structure tab>Structure panel click  (Structural 
Trusses).

2. In the Type Selector, select the type of truss you want to use.

• Click  (Load Family) and navigate to the Structural 
Trusses folder to add families to the project.

3. In the Modify | Place Truss tab>Draw panel, click  (Line) or

 (Pick Lines) and add the trusses to the project.

Top chord Web members

Bottom chord



Structural Framing

© 2020, ASCENT - Center for Technical Knowledge® 7–39

Attaching
Trusses to

Roofs

Trusses can be attached to roofs or floor slabs. They can also 
follow the slope of the roof and automatically extend to fit, as 
shown in Figure 7–62. 

Figure 7–62

How To: Attach Trusses to Roofs

1. In the Modify | Structural Trusses tab>Modify Truss panel, 

click  (Attach Top/Bottom). 
2. In the Options Bar, set Attach Trusses to Top or Bottom.
3. Select the roof or floor element. The truss attaches to the 

element and follows the angle or slope, as shown in 
Figure 7–63.

Figure 7–63

• The top chord must be one continuous line in the family. If it is 
broken into segments, attaching it might not work properly.

•  Verify that the bottom chord is specified as the bearing chord 
in the element properties of the truss. This ensures that the 
roof loads are carried throughout the truss appropriately. 

• If the roof/floor slab does not cover the length of the truss, an 
error message opens and you might have to detach the truss.
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Setting Framing
Types in
Trusses

When truss families are created they can include structural 
framing members for the chords and webs. However, they often 
just use default members. Therefore, you need to specify the 
precise framing types you want to use in the project. 

In the Type Properties dialog box, select the Structural Framing 
Type from a list of families loaded into the project, as shown in 
Figure 7–64. Set the Structural Framing Type for the Top 
Chords, Vertical Webs, Diagonal Webs, and Bottom Chords. 

Figure 7–64
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• To select an entire truss, ensure that the dashed lines are 
displayed, as shown on the left in Figure 7–65. To select one 
element of the truss, press <Tab> until the element that you 
want to select is highlighted, as shown on the right in 
Figure 7–65.

Figure 7–65

• Individual Truss members are pinned to the truss framework. 
If you want to modify one of these you need to click 

(Prevent or allow change of element position) to unpin 
only that member.

• You can rotate Trusses. and specify if the chords rotate with 
the truss. In Properties, type in a Rotation Angle and select or 
clear Rotate Chords with Truss, as shown in Figure 7–66.

Figure 7–66

Chords not rotated Chords rotated 
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Practice 7c Add Trusses

In this practice, you will set up a truss using specific structural 
framing types for the chords and webs. You will then draw a truss 
and array it across an open span. Finally, you will attach the 
trusses to an existing roof element, as shown in Figure 7–67.

Figure 7–67

Task 1 - Set up a truss type.

1. Open Trusses-Syracuse-Suites.rvt from the practice files
folder.

2. In the Structure tab>Structure panel, click  (Truss).

3. In the Type Selector, select Howe Flat Truss: Standard and

click  (Edit Type).

4. In the Type Properties dialog box, click Duplicate.

5. In the Name dialog box, type Skylight, and click OK.

Practice Objectives

• Set up a truss type.

• Add trusses to a project.

• Attach trusses to a roof.
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6. In the Type Properties dialog box, set the following properties 
as shown in Figure 7–68:

• Top Cords and Bottom Chords:
Set the Structural Framing Type to LL-Double 
Angle:2L6X4X5/8LLBB. 

• Vertical Webs and Diagonal Webs:
Set the Structural Framing Type to LL-Double 
Angle:2L3X2-1/2X1/2LLBB.

Figure 7–68

7. Click OK.

8. Save the project.
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Task 2 - Add trusses.

1. Open the Structural Plans: TOS-14 ROOF view. Some of
the structural framing has been removed in this plan to make
way for a large skylight, as shown in Figure 7–69.

Figure 7–69

2. Start the  (Truss) command.

3. In the Type Selector, verify that the Howe Flat Truss:
Skylight is selected.

4. In Properties, set the Bearing Chord to Bottom and the Truss
Height to 4'-0".

5. Draw the first truss between grid C5 and C7, as shown in
Figure 7–70.
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Figure 7–70

6. Click  (Modify) and select the new truss.

7. In the Modify | Structural Trusses tab>Modify panel, click 

(Array).

8. In the Options Bar: 

• Select  (Linear). 

• Uncheck Group and Associate.

• Set Number to 15.

• Set Move To: to Last.

9. To specify the length of the array, click on Grid C and then on 
Grid E.

Truss

Image has been 
cropped for 
clarification.
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10.Open the 3D Views: Roof and Skylight view and rotate the
view to display the trusses, as shown in Figure 7–71.

Figure 7–71

11. Save the project.

Task 3 - Attach the trusses to a roof.

1. Open the Visibility/Graphic Overrides dialog box and toggle
on Roofs. An existing roof (referencing the location of the
skylight) displays.

2. In the Quick Access Toolbar, click  (Close Inactive 
Windows) so that only the 3D view displays.

3. Open the Elevations (Building Elevations): East and
South views.

4. Type WT to tile the three views and ZA so that they are all
zoomed out fully.

5. Zoom in on the skylight roof in the two elevation views,
similar to that shown in Figure 7–72.
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Figure 7–72

6. In the Elevation: East view, use a crossing window to select 
all of the trusses and other overlapping elements and then 
filter out everything but the trusses.

7. In the Modify |Structural Trusses tab>Modify Truss panel, 

click  (Attach Top/Bottom) and verify in the Options Bar 
that Attach Trusses is set to Top.

8. Select the roof. Allow time for it all to process until the trusses 
expand to touch the roof, as shown in Figure 7–73.

Figure 7–73

9. Make the 3D View: Roof and Skylight view active and type 
TW to return to the tabbed view.

10.Save the project.
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Chapter Review Questions

1. When placing a beam from the Options Bar, which of the
following is NOT an option?

a. Structural Usage

b. Placement Plane

c. 3D Snapping

d. At Columns

2. Which of the following describes a Beam System?

a. Parallel beams grouped together after they are placed.

b. Parallel beams placed at the same time.

c. All beams in a bay grouped together after they are placed.

d. All beams in a bay placed at the same time.

3. In a plan view, which of the following changes the display to
show the stick symbol for beams, as shown in Figure 7–74?

Figure 7–74

a. Detail Level: Coarse

b. Detail Level: Medium

c. Visual Style: Wireframe

d. Visual Style: Hidden
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4. How do you create sloped beams such as those shown in 
Figure 7–75?

Figure 7–75

a. Specify the Slope before you start drawing the beam.

b. Specify the Start/End Level Offset before you start 
drawing the beam.

c. Change the Slope after you have drawn the beam.

d. Change the Start/End Level Offset after you have drawn 
the beam.

5. Where do you assign the structural member types and sizes 
for the components of a truss, such as that shown in 
Figure 7–76? (Select all that apply.)

Figure 7–76

a. In Family Types

b. In Properties

c. In Type Properties

d. In the Options Bar

Slopped beam
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Command Summary

Button Command Location
Clipboard

Copy to 
Clipboard

• Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctr>+C

Paste • Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctr>+<V>

(Paste) Aligned 
to Selected 
Levels

• Ribbon: Modify tab>Clipboard panel

(Paste) Aligned 
to Selected 
View

• Ribbon: Modify tab>Clipboard panel

Structural Framing Elements

Beam • Ribbon: Structure tab>Structure panel

Beam System • Ribbon: Structure tab>Structure panel

Brace • Ribbon: Structure tab>Structure panel

• Shortcut: BR

Structural 
Trusses

• Ribbon: Structure tab>Structure panel

Structural Framing Modification

Apply Coping • Ribbon: Modify tab>Geometry panel,
expand Cope

Attach 
Top/Base

• Ribbon: Modify | Structural Columns>
Modify Column panel

Attach 
Top/Bottom

• Ribbon: Modify | Structural Trusses>
Modify Truss panel

Beam/Column 
Joins

• Ribbon: Modify tab>Geometry panel

Change 
Reference

• Ribbon: Modify | Structural Framing>
Join Tools panel

Connection • Ribbon: Structure tab>Connection
panel

Detach 
Top/Base

• Ribbon: Modify | Structural Columns>
Modify Column panel

Detach 
Top/Bottom

• Ribbon: Modify | Structural Trusses>
Modify Truss panel
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Justification 
Points

• Ribbon: Modify | Structural Framing> 
Justification panel

• Shortcut: JP

Offset • Ribbon: Modify | Structural Framing> 
Justification panel

y Offset • Ribbon: Modify | Structural Framing> 
Justification panel

• Shortcut: JY

z Offset • Ribbon: Modify | Structural Framing> 
Justification panel

• Shortcut: JZ
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