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C h a p t e r

Basic Sketching and Modify 
Tools

Basic sketching, selecting, and modifying tools are the foundation of working with 
all types of elements in the Autodesk® Revit® software. Using these tools with 
drawing aids helps you to place and modify elements to create accurate building 
models. 

Learning Objectives in This Chapter

• Sketch linear elements such as walls, beams, and pipes.

• Ease the placement of elements by incorporating drawing aids such as alignment lines, 
temporary dimensions, and snaps.

• Place Reference Planes as temporary guide lines.

• Use techniques to select and filter groups of elements.

• Modify elements using a contextual tab, Properties, temporary dimensions, and controls.

• Move, copy, rotate, and mirror elements and create array copies in linear and radial patterns. 

• Align, trim, and extend elements with the edges of other elements.

• Split linear elements anywhere along their length.

• Offset elements to create duplicates a specific distance away from the original.
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2.1 Using General Sketching 
Tools

When you start a command, the contextual tab on the ribbon, the 
Options Bar, and Properties (as shown in Figure 2–1) enable you 
to set up features for each new element you are placing in the 
project. As you are working, several features called drawing aids 
display, as shown in Figure 2–1. They help you to create designs 
quickly and accurately. 

Figure 2–1

• In Autodesk Revit, you are most frequently creating 3D model
elements rather than 2D sketches. These tools work with
both 3D and 2D elements in the software.

Draw Tools Many linear elements (such as walls, beams, ducts, pipes, and 
conduits) are modeled using the tools on the contextual tab on 
the Draw panel. Other elements (such as floors, ceilings, roofs, 
and slabs) have boundaries that are sketched using many of the 
same tools. Draw tools are also used when you create details or 
schematic drawings. 

The exact tools vary 
according to the 
element being modeled.

Two methods are available: 

• Draw the element using a geometric form.

• Pick an existing element (such as a line, face, or wall) as
the basis for the new element’s geometry and position.

Contextual tab

Options Bar

Drawing aids

Properties
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How To: Create Linear Elements

1. Start the command you want to use.
2. In the contextual tab>Draw panel (shown in Figure 2–2), 

select a drawing tool. 
3. Select points to define the elements or watch the Status Bar, 

in the lower left corner, for hints on what to do.

You can change from 
one Draw tool shape to 
another in the middle of 
a command.

Figure 2–2

4. Finish the command using one of the standard methods:

• Click (Modify).

• Press <Esc> twice.

• Start another command.

Draw Options

When you are in Drawing mode, several options display in the 
Options Bar, as shown in Figure 2–3.

Different options display 
according to the type of 
element that is selected 
or the command that is 
active.

Figure 2–3

• Chain: Controls how many segments are created in one 
process. If this option is not selected, the Line and Arc tools 
only create one segment at a time. If it is selected, you can 
continue adding segments until you press <Esc> or select the 
command again.

• Offset: Enables you to enter values so you can create linear 
elements at a specified distance from the selected points or 
element. 

• Radius: Enables you to enter values when using a radial tool 
or to add a radius to the corners of linear elements as you 
sketch them.
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Draw Tools

Line Draws a straight line defined by the first and 
last points. If Chain is enabled, you can 
continue selecting end points for multiple 
segments.

Rectangle Draws a rectangle defined by two opposing 
corner points. You can adjust the dimensions 
after selecting both points.

Inscribed 
Polygon

Draws a polygon inscribed in a hypothetical 
circle with the number of sides specified in the 
Options Bar.

Circumscribed 
Polygon

Draws a polygon circumscribed around a 
hypothetical circle with the number of sides 
specified in the Options Bar.

Circle Draws a circle defined by a center point and 
radius.

Start-End-
Radius Arc

Draws a curve defined by a start, end, and 
radius of the arc. The outside dimension shown 
is the included angle of the arc. The inside 
dimension is the radius.

Center-ends Arc Draws a curve defined by a center, radius, and 
included angle. The selected point of the radius 
also defines the start point of the arc.

Tangent End 
Arc

Draws a curve tangent to another element. 
Select an end point for the first point, but do not 
select the intersection of two or more elements. 
Then select a second point based on the 
included angle of the arc.

Fillet Arc Draws a curve defined by two other elements 
and a radius. Because it is difficult to select the 
correct radius by clicking, this command 
automatically moves to edit mode. Select the 
dimension and then modify the radius of the 
fillet.

Spline Draws a spline curve based on selected points. 
The curve does not actually touch the points 
(Sketches, Model and Detail Lines only).

Ellipse Draws an ellipse from a primary and secondary 
axis (Walls, Sketches, Model and Detail Lines 
only).

Partial Ellipse Draws only one side of the ellipse, like an arc. 
A partial ellipse also has a primary and 
secondary axis (Sketches, Model and Detail 
Lines only).
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Pick Tools

Drawing Aids As soon as you start sketching or placing elements, three 
drawing aids display, as shown in Figure 2–4: 

• Alignment line

• Temporary dimensions

• Snaps

These aids are available with most modeling and many 
modification commands.

Figure 2–4

Alignment lines display as soon as you select your first point. 
They help keep lines horizontal, vertical, or at a specified angle. 
They also line up with the implied intersections of walls and other 
elements.

• Hold <Shift> to force the alignments to be orthogonal 
(90° angles only).

Pick 
Lines

Use this option to select existing linear elements in the 
project. This is useful when you start the project from an 
imported 2D drawing.

Pick 
Face

Use this option to select the face of a 3D massing 
element (walls and 3D views only).

Pick 
Walls

Use this option to select an existing wall in the project to 
be the basis for a new sketch line (floors, ceilings, etc.).

Alignment line

Snaps

Temporary dimensions
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Temporary dimensions display to help place elements at the 
correct length, angle and location.

• You can type in a value, or move the cursor until you see the
dimension you want, or you can place the element and then
modify the value as needed.

• The length and angle increments shown vary depending on
how far in or out the view is zoomed.

• For Imperial measurements (feet and inches), the software
uses a default of feet. For example, when you type 4 and
press <Enter>, it assumes 4'-0". For a distance such as 4'-6",
you can type any of the following: 4'-6", 4'6, 4-6, or 4 6 (the
numbers separated by a space). To indicate distances less
than one foot, type the inch mark (") after the distance, or
enter 0, a space, and then the distance.

Snaps are key points that help you reference existing elements 
to exact points when modeling, as shown in Figure 2–6.

Figure 2–6

• When you move the cursor over an element, the snap symbol
displays. Each snap location type displays with a different
symbol.

Hint: Temporary Dimensions and Permanent Dimensions

Temporary dimensions disappear as soon as you finish adding 
elements. If you want to make them permanent, select the 

dimension symbol ( ), as shown in Figure 2–5.

Figure 2–5
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Hint: Snap Settings and Overrides

In the Manage tab>Settings panel, click  (Snaps) to open 
the Snaps dialog box, which is shown in Figure 2–7. The Snaps 
dialog box enables you to set which snap points are active, and 
set the dimension increments displayed for temporary 
dimensions (both linear and angular).

Figure 2–7

• Keyboard shortcuts for each snap can be used to override 
the automatic snapping.Temporary overrides only affect a 
single pick, but can be very helpful when there are snaps 
nearby other than the one you want to use. 
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Reference
Planes

As you develop designs in the Autodesk Revit software, there 
are times when you need lines to help you define certain 
locations. You can sketch reference planes (displayed as dashed 
green lines) and snap to them whenever you need to line up 
elements. For the example shown in Figure 2–8, the lighting 
fixtures in the reflected ceiling plan are placed using reference 
planes. 

Reference planes do 
not display in 3D views.

• To insert a reference plane, in the Architecture, Structure, or

Systems tab>Work Plane panel, click  (Reference Plane) 
or type <RP>. 

Figure 2–8

• Reference planes display in associated views because they
are infinite planes, and not just lines.

• You can name reference planes by clicking on <Click to
name> and typing in the text box, as shown in Figure 2–9.

Figure 2–9

• If you sketch a reference plane in Sketch Mode (used with
floors and similar elements), it does not display once the
sketch is finished.

• Reference planes can have different line styles if they have
been defined in the project. In Properties, select a style from
the Subcategory list.
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Hint: Model Line vs. Detail Line

While most of the elements that you create are representations 
of actual building elements, there are times you may need to 
add lines to clarify the design intent. These can be either detail 
lines, as shown in Figure 2–10, or model lines. Detail lines are 
also useful as references because they are only reflected in 
the view in which you sketch them.

Figure 2–10

• A model line (Architecture or Structure tab>Model panel> 

 (Model Line)) functions as a 3D element and displays 
in all views. 

• A detail line (Annotate tab>Detail panel>  (Detail Line)) 
is strictly a 2D element that only displays in the view in 
which it is drawn.

• In the Modify contextual tab, as shown in Figure 2–11, 
select a Line Style and then the Draw tool that you want to 
use to draw the model or detail line.

Figure 2–11
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2.2 Editing Elements
Building design projects typically involve extensive changes to 
the model. The Autodesk Revit software was designed to make 
such changes quickly and efficiently. You can change an element 
using the following methods, as shown in Figure 2–12:

• Type Selector enables you to specify a different type. This is
frequently used to change the size and/or style of the
elements.

• Properties enables you to modify the information
(parameters) associated with the selected elements.

• The contextual tab in the ribbon contains the Modify
commands and element-specific tools.

• Temporary dimensions enable you to change the element’s
dimensions or position.

• Controls enable you to drag, flip, lock, and rotate the element.

• Shape handles enable you to drag elements to modify their
height or length.

Figure 2–12

• To delete an element, select it and press <Delete>, right-click

and select Delete, or in the Modify panel, click  (Delete).

Temporary 
dimensions

Controls

Type Selector

Properties

Contextual tab

Shape handles
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Working with Controls and Shape Handles

When you select an element, various controls and shape 
handles display depending on the element and view. For 
example, in plan view you can use controls to drag the ends of a 
wall and change its orientation. You can also drag the wall ends 
in a 3D view, and you can also use the arrow shape handles to 
change the height of the wall, as shown in Figure 2–13.

Figure 2–13

• If you hover the cursor over the control or shape handle, a 
tool tip displays showing its function.
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Hint: Editing Temporary Dimensions

Temporary dimensions automatically link to the closest wall. To 
change this, drag the Witness Line control, as shown in 
Figure 2–14, to connect to a new reference. You can also click 
on the control to toggle between justifications in the wall.

Figure 2–14

• The new location of a temporary dimension for an element
is remembered as long as you are in the same session of
the software.

Before - connected to wall

After - connected to grid line
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Selecting
Multiple

Elements

• Once you have selected at least one element, hold <Ctrl> 
and select another item to add it to a selection set.

• To remove an element from a selection set, hold <Shift> and 
select the element.

• If you click and drag the cursor to window around elements, 
you have two selection options, as shown in Figure 2–15. If 
you drag from left to right, you only select the elements 
completely inside the window. If you drag from right to left, 
you select elements both inside and crossing the window.

Figure 2–15

• If several elements are on or near each other, hover your 
cursor over an edge and press <Tab> to cycle through them 
before you click. If there are elements that might be linked to 
each other, such as walls that are connected, pressing <Tab> 
selects the chain of elements.

• Press <Ctrl>+<Left Arrow> to reselect the previous selection 
set. You can also right-click in the view window with nothing 
selected and select Select Previous.

• To select all elements of a specific type, right-click on an 
element and select Select All Instances>Visible in View or 
In Entire Project, as shown in Figure 2–16. For example, if 
you select a column of a specific size and use this command, 
only the columns of the same size are selected.

Figure 2–16

• You can save selections and use them again. For more 
information see Appendix A.1 Selection Sets.

Crossing: right to leftWindow: left to right
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Filtering
Selection Sets

When multiple element categories are selected, the Multi-Select 
contextual tab opens in the ribbon. This gives you access to all of 
the Modify tools, and the Filter command. The Filter command 
enables you to specify the types of elements to select. For 
example, you might only want to select columns, as shown in 
Figure 2–19.

Hint: Measuring Tools

When modifying a model, it is useful to know the distance 
between elements. This can be done with temporary 
dimensions, or more frequently, by using the measuring tools 
found in the Quick Access Toolbar or on the Modify tab> 
Measure panel, as shown in Figure 2–17.

Figure 2–17

• (Measure Between Two References) - Select two
elements and the measurement displays.

• (Measure Along An Element) - Select the edge of a
linear element and the total length displays. Use <Tab> to
highlight other elements and then click to measure along all
of them, as shown in Figure 2–18.

Figure 2–18

• References include any snap point, wall lines, or other parts
of elements (such as door center lines).
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Figure 2–19

How To: Filter a Selection Set

1. Select everything in the area.
2. in the Modify | Multi-Select tab>Selection panel, or in the 

Status Bar, click  (Filter). The Filter dialog box opens, as 
shown in Figure 2–20.

The Filter dialog box 
displays all types of 
elements in the original 
selection.

 
Figure 2–20

3. Click Check None to clear all of the options or Check All to 
select all of the options. You can also select or clear 
individual categories as needed.

4. Click OK. The selection set is now limited to the elements 
you specified.

• The number of elements selected displays on the right end of 
the Status Bar and in Properties.
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Hint: Selection Options

You can control how the software selects specific elements in a 
project by toggling selection options on and off on the Status 
Bar, as shown in Figure 2–21. Alternatively, in any tab on the 
ribbon that has the Modify command, expand the Select panel’s 
title and select the option.

Figure 2–21

• Select links: When toggled on, you can select linked
CAD drawings or Autodesk Revit models. When it is toggled
off, you cannot select them when using Modify or Move.

• Select underlay elements: When toggled on, you can
select underlay elements. When toggled off, you cannot
select them when using Modify or Move.

• Select pinned elements: When toggled on, you can
selected pinned elements. When toggled off, you cannot
select them when using Modify or Move.

• Select elements by face: When toggled on you can
select elements (such as the floors or walls in an elevation)
by selecting the interior face or selecting an edge. When
toggled off, you can only select elements by selecting an
edge.

• Drag elements on selection: When toggled on, you
can hover over an element, select it, and drag it to a new
location. When toggled off, the Crossing or Box select mode
starts when you press and drag, even if you are on top of an
element. Once elements have been selected they can still
be dragged to a new location.
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Practice 2a Sketch and Edit Elements

In this practice, you will use the Wall command along with 
sketching tools and drawing aids, such as temporary dimensions 
and snaps. You will use the Modify command and modify the 
walls using grips, temporary dimensions, the Type Selector, and 
Properties. You will add a door and modify it using temporary 
dimensions and controls. The completed model is shown in 
Figure 2–22.

Figure 2–22

Task 1 - Use sketching tools and temporary dimensions to 
model and modify walls.

1. In the File Tab, click  (New)>  (Project). If you are on 
the Home screen, in the MODELS section, click New....

2. In the New Project dialog box, select Imperial-Architectural 
Template in the Template file drop-down list, and click OK.

3. In the Quick Access Toolbar, click  (Save). When 
prompted, name the project Starting Project.rvt.

4. In the Architecture tab>Build panel, click  (Wall) or type 
the shortcut <WA>.

Practice Objective

• Use sketch tools and drawing aids.
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5. In the Modify | Place Wall tab>Draw panel, click

(Rectangle) and sketch a rectangle approximately
100' x 70'. Drag your mouse from right to left in a diagonal
direction. You do not have to be precise because you can
change the dimensions later.

6. Note that the dimensions are temporary. Select the vertical
dimension text and type 70'-0", as shown in Figure 2–23.
Press <Enter>.

Figure 2–23

7. The dimensions are still displayed as temporary. Click the
dimension controls of both the dimensions to make them
permanent, as shown in Figure 2–24.

Figure 2–24

8. In the Select panel, click  (Modify). You can also use one of
the other methods to switch to Modify:

• Type the shortcut <MD>.

• Press <Esc> once or twice.
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9. Select either vertical wall. The horizontal dimension becomes 
active (changes to blue). Click the dimension text and type 
100'-0", as shown in Figure 2–25.

Figure 2–25

10.Click in an empty space in the view to end the selection. You 
are still in the Modify command.

11. In the Architecture tab>Build panel, click  (Wall). In the 

Draw panel, verify that  (Line) is selected. Sketch a wall 
horizontally from midpoint to midpoint of the vertical walls.

12.Draw another horizontal wall 8'-0" above the middle 
horizontal wall. You can use temporary dimensions to adjust 
if needed.

13.Draw a vertical wall exactly 16'-0" from the left wall, as shown 
in Figure 2–26.

Figure 2–26
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14. In the Draw panel, click  (Circle) and sketch a 14'-0" 
radius circular wall at the midpoint of the lower interior 
horizontal wall, as shown in Figure 2–27.

Figure 2–27

15.Click  (Modify) to finish the command.

16.Hover the cursor over one of the outside walls, press <Tab>
to highlight the chain of outside walls, and click to select the
walls.

17. In the Type Selector, select Basic Wall: Generic-12", as
shown in Figure 2–28. The thickness of the outside walls
change.

Figure 2–28

18.Click in an empty space in the view to release the selection.

Click to expand 
the Type Selector
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19.Select the vertical interior wall. In the Type Selector, change 
the wall to one of the small interior partition styles.

20.Click in an empty space in the view to release the selection.

21.Save the project.

Task 2 - Add and modify a door.

1. Zoom in on the room in the upper left corner.

2. In the Architecture tab>Build panel, click  (Door) or type 
the shortcut <DR>.

3. In the Modify | Place Door tab>Tag panel, click  (Tag on 
Placement).

4. Place a door anywhere along the wall in the hallway.

5. Click  (Modify) to finish the command.

6. Select the door. Use temporary dimensions to move it so that 
it is 2'-6" from the right interior vertical wall. If needed, use 
controls to flip the door so that it swings into the room, as 
shown in Figure 2–29.

Figure 2–29

7. Type <ZE> to zoom out to the full view.

8. Save and close the project.

Temporary 
dimensions

Flip control
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2.3 Working with Basic Modify 
Tools

The basic modifying tools, Move, Copy, Rotate, Mirror, and 
Array, can be used with individual elements or any selection of 
elements. They are found in the Modify panel (shown in 
Figure 2–30), in the Modify tab, and in contextual tabs.

Figure 2–30

• For these modify commands, you can either select the
elements and start the command, or start the command,
select the elements, and press <Enter> to finish the selection
and move to the next step in the command.

Moving
and Copying

Elements

The Move and Copy commands enable you to select the 
element(s) and move or copy them from one place to another. 
You can use alignment lines, temporary dimensions, and snaps 
to help place the elements, as shown in Figure 2–31.

Figure 2–31

How To: Move or Copy Elements

1. Select the elements you want to move or copy.

2. In the Modify panel, click  (Move) or  (Copy).
Alternatively, you can type <MV> for Move and <CO> for
Copy. A boundary box displays around the selected
elements.

3. Select a start point on or near the element.
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4. Select a second point. Use alignment lines and temporary 
dimensions to help place the elements.

5. When you are finished, you can start another modify 
command using the elements that remain selected, or select 

 (Modify) to end the command.

• You can drag elements to new locations without starting the 
Move command. Holding <Ctrl> and dragging copies the 
element. This is quick but not very precise.

Move/Copy Elements Options

The Move and Copy commands have several options that 
display in the Options Bar, as shown in Figure 2–32. 

Figure 2–32
 

• These commands only work in the current view, not between 
views or projects. To copy between views or projects, In the 

Modify tab>Clipboard panel use  (Copy to Clipboard), 

(Cut to the Clipboard) and  (Paste from Clipboard).

Constrain Restricts the movement of the cursor to horizontal or 
vertical, or along the axis of an item that is at an angle. This 
keeps you from selecting a point at an angle by mistake. 
Constrain is off by default.

Disjoin 
(Move only)

Breaks any connections between the elements being 
moved and other elements. If Disjoin is on, the elements 
move separately. If it is off, the connected elements also 
move or stretch. Disjoin is off by default.

Multiple 
(Copy only)

Enables you to make multiple copies of one selection. 
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Rotating
Elements

The Rotate command enables you to rotate selected elements 
around a center point or origin, as shown in Figure 2–34. You 
can use alignment lines, temporary dimensions, and snaps to 
help specify the center of rotation and the angle. You can also 
create copies of the element as it is being rotated.

Figure 2–34

How To: Rotate Elements

1. Select the element(s) you want to rotate.

2. In the Modify panel, click  (Rotate) or type the 
shortcut <RO>.

Hint: Pinning Elements

If you do not want elements to be moved, you can pin them in 
place, as shown in Figure 2–33. Select the elements and in the 

Modify tab, in the Modify panel, click  (Pin) or type the 
shortcut <PN>. Pinned elements can be copied, but not moved. 
If you try to delete a pinned element, a warning dialog displays 
reminding you that you must unpin the element before the 
command can be started.

Figure 2–33

Select the element and click  (Unpin) or type the shortcut 
<UP> to unpin the element.
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3. The center of rotation is automatically set to the center of the 
element or group of elements, as shown on the left in 
Figure 2–35. To change the center of rotation, as shown on 
the right in Figure 2–35, use the following:

• Drag the  (Center of Rotation) control to a new point.

• In the Options Bar, next to Center of rotation, click Place 
and use snaps to move it to a new location.

• Press <Spacebar> to select the center of rotation and 
click to move it to a new location.

To start the Rotate 
command with a prompt 
to select the center of 
rotation, select the 
elements first and type 
<R3>.

Figure 2–35

4. In the Options Bar, specify if you want to make a Copy (select 
Copy), type an angle in the Angle field (shown in 
Figure 2–36), and press <Enter>. You can also specify the 
angle on screen using temporary dimensions.

Figure 2–36

5. The rotated element(s) remain highlighted, enabling you to 
start another command using the same selection, or click 

(Modify) to finish.

• The Disjoin option breaks any connections between the 
elements being rotated and other elements. If Disjoin is on 
(selected), the elements rotate separately. If it is off (cleared), 
the connected elements also move or stretch, as shown in 
Figure 2–37. Disjoin is toggled off by default.

Figure 2–37

Disjoin onDisjoin off
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Mirroring
Elements

The Mirror command enables you to mirror elements about an 
axis defined by a selected element, as shown in Figure 2–38, or 
by selected points.

Figure 2–38

How To: Mirror Elements

1. Select the element(s) to mirror.
2. In the Modify panel, select the method you want to use:

• Click  (Mirror - Pick Axis) or type the shortcut <MM>. 
This prompts you to select an element as the Axis of 
Reflection (mirror line).

• Click  (Mirror - Draw Axis) or type the shortcut <DM>. 
This prompts you to select two points to define the axis 
about which the elements mirror.

3. The new mirrored element(s) remain highlighted, enabling
you to start another command, or return to Modify to finish.

• By default, the original elements that were mirrored remain.
To delete the original elements, clear the Copy option in the
Options Bar.

Hint: Scale

The Autodesk Revit software is designed with full-size 
elements. Therefore, not much should be scaled. For example, 
scaling a wall increases its length but does not impact the 
width, which is set by the wall type. However, you can use 

(Scale) in reference planes, images, and imported files 
from other programs.



Basic Sketching and Modify Tools

© 2021, ASCENT - Center for Technical Knowledge® 2–27

Creating Linear
and Radial

Arrays

The Array command creates multiple copies of selected 
elements in a linear or radial pattern, as shown in Figure 2–39. 
For example, you can array a row of columns to create a row of 
evenly spaced columns on a grid, or array a row of parking 
spaces. The arrayed elements can be grouped or placed as 
separate elements.

A linear array creates a 
straight line pattern of 
elements, while a radial 
array creates a circular 
pattern around a center 
point.

Figure 2–39

How To: Create a Linear Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array) or type the shortcut 
<AR>. 

3. In the Options Bar, click  (Linear).
4. Specify the other options as needed.
5. Select a start point and an end point to set the spacing and 

direction of the array. The array is displayed.
6. If Group and Associate is selected, you are prompted again 

for the number of items, as shown in Figure 2–40. Type a 
new number or click on the screen to finish the command.

Figure 2–40

• To make a linear array in two directions, you need to array 
one direction first, select the arrayed elements, and then 
array them again in the other direction.

Linear Array

Radial Array
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Array Options

In the Options Bar, set up the Array options for Linear Array 
(top of Figure 2–41) or Radial Array (bottom of Figure 2–41).

Figure 2–41

How To: Create a Radial Array

1. Select the element(s) to array.

2. In the Modify panel, click  (Array).

3. In the Options Bar, click  (Radial).

4. Drag  (Center of Rotation) or use Place to the move the
center of rotation to the appropriate location, as shown in
Figure 2–42.

Remember to set the 
Center of Rotation 
control first, before 
specifying the angle.

Figure 2–42

5. In the Options Bar, type an angle and press <Enter>, or
specify the rotation angle by selecting points on the screen.

6. Specify the other options as needed.

Group and 
Associate

Creates an array group element out of all arrayed elements. 
Groups can be selected by selecting any elements in the 
group.

Number Specifies how many instances you want in the array.

Move To: 2nd specifies the distance or angle between the center 
points of the two elements.

Last specifies the overall distance or angle of the entire 
array.

Constrain Restricts the direction of the array to only vertical or 
horizontal (Linear only).

Angle Specifies the angle (Radial only).

Center of 
rotation 

Specifies a location for the origin about which the elements 
rotate (Radial only).

Center of rotation
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Modifying Array Groups

When you select an element in an array that has been grouped, 
you can change the number of instances in the array, as shown 
in Figure 2–43. For radial arrays you can also modify the 
distance to the center.

Figure 2–43

• Dashed lines surround the element(s) in a group, and the XY 
control lets you move the origin point of the group.

If you move one of the elements in the array group, the other 
elements move in response based on the distance and/or angle, 
as shown in Figure 2–44.

 
Figure 2–44

• To remove the array constraint on the group, select all of the 
elements in the array group and, in the Modify contextual 

tab>Group panel, click  (Ungroup).

• If you select an individual element in an array and click 

(Ungroup), the element you selected is removed from the 
array, while the rest of the elements remain in the array 
group.

• You can use  (Filter) to ensure that you are selecting only 
Model Groups. 
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Practice 2b Work with Basic Modify Tools

In this practice, you will create a series of offices using the Copy 
and Mirror commands. You will then array desks around a 
circular wall, then rotate and array a pair of columns across the 
front of a simple building, as shown in Figure 2–45.

Figure 2–45

Task 1 - Modify walls and doors.

1. Open the project Simple-Building-1.rvt from the practice
files folder.

2. Select the top arc of the circular wall.

Remember that you can 
also press <Delete>, or 
right-click and select 
Delete.

3. In the Modify panel, click  (Delete). The walls that the 
circular wall crossed are automatically cleaned up.

4. Select the vertical interior wall, door, and door tag. Hold
<Ctrl> to select more than one element, or use a selection
window.

5. In the Modify panel, click  (Copy) or type the shortcut 
<CO>.

Practice Objective

• Use basic modify tools such as Move, Copy, Rotate, and Array
Elements.
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6. In the Options Bar, select Constrain and Multiple (adding a 
check mark means the setting is on). The Constrain option 
forces the cursor to move only horizontally or vertically.

7. Select the start point and, using the temporary dimensions, 
pick the end point 16'-0" away from the start point, as shown 
in Figure 2–46. The wall, door, and door tag are copied to the 
right and the door tag displays 2.

Figure 2–46

Start point

End point

Temporary 
dimension
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8. The new elements are still selected and you can continue to
copy them. Use similar start and end points for the additional
copies, or type 16 (16'-0") and press <Enter> to set the
distance between each copy. The final layout is shown in
Figure 2–47.

Figure 2–47

9. Click  (Modify) to finish the command.

10.Zoom in on the room to the far right.

11. Select door #5 and the associated door tag.

12. In the Modify panel, click  (Mirror - Pick Axis) or type the 
shortcut <MM>. In the Options Bar, ensure that Copy is 
selected.

13.Select the vertical wall between the rooms as the mirror axis.
An alignment line displays along the center of the wall. Place
the new door, as shown in Figure 2–48.

Figure 2–48

14.Click in an empty space in the view to release the selection.

15.Save the project.

Mirror axis
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Task 2 - Add reference planes and use them to place a 
component.

1. In the Architecture tab>Work plane panel, click 

(Reference Plane).

2. Draw two reference planes, as shown in Figure 2–49. The 
vertical one starts at the midpoint of the wall. Place the 
horizontal plane 20'-0" from the horizontal wall, or place the 
reference plane at any distance and then use temporary 
dimensions to place it more exactly.)

Figure 2–49

3. In the Architecture tab>Build panel, click (Component) or 
type <CM>.

4. In the Properties, in the Type Selector, verify that 
Desk: 60" x  30" is selected, as shown in Figure 2–50.

Figure 2–50

5. As you move the cursor you can see that the desk is 
horizontal. Press <Spacebar> to rotate the desk 90°.
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6. Place the desk at the intersection of the two reference
planes, as shown in Figure 2–51. Zoom in as needed to
ensure that you are connected to the reference planes, and
not to any other alignment lines.

Figure 2–51

7. Click  (Modify) and select the desk you just placed.

Type <SM> to snap to 
Midpoint and <SE> to 
snap to Endpoint.

8. In the Modify panel, click  (Move). On the Options Bar, 
select Constrain.

9. Select the start point of the move as the midpoint of the desk
and the end point as the vertical reference plane, as shown in
Figure 2–52.

Figure 2–52

10.Save the project.

First pick point

Second pick point
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Task 3 - Create a radial array.

1. Select the desk. 

2. In the Modify panel, click  (Array) or type the shortcut 
<AR>.

3. In the Options Bar, click  (Radial). Clear the Group and 
associate option, set the Number field to 15, and set the 
Move to: to 2nd.

4. Drag the center of rotation from the center of the desk to the 
midpoint of the wall, as shown in Figure 2–53. Alternatively, 
you can select Place from the Options Bar and snap to the 
midpoint of the wall.

 
Figure 2–53

5. Return to the Options Bar and set the Angle to 360. Press 
<Enter>. The array displays as shown in Figure 2–54.

Sometimes it is easier to 
create more elements 
then you need, and then 
delete the ones that are 
not required, as is done 
in this example.

Figure 2–54
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6. Delete all of the desks that are outside of the room.

7. Zoom out to display the entire view.

8. Save the project.

Task 4 - Place columns in appropriate locations.

1. Pan and zoom to the lower right side of the model. Two
columns (one architectural and one structural) have been
added to the project.

2. Select the square architectural column and drag it over so
that it lines up with the wall, as shown in Figure 2–55. Use the
temporary dimension to set the distance off the wall to 8'-0".

3. Place the structural column at the center of the architectural
column, as shown in Figure 2–56, using the Midpoint and
Extension snaps.

4. Save the project.

Task 5 - Rotate and array the columns.

1. Click  (Modify) and select the two columns.

2. In the Modify | Multi-Select tab>Modify panel, click

(Rotate) or type the shortcut <RO>.

3. For the start ray, click horizontally, as shown in Figure 2–57.

Figure 2–55 Figure 2–56
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4. Move the ray line until you see the temporary dimension 
45.00°, as shown in Figure 2–58.

5. With the two columns still selected, in the Modify | 

Multi-Select tab>Modify panel, click  (Array) or type the 
shortcut <AR>.

6. In the Options Bar, click  (Linear), clear Group and 
Associate, set the Number to 10, and set Move To: to Last.

7. For the start point, click the midpoint of the columns. For the 
endpoint of the array, select the Horizontal and Extension 
of the center of the far right wall as shown in Figure 2–59.

Figure 2–59

8. Zoom out to display the entire building.

9. The columns are arrayed evenly across the front of the 
building as shown in Figure 2–60.

Figure 2–60

10.Save and close the project.

Figure 2–57 Figure 2–58
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2.4 Working with Additional 
Modify Tools

As you work on a project, some additional tools found on the 
Modify tab>Modify panel, as shown in Figure 2–61, can help you 
with placing, modifying, and constraining elements. Align can be 
used with a variety of elements, while Split Element, 
Trim/Extend, and Offset can only be used with linear elements.

Figure 2–61

Aligning
Elements

The Align command enables you to line up one element with 
another, as shown in Figure 2–62. Most Autodesk Revit 
elements can be aligned. For example, you can line up the tops 
of windows with the top of a door, or line up furniture with a wall.

Figure 2–62

How To: Align Elements

1. In the Modify tab>Modify panel, click  (Align) or type the 
shortcut <AL>.

2. Select a line or point on the element that is going to remain
stationary. For walls, press <Tab> to select the correct wall
face.

3. Select a line or point on the element to be aligned. The
second element moves into alignment with the first one.

• The Align command works in all model views, including
parallel and perspective 3D views.

Second PickFirst Pick

Before During After
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• You can lock alignments so that the elements move together 
if either one is moved. Once you have created the alignment, 
a padlock is displayed. Click on the padlock to lock it, as 
shown in Figure 2–63.

Locking elements 
enlarges the size of the 
project file, so use this 
option carefully.

Figure 2–63

• From the Options Bar, select Multiple Alignment to select 
multiple elements to align with the first element. You can also 
hold <Ctrl> to select multiple elements to align.

• For walls, you can specify if you want the command to prefer 
Wall centerlines, Wall faces, Center of core, or Faces of 
core, as shown in Figure 2–64. The core refers to the 
structural members of a wall as opposed to facing materials, 
such as sheet rock.

Figure 2–64

Splitting Linear
Elements

The Split Element command enables you to break a linear 
element at a specific point. You can use alignment lines, snaps, 
and temporary dimensions to help place the split point. After you 
have split the linear element, you can use other editing 
commands to modify the two parts, or change the type of one 
part, as shown with walls in Figure 2–65. You can split walls in 
plan, elevation, or 3D views.

Figure 2–65

• The Split with Gap command only works when splitting 
walls.
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How To: Split Linear Elements

1. In the Modify tab>Modify panel, click  (Split Element) or 
type the shortcut <SL>.

2. In the Options Bar, select or clear the Delete Inner Segment
option.

3. Move the cursor to the point you want to split and select the
point.

4. Repeat for any additional split locations.
5. Modify the elements that were split, as needed.

• The Delete Inner Segment option is used when you select
two split points along a linear element. When the option is
selected, the segment between the two split points is
automatically removed.

• An additional option,  (Split with Gap), splits the linear
element at the point you select, as shown in Figure 2–66, but
also creates a Joint Gap specified in the Options Bar.

This command is 
typically used with 
structural precast walls.

Figure 2–66

Trimming and
Extending

There are three trim/extend methods that you can use with linear 
elements: Trim/Extend to Corner, Trim/Extend Single 
Element, and Trim/Extend Multiple Elements.

• When selecting elements to trim, click the part of the element
that you want to keep. The opposite part of the line is then
trimmed.

How To: Trim/Extend to Corner

1. In the Modify tab>Modify panel, click  (Trim/Extend to 
Corner) or type the shortcut <TR>.

2. Select the first linear element on the side you want to keep.

Split

Split with Gap
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3. Select the second linear element on the side you want to 
keep, as shown in Figure 2–67.

Figure 2–67

How To: Trim/Extend a Single Element

1. In the Modify tab>Modify panel, click  (Trim/Extend Single 
Element).

2. Select the cutting or boundary edge.
3. Select the linear element to be trimmed or extended, as 

shown in Figure 2–68.

Figure 2–68

How To: Trim/Extend Multiple Elements

1. In the Modify tab>Modify panel, click  (Trim/Extend 
Multiple Elements).

2. Select the cutting or boundary edge.

Pick 1

Pick 2

Pick 1

Pick 2



Autodesk Revit 2022 Architecture Fundamentals

2–42 © 2021, ASCENT - Center for Technical Knowledge®

3. Select the linear elements that you want to trim or extend by
selecting one at a time, or by using a crossing window, as
shown in Figure 2–69. For trimming, select the side you want
to keep.

Figure 2–69

• You can click in an empty space in the view to clear the
selection and select another cutting edge or boundary.

Offsetting
Elements

The Offset command is an easy way of creating parallel copies 
of linear elements at a specified distance, as shown in 
Figure 2–70. Walls, beams, braces, and lines are among the 
elements that can be offset.

Figure 2–70

• If you offset a wall that has a door or window embedded in it,
the elements are copied with the offset wall.

The offset distance can be set by typing the distance (Numerical 
method) shown in Figure 2–71 or by selecting points on the 
screen (Graphical method).

Figure 2–71

Pick 3

Pick 2

Pick 1
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How To: Offset Using the Numerical Method

The Copy option (which 
is on by default) makes 
a copy of the element 
being offset. If this 
option is not selected, 
the Offset command 
moves the element the 
set offset distance.

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut <OF>.

2. In the Options Bar, select the Numerical option.
3. In the Options Bar, type the required distance in the Offset 

field.
4. Move the cursor over the element you want to offset. A 

dashed line previews the offset location. Move the cursor to 
flip the sides, as needed.

5. Click to create the offset.
6. Repeat Steps 4 and 5 to offset other elements by the same 

distance, or to change the distance for another offset.

• With the Numerical option, you can select multiple 
connected linear elements for offsetting. Hover the cursor 
over an element and press <Tab> until the other related 
elements are highlighted. Select the element to offset all of 
the elements at the same time.

How To: Offset Using the Graphical Method

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut <OF>.

2. In the Options Bar, select Graphical.
3. Select the linear element to offset.
4. Select two points that define the distance of the offset and 

which side to apply it. You can type an override in the 
temporary dimension for the second point.

• Most linear elements connected at a corner automatically trim 
or extend to meet at the offset distance, as shown in 
Figure 2–72.

Figure 2–72
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Practice 2c Work with Additional Modify 
Tools

In this practice, you will split a wall into three parts and delete the 
middle portion. You will offset walls and then trim or extend them 
to form new rooms. You will then align the new walls to match 
existing walls.as shown in Figure 2–73.

Figure 2–73

Task 1 - Split and remove walls.

1. Open the project Simple-Building-2.rvt from the practice
files folder.

2. In the Modify tab>Modify panel, click  (Split Element) or 
type the shortcut <SL>.

Practice Objective

• Align, Split, Trim/Extend, and Offset elements.



Basic Sketching and Modify Tools

© 2021, ASCENT - Center for Technical Knowledge® 2–45

3. In the Options Bar, select Delete Inner Segment.

4. Click on the horizontal wall where it intersects with the curved 
wall at both ends. The wall segment between these points is 
removed, as shown in Figure 2–74.

Figure 2–74

5. Click  (Modify) to finish.

6. Save the project.

Task 2 - Offset and trim walls.

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut <OF>.

2. In the Options Bar, set the Offset to 14'-0" and ensure that 
Copy is selected.

3. Select the top horizontal wall while ensuring that the dashed 
alignment line displays inside the building, as shown in 
Figure 2–75.

Figure 2–75

Split points
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4. With Offset still active, change the Offset to 10'-0" and offset
the last vertical interior wall to the right, as shown in
Figure 2–76.

Figure 2–76

5. Click  (Modify) and select the new horizontal wall that was
created from the exterior wall. Change the wall to Basic
Wall: Interior - 3 1/8" Partition (1-hr). The layout of the new
walls should display as shown in Figure 2–77.

The vertical wall does 
not need to be changed 
because it was offset 
from an interior wall.

Figure 2–77

6. In the Modify tab>Modify panel, click  (Trim/Extend 
Multiple Elements).

7. Select the new horizontal wall as the element to trim against.

8. Select every other wall below the new wall. (Remember, you
select the elements that you want to keep.) The walls should
display as shown in Figure 2–78.

Figure 2–78

Select these walls 
to trim and keep

Select this wall to 
trim against
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9. In the Modify tab>Modify panel, click  (Trim/Extend to 
Corner) or type the shortcut <TR> and select the two walls to 
trim as shown in Figure 2–79.

 
Figure 2–79

10.Add doors into the three new rooms.

11. Save the project.

Task 3 - Align walls.

1. Select and extend the vertical reference plane. Use the 
control to drag the top end so it extends beyond the outer 
wall, as shown in Figure 2–80.

Figure 2–80

2. In the Modify tab>Modify panel, click  (Align) or type the 
shortcut <AL>.

3. Select the reference plane, and then the wall to the left. The 
wall should line up with the reference plane.

4. Save and close the project.

Trimmed 
walls

Vertical reference plane
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Chapter Review Questions

1. What is the purpose of an alignment line?

a. Displays when the new element you are placing or
modeling is aligned with the grid system.

b. Indicates that the new element you are placing or
modeling is aligned with an existing element.

c. Displays when the new element you are placing or
modeling is aligned with a selected tracking point.

d. Indicates that the new element is aligned with true north
rather than project north.

2. When you are modeling (not editing) a linear element, how do
you edit the temporary dimension shown in Figure 2–81?

Figure 2–81

a. Select the temporary dimension and enter a new value.

b. Type a new value and press <Enter>.

c. Type a new value in the Distance/Length box in the
Options Bar and press <Enter>.

3. How do you select all the doors of various sizes, but no other
elements in a view?

a. In the Project Browser, select the Door category.

b. Select one door, right-click and select Select All
Instances>Visible in View.

c. Select all of the elements in the view and use  (Filter) 
to clear the other categories.

d. Select one door, and click  (Select Multiple) in the 
ribbon.
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4. What are the two methods for starting commands such as 
Move, Copy, Rotate, Mirror, and Array?

a. Start the command from the Modify tab and select the 
elements, then start the command.

b. Start the command from the Modify tab and select the 
elements, then select the command from the Status Bar.

c. Start the command from the Modify tab and select the 
elements, then right-click and select the command from 
the list.

5. Where do you change the wall type for a selected wall, as 
shown in Figure 2–82?

Figure 2–82

a. In the Modify | Walls tab>Properties panel, click (Type 
Properties) and select a new wall type in the dialog box.

b. In the Options Bar, click Change Element Type.

c. Select the dynamic control next to the selected wall and 
select a new type in the drop-down list.

d. In Properties, select a new type in the Type Selector 
drop-down list.

Change this wall type to this wall type
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6. Both  (Rotate) and  (Array) with  (Radial) have a
center of rotation that defaults to the center of the element or
group of elements you have selected. How do you move the
center of rotation to another point, as shown in Figure 2–83?
(Select all that apply.)

Figure 2–83

a. Select the center of rotation and drag it to a new location.

b. In the Options Bar, click Place and select the new point.

c. In the Modify tab>Placement panel, click  (Center) and
select the new point.

d. Right-click and select Snap Overrides>Centers and
select the new point.

7. Which command would you use to remove a part or a
segment of a wall?

a. (Split Element)

b. (Wall Joins)

c. (Cut Geometry)

d. (Demolish)



Basic Sketching and Modify Tools

© 2021, ASCENT - Center for Technical Knowledge® 2–51

8. Which of the following are ways in which you can create 
additional parallel walls, as shown in Figure 2–84? (Select all 
that apply.)

Figure 2–84

a. Use the Trim/Extend Multiple Elements tool.

b. Use the Offset tool in the Modify tab.

c. Select an existing wall, hold <Ctrl> and drag the wall to a 
new location. 

d. Use the Align command with an offset.

9. Which command do you use if you want two walls that are not 
touching to come together, as shown in Figure 2–85?

Figure 2–85

a.  (Edit Wall Joins)

b.  (Trim/Extend to Corner)

c.  (Join Geometry)

d.  (Edit Profile) 

Before After
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Command Summary

Button Command Location
Draw Tools

Center-ends 
Arc

• Ribbon: Modify | (various linear
elements) tab>Draw panel

Circle • Ribbon: Modify | (various linear
elements) tab>Draw panel

Circumscribed 
Polygon

• Ribbon: Modify | (various linear
elements) tab>Draw panel

Ellipse • Ribbon: Modify | Place Lines, Place
Detail Lines, and various boundary
sketches>Draw panel

Ellipse Arc • Ribbon: Modify | Place Lines, Place
Detail Lines, and various boundary
sketches>Draw panel

Fillet Arc • Ribbon: Modify | (various linear
elements) tab>Draw panel

Inscribed 
Polygon

• Ribbon: Modify | (various linear
elements) tab>Draw panel

Line • Ribbon: Modify | (various linear
elements) tab>Draw panel

Pick Faces • Ribbon: Modify | Place Wall> Draw
panel

Pick Lines • Ribbon: Modify | (various linear
elements) tab>Draw panel

Pick Walls • Ribbon: Modify | (various boundary
sketches)>Draw panel

Rectangle • Ribbon: Modify | (various linear
elements) tab>Draw panel

Spline • Ribbon: Modify | Place Lines, Place
Detail Lines, and various boundary
sketches>Draw panel

Start-End-
Radius Arc

• Ribbon: Modify | (various linear
elements) tab>Draw panel

Tangent End 
Arc

• Ribbon: Modify | (various linear
elements) tab>Draw panel

Modify Tools

Align • Ribbon: Modify tab>Modify panel

• Shortcut: AL

Array • Ribbon: Modify tab>Modify panel

• Shortcut: AR

Copy • Ribbon: Modify tab>Modify panel

• Shortcut: CO
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Copy to 
Clipboard

• Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctrl>+<C>

Delete • Ribbon: Modify tab>Modify panel

• Shortcut: DE

Mirror - Draw 
Axis

• Ribbon: Modify tab>Modify panel

• Shortcut: DM

Mirror - Pick 
Axis

• Ribbon: Modify tab>Modify panel

• Shortcut: MM

Move • Ribbon: Modify tab>Modify panel

• Shortcut: MV

Offset • Ribbon: Modify tab>Modify panel

• Shortcut: OF

Paste • Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctrl>+<V>

Pin • Ribbon: Modify tab>Modify panel

• Shortcut: PN

Rotate • Ribbon: Modify tab>Modify panel

• Shortcut: RO, R3

Scale • Ribbon: Modify tab>Modify panel

• Shortcut: RE

Split Element • Ribbon: Modify tab>Modify panel

• Shortcut: SL

Split with Gap • Ribbon: Modify tab>Modify panel

Trim/Extend 
Multiple 
Elements

• Ribbon: Modify tab>Modify panel

Trim/Extend 
Single Element

• Ribbon: Modify tab>Modify panel

Trim/Extend to 
Corner

• Ribbon: Modify tab>Modify panel

• Shortcut: TR

Unpin • Ribbon: Modify tab>Modify panel

• Shortcut: UP

Select Tools

Drag elements 
on selection

• Ribbon: All tabs>Expanded Select 
panel

• Status Bar

Filter • Ribbon: Modify | Multi-Select tab>
Filter panel

• Status Bar

Select Elements 
By Face

• Ribbon: All tabs>Expanded Select 
panel

• Status Bar
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Select Links • Ribbon: All tabs>Expanded Select
panel

• Status Bar

Select Pinned 
Elements

• Ribbon: All tabs>Expanded Select
panel

• Status Bar

Select Underlay 
Elements

• Ribbon: All tabs>Expanded Select
panel

• Status Bar

Additional Tools

Aligned 
Dimension

• Ribbon: Modify tab>Measure panel

• Quick Access Toolbar

Component • Ribbon: Architecture/Structure/
Systems tab

• Shortcut: CM

Detail Line • Ribbon: Annotate tab>Detail panel

• Shortcut: DL

Model Line • Ribbon: Architectural tab>Model panel

• Shortcut: LI

Reference 
Plane

• Ribbon: Architecture/Structure/
Systems tab> Work Plane panel
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