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C h a p t e r

Basic Sketching and Modify 
Tools

Basic sketching, selecting, and modifying tools are the foundation of working with 
all types of elements in the Autodesk® Revit® software. Using these tools with 
drawing aids helps you to place and modify elements to create accurate building 
models. 

Learning Objectives in This Chapter

• Sketch linear elements, such as walls, beams, and pipes.

• Ease the placement of elements by incorporating drawing aids, such as alignment lines, 
temporary dimensions, snaps, and connectors.

• Insert components such as mechanical equipment, plumbing fixtures, and electrical devices.

• Use techniques to select and filter groups of elements.

• Modify elements using a contextual tab, Properties, temporary dimensions, and controls.

• Move, copy, rotate, and mirror elements and create array copies in linear and radial patterns. 

• Align, trim, and extend elements with the edges of other elements.

• Split linear elements anywhere along their length.

• Offset elements to create duplicates a specific distance away from the original.
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2.1 Using General Sketching 
Tools

When you start a command, the contextual tab on the ribbon, the 
Options Bar, and the Properties palette (as shown in Figure 2–1) 
enable you to set up features for each new element you are 
placing in the project. As you are working, several features called 
drawing aids display, as shown in Figure 2–1. They help you to 
create designs quickly and accurately. 

Figure 2–1

• In Autodesk Revit, you are most frequently creating 3D model
elements rather than 2D sketches. These tools work with
both 3D and 2D elements in the software.

Draw Tools Many linear elements (such as walls, beams, ducts, pipes, and 
conduits) are modeled using the tools on the contextual tab on 
the Draw panel. Other elements (such as floors, ceilings, roofs, 
and slabs) have boundaries that are sketched using many of the 
same tools. Draw tools are also used when you create details or 
schematic drawings. 

Drawing aids

Contextual tab

Options Bar

Properties 
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The exact tools vary 
according to the 
element being modeled.

Two methods are available: 

• Draw the element using a geometric form.

• Pick an existing element (such as a line, face, or wall) as 
the basis for the new element’s geometry and position.

How To: Create Linear Elements

1. Start the command you want to use.
2. In the contextual tab>Draw panel (shown in Figure 2–2), 

select a drawing tool. 
You can change from 
one Draw tool shape to 
another in the middle of 
a command.

Figure 2–2

3. Select points to define the elements or watch the Status Bar, 
in the lower-left corner, for hints on what to do.

4. Finish the command using one of the standard methods:

• Click (Modify).

• Press <Esc> twice.

• Start another command.

Draw Options

When you are in Drawing mode, several options display in the 
Options Bar, as shown in Figure 2–3.

Different options display 
according to the type of 
element that is selected 
or the command that is 
active.

Figure 2–3

• Chain: Controls how many segments are created in one 
process. If this option is not selected, the Line and Arc tools 
only create one segment at a time. If it is selected, you can 
continue adding segments until you press <Esc> or select the 
command again.

• Offset: Enables you to enter values so you can create linear 
elements at a specified distance from the selected points or 
element. 

• Radius: Enables you to enter values when using a radial tool 
or to add a radius to the corners of linear elements as you 
sketch them.
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Draw Tools

Line Draws a straight line defined by the first and 
last points. If Chain is enabled, you can 
continue selecting end points for multiple 
segments.

Rectangle Draws a rectangle defined by two opposing 
corner points. You can adjust the dimensions 
after selecting both points.

Inscribed 
Polygon

Draws a polygon inscribed in a hypothetical 
circle, with the number of sides specified in the 
Options Bar.

Circumscribed 
Polygon

Draws a polygon circumscribed around a 
hypothetical circle, with the number of sides 
specified in the Options Bar.

Circle Draws a circle defined by a center point and 
radius.

Start-End-
Radius Arc

Draws a curve defined by a start, end, and 
radius of the arc. The outside dimension shown 
is the included angle of the arc. The inside 
dimension is the radius.

Center-ends Arc Draws a curve defined by a center, radius, and 
included angle. The selected point of the radius 
also defines the start point of the arc.

Tangent End 
Arc

Draws a curve tangent to another element. 
Select an end point for the first point, but do not 
select the intersection of two or more elements. 
Then, select a second point based on the 
included angle of the arc.

Fillet Arc Draws a curve defined by two other elements 
and a radius. Because it is difficult to select the 
correct radius by clicking, this command 
automatically moves to edit mode. Select the 
dimension and then modify the radius of the 
fillet.

Spline Draws a spline curve based on selected points 
(sketches, model lines, and detail lines only). 
The curve does not actually touch the points.

Ellipse Draws an ellipse from a primary and secondary 
axis (walls, sketches, model lines, and detail 
lines only).

Partial Ellipse Draws only one side of the ellipse, like an arc 
(sketches, model lines, and detail lines only). A 
partial ellipse also has a primary and 
secondary axis.
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Pick Tools

Drawing Aids As soon as you start sketching or placing elements, three 
drawing aids display, as shown in Figure 2–4: 

• Alignment line

• Temporary dimensions

• Snaps

• Connectors

These aids are available with most modeling and many 
modification commands.

Figure 2–4

Alignment lines display as soon as you select your first point. 
They help keep lines horizontal, vertical, or at a specified angle. 
They also line up with the implied intersections of walls and other 
elements.

• Hold <Shift> to force the alignments to be orthogonal 
(90° angles only).

Pick 
Lines

Use this option to select existing linear elements in the 
project. This is useful when you start the project from an 
imported 2D drawing.

Pick 
Face

Use this option to select the face of a 3D massing 
element (walls and 3D views only).

Pick 
Walls

Use this option to select an existing wall in the project to 
be the basis for a new sketch line (floors, ceilings, etc.).

Alignment lines

Snaps

Temporary 
dimensions
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Temporary dimensions display to help place elements at the 
correct length, angle, and location.

• You can type in a value or move the cursor until you see the
dimension you want, or you can place the element and then
modify the value as needed.

• The length and angle increments shown vary depending on
how far in or out the view is zoomed.

• For imperial measurements (feet and inches), the software
uses a default of feet. For example, when you type 4 and
press <Enter>, it assumes 4'-0". For a distance such as 4'-6",
you can type any of the following: 4'-6", 4'6, 4-6, or 4 6 (the
numbers separated by a space). To indicate distances less
than one foot, type the inch mark (") after the distance, or
enter 0, a space, and then the distance.

Snaps are key points that help you reference existing elements 
to exact points when modeling, as shown in Figure 2–6.

Figure 2–6

• When you move the cursor over an element, the snap symbol
displays. Each snap location type displays with a different
symbol.

Hint: Temporary Dimensions and Permanent Dimensions

Temporary dimensions disappear as soon as you finish adding 
elements. If you want to make them permanent, select the 

dimension symbol ( ), as shown in Figure 2–5.

Figure 2–5
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Connectors work similarly to snaps, but they have more 
intelligence about the size, system, and flow of items (e.g., ducts, 
pipes, and electrical connections). For example, connectors 
automatically add fittings to ducts, such as the elbow, transition, 
and tee shown in Figure 2–7.

Figure 2–7

Fittings controlled by connectors Connectors
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Hint: Snap Settings and Overrides

In the Manage tab>Settings panel, click  (Snaps) to open 
the Snaps dialog box, which is shown in Figure 2–8. The Snaps 
dialog box enables you to set which snap points are active, and 
set the dimension increments displayed for temporary 
dimensions (both linear and angular).

Figure 2–8

• Keyboard shortcuts for each snap can be used to override
the automatic snapping.Temporary overrides only affect a
single pick, but can be very helpful when there are snaps
nearby other than the one you want to use.
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Reference
Planes

As you develop designs in Revit, there are times when you need 
lines to help you define certain locations. You can sketch 
reference planes (displayed as dashed green lines) and snap to 
them whenever you need to line up elements. For the example 
shown in Figure 2–9, the lighting fixtures in the reflected ceiling 
plan are placed using reference planes. 

Reference planes do 
not display in 3D views.

• To insert a reference plane, in the Architecture, Structure, or 

Systems tab>Work Plane panel, click  (Reference Plane) 
or type RP. 

Figure 2–9

• Reference planes display in associated views because they 
are infinite planes and not just lines. 

• You can name reference planes by clicking <Click to name> 
and typing in the text box, as shown in Figure 2–10.

Figure 2–10

• If you sketch a reference plane in sketch mode (used with 
floors and similar elements), it does not display once the 
sketch is finished.

• Reference planes can have different line styles if they have 
been defined in the project. In Properties, select a style from 
the Subcategory list.
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Hint: Model Line vs. Detail Line

While most of the elements that you create are representations 
of actual building elements, there are times you may need to 
add lines to clarify the design intent. These can be either detail 
lines, as shown in Figure 2–11, or model lines. Detail lines are 
also useful as references because they are only reflected in 
the view in which you sketch them.

Figure 2–11

• A model line (Architecture or Structure tab>Model panel>

 (Model Line)) functions as a 3D element and displays 
in all views. 

• A detail line (Annotate tab>Detail panel>  (Detail Line)) is
strictly a 2D element that only displays in the view in which
it is drawn.

• In the Modify contextual tab, shown in Figure 2–12, select a
Line Style and then the Draw tool that you want to use to
draw the model or detail line.

Figure 2–12
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2.2 Inserting Components
Components (also known as families) are full 3D elements that 
can be placed at appropriate locations and heights, and which 
interact with the building elements around them. For example, a 
lighting fixture can be designed to be hosted by a face (such as a 
wall or ceiling), or to stand alone by itself, as shown in 
Figure 2–13. The Autodesk Revit software includes both 
architectural components (such as the lamp and wall sconces in 
Figure 2–13) and MEP components (such as the downlight 
fixtures) that include connectors. 

Components are 
located in family files 
with the extension .RFA. 
For example, a 
component family 
named Wall Sconce.rfa 
can contain several 
types and sizes.

Figure 2–13

Exact steps for inserting 
specific components are 
covered later in this 
guide.

Most components are inserted using specific tools, including:

Stand-alone 
family

Wall-based 
family

Ceiling-based 
family

 Air terminal  Electrical Equipment

 Mechanical Equipment    Devices (Data, Fire Alarm, 
Switches, etc.)

 Plumbing Fixture  Lighting Fixtures

Sprinkler
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• Take time to get to know the components that come with the
Autodesk Revit software. Their most critical content are the
connectors, as you see in for a piece of mechanical
equipment in Figure 2–14.

Figure 2–14

• Connectors often contain options to create systems and draw
ducts and pipes when you right-click on them.

How To: Insert Components

1. In the Systems tab>Model panel, click  (Place a 
Component), or type CM.

2. In the Type Selector, select the type/size you want to use, as
shown in Figure 2–15.
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Figure 2–15

3. In the command-specific contextual tab>Tag panel, click 

(Tag on Placement) to toggle this option on or off. 
4. Proceed as follows, based on the type of component used:

If the 
component is...

Then...

Not hosted Set the Level and Offset from Host in Properties, as 
shown in Figure 2–16.

Wall hosted Set the Elevation from Level in Properties, as shown in 
Figure 2–17.

Face hosted Select the appropriate method in the contextual tab> 
Placement panel, as shown in Figure 2–18.

• Vertical Faces include walls and columns.

• Faces include ceilings, beams, and roofs.

• Work Planes can be set to levels, faces, and named 
reference planes.

Figure 2–16 Figure 2–17

Figure 2–18
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5. Place the component in the model.

• Many components can be rotated by pressing <Spacebar>
when placing them. This will rotate them in 90° increments,
unless your cursor is over an angled wall, reference plane, or
grid line.

• In the Options Bar, many components will have an option to
Rotate after placement, as shown in Figure 2–19. This
allows you to rotate the element by any degree immediately
after placing the family.

Figure 2–19

• A fast way to add components that match those already in
your project is to select one, right-click on it, and select
Create Similar, as shown in Figure 2–20. This starts the
appropriate command with the same type selected.

Figure 2–20
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Hint: Work Planes

A work plane is the surface you sketch on or extrude from. In a 
plan view, the work plane is automatically parallel to the level. 
In an elevation or 3D view, you must specify the work plane 
before you start sketching.

How To: Select a Work Plane

1. Start a command that requires a work plane or, in the 

Systems tab>Work Plane panel, click  (Set).
2. In the Work Plane dialog box, select one of the following 

options:

• Name: Select an existing level, grid, or named reference 
plane (as shown in Figure 2–21) and click OK.

Figure 2–21

• Pick a plane: Click OK and select a plane in the view, 
such as a wall face. Ensure the entire plane is 
highlighted before you select it. 

• Pick a line and use the work plane it was sketched 
in: Click OK and select a model line, such as a room 
separation line.

If you are in a view in which the sketch cannot be created, the 
Go To View dialog box opens. Select one of the views and click 
Open View.
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Loading
Components

To optimize project size and improve performance, by default, 
the Revit project templates are not fully loaded with all Revit 
families. However, you can load more families with multi-options 
from the Autodesk Revit Library or the Autodesk website. You 
can also load your company’s custom families or families from 
other manufacturers that you may have available in your local 
device. 

You can also copy a component to the clipboard in one project 
and paste it into a different project.The Revit Library has 
MEP-based components available in the following folders: Cable 
Tray, Conduit, Duct, Electrical, Fire Protection, Lighting, 
Mechanical, Pipe, and Plumbing.

How To: Load a Family

1. In the related contextual tab>Mode panel or Insert tab>Load

from Library panel,  click (Load Family).
2. In the Load Family dialog box, locate the folder that contains

the family or families you want to load, as shown in
Figure 2–22.

• If the Load Family dialog box does not default to the Revit
Library folder, click on Imperial Library in the Places
panel.

Figure 2–22

3. Select the family or families you want to load. You can hold
<Ctrl> to select multiple families.

• The program remembers the last-used folder.

4. Click Open.

Places panel

Click on library 
shortcut
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How To: Load an Autodesk Family

1. In the Insert tab>Load from Library panel, click  (Load 
Autodesk Family).

2. In the Load Autodesk Family dialog box, filter your search by 
typing in what kind of family you are looking for, or click on a 
category in the Browse section, as shown in Figure 2–23.

Figure 2–23

3. Click Load to load the family into your project.

Search bar
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Purging
Unused

Components

You can remove unused elements from a project, including 
individual component types, as shown in Figure 2–24.

Figure 2–24

• Some elements are nested in other elements and it might
require several rounds of purging the project to remove them.

How To: Purge Unused Elements

1. In the Manage tab>Settings panel, click  (Purge Unused).
2. In the Purge unused dialog box, click Check None and select

the elements that you want to purge.
3. Click OK.
4. Purging unused components not only helps simplify the

component list, but more importantly, reduces the project file
size.
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Practice 2a Insert Components - Mechanical

In this practice, you will insert air terminals and a mechanical 
equipment fixture, as shown in Figure 2–25. You will use various 
drawing aids to help you place the fixtures appropriately.

Figure 2–25

1. In the practice files Working Models>Mechanical folder, open 
Mech-Start.rvt.

2. In the Project Browser, expand the Mechanical>HVAC>
Floor Plans node. Double-click on the 1 - Mech view to 
open it.

3. In the Systems tab>HVAC panel, click  (Air Terminal).

4. In Properties, note that the default in the Type Selector is a 
Supply Diffuser and that the Level is Level 1.

5. Set the Offset from Host to 9'-0".

Practice Objectives

• Insert components.

• Use drawing aids.
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6. Click near the center of the room labeled Lab 101, as shown
in Figure 2–26.

Figure 2–26

7. While still in the Air Terminal command, in the Type Selector,
change the Type to Return Diffuser: 24 x 24 Face 12 x 12
Connection and set the Offset from Host to 9'-0".

8. Click to place the component in the lower-left corner of
Lab 101.

9. Click  (Modify).

10. In the Systems tab>Mechanical panel, click  (Mechanical 
Equipment.)

11. In the Type Selector, select Boiler: Standard.

12. In the Mech/Elec room, move the cursor near the exterior
wall. Note that the interior side of the wall highlights, as
shown in Figure 2–27. Press <Spacebar> and the boiler will
rotate around the placement point, which is your cursor.
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Figure 2–27

13.Click to place the component.

14.Click  (Modify) to end the command. 

15.Save and close the project.
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Practice 2b Insert Components - Electrical

In this practice, you will insert lighting fixtures, as shown in 
Figure 2–28. You will use various drawing aids to help you place 
the fixtures appropriately.

Figure 2–28

1. In the practice files Working Models>Electrical folder, open
Elec-Start.rvt.

2. In the Project Browser, expand the Electrical>Lighting>
Ceiling Plans node and double-click on 1 - Ceiling Elec to
open the view.

• Ensure that you are opening the ceiling plan so that the
ceiling grids display.

3. In the Systems tab>Electrical panel, click  (Lighting 
Fixture).

4. In the Type Selector, select Plain recessed Lighting
Fixture: 2x4 - 277.

5. In the Modify | Place Fixture tab>Placement panel, click

(Place on Face).

Practice Objectives

• Insert components.

• Use drawing aids.

• Select a work plane.
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6. In the room Lab 101, hover the cursor over the grid. The light 
fixture snaps to the ceiling grid intersection lines, as shown in 
Figure 2–29.

7. Press <Spacebar> to rotate the fixture about the placement 
point, which is your cursor. Click to place two fixtures in the 
room, as shown in Figure 2–30.

8. Open the Electrical>Lighting>Floor Plans>1 - Lighting view. 
The light fixtures display in this view although you are seeing 
a plan view.

9. In the Systems tab>Electrical panel, expand the Device 

drop-down list and select  (Lighting). 

10. In the Type Selector, select Lighting Switches: Single Pole.

11. In Properties, note that the Elevation from Level is set to 
4'-0", a standard height for switches.

Figure 2–29 Figure 2–30
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12.Place the switch next to the door. It displays only as a
symbol, as shown in Figure 2–31.

Figure 2–31

13.Click  (Modify) to end the command.

14.Save and close the project.
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Practice 2c Insert Components - Plumbing

In this practice, you will insert plumbing fixtures, as shown in 
Figure 2–32. You will use drawing aids to help you place the 
fixtures appropriately.

Figure 2–32

1. In the practice files Working Models>Plumbing folder, open 
Plumb-Start.rvt.

2. In the Project Browser, expand the Plumbing>Plumbing>
Floor Plans node and double-click on 1 - Plumbing to open 
the view. 

3. In the Systems tab>Plumbing & Piping panel, click 

(Plumbing Fixture).

4. In the Type Selector, select one of the wall-mounted water 
closets. 

Practice Objectives

• Load and insert components.

• Use drawing aids.
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5. Click along the wall in the men’s restroom to place the fixture,
as shown in Figure 2–33.

Figure 2–33

6. Return to the Type Selector and review the list. Note that
there are sinks, but no lavatories.

7. In the Modify | Place Plumbing Fixture tab>Mode panel, click

 (Load Family).

If the Revit Library folder 
does not automatically 
display, refer to the 
Loading Components 
section in 2.2 Inserting 
Components.

8. In the Load Family dialog box, the Autodesk Revit Library
automatically displays. Navigate to the Plumbing>
MEP>Fixtures>Lavatories folder and select Lavatory -
Oval.rfa, as shown in Figure 2–34.
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Figure 2–34

9. Click Open. 

10. In the Type Selector, select Lavatory - Oval: 25"x 20" - 
Public.

11. Place the lavatory against the wall across from the water 
closet. 

12.Click  (Modify) and select the new fixture. Drag it up or 
down until it meets with the alignment line of the water closet, 
as shown in Figure 2–35.

Figure 2–35

13.Click outside the building model in an empty area to release 
the selection.

14.Save and close the project.

Alignment line
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2.3 Selecting and Editing 
Elements

Building design projects typically involve extensive changes to 
the model. Revit was designed to make such changes quickly 
and efficiently. You can change an element using the following 
methods, as shown in Figure 2–36:

• Type Selector enables you to specify a different type. This is
frequently used to change the size and/or style of the
elements.

• Properties enables you to modify the information
(parameters) associated with the selected elements.

• The contextual tab in the ribbon contains the Modify
commands and element-specific tools.

• Temporary dimensions enable you to change the element’s
dimensions or position.

• Controls enable you to drag, flip, lock, and rotate the element.

• Shape handles enable you to drag elements to modify their
height or length.

• Connectors show how related elements attach to each other
with intelligence about size, needed fittings, and system
information.

Figure 2–36

Contextual tab
Type Selector

Properties Temporary dimension

Connector Shape handle
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• To delete an element, select it and press <Delete>, right-click 

and select Delete, or in the Modify panel, click  (Delete).

Working with Controls and Connectors

When you select an element, various controls and connectors 
display depending on the element and view. Using controls, you 
can change an elements length or location, and flip or rotate 
some elements. MEP connectors also provide information about 
attachments and enable you to add related elements, as shown 
for creating pipe from a pipe accessory in Figure 2–37.

Figure 2–37

• If you hover the cursor over the control or connector, a tooltip 
displays showing its function.
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Hint: Editing Temporary Dimensions

Temporary dimensions automatically link to the closest wall. To 
change the location, you can drag the Witness Line control, as 
shown in Figure 2–38, to connect to a new reference. You can 
also click on the control to toggle between justifications in the 
wall.

Figure 2–38

• The new location of a temporary dimension for an element
is remembered as long as you are in the same session of
the software.

Before - connected to 
centerline of wall

After - connected to 
edge of wall
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Selecting
Multiple

Elements

You can select more than one element at a time. Once you have 
selected at least one element, hold <Ctrl> and select another 
item to add it to a selection set. 

• To remove an element from a selection set, hold <Shift> and 
select the element.

• If you click and drag the cursor to window around elements, 
you have two selection options, as shown in Figure 2–39. If 
you drag from left to right, you only select the elements 
completely inside the window. If you drag from right to left, 
you select elements both inside and crossing the window.

Figure 2–39

• If several elements are on or near each other, hover your 
cursor over an edge and press <Tab> to cycle through them 
before you click. If there are elements that might be linked to 
each other, such as walls that are connected, pressing <Tab> 
selects the chain of elements.

• Press <Ctrl>+<Left Arrow> to reselect the previous selection 
set. You can also right-click in the view window with nothing 
selected and select Select Previous.

• To select all elements of a specific type, right-click on an 
element and select Select All Instances>Visible in View or 
In Entire Project, as shown in Figure 2–40. For example, if 
you select a column of a specific size and use this command, 
only the columns of the same size are selected.

Figure 2–40

• You can save selections and use them again.

Crossing: right to leftWindow: left to right
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Hint: Measuring Tools

When modifying a model, it is useful to know the distance 
between elements. This can be done with temporary 
dimensions or, more frequently, by using the measuring tools 
found in the Quick Access Toolbar or in the Modify tab> 
Measure panel, as shown in Figure 2–41.

Figure 2–41

• (Measure Between Two References): Select two
elements and the measurement displays.

• (Measure Along An Element): Select the edge of a
linear element and the total length displays. Use <Tab> to
highlight other elements and then click to measure along all
of them, as shown in Figure 2–42.

Figure 2–42

• References include any snap point, wall lines, or other parts
of elements (such as door center lines).
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Filtering
Selection Sets

When multiple element categories are selected, the Multi-Select 
contextual tab opens in the ribbon. This gives you access to all of 
the Modify tools and the Filter command. The Filter command 
enables you to specify the types of elements to select. For 
example, you might only want to select light fixtures, as shown in 
Figure 2–43.

 
Figure 2–43

How To: Filter a Selection Set

1. Select everything in the area.
2. In the Modify | Multi-Select tab>Selection panel, or in the 

Status Bar, click  (Filter). The Filter dialog box opens, as 
shown in Figure 2–44.

The Filter dialog box 
displays all types of 
elements in the original 
selection.

 
Figure 2–44
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3. Click Check None to clear all of the options or Check All to
select all of the options. You can also select or clear
individual categories as needed.

4. Click OK. The selection set is now limited to the elements
you specified.

• The number of elements selected displays on the right end of
the Status Bar and in Properties.
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Hint: Selection Options

You can control how the software selects specific elements in a 
project by toggling selection options on and off in the Status 
Bar, as shown in Figure 2–45. Alternatively, in any tab on the 
ribbon that has the Modify command, you can expand the 
Select panel and select the options shown in Figure 2–46.

Figure 2–45

Figure 2–46

•  Select links: When toggled on, you can select linked 
drawings or Autodesk Revit models. When toggled off, you 
cannot select linked drawings when using Modify or Move.

•  Select underlay elements: When toggled on, you 
can select underlay elements. When toggled off, you cannot 
select underlay elements when using Modify or Move.

•  Select pinned elements: When toggled on, you 
can select pinned elements. When toggled off, you cannot 
select pinned elements when using Modify or Move.

•  Select elements by face: When toggled on, you can 
select elements (such as the floors or walls in an elevation) 
by selecting the interior face or selecting an edge. When 
toggled off, you can only select elements by selecting an 
edge.

•  Drag elements on selection: When toggled on, you 
can hover over an element, select it, and drag it to a new 
location. When toggled off, the crossing or box select mode 
starts when you press and drag, even if you are on top of an 
element. Once elements have been selected, they can still 
be dragged to a new location.

Click to 
expand
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Practice 2d Select and Edit Elements - 
Mechanical

In this practice, you will modify the location of an air terminal and 
use Create Similar to add additional components, as shown in 
Figure 2–47. You will also modify the height of the air terminals in 
Properties. 

Figure 2–47

• Note: Elements have been modified so that you will have the
opportunity to modify their properties.

Practice Objectives

• Use a variety of selection methods.

• Use Create Similar to add similar elements.

• Use alignment lines to line up elements.

• Modify elements using Properties.

• Become familiar with selecting elements.
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Task 1 - Use a variety of selection methods.

1. In the practice files Working Models>Mechanical folder, open 
Mech-Edit.rvt.

2. Open the Mechanical>HVAC>Floor Plans>1 - Mech view.

3. Draw a selection window from left to right around some of the 
elements so only those completely inside the window are 
selected. The elements that are selected will highlight in blue, 
as shown in Figure 2–48.

Figure 2–48

4. Click in an empty space in the view to clear the selection.

Selection 
window

First click

Second 
click
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5. Draw a crossing window (i.e., from right to left) around the
same area, as shown in Figure 2–49. Note that any elements
that the window touches are included in the selection,
including the linked architectural model.

You can toggle 

(Select Links) in the 
Status Bar to keep the 
link from being selected.

Figure 2–49

6. Hold <Shift> and select the edge of the architectural model.
This removes it from the selection.

7. In the Status Bar, note the number of items that are selected

and click  (Filter).

8. In the Filter dialog box, view the categories and clear the
checkmark from Air Terminals.

9. Click OK. Only the room tags remain selected.

10.Press <Esc>. The elements are no longer selected.

11. Select one of the room tags. Right-click and select Select All
Instances>Visible in View. All of the tags are selected.

12.Click  (Modify). The elements are no longer selected.

• Remember these selection methods as you start working in
the projects.

Crossing 
window

First 
click

Second 
click
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Task 2 - Modify elements using controls and properties.

1. Still in the Mechanical>HVAC>Floor Plans>1 - Mech view, 
select the supply air terminal, then click and drag it to a new 
location using the alignment line referencing the return air 
terminal, as shown in Figure 2–50.

Figure 2–50

2. Right-click on the control and look at the variety of options 
you can use. Figure 2–51 shows a partial menu.

Figure 2–51

Alignment line
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3. In the shortcut menu, select Create Similar. This starts the
Place Component command using the same supply diffuser
type. Place two more air terminals in the same room, using
alignment lines to place them, as shown in Figure 2–52.

Figure 2–52

4. Click  (Modify) and select all three of the supply air
terminals. Note the information in Properties. The Offset from
Host is set to 0'-0" above Level 1.

5. Hold <Ctrl> and select the return air terminal. The Level and
Offset from Host are available to change, although two
different types of components are selected.

6. Note that similar parameters with different values show as
<varies> in Properties, as shown on the left in Figure 2–53.

Alignment lines
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7. Change the Offset from Host to 8'-0" and click Apply. The 
offset for all of the air terminals is updated, as shown on the 
right in Figure 2–53.

Figure 2–53

8. Click in an empty space to clear the selection.

9. Save and close the project.
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Practice 2e Select and Edit Elements - 
Electrical

In this practice, you will select lighting fixtures and change their 
type (as shown in Figure 2–54).

Figure 2–54

Task 1 - Use a variety of selection methods.

1. In the practice files Working Models>Electrical folder, open
Elec-Edit.rvt.

2. In the Project Browser, open the Electrical>Lighting>Floor
Plans>1 - Ceiling Elec view.

3. Draw a selection window from left to right around some of the
elements so only those completely inside the window are
selected. The elements that are selected will highlight in blue,
as shown in Figure 2–55.

Practice Objective

• Change an element’s type using the Type Selector.

• Use Create Similar to add similar elements.

• Use alignment lines to line up elements.

• Modify elements using Properties.

• Become familiar with selecting elements.
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Figure 2–55

4. Click in an empty space in the view to clear the selection.

5. Draw a crossing window (i.e., from right to left) around the 
same area, as shown in Figure 2–56. Note that any elements 
that the window touches are included in the selection, 
including the linked architectural model.

You can toggle 

(Select Links) in the 
Status Bar to keep the 
link from being selected.

Figure 2–56

6. Hold <Shift> and select the edge of the architectural model. 
This removes it from the selection.

Selection 
window

Second 
click

First 
click

Crossing 
window

First 
click

Second 
click



Autodesk Revit 2022 MEP Fundamentals

2–44 © 2021, ASCENT - Center for Technical Knowledge®

7. In the Status Bar, note the number of items that are selected

and click  (Filter).

8. In the Filter dialog box, view the categories and clear the
checkmark from Lighting Fixtures.

9. Click OK. Only the room tags remain selected.

10.Press <Esc>. The elements are no longer selected.

11. Select one of the room tags. Right-click and select Select All
Instances>Visible in View. All of the tags are selected.

12.Click  (Modify). The elements are no longer selected.

• Remember these selection methods as you start working in
the projects.

Task 2 - Modify elements using controls and properties.

1. Select one of the lighting fixtures in Lab 101.

2. Right-click on the control and look at the variety of options
you can use. Figure 2–57 shows a partial menu.

Figure 2–57

3. In the shortcut menu, select Create Similar. This starts the
Place Component command using the same lighting fixture
type.
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4. In the Modify | Place Fixture tab>Placement panel, click 

(Place on Face). Place two more lighting fixtures in the 
same room, using the ceiling grid to place them below the 
existing lighting fixtures, as shown in Figure 2–58.

Figure 2–58

5. In the Project Browser, open the Electrical>Lighting>Floor 
Plans>1 - Lighting view.

6. Select one of the light fixtures. The connectors and controls 
are displayed.

7. Hold <Ctrl> and select the other fixtures. The connectors no 
longer display, but you can still modify the fixture type. 
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8. In the Type Selector, change the type to Plain Recessed
Lighting Fixture: 1x4 - 277. Both fixtures change, as shown
in Figure 2–59.

Figure 2–59

9. Click in an empty space to clear the selection.

10.Save and close the project.
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Practice 2f Select and Edit Elements - 
Plumbing

In this practice, you will modify the height of the lavatory and 
water closet in Properties (as shown in Figure 2–63).

Task 1 - Use a variety of selection methods.

1. In the practice files Working Models>Plumbing folder, open 
Plumb-Edit.rvt.

2. In the Project Browser, open the Plumbing>Plumbing>Floor 
Plans>1 - Plumbing view.

3. Draw a selection window from left to right around some of the 
elements so only those completely inside the window are 
selected. The elements that are selected will highlight in blue, 
as shown in Figure 2–60.

Figure 2–60

Practice Objective

• Modify an element’s properties.

• Use Create Similar to add more elements.

• Become familiar with selecting elements.

Selection 
window

First click

Second 
click
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4. Click in an empty space in the view to clear the selection.

5. Draw a crossing window (i.e., from right to left) around the
same area, as shown in Figure 2–61. Note that any elements
that the window touches are included in the selection,
including the linked architectural model.

You can toggle 

(Select Links) in the 
Status Bar to keep the 
link from being selected.

Figure 2–61

6. Hold <Shift> and select the edge of the architectural model.
This removes it from the selection.

7. In the Status Bar, note the number of items that are selected

and click  (Filter).

8. In the Filter dialog box, view the categories and clear the
checkmark from Plumbing Fixtures.

9. Click OK. Only the room tags remain selected.

10.Press <Esc>. The elements are no longer selected.

11. Select one of the room tags. Right-click and select Select All
Instances>Visible in View. All of the tags are selected.

12.Click  (Modify). The elements are no longer selected.

• Remember these selection methods as you start working in
the projects.

Crossing 
window

Second 
click

First 
click
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Task 2 - Modify elements using controls and properties.

1. Select one of the lavatories in room 102.

2. Right-click on the control and look at the variety of options 
you can use. Figure 2–62 shows a partial menu.

Figure 2–62

3. In the shortcut menu, select Create Similar. This starts the 
Place Component command using the same lavatory type. 
Place more lavatories (sinks) along the wall.

4. Click  (Modify) to end the command.
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5. Select all of the lavatories and, in Properties, set the
Elevation from Level to 2'-10", as shown in Figure 2–63.

Figure 2–63

6. Select the two water closets (toilets) and set the Elevation
from Level to 16" (make sure to include the inches symbol).
Note: This will automatically change to 1'-4" in Properties.

7. Click  (Modify) to end the command.

8. Save and close the project.
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2.4 Working with Basic Modify 
Tools

The basic modifying tools, Move, Copy, Rotate, Mirror, and 
Array, can be used with individual elements or any selection of 
elements. They are found in the Modify panel (shown in 
Figure 2–64), in the Modify tab, and in contextual tabs.

Figure 2–64

• For these modify commands, you can either select the 
elements and start the command, or start the command, 
select the elements, and press <Enter> to finish the selection 
and move to the next step in the command.

Moving
and Copying

Elements

The Move and Copy commands enable you to select the 
element(s) and move or copy them from one place to another. 
You can use alignment lines, temporary dimensions, and snaps 
to help place the elements, as shown in Figure 2–65.

Figure 2–65
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How To: Move or Copy Elements

1. Select the elements you want to move or copy.

2. In the Modify panel, click  (Move) or  (Copy).
Alternatively, you can type MV for Move and CO for Copy. A
boundary box displays around the selected elements.

3. Select a start point on or near the element.
4. Select a second point. Use alignment lines and temporary

dimensions to help place the elements.
5. When you are finished, you can start another modify

command using the elements that remain selected, or click

 (Modify) to end the command.

• You can drag elements to new locations without starting the
Move command. Holding <Ctrl> and dragging copies the
element. This is quick, but not very precise.

Move/Copy Elements Options

The Move and Copy commands have several options that 
display in the Options Bar, as shown in Figure 2–66. 

Figure 2–66

• These commands only work in the current view, not between
views or projects. To copy between views or projects, in the

Modify tab>Clipboard panel, click  (Copy to Clipboard), 

(Cut to the Clipboard) or  (Paste from Clipboard).

Constrain Restricts the movement of the cursor to horizontal or 
vertical, or along the axis of an item that is at an angle. This 
keeps you from selecting a point at an angle by mistake. 
Constrain is off by default.

Disjoin 
(Move only)

Breaks any connections between the elements being 
moved and other elements. If Disjoin is on, the elements 
move separately. If it is off, the connected elements also 
move or stretch. Disjoin is off by default.

Multiple 
(Copy only)

Enables you to make multiple copies of one selection. 



Basic Sketching and Modify Tools

© 2021, ASCENT - Center for Technical Knowledge® 2–53

Rotating
Elements

The Rotate command enables you to rotate selected elements 
around a center point or origin, as shown in Figure 2–68. You 
can use alignment lines, temporary dimensions, and snaps to 
help specify the center of rotation and the angle. You can also 
create copies of the element as it is being rotated.

Figure 2–68

Hint: Pinning Elements

If you do not want elements to be moved, you can pin them in 
place, as shown in Figure 2–67. Select the elements and in the 

Modify tab>Modify panel, click  (Pin) or type the shortcut 
PN. Pinned elements can be copied, but not moved. If you try 
to delete a pinned element, a warning dialog displays reminding 
you that you must unpin the element before the command can 
be started.

Figure 2–67

Select the element and click  (Unpin) or type the shortcut 
UP to unpin the element.

Pin icon

Original In process Completed
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How To: Rotate Elements

1. Select the element(s) you want to rotate.

2. In the Modify panel, click  (Rotate) or type the 
shortcut RO.

3. The center of rotation is automatically set to the center of the
element or group of elements, as shown in Figure 2–69. To
change the center of rotation, as shown in Figure 2–70, use
the following:

To start the Rotate 
command with a prompt 
to select the center of 
rotation, select the 
elements first and type 
R3.

• Drag the  (Center of Rotation) control to a new point.

• In the Options Bar, next to Center of rotation, click Place
and use snaps to move it to a new location.

• Press <Spacebar> to select the center of rotation and
click to move it to a new location.

4. In the Options Bar, specify if you want to make a copy (select
Copy), type an angle in the Angle field (shown in
Figure 2–71), and press <Enter>. You can also specify the
angle on screen using temporary dimensions.

Figure 2–71

5. The rotated element(s) remain highlighted, enabling you to
start another command using the same selection, or click

(Modify) to finish.

Figure 2–69 Figure 2–70

Center of 
rotation

Center of 
rotation
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• The Disjoin option breaks any connections between the 
elements being rotated and other elements. If Disjoin is on 
(selected), the elements rotate separately; however, with 
MEP elements, the connection to the system will be broken. If 
it is off (cleared), the connected elements also move or 
stretch, as shown for a wall in Figure 2–72. Disjoin is toggled 
off by default.

Figure 2–72

• Rotating connected MEP elements can easily cause 
connection and system problems.

Disjoin on Disjoin off
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Mirroring
Elements

The Mirror command enables you to mirror elements about an 
axis defined by a selected element, as shown in Figure 2–73, or 
by selected points.

Figure 2–73

How To: Mirror Elements

1. Select the element(s) to mirror.
2. In the Modify panel, select the method you want to use:

• Click  (Mirror - Pick Axis) or type the shortcut MM. This 
prompts you to select an element as the Axis of 
Reflection (mirror line).

• Click  (Mirror - Draw Axis) or type the shortcut DM.
This prompts you to select two points to define the axis
about which the elements mirror.

3. The new mirrored element(s) remain highlighted, enabling

you to start another command, or click  (Modify) to finish.

• By default, the original elements that were mirrored remain.
To delete the original elements, clear the Copy option in the
Options Bar.

Mirroring the recessed 
lights by Draw Axis

Where the lights
will mirror to
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Creating Linear
and Radial

Arrays

The Array command creates multiple copies of selected 
elements in a linear or radial pattern, as shown in Figure 2–74. 
For example, you can array a row of columns to create a row of 
evenly spaced columns on a grid line, or array a row of parking 
spaces. The arrayed elements can be grouped or placed as 
separate elements.

• A linear array creates a straight line pattern of elements, 
while a radial array creates a circular pattern around a center 
point.

Figure 2–74

How To: Create a Linear Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array) or type the shortcut AR. 

3. In the Options Bar, click  (Linear).
4. Specify the other options as needed.
5. Select a start point and an end point to set the spacing and 

direction of the array. The array is displayed.

Hint: Scale

The Autodesk Revit software is designed with full-size 
elements. Therefore, not much should be scaled. For example, 
scaling a wall increases its length but does not impact the 
width, which is set by the wall type. However, you can use 

(Scale) in reference planes, images, and imported files 
from other programs.

Linear array

Radial array
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6. If Group And Associate is selected, you are prompted again
for the number of items, as shown in Figure 2–75. Type a
new number or click on the screen to finish the command.

Figure 2–75

• To make a linear array in two directions, you need to array
one direction first, select the arrayed elements, and then
array them again in the other direction.

Array Options

In the Options Bar, set up the array options for Linear Array (top 
of Figure 2–76) or Radial Array (bottom of Figure 2–76).

Figure 2–76

Group And 
Associate

Creates an array group element out of all arrayed elements. 
The group can be selected by selecting any elements in the 
group.

Number Specifies how many instances you want in the array.

Move To: 2nd specifies the distance or angle between the center 
points of the two elements.

Last specifies the overall distance or angle of the entire 
array.

Constrain Restricts the direction of the array to only vertical or 
horizontal (Linear only).

Angle Specifies the angle (Radial only).

Center of 
rotation 

Specifies a location for the origin about which the elements 
rotate (Radial only).
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How To: Create a Radial Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array).

3. In the Options Bar, click  (Radial).

4. Drag  (Center of Rotation) or use Place to move the center 
of rotation to the appropriate location, as shown in 
Figure 2–77.

Remember to set the 
Center of Rotation 
control first, before 
specifying the angle.

Figure 2–77

5. In the Options Bar, type an angle and press <Enter>, or 
specify the rotation angle by selecting points on the screen.

6. Specify the other options as needed.

Modifying Array Groups

When you select an element in an array that has been grouped, 
you can change the number of instances in the array, as shown 
in Figure 2–78. For radial arrays, you can also modify the 
distance to the center.

Figure 2–78

• Dashed lines surround the elements in a group, and the XY 
control lets you move the origin point of the group.

Center of rotation
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If you move one of the elements in the array group, the other 
elements move in response based on the distance and/or angle, 
as shown in Figure 2–79.

Figure 2–79

• To remove the array constraint on the group, select all of the
elements in the array group and, in the Modify contextual

tab>Group panel, click  (Ungroup).

• If you select an individual element in an array and click

(Ungroup), the element you selected is removed from the 
array, while the rest of the elements remain in the array 
group.

• You can use  (Filter) to ensure that you are selecting only 
Model Groups.

• When using an array with MEP objects, you will need to
ungroup the objects in order to see the connectors.
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Practice 2g Work with Basic Modify Tools - 
Mechanical

In this practice, you will copy air terminals to several rooms and 
move some so they fit the room logically.

This exercise only covers the Move and Copy tools. For practice 
using other basic modify tools, you can complete the exercises 
for the other disciplines.

• For practice using the Copy and Rotate tools, complete 
Practice 2h Work with Basic Modify Tools - Electrical.

• For practice using the Rotate, Mirror, and Array tools, 
complete Practice 2i Work with Basic Modify Tools - 
Plumbing.

1. In the practice files Working Models>Mechanical folder, open 
Mech-Modify.rvt. 

2. Open the Mechanical>HVAC>Floor Plans>1 - Mech view.

3. Select the four air terminals.

4. In the Modify | Air Terminals tab>Modify panel, click 

(Copy).

5. In the Options Bar, verify that Multiple is checked and 
uncheck Constraint.

Practice Objective

• Use the Move and Copy basic modify tools.
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6. Select the upper-left corners of the following rooms, as
shown in Figure 2–80:

• First point: Lab 101

• Second point: Lab 104

• Third point: Lab 107

(You may need to uncheck Constraint from the Options Bar 
for the third point.)

Figure 2–80

7. The air terminals are copied into each room.

8. Click  (Modify).

9. You need to adjust the placement of the air terminals in Lab
107 since the room is the larger than Lab 101. In the Modify

tab>Modify panel, click  (Move).

10.As there is no current selection, you need to select the
elements to move. In Lab 107, select the two air terminals on
the right and then press <Enter>.

First point

Second point

Third point
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11. Select a base point on one of the air terminals and then use 
temporary dimensions to move the air terminals 4'-0" to the 
right, as shown in Figure 2–81.

Figure 2–81

12.Click  (Modify) to end the command.

13.Save and close the project.
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Practice 2h Work with Basic Modify Tools - 
Electrical

In this practice, you will rotate lighting fixtures to fit an angled 
ceiling grid, as shown in Figure 2–82.

Figure 2–82

This exercise only covers the Copy and Rotate tools. For 
practice using other basic modify tools, you can complete the 
exercises for the other disciplines.

• For practice using the Move and Copy tools, complete
Practice 2g Work with Basic Modify Tools - Mechanical.

• For practice using the Rotate, Mirror, and Array tools,
complete Practice 2i Work with Basic Modify Tools -
Plumbing.

1. In the practice files Working Models>Electrical folder, open
Elec-Modify.rvt.

2. Open the Electrical>Lighting>Ceiling Plans>1 - Ceiling Elec
view.

3. Select the lighting fixtures.

Practice Objective

• Use the Copy and Rotate basic modify tools.
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4. In the Modify | Lighting Fixtures tab>Modify panel, click 

(Copy).

5. In the Options Bar, verify that Multiple is checked and 
uncheck Constraint.

6. Using the ceiling grids, select inside the other rooms on the 
same side of the hall to copy the lighting fixtures into them in 
approximately the same position, as shown in Figure 2–83.

Figure 2–83

7. Press <Esc> twice.

8. Add a Plain Recessed Lighting Fixture: 2x2 - 277 type 
lighting fixture to the room with the 45 degree ceiling. 
(Remember to use Place on Face.)

9. Click  (Modify) and select the new square lighting fixture.

10. In the Modify | Lighting Fixtures tab>Modify panel, click 

(Rotate).

11. In the Options Bar, verify that Disjoin is unchecked.
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12.Drag the center of rotation control over to the corner of the
light, as shown in Figure 2–84.

13.For the rotation’s first pick, click when the cursor displays a
horizontal line. For the second pick, click on the nearby
45-degree angled line, as shown in Figure 2–85. The fixture
now fits in the grid.

14.Copy the fixture to additional places in the room.

15.Click  (Modify) to end the command.

16.Save and close the project.

Figure 2–84 Figure 2–85

Center of rotation 
control
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Practice 2i Work with Basic Modify Tools - 
Plumbing

In this practice, you will array plumbing fixtures in a restroom and 
then mirror them to the other restroom.

This exercise only covers the Rotate, Mirror, and Array tools. For 
practice using other basic modify tools, you can complete the 
exercises for the other disciplines.

• For practice using the Move and Copy tools, complete 
Practice 2g Work with Basic Modify Tools - Mechanical.

• For practice using the Copy and Rotate tools, complete 
Practice 2h Work with Basic Modify Tools - Electrical.

Note: The model used for this practice has been modified from 
the last plumbing practice.

1. In the practice files Working Models>Plumbing folder, open 
Plumb-Modify.rvt.

2. Open the Plumbing>Floor Plans>1 - Plumbing view.

3. Select the water closet (toilet) and lavatory (sink).

4. In the Modify | Plumbing Fixtures tab>Modify panel, click 

(Array).

5. In the Options Bar, verify that Group and Associate is 
checked, Number is set to 2, and Move to is set to 2nd.

Practice Objective

• Use the Rotate, Mirror, and Array basic modify tools.
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6. Pick the lavatory as the first point and pick a second point
3'-0" below. You are prompted for the number of elements, as
shown in Figure 2–86.

7. Change the array number to 4 and press <Enter>. The
additional fixtures are placed, as shown in Figure 2–87.

8. Click  (Modify) and select all of the fixtures. They are
grouped together.

9. In the Modify | Model Groups tab>Group panel, click

(Ungroup). Each element can now be moved separately.

10.Click  (Modify) and select all the water closets.

11. In the Modify | Plumbing Fixtures tab>Modify panel, click

(Mirror - Pick Axis). In the Options Bar, verify that Copy 
is selected.

12.Hover the cursor on the wall between rooms 102 and 103.
The center of the wall should highlight; if not, use <Tab> to
cycle through the wall’s faces. Select the center of the wall,
as shown in Figure 2–88.

Figure 2–86 Figure 2–87
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Figure 2–88

Note that mirroring the 
lavatories reverses the 
hot and cold water 
connectors. 

13.Click in an empty area in the view to clear the selection.

14.Select one of the lavatories, right-click, and select Create 
Similar. 

15.Place the lavatory across from the water closet in the 
Women’s room.

16.Click  (Modify). Zoom in to the Women’s restroom and 
select and drag the lavatory into place so it aligns with the 
water closet, as shown in Figure 2–89.

Figure 2–89



Autodesk Revit 2022 MEP Fundamentals

2–70 © 2021, ASCENT - Center for Technical Knowledge®

17.With the lavatory still selected, start the Array command.

18. In the Options Bar, clear the Group and Associate option
and set the Number to 4. Verify that Move to is set to 2nd.

19.Click a base point on the lavatory’s upper left corner, then
click a second point 3'-0" below it. Four lavatories are now
placed, which do not need to be ungrouped.

20.Select two of the water closets in Room 102. In the Type
selector, change the type to Urinal - Wall Hung: 3/4" Flush
Valve.

21.Click  (Modify) to end the command.

22.Save and close the project.



Basic Sketching and Modify Tools

© 2021, ASCENT - Center for Technical Knowledge® 2–71

2.5 Working with Additional 
Modify Tools

As you work on a project, some additional tools found in the 
Modify tab>Modify panel (shown in Figure 2–90) can help you 
with placing, modifying, and constraining elements. Align can be 
used with a variety of elements, while Split Element, 
Trim/Extend, and Offset can only be used with linear elements.

Figure 2–90

Aligning
Elements

The Align command enables you to line up one element with 
another, as shown in Figure 2–91. Most Autodesk Revit 
elements can be aligned. For example, you can line up the tops 
of windows with the top of a door or line up furniture with a wall.

Figure 2–91

How To: Align Elements

1. In the Modify tab>Modify panel, click  (Align) or type the 
shortcut AL.

2. Select a line or point on the element that is going to remain 
stationary. For walls, press <Tab> to select the correct wall 
face.
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3. Select a line or point on the element to be aligned. The
second element moves into alignment with the first one.

• The Align command works in all model views, including
parallel and perspective 3D views.

• You can lock alignments so that the elements move together
if either one is moved. Once you have created the alignment,
a padlock is displayed. Click on the padlock to lock it, as
shown in Figure 2–92.

Locking elements 
enlarges the size of the 
project file, so use this 
option carefully.

Figure 2–92

• In the Options Bar, select Multiple Alignment to select
multiple elements to align with the first element. You can also
hold <Ctrl> to select multiple elements to align.

• For walls, you can specify if you want the command to prefer
Wall centerlines, Wall faces, Center of core, or Faces of
core, as shown in Figure 2–93. The core refers to the
structural members of a wall as opposed to facing materials,
such as sheet rock.

Figure 2–93

Splitting Linear
Elements

The Split Element command enables you to break a linear 
element at a specific point. You can use alignment lines, snaps, 
and temporary dimensions to help place the split point. After you 
have split the linear element, you can use other editing 
commands to modify the two parts, or change the type of one 
part, as shown with walls in Figure 2–94. You can split walls in 
plan, elevation, or 3D views.
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Figure 2–94

• The Split with Gap command only works when splitting 
walls.

How To: Split Linear Elements

1. In the Modify tab>Modify panel, click  (Split Element) or 
type the shortcut SL.

2. In the Options Bar, select or clear the Delete Inner Segment 
option.

3. Move the cursor to the point you want to split and select the 
point.

4. Repeat for any additional split locations.
5. Modify the elements that were split, as needed.

• The Delete Inner Segment option is used when you select 
two split points along a linear element. When the option is 
selected, the segment between the two split points is 
automatically removed.

• An additional option,  (Split with Gap), splits the linear 
element at the point you select, as shown in Figure 2–95, but 
also creates a Joint Gap that is specified in the Options Bar.

Figure 2–95

Split

Split with Gap
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Trimming and
Extending

There are three trim/extend methods that you can use with linear 
elements: Trim/Extend to Corner, Trim/Extend Single 
Element, and Trim/Extend Multiple Elements.

• When selecting elements to trim, click the part of the element
that you want to keep. The opposite part of the line is then
trimmed.

How To: Trim/Extend to Corner

1. In the Modify tab>Modify panel, click  (Trim/Extend to 
Corner) or type the shortcut TR.

2. Select the first linear element on the side you want to keep.
3. Select the second linear element on the side you want to

keep, as shown in Figure 2–96.

Figure 2–96

How To: Trim/Extend a Single Element

1. In the Modify tab>Modify panel, click  (Trim/Extend Single 
Element).

2. Select the cutting or boundary edge.
3. Select the linear element to be trimmed or extended, as

shown in Figure 2–97.

Figure 2–97

Pick 1

Pick 2

Pick 1

Pick 2
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How To: Trim/Extend Multiple Elements

1. In the Modify tab>Modify panel, click  (Trim/Extend 
Multiple Elements).

2. Select the cutting or boundary edge.
3. Select the linear elements that you want to trim or extend by 

selecting one at a time, or by using a crossing window (as 
shown in Figure 2–98). For trimming, select the side you 
want to keep.

Figure 2–98

• You can click in an empty space in the view to clear the 
selection and select another cutting edge or boundary.

Offsetting
Elements

The Offset command is an easy way of creating parallel copies 
of linear elements at a specified distance, as shown in 
Figure 2–99. MEP elements can be offset, but you should 
typically use other tools to create parallel elements, such as 
ducts, pipes, and conduits.

Figure 2–99

Pick 3

Pick 2

Pick 1

Alignment line
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The offset distance can be set by typing the distance (Numerical 
method), as shown in Figure 2–100, or by selecting points on the 
screen (Graphical method).

Figure 2–100

How To: Offset Using the Numerical Method

The Copy option (which 
is on by default) makes 
a copy of the element 
being offset. If this 
option is not selected, 
the Offset command 
moves the element the 
set offset distance.

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut OF.

2. In the Options Bar, select the Numerical option.
3. In the Options Bar, type the required distance in the Offset

field.
4. Move the cursor over the element you want to offset. A

dashed line previews the offset location. Move the cursor to
flip the sides, as needed.

5. Click to create the offset.
6. Repeat Steps 4 and 5 to offset other elements by the same

distance.
The offset is from 
centerline to centerline 
of elements, such as 
ducts or pipes.

Most linear elements 
connected at a corner 
automatically trim or 
extend to meet at the 
offset distance.

• With the Numerical option, you can select multiple
connected linear elements for offsetting. Hover the cursor
over an element and press <Tab> until the other related
elements are highlighted, as shown in Figure 2–101. Select
the element to offset all of the elements at the same time.

Figure 2–101

Alignment line
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How To: Offset Using the Graphical Method

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut OF.

2. In the Options Bar, select Graphical.
3. Select the linear element to offset.
4. Select two points that define the distance of the offset and 

which side to apply it. You can type an override in the 
temporary dimension for the second point.

Hint: Using Thin Lines

The software automatically applies line weights to views, as 
shown for a section on the left in Figure 2–102. If a line weight 
seems heavy or obscures your work on the elements, toggle off 
the line weights. In the Quick Access Toolbar or in the View 

tab>Graphics panel, click  (Thin Lines) or type TL. The 
lines display with the same weight, as shown on the right in 
Figure 2–102.

Figure 2–102

• The Thin Line setting is remembered until you change it, 
even if you shut down and restart the software.

Thin Lines off Thin Lines on
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Practice 2j Work with Additional Modify 
Tools - All Disciplines 

In this practice, you will discover and delete excess piping and 
clean it up with modify tools. You will align air terminals to ceiling 
grids. Finally you will offset cable trays and use trim/extend 
commands to link them. You will also split and resize part of the 
tray.

• Additional linear elements, including pipes and cable trays,
have been added to this practice.

Task 1 - Clean up excess piping.

1. In the practice files Working Models>General folder, open
Gen-Align.rvt.

2. Open the Plumbing>Plumbing>3D Views>3D Plumbing
view. Zoom in on the Tee - Generic connection between the
water heater and the pipe in the hall.

3. In the View Control Bar, change the Detail Level to  (Fine)

and the Visual Style to  (Shaded) to help display the pipes
more clearly.

4. If required, in the Quick Access Toolbar, click  (Thin 
Lines) to see the piping better.

5. Delete the highlighted pipe, tee, and transition connectors
between the pipes, as shown in Figure 2–103.

Figure 2–103

Practice Objective

• Use Align, Split, Offset, and Trim/Extend.
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6. You need to connect the two pipes, as shown in 

Figure 2–104. In the Modify tab>Modify panel, click  
(Trim/Extend to Corner).

7. Select the smaller 1/2" pipe first and the 3/4" pipe second. 

• This is so the elbow connector uses the size of the larger 
pipe, as shown in Figure 2–105. 

8. Click  (Modify). 

9. Type ZF to zoom the model to fit the view.

10.Save the project.

Task 2 - Align air terminals to ceiling grids.

1. Open the Mechanical>HVAC>Ceiling Plans>1-Ceiling Mech 
view.

2. Zoom in on Lab 101.

3. In the Modify tab>Modify panel, click  (Align).

Figure 2–104 Figure 2–105
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4. Select a vertical grid line and then the side of the air terminal,
as shown in Figure 2–106.

Figure 2–106

5. While still in the Align command, in the Options Bar, select
Multiple Alignment.

6. Without stopping, select the following items in the order
listed, as shown in Figure 2–107:

• Horizontal grid line

• Horizontal edge of the first air terminal

• Horizontal edge of the 2nd air terminal

Figure 2–107

7. Click in an empty area in the view. This keeps you in the
command but releases the alignment line.

First selection

Second selection

Third 
selection

First selection

Second 
selection
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8. Align the other air terminals to the ceiling grid, as shown in 
Figure 2–108.

Figure 2–108

9. Use the Align tool with or without the multiple alignment (see 
which works the best for you) to move the air terminals in the 
other lab rooms.

10.Zoom to fit the view and then save the project.

Task 3 - Offset, trim, and split cable trays.

1. Open the Electrical>Power>Floor Plans>1 - Power view. 
Zoom all if needed.

2. In the Modify tab>Modify panel, click  (Offset).

3. In the Options Bar, select Numerical, set the Offset to 15'-0", 
and ensure that Copy is selected.
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4. Hover the cursor over the vertical cable tray and ensure that
the alignment line is to the right, as shown in Figure 2–109.
Click to create the copy.

Figure 2–109

5. Select the cable tray in the Mech/Elec 106 room (ensuring
that the offset is to the right) and continue until there are five
total runs, as shown in Figure 2–110.

Figure 2–110

6. Click  (Modify).

7. In the Modify tab>Modify panel, click  (Trim/Extend 
Multiple Elements).

8. Select the cable tray running down the hall and then draw a
crossing window from right to left, as shown in Figure 2–111.

Figure 2–111

Alignment line

Selection startSelection end
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9. The cable trays are extended and fittings applied, as shown 
in Figure 2–112. The last cable tray does not clean up, use 

the  (Trim/Extend to Corner) command to finish it.

Figure 2–112

10.Click  (Modify).

11. In the Modify tab>Modify panel, click  (Split Element).

12.On the cable tray in the Mech/Elec 106 room, select the point 
on the vertical cable tray shown in Figure 2–113. The cable 
tray is split and a fitting is applied.

Figure 2–113

Fitting

Before split After split
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13.Click  (Modify) and select the lower part of the tray. In the
Options Bar, change the Width to 4". The size changes and
the fitting is applied, as shown in Figure 2–114.

Figure 2–114

• Note: You will learn how to justify cable trays in Section
10.5 Adding Cable Trays and Conduit.

14.Save and close the project.
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Chapter Review Questions

1. What is the purpose of an alignment line?

a. Displays when the new element you are placing or 
modeling is aligned with the grid system.

b. Indicates that the new element you are placing or 
modeling is aligned with an existing element.

c. Displays when the new element you are placing or 
modeling is aligned with a selected tracking point.

d. Indicates that the new element is aligned with true north 
rather than project north.

2. Which of the following commands imports a component that 
is not available in your project?

a. .Load Family

b. .Load Equipment

c. .Load Component

d. .Load Fixture

3. How do you select all lighting fixture of various sizes, but no 
other elements in a view?

a. In the Project Browser, select the Lighting Fixtures 
category.

b. Select one lighting fixture, right-click, and select Select 
All Instances>Visible in View.

c. Select all of the elements in the view and use  (Filter) 
to clear the other categories.

d. Select one lighting fixture and click  (Select Multiple) 
in the ribbon.

4. What are the two methods for starting commands such as 
Move, Copy, Rotate, Mirror, and Array?

a. Start the command from the Modify tab and select the 
element.

b. Select the element, then start the command from the 
Modify tab.

c. Select the element, right-click, and select the command 
from the list.
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5. Where do you change the type for a selected plumbing
fixture?

a. In the Modify | Plumbing Fixtures tab>Properties panel,

click (Type Properties) and select a new type in the
dialog box.

b. In the Options Bar, click Change Element Type.

c. Select the dynamic control next to the selected plumbing
fixture and select a new type in the drop-down list.

d. In Properties, select a new type in the Type Selector
drop-down list.

6. Both Rotate and Array with Radial have a center of rotation
that defaults to the center of the element or group of
elements you have selected. How do you move the center of
rotation to another point? (Select all that apply.)

a. Select the center of rotation and drag it to a new location.

b. In the Options Bar, click Place and select the new point.

c. In the Modify tab>Placement panel, click  (Center) and
select the new point.

d. Right-click and select Snap Overrides>Centers and
select the new point.

7. Which command would you use to break part of a duct so
that you can change the duct type?

a. (Align)

b. (Split)

c. (Trim)

d. (Offset)
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Command Summary

Button Command Location
Draw Tools

Center-ends 
Arc

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Circle • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Circumscribed 
Polygon

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Ellipse • Ribbon: Modify | Place Lines, Place 
Detail Lines, and various boundary 
sketches tab>Draw panel

Ellipse Arc • Ribbon: Modify | Place Lines, Place 
Detail Lines, and various boundary 
sketches tab>Draw panel

Fillet Arc • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Inscribed 
Polygon

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Line • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Pick Faces • Ribbon: Modify | Place Wall tab> Draw 
panel

Pick Lines • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Pick Walls • Ribbon: Modify | (various boundary 
sketches) tab>Draw panel

Rectangle • Ribbon: Modify | (various linear 
elements) tab>Draw panel

Spline • Ribbon: Modify | Place Lines, Place 
Detail Lines, and various boundary 
sketches tab>Draw panel

Start-End-
Radius Arc

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Tangent End 
Arc

• Ribbon: Modify | (various linear 
elements) tab>Draw panel

Modify Tools

Align • Ribbon: Modify tab>Modify panel

• Shortcut: AL

Array • Ribbon: Modify tab>Modify panel

• Shortcut: AR

Copy • Ribbon: Modify tab>Modify panel

• Shortcut: CO
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Copy to 
Clipboard

• Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctrl>+<C>

Delete • Ribbon: Modify tab>Modify panel

• Shortcut: DE

Mirror - Draw 
Axis

• Ribbon: Modify tab>Modify panel

• Shortcut: DM

Mirror - Pick 
Axis

• Ribbon: Modify tab>Modify panel

• Shortcut: MM

Move • Ribbon: Modify tab>Modify panel

• Shortcut: MV

Offset • Ribbon: Modify tab>Modify panel

• Shortcut: OF

Paste • Ribbon: Modify tab>Clipboard panel

• Shortcut: <Ctrl>+<V>

Pin • Ribbon: Modify tab>Modify panel

• Shortcut: PN

Rotate • Ribbon: Modify tab>Modify panel

• Shortcut: RO, R3

Scale • Ribbon: Modify tab>Modify panel

• Shortcut: RE

Split Element • Ribbon: Modify tab>Modify panel

• Shortcut: SL

Split with Gap • Ribbon: Modify tab>Modify panel

Trim/Extend 
Multiple 
Elements

• Ribbon: Modify tab>Modify panel

Trim/Extend 
Single Element

• Ribbon: Modify tab>Modify panel

Trim/Extend to 
Corner

• Ribbon: Modify tab>Modify panel

• Shortcut: TR

Unpin • Ribbon: Modify tab>Modify panel

• Shortcut: UP

Select Tools

Drag elements 
on selection

• Ribbon: All tabs>expanded Select
panel

• Status Bar

Filter • Ribbon: Modify | Multi-Select tab>
Filter panel

• Status Bar

Select Elements 
By Face

• Ribbon: All tabs>expanded Select
panel

• Status Bar
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Select Links • Ribbon: All tabs>expanded Select 
panel

• Status Bar

Select Pinned 
Elements

• Ribbon: All tabs>expanded Select 
panel

• Status Bar

Select Underlay 
Elements

• Ribbon: All tabs>expanded Select 
panel

• Status Bar

Additional Tools

Aligned 
Dimension

• Ribbon: Modify tab>Measure panel

• Quick Access Toolbar

Component • Ribbon: Architecture/Structure/ 
Systems tab

• Shortcut: CM

Detail Line • Ribbon: Annotate tab>Detail panel

• Shortcut: DL

Model Line • Ribbon: Architecture tab>Model panel

• Shortcut: LI

Reference 
Plane

• Ribbon: Architecture/Structure/ 
Systems tab>Work Plane panel
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