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Mass Elements 
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Lesson 2 
Mass Elements 
 
Mass Elements are used to give you a conceptual idea of the space and shape of a 
building without having to take the time to put in a lot of detail. It allows you to create 
alternative designs quickly and easily and get approval before you put in a lot of effort. 
 

Massing Tools 
 
 

 

Show Mass controls the visibility of mass entities. 

 

Creates a solid shape. 

 

Inserts a mass group into the active project.  

 

Model by Face: 
Converts a face into a Roof, Curtain Wall System, Wall, or Floor. 

 
 
When creating a conceptual mass to be used in a project, follow these steps: 
 

1. Create a sketch of the desired shape(s). 
2. Create levels to control the height of the shapes. 
3. Create reference planes to control the width and depth of the shapes. 
4. Draw a sketch of the profile of the shape. 
5. Use the Massing tools to create the shape. 

 
 
Masses can be used to create a component that will be used in a project, such as a 
column, casework, or lighting fixture, or they can be used to create a conceptual building.
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Exercise 2-1 
Shapes 
 
Drawing Name: shapes.rfa 
Estimated Time: 5 minutes 
 
This exercise reinforces the following skills: 
 

 Creating basic shapes using massing tools 
 Create an extrude 
 Modify the extrude height 
 Create a revolve 
 Create a sweep 
 Create a blend 
 Modify a blend 

 
 
 
1.  

 
 

There are several 
sketches in the 
file. 
 
Each set of 
sketches will be 
used to create a 
specific type of 
mass form. 
 
Revit knows 
what type of 
shape you want 
to create based 
on what you 
select.  It’s all in 
the ingredients! 
 

2.  

 

The most basic mass form is an extrude. This 
mass form requires a single closed polygonal 
sketch. 
 
The sketch should have no gaps or self-
intersecting lines. 
 
Select the rectangle so it highlights. 
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3.  

 

When the sketch is selected, you will see grips 
activated at the vertices. 

4.  

 
 

Select Create Form→Solid Form to create the extrude. 
 
You won’t see the Create Form tool on the ribbon unless a sketch 
is selected. 

5.  A preview of the extrude is displayed. 
 

 
 

 
 
You can use the triad on the top of the 
extrude to extend the shape in any of the 
three directions. 
 
There are two dimensions: 
 
The bottom dimension controls the height 
of the extrude. 
The top dimension controls the distance 
from top face of the extrude and the next 
level. 

6.  Activate the East Elevation. 
 

 
 

 
 
You can see how the 
dimensions are indicating 
the relative distances 
between the top face and 
the upper level, the bottom 
face, and another sketch. 
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7.  

 
 

Change the 30′-0″ dimension to 45′-0″. 
To change the dimension, left click on the 
30' 0" dimension text. 
 
Click Enter. 
 
 

8.  

 
 

Note how the other 
relative dimensions 
update. 
 
Left Click anywhere in 
the window to exit 
defining the mass. 
 
 
 
If you click Enter, you 
will create a second 
mass. 

9.  
 

 

Switch to a 3D view. 

10.  

 
 

 
Select the Back/North face of the 
block.  Use the Viewcube to verify 
the orientation. 
 
To select the face, place the mouse 
over the face and click the tab key 
until the entire face highlights. 
 
This activates the triad and also 
displays the temporary dimensions. 
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11.  

 

You will see two temporary dimensions. 
One dimension indicates the distance of 
the face to the opposite face (the length 
of the block). One dimension indicates 
the distance of the face to the closest 
work plane. 
 
Change the 88′ 0″ dimension to 90′-0″. 
 
Left click in the window to release the 
selection and complete the change. 
 
If you click Enter, you will create a 
second mass. 
 

12.  

 

Use the View Cube to reorient 
the view so you can clearly see 
the next sketch. 
 
This sketch will be used to 
create a Revolve. 
 
A Revolve requires a closed 
polygonal shape PLUS a 
reference line which can be 
used as the axis of revolution. 

 
 

13.  

 
 

Hold down the CONTROL key and select the Axis Line 
(this is a reference line) and the sketch. 
 
 
 
 
 
Note that a reference line automatically defines four 
reference planes. These reference planes can be used to 
place sketches. 
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14.  

 
 

Select Create Form→Solid Form. 

15.  

 
 

A Revolve will be created. 

 Our next mass form will be a SWEEP. 
 
A sweep requires two sketches. One sketch must be a closed polygonal shape. This 
sketch is called the profile. The second sketch can be open or closed and is called 
the path. The profile travels along the path to create the sweep. 
 

16.  

 
 

Hold down the CONTROL key and select the 
small circle and the sketch that looks like a 
question mark. 
 
The two sketches will highlight. 

17.  

 
 

Select Create Form→Solid Form. 

18.  

 
 

The sweep will be created. 
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 The most common error when creating a sweep is to make the profile too big for the 

path. If the profile self-intersects as it travels along the path, you will get an error 
message. Try making the profile smaller to create a successful sweep.  Sweeps are 
useful for creating gutters, railings, piping, and lighting fixtures. 
 

19.  

 
 

Our final shape will be a BLEND or LOFT. 
A blend is created using two or more open 
or closed sketches. Each sketch must be 
placed on a different reference plane or 
level. 
 
Hold down the CONTROL key and select 
the three arcs. 

20.  

 

Select Create Form→Solid Form. 

21.  

 

A blend shape is created. 
 
Blends are used for complex profiles and shapes. 
 
Close without saving. 

 
 
 
Challenge Task: 
 
Can you create the four basic shapes from scratch? 
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Create an extrude, revolve, sweep and blend using New→Conceptual Mass from the 
Applications menu. 
 
Steps to make an Extrude: 
 

1. Set your active plane using the Set Work Plane tool. 
2. Create a single polygonal sketch with no gaps or self-intersecting lines. 
3. Select the sketch. 
4. Create Form→Solid Form. 
5. Green Check to finish the mass. 

 
Steps to make a Revolve: 
 

1. Set your active plane using the Set Work Plane tool. 
2. Switch to a 3D view. 
3. Draw a reference line to be used as the axis of revolution.  
4. Pick one of the planes defined by the reference line as the active plane to place 

your sketch. 
5. Create a single polygonal sketch – no gaps, overlapping or self-intersecting lines 

– for the revolve shape.  
6. Hold down the CONTROL key and select BOTH the sketch and reference line. If 

the reference line is not selected, you will get an extrude. 
7. Create Form→Solid Form. 
8. Green Check to finish the mass. 
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Steps to make a Sweep: 
 

1. Activate Level 1 floor plan view. You need to select one reference plane for the 
profile and one reference plane for the path. The reference planes must be 
perpendicular to each other. Set Level 1 for the path’s reference plane.  

2. Draw a path on Level 1. The path can be a closed or open sketch. 
3. Create a reference plane to use for the profile. Draw a reference plane on Level 1 

– name it profile plane. Make this the active plane for the profile sketch. 
4. Switch to a 3D view. Create a single polygonal sketch – no gaps, overlapping or 

self-intersecting lines. The profile sketch should be close to the path or intersect it 
so it can follow the path easily. If it is too far away from the path, it will not 
sweep properly, or you will get an error. 

5. Hold down the CONTROL key and select BOTH the path and the profile. If only 
one object is selected, you will get an extrude. 

6. Create Form→Solid Form. 
7. Green Check to finish the mass. 

 
Steps to make a Blend: 
 

1. Blends require two or more sketches. Each sketch should be on a parallel 
reference plane. You can add levels or reference planes for each sketch. If you 
want your blend to be vertical, use levels. If you want your blend to be horizontal, 
use reference planes. 

a. To add levels, switch to an elevation view and select the Level tool. 
b. To add reference planes, switch to a floor plan view and select the 

Reference Plane tool. Name the reference planes to make them easy to 
select. 

2. Set the active reference plane using the Option Bar or the Set Reference Plane 
tool. 

3. Create a single polygonal sketch – no gaps, overlapping or self-intersecting lines.  
4. Select at least one more reference plane to create a second sketch. Make this the 

active plane. 
5. Create a single polygonal sketch – no gaps, overlapping or self-intersecting lines.  
6. Hold down the CONTROL key and select all the sketches created. If only one 

object is selected, you will get an extrude. 
7. Create Form→Solid Form. 
8. Green Check to finish the mass. 
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Exercise 2-2 
Create a Conceptual Model 
 
Drawing Name: default.rte [DefaultMetric.rte] 
Estimated Time: 5 minutes 
 
This exercise reinforces the following skills: 
 

 Switching Elevation Views 
 Setting Project Units 
 Add a Level 

 
This tutorial uses metric or Imperial units. Metric units will be designated in brackets. 
 
Revit uses a level to define another floor or story in a building. 
 
1.   

 

 
Select New →Project. 

2.  

 
 

Select the default template in the drop-down list. 
 
This template was added to the list in Exercise 1-8. 
 

3.  

 
 

If you don’t see the default 
template… 
 
Under the Template file, select 
Browse. 

4.   
 

Locate the English-Imperial folder under 
ProgramData/Autodesk/RVT 2023/ 
Templates. 

 

 
 

For Metric:  
Locate the English folder under 
ProgramData/Autodesk/RVT 2023/ 
Templates. 
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5.  

 
 

Notice the types of templates available in each of these 
folders. 
 
The number of templates available was determined 
when the software was installed. You can add more 
templates by modifying the installation using the 
Control Panel or download additional templates from 
Autodesk’s content library. 
 

6.  

  
Click OK. 

Select the default.rte [DefaultMetric.rte] 
template. 
 
Brackets indicate metric, which can be 
selected as an alternative. 
 

If you accidentally picked Metric when you wanted Imperial or vice versa, you can 
change the units at any time.  
To change Project Units, go to the Manage Ribbon. 
 

 
 

Select Settings→Project Units. 

 

Left click the Length button, then select 
the desired units from the drop-down list. 
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7.  

 
 

Double click East under Elevations. 
 
This activates the East view orientation. 

8.   
 

Select the Architecture ribbon. 

9.  

 
 

Select the Level tool under Datum. (This adds a floor elevation.) 

10.  

 
 

Move your mouse to set an elevation of 22′ [3650 mm] using 
12’ above Level 2.  
 
Pick to start the elevation line. 

 
11.   

 

In the Options bar, enable Make Plan View.  
The Options bar can be located below the ribbon or at the bottom of the screen. 
 

  If the Options bar is located below the ribbon and you 
would prefer it on the bottom of the screen, right click and select Dock at Bottom. 

  If the Options bar is located at the bottom of the screen 
and you would prefer it to be below the ribbon, right click on the Options bar and 
select Dock at Top. 

  
Make Plan View should be enabled if you want Revit to automatically create a floor 
plan view of this level. If you forget to check this box, you can create the floor plan 
view later using the View Ribbon. 
 

 
Double click on the blue elevation symbol to automatically switch to the 
floor plan view for that elevation. 
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12.  

 
 

Pick to place the end point to position the level indicator 
above the other indicators. 
 

13.  Basically, you place a new level by picking two points at the desired height. 
 
Right click and select Cancel to exit the Level command. 

  
Revit is always looking for references even among annotations; you will notice that 
your level tags snap and lock together so when you move one to the right or left, all 
those in line with it will follow. 
 
The jogged line allows the user to create a jog if desired.  
 
If you need to adjust the position of the tag, just click on the line; 3 blue grips will 
appear. These can be clicked and dragged as needed. You can also right click on a 
level tag and select ‘Hide annotation in view’ and the tag and level line will 
disappear in that view only. 

 Hide Annotation in View is only enabled if an object is selected first. 
 

14.  Save the file as a project as ex2-2.rvt. 
 
 
 

 
 
Revit has an option where you can save the current file, whether it is a project file or a 
family, to a cloud server.  In order for this option to be available, you have to pay a 
subscription fee to Autodesk for the cloud space. 
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Exercise 2-3 
Adding an In-Place Mass 
 
Drawing Name: in-place mass.rvt 
Estimated Time: 10 minutes 
 
This exercise reinforces the following skills: 
 

 Switching Elevation Views 
 Add Mass 

 
1.   

 
Open in-place mass.rvt. 

2.  

 
 

Activate the Level 1 view. 

3.   
 

Select the Massing & Site ribbon. 

4.  

 
 

Select the In-Place Mass tool. 
 
 

 Revit uses three different family categories. System families are families which are 
defined inside the project, such as floors, walls, and ceilings. Loadable families are 
external files which can be loaded into the project, such as doors, windows, and 
furniture. The third family category is in-place masses, which are families created 
on-the-fly.  In-place masses are only available inside the project where they are 
created and are usually unique to the project since they aren’t loadable.  However, 
you can use the Copy and Paste function to copy in-place masses from one project 
to another, if you decide to re-use it.  That can be a hassle because you need to 
remember which project is storing the desired in-place mass. 
 

5.  

 
 

Masses, by default, are invisible. However, in 
order to create and edit masses you need to see 
what you are doing. Revit brings up a dialog to 
let you know that the software is switching the 
visibility of masses to ON, so you can work. 
 
Click Close. 

 If you don’t want to be bugged by this dialog, enable the Don’t show me this 
message again option. 
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6. 
 

Enter Mass 1 in the Name field. 
 
Click OK. 

 
Next, we create the boundary sketch to define our mass. This is the footprint for the 
conceptual building. 

 

7.  

 
 

Select the Line tool located under the Draw 
panel. 

8.   
 
Enable Chain in the Options bar. 
This allows you to draw lines without always having to pick the start point. 
If you hold down the SHIFT key while you draw, this puts you in orthogonal mode. 

 
9.  Create the shape shown. 

The left figure shows the units in Imperial units (feet and inches). 
The right figure shows the units in millimeters.  
 

      
 

 You can draw using listening dimensions or enter the dimension values as you draw. 
 
For feet and inches, you do not need to enter the ‘ or “ symbols.  Just place a space 
between the numbers. 
 
Revit doesn’t have a CLOSE command for the LINE tool unlike AutoCAD, so you do 
have to draw that last line. 
 

10.  Exit out of drawing mode by right clicking and selecting Cancel twice, selecting 
ESC on the keyboard or by selecting the Modify button on the ribbon. 
 

11.  
 

 

Switch to a 3D view. 
Activate the View ribbon and select 3D View. 
 
You can also switch to a 3D view from the Quick Access toolbar by 
selecting the house icon.  
 

  
 

12.  Window around the entire sketch so it is highlighted. 
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13.  

 
 

Select Form→Create Form→Solid Form. 
 
 
You must select the sketch to create the form. 
 
If the sketch has any gaps, overlapping lines, or self-intersecting 
lines, you will get an error. Exit the command and inspect the 
sketch to make sure it is a cleanly closed polygon. 

14.  

 
 

An extrusion distance is displayed. 
This can be edited, if desired. 

15.  

 
 

Select the green check box to Finish Mass. 

 The Mass is created. 
 

 
 

16.  Save the file as ex2-3.rvt.  
 

 
Object tracking will only work if the sketch objects are active and 
available in the current sketch. You can use Pick to copy entities into the 
current sketch. 
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Exercise 2-4 
Modifying Mass Elements 
 
Drawing Name: modify mass.rvt 
Estimated Time: 30 minutes 
 
This exercise reinforces the following skills: 
 

 Show Mass 
 Align 
 Modify Mass 
 Mirror 
 Create Form 
 Save View 

 
1.  Open modify mass.rvt. 

 
 

2.  

 

If you don’t see the mass, Show Mass Form 
and Floors on the Massing & Site ribbon to turn 
mass visibility ON. 
 

  
Some students may experience this issue if they close the file and then re-open it for 
a later class. 
 

3.  

 
 

Activate the East Elevation. 

 
Remember if you don’t see the mass, Show Mass Form 
and Floors on the Massing & Site ribbon to turn mass 
visibility ON. 
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4.  We see that top of the building does not align with Level 3. 

 

 
 

 To adjust the horizontal position of the level lines, simply select the line and use the 
grip to extend or shorten it. 
 

5.   
 

Select the Modify Ribbon. 

6.  

 
 

Select the Align tool. 
 
 

 When using Align, the first element selected acts as the source, and the second 
element selected shifts position to align with the first element. 
 

7.  

 
 

Select the top level line (Level 3) 
then select the top of the extrusion. 
 
Right click and select Cancel twice 
to exit the Align command. 

8.  The top of the extrusion now aligns to Level 3. 
 

 

 
 
The lock would constrain or lock 
the top of the extrusion to the 
level. If the level elevation 
changes, then the extrusion will 
automatically update. 

   
9.  

 
 

Activate Level 2 under Floor Plans. 
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10.  

 
 

Select In-Place Mass from the Massing & Site ribbon. 
 

11.  

 

Name the new mass Tower. 
 
Click OK. 

 
12.  

 
 

You can use object tracking to locate the 
intersection between the two corners. 
 
To activate object tracking, enable the Pick 
Lines tool located under Draw. Then select 
the two lines you want to align with. 

13.  

 
 

Select the two lines indicated to be used for object 
tracking to locate the center of the circle. 
 
Click ESC or CANCEL to exit the Pick Lines 
command. 

14.  

 
 

Select the Circle tool under Draw. 

15.   
Uncheck Make surface from closed loops on the Options bar. Enable Chain. 
 

16.  

 
 

When you see the large X and the tooltip says Intersection, you 
will have located the intersection. 
 
Pick to locate the center of the circle at the intersection. 

17.  

 
 

Enter a radius of 16′-0″ [4880]. 
 
Cancel out of the command. 
 
 

 When you used the Pick Line tool, you copied those lines into the current sketch. 
Once the lines were part of the current sketch, they could be used for object 
tracking. 
 

18.  Select the circle sketch so it is highlighted. 
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19.  

 
 

Select the Draw Mirror Axis tool on the Modify panel. 

20.  

 

Locate the midpoint of 
the small horizontal line 
and pick. 
 

21.  

 
 

Bring your mouse down in the 
Vertical direction and pick for the 
second point of the mirror axis. 

22.  

 
 

The circle 
sketch is 
mirrored. 
 
Left click 
to release 
the 
selection. 

23.  

 
 

Switch to a 3D view using the Project Browser. 
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24.  

 
 

Select one of the circles so it is highlighted. 
Remember you can only extrude one closed polygon at a time. 
 

Select Form→Create Form→Solid Form. 

25.  

 
 

A small toolbar will appear with two options for extruding 
the circle. 
 
Use the SPACE BAR to cycle through the different forms.  
 
 
Click ENTER to select the option that looks like a 
cylinder or right click the mouse. 
 

26.  

 
 

A preview of the extrusion will appear with the temporary 
dimension. You can edit the temporary dimension to modify the 
height of the extrusion. 
 
Click ENTER or left click to accept the default height. 

27.  

 
 

If you click ENTER more than 
once, additional cylinders will 
be placed. 
 
The circle is extruded. 

28.  

 
 

Select the remaining circle so it is highlighted. 
 

Select Form→Create Form→Solid Form. 
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29.  

 
 

A small toolbar will appear with two options for extruding 
the circle. 
 
Use the SPACE BAR to cycle through the different forms.  
 
 
Click ENTER to select the option that looks like a cylinder 
or right click the mouse. 
 
 

30.  

 
 

A preview of the extrusion will appear with the temporary 
dimension. You can edit the temporary dimension to modify the 
height of the extrusion. 
 
Click ENTER or left click to accept the default height. 
 
If you click ENTER more than once, you will keep adding 
cylinders.  
 
Click ESC or right click and select CANCEL to exit the 
command. 

 

 
 

Both circles are now extruded. 

31.  

 
 

Select the two lines 
used to locate the 
circle sketch. 
 
Right click and select 
Delete from the 
shortcut menu to 
delete the lines. 
 
 

 You can also click the Delete key on the keyboard or use the Delete tool on the 
Modify panel. 
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32.  

 
 

Select Finish Mass.  
 
If you do not delete the lines before you finish the mass, you will get an 
error message. 

33.  

 
 

Activate the South Elevation. 

34.  Select each level line. 
 

 

 
 

Right click and select Maximize 3D Extents. 
This will extend each level line so it covers the entire model. 
 

35.  
 

 

Activate the Modify ribbon. 
 
Select the Align tool from the Modify Panel. 

36.  

 
 

On the ribbon, enable Multiple Alignment. 
Select Wall faces from the drop down list. 
 

37.  

 

Select the Level 3 line as the source object. 

 
38.  Select the top of the two towers as the edges to be shifted. 

Right click and select CANCEL twice to exit the command or click ESC. 
 

 
 

39.  

 
 

Switch to a 3D view using the Project Browser. 

40.  

 
 

Use the ViewCube located in the upper right of the screen to orbit 
the model. 
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41.  To save the new orientation, right click on 
the ViewCube and select Save View. 
 

 
 

42.  
 

 

Enter 3D Ortho for the name of the view. 
 
Click OK. 
 

43.  
 

 

The Saved view is now listed in the Project browser under 3D 
Views. 

44.  Save the file as ex2-4.rvt.  
 
 

 Pick a mass element to activate the element’s grips. You can use the 
grips to change the element’s shape, size, and location. 

 You can only use the View→Orient menu to activate 3D views 
when you are already in 3D view mode. 

 

Wall by Face 
 

 

This tool can be used to place walls on non-horizontal faces of 
a mass instance or a generic model. 
 
If you modify the mass, the wall will not update. To update the 
wall, use the Update to Face tool. 
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Exercise 2-5 
Create Wall by Face 
 
Drawing Name: wall by face.rvt 
Estimated Time: 15 minutes 
 
This exercise reinforces the following skills: 
 

 Wall by Face 
 Trim 
 Show Mass 

 
You can add doors and windows to your conceptual model to make it easier to visualize. 
 
1.  Open wall by face.rvt. 

 
 

2.  

 
 

Activate the 3D Ortho view under 3D Views. 

3.   
 

Activate the Massing & Site ribbon. 

4.  

 
 

Select Model by Face→Wall. 

5.  

 
 

Imperial: 
Set the Default Wall Type to:  
Basic Wall: Generic- 8″. 

Note the wall type currently enabled in the 
Properties pane. A different wall type can be 
selected from the drop-down list available using 
the small down arrow. 
 
Metric: 
Set the Default Wall Type to:  
Basic Wall: Generic- 200 mm. 

   
6.  

 
 

Enable Pick Faces from the Draw Panel on the ribbon. 
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7.  

 
 

Select each wall and cylinder. 
The cylinder will be halved by the 
walls, so you will have to select 
each half. 
 
You will have to do some cleanup 
work on the corners where the 
towers are. 
 
Right click and select CANCEL to 
exit the command. 
 

 Some students will accidentally pick the same face more than once. You will see an 
error message that you have overlapping/duplicate walls. Simply delete the extra 
walls. 
 

8.  

 
 

Select any visible mass. 
Right click and select Hide in 
View→ Category. 
 
This will turn off the visibility of 
masses. 
 

 

You can also disable 
Show Mass on the 
ribbon. 

 

9.  

 
 

Activate Level 1 floor plan. 

10.  

 
 

Window around all 
the walls to select. 
 

11.  

 
 

Select the Filter tool from the ribbon. 

12.  

 

Uncheck all the boxes EXCEPT walls. 
Click OK. 
 
There are some duplicate walls in this selection. 
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13.  

 
 

In the Properties pane: 
 
Set the Top Constraint to up to Level 3. 
 
Right click and select Cancel to release the 
selection or left click in the display 
window to release the selection. 
 

14.  

 
 

Hold down the Ctrl Key. 
Select the four walls indicated. 
 

15.  

 
 

In the Properties pane: 
 
Set the Top Constraint to Up to Level 2. 
 
Right click and select Cancel to release 
the selection or left click in the display 
window to release the selection. 
 

16.  

 

Activate Level 2 under Floor Plans. 

 
17.  

 
 

In the Properties Pane: 
Go to the Underlay category. 
 
Set the Range Base Level to Level 2. 
Set the Range Top Level to Level 3. 
Set the Underlay orientation to Look down. 
 

 This will turn off the visibility of all entities located below Level 2.  
 
Each view has its own settings. We turned off the visibility of masses on Level 1, but 
we also need to turn off the visibility of masses on the Level 2 view. 
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18.  

 
 

On the Massing & Site ribbon: Toggle the Show 
Mass tool to turn the visibility of masses OFF. 

 

 
 

The view should look like this 
with the visibility of masses 
turned off. 

19.  

 
 

Activate the Modify ribbon. 
 
Select the Trim tool from the Modify ribbon 
to clean up where the tower joins with the 
walls. 

20.  When you select to trim, be sure to select the section you want to keep. 
 

 

21.  

 

Select the arc and wall indicated. 

22.  

 

If you see this dialog, click the Unjoin Elements 
button and proceed. 

23.  

 

Select the arc and wall indicated.  
 

  
 
Note that you have some instructions in the lower 
left of the screen to assist you. 
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24.  

 
 

Trim the walls as 
shown on Level 2. 

25.  

 

Activate Level 1. 

26.  

 
 

On Level 1, you should only see the 
walls with no towers. 
 
There are some small gaps where the 
towers overlap. 
 
If you see the mass, select it, right 
click and select Hide in 
View→Elements. 

27.  

 
 

Activate the Architecture ribbon. 
 
Select the Wall tool on the Build Pane. 

28.  
 

On the Options bar: 
Set the Height to Level 2. 
 

29.  
 

 
Disable Chain. 

30.  

 
 

Close the gaps and 
trim as needed. 
 
Cancel out of the 
command. 
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31.  Switch to a 3D view and orbit your model. 

 
 

 
 
Check to make sure the walls 
and towers are adjusted to the 
correct levels. 
 
Turn off the visibility of 
masses to see the walls. 

32.  Save as ex2-5.rvt.  
 
Exercise 2-6 
Adding Doors and Windows 
 
Drawing Name: doors and windows.rvt 
Estimated Time: 30 minutes 
 
This exercise reinforces the following skills: 
 

 Basics 
 Door 
 Load from Library 
 Window 
 Array 
 Mirror 
 Shading 

 
You can add doors and windows to your conceptual model to make it easier to visualize. 
 
1.  Open doors and windows.rvt. 

 
 

2.  

 
 

Activate Level 1 under Floor Plans. 

3.  

 

Level 1 should appear like this. 
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4.   

 
Activate the Architecture ribbon. 

5.  
 

 

Select the Door tool under the Build panel. 

6.  

 

Select Load Family under the Mode panel. 
 
Doors are loadable families. 

   
7.   

 

 

 
 
Browse to the Doors folder under the Imperial or Metric library – use English- 
Imperial if you are using Imperial units or use English if you are using Metric units. 

 

 
 

As you highlight each file in the folder, you can see a preview of the 
family. 
 
 
Note that the files are in alphabetical order. 

8.  

 
 

 

For Imperial Units: Go to the Commercial folder. 
Locate the Door-Exterior-Double.rfa file. 
 
For Metric Units: Go to the Commercial folder. 
Locate the M_Door-Exterior-Double.rfa file. 
 
Click Open. 
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9.  

 
For Imperial Units:  Highlight the 84” x 80” type and click OK. 
 

 
For Metric Units:  Highlight 2100 x 2000m type and click OK. 
 

10.  

 
Place the door so it is centered on the wall as shown. 
Doors are wall-hosted, so you will only see a door preview when you place your 
cursor over a wall. 
 
Right Click and CANCEL to exit the command. 
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11.  

 
 

If you click the space bar before you pick to place, you can 
control the orientation of the door. 
 
After you have placed the door, you can flip the door by 
picking on it then pick on the vertical or horizontal arrows. 
 

12.  

 
 

Pick the Window tool from the Build panel. 
 

Windows are model families. 

13.  

 
 

Select Load Family from the Mode panel. 

14.   

 
 

 
Browse to the Windows folder under the Imperial or Metric library – use English- 
Imperial if you are using Imperial units or use English if you are using Metric units. 

   
15.  

 
 

 

For Imperial Units: 
Locate the Window-Casement-Double.rfa file. 
 
 
For Metric Units: 
Locate the M_Window-Casement-Double.rfa file. 
 
Click Open. 
 

16.  

 
 

For Imperial Units: 
 

Select the 48” x 24″ type window to be loaded. 
 
 
 

 

 
 

For Metric Units: 
 
From the Type Selector drop-down list, select the 1400 x 
600mm size for the M_Window-Casement-Double 
window. 
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17.  The family is already loaded in 
the project but doesn’t have this 
size.  Select the second option to 
add the additional type. 

 
18.  

 
 

Verify that the correct window type is selected in the 
Type Selector on the Properties pane. 

19.  

 

Place the window 6′-6″ [3000 mm] from the inner left wall. 
 
Right click and select Cancel to exit the command. 

 
20.  

 
 

The arrows appear on the exterior side of the 
window. If the window is not placed correctly, left 
click on the arrows to flip the orientation. 

21.  

 
 

Select the window so it highlights. 

22.   
 

Select the Array tool under the Modify panel. 

23.  

 

Select the midpoint of the window as the basepoint for the array. 

24.  
 

 
Enable Group and Associate. This assigns the windows placed to a group and allows 
you to edit the array. 
 
Set the array quantity to 5 on the options bar located on the bottom of the screen. 
Enable Last. 
 
Enable Constrain. 
 
Enabling Constrain ensures that your elements are placed orthogonally. 
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Array has two options. One option allows you to place elements at a set distance 
apart. The second option allows you to fill a distance with equally spaced elements. 
We will fill a specified distance with five elements equally spaced. 
 

25.  

 
Pick a point 49′-0″ [14,935.20] from the first selected point to the right. 
 

26.  

 
You will see a preview of how the windows will fill the space.  
 
Click ENTER to accept. 
 
Cancel out of the command. 
 

27.   
 

Select the Measure tool on the Quick Access toolbar. 

28.  

 
 

Check the distance between the windows and you will 
see that they are all spaced equally. 

29.  

 
Window around the entire array to select all the windows. 
 
The array count will display. 
 

30.  
 

Use the Mirror→Draw Mirror Axis tool to mirror the windows to the other 
side of the wall opposite the door. 
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31.  

 
 

Select the center of the door as the start point 
of the mirror axis. 
 
Move the cursor upwards at a 90 degree 
angle and pick a point above the door. 

32.  Left pick anywhere in the graphics window to complete the command. 
 
You will get an error message, and the windows will not array properly if you do not 
have the angle set to 90 degrees or your walls are different lengths. 
 

33.  
 

Switch to a 3D View. 

  
  
34.  

 
 

Set the Model Graphics Style to Consistent 
Colors. 
 
We have created a conceptual model to show a 
client. 
 

35.  Save the file as ex2-6.rvt.  
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Exercise 2-7 
Creating a Conceptual Mass 
 
Drawing Name: New Conceptual Mass 
Estimated Time: 60 minutes 
 
This exercise reinforces the following skills: 
 

 Masses 
 Levels 
 Load from Library 
 Aligned Dimension 
 Flip Orientation 

 
 
1.  Close any open files. 

 
2. 

 
Use the Application Menu and 
go to New→Conceptual Mass. 

     

 
 

3.  

 
 

Browse to the Conceptual Mass folder 
under Family Templates\English-
Imperial. 

4.  

 

Select the Mass template. 
 
Click Open. 

5.  

 

Activate the South Elevation. 
 
You don’t see the icons for the views because we are working 
in a family file. The family will be used in a project. 
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6.  

 
 

On the Create ribbon, select the Level tool. 

7.  

 
 

Place a Level 2 at 50′ 0″. 
 
You can type in 50 as a listening dimension to position 
the level or place the level, then modify the elevation 
value by selecting the dimension. 

8.  
 

 

Activate the Level 1 floor plan. 

9.   
 

Activate the Create ribbon. 
 
Select the Plane tool from the Draw panel. 
 

10.  Draw a vertical plane and a horizontal plane to form a box. 
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11.  

 

Use the ALIGNED DIMENSION tool to add 
dimensions to the reference planes. 

 
To modify the dimensions, select the plane, then 
modify the temporary dimension. The permanent 
dimension will automatically update. 
 
Set the horizontal dimension to 100′ 0″ overall. 
 

Set the vertical dimension to 60′ 0″ overall. 
 

  
Remember the permanent dimensions are driven by the values of the temporary 
dimensions. To set the temporary dimension values, select the reference planes. 
The planes you placed are unlocked – so their dimensions can be changed.  

12.  

 
 

Activate the Insert ribbon. 
 

Select Load Family from Library→Load Family. 

13.  

 
 

Browse to the Mass folder. 

14.  

 
 

Hold down the CTRL Key and 
select the Dome, Box, and 
Cylinder files. 
 
Click Open. 
 
Notice that the file names are 
alphabetized. 
 

15.  

 
 

Activate the Create ribbon. 
 
Select the Component tool on the Model panel. 
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16.  

 

Select the Box component using the Type 
Selector. 

17.  

 
 

Select Place on Work Plane on the Placement panel. 

18.   
 

Set the Placement Plane to Level 1. 

19.  

 
 

Place the box in the view. 
 
Right click and select Cancel 
twice to escape the command. 

20.  

 
 

Select the ALIGN tool from the Modify panel. 

21.  
 

 

Disable Multiple Alignment on the Options bar. 

22.  

 
 

Select the reference plane on the left. 
 
Select the left side of the box. 
 
Left click on the lock to fix the alignment. 



Mass Elements 

2-41 

23.  

 

Select the reference plane on 
the top. 
 
Select the top side of the box. 
 
Left click on the lock to fix 
the alignment. 
 
Right click and select Cancel 
to exit the ALIGN command. 

24.  

 
 

Left click on the box to select it. 
 
Use the right grip to drag the right side 
of the box to the right reference plane. 
 
Left click on the lock to fix the 
alignment. 

25.  

 
 

Use the bottom grip to drag the bottom 
side of the box to the right reference 
plane. 
 
Left click on the lock to fix the 
alignment. 
 
Left click in the window to release the 
selection. 

26.  

 
 

Activate the South Elevation. 

27.  

 
 

The box height is not aligned to 
Level 2. 
 
 

28.  

 

Switch to a 3D view. 
 
Select the box. 
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29.  

 

Change the Height to 50’ 0” in the Properties 
pane. 
 
Click the Apply button. 
 
Click ESC to release the box selection or left 
click anywhere in the window. 
 

30.  
 

 

Activate the Level 2 floor plan. 

31.  

 
 

With Level 2 highlighted, scroll down the Properties 
pane to the Underlay category. 
Set the Range: Base Level to Level 1. 
 
If you don’t set the underlay correctly, you won’t see the 
box that was placed on Level 1. 
 

32.  

 
 

Activate the Create ribbon. 
 
Select the Component tool on the Model panel. 

33.  

 
 

Select the Cylinder component using the 
Type Selector. 

34.  

 
 

In the Properties Pane:   
 

Set the Radius to 25′ 0″. 
Set the Height to 5′ 0″. 
 

 If you need to adjust the position of the cylinder: Set the Offset to -5′ 0″.  
 
This aligns the top of the cylinder with the top of the box. 
 

35.  

 
 

Select Place on Work Plane on the Placement panel. 

36.  
 

 

Set the Placement Plane to Level 2. 
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37.  

 
 

Place a cylinder at the midpoint of the 
bottom edge of the box. 
 
Right click and select Cancel twice to 
escape the command. 

38.  

 
 

Switch to a 3D View. 

39.  

 
 

You should see the box as well as the cylinder. 

40.  
 

 

Activate Level 2. 

41.  

 
 

Activate the Create ribbon. 
 
Select the Component tool on the Model panel. 

42.  

 
 

Select the Dome component using the 
Type Selector. 
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43.  In the Properties Pane:   

 

 
 

 
 
Set the Radius to 15′ 0″. 
Set the Height to 20′ 0″. 
 

44.  

 
 

Select Place on Work Plane on the Placement panel. 

45.   
 

Set the Placement Plane to Level 2. 

46.  

 
 

Place the dome so it is centered on the 
box. 
 
Right click and select Cancel twice to 
exit the command. 

47.  

 
 

Switch to a 3D View. 
 
 

48.  

 
 

Switch to a Wireframe display. 
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49.  

 
 

The dome is upside down. 
 
Select the dome. 

50.  

 

Left click on the orientation arrows to flip the 
dome. 

51.  In the Properties pane: 
 

 
 

 
Change the Radius to 30′ 0″. 
Change the Height to 15′ 0″. 
Click Apply. 
 

52.  

 
 

Change the display back to Shaded. 

53.  Save as ex2-7.rfa. 
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Exercise 2-8 
Using a Conceptual Mass in a Project 
 
Drawing Name: New  
Estimated Time: 30 minutes 
 
This exercise reinforces the following skills: 
 

 Masses 
 Load from Library 
 Edit Family 
 Update to Face 
 Visibility/Graphics 

 
 
1.  Close any open files. 

 
 Use the Application Menu and go to 

New→Project. 
 

 
 

 

 
Click OK to accept the Imperial-Architectural Template. 

 

2.  

 
 

Type VV to launch the Visibility/Graphics dialog. 
 
Enable Mass visibility on the Model Categories tab. 
 
Click OK. 

3.  

 
 

Switch to a South Elevation. 

4.  
 

 

Set Level 2 to 50′ 0″. 
 
To change the dimension value, just left click on the dimension 
and type the new dimension. 
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Click ESC to release any selection. 
 

5.  

 
 

Activate Level 1. 

6.  

 
 

Activate the Insert Ribbon. 
 
Select Load Family from the Load from Library panel. 

7.  

 
 

Locate conceptual model.rfa. 
 
This is one of the downloaded files from the 
publisher’s website. 
 
Click Open. 
 

8.  

 
 

Activate the Architecture ribbon. 
 

Select Component→Place a Component 
from the Build panel. 

9.  

 
 

Select Place on Work Plane from the Placement panel. 

10.   
 

Set the Placement Plane to Level 1. 

11.  

 
 

Click to place the mass in the 
view. 
 
Right click and select Cancel 
to exit the command. 

12.   
 

Switch to a 3D view. 

13.  

 

Switch to the Massing & Site ribbon. 
Enable Show Mass. 
 

 
 
 

14.  

 

Right click and select Zoom to Fit to 
see the placed mass family. 
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Notice that visibility settings are view-
specific.  Just because you enabled mass 
visibility in one view does not mean 
masses will be visible in all views. 
 

15.  

 
 

Switch to the Architecture ribbon. 
 
Select the Wall by Face tool. 

16.  

 
 

Select the four sides of the box, 
the outside arc of the cylinder 
and the two sides of the dome 
to place walls. 
 
Right click and select 
CANCEL. 

17.  

 
 

Select the Roof by Face tool on the Build panel. 
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18.  

 
 

Select the top face of the box and 
the top half of the cylinder. 

19.  

 
 

Select Create Roof on the ribbon. 

20.  The roof is placed. Right click and select Cancel. 
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21.  

 

Select the conceptual family. 
 

22.  

 

Select Edit Family on the ribbon. 
 
You will be modifying the external file.  

23.  

 

A window opens with the 
conceptual model. 
 
Select the cylinder. 

24.  

 

Change the radius of the cylinder to 50’-0”. 
 
Left click in the window to release the selection. 

 

 

The model updates. 
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25.  

 

Go File→Save As→Family. 

26.  

 

Change the name to conceptual model – 
revised. 
 
Click Save. 
This ensures that the original file is not 
modified. 
 

27.  

 

Select Load into Project and Close. 
 
This loads the revised family into the existing project. 
 
The family file is closed. 

28.  Click ESC to exit the insert command. 
 
Revit automatically assumed you want to place the revised family. 

29.  

 

 

 
Switch to a 3D view. 
 
You see the original conceptual model has 
not changed. 
 
Select the conceptual model by windowing 
around it. 

30.  

 

On the Properties pane: 
 
Select Mass from the drop down list. 
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31.  

 

Use the Type Selector to switch to the 
conceptual model – revised. 
 
The model is replaced with the new version. 

 

 

The wall that was placed on the cylinder did 
not update. 
 
Select the wall. 

32.  

 

Click Update to Face on the ribbon. 

33.  

 

The wall updates. 
 
However, now you see that the roof also 
needs to be updated. 
 
Release the wall selection by left clicking in 
the window. 

34.  

 

Select the roof. 
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35.  

 

Select Update to Face. 

 

 

The roof updates. 

36.  

 
 

Type VV to launch the Visibility/Graphics dialog. 
 
Disable Mass visibility on the Model Categories tab. 
 
 
Click OK. 
 

 You can also disable 
the Show Mass tool on 
the Massing & Site 
tab. 

 
37.  

 

Change the Display to Shaded. 

 
38.  Save as ex2-8.rvt.  
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Notes:  



Mass Elements - Additional Projects  

AP2-1 

Additional Projects 
 

 
1) Create a conceptual mass family like the one shown. 
 
 

 
2) Make the shape shown using a Blend. The base is a rectangle and the top is a 

circle located at the center of the rectangle. 
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3) Make a conceptual mass family as shown. 

Use Solid Void to create the two openings. 
 

 
4)  Design a pergola using 4″ x 4″ posts and beams. 



Lesson 2 Quiz 

Q2-1 

Lesson 2 Quiz 
 
 
True or False 
 

1. Masses can be created inside Projects or as a Conceptual Mass file. 
2. Forms are always created by drawing a sketch, selecting the sketch, and clicking 

 Create Form. 
3. In order to see masses, Show Mass must be enabled. 
4. Masses are level-based. 
5. You can modify the dimensions of conceptual masses. 
 

 
Multiple Choice [Select the Best Answer] 
 

6. Faces on masses can be converted to the following: 
 

A. Walls 
B. Roofs 
C. Floors 
D. Doors 
E. A, B, and C, but NOT D 

 
7. You can adjust the distance a mass is extruded by: 
 

A. Editing the temporary dimension that appears before a solid form is 
created. 

B. Using the ALIGN tool. 
C. Using the 3D drag tool. 
D. Using the Properties pane located on the left of the screen. 
E. All of the above 

 
8.  To insert a conceptual mass family in a project: 
 

A. Use the INSERT tool. 
B. Use the PLACE COMPONENT tool. 
C. Use the BLOCK tool. 
D. Use the MASS tool. 
 

9. Masses are hosted by: 
 

A. Projects 
B. Work Planes 
C. Families 
D. Files 
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10. Mass Visibility can be controlled using: 
 

A. The SHOW MASS tool 
B. Display Settings 
C. Object Settings 
D. View Properties 

 
11. Each mass is defined by _____________. 

 
A. A single profile sketch 
B. Multiple profile sketches 
C. Properties 
D. Materials 

 
12. Revit comes with many pre-made mass shapes. Select the mass shape NOT 
 available in the Revit mass library: 
 

A. BOX 
B. ARC 
C. CONE 
D. TRIANGLE-RIGHT 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ANSWERS:  

1)  T; 2) T; 3) T; 4) T; 5) T; 6) E; 7) E; 8) B; 9) B; 10) A; 11) A; 12) B 
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