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C h a p t e r

Starting a Project

Starting a project in Revit begins by using a template. You can then link in a CAD 
file or an existing Revit model, if these are available. From there, you can add the 
framework for a building, including levels to define vertical heights and grids to 
define the structural layout for architectural and structural columns.

Learning Objectives in This Chapter

• Link and import CAD files to be used as a basis for developing a design.

• Link and import raster image and PDF files.

• Link existing Revit models to develop and coordinate with other disciplines.

• Add and modify levels to define floor-to-floor heights and other vertical references.

• Add and modify grids to provide locations for model elements.
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2.1 Selecting a Project Template
New projects are based on a project template file. The template 
file includes preset levels, views, and some families, such as wall 
styles and text styles. When using templates, most of the views 
are set to display only the elements specific to the template, so it 
is best practice to select a template that reflects your company’s 
discipline.

• Check with your BIM manager about which template you
need to use for your projects. Your company might have more
than one based on the type of project you are designing.

How To: Start a New Project

1. In the File tab, expand  (New) and click (Project), as 
shown in Figure 2–1, or press <Ctrl>+<N>.

Figure 2–1

2. In the New Project dialog box (shown in Figure 2–2), select
the template that you want to use and click OK.

The list of template files 
is set in the Options 
dialog box in the File 
Locations tab. It might 
vary depending on the 
installed product and 
company standards.

Figure 2–2
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Hint: Revit Worksharing

If established by your company that worksharing is needed, 
you would typically want to start a worksharing project on your 
local network once a project has been created.

• For more information on worksharing, see A.9 Introduction 
to Revit Worksharing.

• For more information about establishing and using 
worksets, refer to the ASCENT guide Autodesk Revit: 
Collaboration Tools.
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2.2 Linking and Importing Files

Linking and
Importing CAD

Files

CAD files can be imported or linked into a Revit project. As an 
example, a designer might lay out a floor plan using the standard 
2D AutoCAD software, and you then need to incorporate that 
information into your structural model. In addition, many 
renovation projects start with existing 2D drawings. Instead of 
redrawing from scratch, link or import the CAD file (as shown in 
Figure 2–3) and trace over it in Revit. You can also print a hybrid 
drawing that is part Revit project and part imported/linked 
drawing.

When you select an 
imported or linked CAD 
file, you can see in the 
tooltip that it is called an 
Import Symbol.

Figure 2–3

• When you hover your cursor over an imported or linked CAD
file, a tooltip displays indicating that it is an import file.

• CAD file formats that can be imported or linked include

AutoCAD® (DWG and DXF), MicroStation (DGN), 3D ACIS
modeling kernel (SAT), Trimble SketchUp (SKP), FormIt
(AXM), 3D Shape (OBJ and STL), and Rhino (3dm).

• When linking or importing a CAD file, you can specify a level
or a named horizontal reference plane in the project to
position the CAD file at.
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Linking vs. Importing

• Link: A connection is maintained with the original file and the 
link updates if the original file is updated.

• Import: No connection is maintained with the original file. It 
becomes a separate element in the Revit model.

How To: Link or Import a CAD File

1. Open the view into which you want to link or import the file.

• For a 2D file, this should be a 2D view. For a 3D file, open 
a 3D view.

2. In the Insert tab>Link panel, click  (Link CAD), or in the 

Insert tab>Import panel, click  (Import CAD).
3. In the Link CAD Formats (shown in Figure 2–4) or Import 

CAD Formats dialog box, select the file that you want to 
import.

• Select a file format in the Files of type drop-down list to 
limit the files that are displayed.

The dialog boxes for 
Link CAD Formats and 
Import CAD Formats are 
the same.

Figure 2–4
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4. If Current view only is selected, as shown in Figure 2–5, you
can set all options except the Place at and the Orient to View
options. The view will only display in the current view.

Figure 2–5

5. If you would like to place the CAD file at a level or reference
plane, verify Current view only is unchecked and set the
Place at option, as shown in Figure 2–6.

Figure 2–6

6. Click Open.

Link and Import Options

Current view 
only

Determine whether the CAD file is placed in every view, 
or only in the current view. This is especially useful if you 
are working with a 2D floor plan that you only need to 
have in one view.

Colors Specify the color settings. Typical Revit projects are 
mainly black and white. However, other software 
frequently uses color. You can Invert the original colors, 
Preserve them, or change everything to Black and 
White.

Layers/Levels Indicates which CAD layers are going to be brought into 
the model. Select how you want layers to be imported: 
All, Visible, or Specify....

Import units Select the units of the original file, as required. 
Auto-Detect works in most cases.

Correct lines... If lines in a CAD file are off axis by less than 0.1 degree, 
selecting this option straightens them. It is selected by 
default.
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• When a file is positioned Auto - Origin to Internal Origin, it 
is pinned in place and cannot be moved. To move the file, 
click on the pin to unpin it, as shown in Figure 2–7.

For more information on 
importing and linking 
CAD files, see the 
ASCENT guide 
Autodesk Revit: 
Collaboration Tools.

Figure 2–7

Positioning Specify how you want the imported file to be positioned in 
the current project:

The default position is Auto - Origin to Internal Origin.

Place at Select a level or named reference plane at which to place 
the imported file. If you selected Current view only, this 
option is grayed out.

Orient to View Used to orient the CAD file on import/link.

Linking optionImport option
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Linking and
Importing

Raster Image
Files

Raster images are made up of pixels or dots in a file that create a 
picture. For example, a raster file is created when you scan a 
blueprint and then import or link it into Revit to reference or trace. 
You can add raster images to any 2D view, including sheet views 
(as shown in Figure 2–8). They can be used as background 
views or as part of the final drawing. Imported or linked images 
can be placed behind model objects and annotations.

Figure 2–8

For more information 
about the different types 
of files and how to 
import them, refer to the 
ASCENT guide 
Autodesk Revit: 
Collaboration Tools.

• Link a PDF or raster image into a 2D view if you need to
reference a file that will be updated throughout the project
cycle and to keep the project’s file size from increasing when
importing files.

• Linked PDFs or raster images can be scaled, rotated, and
moved just like an imported PDF or raster image. Any
changes made to the PDF or raster image will update in the
project it is linked into when you open the project.

• A PDF can be imported into Revit as a raster image. If the
PDF contains vector data, you can snap to the elements in
the PDF.

How To: Import and Link an Image

1. In the Import Image or Link Image dialog box, select the
image you want to insert. You can insert .BMP, .JPG, .JPEG,
.PNG, and .TIF files.

To... Then...

Import an image file In the Insert tab>Import panel, click (Import 
Image).

Link an image file In the Insert tab>Link panel, click (Link Image).
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2. Click Open. Four blue dots and an “x” illustrate the default 
size of the image file, as shown on the left in Figure 2–9. 
Click on the screen to place the image. It displays with the 
shape handles still visible, as shown on the right in 
Figure 2–9.

Figure 2–9

• In Properties, you can adjust the height and width and also 
set the Draw Layer to either Background or Foreground, as 
shown in Figure 2–10.

Figure 2–10

• You can select more than one image at a time and move 
them as a group to the background or foreground.

• In the Modify | Raster Images tab (shown in Figure 2–11), 
you can access the Arrange options and Manage Images.

Figure 2–11
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Linking and
Importing
PDF Files

PDF files are often created for sharing information with people 
that do not have the original program and when you do not want 
anyone to change the original information. They can also be 
used as underlays when the original information includes vector 
data.

How To: Import and Link a PDF File

1. In the Import PDF or Link PDF dialog box, navigate to the
location where the PDF file is stored, select it, and click
Open.

2. In the Import PDF or Link PDF dialog box (Figure 2–12
shows the Import PDF dialog box), select the page you want
to import/link and click OK.

Figure 2–12

• Only one page can be imported/linked at a time, but you
can import/link additional pages by repeating the process.

To... Then...

Import a PDF file In the Insert tab>Import panel, click (Import PDF).

Link a PDF file In the Insert tab>Link panel, click (Link PDF).



Starting a Project

© 2022, ASCENT - Center for Technical Knowledge® 2–11

3. In Properties, you can specify the size and scale of the 
image, as shown in Figure 2–13. 

• If the PDF comes from a vector source, you can also 
choose to enable snaps and trace over the elements in 
the PDF.

• The Foreground/Background status can also be set in the 
Options Bar and in Properties.

Figure 2–13

Options Bar

Properties
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2.3 Linking in Revit Models
You can link Revit models directly into a project. These models 
can be an existing building that you are creating an addition to, 
as shown in Figure 2–14, or engineering models that you are 
checking to ensure that they line up with your model. They are 
also used for campus-like projects where the same building is 
repeated multiple times.They are full 3D models.

A linked model 
automatically updates 
when the original file is 
changed.

Figure 2–14

• Architectural, structural, and MEP models created in Revit
can be linked to each other as long as they are from the
same release cycle.

• When you use linked models, clashes between disciplines
can be detected and information can be passed between
disciplines.

• Revit models are always linked. They cannot be imported.

Linked Revit model with outline 
of addition in the current project
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How To: Add a Linked Model to a Host Project

1. In the Insert tab>Link panel, click  (Link Revit).
2. In the Import/Link RVT dialog box, select the file that you 

want to link. Before opening the file, set the Positioning, as 
shown in Figure 2–15.

Figure 2–15

3. Click Open.
4. Depending on how you decide to position the file, it is 

automatically placed in the project or you can manually place 
it with the cursor.

As the links are loading, do not click on the screen or click any 
buttons. The more links present in a project, the longer it takes to 
load.
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2.4 Modifying Imported/Linked 
Files

When you select an imported/linked file, you can modify it by 
arranging the Foreground/Background status, modifying its Type 
Properties, querying information about elements in the file, and 
deleting layers. You can also modify the Visibility/Graphic 
Overrides of each imported/linked instance.

• An imported/linked file is called an import symbol once it is
inserted into a project, as shown in Figure 2–16.

Figure 2–16

Setting an Imported or Linked File to Halftone

To see the difference between the host model elements and the 
linked or imported file, you can set the linked/imported file to 
halftone, as shown in Figure 2–17.
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Figure 2–17

How To: Set an Element Halftone 

1. Select the imported file.
2. Right-click and select Override Graphics in View>By 

Element....
3. In the View Specific Element Graphics dialog box, select 

Halftone, as shown in Figure 2–18.

Figure 2–18

4. Click OK.

• You can use this method to set any element or category to 
halftone.

Linked/imported file

Revit elements
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Draw Layer

Linked CAD files are typically in the background of a view. To 
change this, select the CAD file in the view and in the Options 
Bar or in Properties, in the Other section, change the Draw Layer 
to Foreground.

Editing Raster Files

Select an imported/linked image to make changes. Once it is 
selected, you can resize the image as you did when you first 
inserted it or specify the Width and Height values in Properties.

• Select Lock Proportions in the Options Bar to ensure that
the length and width resize proportionally to each other when
you adjust the size of an image.

• Use the standard modification tools to Move, Copy, Rotate,
Mirror, Array, and Scale images. Images can also be
grouped together into detail groups.

• The Foreground/Background status can also be set in the
Options Bar and in Properties, as shown in Figure 2–19.

Figure 2–19

• In the Modify | Raster Images tab>Arrange panel (shown in
Figure 2–20), use the Arrange tools to move images to the
front or back of other images or objects.

Options Bar

Properties
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• You can snap to edges of images, as shown in Figure 2–21.

Managing Links The Manage Links dialog box (shown in Figure 2–22) enables 
you to reload, unload, add, and remove links, and it also 
provides access for you to set other options. To open the 
Manage Links dialog box, in the Insert tab>Link panel, click 

(Manage Links). Alternatively, you can go to the Manage 

tab>Manage Projects panel and click  (Manage Links).

• You can also select the link and click  (Manage Links) in 
the Modify | RVT Links tab>Link panel.

Figure 2–22

• The Manage Links dialog box does not show imported CAD 
files.

• You can manage both imported and linked images and PDFs.

Figure 2–20 Figure 2–21
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The following options are available:

Some of these options 
are also available in the 
Project Browser. 
Expand the Revit Links 
node, then right-click on 
the Revit Link and select 
Reload, Unload, or 
Reload From…. 

• Reload From: Opens the Add Link dialog box, which enables
you to select the file you want to reload. Use this if the linked
file location or name has changed.

• Reload: Reloads the file without additional prompts.

• Unload: Unloads the file so that the link is kept, but the file is
not displayed or calculated in the project. Use Reload to
restore it.

• Add: Opens the Import/Link RVT dialog box, which enables
you to link additional models into the host project.

• Remove: Deletes the link from the file.

Links can be nested into one another. How a link responds when 
the host project is linked into another project depends on the 
option in the Reference Type column. 

• Overlay: The nested linked model is not referenced in the
new host project.

• Attach: The nested linked model displays in the new host
project.

The option in the Path Type column controls how the location of 
the link is remembered.

• Relative

• Searches the root folder of the current project.

• If the file is moved, the software still searches for it.

• Absolute

• Searches the entire file path where the file was originally
saved.

• If the original file is moved, the software is not able to
find it.

• Other options control how the linked file interfaces with
worksets and shared positioning.
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Modifying the
Visibility of

Imported/
Linked Files

If you have used the imported/linked file as a guideline for 
tracing, you can toggle off the visibility of the entire image using 
the Visibility/Graphic Overrides dialog box, without removing it 
from the project in case you need it later. You can also toggle off 
individual layers or levels.

How To: Hide individual Layers

1. In the View tab>Graphics panel, click 

(Visibility/Graphics), or type VG or VV to open the 
Visibility/Graphic Overrides dialog box.

2. Switch to the Imported Categories tab. It displays a list for 
each imported instance and their layers/levels, as shown in 
Figure 2–23.

3. To have the linked/imported file display in halftone, check the 
box in the Halftone column. 

Figure 2–23

4. Click the plus sign beside the file name to expand a list of the 
layers or levels in that file.

5. Clear the check mark from the individual layers that you do 
not want to display.

• Typically, these layers contain similar information, such as 
all windows or all notes in a drawing. However, it is not as 
definite as using Revit elements. An item might have been 
misplaced on a different layer and, if so, it does not toggle 
off.

6. Close the dialog box.

• To toggle off the entire file, clear the checkmark next to the 
file name.

Click to have the imported/linked 
file display in halftone
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Temporarily Hide/Isolate

You might want to temporarily remove linked or imported files 
from a view, modify the project, and then restore the elements. 
Instead of completely toggling the elements off, you can 
temporarily hide them.

Select the elements you want to hide (make invisible) or isolate 
(keep displayed while all other elements are hidden) and click 

 (Temporary Hide/Isolate). Select the method you want to 
use, as shown in Figure 2–24.

Figure 2–24

• The category or elements are hidden or isolated. A cyan
border displays around the view with a note in the upper left
corner, as shown in Figure 2–25. It indicates that the view
contains temporarily hidden or isolated elements.

Figure 2–25

• Click  (Temporary Hide/Isolate) again and select Reset 
Temporary Hide/Isolate to restore the elements to the view.

• If you want to permanently hide the elements in the view,
select Apply Hide/Isolate to View.

• Elements that are temporarily hidden in a view are not hidden
when the view is printed.
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Hide Elements in a View

When working in views, you can quickly hide linked or imported 
files. To hide the imported or linked file, select it and right-click to 
display the shortcut menu, then select Hide in View and select 
either Elements or Category, as shown in Figure 2–26.

Figure 2–26
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Practice 2a Start a Project and Link Files

In this practice, you will start a Revit project, then import floor 
plans created in AutoCAD and use them as a base layout for the 
first floor lobby and for a typical guest floor. You will then link in a 
Revit model that includes a standard poolhouse and platform for 
the building, as shown in Figure 2–27.

Figure 2–27

Task 1 - Start a project.

1. In the File tab, expand  (New) and click (Project).

• Alternatively, if you are on the Home screen, click the
New button under the MODEL section.

Practice Objectives

• Start a Revit project.

• Link a CAD file.

• Link a Revit file.
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2. In the New Project dialog box, expand the Template file list, 
select the default Imperial-Architectural Template, and 
click OK. (There are no elements in this file, only datums and 
basic views.)

3. Save the project as Hotel-Start.rvt.

4. Review the Project Browser and note that the project has 
default floor plan, ceiling plan, and elevation views. By 
default, the Floor Plans: Level 1 view is open and displays 
in bold in the Project Browser, as shown in Figure 2–28.

Figure 2–28

Task 2 - Link a CAD file.

1. In the Insert tab>Link panel, click  (Link CAD).

2. In the Link CAD Formats dialog box, navigate to the practice 
files CAD Files folder and select the file Hotel-Level-1.dwg, 
then set the following options:

• Select Current view only

• Colors: Black and White

• Layers/Levels: All

• Import Units: Auto-Detect

• Positioning: Auto - Origin to Internal Origin

3. Click Open. The linked CAD file is placed in the project on 
the Floor Plans: Level 1 view.
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4. Select the linked CAD file. It is a single imported symbol and
pinned in place because it was imported origin to internal
origin.

5. In the Options Bar, change Background to Foreground.

6. With the CAD file still selected, right-click and select
Override Graphics in View>By Element....

7. In the View-Specific Element Graphics dialog box, select
Halftone and click OK.

8. Click in an empty space in the view to release the selection.
The linked file displays in halftone, as shown in Figure 2–29.

Figure 2–29

9. Open the Floor Plans: Level 2 view. The CAD file linked in
Level 1 does not display because you specified to link the
CAD file with Current view only selected.

10.Link the CAD file Hotel-Level-2.dwg using the options that
were used for Level 1.

11. Override the graphics and set the linked file to Halftone.

12.Save the project.

Task 3 - Link in a Revit file.

1. In the Quick Access Toolbar, click  (Default 3D View). 
Neither of the linked CAD files display in this view.

2. In the Insert tab>Link panel, click  (Link Revit).
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3. Navigate to the practice files Revit Link Files folder and select 
Hotel-Pool.rvt. Verify that the Positioning is set to Auto - 
Internal Origin to Internal Origin and click Open.

4. In the View Control Bar, change the Visual Style to 

(Shaded).

5. Select one of the levels and type VH to hide in view.

6. Type ZF to fit all the model to the view or ZA to zoom all, as 
shown in Figure 2–30.

Figure 2–30

7. Along the top of the view window, select the Level 1 tab to 
switch back to this view. Both the linked CAD file and linked 
Revit file display in this view.

8. Open the Visibility/Graphic Overrides dialog box by typing 
VV.

9. Click on the Revit Links tab. Next to Hotel Pool.rvt, check 
the checkbox for Halftone, as shown in Figure 2–31. 

Figure 2–31

10.Click OK.

11. Select the text that is part of the CAD file below the platform 
and in Properties, in the Other section, change the Draw 
Layer to Foreground.

12.Save and close the project.
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2.5 Setting Up Levels
Levels define stories and other vertical heights, such as the 
parapet and other reference heights shown in Figure 2–32. The 
default template includes two levels, but you can define as many 
levels in a project as required. They can go below 0'-0" or in the 
negative (for basements) as well.

Figure 2–32

• You must be in an elevation or section view to define levels.

• Once you constrain an element to a level, it moves with the
level when the level is changed.

How To: Create Levels

1. Open an elevation or section view.
2. In the Architecture tab>Datum panel, click  (Level), or 

type LL.
3. In the Type Selector, set the level head type, if needed.
4. In the Options Bar, select or clear Make Plan View as

needed. You can also click Plan View Types... to select the
types of views to create when you place the level.

5. In the Modify | Place Level tab>Draw panel, click either

 (Pick Lines) to select an element or  (Line) to sketch a 
level.

6. Continue adding levels as needed.

• Level names are automatically incremented as you place
them. This automatic numbering is most effective when you
use names such as Floor 1, Floor 2, etc. (as opposed to First
Floor, Second Floor, etc.). In addition, this makes it easier to
find the view in the Project Browser.
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• A fast way to create multiple levels is to use the  (Pick 
Lines) option. In the Options Bar, specify an Offset, select an 
existing level, and then pick above or below to place the new 
level, as shown in Figure 2–33. 

You specify above or 
below the offset by 
hovering the cursor on 
the needed side.

Figure 2–33

• When using the  (Line) option, alignments and temporary 
dimensions help you place the line correctly, as shown in 
Figure 2–34.

Figure 2–34

• Sketch the level lines from left to right or right to left to keep 
consistent.

• You can also use  (Copy) to duplicate level lines. The 
level names are incremented but a plan view is not created. 
These are called reference levels.

• Levels display in the default 3D view. They can be modified 
and copied, but cannot be created in this view. 

• Levels can be hidden in any view.

Offset alignment line

Temporary 
dimension

First click Second click

Alignment line
Alignment line
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Modifying
Levels

You can change levels using standard controls and temporary 
dimensions, as shown in Figure 2–35 to the levels’ appearance. 
You can also make changes to the name and height of the level 
by selecting on the individual items in the view as well as change 
these in Properties. You can change just the name of the level in 
the Project Browser but not the height.

Figure 2–35

• (Hide / Show Bubble) displays on either end of the
level line and toggles the level head symbol and level
information on or off.

• (Switch to 3d / 2d extents) controls whether any
movement or adjustment to the level line is reflected in other
views (3D) or only affects the current view (2D).

• (Modify the level by dragging its model end) at each end
of the line enables you to drag the level head to a new
location.

• (Create or remove a length or alignment constraint)
controls whether the level is locked in alignment with the
other levels. If it is locked and the level line is stretched, all of
the other level lines stretch as well. If it is unlocked, the level
line stretches independent of the other levels.

• Click  (Add Elbow) to add a jog to the level line, as shown 
in Figure 2–36. Drag the shape handles to new locations as 
needed. This is a view-specific change.

Controls
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Figure 2–36

• To change the level name or elevation, double-click on the 
information next to the level head, or select the level and 
modify the Name or Elevation fields in Properties, as shown 
in Figure 2–37.

Figure 2–37

• When you rename a level, an alert box opens, prompting you 
to rename the corresponding views, as shown in 
Figure 2–38. 

Figure 2–38

• The view is also renamed in the Project Browser.

After Before 
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• If you delete a level, the views related to that level are also
deleted. A warning displays, as shown in Figure 2–39.

Figure 2–39

Creating Plan
Views

By default, when you place a level, plan views for that level are 
automatically created. If Make Plan View was toggled off when 
adding the level, or if the level was copied, you can create plan 
views to match the levels. 

• Level heads with views are blue and level heads without
views are black, as shown in Figure 2–40.

Typically, you do not 
need to create plan 
views for levels that 
specify data, such as 
the top of a storefront 
window or the top of a 
parapet.

Figure 2–40

Hint: Copying Levels and Grids from Other Projects

Levels and grid lines can be added by drawing over existing 
levels or grids in an imported or linked CAD file. It can also be 
copied and monitored from a linked Revit file. Some projects 
might require both methods.

• For more information on using the Copy/Monitor tools, see
the ASCENT guide Autodesk Revit: Collaboration Tools.

Black - no plan 
views

Blue - plan views 
created
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How To: Create Plan Views

1. In the View tab>Create panel, expand  (Plan Views) and 
select the type of plan view you want to create, as shown in 
Figure 2–41.

2. In the New Plan dialog box (shown in Figure 2–42), select the 
levels for which you want to create plan views. Hold <Ctrl> to 
select more than one level.

• Clear Do no duplicate existing views to create a copy of an 
existing view.

3. Click OK.

Figure 2–41 Figure 2–42
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• Once a plan view is made from a level, you can double-click
on the level head to open the related floor plan view.You
create other plan views similar to creating a floor plan.Ceiling
plans are typically created by default when you add a level
with a view. If you do not want a level to have a ceiling plan,
you can right-click on its name in the Project Browser and
select Delete, as shown in Figure 2–43.

Figure 2–43
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Practice 2b Set Up Levels

In this practice, you will set up the levels required in the Modern 
Hotel project, including the floors, the top of the footing, and the 
parapet, as shown in Figure 2–44. You should see the linked 
Revit model on your screen. (The RVT link has been hidden in 
the figure below for clarity.)

Figure 2–44

1. Open the project Hotel-Levels.rvt from the practice files 
folder.

2. Open the Elevations (Building Elevation): North view. You 
will see your project’s Level 1 and Level 2 levels, as well as 
the levels and grid lines that are part of the linked Revit file.

3. Select the linked Revit file.

Practice Objective

• Add and modify levels.
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4. In the View Control Bar, expand  (Temporary Hide/
Isolate) and select Hide Element. This toggles off the linked
Revit file.

5. Zoom in on the level names.

6. Slowly click twice on the name Level 1 and rename it to
Floor 1, as shown in Figure 2–45. Press <Enter>.

Figure 2–45

7. Click Yes or press <Y> when prompted to rename the
corresponding views.

8. Repeat the process and rename Level 2 as Floor 2. Click on
the height of Floor 2 and change it from 10'-0" to 18'-0".

9. In the Architecture tab>Datum panel, click  (Level). 

10. In the Options Bar, verify that Make Plan View is selected.
Click Plan View Types.... 

11. In the Plan View Types dialog box, click Structural Plan to
deselect it (so that only Ceiling Plan and Floor Plan are
selected), as shown in Figure 2–46. Click OK.

Figure 2–46

12. In the Modify | Place Level tab>Draw panel, click  (Pick 
Lines). In the Options Bar, set the Offset to 12'-0".
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13.Hover the cursor over the level line of Floor 2 and move the 
cursor slightly upward until you see the dashed alignment line 
display above the Floor 2 level. Click to create the new level 
Floor 3.

14.Create additional levels until there are a total of nine levels, 
all with the Offset of 12'-0". 

15.Click  (Modify) and select the Floor 9 level. 

16.Rename Floor 9 as Roof. (Rename the corresponding 
views.)

17.Click  (Modify).

18.Start the Level command again.

19. In the Modify | Place Level tab>Draw panel, click

 (Pick Lines).

20. In the Options Bar, clear the Make Plan View option and set 
the Offset to 5'-0". Create one additional level above the 
Roof level. This level does not need a plan view.

21.Rename the top level as Parapet, as shown in Figure 2–47.

Figure 2–47

22.Zoom and pan to the Floor 1 level. Select the Floor 1 level 
line.

23. In the Modify | Levels tab>Modify panel, click  (Copy).

24. In the Options Bar, select Multiple.

25. In the view, click Floor 1’s level line for the copy start point. 
For the second point, click below Floor 1 (the distance does 
not matter right now as you will set this in the next few steps).

26.Click again below the level you just placed to make two new 
levels below Floor 1.
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27.Click  (Modify) to end the command.

28.Rename the level below Floor 1 to Basement and set the
height to (negative) -10'-0".

29.Rename the level below Basement to T.O. Footing and set
the height to (negative) -12'-0", as shown in Figure 2–48. You
can modify the levels for clarity by selecting the level and

clicking the  (Add Elbow) control between the level name
and height.

Figure 2–48

30. In the View Control Bar, select  (Temporary Hide/ Isolate) 
and select Reset Temporary Hide/Isolate.

31.Select the Floor 1 level line. Select  (Drag the extents of 
the level in the model) and drag the level over until it is far 
enough away from the linked model. The other levels will 
follow because of the alignment constraint.

32.Zoom out to display the entire project.

• Because the Basement and T.O. Footing were copies of
Floor 1, you need to create a floor plan view.

33. In the View tab>Create panel, expand  (Plan Views) and 

select  (Floor Plan).

34. In the New Floor Plan dialog box, select Basement and T.O.
Footing. (Hint: Use <Ctrl> to select the two levels.)

35.Click OK. The floor plan views now show in the Project
Browser and the T.O. Footing view (or the last view to be
created) becomes the active view.



Starting a Project

© 2022, ASCENT - Center for Technical Knowledge® 2–37

36.Create a new ceiling plan view. In the View tab>Create panel, 

expand  (Plan Views) and select  (Reflective Ceiling 
Plan).

37. In the New RCP dialog box, select Basement and click OK. 

38.Select the Floor 1 tab above the view window to make it the 
active view.

39.Close any open views by going to the Quick Access Toolbar 

and clicking  (Close Inactive Views).

40.Open the Default 3D view. 

41.Because you hid the levels when linking in the models, you 
need to unhide them. In the View Control Bar, click 

(Reveal Hidden Elements).

42.Select one level and in the Modify | Levels tab>Reveal 

Hidden Elements panel, click  (Unhide Category).

43. In the View Control Bar, click  (Close Reveal Hidden 
Elements).

44. In the Project Browser, select both the Parapet and Roof 
views in the Ceiling Plans section. Right-click and select 
Delete to delete the views.

45.Save and close the project.



Autodesk Revit 2023 Architecture Fundamentals

2–38 © 2022, ASCENT - Center for Technical Knowledge®

2.6 Creating Grids
Grids are annotation elements that display in most views, 
including plan, ceiling, section, and elevation views. They help 
organize your design when developing a layout and describe the 
pattern and location for columns, as shown in Figure 2–49. Grids 
can be multi-segmented, arcs, or straight lines, and they can be 
hidden in the view if needed. 

Figure 2–49

Each line or arc in a grid is a separate entity and can be placed, 
moved, and modified individually. 

If you are upgrading a 
model to the 2023 
version, you will need to 
turn on the grids.

Grids cannot be drawn in a 3D view but grids can be displayed in 
a 3D view, perspective view, or in a 3D view with a selection box. 
and when you click on a grid, the surface contour displays. 

How To: Create a Grid

1. In the Architecture tab>Datum panel, click  (Grid), or 
type GR.

2. In the Properties Type Selector, select the grid type, which
will control the size of the bubble and the linestyle.

3. In the Modify | Place Grid tab>Draw panel, shown in
Figure 2–50, select the draw method you want to use.

Figure 2–50

4. In the Options Bar, set the Offset if needed.
5. Start drawing grid lines.
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• Grids can be sketched at any angle, but you should ensure 
that all parallel grids are sketched in the same direction 
(e.g., from left to right or from bottom to top).

• When using the Multi-Segment tool, shown in Figure 2–51, 

sketch the line and click  (Finish Edit Mode) to complete 
the command.

Figure 2–51

How To: Show Grids in 3D

1. Open a 3D or perspective view and press <Esc> twice to 
verify nothing is selected. 

2. In Properties, click Edit... next to Show Grids, as shown in 
Figure 2–52.

Figure 2–52
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3. In the Show Grids dialog box, select the level(s) that you
want the grids to display at in the 3D view, as shown in
Figure 2–53.

Figure 2–53

4. Click OK.
5. (Optional) To display the grids on the bottom of a section box,

in Properties, verify that Section Box is selected, and click
Edit... next to Show Grids.

6. In the Show Grids dialog box, select only the Project Grids
On Section Box option, as shown in Figure 2–54, and click
OK.

Figure 2–54

Grid 
lines
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Modifying
Grid Lines

Grid lines are very similar to level lines. You can modify grid lines 
using controls, alignments, and temporary dimensions in the 
view (as shown in Figure 2–55). You can change the bubble type 
using the Type Selector.

Figure 2–55

• Grid numbers can be numbers, letters, or a combination of 
the two. To modify a grid number, double-click on the number 
in the bubble and type the new letter/number. You can also 
change the grid number by entering a new Name in 
Properties.

• Grid numbers increment automatically.

• In a 3D view, you can modify the grid line name and adjust 
the grid line and grid distance. 

• Click the  (Drag the extents of the grid in the model) 
control to lengthen the grid line. 

• Modify the temporary dimension (as shown in 
Figure 2–56) to change the grid line’s distance from 
another grid line.

Figure 2–56

Add elbow

Plan view symbols end 1 and 2

Temporary 
dimension

Alignment 
line

Drag 
control

Temporary 
dimension
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• Change the grid line name by selecting the bubble and
typing in a new name; alternatively, the name can be
changed in Properties.

• In Type Properties, change the way the grid Plan View
Symbols Ends display, as shown in Figure 2–57. The
first pick point is plan view symbol end 1 and the second
pick point is plan view symbol end 2.

Figure 2–57
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Hint: Propagating Datum Extents

If column grids do not display in a view, this might be due to 
adding a level after the grid lines were added. To display the 
grid lines in plan views, select the grid lines in a view in which 
they are displayed. In the Modify | Grids tab>Datum panel, click 

(Propagate Extents). In the Propagate datum extents 
dialog box (shown in Figure 2–58), select the views to project 
the grid lines to.

Figure 2–58

• This also works for levels.

• (Propagate Extents) is particularly useful to make grid 
lines display the same in all views.
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Practice 2c Add Grids 

In this practice, you will add grid lines using information in the 
imported file.

1. Open the project Hotel-Grids.rvt from the practice files
folder.

2. From the Project Browser, open the Floor Plans: Floor 1
view.

3. Select the linked Revit file with the pool (Hotel-Pool.rvt). In

the View Control Bar, expand (Temporary Hide/Isolate)
and select Hide Element.

4. In the Architecture tab>Datum panel, click  (Grid).

5. In the Modify | Place Grid tab>Draw panel, click  (Pick
Lines).

6. Select the first vertical grid line on the left of the linked file.
Zoom into the grid and click inside the bubble, type A, and
press <Enter>.

7. Continue selecting the vertical grid lines displayed in the
imported file. The letters automatically increment.

8. Click the first horizontal grid line and change the letter in the
bubble to 1.

9. Continue selecting the horizontal grid lines. The numbers
automatically increment.

10.Click  (Modify) to end the command.

11. Select the CAD file (Hotel-Level-1.dwg). In the View Control

Bar, expand (Temporary Hide/Isolate) and select Hide
Element.

Practice Objective

• Add and modify grid lines.
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12.Only the grids should now display, as shown in Figure 2–59. 
Check the lengths of all grid lines. Modify the length by 
dragging the ends if needed.

Figure 2–59

13. In the View Control Bar, select  (Temporary Hide/ Isolate) 
and select Reset Temporary Hide/Isolate.

14.Open the default 3D view by selecting the tab at the top of the 
view. Note that you do not see the grids.

15.Click  (Modify).

16. In Properties, in the Graphics section, click Edit... next to 
Show Grids.

17. In the Show Grids dialog box, select Floor 1 and click OK.

18.The grids now display. Select the linked Revit file with the 
pool (Hotel-Pool.rvt). 
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19. In the View Control Bar, expand (Temporary
Hide/Isolate) and select Hide Element to see the grids
unobstructed as shown in Figure 2–60.

Figure 2–60

20. In the View Control Bar, select  (Temporary Hide/ Isolate) 
and select Reset Temporary Hide/Isolate.

21.Save and close the project.
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Chapter Review Questions

1. What type of view do you need to be in to add a level to your 
project?

a. Any non-plan view.

b. As this is done using a dialog box, the view does not 
matter.

c. Any view except for 3D.

d. Any section or elevation view.

2. How do you line up grid lines that might be different lengths, 
as shown in Figure 2–61?

Figure 2–61

a. Use  (Trim/Extend Multiple Elements) to line them up 
with a common reference line.

b. Select the grid line and use the drag control to line up with 
the other grid lines.

c. Select the grid line, right-click and select Auto-Align.

d. In Properties, change the Length and then use  (Move) 
to get them into position.

3. Grids can be displayed in a 3D view.

a. True

b. False

4. In order for architectural columns to move with grids, what 
needs to be selected when placing the column?

a. In the ribbon, select At Grids.

b. Set the Top Constraint to grids.

c. Columns always move with grids no matter what type.

d. In Properties, select Moves With Grids.
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5. Which of the following types of CAD formats can you import
into Revit? (Select all that apply.)

a. .DWG

b. .XLS

c. .SAT

d. .DGN

6. Imported CAD files cannot be reloaded in the Manage Links
dialog box.

a. True

b. False

7. To modify linked CAD files, you need to open what dialog
box?

a. Type Properties

b. Link CAD

c. Manage Links

d. Insert from File
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Command Summary

Button Command Location
Grid • Ribbon: Architecture tab>Datum panel

• Shortcut: GR

Import CAD • Ribbon: Insert tab>Import panel

Level • Ribbon: Architecture tab>Datum panel

• Shortcut: LL

Link CAD • Ribbon: Insert tab>Link panel

Link PDF • Ribbon: Insert tab>Link panel

Link Revit • Ribbon: Insert tab>Link panel

Multi-Segment 
(Grid)

• Ribbon: Modify | Place Grid tab>Draw 
panel

Import PDF • Ribbon: Insert tab>Import panel

Propagate 
Extents

• Ribbon: Modify | Grids or Modify | 
Levels tab>Datum panel

Temporary 
Hide/Isolate

• View Control Bar
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