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C h a p t e r

Creating Custom Templates

Custom templates can save you time and effort when creating similar projects by 
providing an efficient way to apply your organization’s graphic and documentation 
standards. Templates can include items such as levels, views, sheets, schedules, 
and annotation types for text, dimensions, and tags. A custom title block is a 
typical family that is added to templates that ensures that sheets are created with 
the appropriate information. You may also want to add rule-based view filters and 
view templates to project template files for improved workflow within the project.

 Learning Objectives in This Chapter

• Create project templates.

• Use resource projects to store additional system families, details, schedules, and other data.

• Create standard text and dimension types for use in your projects.

• Modify callout, elevation, and section tags and specify which tags are loaded in a template.

• Create title blocks, including detail lines, text, labels, symbols, regions, and revision 
schedules.

• Set up visibility/graphic override filters for various categories of elements.

• Create and apply view templates.
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1.1 Preparing Project Templates
A project template is a file that contains information that can be 
used over and over to create new projects. The goal is to save 
time by using company standards, enabling you to concentrate 
on the design. For example, predefined levels (as shown in 
Figure 1–1 for a residential project) and the associated plan 
views and elevations provides a starting point for a model.

Figure 1–1

• Some items in a project template include: 

• Project views: Levels, schedules, legends, sheets, plan 
views, and view templates.

• Project-based settings: Project units, object styles, fill 
patterns, line styles, discipline-specific settings, etc.

• Families: System families, component families, custom 
families, and title blocks.

• Print settings: Define printers and print settings.

• Annotation types: Dimension style, text, arrowheads, 
and tags.

• If you provide constant work to a specific client (e.g., a school 
system or government entity), you can create a template 
specific to their projects with associated title blocks and other 
information. 

• You can also store items such as sheets, schedules, families, 
and drafting views (details) in a separate resource file and 
add the elements to the current project, as needed.

• As you create new templates, families, and title blocks, it is 
recommended that you save them in a safe location where 
they will not be deleted and are outside of the Revit file 
structure.
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How To: Create a Project Template File

Project templates are 
located in the 
C:\ProgramData\
Autodesk\RVT 2023\
Templates\English
(Metric) or 
English-Imperial folder.

1. In the File tab, expand  (New) and click (Project). 

• Alternatively, on the Revit Home screen, click (New...) 
in the MODELS area, as shown in Figure 1–2. 

Figure 1–2

2. In the New Project dialog box, in the Template file area, 
select a template file to begin with or select <None> to use a 
blank project file.

3. In the Create new area, select Project template, as shown in 
Figure 1–3.

• Project template files have the extension .rte.

Figure 1–3

4. Click OK.
5. Add settings, families, views, etc., as needed to the new file.
6. Save the project template file.

• To save time, use an existing project or template that includes 
some of the basics you need rather than starting from 
scratch. Note: Make sure to clean up all existing project data 
that is not standard.
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• If you select <None> in the Template file list, you are 
prompted to specify the initial unit system for the project: 
Imperial or Metric, as shown in Figure 1–4. Choosing this 
option requires all settings to be defined and updated versus 
choosing a predefined template that is similar to your needs.

Figure 1–4

Managing
Settings

Most of the settings stored in a template file are found in the 
Manage tab>Settings panel, as shown in Figure 1–5. These 
settings include Materials, Object Styles, Snaps, and Additional 
Settings (e.g., Line Styles, Fill Patterns, Annotations, etc.)

Figure 1–5

• Specific Structural Settings, MEP Settings, and Panel 
Schedule Templates are also included in the Settings panel.

For more information on managing settings, refer to the following 
sections in Appendix A: 

• A.1 Project Browser Organization

• A.2 General Settings

• A.3 Creating Object Styles

• A.4 Creating Fill Patterns

• A.5 Creating Materials

• A.6 Settings for Mechanical Projects

• A.7 Settings for Electrical Projects

• A.8 Settings for Structural Projects
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Families in
Templates

There are two kinds of families that can be set up in template 
files: system families, such as the duct shown in Figure 1–6, and 
component families, such as the air terminal shown in 
Figure 1–6.

Figure 1–6

For more information on 
setting up system 
families, see Chapter 3: 
Custom System 
Families.

System Families are families that are predefined in Revit 
projects and templates. Unlike external loadable families, system 
families can be created by duplicating existing types and 
modifying the Type Parameters, as shown in Figure 1–7. This 
can only be done within a project and helps to establish the 
company standard for the families set up in a template file. 
System families include walls, wall foundations, floors, structural 
slabs, ceilings, stairs, railings, and roofs. They also include duct, 
pipe, cable tray, and conduit types, along with some annotation 
types, such as text and dimensions.

Figure 1–7
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For more information on 
creating component 
families, see Chapter 4: 
Component Family 
Concepts.

Component Families are external loadable families that are 
created outside of a project and can be loaded directly in a 
template file with types and sizes that are used frequently. 
Component families include elements such as furniture, trees, 
beams, columns, mechanical equipment, and electrical fixtures. 

How To: Load a Family from the Revit Library

1. In the Insert tab>Load from Library panel,  click 

(Load Family).
Go to the Autodesk.com 
website and search 
Autodesk Revit 2023 
Content.

• Alternatively, you can load a family by starting a loadable 
family command, then in the Modify contextual tab>Mode 

panel, click  (Load Family). 

• Note: To use the Load Family method, you must install the 
Autodesk Revit 2023 Content in your desired language 
from the Autodesk website.

2. In the Load Family dialog box, locate the folder that contains 
the family or families you want to load, as shown in 
Figure 1–8. To load more than one family at a time, hold 
<Ctrl> while selecting.

• The program remembers the last-used folder. If the Load 
Family dialog box does not default to the Revit Library 
folder, click on Imperial Library in the Places panel.

• If the Load family dialog box does not default to the Revit 
Library folder, click on Imperial Library in the Places 
panel.

Figure 1–8

Places panel

Click on library 
shortcut
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3. Click Open.

• Note: When inserting a family using a loadable family 
command, after you load the family your cursor will have the 
loaded element at the end of the cursor to prompt you to 
place the element. You will need to press <Esc> twice or click 

 (Modify) to clear the cursor.

4. For some families, the Specify Types dialog box displays, as 
shown for a door in Figure 1–9. Select the types you want to 
include in your project and click OK.

• To select more than one type, hold <Ctrl> as you select.

• You can use the drop-down lists under the columns to 
filter the sizes.

Figure 1–9
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5. Once the families are loaded, from Properties, expand the 
Type Selector, as shown in Figure 1–10, and select the type 
you want to use.

Figure 1–10

Hint: Using Families with this Learning Content

For the practices in this learning content, all families that are 
used have been provided with the practice files. This was done 
to ensure that all users can easily locate and use the required 
files to successfully complete all practices. In general, it is 
recommended that you use families from the provided 
Autodesk Revit Content via downloaded content or the cloud, 
or from your own custom company library.
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How To: Use Load Autodesk Family

Connection to the 
Internet is required.

In addition to loading families from the installed Revit Library, you 
can also load families from the Autodesk online library using the 
Load Autodesk Family command. 

1. In the Insert tab>Load from Library panel, click  (Load 
Autodesk Family).

2. In the Load Autodesk Family dialog box, filter your search by 
typing in what kind of family you are looking for or click on a 
category in the Browse section, as shown in Figure 1–11.

Figure 1–11

3. You can select as many families from the category as 
needed, and then click Load to load them into your project.

Search bar
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Review Loaded
Families

You can review which families have already been loaded to 
determine which families still need to be loaded.

How To: Review the Loaded Families

1. In the Project Browser, expand the Families node.
2. Expand various nodes within the Families node, such as the 

Cable Trays>Cable Tray with Fittings node shown on the 
left in Figure 1–12, to verify which families (in this case, which 
cable tray families) have been loaded into the template.

3. Select the family name, such as Channel Cable Tray, to 
review its Properties, as shown on the right in Figure 1–12.

Figure 1–12

• Alternatively, you can start a command like Door, Air 
Terminal, or Plumbing Fixture to verify from the Type 
Selector which families are loaded. If a family is not loaded, a 
dialog box will display (as shown in Figure 1–13). Click Yes to 
launch the Load Family dialog box.

Figure 1–13
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Purging
Unused

Components

You can clean up a template by removing unnecessary elements 
from a project, including individual component types, as shown 
in Figure 1–14.

Figure 1–14

• Some elements are nested in other elements, and it might 
require several rounds of purging the project to remove them.

How To: Purge Unused Elements

1. In the Manage tab>Settings panel, click  (Purge Unused).
2. The Purge Unused dialog box opens and all elements will be 

selected. Click Check None to clear the selection.
3. Select only the elements that you want to purge. 
4. Click OK.

Purging unused components not only helps simplify the 
component list, but also, more importantly, reduces the project 
file size.
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Using Resource
Projects

Although you can use a template file to start a project, you might 
also want to have resource projects that include additional 
system and component families, pre-drawn details (as shown in 
Figure 1–15), schedules, and sheets. You can then copy these 
elements into a new template or the current project, as needed.

Figure 1–15

• To copy drafting views (details), sheets, schedules, or reports 
into the current project, use Insert Views from File.

• To copy system families (e.g., wall, floor, duct, pipe, wire 
types, etc) or annotations (e.g., text and dimension styles, 
materials, etc.), use Transfer Project Standards. Make sure 
that both the template/model you want to copy from and the 
host template/model you are copying to are open. Also, 
ensure that the host template/model is the active project 
before you start copying.

• To copy component families from a resource project, use 
Copy to the Clipboard and either Paste Aligned to 
Selected Levels or Paste Aligned to Selected Views.

How To: Insert Views from an Existing Project

1. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).
2. In the Open dialog box, select the project file you want to 

copy from.
3. In the Insert Views dialog box, select the views you want to 

insert into the current project, as shown in Figure 1–16. 
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• In the lower left corner, you can select Preview selection 
to preview your selection.

Figure 1–16

4. Click OK. The views are added to the file.

• Schedules are completed with the information in the current 
project. Sheets are added, but do not include any views.

How To: Transfer Project Standards

1. Open the project from which you want to transfer information.
2. Switch to the current project you are copying to.

3. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

4. In the Select Items To Copy dialog box, expand the Copy 
from drop-down list and select the file to copy from.
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Click Check None or 
Check All, as needed.

5. Select the items you want to copy into the current project, as 
shown in Figure 1–17. Then, click OK.

Figure 1–17

• All types of the selected category will be copied. You do not 
have the option to select individual types.

• If the Duplicate Types dialog box displays (shown in 
Figure 1–18), choose Overwrite or New Only to update the 
existing project.

Figure 1–18

• Floor, ceiling, and elevation section plan view types and Revit 
link visibility settings cannot be transferred and need to be set 
up manually.
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Setting Default
Template Files

If your company uses several different templates, you can create 
a list that displays in the New Project dialog box, as shown in 
Figure 1–19. 

Figure 1–19

How To: Set the Default Template Files List

1. In the File tab, click Options. 
2. In the Options dialog box, in the left pane, select File 

Locations, as shown in Figure 1–20. 

Figure 1–20

• Use  (Add Value) to add additional templates (RTE).

• To put your templates in order, use  (Move Rows Up) 

and  (Move Rows Down). Move the templates that are 
used most often to the top.

•  Use  (Remove Value) if you do not need a template 
anymore.

3. Once the template is loaded, you can click on the name in the 
Name column to change it or leave it with its default file 
name. You can also click on any of the other names in the 
Name column and change them if needed.

4. To update a template, click on the file path in the Path column 

and select the  (Browse) button. 
5. In the Browse for Template File dialog box, navigate to the 

correct folder, select the template file, and click Open.
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Practice 1a Prepare Project Templates: 
Architecture
 

In this practice, you will create a new template file based on an 
existing template and add several levels to the project. You will 
review the existing system and component families and load a 
component family. You will then insert views and transfer project 
standards from a resource project, as shown for text types 
before in Figure 1–21 and after in Figure 1–22.

Task 1 - Establish a project template file.

1. On the Home screen, click New... in the MODELS area, or if 

currently in a model, in the File tab, expand (New) and 

click (Project).

Practice Objectives

• Create a new project template file.

• Add levels with plan views.

• Review existing system and component families.

• Load a component family.

• Insert views and transfer project standards from a resource project.

Figure 1–21 Figure 1–22

Before After
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2. In the New Project dialog box, select Imperial-Architectural 
Template.rte.

• Alternatively, if you do not have templates installed, click 
Browse... in the New Project dialog box and navigate to the 
practice files Architectural >RTE folder.

3. In the Create new area, select Project template, as shown in 
Figure 1–23, and click OK.

Figure 1–23

4. In the Quick Access Toolbar, click  (Save) and save the 
template in the practice files Architectural >RTE folder as 
Midrise-Template.rte. 

Task 2 - Add default levels.

1. Open an elevation view. 

2. Click on the level head and rename Level 1 to Floor 1 and 
Level 2 to Floor 2. Click Yes to rename the corresponding 
views. 

3. Change the Floor 2 height to 16'-0", as shown in 
Figure 1–24.

Figure 1–24

4. In the Architecture tab>Datum panel, click  (Level).

5. In the Options Bar, verify that the Make Plan View option is 
selected and click Plan View Types....
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6. In the Plan View Types dialog box, select the Ceiling Plan 
and Floor Plan view types, as shown in Figure 1–25, and 
click OK.

Figure 1–25

7. Add three more levels above Floor 2 with a distance of 
12'-0" between each level, and two levels below Floor 1 with 
a distance of 10'-0" between them. Rename them as shown 
in Figure 1–26. Click Yes to rename the corresponding views.

Scale change and 
dimensions are added 
for clarity.

Figure 1–26

8. Return to the Floor 1 plan view.

9. Save the template.
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Task 3 - Load a component family.

1. In the Insert tab>Load from Library panel, click  (Load 
Family).

• Using the Load Family command, you can load any type 
of component. However, if you use a specific command 
such as Column or Door, you can only load that type of 
family.

2. In the Load Family dialog box, navigate to the practice files 
Architectural>RFA folder and select the Doric Column.rfa 
family to load, then click Open.

3. Save the template.

Task 4 - Review existing family elements in the template.

In this task, you will review existing families in a project using 
both the Type Selector and the Project Browser.

1. In the Annotate tab>Text panel, click  (Text).

2. Expand the list in the Type Selector. Only a few text types are 
available, as shown in Figure 1–27.

Figure 1–27

3. In the Architecture tab>Build panel, select  (Component) 
and review the list of families in the Type Selector.

4. In the Architecture tab>Build panel, click  (Column: 
Architectural) and note that Doric Column is showing in the 
Type Selector.
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5. In the Project Browser, expand the Families>Columns node 
and note that Doric Column is listed there as well, as shown 
in Figure 1–28. Continue to expand nodes within the Project 
Browser to see what other families are loaded in the project.

Figure 1–28

6. Save the template.

Task 5 - Copy information from a resource project.

Inserting views from 
another Revit model 
does not require the 
model to be open when 
performing this task.

1. Close any open projects other than the template file.

2. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).

3. In the Open dialog box, navigate to the practice files 
Resource Project folder, select Construction Resource 
Project.rvt, and click Open.

4. In the Insert Views dialog box, set the Views drop-down list to 
Show all views and sheets.

5. Select one or two drafting views and one or two schedules 
from the list, as shown in Figure 1–29. 
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Figure 1–29

6. Click OK.

7. If the Duplicate Types warning displays, click OK and close 
any warning messages that pop up.

8. In the Project Browser of your template file, review the new 
drafting views and schedules that are added. 

9. Return to the floor plan view.

Task 6 - Use Transfer Standards

Using Transfer 
Standards to copy 
elements from a Revit 
model require the model 
to be open when 
performing this task.

1. In the Open dialog box, navigate to the Practice 
Project>Resource Project folder, select Construction 
Resource Project.rvt. 

2. Click on the view tab to make the Midrise-Template.rte file 
the active project.

3. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

4. In the Select Items To Copy dialog box, note that the Copy 
from drop-down list is set to Construction Resource 
Project.rvt, which is the project that was just used for 
inserting a view from a file.
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5. Click Check None, select Text Types (as shown in 
Figure 1–30), and click OK.

Figure 1–30

6. If the Duplicate Types dialog box displays, select New Only 
because you do not want to overwrite existing text types in 
your template.

7. Start the Text command and look at the expanded list of text 
types that are now available, as shown in Figure 1–31.

Figure 1–31

8. Click  (Modify).

9. Save and close the template file.
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Practice 1b Prepare Project Templates: MEP
 

In this practice, you will create a new template file based on an 
existing template. You will review the existing system and 
component families and load a component family. You will then 
insert views and transfer project standards from a resource 
project, as shown for text types before in Figure 1–32 and after 
in Figure 1–33.

Task 1 - Establish a project template file.

1. On the Home screen, click New... in the MODELS area, or if 

currently in a model, in the File tab, expand (New) and 

click (Project).

Practice Objectives

• Create a new project template file.

• Review existing system and component families.

• Load a component family.

• Insert views and transfer project standards from a resource project.

Figure 1–32 Figure 1–33

Before After
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2. In the New Project dialog box, select the Imperial-Systems 
Template.rte. This template will have electrical, mechanical, 
and plumbing views and families in it.

• For an electrical template, click Browse... and select 
Electrical-Default.rte.

• For a mechanical template, click Browse... and select 
Mechanical-Default.rte.

• For a plumbing template, click Browse... and select 
Plumbing-Default.rte.

• Alternatively, if you do not have templates installed, click 
Browse... in the New Project dialog box and navigate to the 
practice files MEP>RTE folder.

3. In the Create new area, select Project template, as shown in 
Figure 1–34, and click OK.

Figure 1–34

4. In the Quick Access Toolbar, click  (Save) and save the 
template in the practice files MEP>RTE folder as 
Midrise-Template.rte. 

Note: MEP templates typically do not have additional levels. 
Levels are created using Copy/Monitor with a linked file.

Task 2 - Load a component family.

1. In the Insert tab>Load from Library panel, click  (Load 
Family).

• By using the Load Family command, you can load any 
type of component. If you use a specific command, such 
as Mechanical Equipment, you can only load that type of 
family.
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2. In the Load Family dialog box, navigate to the practice files 
MEP>RFA folder and select the Indoor AHU - Horizontal - 
Chilled Water Coil.rfa family to load, then click Open.

Task 3 - Review existing family elements in the template.

In this task, you will review existing families in a project using 
both the Type Selector and the Project Browser.

1. In the Annotate tab>Text panel, click  (Text).

2. Expand the list in the Type Selector. Only a few text types are 
available, as shown in Figure 1–35.

Figure 1–35

3. In the Systems tab>Model panel, select  (Component) and 
review the list of families in the Type Selector.

4. In the Systems tab>Mechanical panel, click  (Mechanical 
Equipment). Note that Indoor AHU - Horizontal - Chilled 
Water Coil is showing in the Type Selector.
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5. In the Project Browser, expand the Families>Mechanical 
Equipment node and note that Indoor AHU - Horizontal - 
Chilled Water Coil is listed there as well, as shown in 
Figure 1–36. Continue to expand nodes within the Project 
Browser to see what other families are loaded in the project.

Figure 1–36

6. Save the template.

Task 4 - Copy information from a resource project.

1. Close any open projects other than the template file.

2. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).

3. In the Open dialog box, navigate to the practice files 
Resource Project folder, select Construction Resource 
Project.rvt, and click Open.
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4. In the Insert Views dialog box, set the Views drop-down list to 
Show all views and sheets.

5. Select one or two drafting views and one or two schedules 
from the list, as shown in Figure 1–37. 

Figure 1–37

If you started with the 
systems or electrical 
template, the drafting 
views will be in the 
Coordination section in 
the Project Browser.

6. Click OK.

7. If the Duplicate Types warning displays, click OK and close 
any warning messages that pop up.

8. In the Project Browser of your template file, review the new 
drafting views and schedules that are added. 

9. Return to the floor plan view.

Task 5 - Use Transfer Standards.

Using Transfer 
Standards to copy 
elements from a Revit 
model require the model 
to be open when 
performing this task.

1. In the Open dialog box, navigate to the practice files 
Resource Project folder, select Construction Resource 
Project.rvt.

2. Click on the view tab to make the Midrise-Template.rte file 
the active project.
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3. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

4. In the Select Items To Copy dialog box, note that the Copy 
from drop-down list is set to Construction Resource 
Project.rvt, which is the project that was just used for 
inserting a view from a file.

Note: If the Insert from 
File command was not 
used, you would have 
had to open the project 
in order to transfer 
standards.

5. Click Check None, select Text Types (as shown in 
Figure 1–38), and click OK.

Figure 1–38

6. If the Duplicate Types dialog box displays, select New Only 
because you do not want to overwrite existing text types in 
your template.
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7. Start the Text command and look at the expanded list of text 
types that are now available, as shown in Figure 1–39.

Figure 1–39

8. Click  (Modify).

9. Save and close the template file.
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Practice 1c Prepare Project Templates: 
Structural 
 

In this practice, you will create a new template file based on an 
existing template and add several levels to the project. You will 
review the existing system and component families and load a 
component family. You will then insert views and transfer project 
standards from a resource project, as shown for text types 
before in Figure 1–40 and after in Figure 1–41.

Task 1 - Establish a project template file.

1. On the Home screen, click New... in the MODELS area, or if 

currently in a model, in the File tab, expand (New) and 

click (Project).

Practice Objectives

• Create a new project template file.

• Add levels with plan views.

• Review existing system and component families.

• Load a component family.

• Insert views and transfer project standards from a resource project.

Figure 1–40 Figure 1–41

Before After
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2. In the New Project dialog box, select the Imperial-Structural 
Template.rte. 

• Alternatively, if you do not have templates installed, click 
Browse... in the New Project dialog box and navigate to the 
practice files Structural >RTE folder.

3. In the Create new area, select Project template, as shown in 
Figure 1–42, and click OK.

Figure 1–42

4. In the Quick Access Toolbar, click  (Save) and save the 
template in the practice files Structural>RTE folder as 
Midrise-Template.rte. 

Task 2 - Add default levels.

1. Open an elevation view. 

2. Click on the level head and rename Level 1 to Ground Floor 
and Level 2 to TOS-Floor 1. Click Yes to rename the 
corresponding views. 

3. Change the TOS-Floor 1 height to 14'-7", as shown in 
Figure 1–43.

Figure 1–43

4. In the Structure tab>Datum panel, click  (Level).
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5. In the Options Bar, verify that the Make Plan View option is 
selected and click Plan View Types....

6. In the Plan View Types dialog box, select the Structural Plan 
view type, as shown in Figure 1–44, and click OK.

Figure 1–44

7. Add three more levels above TOS-Floor 1 with a distance of 
15'-0" between each level, and one level below Ground 
Floor with a distance of 15'-0" between them. Rename them 
as shown in Figure 1–45. Click Yes to rename the 
corresponding views.

Scale change and 
dimensions are added 
for clarity.

Figure 1–45
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8. Return to the Ground Floor plan view.

9. Save the template.

Task 3 - Load a component family.

1. In the Insert tab>Load from Library panel, click  (Load 
Family).

• By using the Load Family command, you can load any 
type of component. If you use a specific command, such 
as Column or Truss, you can only load that type of 
family.

2. In the Load Family dialog box, navigate to the practice files 
Structural>RFA folder, select Pipe-Column.rfa, and click 
Open.

3. In the Specify Types dialog box, select Pipe8STD and click 
OK.

4. Save the template.

Task 4 - Review existing family elements in the template.

In this task, you will review existing families in a project using 
both the Type Selector and the Project Browser.

1. In the Annotate tab>Text panel, click  (Text).

2. Expand the list in the Type Selector. Only a few text types are 
available, as shown in Figure 1–46.

Figure 1–46

3. In the Structure tab>Model panel, select  (Component) 
and review the list of families in the Type Selector.



Autodesk Revit 2023 BIM Management: Template and Family Creation 

1–34 © 2022, ASCENT - Center for Technical Knowledge®

4. In the Structural tab>Structure panel, select  (Column). 
Note that Pipe8STD is displayed in the Type Selector.

5. In the Project Browser, expand the Families>Structural 
Columns>Pipe-Column node and note that Pipe8STD is 
listed there as well, as shown in Figure 1–47. Continue to 
expand nodes within the Project Browser to see what other 
families are loaded in the project.

Figure 1–47

6. Save the template.
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Task 5 - Copy information from a resource project.

1. Close any open projects other than the template file.

2. In the Insert tab>Load from Library panel, expand  (Insert 

from File) and click  (Insert Views from File).

3. In the Open dialog box, navigate to the practice files 
Resource Project folder, select Construction Resource 
Project.rvt, and click Open.

4. In the Insert Views dialog box, set the Views drop-down list to 
Show all views and sheets.

5. Select one or two drafting views and one or two schedules 
from the list, as shown in Figure 1–48. 

Figure 1–48

6. Click OK.

7. If the Duplicate Types warning displays, click OK and close 
any warning messages that pop up.

8. In the Project Browser of your template file, review the new 
drafting views and schedules that are added. 

9. Return to the floor plan view.



Autodesk Revit 2023 BIM Management: Template and Family Creation 

1–36 © 2022, ASCENT - Center for Technical Knowledge®

Task 6 - Use Transfer Standards.

Using Transfer 
Standards to copy 
elements from a Revit 
model require the model 
to be open when 
performing this task.

1. In the Open dialog box, navigate to the practice files 
Resource Project folder, select Construction Resource 
Project.rvt.

2. Click on the view tab to make the Midrise-Template.rte file 
the active project.

3. In the Manage tab>Settings panel, click  (Transfer Project 
Standards).

4. In the Select Items To Copy dialog box, note that the Copy 
from drop-down list is set to Construction Resource 
Project.rvt, which is the project that was just used for 
inserting a view from a file.

5. Click Check None, select Text Types (as shown in 
Figure 1–49), and click OK.

Figure 1–49

6. If the Duplicate Types dialog box displays, select New Only 
because you do not want to overwrite existing text types in 
your template.
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7. Start the Text command and look at the expanded list of text 
types that are now available, as shown in Figure 1–50.

Figure 1–50

8. Click  (Modify).

9. Save and close the template file.
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1.2 Customizing Annotation 
Types

Establishing annotation style types is an important part of 
template creation. You can customize annotation types in your 
project template file, including dimensions, text, arrowheads, and 
tags. Figure 1–51 shows the different types of annotations. 
Within each annotation type, you can customize font, text size, 
background, leaders, etc.

Figure 1–51

Text, Dimensions, and Arrowheads are all system families and 
are depicted with the label System Family in front of the name in 
their Type Properties (as shown in Figure 1–52) and component 
families. This means they have a standard set of parameters, 
which you can modify and save as a type. 

Figure 1–52

Callout, section, and elevation tags can be modified in Revit. 
Most other tags, like door, window, and beam tags, are created 
using component families.
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Creating Text
Types

Text types are used to standardize text formatting (such as the 
font, text height, etc.), as shown in Figure 1–53. They can be 
created for both annotative text and model text.

Figure 1–53

• The Text command places 2D text at the height you need for 
the final plot. The view scale controls the height of the 
standard text in the views.

• The Text Size parameter represents the height of an upper 
case letter. (Verify that the text in projects created in earlier 
versions of the software displays as expected.)

• The Model Text command places work plane based 3D text 
that is typically used on buildings, walls, doors, or signs, as 
shown in Figure 1–54. Text types for model text should be the 
actual height of the final signage element and are not 
affected by the view scale.

Figure 1–54

Model Text
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How To: Create a Text Type

1. Start the Text command. 

2. In Properties, click  (Edit Type) or in the Annotate tab> 

Text panel title, click  (Text Types).
3. In the Type Properties dialog box, click Duplicate....
4. Type a new name and click OK.The new type is activated.
5. Modify the parameters as needed for the new type, as shown 

for annotation text in Figure 1–55.

Figure 1–55

6. Click OK to finish.

How To: Create a Model Text Type

1. In the Architecture tab>Model panel, click  (Model Text). 
Alternatively, in the Structure tab>Model panel, click 

(Model Text).
2. In the Edit Text dialog box, keep the default text and click OK, 

then place the text in the view.

3. Select the model text and from Properties, click Edit Type. 

4. In the Type Properties dialog box, click Duplicate....
5. Type a new name and click OK. The new type is activated.
6. Modify the parameters as needed for the new text type.
7. Click OK to finish.
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Creating
Dimension

Types

Dimensions are one of the more complex system families in 
terms of the number of parameters you can modify. They include 
options for the Dimension Text, Dimension Line, Tick Marks, and 
Witness Lines. You can specify information such as the units, 
color, and all of the gap sizes between elements, as shown in 
Figure 1–56.

Figure 1–56

• You can add a suffix or prefix to a dimension type by creating 
a type-driven dimension style. Duplicate the dimension style 
and specify a set prefix and suffix within the type parameters. 
This eliminates the need for users to manually modify the 
dimension every time they need to add a prefix or suffix.

Witness Line

Set gap between witness 
line and reference

Tick Mark

Dimension Text

Dimension Line
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How To: Create Dimension Types

1. In the Annotate tab>Dimension panel, expand the Dimension 
panel title (as shown in Figure 1–57) and click the dimension 

type with the  icon next to it that you want to create.

You create separate 
types for each 
dimension method. 

Figure 1–57

2. In the Type Properties dialog box, click Duplicate....
3. Type a new name and click OK. The new type is activated.
4. Modify the parameters as needed for the new type, as shown 

in Figure 1–58. 

• Values for parameters (such as text size, witness line 
extension, etc.) are the actual plot size for these 
elements. The view scale controls how large they are in 
the specific view.



Creating Custom Templates

© 2022, ASCENT - Center for Technical Knowledge® 1–43

• Specify a prefix or suffix for Primary Units, as shown in 
Figure 1–58.

Figure 1–58

5. Click OK when you are finished.

• For linear dimensions, you can specify a Leader Type, 
Shoulder Length, and Leader Tick Mark, as well as the Show 
Leader When Text Moves option that is used when the text is 
pulled away from the dimension string. You can also specify 
the text inserted for Equality Text (the default is EQ).

• You can specify a Text Background option. If you set the 
value to opaque, it automatically masks any elements behind 
the text. If it is set to transparent, anything the text overlaps 
is still visible.

• If you are dimensioning doors and windows by their widths 
rather than their centers, you can also have the opening 
height displayed with the dimension. Select Show Opening 
Height.
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Labeling
Dimensions

If you have a distance that needs to be repeated multiple times, 
such as the Wall to Window label shown in Figure 1–59, or one 
where you want to use a formula based on another dimension, 
you can create and apply a global parameter, also called a label, 
to the dimension.

Figure 1–59

• To apply an existing label to a dimension, select the 
dimension and in the Modify | Dimensions tab>Label 
Dimension panel, select the label in the drop-down list, as 
shown in Figure 1–60.

Figure 1–60

Indicates there is a label
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How To: Create a Label

1. Select a dimension.
2. In the Modify | Dimensions tab>Label Dimension panel, click 

 (Create Parameter)
3. In the Global Parameter Properties dialog box, type in a 

Name, as shown in Figure 1–61, and click OK.

Figure 1–61

4. The label is applied to the dimension.

How To: Edit the Label Information

1. Select a labeled dimension.

2. Click  (Global Parameters), as shown in Figure 1–62. 

Figure 1–62

Global Parameters
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3. In the Global Parameters dialog box, in the Value column, 
type the new distance, as shown in Figure 1–63.

Figure 1–63

4. Click OK. The selected dimension and any other dimensions 
using the same label are updated.

• You can also edit, create, and delete global parameters in 
this dialog box.

Loading Tags
and Symbols

Tags and symbols are 2D component families that must be 
loaded into a project. Not all types of tags need to be in each 
project, so you can choose which ones you want to include in 
your templates. For example, if you are working in an 
architectural project, you can load tags such as the door, 
window, and wall shown in Figure 1–64. 

Figure 1–64
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How To: Specify Loaded Tags and Symbols

1. In the Annotate tab>Tag panel, expand the panel title and 

click  (Loaded Tags and Symbols).
2. In the Loaded Tags and Symbols dialog box, use the Filter list 

field to limit the types of tags you are looking for by discipline, 
as shown in Figure 1–65.

Some elements, such 
as Floors and Structural 
Fabric Reinforcement, 
have both tags and 
symbols. They can both 
be specified in this 
dialog box.

Figure 1–65

3. Click Load Family....
4. In the Load Family dialog box, navigate to the appropriate 

library and folder. Note, tags are typically found in the Revit 
Library’s Annotations folder and sorted within discipline 
sub-folders.

5. Select the required tags and click Open. Hold <Ctrl> or 
<Shift> to select multiple tags.

6. The selected tags are assigned to their appropriate 
categories.

7. When you have loaded all of the tags that you need for a 
project, click OK.



Autodesk Revit 2023 BIM Management: Template and Family Creation 

1–48 © 2022, ASCENT - Center for Technical Knowledge®

8. If multiple tags are loaded for a category, you can choose 
which one is the default tag by choosing it in the Loaded Tags 
column, as shown in Figure 1–66.

Figure 1–66

Specifying
View Tags

Callouts, Elevations, and Section markers are system family 
view tags and can be modified to suit office standards. For 
example, you can create a new Elevation view type containing a 
tag that displays the view name by duplicating an existing one 
and modifying the properties, as shown in Figure 1–67.

Figure 1–67
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How To: Create Custom System Family Tags for 
View Types

1. In the View tab>Create panel, click  (Callout), 

(Elevation), or  (Section), and in Properties, click 

(Edit Type). In the Type Properties dialog box, select an 
existing type, then duplicate and name the new view type, as 
shown for an elevation view in Figure 1–68.

Each view type has 
different parameters.

Figure 1–68

2. Beside any of the tag parameters, click in the Value column 

and then click  (Browse). 
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3. In the Type Properties dialog box for the tag, select from an 
existing tag type or duplicate a tag type, and specify a new 
mark element from a list of families that have been loaded 
into the project, as shown in Figure 1–69.

Figure 1–69

4. Click OK to apply the tag type.
5. Modify the other parameters as needed and click OK to close 

the Type Properties dialog box.

• Levels (shown in Figure 1–70) and grids (shown in 
Figure 1–71) are also system families that are set up in Type 
Properties and include component families such as the 
Symbol Level Head-Circle and Grid Head-Circle.

Tag type

Figure 1–70 Figure 1–71
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How To: Create Custom System Family Tag Types 
from an Existing Tag

1. In the Manage tab>Settings panel, expand (Additional 

Settings), expand  (Annotations), and select  (Callout 

Tags), (Elevation Tags), (Arrowheads), or 

(Section Tags). 
2. In the Type Properties dialog box for the tag, select from an 

existing tag type or duplicate a tag type, as shown in 
Figure 1–72.

Figure 1–72

3. In the Type Parameters area, in the Graphics section, specify 
a new mark element from a list of families that have been 
loaded into the project, as shown in Figure 1–73.

Figure 1–73

4. Click OK.
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