
Autodesk

Revit 2025 Architecture 
Fundamentals

®

®

SDC
PUBLICATIONS www.SDCpublications.com

Better Textbooks. Lower Prices.

https://www.sdcpublications.com


Visit the following websites to learn more about this book:

Powered by TCPDF (www.tcpdf.org)

https://www.sdcpublications.com/Textbooks/Autodesk-Revit-2025-Architecture-Fundamentals/ISBN/978-1-63057-680-6/
http://www.tcpdf.org


© 2024 ASCENT - Center for Technical Knowledge 2–1

Chapter

2
Starting a Revit Project
Starting a Revit project begins by using a template. You can then link in a CAD file or an existing 
Revit model, if these are available. From there, you can add the framework for a design, 
including levels to define vertical heights and grids to help define the Revit elements’ layout.

Learning Objectives 

• Select and open a project template.

• Link and import CAD files to be used as a basis for developing a design.

• Link existing Revit models to develop and coordinate with other disciplines.

• Add and modify levels to define floor-to-floor heights and other vertical references.

• Add and modify grids to provide locations for model elements.
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2.1 Selecting a Project Template
New projects are based on a project template file. The template file includes preset levels, 
views, and some families, such as wall styles and text styles. When using templates, most of 
the views are set to display only the elements specific to the template, so it is best practice to 
select a template that reflects your company’s discipline.

• Check with your BIM manager about which template you need to use for your projects. Your
company might have more than one based on the type of project you are designing.

• Ideally, you should not start your work inside of another discipline or model. Instead, you
should start from one of the default Revit templates or your company’s custom template
and link the architectural model into your project. If you link a Revit model into your
project, you can use the monitoring and coordinating features to copy/monitor
necessary items, such as walls, floors, and grids, from the architect. To learn more about
Copy/Monitoring, see ASCENT’s Autodesk Revit: Collaboration Tools guide.

How To: Start a New Project

1. In the File tab, expand  (New) and click (Project), as shown in Figure 2–1, or press 
<Ctrl>+<N>.

Figure 2–1
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2. In the New Project dialog box (shown in Figure 2–2), select the template that you want to 
use and click OK.

Note: The list of template files is set in the Options dialog box in the File Locations tab. It 
might vary depending on the installed product and company standards.

Figure 2–2

Hint: Revit Worksharing
If established by your company that worksharing is needed, you would typically want to start 
a worksharing project on your local network once a project has been created.

• For more information on worksharing, see A.9 Introduction to Revit Worksharing in 
Appendix A Additional Tools for Design Development.

• For more information about establishing and using worksets, refer to ASCENT’s 
Autodesk Revit: Collaboration Tools guide.
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2.2 Linking and Importing Files
CAD files can be imported or linked into a Revit project. As an example, a designer might lay out 
a floor plan using the standard 2D AutoCAD software, and you then need to incorporate that 
information into your structural model. In addition, many renovation projects start with existing 
2D drawings. Instead of redrawing from scratch, link or import the CAD file (as shown in 
Figure 2–3) and trace over it in Revit. You can also print a hybrid drawing that is part Revit 
project and part imported/linked drawing.

Note: When you hover over an imported or linked CAD file, you can see in the tooltip that it 
is called an Import Symbol.

Figure 2–3

• CAD file formats that can be imported or linked include AutoCAD® (DWG and DXF),
MicroStation (DGN), 3D ACIS modeling kernel (SAT), Trimble SketchUp (SKP), FormIt (AXM),
3D Shape (OBJ and STL), and Rhino (3dm).

• When linking or importing a CAD file, you can specify a level or a named horizontal reference
plane in the project to position the CAD file at.

• You can specify the linking or import units (e.g., feet, meter, or US survey feet).
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Linking vs. Importing
• Link: A connection is maintained with the original file and the link updates if the original file 

is updated.

• Import: No connection is maintained with the original file. It becomes a separate element in 
the Revit model.

How To: Link or Import a CAD File

1. Open the view into which you want to link or import the file.

• For a 2D file, this should be a 2D view. For a 3D file, open a 3D view.

2. In the Insert tab>Link panel, click  (Link CAD), or in the Insert tab>Import panel, click 

(Import CAD).

3. In the Link CAD Formats (shown in Figure 2–4) or Import CAD Formats dialog box, select the 
file that you want to import.

• Select a file format in the Files of type: drop-down list to limit the files that are displayed.

Note: The dialog boxes for Link CAD Formats and Import CAD Formats are the same.

Figure 2–4
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4. If Current view only is selected, as shown in Figure 2–5, you can set all options except the
Place at and the Orient to View options. The view will only display in the current view.

Figure 2–5

5. If you would like to place the CAD file at a level or reference plane, verify Current view only
is unchecked and set the Place at option, as shown in Figure 2–6.

Figure 2–6

6. Click Open.

Link and Import Options
Current view only Determine whether the CAD file is placed in every view, or only in the current 

view. This is especially useful if you are working with a 2D floor plan that you 
only need to have in one view.

Colors Specify the color settings. Typical Revit projects are mainly black and white. 
However, other software frequently uses color. You can Invert the original 
colors, Preserve them, or change everything to Black and White.

Layers/Levels Indicates which CAD layers are going to be brought into the model. Select 
how you want layers to be imported: All, Visible, or Specify....

Import units Select the units of the original file, as required. Auto-Detect works in most 
cases.

Correct lines... If lines in a CAD file are off axis by less than 0.1 degree, selecting this option 
straightens them. It is selected by default.

Positioning Specify how you want the imported file to be positioned in the current project:

The default position is Auto - Origin to Internal Origin.

Linking optionImport option
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• When a file is positioned Auto - Origin to Internal Origin, it is pinned in place and cannot be 
moved. To move the file, click on the pin to unpin it, as shown in Figure 2–7.

Figure 2–7

Place at Select a level or named reference plane at which to place the imported file. If 
you selected Current view only, this option is grayed out.

Orient to View Used to orient the CAD file on import/link.
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2.3 Linking in Revit Models
You can link Revit models directly into a project. These models can be an existing building that 
you are creating an addition to, as shown in Figure 2–8, or engineering models that you are 
checking to ensure that they line up with your model. They are also used for campus-like 
projects where the same building is repeated multiple times.They are full 3D models.

Note: A linked model automatically updates when the original file is changed.

Figure 2–8

• Architectural, structural, and MEP models created in Revit can be linked into each other as
long as they are from the same release cycle.

• When you use linked models, clashes between disciplines can be detected and information
can be passed between disciplines.

• Revit models are always linked. They cannot be imported.

Linked Revit model with outline of 
addition in the current project
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How To: Add a Linked Model to a Host Project

1. In the Insert tab>Link panel, click  (Link Revit).

2. In the Import/Link RVT dialog box, select the file that you want to link. Before opening the 
file, set the Positioning, as shown in Figure 2–9.

Figure 2–9

3. Click Open.

4. Depending on how you decide to position the file, it is automatically placed in the project or 
you can manually place it with the cursor.

• As the links are loading, do not click on the screen or click any buttons. The more links 
present in a project, the longer it takes to load.
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2.4 Modifying Imported/Linked Files
When you select an imported/linked file, you can modify it by arranging the Foreground/
Background status, modifying its type properties, querying information about elements in the 
file, and deleting layers. You can also modify the Visibility/Graphic Overrides of each imported/
linked instance.

• An imported/linked file is called an import symbol once it is inserted into a project, as shown
in Figure 2–10.

Figure 2–10

Setting an Imported or Linked File to Halftone
To see the difference between the host model elements and the linked or imported file, you can 
set the linked/imported file to halftone, as shown in Figure 2–11.

Figure 2–11

Linked/imported file

Revit elements
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How To: Set an Element to Halftone 

1. Select the imported file.

2. Right-click and select Override Graphics in View>By Element....

3. In the View Specific Element Graphics dialog box, select Halftone, as shown in Figure 2–12.

• The options shown in the View Specific Element Graphics dialog box will depend on the 
element selected.

Figure 2–12

4. Click OK.

• You can use this method to set any element or category to halftone.

Draw Layer
Linked CAD files are typically in the background of a view. To change this, select the CAD file in 
the view and in the Options Bar or in Properties, in the Other section, change the Draw Layer to 
Foreground.

• In the contextual tab>Arrange panel (shown in Figure 2–13), use the Arrange tools to move 
linked files to the front or back of the host elements.

Figure 2–13
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How To: Hide Individual Layers

1. In the View tab>Graphics panel, click (Visibility/Graphics), or type VG or VV to open the 
Visibility/Graphic Overrides dialog box.

2. Switch to the Imported Categories tab. It displays a list for each imported instance and their
layers/levels, as shown in Figure 2–14.

3. To have the linked/imported file display in halftone, check the box in the Halftone column.

Figure 2–14

4. Click the plus sign beside the file name to expand a list of the layers or levels in that file.

5. Clear the checkmark from the individual layers that you do not want to display.

• Typically, these layers contain similar information, such as all windows or all notes in a
drawing. However, it is not as definite as using Revit elements. An item might have been
misplaced on a different layer and, if so, it does not toggle off.

6. Close the dialog box.

• To toggle off the entire file, clear the checkmark next to the file name.

Click to have the 
imported/linked file 
display in halftone
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Temporarily Hide/Isolate
You might want to temporarily remove linked or imported files from a view, modify the project, 
and then restore the elements. Instead of completely toggling the elements off, you can 
temporarily hide them.

Select the elements you want to hide (make invisible) or isolate (keep displayed while all other 
elements are hidden) and click  (Temporary Hide/Isolate). Select the method you want to 
use, as shown in Figure 2–15.

Figure 2–15

• The category or elements are hidden or isolated. A cyan border displays around the view 
with a note in the upper left corner, as shown in Figure 2–16. It indicates that the view 
contains temporarily hidden or isolated elements.

Figure 2–16

• Click  (Temporary Hide/Isolate) again and select Reset Temporary Hide/Isolate to 
restore the elements to the view.

• If you want to permanently hide the elements in the view, select Apply Hide/Isolate to View.

• Elements that are temporarily hidden in a view are not hidden when the view is printed.
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Hide Linked or Imported Files in a View
When working in views, you can quickly hide linked or imported files. To hide the imported or 
linked file, select it and right-click to display the shortcut menu, then select Hide in View and 
select either Elements or Category, as shown in Figure 2–17. Alternatively, select the link in the 
view and type VH to hide the selected file in the view.

Figure 2–17

Managing Links
The Manage Links dialog box (shown in Figure 2–18) enables you to reload, unload, add, and 
remove links, and it also provides access for you to set other options. To open the Manage 

Links dialog box, in the Insert tab>Link panel, click (Manage Links). Alternatively, you can go 

to the Manage tab>Manage Projects panel and click  (Manage Links).

• You can also select the link and click  (Manage Links) in the Modify | RVT Links tab>Link 
panel.

Figure 2–18
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• The Manage Links dialog box does not show imported CAD files.

• You can manage both imported and linked images and PDFs.

The following options are available:

• Reload From: Opens the Add Link dialog box, which enables you to select the file you want 
to reload. Use this if the linked file location or name has changed.

• Reload: Reloads the file without additional prompts.

• Unload: Unloads the file so that the link is kept, but the file is not displayed or calculated in 
the project. Use Reload to restore it.

Note: Some of these options are also available in the Project Browser. Expand the Revit 
Links node, then right-click on the Revit link and select Reload, Unload, or Reload From…. 

• Add: Opens the Import/Link RVT dialog box, which enables you to link additional models into 
the host project.

• Remove: Deletes the link from the file.

Links can be nested into one another. How a link responds when the host project is linked into 
another project depends on the option in the Reference Type column. 

• Overlay: The nested linked model is not referenced in the new host project. 

• Attach: The nested linked model displays in the new host project.

The option in the Path Type column controls how the location of the link is remembered.

• Relative

• Searches the root folder of the current project.

• If the file is moved, the software still searches for it.

• Absolute

• Searches the entire file path where the file was originally saved.

• If the original file is moved, the software is not able to find it.

• Other options control how the linked file interfaces with worksets and shared positioning.
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Practice 2a
Start a Project and Link Files

Practice Objectives 

• Start a Revit project.

• Link a CAD file.

• Link a Revit file.

• Modify the linked files in a view.

In this practice, you will start a Revit project, then import floor plans created in AutoCAD and use 
them as a base layout for the first floor lobby and for a typical guest floor. You will then link in a 
Revit model that includes a standard poolhouse and platform for the building. Figure 2–19 
shows the completed practice.

Figure 2–19

Task 1:  Start a project.

1. On the Home screen, click the New button under the MODEL section. Alternatively, in the

File tab, expand  (New) and click (Project).

2. In the New Project dialog box, click Browse....
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3. In the Choose Template dialog box, navigate to the practice files Templates folder, select 
Imperial-Arch Template, and click Open.

4. In the New Project dialog box, click OK. (There are no elements in this file, only datums and 
basic views.)

5. In the File tab, expand  (Save As) and select  (Project). In the Save As dialog box, 
navigate to the practice files folder and name the project as Hotel-Start.rvt. Click Save.

6. Review the Project Browser and note that the project has default floor plan, ceiling plan, and 
elevation views. By default, the Floor Plans: Level 1 view is open and displays in bold in the 
Project Browser, as shown in Figure 2–20.

Figure 2–20

Task 2:  Link a CAD file.

1. In the Insert tab>Link panel, click  (Link CAD).

2. In the Link CAD Formats dialog box, navigate to the practice files CAD Files folder and select 
the file Hotel-Level-1.dwg, then set the following options:

• Select Current view only

• Colors: Black and White

• Layers/Levels: All

• Import Units: Auto-Detect

• Positioning: Auto - Origin to Internal Origin

3. Click Open. The linked CAD file is placed in the project on the Floor Plans: Level 1 view.
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4. Select the linked CAD file. It is a single imported symbol and pinned in place because it was
imported origin to internal origin.

5. With the linked CAD file still selected, in Properties, in the Other section, change the Draw
Layer to Foreground. Alternatively, this can be set in the Options Bar.

Note: As you are drawing walls, floors, ceilings, and roofs within your project, you will
want to change how the DWG is displaying in your view from Foreground to Background,
depending on what you need to see.

6. With the CAD file still selected, right-click in the draw area and select Override Graphics in
View>By Element....

7. In the View Specific Element Graphics dialog box, select Halftone and click OK.

8. Click in an empty space in the view to release the selection. The linked file displays in
halftone, as shown in Figure 2–21.

Figure 2–21

9. Open the Floor Plans: Level 2 view. The CAD file linked in Level 1 does not display because
you specified to link the CAD file with Current view only selected.

10. Link the CAD file Hotel-Level-2.dwg using the options that were used for Level 1.

11. Override the graphics and set the linked file to Halftone.

12. Save the project.

Task 3:  Link in a Revit file.

1. In the Quick Access Toolbar, click  (Default 3D View). Neither of the linked CAD files 
display in this view.
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2. In the Insert tab>Link panel, click  (Link Revit).

3. In the Import/Link RVT dialog box, navigate to the practice files Revit Link Files folder and 
select Hotel-Pool.rvt. Verify that the Positioning is set to Auto - Internal Origin to Internal 
Origin and click Open.

4. In the View Control Bar, change the Visual Style to (Shaded).

5. Select one of the levels and type VH to hide in view.

6. Type ZF to fit all the model to the view or ZA to zoom all, as shown in Figure 2–22.

Figure 2–22

7. Along the top of the view window, select the Level 1 tab to switch back to this view. Both the 
linked CAD file and linked Revit file display in this view.

8. In the View tab>Graphics panel, click (Visibility/Graphics), or type VG or VV to open the 
Visibility/Graphic Overrides dialog box.

9. Click on the Revit Links tab. Next to Hotel Pool.rvt, check the checkbox for Halftone, as 
shown in Figure 2–23. 

Figure 2–23

10. Click OK.

11. Save and close the project.

End of practice
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2.5 Setting Up Levels
Levels define stories and other vertical heights, such as the first and second floor reference 
heights shown in Figure 2–24. The default template includes two levels, but you can define as 
many levels in a project as required. They can go below 0'-0" in the negative (for basements) 
as well.

Figure 2–24

• You must be in an elevation or section view to define levels.

• Once you constrain an element to a level, it moves with the level when the level is changed.

How To: Create Levels

1. Open an elevation or section view.

2. In the Architecture tab>Datum panel, click  (Level), or type LL.

3. In the Type Selector, set the level head type, if needed.

4. In the Modify | Place Level tab>Plan Views panel, check Create Plan View, as shown in
Figure 2–25.

Figure 2–25
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5. Click Plan View Types to select or unselect the types of views to create when you place the 
level. Figure 2–26 shows the Plan View Types dialog box.

Note: If you have Structural Tabs and Tools turned off in Revit Options>User Interface, 
you will not see the Structural Plan in the Plan View Types dialog box.

Figure 2–26

6. In the Modify | Place Level tab>Draw panel, click either  (Pick Lines) to select an element 

or  (Line) to sketch a level.

7. When using Pick Lines, ensure that you do not place levels on top of each other or other 
elements by mistake.Continue adding levels as needed.

• Level names are automatically incremented as you place them. This automatic numbering 
is most effective when you use names such as Floor 1, Floor 2, etc. (as opposed to First 
Floor, Second Floor, etc.). In addition, this makes it easier to find the view in the Project 
Browser. 

• A fast way to create multiple levels is to use the  (Pick Lines) option. In the Options Bar, 
specify an Offset, select an existing level, and then pick above or below to place the new 
level, as shown in Figure 2–27. 

Note: You specify above or below the offset by hovering the cursor on the needed side.

Figure 2–27

Offset alignment line
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• When using the  (Line) option, alignments and temporary dimensions help you place the 
line correctly, as shown in Figure 2–28.

Figure 2–28

• Sketch the level lines from left to right or right to left to keep consistent.

• You can also use  (Copy) to duplicate level lines. The level names are incremented but a 
plan view is not created. These are called reference levels.

• Levels display in the default 3D view. They can be modified and copied, but cannot be
created in this view.

• Levels can be hidden in any view.

Modifying Levels
You can change levels using standard controls and temporary dimensions, as shown in 
Figure 2–29 to the levels’ appearance. You can also make changes to the name and height of 
the level by selecting on the individual items in the view as well as change these in Properties. 
You can change just the name of the level in the Project Browser but not the height.

Figure 2–29

Temporary 
dimension

First click Second click

Alignment 
line

Alignment 
line

Controls

Controls
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•  (Hide/Show Bubble) displays on either end of the level line and toggles the level 
head symbol and level information on or off. 

•  (Switch to 3d/2d extents) controls whether any movement or adjustment to the 
level line is reflected in other views (3D) or only affects the current view (2D).

•  (Modify the level by dragging its model end) at each end of the line enables you to drag 
the level head to a new location.

•  (Create or remove a length or alignment constraint) controls whether the level is 
locked in alignment with the other levels. If it is locked and the level line is stretched, all of 
the other level lines stretch as well. If it is unlocked, the level line stretches independent of 
the other levels.

• Click  (Add Elbow) to add a jog to the level line, as shown in Figure 2–30. Drag the shape 
handles to new locations as needed. This is a view-specific change.

Figure 2–30

• To change the level name or elevation, double-click on the information next to the level head, 
or select the level and modify the Name or Elevation fields in Properties, as shown in 
Figure 2–31.

Figure 2–31

After Before 
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• When you rename a level, an alert box opens, prompting you to rename the corresponding
views, as shown in Figure 2–32.

Figure 2–32

• The view is also renamed in the Project Browser.

• If you delete a level, the views related to that level are also deleted. A warning displays, as
shown in Figure 2–33.

Figure 2–33

Hint: Modifying Measurements
For imperial measurements (feet and inches), the software uses a default of feet. For 
example, when you type 4 and press <Enter>, it assumes 4'-0". For a distance such as 4'-6", 
you can type any of the following: 4'-6", 4'6, 4-6, or 4 6 (the numbers separated by a space). 
To indicate distances less than one foot, type the inch mark (") after the distance, or enter 0, 
a space, and then the distance.

Hint: Copying Levels and Grids from Other Projects
Levels and grid lines can be added by drawing over existing levels or grids in an imported or 
linked CAD file. They can also be copied and monitored from a linked Revit file. Some 
projects might require both methods.
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Creating Plan Views
By default, when you place a level, plan views for that level are automatically created. If Make 
Plan View was toggled off when adding the level, or if the level was copied, you can create plan 
views to match the levels. 

• Level heads with views are blue and level heads without views are black, as shown in 
Figure 2–34.

Figure 2–34

Note: Typically, you do not need to create plan views for levels that specify data, such as 
the top of a storefront window or the top of a parapet.

How To: Create Plan Views

1. In the View tab>Create panel, expand  (Plan Views) and select the type of plan view you 
want to create, as shown in Figure 2–35.

Figure 2–35

Black = no plan views

Blue = plan views created



Autodesk Revit 2025: Fundamentals for Architecture

2–26 © 2024 ASCENT - Center for Technical Knowledge

2. In the New Plan dialog box (shown in Figure 2–36), select the levels for which you want to
create plan views. Hold <Ctrl> to select more than one level.

• Clear Do not duplicate existing views to create a copy of an existing view.

Figure 2–36
3. Click OK.

• Once a plan view is made from a level, you can double-click on the level head to open the
related floor plan view. You create other plan views similar to creating a floor plan. Ceiling
plans are typically created by default when you add a level with a view. If you do not want a
level to have a ceiling plan, you can right-click on its name in the Project Browser and select
Delete, as shown in Figure 2–37.

Figure 2–37
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Practice 2b
Set Up Levels

Practice Objectives 

• Add and modify levels

• Create a plan view.

In this practice, you will set up the levels required in the hotel project, including the floors, top of 
the footing, basement, and parapet levels. Figure 2–38 shows the completed practice, though 
you should see the linked Revit model on your screen. (The RVT link has been hidden in the 
figure below for clarity.)

Figure 2–38
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1. Open the project Arch-Levels.rvt from the practice files folder.

2. In the Project Browser, open the Elevations (Building Elevation): North view. You will see
your project’s Level 1 and Level 2 levels, as well as the Level 1 and Level 2 levels and grid
lines that are part of the linked Revit file.

3. Select the linked Revit file.

4. In the View Control Bar, expand  (Temporary Hide/Isolate) and select Hide Element. 
This toggles off the linked Revit file.

5. Zoom in on the level names.

6. Slowly click twice on the name Level 1 and rename it to Floor 1, as shown in Figure 2–39.
Press <Enter>.

Figure 2–39

7. In the Confirm Level Rename dialog box, click Yes or press <Y> when prompted to rename
the corresponding views and note that in the Floor Plans section, the view name has
changed.

8. Repeat the process and rename Level 2 as Floor 2. (Rename the corresponding views.)
Click on the height of Floor 2. Change it from 10'-0" to 18'-0" and press <Enter>.

Note: Instead of typing the hyphen, just press <spacebar> between the feet and inch.

9. Click  (Modify).

10. In the Architecture tab>Datum panel, click  (Level). 

11. In the Modify | Place Level tab>Plan Views panel, check Create Plan View, then click Plan
View Types.
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12. In the Plan View Types dialog box, uncheck Structural Plan to deselect it (so that only 
Ceiling Plan and Floor Plan are selected), as shown in Figure 2–40. Click OK.

Note: If you have Structural Tabs and Tools turned off in Revit Options>User Interface, 
you will not see the Structural Plan in the Plan View Types dialog box.

Figure 2–40

13. In the Modify | Place Level tab>Draw panel, click  (Pick Lines). In the Options Bar, set the 
Offset to 12'-0".

14. Hover the cursor over the level line of Floor 2 and move the cursor slightly upward until you 
see the dashed alignment line display above the Floor 2 level. Click to create the new level 
Floor 3.

15. Create additional levels until there are a total of nine levels, all with the Offset of 12'-0". 

16. Click  (Modify) and select the Floor 9 level. 

17. Rename Floor 9 as Roof. (Rename the corresponding views.)

18. Click  (Modify).

19. Start the Level command again.

20. In the Modify | Place Level tab>Draw panel, click  (Pick Lines).

21. In the Modify | Place Level tab>Plan Views panel, uncheck the Create Plan View option.

22. In the Options Bar, set the Offset to 5'-0". Create one additional level above the Roof level. 
This level does not need a plan view.

23. Click  (Modify).
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24. Rename the top level as Parapet, as shown in Figure 2–41. 

Note: You do not get the request to rename corresponding views because you unchecked 
Create Plan View, so no view was created when the level was placed in the view. The 
Parapet level head is black as opposed to blue like the rest of the levels. A black level 
head means that there are no views created for this level.

Figure 2–41
25. Click  (Modify).

26. Zoom and pan to the Floor 1 level. 

27. Select the Floor 1 level line. In the Modify | Levels tab>Modify panel, click  (Copy).

28. In the Options Bar, verify Multiple is checked.

29. In the view, click Floor 1’s level line for the copy start point. For the second point, click 
below Floor 1 (the distance does not matter right now as you will set this in the next few 
steps).

30. Click again below the level you just placed to make two new levels below Floor 1.

31. Click  (Modify) to end the command.

32. Select the level below Floor 1. In Properties, in the Identity Data section, type Basement next 
to Name. In the Constraints section, set the Height to (negative) -10'-0". 

33. In Properties, click Apply, or move your cursor into the drawing area to apply the changes.

34. Rename the level below Basement to T.O. Footing and set the height to (negative) -12'-0", 
as shown in Figure 2–42. 

35. You can modify the levels for clarity by selecting the level and clicking the  (Add Elbow) 
control between the level name and height.

Figure 2–42
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36. In the View Control Bar, select  (Temporary Hide/Isolate) and select Reset Temporary 
Hide/Isolate.

37. Select the Floor 1 level line. Select  (Drag the extents of the level in the model) and drag 
the level over until it is far enough away from the linked model. The other levels will follow 
because of the alignment constraint.

38. Zoom out to display the entire project.

Note: Because the Basement and T.O. Footing were copies of Floor 1, you need to create 
a floor plan view. Note that these two views’ level heads are black as opposed to the rest 
of the levels that have views created.

39. In the View tab>Create panel, expand  (Plan Views) and select  (Floor Plan).

40. In the New Floor Plan dialog box, select Basement and T.O. Footing, as shown in 
Figure 2–43. (Hint: Use <Ctrl> to select the two levels.)

Figure 2–43

41. Click OK. The floor plan views now show in the Project Browser and the T.O. Footing view 
(or the last view to be created) becomes the active view. 

42. Create a new ceiling plan view. In the View tab>Create panel, expand  (Plan Views) and 

select  (Reflected Ceiling Plan).

43. In the New RCP dialog box, select Basement and click OK. 

44. Select the Floor 1 tab above the view window to make it the active view.

45. Close any open views by going to the Quick Access Toolbar and clicking  (Close Inactive 
Views).
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46. Open the Default 3D view. 

47. Because you hid the levels when linking in the models, you need to unhide them. In the View 

Control Bar, click (Reveal Hidden Elements).

48. Using your mouse wheel, zoom out so you can see the level lines.

49. Select one level and in the Modify | Levels tab>Reveal Hidden Elements panel, click 

(Unhide Category).

50. In the View Control Bar, click  (Close Reveal Hidden Elements).

51. In the Project Browser, select the Roof view in the Ceiling Plans section. Right-click and 
select Delete to delete the view.

52. Save and close the project.

End of practice
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2.6 Creating Grids
Grids are annotation elements that display in most views, including plan, ceiling, section, and 
elevation views. They help organize your design when developing a layout and describe the 
pattern and location for columns, as shown in Figure 2–44. Grids can be multi-segmented, arcs, 
or straight lines, and they can be hidden in the view if needed. 

Figure 2–44

Each line or arc in a grid is a separate entity and can be placed, moved, and modified 
individually. 

Grids cannot be drawn in a 3D view but grids can be displayed in a 3D view, perspective view, or 
in a 3D view with a selection box, and when you click on a grid, the surface contour displays. 

Note: If you are upgrading a model to the 2024 version, you will need to turn on the grids.

How To: Create a Grid

1. In the Architecture tab>Datum panel, click  (Grid), or type GR.

2. In the Properties Type Selector, select the grid type, which will control the size of the bubble 
and the linestyle.

3. In the Modify | Place Grid tab>Draw panel (shown in Figure 2–45), select the draw method 
you want to use. 

Figure 2–45

4. In the Options Bar, set the Offset if needed.
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5. Start drawing grid lines.

• Grids can be sketched at any angle, but you should ensure that all parallel grids are sketched 
in the same direction (e.g., from left to right or from bottom to top).

• When using the Multi-Segment tool (shown in Figure 2–46), sketch the line and click 

(Finish Edit Mode) to complete the command.

Figure 2–46

How To: Show Grids in 3D

1. Open a 3D or perspective view and press <Esc> twice to verify nothing is selected. 

2. In Properties, click Edit... next to Show Grids, as shown in Figure 2–47.

Figure 2–47
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3. In the Show Grids dialog box, select the level(s) that you want the grids to display at in the 
3D view, as shown in Figure 2–48.

Figure 2–48

4. Click OK.

5. (Optional) To display the grids on the bottom of a section box, in Properties, verify that 
Section Box is selected, and click Edit... next to Show Grids.

6. In the Show Grids dialog box, select only the Project Grids On Section Box option, as shown 
in Figure 2–49, and click OK.

Figure 2–49

Grid 
lines
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Modifying Grid Lines
Grid lines, like levels, are data elements. You can modify grid lines using controls, alignments, 
and temporary dimensions in the view (as shown in Figure 2–50). You can change the bubble 
type using the Type Selector.

Figure 2–50

• Grid numbers can be numbers, letters, or a combination of the two. To modify a grid number, 
double-click on the number in the bubble and type the new letter/number. You can also 
change the grid number by entering a new Name in Properties.

• Grid numbers increment automatically.

• In a 3D view, you can modify the grid line name and adjust the grid line and grid distance. 

• Click the  (Drag the extents of the grid in the model) control to lengthen the grid line. 

• Modify the temporary dimension (as shown in Figure 2–51) to change the grid line’s 
distance from another grid line.

Figure 2–51

• Change the grid line name by selecting the bubble and typing in a new name; 
alternatively, the name can be changed in Properties.

Add elbow

Plan view symbols end 1 and 2

Alignment 
line

Drag 
control

Temporary dimension

Temporary 
dimension
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• In the Type Properties dialog box, change the way the grid Plan View Symbols Ends 
display, as shown in Figure 2–52. The first pick point is plan view symbol end 1 and the 
second pick point is plan view symbol end 2.

Figure 2–52
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Hint: Propagating Datum Extents
If column grids do not display in a view, this might be due to adding a level after the grid lines 
were added. To display the grid lines in plan views, select the grid lines in a view in which 

they are displayed. In the Modify | Grids tab>Datum panel, click (Propagate Extents). In 
the Propagate datum extents dialog box (shown in Figure 2–53), select the views to project 
the grid lines to.

Figure 2–53

• This also works for levels.

• (Propagate Extents) is particularly useful to make grid lines display the same in all 
views.
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Practice 2c
Add Grids

Practice Objectives 

• Add and modify grid lines.

• Modify grid properties in a 3D view.

In this practice, you will place grid lines using the linked CAD model as a guide. You will then 
turn grid lines on in a 3D view.

1. Open the project Arch-Grids.rvt from the practice files folder.

2. From the Project Browser, open the Floor Plans: Floor 1 view.

3. Select the linked Revit file with the pool (Hotel-Pool.rvt). In the View Control Bar, expand 

(Temporary Hide/Isolate) and select Hide Element. 

4. In the Architecture tab>Datum panel, click  (Grid).

5. In the Modify | Place Grid tab>Draw panel, click  (Pick Lines).

6. Select grid line A from the linked DWG file to create a grid line in the Revit model.

7. Press <Esc> twice.

8. Zoom in to the new grid line. Click inside the bubble, type A, and press <Enter>.

Note: If you zoom in to the bubble and click on the number or letter, you can change the 
value without exiting the command.

9. Start the Grid command again and use Pick Lines to continue selecting the vertical grid 
lines displayed in the imported file. The letters automatically increment.

10. Click the first horizontal grid line, press <Esc> twice, and change the letter in the bubble 
to 1.

11. Start the Grid command again and use Pick Lines to continue selecting the horizontal grid 
lines. The numbers automatically increment.

12. Click  (Modify) to end the command.

13. Select the CAD file (Hotel-Level-1.dwg). In the View Control Bar, expand (Temporary 
Hide/Isolate) and select Hide Element. 
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14. Only the grids should now display, as shown in Figure 2–54. Check the lengths of all grid 
lines. Modify the length by dragging the ends if needed.

Figure 2–54

15. In the View Control Bar, select  (Temporary Hide/Isolate) and select Reset Temporary 
Hide/Isolate.

16. Open the default 3D view by selecting the tab at the top of the view. Note that you do not 
see the grids.

17. Click  (Modify).

18. In Properties, in the Graphics section, click Edit... next to Show Grids.

19. In the Show Grids dialog box, select Floor 1 and click OK.

20. The grids now display. Select the linked Revit file with the pool (Hotel-Pool.rvt). 
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21. In the View Control Bar, expand (Temporary Hide/Isolate) and select Hide Element to 
see the grids unobstructed as shown in Figure 2–55.

Figure 2–55

22. In the View Control Bar, select  (Temporary Hide/Isolate) and select Reset Temporary 
Hide/Isolate.

23. Save and close the project.

End of practice
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Chapter Review Questions
1. What type of view do you need to be in to add a level to your project?

a. Any non-plan view.

b. As this is done using a dialog box, the view does not matter.

c. Any view except for 3D.

d. Any section or elevation view.

 

2. How do you line up grid lines that might be different lengths, as shown in Figure 2–56?

Figure 2–56

a. Use  (Trim/Extend Multiple Elements) to line them up with a common reference line.

b. Select the grid line and use the drag control to line up with the other grid lines.

c. Select the grid line, right-click and select Auto-Align.

d. In Properties, change the Length and then use  (Move) to get them into position.

 

3. Grids can be displayed in a 3D view.

a. True

b. False

 

4. Which of the following types of CAD formats can you import into Revit? (Select all that 
apply.)

a. .DWG

b. .XLS

c. .SAT

d. .DGN 
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5. Imported CAD files cannot be reloaded in the Manage Links dialog box.

a. True

b. False

 

6. To modify linked CAD files, you need to open what dialog box?

a. Type Properties

b. Link CAD

c. Manage Links

d. Insert from File

 

7. When creating a new level, you have to change all corresponding views.

a. True

b. False

 

8. Where can you change a level’s name?

a. In the Options Bar.

b. Within the plan view and in the Options Bar.

c. In the Project Browser, in Properties, or in an elevation view by clicking on the level’s 
name.

d. You cannot change the name after the level has been placed in the view.

 

9. You can set the imported DWG to be in the foreground or background throughout the 
project’s life cycle. 

a. True

b. False
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Command Summary
Button Command Location

Grid • Ribbon: Architecture tab>Datum panel
• Shortcut: GR

Import CAD • Ribbon: Insert tab>Import panel

Import PDF • Ribbon: Insert tab>Import panel

Level • Ribbon: Architecture tab>Datum panel
• Shortcut: LL

Link CAD • Ribbon: Insert tab>Link panel

Link PDF • Ribbon: Insert tab>Link panel

Link Revit • Ribbon: Insert tab>Link panel

Multi-Segment (Grid) • Ribbon: Modify | Place Grid tab>Draw panel

Propagate Extents • Ribbon: Modify | Grids or Modify | Levels tab>Datum 
panel

Temporary Hide/Isolate • View Control Bar
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