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Chapter

7
Foundations 
Structural foundations are created using concrete walls, columns, and footings. Revit® includes 
standard tools for creating walls and columns in several different materials, as well as specific 
tools for adding footings.

Learning Objectives 

• Create walls that can be used in foundations.

• Add bearing and retaining wall footings under the walls.

• Create column types to be used as piers and pilasters.

• Place isolated footings under the columns.
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7.1 Modeling Walls
Walls in Revit are more than just two lines on a plan. They are full 3D elements that store 
detailed information, including height, thickness, and materials. This means they are useful in 
2D and 3D views. Structural walls (as shown in Figure 7–1) are bearing walls that can act as 
exterior, foundation, retaining, and shaft walls.

• Walls also impact material takeoff schedules. 

• Walls are a system family that is predefined in the Revit template file and cannot be loaded 
in from an external location or saved out to a external location. 

• Walls can be customized to suit your company needs, if necessary.

• To ensure that your walls are oriented correctly, it is best practice to draw your walls in a 
clockwise manner.

Figure 7–1

In a building, different types of walls serve different purposes. Structural walls are load-bearing, 
carrying the weight of the roof and floors and helping to support the building. Non-load-bearing 
walls do not support any weight and are mainly used to divide spaces inside. A face wall is the 
outer wall of a building, which closes off the space and may also be decorative. A finish wall is 
the layer added to the surface of a wall, like paint, tiles, wallpaper, or paneling, best used for 
presentations.

In Revit, there are three broad categories of walls: 

• Basic walls: Compound walls that contain one or more layers (e.g., blocks, air space, 
bricks, etc.). 

• Curtain walls: Walls that are divided horizontally and vertically into a grid system. 

• Stacked walls: Consist of two or more basic walls stacked vertically, such as a brick wall 
over a concrete wall.
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Wall Cross-Section
The Cross-Section for the basic wall category can be modified to be Vertical, Slanted, or 
Tapered, as shown in Figure 7–2.

Figure 7–2

Vertical Wall 
All walls are drawn by default as a vertical wall and are at a 0° vertical when comparing it to a 
slanted wall type. 

Note: If you change a wall’s cross-section to Tapered and adjust the settings for the 
tapered wall, then you will see only the Tapered wall types displayed in the Type Selector. 
If you need to draw a vertical or slanted wall after the tapered wall is drawn, you will need 
to set the cross-section back to Vertical or Slanted so that you can see all the wall types 
in the Type Selector.
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Slanted Wall 
You can draw a slanted wall type and specify the Angle From Vertical degree value in Properties. 
The slant degree needs to be within -90° to 90°. You can also change a vertically drawn wall to a 
slanted wall type. If there are any doors, door openings or window added to the wall, you will 
need to select those objects and, in Properties, specify their Orientation. The direction to which 
the wall has been drawn (right to left or left to right) will determine the direction the angle will go. 
Figure 7–3 shows that when drawing from left to right the wall slant will go in the negative 
direction, and drawing from right to left the slant wall goes in the positive direction.

Figure 7–3

• Slanted walls can be modified in a plan, 3D, section, and perspective views. 

• You can create a slanted wall with curved, circle, arc, polygon, or elliptical paths.

• If the angle is not going in the correct direction, + or -, you can add a (negative) - symbol in 
front of the degree value in Properties.

Tapered Wall
You can create a tapered wall from any wall type except walls with sweeps and reveals. You 
must first edit the structure of the wall to set the variable thickness for the available wall layers. 
If not, you are prompted to set this before drawing the wall, as shown in Figure 7–4. 

Figure 7–4

• To set the default angles of the tapered wall, you can set the Default Exterior and Interior 
Angle in the Type Properties dialog box.

- +

0°
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• If you have multiple instances of the same tapered wall type, you can select a tapered wall, 
and in Properties, override the angles by selecting the Override Type Properties option and 
also setting the Exterior Angle and Interior Angle, as shown in Figure 7–5.

Figure 7–5

• Curtain walls and stacked wall types cannot be tapered.

• If doors, door openings, or windows are placed in a tapered wall, you can specify the 
orientation of the door and wall.

Wall Display per View
You can alter the way a wall is displayed in the active view by setting the Detail Level, as shown 
in Figure 7–6. You can also override the visibility settings of all walls in a view by opening the 
Visibility/Graphic Overrides dialog box and modifying the Wall category. To change the way 
selected walls display in the active view, you would override the setting for graphics in view by 
element. To display the hatching in all walls in the active view where a wall is being cut through, 
in the View Control Bar, set the Detail Level to Medium or Fine, as shown in Figure 7–6.

Figure 7–6
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• To access the Visibility/Graphic Overrides dialog box to change all walls in a view, go to the 

View tab>Graphics panel and click (Visibility/Graphics), or type VG or VV. You can 
uncheck Non-Core Layers (as shown in Figure 7–7) to only view the core layer in the view. 
This overrides all walls in the view.

Figure 7–7

• To modify a single or a select few walls in the view, select the walls, right-click, and select 
Override Graphics in View>By Element, as shown in Figure 7–8.

Figure 7–8

How To: Model a Wall

1. In the Structure tab>Structure panel, click  (Wall: Structural), or type WA.

• Architectural walls (which are created with the Wall: Architectural command) are 
typically non-bearing walls, such as curtain walls and partitions. They do not display 
when the view Discipline is set to Structural.
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2. In the Type Selector, select a wall type, as shown in Figure 7–9. You can use the search box 
to quickly find specific types of walls.

Figure 7–9

3. In Properties, set the Cross-Section to Vertical, Slanted, or Tapered, depending on the wall 
you need to create, as shown in Figure 7–10. Specify the properties and type properties as 
needed. If this is not set at the beginning of drawing a wall, the last cross-section used will 
be the default.

• If you set the Cross-Section to Slanted, you are able to set the Angle From Vertical 
degree, as shown in Figure 7–10. 

Figure 7–10

Search
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• If you set the Cross-Section to Tapered, you will get a warning about the wall type. You must 
first edit the structure of the wall before setting the Cross-Section to Tapered.

a. With the wall type selected, click Edit Type in Properties.

b. Click Edit... next to Structure. 

c. In the Edit Assembly dialog box, select the option in the Variable column (as shown in 
Figure 7–11) for the layer that you want tapered.

Figure 7–11

d. Click OK.
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e. In the Type Properties dialog box, you will now have the ability to set the Cross Section 
Properties, as shown in Figure 7–12.

Figure 7–12

4. In the Options Bar (shown in Figure 7–13), specify the following information about the wall 
before you start modeling:

Figure 7–13

• Height: Set the height of a wall to either Unconnected (with a specified height) or to a 
level.

• Location Line: Set the justification of the wall using the options shown above in 
Figure 7–13.

• Chain: Enables you to model multiple connected walls.

• Offset: Enables you to enter the distance at which a new wall is created from an existing 
element.

• Radius: Adds a curve of a specified radius to connected walls as you model.

• Join Status: Allow or Disallow automatic wall joins.
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5. In the Modify | Place Wall tab>Draw panel (shown in Figure 7–14), select one of the options 
to create the wall.

Figure 7–14

• Use alignment lines, temporary dimensions, and snaps to place the walls.

• As you are sketching, you can press <Spacebar> to flip the orientation of compound 
walls.

• When using the Chain option, press <Esc> once to finish the string of walls and remain in 
the Wall command or press <Esc> twice to get out of the Wall command completely. 
Hint: <Esc> works similarly on other commands.
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7.2 Modifying Walls
There are several methods of modifying walls. You can change the type of wall using the Type 
Selector, modify the Properties, use controls and shape handles to modify the length and wall 
orientation, and use temporary and permanent dimensions to change the location or length of a 
wall in 2D and 3D views, as shown in Figure 7–15. Additional tools enable you to modify wall 
joins, edit the profile of a wall, and add wall openings.

Figure 7–15

Drag wall end

Temporary dimensions

Change wall’s 
orientation

Shape handle

Temporary dimensions

Drag 
wall end

Type Selector

Properties

Type Selector
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Modifying Slanted and Tapered Walls 
Modifying a slanted or tapered wall is similar to modifying a vertical wall type with the 
exception of modifying the angle. 

• When modifying a slanted wall type, you have the ability to modify the Drag Wall Slant grip or 
modify the temporary dimension in a 3D, section, elevation, or isometric view, as shown in 
Figure 7–16.

Figure 7–16

• When modifying a tapered wall, you have the ability to modify the Drag Wall Exterior Face 
Slant and Drag Wall Interior Face Slant grips or modify the temporary dimension in a 3D, 
section, elevation, or isometric view, as shown in Figure 7–17.

Temporary dimension

Drag Wall Slant grip
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Figure 7–17

• You can set the wall’s structural properties as Non-bearing, Bearing, Shear, or Structural 
combined, as shown in Figure 7–18.

Figure 7–18

Temporary 
dimension

Drag Wall 
Slant grips
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Wall Joins
The software automatically joins walls with common materials when they come together at an 
intersection, as shown on the left in Figure 7–19. However, there are times when you do not 
want the walls to clean up, such as when one fire-rated wall butts into another, or when a wall 
touches a column surround, as shown on the right in Figure 7–19.

Figure 7–19

• While you are creating walls, change the Join Status to Disallow in the Options Bar, as 
shown in Figure 7–20.

Figure 7–20

• If a wall is already placed, select the wall and right-click on the Drag Wall End control at the 
end of the wall and select Disallow Join, as shown on the left in Figure 7–21. Once the end 
is not joined, you can drag it to the appropriate location, as shown on the right in 
Figure 7–21.

Figure 7–21

• To rejoin the walls, right-click on the end control and select Allow Join. Manually drag the 
wall back to where you want it to touch the target wall.

Wall joined Wall not joined

After: Walls not joined

Drag Wall End control

Before: Walls join automatically
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If you select a wall, you can change the Allow Join/Disallow Join option by clicking on the icon 

that displays next to the wall’s end, as shown in Figure 7–22. Click  (Allow Join) to join the 

walls together or click  (Disallow Join) to unjoin them.

Figure 7–22

Editing Wall Joins
Use Wall Joins to modify the configuration of the intersections, as shown in Figure 7–23. Do 
not use this command if you have complex wall joins; instead, modify the length of the wall in 
relation to the adjoining walls.

Figure 7–23

How To: Modify the Configuration of a Wall Join

1. In the Modify tab>Geometry panel, click  (Wall Joins). 

2. Click on the wall join that you want to edit. There is a square box around the join. Hold 
<Ctrl> to select multiple joins.

3. In the Modify | Wall Joins tab>Configuration panel, select the required configuration and 
display options, as shown in Figure 7–24.

Figure 7–24

Not mitered Mitered
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• Select from three configurations:  (Butt),  (Miter), or  (Square Off), as shown in 
Figure 7–25. 

Figure 7–25

• Click  (Previous) and  (Next) to toggle the butt or squared-off corner 
configurations through the various intersection options.

How To: Modify Display Options of Wall Joins

1. In the Modify tab>Geometry panel, click  (Wall Joins). 

2. Click on the wall join that you want to edit. To modify multiple joins at the same time, draw 
a window around several wall intersections (as shown in Figure 7–26), or hold <Ctrl> and 
pick additional intersections. A square box displays around each join.

Figure 7–26

3. In the Modify | Wall Joins tab>Display panel, expand  (Display). This controls whether or 
not wall joins are displayed. The options are Use View Setting (set up in View Properties), 
Clean Join, and Don’t Clean Join, as shown in Figure 7–27.

Figure 7–27
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4. With any Display options selected, you can click  (Allow Join) or  (Disallow Join) in the 
Modify | Wall Joins tab>Display panel (shown previously in Figure 7–27). When you select 
one of these two options, the contextual tab options gray out. To bring back your options, 
click the wall’s corner again.

Editing Wall Profiles
Walls often follow the contours of a site or an angle, such as following a line of stairs, as shown 
in Figure 7–28. If needed, you can edit the profile of a wall.

 

Figure 7–28

How To: Edit the Profile of a Wall

1. Open an elevation or section view in which you can see the face of the wall that you want 
to edit.

2. Select the wall (by highlighting the wall boundary). You can also double-click on a wall to 
edit the profile.

• You cannot edit the profile of a tapered wall.

3. In the Modify | Walls tab>Model panel, click  (Edit Profile). The wall is outlined in 
magenta, indicating the profile of the wall.
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4. In the Modify | Walls>Edit Profile tab>Draw panel, use the tools to modify the profile sketch 
of the wall, as shown on the top in Figure 7–29.

Note: The sketch must form a continuous loop. Verify that the lines are clean without any 
gaps or overlaps. Use any of the tools in the Modify panel to clean up the sketch.

5. Once the profile is complete, click  (Finish Edit Mode). The wall now follows the new 
profile, as shown on the bottom in Figure 7–29.

Figure 7–29

• After you adjust the sketch, you can add isolated footings to create the appropriate shape.

Editing Wall Layer Elevations
Individual layers of walls can have their height modified to better control elevations of finishes, 
such as brick veneer extending to a foundation (as shown in Figure 7–30), while the other 
layers rest on the floor slab.

Figure 7–30

Modified sketch

Finished wall

Brick finish layer

Other wall layer



Foundations

© 2025 ASCENT - Center for Technical Knowledge 7–19

How To: Edit Wall Layers

1. In any view, select a wall. In Properties, click Edit Type.

2. In the Type Properties dialog box, click the Edit... button next to Structure in the 
Construction section.

3. In the Edit Assembly dialog box, click the <<Preview button to expand the preview window, 
as shown in Figure 7–31.

Figure 7–31

4. Set the View to Section: Modify type attributes, as shown in Figure 7–32.

Figure 7–32

Click to expand the 
preview window
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5. In the preview window, zoom in to the bottom edge of the wall, as shown in Figure 7–33, and 
in the Modify Vertical Structure area, click Modify. The brick layer will turn from blue to red.

Figure 7–33

Note: If doing this to multiple layers in a wall, all the layers must be adjacent to each other.

6. Click on the outer boundary at the bottom of the brick layer, as shown on the right in 
Figure 7–34. A lock will display, as shown on the left in Figure 7–34.

Figure 7–34

7. Click the lock to make the brick layer or region extendable. 

Note: Make sure the lock displayed shows as unlocked, as shown in Figure 7–35, before 
you proceed. 

Figure 7–35
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8. Click OK twice.

9. In a section view, you can select the wall and use the grips to extend the brick layer, as 
shown in Figure 7–36.

Figure 7–36

• An alternative option for adjusting the extension is in the instance properties of the wall. Set 
the Base Extension Distance to adjust unlocked layers, as shown in Figure 7–37.

Figure 7–37

• If the layers were unlocked at the top instead of the bottom, you would be able to adjust the 
top extension distance in Properties or by dragging grips in a section view.
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Wall Openings
You can add openings in walls that are not windows or doors by using the Wall Opening tool. 
This creates rectangular openings for both straight and curved walls, as shown in Figure 7–38.

Figure 7–38

How To: Add Wall Openings

1. Open a plan, elevation, section, or 3D view. 

2. In the Architecture tab>Openings panel, click  (Wall Opening).

3. Select the wall.

4. Pick two points on the diagonal to determine the opening size, if in elevation, section, or 3D 
view. If you are in plan, you need to pick the start and stop points for the wall opening.

• You can use temporary dimensions to size the opening while in the command and both 
temporary dimensions and shape handles to modify the opening when it is selected, as 
shown in Figure 7–39.

Figure 7–39

Shape handles
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Hint: Matching Properties
You can select an existing wall and use it to assign the wall type and instance properties to 
other walls by using the Match Type command. This command also works with all elements 
that have types. 

1. In the Modify tab>Clipboard panel, click  (Match Type), or type MA. The cursor 
changes to an arrow with a clean paintbrush.

2. Select the source element that you want all of the others to match. The paintbrush 
changes to look as if it has been dipped in black paint, as shown in Figure 7–40.

Figure 7–40

3. To select more than one element, in the Modify | Match Type tab>Multiple panel, click 

(Select Multiple). You can then use windows, crossings, <Ctrl>, and <Shift> to create 
a selection set of elements to change.

4. Click  (Finish) to apply the type to the selection.

• Click in an empty space in the view to empty the brush so that you can repeat the 
command with a different element.

• Elements to be matched must be of the same type (e.g., all walls, all doors, etc.).

5. Click  (Modify) to end the command.
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7.3 Adding Wall Footings
Footings are appended to the bottom of a wall, which means that any change to the base of the 
host wall influences the footing. This occurs for lateral movement and horizontal movement. 
For the example shown in Figure 7–41, when the wall profile changes based on a sloped site 
(as shown on the left), the footing breaks and follows the modified profile (as shown on the 
right). This is accomplished by editing the profile of the foundation wall.

Figure 7–41

• Once a footing is in place, you can add reinforcement in a section view, as shown in 
Figure 7–42. With the advantages of having a true foundation in place, you can accurately 
tag and schedule the footings.

Figure 7–42

• You can edit a footing’s profile the same way you would edit a wall profile.

Wall profile in process Completed wall with footing
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• You can apply two types of continuous footing systems, as shown in Figure 7–43. You must 
have walls in your model to add a footing system.

• Retaining footings: A footing with one side offset to accommodate additional lateral 
loads and reinforcement. 

• Bearing footings: A footing with an equal distance on either side of the bearing wall.

Figure 7–43

How To: Place a Bearing or Retaining Footing

1. Create or use existing walls in a 3D, section, or elevation view. 

• A wall must be in place to add a bearing or retaining footing.

2. Open a foundation plan and set it up so that the walls are displayed and you can select 
them.

3. In the Structure tab>Foundation panel, click  (Structural Foundation: Wall) to start the 
Structural Foundations: Wall command, or type FT.

4. In the Type Selector, select a type, as shown in Figure 7–44.

Figure 7–44

Retaining footing Bearing footing
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5. Select a wall. The footing is placed beneath the wall, as shown in Figure 7–45.

Figure 7–45

• To select multiple walls, hover over one wall and then press <Tab> to select all 
connected walls. Alternatively, in the Modify | Place Wall Foundation tab>Multiple panel, 

click  (Select Multiple). Select the walls using any selection method and click 

(Finish) to place the footings.

• You can flip retaining footings using the Flip control, as shown in Figure 7–46.

Figure 7–46

Wall Footing

Footing
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Hint: Materials
When you are creating some types, such a wall footings, one option is to set the Structural 
Material. In the Type Properties dialog box, in the Materials and Finishes section, click in the 

Value column and then click  (Browse), as shown in Figure 7–47.

Figure 7–47

In the Material Browser (shown in Figure 7–48), specify the material you want to use and 
click OK.

Figure 7–48
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Practice 7a
Model Walls and Wall Footings

Practice Objectives 

• Place structural walls.

• Create and apply wall footings.

In this practice, you will model the perimeter foundation walls as well as the elevator and 
stairwell walls, as shown in Figure 7–49. (Grids have been turned off in the image for clarity.)

Figure 7–49

Task 1:  Add foundation walls.

1. Open Structural-Walls.rvt from the practice files folder. The default {3D} view displays.

2. Open the Structural Plan: 00 GROUND FLOOR view. (The green lines are the outline of the 
building.)

3. In the Structure tab>Structure panel, click  (Wall: Structural).

4. In the Type Selector, select Basic Wall: Exterior - 8" Concrete.

5. In the Options Bar, set the Depth to 00 T.O. FOOTING and ensure that the Location Line is 
set to Wall Centerline and that Chain is checked. 
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6. In the Modify | Place Structural Wall tab>Draw panel, click (Line).

7. Select the start point by snapping to the G1 grid intersection, as shown in Figure 7–50.

Figure 7–50

8. Draw the wall up to the E1 grid intersection.

9. In the Draw panel, click  (Start-End-Radius Arc). Select the second point at the C1 grid 
intersection and then the third point at the D2 grid intersection at the midpoint of the 
column to specify the radius of the arc, as shown in Figure 7–51.

Figure 7–51
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10. Click  (Line) again and select the B1 grid intersection.

11. Following the green outline, continue drawing walls all the way around the perimeter, as 
shown in Figure 7–52.

Figure 7–52

12. Click (Modify).

13. Save the project.

Task 2:  Apply foundation wall footings.

1. Open the Structural Plans: 000 FOUNDATION PLAN view.

2. In the Structure tab>Foundation panel, click  (Structural Foundation: Wall), or type FT.

3. In the Type Selector, select the Wall Foundation: Bearing Footing - 24" x 12".

4. Hover the cursor over one of the existing walls and press <Tab> to highlight the entire wall 
system. Click to select the walls. The footing is placed under the entire structure.

• If you do not see the new wall foundation elements, you might be in the wrong view 
where they are not visible. Open the Structural Plans: 000 FOUNDATION PLAN view.

5. Click (Modify). 
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6. In the Quick Access Toolbar, click  (Default 3D View) to activate the {3D} view. Verify 
that the footing is placed correctly, as shown in part in Figure 7–53. Change the visual style 
as needed.

Figure 7–53

7. Save the project.

Task 3:  Create walls for the elevators and the stairwell.

In this task, you will draw walls for two elevator shafts and a stairwell using reference lines to 
lay out their positions within the building.

1. Open the Structural Plan: 00 T.O. FOOTING view. 

2. Zoom in to the C9 and B10 grid intersections in the upper-right corner. 

3. In the Structure tab>Work Plane panel, click  (Reference Plane). 

4. In the Modify | Place Reference Plane tab>Draw panel, click  (Pick Line).

5. In the Options Bar, set the Offset to 9'-2 1/4" .
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6. Hover your cursor over the foundation wall (not the bearing footing) along grid line B. When 
the preview line is on the inside of the wall, click to place the reference plane. Repeat this 
for the wall along grid line 10, as shown in Figure 7–54. (The dimensions in the image are 
for reference only.)

Figure 7–54

7. Repeat the process, but this time change the Offset in the Options Bar to 20'-1 7/8" .

8. Click (Modify). 

9. In the Structure tab>Structure panel, click  (Wall: Structural).

10. In the Type Selector, select Basic Wall: Generic - 12" Masonry.

11. In the Options Bar, change Depth to Height and set it to TOS-14 ROOF, then set the Location 
Line to Finish Face: Exterior. 

12. In the Modify | Place Structural Wall tab>Draw panel, click (Rectangle).
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13. Draw the walls using the reference planes as a guide, as shown in Figure 7–55.

Figure 7–55

14. Click (Modify). 

15. Open the {3D} view to see the walls.

16. Return to the 00 T.O. FOOTING view, then select the reference planes and press <Delete>.
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17. Zoom in to the E9 and G10 grid intersections.

18. Start the Reference Plane command and use the following offsets to draw reference 
planes from the foundation walls shown in Figure 7–56: 

• 15'-10 3/4" from the foundation wall on grid line G

• 26'-10 3/8" from the foundation wall on grid line G

• 9'-2 1/4" from the foundation wall on grid line 10

• 20'-1 7/8" from the foundation wall on grid line 10

19. Draw the elevator walls using the reference planes as a guide with the same settings used 
previously.

20. Delete the reference planes.

Figure 7–56

21. Click (Modify). 

22. Select a bearing footing along the exterior wall in the view. In the View Control Bar, expand 
 (Temporary Hide/Isolate) and select Hide Category. 

23. Select grid line 9.1 and in the View Control Bar, expand  (Temporary Hide/Isolate) and 
select Hide Element.
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24. Draw reference planes with the following offsets, as shown in Figure 7–57. Extend the 
reference lines so they intersect.

• 0'-6 3/8" from the foundation wall on grid line G

• 11'-10 5/8" from the foundation wall on grid line G

• 0'-6 3/8" from the foundation wall on grid line 10 

• 27'-11 1/4" from the foundation wall on grid line 10

Figure 7–57

25. Draw walls using the reference planes, similar to the elevator shafts above.

26. Click (Modify). 

27. Delete the reference planes. In the View Control Bar, expand  (Temporary Hide/Isolate) 
and select Reset Temporary Hide/Isolate.

28. If time permits, open the 000 FOUNDATION PLAN view, start the Structural Foundation : 
Wall command, and add Wall Foundation: Bearing Footing - 24" x 12" to the stairwell walls.

29. Save and close the project.

End of practice
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7.4 Adding Isolated Footings
Footings for columns (shown in Figure 7–58) are placed using the Structural Foundation: 
Isolated command. When you select a column, the footing automatically attaches to the 
bottom of the column. This is true even when the bottom of the column is on a lower level than 
the view you are working in.

Figure 7–58

How To: Place an Isolated Footing

1. Open a plan view, such as a top of footing structural floor plan.

2. In the Structure tab>Foundation panel, click  (Isolated) to start the Structural Foundation: 
Isolated command.

3. In the Type Selector, select a footing type.

4. In Properties, set the Level and any other parameters.

Isolated footing
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5. In the view, click to place the individual footing, as shown in Figure 7–59.

• If needed, press <Spacebar> to rotate the isolated footings after they are placed.

Figure 7–59

• To add more than one footing at a time, in the Modify | Place Isolated Foundation tab> 

Multiple panel, select  (At Grids) or  (At Columns) and select the grids or columns.

• If needed, press <Spacebar> to rotate the isolated footings after they are placed.

• If the material of the wall footing and the material of the isolated footing are the same, they 
automatically join, as shown in Figure 7–60.

Figure 7–60

Isolated footing

Wall footing
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Working with Custom Families
Sometimes you need to work with a custom family that has parameters that you can 
manipulate to fit a specific situation. For example, to add the step footings shown in 
Figure 7–62, you need to insert an angled isolated footing and modify it to fit the exact size and 
location.

Figure 7–62

Hint: Foundation Element Properties
Some of the element properties are automatically generated from the location and size of 
the element in the model and are grayed out, for example Host, Elevation at Top, and 
Elevation at Bottom as shown in Figure 7–61. These can be used in tags and schedules.

Figure 7–61
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How To: Load, Insert, and Modify a Custom Footing

1. Open a plan view.

2. In the Structure tab>Foundation panel, click  (Isolated).

3. In the Modify | Place Isolated Foundation tab>Mode panel, click  (Load Family).

4. In the Load Family dialog box, find the structural foundation family that you want to use and 
click Open.

5. Place the footing in the plan view. It might not be in the right place, but you can modify it in 
a section or elevation view.

6. Open an elevation or section view.

7. Move the footing to the correct location. As long as it is in line with another footing, it 
automatically cleans up, as shown in Figure 7–63.

Figure 7–63

• Use  (Align) to align the isolated footing with the footing already in the model. When it is 
aligned, select the lock, as shown in Figure 7–64. This ensures that if the elevation of the 
footing wall changes, the step footing will also adjust appropriately.

Figure 7–64

Isolated footing
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• Some custom families have sizing options in either Properties (per instance) or in the Type 
Properties dialog box (as shown in Figure 7–65) so that you can create additional types in 
various sizes as needed in the project.

Figure 7–65
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Practice 7b
Add Isolated Footings

Practice Objectives 

• Place isolated footings.

• Modify a wall profile and add stepped footings.

In this practice, you will place isolated footings, as shown in Figure 7–66. You will also create a 
series of stepped footings by modifying a wall profile and adding custom footings. (The 
stairwell and elevator walls are hidden in this practice’s images for clarity.)

Figure 7–66

Task 1:  Place isolated footings.

1. Open Structural-Footings.rvt from the practice files folder.

2. Open the Structural Plans: 00 T.O. FOOTING view.

3. In the Structure tab>Foundation panel, click  (Isolated).

4. In Properties, select one of the Footing Rectangular Foundations and click  (Edit Type).

5. In the Type Properties dialog box, click Duplicate... and name it 36"x36"x12".

6. Set the values for the following parameters:

• Foundation Thickness: 1'-0"

• Width: 3'-0"

• Length: 3'-0"

Isolated 
footings
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7. Click OK.

8. Zoom in to the column at the B1 grid intersection and place the isolated footing. The 
isolated footing and wall footing automatically join together, as shown in Figure 7–67.

Figure 7–67

9. In the Modify | Place Isolated Foundation tab>Multiple panel, click  (At Columns). Use a 

selection window to select all of the columns and click  (Finish).

10. Reopen the default 3D view. 

11. There should be an isolated footing under each pier and pilaster, as shown in Figure 7–68.

Note: The steel columns were hidden in this figure for clarity.

Figure 7–68

12. Save the project.

Before After

You will create a 
stepped footing on this 
wall in the next task
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Task 2:  Modify the profile of a wall and add stepped footings.

1. Open the Elevations (Building Elevation): North view.

2. Zoom in on the left end of the foundation wall and select the wall located between grid lines 
10 and 9, as shown in Figure 7–69. 

Figure 7–69

3. In the Modify | Walls tab>Mode panel, click  (Edit Profile).

4. Select any magenta line to select the wall. Click on the lock at the bottom of the wall to 
unlock it, as shown in Figure 7–70.

Figure 7–70
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5. Using the dimensions shown in Figure 7–71, modify the wall’s profile. (The dimensions 
shown in the figure are for information only.)

6. Select the bottom magenta sketch line and drag it down to 23'-0" to add the additional 8'-0".

• If a warning that cannot be ignored displays, click Remove Constraints to continue 
editing the wall’s profile.

7. With the line still selected, click on the rightmost grip and drag the line to the left so it is only 
7'-6" long.

8. In the Modify | Walls>Edit Profile tab>Draw panel, use the draw tools to sketch the rest of 
the stepped wall. In the Modify panel, use the Trim/Extents to Corner tool to clean up any 
line work.

Figure 7–71

Wall profile

00 T.O. Footing 
level
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9. Click  (Finish Edit Mode). The wall profile is modified along with the footings, as shown 
in Figure 7–72.

Figure 7–72

10. Open the Structural Plans: 00 T.O. FOOTING view and zoom in on the upper-right corner 
between grid intersections B9 and B10 to see lines that show the steps of the wall’s 
footing.

11. In the Structure tab>Model panel, click  (Place a Component), or type CM.

12. In the Type Selector, select Angled-Footing: 24" x 24" x 36".

13. Place three footings along the wall, similar to those shown in Figure 7–73. Do not worry 
about the exact location; you will modify their position in the next steps.

Figure 7–73

14. Click  (Modify).

Wall

Footings
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15. Return to the North elevation view. The three angled footings are still on the level where 
they were placed, as shown in Figure 7–74 (your angled footings’ positions may differ from 
those shown in the image).

 

Figure 7–74

16. In the Modify tab>Modify panel, click  (Align), or type AL. Verify in the Modify | Align 
tab>Align panel that Multiple Alignment and Lock are unchecked.

17. Starting with the leftmost angled footing, first click the edge of the wall, then click the left 
edge of the angled footing, as shown on the left in Figure 7–75. Hint: You may need to use 
<Tab> to cycle through edges.

18. Still in the Align command, click the bottom of the wall footing, then the top of the angled 
footing, as shown on the left in Figure 7–75. 

19. The angled footing joins to the wall footing, as shown on the right in Figure 7–75. 

Figure 7–75

20. Continue aligning the rest of the angled footings to the wall footings.

First align clicks

Second align 
clicks

Before After
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21. View the new footings in 3D, as shown in Figure 7–76.

Figure 7–76

22. (Optional) Modify the nearby wall, columns, and footings to match up with the new stepped 
footings.

23. Save and close the project.

End of practice
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Chapter Review Questions
1. Which of the following are ways that you can sketch walls in a project? (Select all that 

apply.)

a. Line

b. Pick Lines

c. Insert Lines

d. Pick Faces

 

2. Which command do you use to insert a pier or a pilaster such as those shown in 
Figure 7–77?

Figure 7–77

a. Structural Foundation

b. Isolated Foundation

c. Structural Column

d. Isolated Column

 

3. The  (Structural Foundation: Wall) command requires a host wall to already be in place.

a. True

b. False
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4. Some walls are made from multiple layers of materials, such as brick, block, and drywall, as 
shown on the bottom in Figure 7–78. If the hatching for these materials is not displayed (as 
shown at the top in Figure 7–78), how do you change this?

Figure 7–78

a. Set the Visual Style to Realistic.

b. Set the Detail Level to Medium.

c. Set the View Scale to be higher.

d. Set the Phase to New.

 

5. Which command do you use to add a custom footing type under a wall such as the ones 
shown in Figure 7–79?

Figure 7–79

a. Place a Component

b. Structural Foundation: Isolated

c. Structural Foundation: Wall

d. Component: Structural Foundation
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6. Which of the following are potential differences between the column surround wall and the 
associated walls, as shown in Figure 7–80? (Select all that apply.)

Figure 7–80

a. The column surround and wall on the left are made with the same wall type, while the 
wall type on the right is a different wall type.

b. The wall on the left has been joined together with the column surround, while the wall on 
the right was set to Disallow Join.

c. The wall on the left was trimmed against the column surround.

d. The wall on the right was extended to the column surround.

 

7. Which of the following would be true if you changed the top constraint of one wall from an 
unconnected height to a level?

a. All walls of that type would also change height.

b. Only that wall would change height.

c. You cannot change just one walls height.
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Command Summary
Button Command Location

Detail Level: Coarse • View Control Bar

Detail Level: Fine • View Control Bar

Detail Level: Medium • View Control Bar

Edit Profile • Ribbon: (when a wall is selected) Modify | Walls tab> 
Mode panel

Isolated • Ribbon: Structure tab>Foundation panel

Match Type • Ribbon: Modify tab>Clipboard panel
• Shortcut: MA

Properties • Ribbon: Modify tab>Properties panel
• Shortcut: PP

Structural Foundation: 
Wall

• Ribbon: Structure tab>Foundation panel

N/A Type Selector • Properties
• Ribbon: Modify tab (Optional)
• Quick Access Toolbar (Optional)

Wall • Ribbon: Architecture tab>Build panel

Wall Opening • Ribbon: Architecture tab>Opening panel

Wall: Structural • Ribbon: Structure tab>Structure panel
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