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Chapter

2
Starting a Revit Project
Starting a Revit project begins by using a template. You can then link in a CAD file or an existing 
Revit model, if these are available. From there, you can add the framework for a design, 
including levels to define vertical heights and grids to help define the Revit elements’ layout.

Learning Objectives 

• Select and open a project template.

• Link and import CAD files to be used as a basis for developing a design.

• Link existing Revit models to develop and coordinate with other disciplines.

• Add and modify levels to define floor-to-floor heights and other vertical references.

• Add and modify grids to provide locations for model elements.



Autodesk Revit 2026: Fundamentals for MEP

2–2 © 2025 ASCENT - Center for Technical Knowledge

2.1 Selecting a Project Template
New projects are based on a project template file. The template file includes preset levels, 
views, and some families, such as wall styles and text styles. When using templates, most of 
the views are set to display only the elements specific to the template, so it is best practice to 
select a template that reflects your company’s discipline.

• Check with your BIM manager about which template you need to use for your projects. Your 
company might have more than one based on the type of project you are designing. Ideally, 
you should not start your work inside of another discipline or model. Instead, you should start 
from one of the default Revit templates or your company’s custom template and link the 
architectural model into your project. 

If you link a Revit model into your project, you can use the monitoring and coordinating features 
to copy/monitor necessary items, such as walls, floors, and grids, from the architect. To learn 
more about copying/monitoring, see ASCENT’s Autodesk Revit: Collaboration Tools guide.

How To: Start a New Project

1. Click New from the Home screen. Alternatively, in the File tab, expand  (New) and click 

(Project), as shown in Figure 2–1, or press <Ctrl>+<N>.

Figure 2–1

2. In the New Project dialog box (shown in Figure 2–2), select the template that you want to 
use and click OK.

Note: The list of template files is set in the Options dialog box in the File Locations tab. It 
might vary depending on the installed product and company standards.

Figure 2–2
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Recommended Project Setup
A multidiscipline approach to design and data sharing is the recommended best practice for all 
Revit projects. It allows multiple teams to create and work on their own trade-specific designs 
and then easily share the models with other teams so they can consolidate all design data into 
one host model by linking in other disciplines, as illustrated in Figure 2–3. 

Figure 2–3

Hint: Revit Worksharing
If established by your company that worksharing is needed, you would typically want to start 
a worksharing project on your local network once a project has been created.

• For more information on worksharing, see A.8 Introduction to Revit Worksharing in 
Appendix A Additional Tools for Design Development.

• For more information about establishing and using worksets, refer to ASCENT’s 
Autodesk Revit: Collaboration Tools guide.
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In Revit, models from different disciplines (such as architectural, mechanical, electrical, 
plumbing, and structural) can be linked together into one project. For example, mechanical and 
structural models can be linked into an architectural model, allowing teams to coordinate 
designs while maintaining separate project files.

Once saved, the links are part of the current project, and if any of the linked files are modified, 
the updated projects can be reloaded. Alternatively, each time a project is opened, it 
automatically loads the latest version of the linked projects. All links can be managed using the 

Manage Links dialog box, as shown in Figure 2–4. To open it, click (Manage Links) in the 
Insert tab>Link panel or in the Manage tab>Manage Projects panel. 

Figure 2–4
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2.2 Linking and Importing CAD Files
CAD files can be imported or linked into a Revit project. As an example, a designer might lay out 
a floor plan using the standard 2D AutoCAD software, and you then need to incorporate that 
information into your structural model. In addition, many renovation projects start with existing 
2D drawings. Instead of redrawing from scratch, link or import the CAD file (as shown in 
Figure 2–5) and trace over it in Revit. You can also print a hybrid drawing that is part Revit 
project and part imported/linked drawing.

Note: When you hover over an imported or linked CAD file, you can see in the tooltip that it 
is called an Import Symbol.

Figure 2–5

• CAD file formats that can be imported or linked include AutoCAD® (DWG and DXF), 
FormIt (AXM), 3D ACIS modeling kernel (SAT), MicroStation (DGN), 3D Shape (OBJ, STL, 
STEP, STP, and STPZ), Rhino (3dm), and Trimble SketchUp (SKP). 

• When linking or importing a CAD file, you can specify a level or a named horizontal reference 
plane in the project to position the CAD file at.

• You can specify the linking or import units (e.g., feet, meter, or US survey feet).
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Linking vs. Importing
• Link: A connection is maintained with the original file and the link updates if the original file 

is updated. Within the Manage Links dialog box (as shown in Figure 2–6), you can manually 
Reload the linked CAD file if updates occur. There are also options to Unload, Remove, or 
Import. 

Figure 2–6

• Import: No connection is maintained with the original file. It becomes a separate element in 
the Revit model. Within the Manage Links dialog box, you only have the option to Remove 
the imported CAD file, as shown in Figure 2–7.

Figure 2–7

How To: Link or Import a CAD File

1. Open the view into which you want to link or import the file.

• For a 2D file, this should be a 2D view. For a 3D file, open a 3D view.

2. In the Insert tab>Link panel, click  (Link CAD), or in the Insert tab>Import panel, click 

(Import CAD).



Starting a Revit Project

© 2025 ASCENT - Center for Technical Knowledge 2–7

3. In the Link CAD Formats (shown in Figure 2–8) or Import CAD Formats dialog box, select the 
file that you want to import.

• Select a file format in the Files of type: drop-down list to limit the files that are displayed.

Note: The dialog boxes for Link CAD Formats and Import CAD Formats are the same.

Figure 2–8

4. If Current view only is selected, as shown in Figure 2–9, you can set all options except the 
Place at and the Orient to View options. The view will only display in the current view.

Figure 2–9
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5. If you would like to place the CAD file at a level or reference plane, verify Current view only 
is unchecked and set the Place at option, as shown in Figure 2–10. Click Open.

Figure 2–10

Link and Import Options
Current view only Determine whether the CAD file is placed in every view, or only in the current 

view. This is especially useful if you are working with a 2D floor plan that you 
only need to have in one view.

Colors Specify the color settings. Typical Revit projects are mainly black and white. 
However, other software frequently uses color. You can Invert the original 
colors, Preserve them, or change everything to Black and White.

Layers/Levels Indicates which CAD layers are going to be brought into the model. Select 
how you want layers to be imported: All, Visible, or Specify....

Import units Select the units of the original file, as required. Auto-Detect works in most 
cases.

Correct lines... If lines in a CAD file are off axis by less than 0.1 degree, selecting this option 
straightens them. It is selected by default.

Positioning Specify how you want the imported file to be positioned in the current project:

The last option used will be the default position.

Place at Select a level or named reference plane at which to place the imported file. If 
you selected Current view only, this option is grayed out.

Orient to View Used to orient the CAD file on import/link.

Linking optionImport option
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• When a file is positioned Auto - Origin to Internal Origin, it is pinned in place and cannot be 
moved. To move the file, click on the pin to unpin it, as shown in Figure 2–11.

Figure 2–11
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2.3 Modifying Imported/Linked CAD Files
An imported/linked CAD file is called an import symbol once it is inserted into a project, as 
shown in Figure 2–12. When you select an imported/linked file, you can modify it by arranging 
the Foreground/Background status, modifying its type properties, querying information about 
elements in the file, and deleting layers. You can also modify the visibility/graphic overrides of 
each imported/linked file instance.

Figure 2–12

Arrange Linked/Imported CAD Files
CAD files that are linked or imported using the Current view only setting have the option to set 
the file to display in the foreground or background.

• Select the CAD file in the view and in Properties, expand Draw Layer (as shown on the left in 
Figure 2–13) and select either Foreground or Background.

• In the contextual tab>Arrange panel (shown on the right in Figure 2–13), select either Bring 
to Front or Send to Back or expand them to see more options to move linked files to the 
front or back of the host elements.
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Figure 2–13

Visibility/Graphic Overrides – Imported Categories
Imported or linked CAD files have their own visibility settings in the Visibility/Graphic Overrides 
dialog box on the Imported Categories tab. You can control the display of individual layers 
within the CAD file by turning them on or off in the Visibility column (as shown in Figure 2–14) 
and changing their colors, line weights, and line patterns. This helps ensure that the CAD file 
appears clean and consistent with your Revit project’s graphic standards. This is also where 
you can set your imported or linked CAD file to display in the view in halftone or turn it off 
completely.

Figure 2–14

Properties

Contextual ribbon
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How To: Hide Individual CAD File Layers

1. In the View tab>Graphics panel, click (Visibility/Graphics), or type VG or VV to open the 
Visibility/Graphic Overrides dialog box.

2. Select the Imported Categories tab. It displays a list of each imported instance and its 
layers/levels, as shown in Figure 2–15.

3. To have the linked/imported file display in halftone, check the box in the Halftone column. 

4. Click the plus sign beside the file name to expand the list of the layers in that file.

5. Clear the checkmark from the individual layers that you do not want to display.

• Typically, these layers contain similar information, such as all windows or all notes in a 
drawing. However, it is not as definite as using Revit elements. An item might have been 
misplaced on a different layer and, if so, it does not toggle off.

• To toggle off the entire file, clear the checkmark next to the file name in the Visibility column.

Figure 2–15

6. Close the dialog box.

Turn off linked/
imported file’s layers

Turn link to 
halftone in view
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Setting an Imported or Linked CAD File to Halftone in View
To see the difference between the host model elements and the linked or imported CAD file, you 
can set the linked/imported file to halftone, as shown in Figure 2–16.

Figure 2–16

How To: Set a CAD File to Halftone in a View

1. Select the imported/linked CAD file.

2. Right-click and select Override Graphics in View>By Element... or By Category..., as shown 
in Figure 2–17.

Figure 2–17

Linked/imported file

Revit elements



Autodesk Revit 2026: Fundamentals for MEP

2–14 © 2025 ASCENT - Center for Technical Knowledge

3. In the View Specific Element (or Category) Graphics dialog box, select Halftone, as shown in 
Figure 2–18.

• If halftone is set using By Element, the setting will not show up in the Visibility/Graphic 
Override dialog box. You will need to select the CAD file, right-click, and select Override 
Graphics in View>By Element to turn it off in the View Specific Element Graphics dialog 
box. 

• If halftone is set using By Category, you can turn it off in the View Specific Category 
Graphics dialog box or using the Visibility/Graphic Overrides dialog box.

Figure 2–18

4. Click OK.

Override by Element Override by Category
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2.4 Linking in Revit Models
You can link Revit models directly into a project. These models can be an existing building that 
you are creating an addition to, as shown in Figure 2–19, or engineering models that you are 
checking to ensure that they line up with your model. This can also be used for campus-like 
projects where the same building is repeated multiple times. The Revit models that are linked 
are full 3D models.

Note: A linked model automatically updates when the original file is changed.

Figure 2–19

• Architectural, structural, and MEP models created in Revit can be linked into each other. It is 
best practice to always link Revit models that are from the same release cycle.

• When you link Revit models, clashes between disciplines can be detected and information 
can be passed between disciplines. 

• Revit models are always linked. They cannot be imported.

Linked Revit model with outline of 
addition in the current project
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How To: Add a Linked Model to a Host Project

1. In the Insert tab>Link panel, click  (Link Revit).

2. In the Import/Link RVT dialog box, select the file that you want to link. Before opening the 
file, set the Positioning, as shown in Figure 2–20.

Figure 2–20

3. Click Open.

• Depending on how you decide to position the file, it is automatically placed in the project or 
you can manually place it with the cursor. The more links present in a project, the longer it 
takes to load.
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2.5 Modifying Linked Revit Models
A Revit linked model is a separate Revit file that you bring into your current project to use as a 
reference. It is often used when different teams are working on different parts of a building, like 
architecture, structure, or MEP. Linking the model lets you see and coordinate with other 
disciplines’ work without editing their files directly. You can control how the linked model looks 
and behaves in your views, but the original file stays unchanged.

It is best practice to adjust a linked Revit model’s visibility using the Revit Links tab in the 
Visibility/Graphic Overrides dialog box.

Visibility/Graphic Overrides – Revit Links
The Revit Links tab in the Visibility/Graphic Overrides dialog box (shown in Figure 2–21) allows 
you to control how linked Revit models appear in your views. In the Visibility column, you can 
turn on or off each link to show or hide it in the current view. The Halftone column lets you set 
the link to a gray tone, making it easier to distinguish from the main model. Checking the box in 
the Underlay column shows the linked model as a background reference. In the Display Settings 
column, By Host View means the linked model will follow the visibility settings of the current 
view in the host project for all view settings and visibility/graphic overrides settings for the 
model, annotation, analytical model, and imported categories.

Figure 2–21

How To: Use Visibility/Graphic Overrides to Set the Revit Model to Halftone

1. In the View tab>Graphics panel, click (Visibility/Graphics), or type VG or VV to open the 
Visibility/Graphic Overrides dialog box.
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2. In the Visibility/Graphic Overrides dialog box, on the Revit Links tab, check the checkbox for 
a specific Revit linked model in the Halftone column, as shown in Figure 2–22.

• If you want to turn off the Revit model in the view, uncheck the checkbox next to the model’s 
name in the Visibility column.

Figure 2–22

• If you select a Revit linked model and type VH, it will hide all Revit links in the model. To 
unhide the links, you will need to use Reveal Hidden Elements in the View Control Bar.

How To: Set Revit Models to Halftone Directly in a View

1. In the view, select a Revit model.

2. Right-click and select Override Graphics in View>By Category....

3. In the View Specific Category Graphics dialog box, select the checkbox for Halftone, as 
shown in Figure 2–23, and click OK. All linked Revit models in the view are set to halftone.

Figure 2–23

• You will need to remember that you set the linked Revit models to halftone using this 
dialog box, as the setting will not be reflected in the Visibility/Graphic Overrides dialog 
box as it is with CAD files. 

Turn off link in view Turn link to halftone in view
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2.6 Temporary Hide/Isolate
You might want to temporarily remove linked or imported CAD files and models from a view, 
modify the project, and then restore the elements. Instead of completely toggling the elements 
off, you can temporarily hide them.

Select the elements you want to hide (make invisible) or isolate (keep displayed while all other 
elements are hidden) and click  (Temporary Hide/Isolate). Select the method you want to 
use, as shown in Figure 2–24.

Figure 2–24

• The category or elements are hidden or isolated. A cyan border displays around the view 
with a note in the upper-left corner, as shown in Figure 2–25. It indicates that the view 
contains temporarily hidden or isolated elements.

Figure 2–25

• Click  (Temporary Hide/Isolate) again and select Reset Temporary Hide/Isolate to 
restore the elements to the view.

• If you want to permanently hide the elements in the view, select Apply Hide/Isolate to View.

• Elements that are temporarily hidden in a view are not hidden when the view is printed.
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2.7 Managing Links
The Manage Links dialog box (shown in Figure 2–26) enables you to reload, unload, add, and 
remove links. You can also convert a linked CAD file to an imported file. If you accidentally click 
Import, you can close the Manage Links dialog box and click Undo in the Quick Access Toolbar. 

There are three ways to open the Manage Links dialog box: 

• In the Insert tab>Manage panel, click (Manage Links). 

• In the Manage tab>Manage Project panel, click  (Manage Links). 

• Select the Revit link and click  (Manage Links) in the Modify | RVT Links tab>Link 
panel.

Figure 2–26

1. Type Drop-Down List 4. File Detail Panel

2. Search Bar 5. Add Menu

3. Show Columns List 6. File List

1 2

3

4

5

6
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1. Type Drop-Down List
By default, the Manage Links dialog box is set to show all file types. You can adjust this by 
expanding the Type drop-down list and changing it from All to a specific type, as shown in 
Figure 2–27. The Manage Links dialog box shows both linked and imported CAD files.

Figure 2–27

2. Search Bar
At the top of the Manage Links dialog box is a search bar to narrow down the list of linked and 
imported files that display. As soon as you start typing in the search bar, the list of files below 
will automatically update. It will only show the files that match the letters or words you are 
typing. Click the X in the search bar (shown in Figure 2–28) to clear the search and return to the 
full list.

Figure 2–28

Click to clear the 
search results
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3. Show Columns List
To choose which columns you want to see in the Manage Links dialog box, click the gear icon to 
expand a list of all available columns, as shown in Figure 2–29. You can check the boxes for the 
columns you want to show, and uncheck the ones you do not need. When you are done, click 
the gear icon again to close the list.

Figure 2–29

4. File Detail Panel
When you select a file in the file list, the file detail panel displays information about the file. This 
panel can be expanded and collapsed by clicking the icon in the upper-right corner. Depending 
on the file that is selected, you can modify things like Path type and Reference type, as shown in 
Figure 2–30.

Figure 2–30

Click to collapse 
or expand 
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5. Add Menu
At the top of the Manage Links dialog box is the Add menu. When you click to expand it, as 
shown in Figure 2–31, a list displays of file types that you can add, including Revit, CAD 
Formats, PDF, and Images. When you select a type, it will open the respective import or link 
dialog box, where you can navigate to the file to bring it into the model. For file types that allow 
you to position the file manually, the manual options will not be available in the link or import 
dialog box. For example, if you select Revit, the Link Revit dialog box’s Positioning options will 
not include any manual options.

Figure 2–31

6. File List
By default, imported and linked file types display in the Manage Links dialog box within a tree 
structure that organizes the file types into their respective categories. When you select a file, 
operation tools display along the top of the dialog box, depending on which file type was 
selected. The tools are also available by right-clicking on a file or expanding the more menu at 
the end of the file. Figure 2–32 shows the operation tools that display when a Revit file is 
selected.

Figure 2–32

Operation tools
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The Saved Path column shows the location where the file is stored on your computer or 
network. To copy the saved path for a file, hover your cursor over the file’s saved path, as shown 
in Figure 2–33, triple-click on the path name to select the full path, and press <Ctrl>+<C> to 
copy the information.

Figure 2–33

The following options are available:

• Reload: Reloads the file without additional prompts.

• Reload From: Opens the Add Link dialog box, which enables you to select the file you want 
to reload. Use this if the linked file location or name has changed. This is accessed by 
expanding Reload.

• Unload: Unloads the file so that the link is kept, but the file is not displayed or calculated in 
the project. Use Reload to restore it.

Note: For Revit links, some of these options are also available in the Project Browser. 
Expand the Revit Links section, then right-click on the Revit link and select Reload, Unload, 
or Reload From…. 

• Remove: Deletes the link or imported file from the host model.

• Import: Converts the linked file to an imported file.

Links can be nested into one another. How a link responds when the host project is linked into 
another project depends on the option in the Reference Type column. 

• Overlay: The nested linked model is not referenced in the new host project. 

• Attach: The nested linked model displays in the new host project.

The option in the Path Type column controls how the location of the link is remembered.

• Relative

• Searches the root folder of the current project.

• If the file is moved, the software still searches for it.

• Absolute

• Searches the entire file path where the file was originally saved.

• If the original file is moved, the software is not able to find it.

• Other options control how the linked file interfaces with worksets and shared positioning.
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Unresolved Reference
When opening a project with linked files that have been moved or deleted, an Unresolved 
References dialog box will appear after the project opens in Revit, as shown in Figure 2–34. This 
message will only display for files that have been linked into the project and not for imported 
files. At the bottom of the dialog box, click Show details to view a list of the files that have 
unresolved issues.

Figure 2–34

How To: Fix Unresolved References

1. After you open a Revit project that contains linked files, the Unresolved References dialog 
box displays.

2. In the Unresolved References dialog box, click Open Manage Links to correct the problem. 

• Alternatively, if you click Ignore and continue opening the project, you can open the 
Manage Links dialog box and resolve the issues at a later time. Note that if any elements 
in the project are hosted to a surface or element in a linked Revit model, the hosted 
elements will be orphaned or disassociated, potentially causing further issues.
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3. In the Manage Links dialog box, any file that is missing will have a warning symbol in the 
Status column, as shown in Figure 2–35. 

Figure 2–35

4. Click on the file in the Name column. The operation tools display at the top of the columns, 
as shown in Figure 2–36. Expand Reload and select Reload from....

Figure 2–36

5. In the file browser dialog box, navigate to the file and click Open.

Operation tools
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Practice 2a
Start a Project and Link Files – All Disciplines

Practice Objectives 

• Start a Revit project.

• Link a CAD file.

• Link a Revit file.

• Modify the linked files in a view.

In this practice, you will start a Revit project, then link in a grid plan created in AutoCAD and a 
Revit model of the school. You will then modify the view properties. Figure 2–37 shows the 
completed practice.

Figure 2–37

Task 1:  Start a project.

1. On the Home screen, click the New button under the Models section. Alternatively, in the 

File tab, expand  (New) and click (Project).
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2. In the New Project dialog box, click Browse.... 

3. In the Choose Template dialog box, navigate to the practice files Templates folder, select 
Imperial-MEP-Template.rte, and click Open.

4. In the New Project dialog box, click OK. (There are no elements in this file, only datums and 
basic views.)

5. In the File tab, expand  (Save As) and select  (Project). In the Save As dialog box, 
navigate to the practice files folder and name the project as School-MEP-Start.rvt. Click 
Save.

6. Review the Project Browser and note that the project has default floor plan, ceiling plan, and 
elevation views. By default, the 1 - Mech view is open and displays in bold in the Project 
Browser within the Mechanical>HVAC>Floor Plans section. (You may need to scroll down in 
the Project Browser as this template displays all MEP disciplines.)

7. Note in the view area that the elevation markers are the only thing that displays.

Task 2:  Link a CAD file.

1. In the Insert tab>Link panel, click  (Link CAD).

2. In the Link CAD Formats dialog box, navigate to the practice files Working 
Models>General>CAD folder and select the file Struct-School_Grids.dwg, then set the 
following options, as shown in Figure 2–38:

• Uncheck Current view only (if applicable)

• Colors: Black and White

• Layers/Levels: All

• Import units: Auto-Detect

• Positioning: Auto - Origin to Internal Origin

• Place at: Level : Level 1

• Keep Orient to View checked

Figure 2–38

3. Click Open. The linked CAD file is placed in the project.

4. Double-click your mouse wheel or type ZF (Zoom to Fit) to zoom to the extents of the view.

5. Select the linked CAD file. In Properties, you can see that it is an imported symbol. In the 
view, you can see a pin at the center of the CAD file because it was imported origin to 
internal origin.
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6. In the ribbon, expand the Select drop-down list under the  (Modify) tool and make sure 

that Select Links is checked, or verify that the  (Select Link) icon in the Status Bar does 
not have a red X on it. 

7. Right-click on the linked file and select Override Graphics in View>By Category.

8. In the View Specific Category Graphics dialog box, select Halftone, as shown in 
Figure 2–39.

Figure 2–39

9. Click OK.

10. Click in an empty space in the view to release the selection. The linked file displays in 
halftone. Note that the view’s elevation markers are still dark.

11. From the Project Browser, open the Mechanical>HVAC> Floor Plans>2 - Mech view. The 
CAD file linked in level 1 does not display because the Place at in the Link CAD Formats 
dialog box was set to Level : Level 1.

12. Open the Electrical>Lighting>Floor Plans>1 - Lighting view. The grids display because this 
view is associated to level 1. 

• Note that the grid is not set to halftone like in the 1 - Mech view. This is because 
Override Graphics in View is view specific.

• If you do not want the CAD file to display in other level 1 views, you would select the 
Current view only option in the Link CAD Formats dialog box.

13. Save the project.

Task 3:  Link in a Revit file.

1. In the Quick Access Toolbar, click  (Default 3D View). Note that the linked structural grid 
CAD file displays but is not halftone, and there are two level lines (they may be hard to see).

2. Repeat the steps you performed in the 1 - Mech view and override the graphics of the 
structural grid CAD file to Halftone. The level lines are now easier to see.
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3. Using your mouse wheel, zoom in to the levels and select one, then type VH to hide them in 
the view.

4. Double-click your mouse wheel to zoom to the extents of the view.

5. In the Insert tab>Link panel, click  (Link Revit).

6. In the Import/Link RVT dialog box, navigate to your practice files Working Models>General> 
Revit Link Files folder and select the file School-Arch.rvt. Ensure that the Positioning is set 
to Auto - Internal Origin to Internal Origin and click Open.

7. Type ZF (Zoom to Fit). The new building displays in the active view.

8. With nothing selected, in Properties, look at the Discipline and note that it is set to 
Mechanical. Because it is set to Mechanical, all of the architectural elements (walls, roofs, 
and windows) are grayed out. 

9. Zoom and pan around the model. You can see that the Revit linked model’s MEP-related 
elements display darker than the architectural elements that are grayed out, as shown in 
Figure 2–40.

Figure 2–40

10. Select the school linked model in the view and in the Modify | RVT Links tab>Modify panel, 
click (Pin). This will ensure that the linked model will not be accidentally moved in the 
project.

11. In the Select panel, click  (Modify), or click in an empty area in the view to release the 
selection.

12. In the View tab>Graphics panel, click (Visibility/Graphics), or type VG or VV to open the 
Visibility/Graphic Overrides dialog box.

Architectural elements 
in the linked model

Grids in DWG file

MEP fixtures in 
the linked model
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13. Select the Revit Links tab. Next to School-Arch.rvt, check the checkbox for Halftone, as 
shown in Figure 2–41. Setting a Revit link to halftone will help when trying to see the 
difference between objects in the linked architectural model and MEP objects.

Figure 2–41

14. Select the Imported Categories tab and note that the linked Struct-School_Grids.dwg is set 
to Halftone. This is because you used Override Graphics in View>By Category... to set the 
file to halftone and did not use By Element.

15. Click OK. Note that the lighting fixtures, air terminals, and plumbing fixtures in the linked 
Revit model are now halftone as well.

16. In the View Control Bar, change the Visual Style to Consistent Colors, as shown in 
Figure 2–42, and note that the MEP objects and metal roofs darken.

Figure 2–42

17. In the view, try to select on the lighting fixture, air terminal, or plumbing fixture. The linked 
Revit model School-Arch.rvt highlights and displays in Properties. This is because those 
objects are a part of the linked model.

18. Click in an empty area in the view to release the selection.

19. Zoom to fit the view.

20. Save and close the project.

End of practice
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2.8 Setting Up Levels
Levels define floors and vertical heights in a project, like the first and second floor. The default 
template starts with two levels, but you can add as many as needed, including negative heights 
for things like basements or footings, as shown in Figure 2–43. Levels must be created in an 
elevation or section view, and once an element is attached to a level, it will move with that level 
if it changes. Levels can be shown or hidden in the default 3D view, where they can be modified 
and copied, but not created.

Figure 2–43

There are tools that you can utilize while drawing levels, such as modify tools, draw tools, and 
drawing aids like temporary dimensions and alignment lines. You will learn more about these 
tools in Chapter 5 Basic Sketching and Modify Tools.

How To: Create Levels

1. Open an elevation or section view.

2. In the Architecture or Structure tab>Datum panel, click  (Level), or type LL.

3. In the Type Selector, set the level head type, if needed.

4. In the Modify | Place Level tab>Plan Views panel, check Create Plan View, as shown in 
Figure 2–44.

Figure 2–44
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5. Click Plan View Types to select or unselect the types of views to create when you place the 
level. Figure 2–45 shows the Plan View Types dialog box.

Note: If you have Structural Tabs and Tools turned off in Revit Options>User Interface, 
you will not see the Structural Plan in the Plan View Types dialog box.

Figure 2–45

6. In the Modify | Place Level tab>Draw panel, click either  (Pick Lines) to select an element 

or  (Line) to sketch a level. Sketch the level lines in a consistent direction, either from left 
to right or right to left. When using Pick Lines, ensure that you do not place levels on top of 
each other or other elements by mistake.

• Level names are automatically incremented as you place them. This automatic 
numbering is most effective when you use names such as Floor 1, Floor 2, etc. (as 
opposed to First Floor, Second Floor, etc.). In addition, this makes it easier to find the 
view in the Project Browser. 

7. Continue adding levels as needed.
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How To: Use Draw and Modify Tools When Adding Levels

1. A fast way to create multiple levels is to use the  (Pick Lines) option. In the Options Bar, 
specify an Offset, select an existing level, and then pick above or below to place the new 
level, as shown in Figure 2–46. 

Note: You specify above or below the offset by hovering the cursor on the needed side.

Figure 2–46

2. When using the  (Line) option, alignments and temporary dimensions help you place the 
line correctly, as shown in Figure 2–47.

Figure 2–47

3. Use tools from the Modify tab like  (Copy) to duplicate level lines. The level names are 
incremented but a plan view is not created. These are called reference levels.

Offset alignment line

Temporary 
dimension

First click Second click

Alignment 
line

Alignment 
line
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Modifying Levels
You can change levels using standard controls and temporary dimensions, as shown in 
Figure 2–48 to the levels’ appearance. You can also make changes to the name and height of 
the level by selecting on the individual items in the view as well as change these in Properties. 
You can change just the name of the level in the Project Browser but not the height.

Figure 2–48

•  (Hide/Show Bubble) displays on either end of the level line and toggles the level 
head symbol and level information on or off. 

•  (Switch to 3d/2d extents) controls whether any movement or adjustment to the 
level line is reflected in other views (3D) or only affects the current view (2D).

•  (Modify the level by dragging its model end) at each end of the line enables you to drag 
the level head to a new location.

•  (Create or remove a length or alignment constraint) controls whether the level is 
locked in alignment with the other levels. If it is locked and the level line is stretched, all of 
the other level lines stretch as well. If it is unlocked, the level line stretches independent of 
the other levels.

• Click  (Add Elbow) to add a jog to the level line, as shown in Figure 2–49. Drag the shape 
handles to new locations as needed. This is a view-specific change.

Figure 2–49

Controls

Controls

After Before 
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How To: Modify a Level’s Name and Elevation

1. To change the level name or elevation, double-click on the information next to the level 
head, or select the level and modify the Name or Elevation fields in Properties, as shown in 
Figure 2–50.

Figure 2–50

2. A Confirm Level Rename dialog box displays, prompting you to rename the corresponding 
views, as shown in Figure 2–51. Click Yes if you want to rename the view in the Project 
Browser.

• If you change the name in the Project Browser, a Confirm Plan View Rename dialog box 
displays and you are asked if you would like to rename the corresponding level and views.

Figure 2–51

Hint: Modifying Measurements
For imperial measurements (feet and inches), the software uses a default of feet. For 
example, when you type 4 and press <Enter>, it assumes 4'-0". For a distance such as 4'-6", 
you can type any of the following: 4'-6", 4'6, 4-6, or 4 6 (the numbers separated by a space). 
To indicate distances less than one foot, type the inch mark (") after the distance, or enter 0, 
a space, and then the distance.
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• If you delete a level, the views related to that level are also deleted. A warning displays, as 
shown in Figure 2–52.

Figure 2–52

Creating Plan Views
When you place a level, verify in the contextual tab that Create Plan View is selected. There may 
be instances where you do not need to create plan views for levels that only mark data points, 
such as the top of a storefront window or the top of a parapet. In these cases, either ensure the 
Create Plan View option is unchecked or copy the level. If needed, you can create a plan view 
manually. Level heads with views appear in blue, while those without views are black, as shown 
in Figure 2–53. 

Figure 2–53

Hint: Copying Levels and Grids from Other Projects
Levels and grid lines can be added by drawing over existing levels or grids in an imported or 
linked file. They can also be copied and monitored from a linked Revit file. Some projects 
might require both methods.

Black = no plan views

Blue = plan views created
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How To: Create Plan Views

1. In the View tab>Create panel, expand  (Plan Views) and select the type of plan view you 
want to create, as shown in Figure 2–54.

Figure 2–54

2. In the New Plan dialog box (shown in Figure 2–55), select the levels for which you want to 
create plan views. Hold <Ctrl> to select more than one level.

• Clear Do not duplicate existing views to create a copy of an existing view.

Figure 2–55
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3. Click OK.

• Once a plan view is made from a level, you can double-click on the level head to open the 
related floor plan view. You create other plan views similar to creating a floor plan. Ceiling 
plans are typically created by default when you add a level with a view. If you do not want a 
level to have a ceiling plan, you can right-click on its name in the Project Browser and select 
Delete, as shown in Figure 2–56.

Figure 2–56
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Practice 2b
Set Up Levels – All Disciplines

Practice Objectives 

• Add and modify levels

• Create a floor and reflective ceiling plan view.

In this practice, you will set up the levels required in the project, as shown in Figure 2–57. You 
will then modify the levels’ names and create floor and reflective ceiling plan views.

Figure 2–57

Task 1:  Modify existing levels.

1. In the practice files Working Models>General folder, open Gen-Levels.rvt.

2. In the Project Browser, open the Mechanical>HVAC>Elevations (Building Elevation)>North - 
Mech view.

3. Pan and zoom in to the level markers to the right of the building.

Host MEP 
model’s levels

Linked architectural 
model’s levels
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4. There are two levels in the host project. Select the linked architectural model to help you 
distinguish between them, as shown in Figure 2–58.

Figure 2–58

5. In the View tab>Graphics panel, click (Visibility/Graphics), or type VG or VV to open the 
Visibility/Graphic Overrides dialog box.

6. On the Revit Links tab, check the checkbox in the Halftone column for School-Arch.rvt, as 
shown in Figure 2–59.

Figure 2–59

7. Click OK. It is now easier to distinguish between the linked model’s and the host model’s 
level lines as you work.

8. Click  (Modify).

Linked architectural 
model’s levels

Host MEP 
project’s levels
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9. Select one of the level lines (e.g., click on Level 2) in the host project. Select the level drag 
control (shown in Figure 2–60) and drag it to the side past the linked model’s levels, as 
shown in Figure 2–60. Both of the host levels move together.

Figure 2–60

Note: If required, press <Tab> to select the level in the host project and not the linked 
model. If your levels disappear when dragging them, click (Do Not Crop View) in the 

View Control Bar to turn off the crop region (which will look like this: ).

10. Save the project.

Task 2:  Create new levels.

1. In the Architecture tab>Datum panel, click  (Level). 

2. In the Modify | Place Level tab>Draw panel, click  (Pick Lines).

3. In the Modify | Place Level tab>Plan Views panel, check Create Plan View, then click 

(Plan View Types). 

MEP project’s 
levels moved

Level drag 
control
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4. In the Plan View Types dialog box, uncheck Structural Plan to clear it, as shown in 
Figure 2–61, then click OK.

Note: If you have Structural Tabs and Tools turned off in Revit Options>User Interface, 
you will not see the Structural Plan in the Plan View Types dialog box.

Figure 2–61

5. In the Options Bar, set the Offset to 14'-8" and press <Enter>.

Note: Instead of typing the hyphen, just press <Spacebar> between typing the numerical 
values for feet and inches. When doing this, you do not need to add the symbols for feet 
and inches as well.

6. Hover the cursor over the host project’s Level 2 level line and move the cursor slightly 
upward until you see the dashed alignment line display in line with the Wing Roofs level, as 
shown in Figure 2–62. (The alignment line in the image has been enhanced for clarity.) 
Click to place it.

Figure 2–62

Alignment line
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7. Click  (Modify).

• Note that the new level appears in the Project Browser under Mechanical>HVAC>Floor 
Plans and a new subsection named ???>Ceiling Plans.

8. In the view, click on the new level name and type Wing Roofs, as shown in Figure 2–63, then 
press <Enter>.

Figure 2–63

9. In the Confirm Level Rename dialog box, click Yes or press <Y> when prompted to rename 
the corresponding views. Note that in the Project Browser, in the Floor Plans section, the 
view name has changed.

10. In the Project Browser, in the Mechanical section, expand ???>Ceiling Plans and select the 
Wing Roofs view. 

11. In Properties, change the Sub-Discipline to HVAC and click Apply. In the Project Browser, 
the view moves to be under the HVAC>Ceiling Plans section.

12. Click  (Modify). 

13. In the North - Mech view, start the Level command again. In the Modify | Place Level tab> 

Draw panel, click  (Pick Lines).

14. In the Modify | Place Level tab>Plan Views panel, clear the Create Plan View option. Verify in 
the Options Bar that the Offset is set to 0'-0". Hover your cursor over the linked model’s 
Library Top level. Click to place the new level.

15. With the new level still selected, click and drag the level control (as shown in Figure 2–64) 
to the right to align with the other levels.

Figure 2–64

16. Click  (Modify). 
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17. Select the level and in Properties, in the Identity Data section, change the name to Library 
Top, as shown in Figure 2–65. Move the cursor into the view area to apply the changes and 
click in an empty area to release the selection.

Figure 2–65

Note: You do not get the request to rename corresponding views because you unchecked 
Create Plan View, so no view was created when the level was placed in the view. The level 
head is black as opposed to blue like the rest of the levels. A black level head means that 
there are no views created for this level.

18. In the North - Mech view, start the Level command again. Check Create Plan View and click 

 (Plan View Types). 

19. In the Plan View Types dialog box, uncheck Ceiling Plan and verify Structural Plan is still 
unchecked so that only Floor Plan is checked, as shown in Figure 2–66. Click OK.

Figure 2–66

20. In the Modify | Place Level tab>Draw panel, click  (Pick Lines).

21. Add another level for the Parapet - Gym. Use the level control to drag the level to the right.

22. With the level still selected, change the name to Parapet - Gym and press <Enter>. (Rename 
the corresponding views.)

23. Click  (Modify). 

24. Save the project.
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Task 3:  Create a ceiling and plan view.

1. In the View tab>Create panel, expand  (Plan Views) and click  (Floor Plan).

2. In the New Floor Plan dialog box, select the Library Top level, as shown in Figure 2–67, and 
click OK.

Figure 2–67

3. The new view opens and displays in the Project Browser. 

4. In the View tab>Create panel, expand  (Plan Views) and click  (Reflected Ceiling 
Plan).

5. In the New RCP dialog box, select the Library Top level and click OK.

6. The new view opens. In the Project Browser, select the new view by expanding the 
Coordination>???>Ceiling Plans section. In Properties, set the Discipline to Mechanical and 
the Sub-Discipline to HVAC and click Apply to move the ceiling plan view into the correct 
section in the Project Browser.

7. Save and close the project.

End of practice
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2.9 Creating Grids
Grids are annotation elements that display in most views, including plan, ceiling, section, 
elevation, and 3D views. They help organize your design when developing a layout and describe 
the pattern and location for columns, as shown in Figure 2–68. Grids can be multi-segmented, 
arcs, or straight lines, and they can be hidden in the view if needed. Each line or arc in a grid is a 
separate entity and can be placed, moved, and modified individually. Grids cannot be drawn in a 
3D view but grids can be displayed in a 3D view, perspective view, or in a 3D view with a 
selection box, and when you click on a grid, the surface contour displays.

Figure 2–68

How To: Create a Grid

1. In the Architecture or Structure tab>Datum panel, click  (Grid), or type GR.

2. In the Properties, in the Type Selector, select the grid type, which will control the size of the 
bubble and the linestyle.

3. In the Modify | Place Grid tab>Draw panel (shown in Figure 2–69), select the draw method 
you want to use. 

Figure 2–69

4. In the Options Bar, set the Offset if needed.
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5. Start drawing grid lines. Grids can be sketched at any angle, but you should ensure that all 
parallel grids are sketched in the same direction (e.g., from left to right or from bottom to 
top). When using the Multi-Segment tool (shown in Figure 2–70), sketch the line and click 

(Finish Edit Mode) to complete the command.

Figure 2–70

How To: Turn On or Off Grids in 3D

1. Open a 3D or perspective view and press <Esc> twice to verify nothing is selected. 

2. In Properties, click Edit... next to Show Grids, as shown in Figure 2–71.

Figure 2–71
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3. In the Show Grids dialog box, select the level(s) that you want the grids to display at in the 
3D view, as shown in Figure 2–72.

Figure 2–72

4. Click OK.

5. (Optional) To display the grids on the bottom of a section box, in Properties, verify that 
Section Box is selected, and click Edit... next to Show Grids.

6. In the Show Grids dialog box, select only the Project Grids On Section Box option, as shown 
in Figure 2–73, and click OK. Note that you can also display the grids at a specific level and 
project the grids on the section box.

Figure 2–73

Grid 
lines
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Modifying Grid Lines
Grid lines, like levels, are datum elements that you can adjust using controls, alignments, and 
temporary dimensions in the view, as shown in Figure 2–74. You can change the type using the 
Type Selector, and grid numbers can be letters, numbers, or a mix of both. To modify a grid 
number, double-click the bubble and type the new value, or change the Name in Properties. In 
MEP disciplines, grids serve as a reference guide to help align MEP elements with the 
architectural and structural models.

Figure 2–74

To modify the length of the grid line, select the grid line and click and drag the  (Modify the 
grid by dragging its model end) control to the new location, as shown in Figure 2–75.

Figure 2–75

Add elbow

Grid bubbles

Alignment 
line

Drag 
control

Temporary dimension
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In 3D views, grid lines can be edited just like in plan views – you can rename them, adjust their 
length using the drag control, and change the spacing by modifying temporary dimensions. To 
change how the grid symbols appear at each end of the grid line, use the Type Properties dialog 
box, where the first pick point is End 1 and the second is End 2, as shown in Figure 2–76.

Figure 2–76
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Hint: Propagating Datum Extents
If column grids do not display in a view, this might be due to adding a level after the grid lines 
were added. To display the grid lines in plan views, select the grid lines in a view in which 

they are displayed. In the Modify | Grids tab>Datum panel, click (Propagate Extents). In 
the Propagate datum extents dialog box (shown in Figure 2–77), select the views to project 
the grid lines to.

Figure 2–77

• This also works for levels.

• (Propagate Extents) is particularly useful to make grid lines display the same in all 
views.
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Practice 2c
Add Grids – All Disciplines

Practice Objectives 

• Add and modify grid lines.

• Modify grid properties in a 3D view.

In this practice, you will place grid lines using the linked CAD model as a guide. You will then 
turn grid lines on in a 3D view. Figure 2–78 shows a 3D view of the completed practice. Grids 
are being used in this practice only so you can learn how to place them in a project; they do not 
appear in other practices in this guide.

Figure 2–78

1. Open Gen-Grids.rvt from the practice files Working Models>General folder.

2. From the Project Browser, open the Coordination>All>FloorPlans>Level 1 view.
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3. Type VV to open the Visibility/Graphic Overrides dialog box. On the Revit Links tab, in the 
Visibility column, clear the checkbox next to School-Arch.rvt, as shown in Figure 2–79, to 
turn off the linked Revit file in the view.

Figure 2–79

4. Click OK.

5. The linked architectural model is turned off in the view and only the DWG’s grid displays.

6. Zoom and pan to the upper-right corner of the horizontal grids A and B that are indented to 
the right.

7. In the Architecture tab>Datum panel, click  (Grid).

8. In the Modify | Place Grid tab>Draw panel, click  (Pick Lines).

9. Using the linked DWG as a guide, select grid line A on the linked file to create a grid line in 
the host project. Note that there is a grid bubble on each end of the grid line.

10. Click  (Modify).

11. Zoom in to one of the grid heads and click inside the bubble, then type A and press <Enter>. 
Zoom out so you can see both ends of grid line A and note that both grid bubbles show A.

12. Click  (Modify). Note that the host grid line is darker than the grid lines in the linked 
DWG file.

13. Start the Grid command again and select Pick Lines from the Draw panel.

14. Starting from the next horizontal grid line, which is B, continue selecting the rest of the 
horizontal grid lines in alphabetical order. Note that the grid lines for G, H, I, and K are 
indented to the left. The letters automatically increment. When you get to grid line M, pan 
up to the upper-left corner.

15. Click the first vertical grid line on the linked file and change the letter in the bubble to 1. 
Note that you do not need to end the command to change the grid bubble value.

16. Continue selecting the vertical grid lines. The numbers automatically increment. Pay close 
attention as you get to grid lines 10 and 11 – grid line 10’s bubble is down by grid line F and 
grid lines 11, 12, and 13 are up by grid line A.

17. Zoom in to the lower-right corner and note that there are grid lines 4.1 and 60 in this 
linked file. 

18. You should still be in the Grid command. Select grid line 4.1 to place a grid line in the host 
project. Zoom in to the grid head and click inside the bubble, type 4.1, and press <Enter>. 
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19. Repeat this for grid line 60.

20. Click  (Modify) to end the command.

21. The grid lines in the host should all be the same length as the DWG’s grid lines and each 
end of the grid lines should have a bubble, as shown in Figure 2–80.

Figure 2–80

22. In the Quick Access Toolbar, click  (Default 3D View).

23. Click  (Modify) to ensure nothing in the view is selected.

24. In Properties, in the Graphics section, click Edit... next to Show Grids.

25. In the Show Grids dialog box, select Level 1and click OK.
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26. The grids now display as shown in Figure 2–81.

Figure 2–81

27. Save and close the project.

End of practice
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Chapter Review Questions
1. What type of view do you need to be in to add a level to your project?

a. Any 3D view.

b. As this is done using a dialog box, the view does not matter.

c. Any plan view.

d. Any section or elevation view.

 

2. How do you line up grid lines that might be different lengths, as shown in Figure 2–82?

Figure 2–82

a. Delete and redraw the grid lines.

b. Select the grid line and use the drag control to line up with the other grid lines.

c. Select the grid line, right-click, and select Auto-Align.

d. In Properties, change the Length to get them into position.

 

3. Grids can be displayed in a 3D view.

a. True

b. False

 

4. Which of the following types of CAD formats can you import into Revit? (Select all that 
apply.)

a. .DWG

b. .XLS

c. .SAT

d. .DGN 
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5. Imported CAD files can be reloaded in the Manage Links dialog box.

a. True

b. False

 

6. To modify linked CAD files, you need to open what dialog box?

a. Type Properties

b. Link CAD

c. Manage Links

d. Insert from File

 

7. When linking a Revit model, what should be done to keep the linked model from moving?

a. Lock the model.

b. Pin the model.

c. Center the model.

d. Coordinate the model.

 

8. How many times can one project file be linked into another project?

a. Once

b. It is limited by the size of the link

c. As many as you want

 

9. When creating a new level, you have to change all corresponding views.

a. True

b. False

 

10. Where can you change a level’s name?

a. In the Options Bar.

b. Within the plan view and in the Options Bar.

c. In the Project Browser, in Properties, or in an elevation view by clicking on the level’s 
name.

d. You cannot change the name after the level has been placed in the view.
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11. If imported with the Current view only option selected, you can set the imported DWG to be 
in the foreground or background throughout the project’s life cycle. 

a. True

b. False
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Command Summary
Button Command Location

Grid • Ribbon: Architecture tab>Datum panel
• Shortcut: GR

Import CAD • Ribbon: Insert tab>Import panel

Import PDF • Ribbon: Insert tab>Import panel

Level • Ribbon: Architecture tab>Datum panel
• Shortcut: LL

Link CAD • Ribbon: Insert tab>Link panel

Link PDF • Ribbon: Insert tab>Link panel

Link Revit • Ribbon: Insert tab>Link panel

Manage Links • Ribbon: Insert tab>Manage panel or Manage tab> 
Manage Project panel

• Ribbon: (with link selected) Modify | RVT Links tab>Link 
panel

Multi-Segment (Grid) • Ribbon: Modify | Place Grid tab>Draw panel

Propagate Extents • Ribbon: Modify | Grids or Modify | Levels tab>Datum 
panel

Temporary Hide/Isolate • View Control Bar
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