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Chapter

2
Survey, Points, and Linework
The focus of the content is on creating a topography, property boundaries, and centerline 
locations based on survey data collected from the field. You will learn how to import points and 
create points manually by providing information to ensure proper display of the points. 

Additionally, you will create a parcel from a legal description using the Autodesk® Civil 3D® 
Lines and Curves commands and the transparent commands.

Learning Objectives 

• List the steps for a typical survey workflow.

• Set the appropriate point creation settings and the next available point number.

• Create points manually using the Create Points toolbar.

• Import points from ASCII files created from the field survey.

• Generate a report for specific points.

• Group points together using common properties, such as name, elevation, description, etc.

• Review and edit points using the Panorama window to ensure accuracy.

• Draw a parcel from a legal description.
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2.1 Survey Workflow Overview
Workflow

To create linework from coordinate files, use the following survey workflow:

1. Data needs to be entered into the data collector. The correct language, methodology, and 
basic rules regarding data entry into the data collector begin with an understanding of 
figure commands and field codes (raw descriptions).

2. Data can be transferred from the data collector to the computer using an ASCII file or an 
electronic field book. An ASCII file can be opened in Notepad and data can be separated or 
delineated by spaces or commas. The most popular transfer format is Comma Delimited 
Point Number, Northing, Easting, Elevation, Description (PNEZD) format. 

3. If using an electronic field book file (a type of ASCII file), data needs to be converted from 
the raw coordinate file to a field book (*.FBK) using Survey Link or other methods of the 
Autodesk Civil 3D software. Autodesk has collaborated with major survey equipment 
vendors to develop API and drivers that interface their specific survey equipment (Trimble 
Link, TDS Survey Link, Leica X-Change, TOPCON Link, etc.) with the Autodesk Civil 3D 
software.

4. If following the Linework Code Set command format, you do not need to convert the 
coordinate file to a field book. 

5. The Autodesk Civil 3D software needs to have all of the necessary styles, settings, and 
figure prefixes to create, sort, and place points and linework on the required layers.
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2.2 Survey Figures
Survey figures consist of linework generated by coding and placed in a file that is imported into 
a survey database. A figure represents linear features (edge-of-pavement, toe-of-slopes, etc.).

A figure has many functions, which include: 

• Acting as linework in a drawing. 

• Acting as breaklines for a surface definition.

• Acting as parcel lines. 

• Acting as a pipe run. 

• Acting as targets for Width or Offset Targets in a corridor.

• Acting as targets for Slope or Elevation Targets in a corridor (e.g., limits of construction for a 
road rehab project might be to the face of walk, which exists in the drawing as a survey 
figure, hence a target).

The Figure Prefix database should be set up before importing any survey data to obtain the 
required entities in a drawing. As point and label styles and the description key set need to exist 
before importing points, figure styles and entries in the Figure Prefix database need to exist 
before importing survey data.
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Figure Prefix Database

The Figure Prefix database (found in the TOOLSPACE>Survey tab) assigns the figure a style, a 
layer, and defines whether the figure is a surface breakline and/or lot line (parcel segment). If 
you did not define any figure styles, you should at least assign a layer to correctly place the 
figure in the drawing. Toggling on the Breakline property, as shown in Figure 2–1, enables you 
select all of the tagged survey figures and assign them to a surface without having to insert or 
select from a drawing. Toggling on the Lot Line property creates a parcel segment from the 
figure in the drawing and, if there is a closed polygon or intersecting lines to form an enclosure, 
assigns a parcel label and creates a parcel in the designated site.

Figure 2–1

If the Name is EOP (as shown in Figure 2–1), any figure starting with EOP uses these settings. 
This is similar to using a description key set, except that the entry in the Figure Prefix database 
does not need an asterisk (*). The entry Name matches EOP-R or EOP-West or EOP-Main-East. 
When inserting survey figures in the drawing, Survey checks the Figure Prefix database for style 
or layer values.
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2.3 Points Overview
Survey points are often used at the beginning of a project and COGO points (for stakeout) at the 
end of a project. Surveyors collect data about existing site conditions (elevations, utilities, 
ownership, etc.) for the project. Their world is coordinates, which are represented by points. 
Each point has a unique number (or name) and a label containing additional information 
(usually the elevation of the coordinate and a short coded description).

There are no national standards for point descriptions in the surveying industry. Each company 
or survey crew needs to work out its own conventions. There are no standards for symbols 
either. Each firm can have its own set of symbols. The symbols used in a submission set can be 
specified by the firm contracting the services.

Autodesk Civil 3D COGO/survey points are a single object with two elements: a point style and a 
point label style. A COGO/survey point definition is shown in Figure 2–2.

Figure 2–2

The following is important point information:

• A point style (no matter what it displays), an AutoCAD node, a custom marker, or a block is 
selectable with an AutoCAD Node object snap.

• A point label is not limited to the point’s number, elevation, and description. A point label can 
contain lines, blocks, and other point properties. You can set up user-defined point 
properties as well. For example, point labels might only display an elevation or description. 
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2.4 Point Settings
When creating new points, you must determine the next point number, and which elevations 
and descriptions to assign and how to assign them. To set the current point number, default 
elevations, descriptions, and other similar settings, you can use the expanded Create Points 

toolbar. Click  in the Create Points toolbar to display the Points Creation and Point Identity 
categories (shown in Figure 2–3), which contain the most commonly used values.

Figure 2–3

Points Creation Values
The Points Creation area affects prompting for elevations and descriptions. The two properties 
in this area are Prompt For Elevations and Prompt For Descriptions. These properties can be set 
as follows:

None Does not prompt for an elevation or description.

Manual Prompts for an elevation or description.

Automatic Uses the Default Elevation or Default Description value when creating a point.

Automatic-Object Creates points along an alignment whose description consists of the Alignment 
name and Station. This description is not dynamic and does not update if the 
alignment changes or the point is moved.
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Point Identity Values
The Point Identity area sets the default method of handling duplicate point numbers. If there are 
duplicate point numbers, there are three ways to resolve the duplication: 

1. Overwrite the existing point data.

2. Ignore the new point.

3. Assign it a new number.

This area’s critical property is Next Point Number. It is set to the first available number in the 
point list. If a file of imported point data uses point numbers 1-131 and 152-264, the current 
point number is 132 after importing the file. This value should be set manually to the next 
required point number before creating new points with the Create Points toolbar. 

You can also change these point settings by selecting the TOOLSPACE>Settings tab and 
expanding the Commands collection under the Point collection. Right-click on CreatePoints and 
select Edit Command Settings..., as shown on the left in Figure 2–4. In the Edit Command 
Settings dialog box, you can set the defaults for point creation, as shown on the right in 
Figure 2–4. Ideally, this will be preset for you by your BIM manager, according to your 
organization’s standards.

Figure 2–4
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2.5 Creating Points
You can create points using the commands in the Create Points toolbar. These commands 
include:

• Miscellaneous – Manual: Creates a new point at specified coordinates.

• Alignments – Station/Offset: Creates a point at an alignment’s specific station and offset. 
These points and their descriptions do not update if the alignment is modified or the point is 
moved. If you prefer a dynamic station and offset labels, consider using an alignment label 
instead.

• Alignments – Measure Alignment: Creates point objects at a set interval, which is useful for 
construction staking. Again, these points do not update if the alignment changes.

• Surface – Random Points: Creates points whose elevation is from a specified surface. 
These points can update, but only if you manually force the update. If you prefer a dynamic 
spot label, which will always be up to date, consider a surface label instead.

Each icon in the Create Points toolbar has a drop-down list. If you expand it, you can select a 
command from the list to run, as shown in Figure 2–5.

Figure 2–5
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Practice 2a
Create Autodesk Civil 3D Points

Practice Objective 

• Create a point manually, then zoom to it using transparent commands.

In this practice, a fire hydrant was located by GPS. You will add a point object to locate it 
manually. 

1. Open SUV-A1.dwg from the C:\Civil 3D Essentials\Working\Survey folder.

2. In the Home tab>Create Ground Data panel, select Points>Point Creation Tools to display 

the Create Points toolbar. Expand the toolbar by clicking .

3. In the Point Identity area, set the Next Point Number to 260, as shown in Figure 2–6, then 

collapse the toolbar by clicking .

Figure 2–6

Hint: Software Configuration

For the practices in this chapter to work properly, the configuration changes noted in the 
preface of this guide must be made.
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4. Select the Manual option in the miscellaneous group in the toolbar, as shown in Figure 2–7.

Figure 2–7

5. When prompted for a location, enter 6256069.30,2036634.25 and press <Enter>. 

6. When prompted for a description, type HYD and press <Enter>. 

7. When prompted for an elevation, press <Enter> to accept the default value of <.> (period), 
because it is unknown. The period is a placeholder for the elevation field. Typing zero is not 
correct because 0 is a valid elevation.

8. Press <Enter> again to finish the command, then clickt X in the Create Points dialog box to 
close it. 

9. In the Transparent Commands toolbar, click  (Zoom to Point) and type 260.

Note: The description is labeled Hydrant, even though you typed HYD. Hydrant is the full 
description, HYD is the raw description. The ASCENT description key set assigned the full 
description to the point label.

10. Save the drawing.

End of practice
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2.6 Reviewing and Editing Points
Reviewing and editing point data occurs throughout the Autodesk Civil 3D environment. It is as 
simple as selecting a point in the drawing, right-clicking, and selecting Edit Points…. You can 
also edit points using the shortcut menu in the Points heading in the TOOLSPACE>Prospector 
tab. Alternatively, you can select a point entry in the Prospector tab’s preview area.

Repositioning Point Labels
Each point label style has Dragged State parameters. These parameters affect the label’s 
behavior when moving the label from its original label position. Depending on the Dragged 
State parameters, a label can change completely (Stacked text) or display as it was originally 
defined (As composed). An example of a label is shown in Figure 2–8.

Figure 2–8
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A point displays three grips when selected. Use the Rectangle label grip to move, rotate, toggle 
sub item grips, and reset the label. Use the Diamond point object grip to move and rotate both 
the label and marker, rotate just the marker, reset marker rotation, and reset all. The third grip is 
a plus symbol that enables you to add vertices to the leader, as shown in Figure 2–9.

Note: When selecting a point, it displays multiple grips. Click the move grip when you 
want to relocate the label.

Figure 2–9
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• Each label component can be modified and the change is only for that point.

• Point objects can be set to automatically rotate to match the current view using style 
settings. If this is not preferred, they can have a rotation assigned directly through the 
AutoCAD Properties dialog box.

• You can reset a label to its original position by selecting the point, right-clicking, and 
selecting Reset Label.
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2.7 Point Reports
The surveyor needs to produce point reports. These can include a record list for the project, a 
checklist to find errors, reference for field crews, stakeout, etc. Incorporating survey data with 
an Autodesk Civil 3D engineering project is unique in that it relies on connection and 
communication with third-party survey equipment and software. Autodesk has collaborated 
with the major survey equipment vendors (TDS Survey Link, TOPCON Link, Trimble Link, Carlson 
Connect, and Leica X-Change) and they have developed applications that interface their 
equipment with the Autodesk Civil 3D software.

Autodesk Civil 3D points can be exported and then uploaded to the survey equipment. However, 
a documented point list might also be required, as an audit trial, for example. There are several 
ways to create reports about points.

Reports Manager
The Autodesk Civil 3D Reports Manager produces several point reports. To create reports from 
the Reports Manager, the TOOLSPACE>Toolbox tab must be available. To display the Toolbox 
tab, go to the Home tab>Palettes panel, and select Toolbox. Select the Toolbox tab and expand 
the Reports Manager collection to display a list of object type reports, as shown in Figure 2–10.

Figure 2–10
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Points are easily organized into a convenient, legible list that displays the point number, 
northing, easting, elevation, and description (as shown in Figure 2–11). Another point report 
lists the points’ station and offset values relative to an alignment. Another report calculates 
distances and angles from an occupied and a backsight. You can transfer points to Microsoft 
Excel spreadsheets using a CSV report. To create these reports, select the report’s name, right-
click, and select Execute….

Figure 2–11

Point Editor Reports
Another report method is to use the Point Editor vista. In the TOOLSPACE>Prospector tab, select 
Points, right-click, and select Edit… to display the Point Editor vista, as shown in Figure 2–12. 

Figure 2–12

In the vista, you can select individual points using <Ctrl> or select blocks of points using <Shift>. 
When done selecting points, right-click and select Copy to clipboard. You can then paste the 
copied points into Microsoft Excel, Notepad, or any application that accepts the points, as 
shown in Figure 2–13.

Figure 2–13
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Practice 2b
Manipulate Points and Point Reports

Practice Objectives 

• Modify the label position for points to ensure that the plan is readable.

• Rotate a point symbol.

• Share information about points used for error checking or staking out points using 
predefined reports.

In this practice, you will manipulate points created in the drawing, then you will write a report of 
the points using a predefined report.

Task 1:  Modify the position of the point labels and rotate a point symbol.

1. Continue working with the drawing from the previous practice or open SUV-A2.dwg.

2. In the preview point list, scroll down until the point number 260 displays. Select it, 
right-click, and select Zoom to, as shown in Figure 2–14. This positions the point in the 
center of the screen.

Figure 2–14
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3. In a typical drafting workflow, points can overlap, making them illegible. Since the point 
style’s text height is a function of the drawing scale, changing the Annotation Scale changes 
the text size. If need be, in the Status Bar, set the Annotation Scale to 1" = 40', as shown in 
Figure 2–15, to change the point size in the drawing.

Figure 2–15

4. Select point 260 to display its grips. Select the Drag Label grip, as shown in Figure 2–16, to 
relocate the label. 

Figure 2–16

5. With the label still displaying grips, hover on the rectangle grip and select Reset Label.

6. With the label still displaying grips, hover over the square label grip to display the options 
for moving, rotating, and additional sub item grips, as shown in Figure 2–17. Select Rotate 
label and rotate the label. Type 45 to rotate the label 45° counter-clockwise.

Figure 2–17
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7. With the label still displaying grips, hover over the diamond point grip to display the options 
to Move point, Rotate label and marker, and Rotate marker, as shown in Figure 2–18. 
Select Rotate marker and rotate the marker. Enter 45 to rotate the marker 45° 
counter-clockwise.

Figure 2–18

8. With the label still displaying grips, hover over the diamond point grip again and select 
Reset all, as shown in Figure 2–19. 

Figure 2–19

9. No need to save the drawing since you reset all the changes.



Survey, Points, and Linework

© 2026 ASCENT - Center for Technical Knowledge 2–19

Task 2:  Create point reports.

1. If the Toolbox tab is not displayed in the Toolspace, select the Home tab and click 

(Toolbox) to display it.

2. Select the TOOLSPACE>Toolbox tab and expand the Reports Manager collection to display 
the list of object type reports. Expand the Points collection, as shown in Figure 2–20.

Figure 2–20

3. Select Point List, right-click, and select Execute. 

4. In the Export to LandXML dialog box, click OK to generate the report. In the Save As dialog 
box, browse to the C:\Civil 3D Essentials\Documents\Reports folder, type <Your Initials>-
Points.html, and save the file.

5. The point list displays in an Internet browser. Review the report and when done, close it.

6. No need to save the drawing, for no changes were made to it.

End of practice
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2.8 Importing Survey Data
The Autodesk Civil 3D software has methods to import point data from ASCII text files to 
Autodesk LandXML files, as well as methods to convert AutoCAD points to Autodesk Civil 3D 
points. The TOOLSPACE>Survey tab also inserts points from a survey to a drawing.

Import Points Only

There are two methods of launching the import point feature – one is by using the Insert tab 
and the other is by using the Points creation tool in the Home tab>Create Ground Data panel or 
the TOOLSPACE>Prospector tab.

How To: Use the Insert Tab Method

1. In the Insert tab, click  (Points from File).This opens the Import Points dialog box.

2. In the Import Points dialog box, set the file format, select the files to import, set any 

advanced options, and click OK to import the points. Alternatively, you can click  (Import 
Points) in the Create Points toolbar.

How To: Use the Point Creation Tools Method

1. Open the Create Points dialog box by expanding Points in the Home tab, expanding the 
drop-down list, and selecting a Create Points option, as shown on the left in Figure 2–21. 
Alternatively, in the TOOLSPACE>Prospector tab, select Points, right-click, and select 
Create…, as shown on the right.

Figure 2–21
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• All commands in the Points drop-down list can also be accessed in the Create Points 
toolbar, as shown in Figure 2–22.

Figure 2–22

2. Click  (Import Points) to open the Import Points dialog box (shown in Figure 2–23). 

Figure 2–23

3. In the Import Points dialog box, under the Specify point file format area, select the required 
format. 
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4. After setting the format, click  on the right to open the Select Source File dialog box.You 
can select multiple files if they have the same file format.

5. In the Select Source File dialog box, browse to the import point file, select it, and click Open. 
Assign the imported points to a new or existing point group by selecting the Add Points to 
Point Group option and selecting the point group in the drop-down list. 

6. Select Advanced options as follows:

• Do elevation adjustment if possible: If the point file contains columns labeled 
Thickness, Z+ or Z-, and this checkbox is selected, then Civil 3D will adjust the elevations 
of the points during import. Z+ will add the value to the elevation value, Z- will subtract 
the value from the elevation value, and Thickness (indicating the thickness of a surface, 
such as topsoil or clay) will subtract the value from the elevation value.

• Do coordinate transformation if possible: If the point file format has a coordinate 
system assigned to it (shown in Figure 2–24) and the drawing points to be imported has 
a coordinate zone and transformation information defined, then the imported points that 
are imported are transformed to match the zone of the current drawing.

Figure 2–24

• Do coordinate transformation if possible: If the Coordinate zone transform checkbox is 
selected and if the point file contains coordinate data properties of the points (such as 
degrees (incl. minutes and seconds) and hemispheric values for latitude and longitude), 
then such values are calculated from known coordinate data information contained in 
the point data file, such as grid northing and grid easting.
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Duplicate Point Numbers

If an imported file creates duplicate point numbers, the Autodesk Civil 3D software overwrites, 
merges, or reassigns them during the import process. When encountering duplicate point 
numbers, the Autodesk Civil 3D software can assign the next available number, add an offset 
value (add 5000 to each point number that conflicts), overwrite points (replaces the current 
point values with the file’s values), or merge points (add the file’s values to an existing point’s 
values). If using the offset method, the new point numbers are kept unique in the drawing. If 
using the next available number method, the new points blend into the original points and are 
difficult to identify.

The offset method is preferred when resolving duplicate point numbers. When importing points 
that will potentially duplicate point numbers, the Create Points toolbar’s Point Identity settings, 
as shown in Figure 2–25, is the default when handling duplicate point numbers.

Figure 2–25
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In the Point Identity settings, set the duplicate point resolution method for the If Point Numbers 
Already Exist variable. The four methods are Renumber, Merge, Overwrite, and Notify, as shown 
in Figure 2–26. The import process never overwrites point data unless you specify that it should 
do so. 

Figure 2–26

When encountering a duplicate point, the Duplicate Point Number dialog box opens. After you 
define a resolution, it can be assigned to the current duplicate point or to all encountered 
duplicate points. 

Survey Toolspace

The TOOLSPACE>Survey tab displays a panel through which all surveys are processed. Survey 
uses graphics to display field book imports, figure and network previews, and points. If you 
toggle off these graphics, you can process a survey without a drawing being open. If you want 
to display these graphics, you need to have a drawing open. Survey prompts you to open a 
drawing if you do not have one open.

The Survey tab contains survey settings, equipment defaults, figure prefixes, and linework code 
sets. Survey’s settings can be on a local or network folder. It is preferred to use a network folder 
in larger offices because all users can then standardize the file values.

If your Toolspace does not display the Survey tab, click (Survey) in the Home tab>Palettes 
panel, as shown in Figure 2–27.

Figure 2–27
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Import Points and Figures Using the Survey Database

After collecting and coding the data, and then downloading and converting it, the next step in 
Survey is to import the survey data, review it, and place the survey points and figures into a 
drawing. A working folder defines where the local survey database is located. The preferred 
location is a network folder, in which you place the local survey databases. The Survey User 
Settings dialog box sets the defaults for all new survey databases. You should set these before 
starting Survey. The Survey working folder is the location for all of the survey databases and 
can be local or on the network. The default working folder is C:\Users\Public\Documents\
Autodesk\Civil 3D Essentials.

How To: Set the Working Folder for the Survey Database

1. In the TOOLSPACE>Survey tab, select Survey Databases.

2. Right-click and select Set working folder…, as shown in Figure 2–28. 

Figure 2–28

Survey Database
A survey database is a subfolder in the working folder. The Survey working folder contains the 
survey’s settings and observation database. This database contains the survey’s networks, 
figures, and survey points. 

Survey database folders cannot be deleted in Autodesk Civil 3D Survey. If you want to delete the 
working folder, this process must be done through the Windows File Explorer, external to the 
Autodesk Civil 3D software.

To import a field book, you use the survey’s Import Events collection. Import Events provides 
access to an Import wizard, which guides you through the steps of importing a file. 

1. To open the Import wizard, select Import Events in the survey, right-click, and select Import 
survey data….
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2. The Specify Database page is shown in Figure 2–29. It sets the survey, creates a new 
survey, and edits the survey’s settings.

Figure 2–29
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3. Click Next. The Specify Data Source page (shown in Figure 2–30) defines the file import 
type, the file’s path, and its format (if it is a coordinate file).

Figure 2–30
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4. Click Next. The Specify Network page (shown in Figure 2–31) enables you to change the 
network or create a new one. If importing a field book, a Network must be assigned. If 
importing a point file, a Network is optional.

Figure 2–31

5. Click Next. 
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6. The Import Options page (shown in Figure 2–32) sets the values for the import. These 
settings affect what the import does and which support files it uses.

Figure 2–32

If the field book has figure coding from a conversion, you do not need to toggle on the Process 
linework during import property. This is for point files other than field books that have Linework 
Code Set commands included in the point’s description.

Inserting figures requires entries to be in the Figure Prefix database and figure styles to be in 
the drawing. This is required to point the figure and linework to the correct drawing layers and 
to specify whether the figure is also a breakline in a surface.

When inserting points, it is necessary to have a description key set defined to assign points, 
point label styles, and layers, and to translate raw descriptions to full descriptions.

Open a Survey Database for Editing
Only one survey database can be edited at a time. When opened for editing, this prepares the 
survey for reading and writing. There are options to set the path or location for the survey 
database project files and for all of the settings. When you create a new survey database, a 
Windows folder is created with the same name. If you close a drawing with a survey open, the 
survey database closes automatically. You must start a new drawing or open an existing 
drawing, and then open the required survey database. You can only have one survey database 
open at a time.
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How To: Open a Survey Database 

1. In the TOOLSPACE>Survey tab, expand the Survey Database collection.

2. Select the survey database that you want to open, right-click, and select Open for edit or 
Open for read-only, as shown in Figure 2–33, depending on your requirements. Contrary to 
most Civil 3D functions where double-clicking invokes an edit function, double-clicking on a 
survey database will open it as read-only.

Figure 2–33

Hint: Survey Database Migration to 2020 and Above

The survey database format changed in the 2020 release. If you have existing survey 
databases created in an earlier format, they will be marked and must be migrated. Right-click 
on the survey database and select Migrate.... You will need to select a new location for the 
updated survey database, as shown in Figure 2–34.

Figure 2–34
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2.9 Point Groups
Point groups organize points that share common descriptions and characteristics (such as 
existing storm, gas lines, building corners, etc.). If you consider the points in the project to be a 
database, then point groups can be considered a means of querying the point database. 

Point groups also enable points to display different point or label styles. For example, a 
landscape architect needs to display different symbols for each tree species, while an engineer 
only needs to display a generic tree symbol. The description key set enables you to assign the 
tree species symbols for the landscape architect, and a point group enables generic tree 
symbols to override the symbols for the engineer. Another function of a point group is to hide all 
of the points. 

In the Autodesk Civil 3D software, point groups can be defined in the template along with a 
description key set. When you create a new drawing from this template and import points, they 
are assigned their symbols and can be sorted into point groups.

All points in a drawing belong to the _All Points point group. Consider this point group as the 
point database. It cannot be deleted and initially is not in a drawing until you add points. All new 
point groups include all drawing points or a subset of drawing points (referenced points from 
the _All Points point group).

Point groups can be created when importing points. When importing points into a survey 
database, a unique point group is automatically created.

Defining Point Groups

To create a new point group, select the TOOLSPACE>Prospector tab, right-click on the Point 
Groups collection and select New…. Alternatively, in the Home tab, expand Points and select 
Create Point Group.

When you select New… or Create Point Group, the Point Group Properties dialog box opens. It 
has nine tabs, each affecting the point group’s definition.

The Point Groups, Raw Desc Matching, Include, and Query Builder tabs add points to the point 
group. The Exclude tab removes points from a point group.
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The Information tab defines the point group’s name. The Point style and Point label style should 
remain at their defaults, unless you want to use either style to override the assigned styles of 
the points in the point group. The points in the point group display their originally assigned 
styles until you toggle on the override. A point group can be locked by toggling on the Object 
locked option to prevent any changes to the group. The Point Group Properties dialog box is 
shown in Figure 2–35.

Figure 2–35

The Point Groups tab lists the drawing’s groups. A point group can be created from other point 
groups, thereby creating a hierarchy of point groups. When you select a point group name, the 
group and its points become members of the new point group. For example, the point group 
Trees is created from the point groups Maple, Walnut, Oak, etc.

The Raw Desc Matching tab lists codes from the Description Key Code set. When you toggle on 
the code, any point matching the code becomes part of the point group.

If you cannot select a point with the previous two methods, the Include tab enables you to 
include points by specifically entering in the selection criteria. The criteria include the point 
number (point number list or by selection), elevation, name, raw description, full description, 
and all points.



Survey, Points, and Linework

© 2026 ASCENT - Center for Technical Knowledge 2–33

• With numbers matching: Selects points by a point number range or list. When creating a list, 
sequential point numbers are hyphenated (1-20) and individual numbers are in a comma 
delimited list. A point list can include sequential and individual points (1-20, 14, 44, 50-60). 
Select Selection Set in Drawing to select the points in the drawing and list their point 
numbers at the top of the Include tab.If using the Selection Set in Drawing method, keep in 
mind that a point group defined by exact numbers will not be dynamic since it is fixed on 
individual point numbers.

• With elevations matching: Enables you to select points by entering a specific elevation or by 
specifying a minimum and/or maximum elevation. For example, valid entries include >100, 
<400, and >100. The first entry only includes points whose elevation is above 100, but less 
than 400. The second entry only includes points whose elevation is greater than 100. A point 
without an elevation cannot be selected using this method. An elevation range, defined by 
separating the start and end numbers with a hyphen, includes points whose elevation falls in 
the range (1-100). This can be combined with greater or less than symbols.

• With names matching: Selects points based on matching their point names. Enter one or 
more point names separated by commas.

• With raw/full descriptions matching: Selects points based on matching an entered raw or 
full description. Enter one or more descriptions separated by commas. You can use the 
same wildcards as the description key set. Generally, this method uses the asterisk (*) as 
the wildcard after the description (e.g., PINE*, CTV*, CL*, etc.). By default, this is not 
case-sensitive.

• Include all points: Assigns all points in the drawing to the point group. When this option is 
toggled on, all other Include options are disabled. 

The Exclude tab has the same options as the Include tab, except for the Include All Points 
option.

The Query Builder tab creates one or more expressions to select points. Each query is a row 
selecting points. As with all SQL queries, you combine expressions using the operators AND, 
OR, and NOT. You can also use parentheses to group expressions. It is here where you can 
make the criteria case-sensitive.

The Overrides tab overrides the points in the point group’s raw description, elevation, point style, 
and/or point label style. For example, you can override specific tree species symbols with a 
generic tree symbol, override a label style when displaying this group, or override the point and 
label style with none (to hide all points).

The point group display order affects points and their overrides. To change how the point 
groups display, modify the point group display order.

The Point List tab displays the point group’s points. This tab enables you to review points that 
are currently in the point group.

The Summary tab displays the point group’s settings. You can print this tab as a report by 
cutting and pasting it into a document.
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Updating Out-of-Date Point Groups
After defining point groups and adding points to a drawing, the group becomes out of date 

before assigning the points to the group. The point group will have an Alert symbol ( ) next to 
it for easy recognition in the Prospector tab, as shown in Figure 2–36.

Figure 2–36

This enables you to verify that the point(s) should become part of the group. To review why a 
group is out of date, select the group, right-click, and select Show Changes…. If the changes are 
correct, select Update to add the points to the group. If you know that all of the groups 
displaying as out of date should be updated, right-click on the Point Groups collection and 
select Update. At this level, the command updates all of the point groups.

Unlike other Civil 3D objects (such as surfaces and corridors), you cannot set point groups to be 
Rebuilt Automatically. 
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Overriding Point Group Properties
When working with points, you might want them to display different labels, not be displayed, or 
display different symbols. Each required change is a function of a point group override. A point 
group that contains all of the points and overrides their symbols and labels with none does not 
display any points. This is similar to freezing all of the layers involved with points. A point group 
that changes the symbols that a group displays overrides the label styles assigned to the point 
in the point group. To display a different symbol, the point group overrides the assigned point 
styles. To set the style and override the assigned styles, toggle on the point group in the 
Overrides tab and set the styles in the Override column of the point group, as shown in 
Figure 2–37.

Figure 2–37

Point Group Display Properties
When creating a point group, it is placed at the top of the point group list. The point group list is 
more than a list of point groups; it is also the Autodesk Civil 3D’s point draw order. The 
Autodesk Civil 3D software draws the point groups starting from the bottom of the list to the 
top. If _All Points is the first drawn point group and the remaining point groups are subsets of 
all points, the individual point group does not display, but all of the points display.

To display point groups that are a subset of all points, you must create a point group whose 
purpose is to hide all points. This popular point group is commonly called No Display. With this 
group, any point group drawn after it displays its members without seeing the other points. 
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The Autodesk Civil 3D software draws point groups from the bottom to the top of the list. To 
manipulate the display order, right-click on the Point Groups collection in the TOOLSPACE> 
Prospector tab and select Properties. The Point Groups dialog box opens, enabling you to 
modify the point group display order using the arrows on the right, as shown in Figure 2–38.

Figure 2–38

These arrows enable you to select the required point group and move it up or down (or all the 

way to the top or bottom with one click using / ) in the hierarchy for display purposes. The 
Point Groups dialog box has two additional icons at the top. The first icon displays the changes 
that need to occur in the point groups and the second icon updates them.

If you use description key sets, a point displays the assigned point and label style when it is part 
of any point group. The only time the point displays another style is when you override the style 
(in the Point Group Properties dialog box, on the Overrides tab).

With the description key set and display order shown in Figure 2–39, the points display their 
originally assigned point label styles.

Figure 2–39
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The No Display point group includes all of the points, but overrides the originally assigned point 
style and point label styles with <none>. When No Display is moved to the list’s top, no points 
display. The Point Groups dialog box is shown in Figure 2–40.

Figure 2–40
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Practice 2c
Import Points

Practice Objectives 

• Insert points from a point file.

• Import points from an ASCII file created from the field survey.

In this practice, points will be created in the drawing through importing point files.

Task 1:  Importing points from a point file.

In this task, you will import points directly into the drawing. They will come in as COGO points.

1. Continue working on the previous drawing or open SUV-B.dwg from the C:\Civil 3D 
Essentials\Working\Survey folder. 

2. In the Insert tab>Import panel, click  (Points from File), as shown in Figure 2–41. 

Figure 2–41

Hint: Software Configuration

For the practices in this chapter to work properly, the configuration changes noted in the 
preface of this guide must be made.
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3. In the Import Points dialog box, do the following, as shown in Figure 2–42:

• Click  on the right to open the Select Source File dialog box. 

• In the Select Source File dialog box, browse to C:\Civil 3D Essentials\Survey Databases\
Data and select Groundshots-I.txt, and select Open. 

• Under the Specify point file format area, select the PNEZD (comma deliminated) format 
(which is typically at the bottom of the list).

• Assign the imported points to a new point group by selecting the Add Points to Point 

Group option and clicking  (Create Group).

• In the Create Group dialog box, enter Groundshots as the name of the new point group 
and click OK. All points coming in will belong to this point group.

• In the Advanced options, clear all the checkboxes.

• Click OK to close the dialog box and import the points.

Figure 2–42
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4. The points are imported into the drawing. A new point group has been created. Zoom to the 
extents of the drawing to see the points.

5. In the View tab>Named Views panel, select the preset view Point-Inspect. 

6. Expand the Point Groups branch in the TOOLSPACE>Prospector tab and select the 
Groundshots point group. All the points are listed in the preview area of the Prospector tab, 
as shown in Figure 2–43. The symbol of the points indicates that they are COGO points.

Figure 2–43

7. Save the drawing.

Task 2:  (Optional) Import points into a survey database.

In this task, you will create a survey database and then import an ASCII file created in the field 
into the database, which also display in the drawing.They will come in as survey points.

1. Continue working on the drawing from the previous task. 

2. On the Survey tab, right-click on Survey Databases and select Set working folder, as shown 
in Figure 2–44.

Figure 2–44
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3. Browse to C:\Civil 3D Essentials\Survey Databases and click Select Folder in the lower-right 
corner.

4. In the Home tab>expanded Create Ground Data panel, click (Import Survey Data).

5. On the Specify Database page, click Create New Survey Database..., as shown in 
Figure 2–45.

Figure 2–45

6. Type ASCENT-Essentials for the name and click OK.
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7. Click Edit Survey Database Settings... as shown in Figure 2–46.

Figure 2–46

8. In the Survey Database Settings dialog box, under Units, click the Browse icon for the 
Coordinate Zone. 

9. In the Select Coordinate Zone dialog box, from the Categories drop-down list, select USA, 
California.

10. Expand the Available coordinate systems drop-down list and select NAD83 California State 
Planes, Zone VI, US Foot (as shown in Figure 2–47).

Figure 2–47
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11. Click OK twice and then click Next.

12. On the Specify Data Sources page, do the following, as shown in Figure 2–48: 

• Expand the Data source type drop-down list and select Point File.

• Click  (Add file) and browse to C:\Civil 3D Essentials\Survey Databases\Data. Select 
Field-Survey-I.txt and open it. 

• For the file format, select PNEZD (comma delimited). 

• Click Next.

Figure 2–48

13. On the Survey Network page, click Next (do not make any changes).
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14. On the Import Options page, select Process linework during import, Insert figure objects, 
and Insert survey points, as shown in Figure 2–49. Click Finish.

Figure 2–49

Hint: Survey User Settings

If the listings for Current figure prefix database and Current linework code set are set to 
Sample and not as listed above in Figure 2–49, you will need to change the Survey User 
Settings as follows (this information is also provided in the preface of this guide):

• In the TOOLSPACE>Survey tab, click  (Survey User Settings), as shown in 
Figure 2–50.

Figure 2–50

• Click  (Import User Settings), browse to C:\Civil 3D Essentials\Ascent-Config\
Survey Settings, and select ASCENT-Settings.usr_set.

• Click Open or double-click on the file to open it.
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15. The points are imported into the drawing. A new point group named Field-Survey-I has 
automatically been created. 

16. In the View tab>Named Views panel, expand the drop-down list and select Point-Inspect. 
This zooms into an area located east of the existing road, as shown in Figure 2–51. When 
this view is restored, the viewing scale also changes to 1" = 20', as it is stored in the view 
definition.

Figure 2–51

Note: Many points have different symbols, such as trees, shrubs, etc. Multiple lines were 
created on different layers. This is by using description key sets and Figure Prefix 
databases. The nuances of these tools are beyond the scope of this guide and are 
covered in other content by ASCENT.

17. Expand the Point Groups branch in the Prospector tab. The new point group, Field-Survey-I, 
has been created. 

18. Select the _All Points point group. All the points are listed in the preview area of the 
Prospector tab. The symbol of the new points (250–252) indicates that they are survey 
points, whereas the previous points (253–260) are COGO points.

19. Note that the trees come in at different sizes based on their trunk diameters (based on the 
description key set), and a variety of linework has been created based on the Figure Prefix 
database settings.

20. Save the drawing.

End of practice
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Practice 2d
Create Point Groups

Practice Objective 

• Create point groups and control the visibility of the points within the groups.

In this practice, you will create point groups from filters of existing points in the drawing.

Task 1:  Create point groups.

1. Continue working with the drawing from the previous practice or open SUV-C1.dwg.

2. In the Transparent Commands toolbar, click  (Zoom to Point), and enter 4,9,10. This will 
zoom to the drawing area containing these 3 points.

3. In the TOOLSPACE>Prospector tab, select Point Groups, right-click, and select New…, as 
shown in Figure 2–52.

Figure 2–52
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4. In the Point Group Properties dialog box, on the Information tab, type Boundary Pin Survey 
in the Name field, type Collected April 30, 2024 as a Description, set the Point style to 
ASC-Iron Pin, and set the Point label style to ASC-Elevation and Description, as shown in 
Figure 2–53.

Figure 2–53

5. Select the Include tab. Select the With raw description matching option. Type *IP. in the 
field to select all of the points that have the last three characters IP. (iron pin). (Verify that a 
period follows IP. By default, this is NOT case sensitive.) You can confirm this in the Point 
List tab, as shown in Figure 2–54.This will also select other iron pin descriptions beyond the 
“Found” ones, which the surveyor may use to determine iron pins.

Figure 2–54



Autodesk Civil 3D 2027: Essentials

2–48 © 2026 ASCENT - Center for Technical Knowledge

6. Click OK to close the dialog box and apply the changes. The point symbols change from an 
X marker to an Iron Pin symbol, as shown in Figure 2–55. This is because the Boundary Pin 
Survey is at the top of the point group list. 

Note: If the symbols do not change, first regenerate the drawing. If there are still no 
changes, ensure that the point group is on top, as explained in the next task.

Figure 2–55

7. Create another point group as follows:

• Name: Site-Survey

• Description: Misc. Survey Points

• Point Style: ASC-Basic

• Point Label Style: ASC-Elevation and Description

• Include Tab: With numbers matching: 1 - 1000

• Exclude Tab: With raw description matching: StLight*

8. Save the drawing.

Task 2:  Create the No display point group.

In this task, you will use the point group to control the points display. Not only will you be able to 
display the same point differently, but you will also be able to control the visibility of the points. 
This eliminates needing to use the Layer command to thaw and freeze layers.

1. Continue working with the drawing from the previous task or open SUV-C2.dwg.

2. In the View tab>Named Views panel, select the preset view Start. This changes the 
Annotation Scale to 1"=40' automatically.

3. As in Task 1, select Point Groups, right-click, and select New… to create a new point group. 
In the Information tab, type No display for the Name.

Before point group After point group
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4. Select <none> for both the Point style and the Point label style, as shown in Figure 2–56.

Figure 2–56

5. Select the Include tab and select Include all points to set it to True. Select the Point List tab 
to confirm that all of the points have been included.

6. Select the Overrides tab and select Style and Point Label Style, as shown in Figure 2–57.

Figure 2–57

7. Click OK to create the point group. The points disappear because the newly created No 
display point group is at the top of the list and sets the priorities.

8. To control the hierarchy and the display of the point group style, select the 
TOOLSPACE>Prospector tab, select Point Groups, right-click, and select Properties.



Autodesk Civil 3D 2027: Essentials

2–50 © 2026 ASCENT - Center for Technical Knowledge

9. In the Point Groups dialog box, select the Boundary Pin Survey point group and move it to 

the top of the list by clicking , as shown in Figure 2–58.

Figure 2–58

10. Click OK to apply the changes. Only the points in the Boundary Pin point group display. If the 
property pins are not displayed, you might need to regen the drawing (type RE and press 
<Enter>).

11. Experiment with moving point groups up and down the list to control the display of points.

12. Save the drawing.

End of practice
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2.10 Lines and Curves
A typical land development project commences with plotting out the property being subdivided, 
based on the legal description. Planners need to enter lines and curves representing the 
property boundaries into the computer from legal text description. The Autodesk Civil 3D 
software makes this task easy with the many options under the Lines and Curves commands in 
the Home tab>Draw panel. Expanding the Lines or Curves command displays several options 
that are not found in the ordinary AutoCAD® software, as shown in Figure 2–59.

Figure 2–59
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A second option is to use transparent commands. These are similar to object snaps in that they 
are only accessible while in another command that is searching for a point. 

Once the required command has been started, you can select the transparent commands as 
follows:

• From the Transparent Commands toolbar

• From the Transparent ribbon tab

• By typing an apostrophe letter combination in the Command Line

• From the right-click menu>Transparent Commands

Icon Command Line Description

’AD Angle Distance: Specifies a point location at an angle and distance 
from a known point and direction.

’BD Bearing Distance: Specifies a point location at a bearing and distance 
from a known point (or the last point occupied).

’ZD Azimuth Distance: Specifies a point location at an azimuth and 
distance from a known point (or the last point occupied).

’DD Deflection Distance: Specifies a point location at an angle and 
distance from a known point and previous direction.

’NE Northing Easting: Specifies a point location using northing and easting 
coordinates.

’GN Grid Northing Grid Easting: Specifies a point location using a grid 
northing and grid easting. (You must have the drawing zone, 
coordinate system, and transformations set for grids.)

’LL Latitude Longitude: Specifies a point location using latitude and 
longitude. (You must have the drawing zone, coordinate system, and 
transformations set.)

’PN Point Number: Specifies a point location using a point number found in 
the drawing or active project.

’PA Point Name: Specifies a point location using a point name found in the 
drawing or active project.

’PO Point Object: Specifies a point location by picking any part of an 
existing COGO point in the drawing.

’ZTP Zoom to Point: Zooms to a point in the drawing or active project by 
specifying the point number or name.

’SS Side Shot: Specifies a point location at an angle and distance from a 
known point and direction (uses the last two entered points to set the 
reference line).
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The benefit to using these transparent commands to draw parcels over the Lines and Curves 
options (shown previously in Figure 2–59) is that a Polyline command can be used to create 
one entity rather than using many individual lines that would need to be joined later. 

’SO Station Offset: Specifies a point location at a station and an offset 
from an alignment in the current drawing.

.g Point Object Filter: Specifies a point location by picking any part of an 
existing COGO point in the drawing.

’STAE Profile Station from Plan: Specifies a profile view point location by 
specifying an alignment station in plan and an elevation.

’SSE Profile Station and Elevation from Plan: Specifies a profile view point 
location by specifying a surface, an alignment station, and a point in 
plan view.

’SPE Profile Station and Elevation from COGO Point: Specifies a profile 
view point location by specifying a COGO point and an alignment 
station in plan view.

’PSE Profile Station Elevation: Specifies a profile view point location by 
specifying a station and an elevation.

’PGS Profile Grade Station: Specifies a profile view point location using 
grade and station values from a known point.

’PGE Profile Grade Elevation: Specifies a profile view point location using 
grade and elevation values from a known point.

’PGL Profile Grade Length: Specifies a profile view point location using 
grade and length values from a known point (or the last point 
occupied).

’MR Match Radius: Specifies a radius equal to that of an existing object.

’ML Match Length: Specifies a length equal to that of an existing object.

’CCALC Curve Calculator: Calculates curve parameters based on input.

Icon Command Line Description
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Practice 2e
Begin a Subdivision Project

Practice Objective 

• Draw a parcel from a legal description.

In this practice, you will use the legal description below to draw a parcel. Later, you will create a 
parcel from the linework.

From the POINT OF BEGINNING; thence, S 00° 26' 42.2" W for a distance of 922.4138 feet to a 
point on a line. Thence, S 00° 24' 20.8" W for a distance of 508.3493 feet to a point on a line. 
Thence, S 66° 03' 35.8" W for a distance of 92.1845 feet to the beginning of a curve. 

Said curve turning to the right through 42° 35' 49.2", having a radius of 627.1788 feet, and 
whose long chord bears S 87° 21' 30.4" W for a distance of 455.6165 feet to the beginning of 
another curve. 

Said curve turning to the left through an angle of 19° 13' 40.4", having a radius of 154.4828 feet, 
and whose long chord bears N 80° 57' 25.2" W for a distance of 51.6000 feet. 

Thence, S 89° 25' 44.6" W for a distance of 724.9442 feet to a point on a line. Thence, N 00° 11' 
09.9" E for a distance of 1904.2647 feet to a point on a line. Thence, S 61° 50' 15.3" E for a 
distance of 135.9034 feet to a point on a line. Thence, S 64° 05' 35.8" E for a distance of 
77.8201 feet to a point on a line. Thence, S 78° 09' 29.2" E for a distance of 63.8821 feet to a 
point on a line. Thence, S 66° 23' 19.5" E for a distance of 379.2248 feet to a point on a line. 
Thence, S 66° 17' 17.4" E for a distance of 278.5122 feet to a point on a line. Thence, S 84° 58' 
37.7" E a distance of 466.8116 feet to the POINT OF BEGINNING.
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1. Open SUV-D.dwg from the C:\Civil 3D Essentials\Working\Survey folder.

In effect, you will be tracing over the green perimeter in the drawing, using the legal information 
provided, as shown in Figure 2–60.

Figure 2–60

2. Make the C-PROP-LINE layer current.

3. Start the Line command. For the starting point, type 6257490.0191,2037127.1292 and 
press <Enter>.

4. In the ribbon, in the Transparent tab, click (Bearing Distance). 

5. For the first line, type the following:

• Quadrant: 3 (for the southwest quadrant)

• Bearing: 0.26422

• Distance: 922.4138

Stay in the Line command with the Bearing Distance transparent command running for the next 
few lines.

Start point
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6. For the next two line segments, use the following values:

7. Press <Esc> twice to end the command.

8. In the Home tab>Draw panel, expand the Curve drop-down list and select  (Create 
Curve from End of Object). Select the last line that was drawn using the Bearing Distance 
command. Remember to press <Enter> after you input a value.

9. From the command options, select Radius. Set the radius to 627.1788.

10. From the command options, select Chord. Set the chord length to 455.6165.

11. In the Home tab>Draw panel, expand the Curve drop-down list and select (Create 
Reverse or Compound Curve). Select the last curve drawn.

12. From the command options, select Reverse. Set the radius to 154.4828.

13. From the command options, select Chord. Set the chord length to 51.6.

14. In the Home tab>Draw panel, expand the Line drop-down list and select  (Create Line 
from End of Object). Pick near the endpoint of the last arc drawn. When prompted for a 
distance, enter 724.9442 and press <Enter>.

15. Start the Line command. For the starting point, pick the endpoint of the last line drawn, then 
complete the following:

• In the Transparent toolbar, click  (Bearing Distance).

• For the remaining line segments, use the following values:

16. Press <Esc> once to exit the Bearing Distance transparent command. 

Quadrant Bearing Distance

3 0.24208 508.3493 

3 66.03358 92.1845 

Quadrant Bearing Distance

1 0.11099 1904.2647 

2 61.50153 135.9034 

2 64.05358 77.8201 

2 78.09292 63.8821 

2 66.23195 379.2248 

2 66.17174 278.5122 
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17. Rather than entering the last segment, you will simply draw the final line going back to the 
start point. Hold <Ctrl> as you right-click and select Endpoint, then select the starting point 
of the parcel to close on the point of beginning.

Note: The values of the last segment will probably not form a perfect closure. Closure and 
balances can be calculated; however, this is beyond the level of this guide.

18. Start the Polyline Edit command by typing PE. In the model, select one of the lines or curves 
you just created and press <Enter> to turn it into a polyline. This prevents closure errors 
from occurring later. 

19. Select the Join option and then select all of the lines and curves you just created. Press 
<Enter> to create one closed polyline. Press <Esc> to end the command.

20. Save and close the drawing.

End of practice
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Chapter Review Questions
1. If you need linework, which method should you use to import survey data?

a. Import survey data using the survey database.

b. Import survey data using the Import Points command.

c. Import survey data using the Map Explorer.

d. Create points using the TOOLSPACE>Prospector tab.

 

2. Which of these is not a type of point object within the Autodesk Civil 3D software?

a. COGO Point

b. North Point

c. Survey Point

d. AutoCAD Point

 

3. How do you control the next point number to be used in a drawing?

a. The Point Identity parameters located in the expanded area in the Create Points toolbar.

b. Under Label Styles in the TOOLSPACE>Settings tab.

c. In the TOOLSPACE>Survey tab, right-click on Survey Points.

d. In the TOOLSPACE>Prospector tab, right-click on Survey Points.

 

4. Can the _All Points point group be deleted?

a. Yes

b. No

 

5. Can a point group be made out of point groups?

a. Yes

b. No
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6. How do you draw a parcel boundary from a legal description in the most efficient way 
possible?

a. Calculate the Cartesian coordinate angle for each bearing or azimuth within the legal 
description and type (distance)<(angle) for each line or curve.

b. Calculate the Cartesian coordinate angle for each bearing or azimuth within the legal 
description, place the cursor in that direction, and type the distance.

c. Use the extended Lines and Curves options in the Home tab>Draw panel or transparent 
commands in the Line or Polyline command.

d. There is no fast way to do this.
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Command Summary
Button Command Location

Create Points • Ribbon: Home tab>Create Ground Data panel

Import Points from File • Ribbon: Insert tab>Import panel
• Toolbar: Create Points
• Command Prompt: ImportPoints

Bearing Distance • Toolbar: Transparent Commands
• Command Prompt: ’BD

Create Curve from End of 
Object

• Ribbon: Home tab>Draw panel
• Command Prompt: CurveFromEndOfObject

Import Survey Data • Ribbon: Home tab>Create Ground Data panel
• Command Prompt: ImportSurveyData

Survey • Ribbon: Home tab>Palettes panel

Zoom To Points • Toolbar: Transparent Commands
• Command Prompt: ’ZTP
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